/[packages]/cauldron/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /cauldron/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 309414 - (hide annotations) (download)
Tue Oct 23 02:36:10 2012 UTC (11 years, 6 months ago) by fwang
File size: 15370 byte(s)
new version 1.9.3p286
1 fwang 289958 %define subver 1.9
2 fwang 290007 %define rubyapi 1.9.1
3 fwang 289958 %define rubyver 1.9.3
4 fwang 309414 %define patchversion p286
5     %define rel 1
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21     # The RubyGems library has to stay out of Ruby directory three, since the
22     # RubyGems should be share by all Ruby implementations.
23 fwang 291557 %define rubygems_dir %{_datadir}/ruby/gems
24 fwang 291590 %define rubygems_version 1.8.23
25 fwang 290007
26 fwang 293395 %define bootstrap 0
27 fwang 293412 %define build_gems 0
28 fwang 292558
29 blino 1152 Summary: Object Oriented Script Language
30     Name: ruby
31 fwang 291590 Epoch: 1
32 blino 1152 Version: %{rubyver}.%{patchversion}
33     Release: %mkrel %rel
34     License: Ruby or GPLv2
35     Group: Development/Ruby
36     BuildRequires: autoconf
37     BuildRequires: byacc
38 shlomif 291698 BuildRequires: doxygen
39 blino 1152 BuildRequires: ncurses-devel
40     BuildRequires: readline-devel
41     BuildRequires: tcl-devel tk-devel
42 fwang 276350 BuildRequires: db-devel
43 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
44 blino 1152 BuildRequires: openssl-devel
45     BuildRequires: zlib-devel
46 fwang 289987 BuildRequires: libffi-devel
47     BuildRequires: yaml-devel
48 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
49 blino 1152 Obsoletes: ruby-rexml
50     Provides: ruby-rexml
51     # explicit file provides (since such requires are automatically added by find-requires)
52     Provides: /usr/bin/ruby
53 fwang 293445 Provides: ruby(abi) = %rubyapi
54 blino 1152
55 fwang 289958 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
56 blino 1152 Source3: ruby.macros
57     URL: http://www.ruby-lang.org/
58 fwang 292558 %if !%bootstrap
59     Requires: rubygems >= %{rubygems_version}
60 fwang 293395 BuildRequires: ruby
61 fwang 292558 %endif
62 blino 1152
63 fwang 290007 # == FEDORA PATCHES BEGINS ==
64     # http://redmine.ruby-lang.org/issues/5231
65     Patch0: ruby-1.9.3-disable-versioned-paths.patch
66     # TODO: Should be submitted upstream?
67     Patch1: ruby-1.9.3-arch-specific-dir.patch
68     # http://redmine.ruby-lang.org/issues/5281
69     Patch2: ruby-1.9.3-added-site-and-vendor-arch-flags.patch
70     # http://redmine.ruby-lang.org/issues/5465
71     Patch4: ruby-1.9.3-fix-s390x-build.patch
72     # Fix the uninstaller, so that it doesn't say that gem doesn't exist
73     # when it exists outside of the GEM_HOME (already fixed in the upstream)
74     Patch5: ruby-1.9.3-rubygems-1.8.11-uninstaller.patch
75     # Already fixed upstream:
76     # https://github.com/ruby/ruby/commit/f212df564a4e1025f9fb019ce727022a97bfff53
77     Patch7: ruby-1.9.3-bignum-test-fix.patch
78     # Allows to install RubyGems into custom directory, outside of Ruby's tree.
79     # http://redmine.ruby-lang.org/issues/5617
80     Patch8: ruby-1.9.3-custom-rubygems-location.patch
81     # Add support for installing binary extensions according to FHS.
82     # https://github.com/rubygems/rubygems/issues/210
83     Patch9: rubygems-1.8.11-binary-extensions.patch
84     # == FEDORA PATCHES ENDS ==
85    
86 fwang 291591 %package -n %{libname}
87 fwang 291590 Summary: Libraries necessary to run Ruby
88     Group: Development/Ruby
89    
90 blino 1152 %package doc
91     Summary: Documentation for the powerful language Ruby
92     Group: Development/Ruby
93 fwang 202696 BuildArch: noarch
94 blino 1152
95     %package devel
96     Summary: Development file for the powerful language Ruby
97     Group: Development/Ruby
98 fwang 291590 Requires: %{name} = %{epoch}:%{version}
99     Requires: %{libname} = %{epoch}:%{version}
100 blino 1152
101     %package tk
102     Summary: Tk extension for the powerful language Ruby
103     Group: Development/Ruby
104 fwang 291590 Requires: %{name} = %{epoch}:%{version}
105 blino 1152
106 fwang 291551 %package RubyGems
107     Summary: The Ruby standard for packaging ruby libraries
108     Group: Development/Ruby
109 fwang 291590 Version: %{rubygems_version}
110 fwang 291551 Requires: ruby(abi) = %{subver}
111 fwang 291590 Provides: gem = %{rubygems_version}
112     Provides: rubygems = %{rubygems_version}
113     Provides: ruby(rubygems) = %{rubygems_version}
114 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
115 fwang 291561 BuildArch: noarch
116 fwang 291551
117 fwang 292839 %define rake_ver 0.9.2.2
118 fwang 291551 %package rake
119     Summary: Simple ruby build program with capabilities similar to make
120     Group: Development/Ruby
121 shlomif 291767 Version: %{rake_ver}
122 fwang 291551 Requires: ruby(abi) = %{subver}
123 shlomif 291767 Provides: rubygem(rake) = %{rake_ver}
124 fwang 291561 BuildArch: noarch
125 fwang 291551
126 shlomif 291767 %define minitest_ver 2.5.1
127 fwang 291562 %package minitest
128 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
129 fwang 291562 Group: Development/Ruby
130 shlomif 291767 Version: %{minitest_ver}
131 fwang 291562 License: MIT
132 fwang 291590 Requires: ruby(abi) = %{subver}
133     Requires: ruby(rubygems) >= %{rubygems_version}
134 shlomif 291767 Provides: rubygem(minitest) = %{minitest_ver}
135 fwang 291562 BuildArch: noarch
136    
137 shlomif 291767 %define json_ver 1.5.4
138 fwang 291562 %package json
139     Summary: This is a JSON implementation as a Ruby extension in C
140     Group: Development/Ruby
141 shlomif 291767 Version: %{json_ver}
142 fwang 291562 License: Ruby or GPLv2
143 fwang 291590 Requires: ruby(abi) = %{subver}
144     Requires: ruby(rubygems) >= %{rubygems_version}
145 shlomif 291767 Provides: rubygem(json) = %{json_ver}
146 fwang 291562
147 shlomif 291767 %define rdoc_ver 3.9.4
148 fwang 291562 %package rdoc
149     Summary: A tool to generate HTML and command-line documentation for Ruby projects
150     Group: Development/Ruby
151 shlomif 291767 Version: %{rdoc_ver}
152 fwang 291562 License: GPLv2 and Ruby and MIT
153 fwang 291590 Requires: ruby(abi) = %{subver}
154     Requires: ruby(rubygems) >= %{rubygems_version}
155     Requires: ruby(irb) = %{version}
156 shlomif 291767 Provides: rdoc = %{rdoc_ver}
157     Provides: ri = %{rdoc_ver}
158 fwang 291562 BuildArch: noarch
159    
160 fwang 291590 %package irb
161     Summary: The Interactive Ruby
162     Group: Development/Ruby
163     Provides: irb = %{version}-%{release}
164     Provides: ruby(irb) = %{version}-%{release}
165     BuildArch: noarch
166    
167     %package bigdecimal
168     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
169     Group: Development/Ruby
170     Version: 1.1.0
171     License: GPL+ or Artistic
172     Requires: ruby(abi) = %{subver}
173     Requires: ruby(rubygems) >= %{rubygems_version}
174     Provides: rubygem(bigdecimal) = 1.1.0
175    
176     %package io-console
177     Summary: IO/Console is a simple console utilizing library
178     Group: Development/Ruby
179     Version: 0.3
180     Requires: ruby(abi) = %{subver}
181     Requires: ruby(rubygems) >= %{rubygems_version}
182     Provides: rubygem(io-console) = 0.3
183    
184 blino 1152 %description
185     Ruby is the interpreted scripting language for quick and
186     easy object-oriented programming. It has many features to
187     process text files and to do system management tasks (as in
188     Perl). It is simple, straight-forward, and extensible.
189    
190     %description doc
191     Ruby is the interpreted scripting language for quick and
192     easy object-oriented programming. It has many features to
193     process text files and to do system management tasks (as in
194     Perl). It is simple, straight-forward, and extensible.
195    
196     This package contains the Ruby's documentation
197    
198 fwang 291590 %description -n %{libname}
199     This package includes the libruby, necessary to run Ruby.
200    
201 blino 1152 %description devel
202     Ruby is the interpreted scripting language for quick and
203     easy object-oriented programming. It has many features to
204     process text files and to do system management tasks (as in
205     Perl). It is simple, straight-forward, and extensible.
206    
207     This package contains the Ruby's devel files.
208    
209     %description tk
210     Ruby is the interpreted scripting language for quick and
211     easy object-oriented programming. It has many features to
212     process text files and to do system management tasks (as in
213     Perl). It is simple, straight-forward, and extensible.
214    
215     This package contains the Tk extension for Ruby.
216    
217 fwang 291551 %description RubyGems
218     RubyGems is the Ruby standard for publishing and managing third party
219     libraries.
220    
221 fwang 291552 %description rake
222     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
223     specified in standard Ruby syntax.
224    
225 fwang 291562 %description rdoc
226     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
227     includes the 'rdoc' and 'ri' tools for generating and displaying online
228     documentation.
229    
230     %description json
231     This is a implementation of the JSON specification according to RFC 4627.
232     You can think of it as a low fat alternative to XML, if you want to store
233     data to disk or transmit it over a network rather than use a verbose
234     markup language.
235    
236     %description minitest
237     minitest/unit is a small and incredibly fast unit testing framework.
238    
239     minitest/spec is a functionally complete spec engine.
240    
241     minitest/benchmark is an awesome way to assert the performance of your
242     algorithms in a repeatable manner.
243    
244     minitest/mock by Steven Baker, is a beautifully tiny mock object
245     framework.
246    
247     minitest/pride shows pride in testing and adds coloring to your test
248     output.
249    
250 fwang 291590 %description irb
251     The irb is acronym for Interactive Ruby. It evaluates ruby expression
252     from the terminal.
253    
254     %description bigdecimal
255     Ruby provides built-in support for arbitrary precision integer arithmetic.
256     For example:
257    
258     42**13 -> 1265437718438866624512
259    
260     BigDecimal provides similar support for very large or very accurate floating
261     point numbers. Decimal arithmetic is also useful for general calculation,
262     because it provides the correct answers people expect–whereas normal binary
263     floating point arithmetic often introduces subtle errors because of the
264     conversion between base 10 and base 2.
265    
266     %description io-console
267     IO/Console provides very simple and portable access to console. It doesn't
268     provide higher layer features, such like curses and readline.
269    
270 blino 1152 %prep
271     %setup -q -n ruby-%{rubyver}-%{patchversion}
272 fwang 290007 %apply_patches
273 blino 1152
274     %build
275 fwang 290038 autoconf
276 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
277 fwang 291557 %configure2_5x --enable-shared --disable-rpath --enable-pthread --disable-versioned-paths \
278     --with-rubylibprefix='%{ruby_libdir}' \
279     --with-archdir='%{ruby_libarchdir}' \
280 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
281     --with-sitearchdir='%{ruby_sitearchdir}' \
282     --with-vendordir='%{ruby_vendorlibdir}' \
283     --with-vendorarchdir='%{ruby_vendorarchdir}' \
284 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
285 fwang 293412 --with-rubygemsdir='%{rubygems_dir}'
286 blino 1152 %make
287    
288     %install
289     %makeinstall_std install-doc
290    
291     install -d %buildroot%{_datadir}/emacs/site-lisp
292     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
293    
294     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
295     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
296     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
297     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
298     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
299     EOF
300    
301     # Install the rpm macros
302     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
303     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
304 fwang 289961
305 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
306     %if !%build_gems
307 fwang 293415 rm -f %{buildroot}%{_bindir}/{gem,rake,rdoc,ri}
308 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
309 fwang 293415 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io}
310     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
311 fwang 293412 rm -fr %{buildroot}%{rubygems_dir}
312     %endif
313    
314 blino 1152 %check
315     make test
316    
317 fwang 289961 %files
318 fwang 291551 %{_bindir}/erb
319     %{_bindir}/ruby
320     %{_bindir}/testrb
321 fwang 291560 %dir %{ruby_libdir}
322     %{ruby_libdir}/*.rb
323 fwang 291590 %exclude %{ruby_libdir}/irb.rb
324 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
325     %exclude %{ruby_libdir}/remote-tk.rb
326     %exclude %{ruby_libdir}/tcltk.rb
327     %exclude %{ruby_libdir}/tk.rb
328     %exclude %{ruby_libdir}/tkafter.rb
329     %exclude %{ruby_libdir}/tkbgerror.rb
330     %exclude %{ruby_libdir}/tkcanvas.rb
331     %exclude %{ruby_libdir}/tkclass.rb
332     %exclude %{ruby_libdir}/tkconsole.rb
333     %exclude %{ruby_libdir}/tkdialog.rb
334     %exclude %{ruby_libdir}/tkentry.rb
335     %exclude %{ruby_libdir}/tkfont.rb
336     %exclude %{ruby_libdir}/tkmacpkg.rb
337     %exclude %{ruby_libdir}/tkmenubar.rb
338     %exclude %{ruby_libdir}/tkmngfocus.rb
339     %exclude %{ruby_libdir}/tkpalette.rb
340     %exclude %{ruby_libdir}/tkscrollbox.rb
341     %exclude %{ruby_libdir}/tktext.rb
342     %exclude %{ruby_libdir}/tkvirtevent.rb
343     %exclude %{ruby_libdir}/tkwinpkg.rb
344     %{ruby_libdir}/cgi
345     %{ruby_libdir}/date
346     %{ruby_libdir}/digest
347     %{ruby_libdir}/dl
348     %{ruby_libdir}/drb
349     %{ruby_libdir}/fiddle
350     %{ruby_libdir}/matrix
351     %{ruby_libdir}/net
352     %{ruby_libdir}/openssl
353     %{ruby_libdir}/optparse
354     %{ruby_libdir}/psych
355     %{ruby_libdir}/racc
356     %{ruby_libdir}/rbconfig
357     %{ruby_libdir}/rexml
358     %{ruby_libdir}/rinda
359     %{ruby_libdir}/ripper
360     %{ruby_libdir}/rss
361     %{ruby_libdir}/shell
362     %{ruby_libdir}/syck
363     %{ruby_libdir}/test
364     %{ruby_libdir}/uri
365     %{ruby_libdir}/webrick
366     %{ruby_libdir}/xmlrpc
367     %{ruby_libdir}/yaml
368     %dir %{ruby_libarchdir}
369     %{ruby_libarchdir}/continuation.so
370     %{ruby_libarchdir}/coverage.so
371     %{ruby_libarchdir}/curses.so
372     %{ruby_libarchdir}/date_core.so
373     %{ruby_libarchdir}/dbm.so
374     %dir %{ruby_libarchdir}/digest
375     %{ruby_libarchdir}/digest.so
376     %{ruby_libarchdir}/digest/*.so
377     %dir %{ruby_libarchdir}/dl
378     %{ruby_libarchdir}/dl.so
379     %{ruby_libarchdir}/dl/*.so
380     %dir %{ruby_libarchdir}/enc
381     %{ruby_libarchdir}/enc/*.so
382 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
383     %{ruby_libarchdir}/enc/trans/*.so
384 fwang 291560 %{ruby_libarchdir}/etc.so
385     %{ruby_libarchdir}/fcntl.so
386     %{ruby_libarchdir}/fiber.so
387     %{ruby_libarchdir}/fiddle.so
388     %{ruby_libarchdir}/gdbm.so
389     %{ruby_libarchdir}/iconv.so
390     %dir %{ruby_libarchdir}/io
391     %{ruby_libarchdir}/io/nonblock.so
392     %{ruby_libarchdir}/io/wait.so
393     %dir %{ruby_libarchdir}/mathn
394 fwang 291562 %{ruby_libarchdir}/mathn/*.so
395 fwang 291560 %{ruby_libarchdir}/nkf.so
396     %{ruby_libarchdir}/objspace.so
397     %{ruby_libarchdir}/openssl.so
398     %{ruby_libarchdir}/pathname.so
399     %{ruby_libarchdir}/psych.so
400     %{ruby_libarchdir}/pty.so
401     %dir %{ruby_libarchdir}/racc
402     %{ruby_libarchdir}/racc/*.so
403     %{ruby_libarchdir}/rbconfig.rb
404     %{ruby_libarchdir}/readline.so
405     %{ruby_libarchdir}/ripper.so
406     %{ruby_libarchdir}/sdbm.so
407     %{ruby_libarchdir}/socket.so
408     %{ruby_libarchdir}/stringio.so
409     %{ruby_libarchdir}/strscan.so
410     %{ruby_libarchdir}/syck.so
411     %{ruby_libarchdir}/syslog.so
412     %{ruby_libarchdir}/zlib.so
413 fwang 291551 %{_mandir}/man1/erb.1.*
414     %{_mandir}/man1/ruby.1.*
415 blino 1152 %{_datadir}/emacs/site-lisp/*
416     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
417     %{_sysconfdir}/rpm/macros.d/%{name}.macros
418 fwang 291560 %{_datadir}/ruby/site_ruby
419     %{_libdir}/ruby/site_ruby
420     %{_datadir}/ruby/vendor_ruby
421     %{_libdir}/ruby/vendor_ruby
422 blino 1152
423     %files doc
424     %{_datadir}/ri
425 shlomif 291698 %{_datadir}/doc/ruby/html/*
426 blino 1152
427 fwang 291590 %files -n %{libname}
428     %{_libdir}/libruby.so.%{subver}
429     %{_libdir}/libruby.so.%{rubyapi}
430    
431 blino 1152 %files devel
432 fwang 290003 %{_includedir}/*
433 blino 1152 %{_libdir}/libruby-static.a
434     %{_libdir}/libruby.so
435 fwang 290003 %{_libdir}/pkgconfig/*.pc
436 blino 1152
437     %files tk
438 fwang 291560 %{ruby_libarchdir}/tcltklib.so
439     %{ruby_libarchdir}/tkutil.so
440     %{ruby_libdir}/multi-tk.rb
441     %{ruby_libdir}/remote-tk.rb
442     %{ruby_libdir}/tcltk.rb
443     %{ruby_libdir}/tk.rb
444     %{ruby_libdir}/tkafter.rb
445     %{ruby_libdir}/tkbgerror.rb
446     %{ruby_libdir}/tkcanvas.rb
447     %{ruby_libdir}/tkclass.rb
448     %{ruby_libdir}/tkconsole.rb
449     %{ruby_libdir}/tkdialog.rb
450     %{ruby_libdir}/tkentry.rb
451     %{ruby_libdir}/tkfont.rb
452     %{ruby_libdir}/tkmacpkg.rb
453     %{ruby_libdir}/tkmenubar.rb
454     %{ruby_libdir}/tkmngfocus.rb
455     %{ruby_libdir}/tkpalette.rb
456     %{ruby_libdir}/tkscrollbox.rb
457     %{ruby_libdir}/tktext.rb
458     %{ruby_libdir}/tkvirtevent.rb
459     %{ruby_libdir}/tkwinpkg.rb
460     %{ruby_libdir}/tk
461     %{ruby_libdir}/tkextlib
462 fwang 291551
463 fwang 293412 %files irb
464     %{_bindir}/irb
465     %{ruby_libdir}/irb.rb
466     %{ruby_libdir}/irb
467     %{_mandir}/man1/irb.1*
468    
469     %if %build_gems
470 fwang 291551 %files RubyGems
471     %{_bindir}/gem
472     %dir %{rubygems_dir}
473     %{rubygems_dir}/rbconfig
474     %{rubygems_dir}/rubygems
475     %{rubygems_dir}/rubygems.rb
476     %{rubygems_dir}/ubygems.rb
477    
478 fwang 291562 %files minitest
479     %{ruby_libdir}/minitest
480 fwang 291563 %{rubygems_dir}/%{rubyapi}/specifications/minitest-*.gemspec
481 fwang 291562
482 fwang 291551 %files rake
483     %{_bindir}/rake
484     %{_mandir}/man1/rake.1.*
485 fwang 291562 %{ruby_libdir}/rake
486 fwang 291563 %{rubygems_dir}/%{rubyapi}/gems/rake-*
487 fwang 291590 %{rubygems_dir}/%{rubyapi}/specifications/rake-*.gemspec
488 fwang 291562
489     %files rdoc
490     %{_bindir}/rdoc
491     %{_bindir}/ri
492     %{ruby_libdir}/rdoc
493 fwang 291563 %{rubygems_dir}/%{rubyapi}/gems/rdoc-*
494     %{rubygems_dir}/%{rubyapi}/specifications/rdoc-*.gemspec
495 fwang 291562 %{_mandir}/man1/ri.1.*
496    
497     %files json
498     %dir %{ruby_libarchdir}/json
499     %dir %{ruby_libarchdir}/json/ext
500     %{ruby_libarchdir}/json/ext/*.so
501     %{ruby_libdir}/json
502 fwang 291563 %{rubygems_dir}/%{rubyapi}/specifications/json-*.gemspec
503 fwang 291590
504     %files bigdecimal
505     %{ruby_libdir}/bigdecimal
506     %{ruby_libarchdir}/bigdecimal.so
507 shlomif 291732 %{rubygems_dir}/%{rubyapi}/specifications/bigdecimal-*.gemspec
508 fwang 291590
509     %files io-console
510     %{ruby_libdir}/io
511     %{ruby_libarchdir}/io/console.so
512 shlomif 291732 %{rubygems_dir}/%{rubyapi}/specifications/io-console-*.gemspec
513 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30