/[packages]/cauldron/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /cauldron/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 560987 - (hide annotations) (download)
Fri Dec 27 21:38:48 2013 UTC (10 years, 3 months ago) by pterjan
File size: 17857 byte(s)
Fix use of wrong macro now that they are different
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4 fwang 447652 %define patchversion p247
5 pterjan 560984 %define rel 8
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21     # The RubyGems library has to stay out of Ruby directory three, since the
22     # RubyGems should be share by all Ruby implementations.
23 pterjan 560984 %define rubygems_dir %{_datadir}/rubygems
24 pterjan 560987 %define gems_dir %{_datadir}/ruby/gems
25 pterjan 435211 %define rubygems_version 2.0.2
26 fwang 290007
27 fwang 468908 %define bootstrap 0
28 fwang 468812 %define build_gems 0
29 fwang 292558
30 blino 1152 Summary: Object Oriented Script Language
31     Name: ruby
32     Version: %{rubyver}.%{patchversion}
33     Release: %mkrel %rel
34 kamil 397518 License: Ruby or BSD
35 blino 1152 Group: Development/Ruby
36     BuildRequires: autoconf
37     BuildRequires: byacc
38 shlomif 291698 BuildRequires: doxygen
39 blino 1152 BuildRequires: ncurses-devel
40     BuildRequires: readline-devel
41     BuildRequires: tcl-devel tk-devel
42 fwang 276350 BuildRequires: db-devel
43 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
44 blino 1152 BuildRequires: openssl-devel
45     BuildRequires: zlib-devel
46 fwang 289987 BuildRequires: libffi-devel
47     BuildRequires: yaml-devel
48 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
49 blino 1152 Obsoletes: ruby-rexml
50     Provides: ruby-rexml
51 pterjan 435566 # Couldn't get the standalone gem to work
52     Provides: rubygem(psych)
53 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
54     Provides: /usr/bin/ruby
55 fwang 293445 Provides: ruby(abi) = %rubyapi
56 fwang 463762 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
57 pterjan 435211 Source1: operating_system.rb
58 blino 1152 Source3: ruby.macros
59     URL: http://www.ruby-lang.org/
60 fwang 292558 %if !%bootstrap
61     Requires: rubygems >= %{rubygems_version}
62 fwang 293395 BuildRequires: ruby
63 fwang 292558 %endif
64 blino 1152
65 fwang 290007 # == FEDORA PATCHES BEGINS ==
66 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
67     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
68     # Fixes random WEBRick test failures.
69     # https://bugs.ruby-lang.org/issues/6573.
70     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
71 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
72     # http://redmine.ruby-lang.org/issues/5617
73     Patch8: ruby-1.9.3-custom-rubygems-location.patch
74     # Add support for installing binary extensions according to FHS.
75     # https://github.com/rubygems/rubygems/issues/210
76 pterjan 435211 # Note that 8th patch might be resolved by
77     # https://bugs.ruby-lang.org/issues/7897
78     Patch9: rubygems-2.0.0-binary-extensions.patch
79     # Make mkmf verbose by default
80     Patch12: ruby-1.9.3-mkmf-verbose.patch
81     # This slightly changes behavior of "gem install --install-dir" behavior.
82     # Without this patch, Specifications.dirs is modified and gems installed on
83     # the system cannot be required anymore. This causes later issues when RDoc
84     # documentation should be generated, since json gem is sudenly not accessible.
85     # https://github.com/rubygems/rubygems/pull/452
86     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
87     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
88     # https://github.com/rubygems/rubygems/pull/455
89     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
90 fwang 490240 # Fixes issues with DESTDIR.
91     # https://bugs.ruby-lang.org/issues/8115
92     Patch18: ruby-2.0.0-p247-Revert-mkmf.rb-prefix-install_dirs-only-with-DESTDIR.patch
93 fwang 290007 # == FEDORA PATCHES ENDS ==
94 fwang 552441 Patch100: ruby-2.0.0-CVE-2013-4164.patch
95 fwang 290007
96 fwang 291591 %package -n %{libname}
97 fwang 291590 Summary: Libraries necessary to run Ruby
98     Group: Development/Ruby
99    
100 blino 1152 %package doc
101     Summary: Documentation for the powerful language Ruby
102     Group: Development/Ruby
103 fwang 202696 BuildArch: noarch
104 blino 1152
105     %package devel
106     Summary: Development file for the powerful language Ruby
107     Group: Development/Ruby
108 fwang 311925 Requires: %{name} = %{version}
109     Requires: %{libname} = %{version}
110 blino 1152
111     %package tk
112     Summary: Tk extension for the powerful language Ruby
113     Group: Development/Ruby
114 fwang 311925 Requires: %{name} = %{version}
115 blino 1152
116 fwang 291551 %package RubyGems
117     Summary: The Ruby standard for packaging ruby libraries
118     Group: Development/Ruby
119 fwang 291590 Version: %{rubygems_version}
120 fwang 291551 Requires: ruby(abi) = %{subver}
121 fwang 291590 Provides: gem = %{rubygems_version}
122     Provides: rubygems = %{rubygems_version}
123     Provides: ruby(rubygems) = %{rubygems_version}
124 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
125 fwang 291561 BuildArch: noarch
126 fwang 291551
127 pterjan 435211 %define rake_ver 0.9.6
128 fwang 291551 %package rake
129     Summary: Simple ruby build program with capabilities similar to make
130     Group: Development/Ruby
131 shlomif 291767 Version: %{rake_ver}
132 fwang 291551 Requires: ruby(abi) = %{subver}
133 fwang 291561 BuildArch: noarch
134 fwang 291551
135 pterjan 435211 %define minitest_ver 4.3.2
136 fwang 291562 %package minitest
137 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
138 fwang 291562 Group: Development/Ruby
139 shlomif 291767 Version: %{minitest_ver}
140 fwang 291562 License: MIT
141 fwang 291590 Requires: ruby(abi) = %{subver}
142     Requires: ruby(rubygems) >= %{rubygems_version}
143 fwang 291562 BuildArch: noarch
144    
145 pterjan 435211 %define json_ver 1.7.7
146 fwang 291562 %package json
147     Summary: This is a JSON implementation as a Ruby extension in C
148     Group: Development/Ruby
149 shlomif 291767 Version: %{json_ver}
150 fwang 291562 License: Ruby or GPLv2
151 fwang 291590 Requires: ruby(abi) = %{subver}
152     Requires: ruby(rubygems) >= %{rubygems_version}
153 fwang 291562
154 pterjan 435211 %define rdoc_ver 4.0.0
155 fwang 291562 %package rdoc
156     Summary: A tool to generate HTML and command-line documentation for Ruby projects
157     Group: Development/Ruby
158 shlomif 291767 Version: %{rdoc_ver}
159 fwang 291562 License: GPLv2 and Ruby and MIT
160 fwang 291590 Requires: ruby(abi) = %{subver}
161     Requires: ruby(rubygems) >= %{rubygems_version}
162     Requires: ruby(irb) = %{version}
163 shlomif 291767 Provides: rdoc = %{rdoc_ver}
164     Provides: ri = %{rdoc_ver}
165 fwang 291562 BuildArch: noarch
166    
167 fwang 291590 %package irb
168     Summary: The Interactive Ruby
169     Group: Development/Ruby
170     Provides: irb = %{version}-%{release}
171     Provides: ruby(irb) = %{version}-%{release}
172 fwang 313459 Conflicts: ruby < 1.9
173 fwang 313460 BuildArch: noarch
174 fwang 291590
175 pterjan 435211 %define bigdecimal_ver 1.2.0
176 fwang 291590 %package bigdecimal
177     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
178     Group: Development/Ruby
179 pterjan 435211 Version: %{bigdecimal_ver}
180 fwang 291590 License: GPL+ or Artistic
181     Requires: ruby(abi) = %{subver}
182     Requires: ruby(rubygems) >= %{rubygems_version}
183    
184 pterjan 435211 %define io_console_ver 0.4.2
185 fwang 291590 %package io-console
186     Summary: IO/Console is a simple console utilizing library
187     Group: Development/Ruby
188 pterjan 435211 Version: %{io_console_ver}
189 fwang 291590 Requires: ruby(abi) = %{subver}
190     Requires: ruby(rubygems) >= %{rubygems_version}
191    
192 pterjan 435211 %define psych_ver 2.0.0
193     %package psych
194     Summary: A libyaml wrapper for Ruby
195     Version: %{psych_ver}
196     Group: Development/Ruby
197     License: MIT
198     Requires: ruby(abi) = %{subver}
199     Requires: ruby(rubygems) >= %{rubygems_version}
200     Conflicts: ruby < 2.0.0
201    
202     %define test_unit_ver 2.0.0
203     %package test-unit
204     Summary: test/unit compatible API testing framework
205     Version: %{psych_ver}
206     Group: Development/Ruby
207     License: MIT
208     Requires: ruby(abi) = %{subver}
209     Requires: ruby(rubygems) >= %{rubygems_version}
210     Conflicts: ruby < 2.0.0
211     BuildArch: noarch
212    
213 blino 1152 %description
214     Ruby is the interpreted scripting language for quick and
215     easy object-oriented programming. It has many features to
216     process text files and to do system management tasks (as in
217     Perl). It is simple, straight-forward, and extensible.
218    
219     %description doc
220     Ruby is the interpreted scripting language for quick and
221     easy object-oriented programming. It has many features to
222     process text files and to do system management tasks (as in
223     Perl). It is simple, straight-forward, and extensible.
224    
225     This package contains the Ruby's documentation
226    
227 fwang 291590 %description -n %{libname}
228     This package includes the libruby, necessary to run Ruby.
229    
230 blino 1152 %description devel
231     Ruby is the interpreted scripting language for quick and
232     easy object-oriented programming. It has many features to
233     process text files and to do system management tasks (as in
234     Perl). It is simple, straight-forward, and extensible.
235    
236     This package contains the Ruby's devel files.
237    
238     %description tk
239     Ruby is the interpreted scripting language for quick and
240     easy object-oriented programming. It has many features to
241     process text files and to do system management tasks (as in
242     Perl). It is simple, straight-forward, and extensible.
243    
244     This package contains the Tk extension for Ruby.
245    
246 fwang 291551 %description RubyGems
247     RubyGems is the Ruby standard for publishing and managing third party
248     libraries.
249    
250 fwang 291552 %description rake
251     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
252     specified in standard Ruby syntax.
253    
254 fwang 291562 %description rdoc
255     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
256     includes the 'rdoc' and 'ri' tools for generating and displaying online
257     documentation.
258    
259     %description json
260     This is a implementation of the JSON specification according to RFC 4627.
261     You can think of it as a low fat alternative to XML, if you want to store
262     data to disk or transmit it over a network rather than use a verbose
263     markup language.
264    
265     %description minitest
266     minitest/unit is a small and incredibly fast unit testing framework.
267    
268     minitest/spec is a functionally complete spec engine.
269    
270     minitest/benchmark is an awesome way to assert the performance of your
271     algorithms in a repeatable manner.
272    
273     minitest/mock by Steven Baker, is a beautifully tiny mock object
274     framework.
275    
276     minitest/pride shows pride in testing and adds coloring to your test
277     output.
278    
279 fwang 291590 %description irb
280     The irb is acronym for Interactive Ruby. It evaluates ruby expression
281     from the terminal.
282    
283     %description bigdecimal
284     Ruby provides built-in support for arbitrary precision integer arithmetic.
285     For example:
286    
287     42**13 -> 1265437718438866624512
288    
289     BigDecimal provides similar support for very large or very accurate floating
290     point numbers. Decimal arithmetic is also useful for general calculation,
291     because it provides the correct answers people expect–whereas normal binary
292     floating point arithmetic often introduces subtle errors because of the
293     conversion between base 10 and base 2.
294    
295     %description io-console
296     IO/Console provides very simple and portable access to console. It doesn't
297     provide higher layer features, such like curses and readline.
298    
299 pterjan 435211 %description psych
300     Psych is a YAML parser and emitter. Psych leverages
301     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
302     capabilities. In addition to wrapping libyaml, Psych also knows how to
303     serialize and de-serialize most Ruby objects to and from the YAML format.
304    
305     %description test-unit
306     This library implements test/unit compatible API on minitest.
307     The test/unit means that test/unit which was bundled with Ruby 1.8.
308    
309 blino 1152 %prep
310     %setup -q -n ruby-%{rubyver}-%{patchversion}
311 fwang 290007 %apply_patches
312 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
313     rm lib/mkmf.rb.0*
314 blino 1152
315     %build
316 fwang 290038 autoconf
317 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
318 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
319 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
320 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
321 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
322     --with-sitearchdir='%{ruby_sitearchdir}' \
323     --with-vendordir='%{ruby_vendorlibdir}' \
324     --with-vendorarchdir='%{ruby_vendorarchdir}' \
325 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
326 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
327     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
328     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
329     --with-rubygemsdir='%{rubygems_dir}' \
330     --with-ruby-pc='%{name}.pc' \
331     --enable-multiarch \
332     --with-ruby-version=''
333 blino 1152 %make
334    
335     %install
336     %makeinstall_std install-doc
337    
338     install -d %buildroot%{_datadir}/emacs/site-lisp
339     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
340    
341     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
342     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
343     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
344     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
345     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
346     EOF
347    
348     # Install the rpm macros
349     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
350     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
351 fwang 289961
352 pterjan 435211 # Install custom operating_system.rb
353     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
354     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
355    
356 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
357     %if !%build_gems
358 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
359 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
360 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
361     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
362 pterjan 560987 rm -fr %{buildroot}%{gems_dir}/{gems,specifications}
363 fwang 311915 %if !%bootstrap
364 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
365 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
366     rm -fr %{buildroot}%{rubygems_dir}/rubygems
367 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
368     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
369 fwang 293412 %endif
370 fwang 311914 %endif
371 fwang 293412
372 blino 1152 %check
373     make test
374    
375 fwang 289961 %files
376 fwang 291551 %{_bindir}/erb
377     %{_bindir}/ruby
378 fwang 291560 %dir %{ruby_libdir}
379     %{ruby_libdir}/*.rb
380 fwang 291590 %exclude %{ruby_libdir}/irb.rb
381 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
382     %exclude %{ruby_libdir}/remote-tk.rb
383     %exclude %{ruby_libdir}/tcltk.rb
384     %exclude %{ruby_libdir}/tk.rb
385     %exclude %{ruby_libdir}/tkafter.rb
386     %exclude %{ruby_libdir}/tkbgerror.rb
387     %exclude %{ruby_libdir}/tkcanvas.rb
388     %exclude %{ruby_libdir}/tkclass.rb
389     %exclude %{ruby_libdir}/tkconsole.rb
390     %exclude %{ruby_libdir}/tkdialog.rb
391     %exclude %{ruby_libdir}/tkentry.rb
392     %exclude %{ruby_libdir}/tkfont.rb
393     %exclude %{ruby_libdir}/tkmacpkg.rb
394     %exclude %{ruby_libdir}/tkmenubar.rb
395     %exclude %{ruby_libdir}/tkmngfocus.rb
396     %exclude %{ruby_libdir}/tkpalette.rb
397     %exclude %{ruby_libdir}/tkscrollbox.rb
398     %exclude %{ruby_libdir}/tktext.rb
399     %exclude %{ruby_libdir}/tkvirtevent.rb
400     %exclude %{ruby_libdir}/tkwinpkg.rb
401     %{ruby_libdir}/cgi
402     %{ruby_libdir}/date
403     %{ruby_libdir}/digest
404     %{ruby_libdir}/dl
405     %{ruby_libdir}/drb
406     %{ruby_libdir}/fiddle
407     %{ruby_libdir}/matrix
408     %{ruby_libdir}/net
409     %{ruby_libdir}/openssl
410     %{ruby_libdir}/optparse
411 pterjan 435566 %{ruby_libdir}/psych
412 fwang 291560 %{ruby_libdir}/racc
413     %{ruby_libdir}/rbconfig
414     %{ruby_libdir}/rexml
415     %{ruby_libdir}/rinda
416     %{ruby_libdir}/ripper
417     %{ruby_libdir}/rss
418     %{ruby_libdir}/shell
419 pterjan 435211 %{ruby_libdir}/syslog
420 fwang 291560 %{ruby_libdir}/uri
421     %{ruby_libdir}/webrick
422     %{ruby_libdir}/xmlrpc
423     %{ruby_libdir}/yaml
424     %dir %{ruby_libarchdir}
425     %{ruby_libarchdir}/continuation.so
426     %{ruby_libarchdir}/coverage.so
427     %{ruby_libarchdir}/curses.so
428     %{ruby_libarchdir}/date_core.so
429     %{ruby_libarchdir}/dbm.so
430     %dir %{ruby_libarchdir}/digest
431     %{ruby_libarchdir}/digest.so
432     %{ruby_libarchdir}/digest/*.so
433     %dir %{ruby_libarchdir}/dl
434     %{ruby_libarchdir}/dl.so
435     %{ruby_libarchdir}/dl/*.so
436     %dir %{ruby_libarchdir}/enc
437     %{ruby_libarchdir}/enc/*.so
438 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
439     %{ruby_libarchdir}/enc/trans/*.so
440 fwang 291560 %{ruby_libarchdir}/etc.so
441     %{ruby_libarchdir}/fcntl.so
442     %{ruby_libarchdir}/fiber.so
443     %{ruby_libarchdir}/fiddle.so
444     %{ruby_libarchdir}/gdbm.so
445     %dir %{ruby_libarchdir}/io
446     %{ruby_libarchdir}/io/nonblock.so
447     %{ruby_libarchdir}/io/wait.so
448     %dir %{ruby_libarchdir}/mathn
449 fwang 291562 %{ruby_libarchdir}/mathn/*.so
450 fwang 291560 %{ruby_libarchdir}/nkf.so
451     %{ruby_libarchdir}/objspace.so
452     %{ruby_libarchdir}/openssl.so
453 pterjan 435566 %{ruby_libarchdir}/psych.so
454 fwang 291560 %{ruby_libarchdir}/pathname.so
455     %{ruby_libarchdir}/pty.so
456     %dir %{ruby_libarchdir}/racc
457     %{ruby_libarchdir}/racc/*.so
458     %{ruby_libarchdir}/rbconfig.rb
459     %{ruby_libarchdir}/readline.so
460     %{ruby_libarchdir}/ripper.so
461     %{ruby_libarchdir}/sdbm.so
462     %{ruby_libarchdir}/socket.so
463     %{ruby_libarchdir}/stringio.so
464     %{ruby_libarchdir}/strscan.so
465     %{ruby_libarchdir}/syslog.so
466     %{ruby_libarchdir}/zlib.so
467 fwang 291551 %{_mandir}/man1/erb.1.*
468     %{_mandir}/man1/ruby.1.*
469 blino 1152 %{_datadir}/emacs/site-lisp/*
470     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
471     %{_sysconfdir}/rpm/macros.d/%{name}.macros
472 fwang 291560 %{_datadir}/ruby/site_ruby
473     %{_libdir}/ruby/site_ruby
474     %{_datadir}/ruby/vendor_ruby
475     %{_libdir}/ruby/vendor_ruby
476 fwang 311914 %if %bootstrap
477     %{_bindir}/gem
478 fwang 448831 %dir %{rubygems_dir}
479     %{rubygems_dir}/rbconfig
480     %{rubygems_dir}/rubygems
481     %{rubygems_dir}/rubygems.rb
482     %{rubygems_dir}/ubygems.rb
483 fwang 311914 %endif
484 blino 1152
485     %files doc
486     %{_datadir}/ri
487 pterjan 435211 %{_datadir}/doc/ruby
488 blino 1152
489 fwang 291590 %files -n %{libname}
490     %{_libdir}/libruby.so.%{subver}
491     %{_libdir}/libruby.so.%{rubyapi}
492    
493 blino 1152 %files devel
494 fwang 290003 %{_includedir}/*
495 blino 1152 %{_libdir}/libruby-static.a
496     %{_libdir}/libruby.so
497 fwang 290003 %{_libdir}/pkgconfig/*.pc
498 blino 1152
499     %files tk
500 fwang 291560 %{ruby_libarchdir}/tcltklib.so
501     %{ruby_libarchdir}/tkutil.so
502     %{ruby_libdir}/multi-tk.rb
503     %{ruby_libdir}/remote-tk.rb
504     %{ruby_libdir}/tcltk.rb
505     %{ruby_libdir}/tk.rb
506     %{ruby_libdir}/tkafter.rb
507     %{ruby_libdir}/tkbgerror.rb
508     %{ruby_libdir}/tkcanvas.rb
509     %{ruby_libdir}/tkclass.rb
510     %{ruby_libdir}/tkconsole.rb
511     %{ruby_libdir}/tkdialog.rb
512     %{ruby_libdir}/tkentry.rb
513     %{ruby_libdir}/tkfont.rb
514     %{ruby_libdir}/tkmacpkg.rb
515     %{ruby_libdir}/tkmenubar.rb
516     %{ruby_libdir}/tkmngfocus.rb
517     %{ruby_libdir}/tkpalette.rb
518     %{ruby_libdir}/tkscrollbox.rb
519     %{ruby_libdir}/tktext.rb
520     %{ruby_libdir}/tkvirtevent.rb
521     %{ruby_libdir}/tkwinpkg.rb
522     %{ruby_libdir}/tk
523     %{ruby_libdir}/tkextlib
524 fwang 291551
525 fwang 293412 %files irb
526     %{_bindir}/irb
527     %{ruby_libdir}/irb.rb
528     %{ruby_libdir}/irb
529     %{_mandir}/man1/irb.1*
530    
531     %if %build_gems
532 fwang 291551 %files RubyGems
533     %{_bindir}/gem
534     %dir %{rubygems_dir}
535     %{rubygems_dir}/rbconfig
536     %{rubygems_dir}/rubygems
537     %{rubygems_dir}/rubygems.rb
538     %{rubygems_dir}/ubygems.rb
539    
540 fwang 291562 %files minitest
541     %{ruby_libdir}/minitest
542 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
543 fwang 291562
544 fwang 291551 %files rake
545     %{_bindir}/rake
546     %{_mandir}/man1/rake.1.*
547 fwang 291562 %{ruby_libdir}/rake
548 pterjan 560987 %{gems_dir}/gems/rake-*
549     %{gems_dir}/specifications/default/rake-*.gemspec
550 fwang 291562
551     %files rdoc
552     %{_bindir}/rdoc
553     %{_bindir}/ri
554     %{ruby_libdir}/rdoc
555 pterjan 560987 %{gems_dir}/gems/rdoc-*
556     %{gems_dir}/specifications/default/rdoc-*.gemspec
557 fwang 291562 %{_mandir}/man1/ri.1.*
558    
559     %files json
560     %dir %{ruby_libarchdir}/json
561     %dir %{ruby_libarchdir}/json/ext
562     %{ruby_libarchdir}/json/ext/*.so
563     %{ruby_libdir}/json
564 pterjan 560987 %{gems_dir}/specifications/default/json-*.gemspec
565 fwang 291590
566     %files bigdecimal
567     %{ruby_libdir}/bigdecimal
568     %{ruby_libarchdir}/bigdecimal.so
569 pterjan 560987 %{gems_dir}/specifications/default/bigdecimal-*.gemspec
570 fwang 291590
571     %files io-console
572     %{ruby_libdir}/io
573     %{ruby_libarchdir}/io/console.so
574 pterjan 560987 %{gems_dir}/specifications/default/io-console-*.gemspec
575 pterjan 435211
576     %files psych
577     %{ruby_libdir}/psych
578     %{ruby_libarchdir}/psych.so
579 pterjan 560987 %{gems_dir}/specifications/default/psych-*.gemspec
580 pterjan 435211
581     %files test-unit
582     %{_bindir}/testrb
583     %{ruby_libdir}/test
584 pterjan 560987 %{gems_dir}/gems/test-unit-*
585 pterjan 435211 %{rubygems_dir}/specifications/default/test-unit-*.gemspec
586 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30