/[packages]/cauldron/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /cauldron/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 674754 - (hide annotations) (download)
Thu Sep 11 20:08:26 2014 UTC (9 years, 7 months ago) by tv
File size: 18789 byte(s)
- move rubygem req/prov generator in rubygem subpackage instead of -devel one
  (this one is actually required by gems but not always -devel)
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4 pterjan 601593 %define patchversion p451
5 tv 674754 %define rel 4
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
22     # RubyGems should be shared by all Ruby implementations.
23 pterjan 560984 %define rubygems_dir %{_datadir}/rubygems
24 pterjan 560987 %define gems_dir %{_datadir}/ruby/gems
25 pterjan 435211 %define rubygems_version 2.0.2
26 fwang 290007
27 fwang 468908 %define bootstrap 0
28 fwang 468812 %define build_gems 0
29 fwang 292558
30 blino 1152 Summary: Object Oriented Script Language
31     Name: ruby
32     Version: %{rubyver}.%{patchversion}
33     Release: %mkrel %rel
34 kamil 397518 License: Ruby or BSD
35 blino 1152 Group: Development/Ruby
36     BuildRequires: autoconf
37     BuildRequires: byacc
38 shlomif 291698 BuildRequires: doxygen
39 blino 1152 BuildRequires: ncurses-devel
40     BuildRequires: readline-devel
41 ovitters 648773 BuildRequires: tcl-devel
42     BuildRequires: tk-devel
43 fwang 276350 BuildRequires: db-devel
44 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
45 blino 1152 BuildRequires: openssl-devel
46     BuildRequires: zlib-devel
47 fwang 289987 BuildRequires: libffi-devel
48     BuildRequires: yaml-devel
49 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
50 blino 1152 Obsoletes: ruby-rexml
51     Provides: ruby-rexml
52 pterjan 435566 # Couldn't get the standalone gem to work
53     Provides: rubygem(psych)
54 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
55     Provides: /usr/bin/ruby
56 fwang 293445 Provides: ruby(abi) = %rubyapi
57 fwang 463762 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
58 pterjan 435211 Source1: operating_system.rb
59 blino 1152 Source3: ruby.macros
60 tv 673709 # From FC:
61     # RPM dependency generators.
62     Source8: rubygems.attr
63     Source9: rubygems.req
64     Source10: rubygems.prov
65 blino 1152 URL: http://www.ruby-lang.org/
66 fwang 292558 %if !%bootstrap
67     Requires: rubygems >= %{rubygems_version}
68 fwang 293395 BuildRequires: ruby
69 fwang 292558 %endif
70 blino 1152
71 fwang 290007 # == FEDORA PATCHES BEGINS ==
72 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
73     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
74     # Fixes random WEBRick test failures.
75     # https://bugs.ruby-lang.org/issues/6573.
76     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
77 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
78     # http://redmine.ruby-lang.org/issues/5617
79     Patch8: ruby-1.9.3-custom-rubygems-location.patch
80     # Add support for installing binary extensions according to FHS.
81     # https://github.com/rubygems/rubygems/issues/210
82 pterjan 435211 # Note that 8th patch might be resolved by
83     # https://bugs.ruby-lang.org/issues/7897
84     Patch9: rubygems-2.0.0-binary-extensions.patch
85     # Make mkmf verbose by default
86     Patch12: ruby-1.9.3-mkmf-verbose.patch
87     # This slightly changes behavior of "gem install --install-dir" behavior.
88     # Without this patch, Specifications.dirs is modified and gems installed on
89     # the system cannot be required anymore. This causes later issues when RDoc
90     # documentation should be generated, since json gem is sudenly not accessible.
91     # https://github.com/rubygems/rubygems/pull/452
92     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
93     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
94     # https://github.com/rubygems/rubygems/pull/455
95     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
96 fwang 490240 # Fixes issues with DESTDIR.
97     # https://bugs.ruby-lang.org/issues/8115
98     Patch18: ruby-2.0.0-p247-Revert-mkmf.rb-prefix-install_dirs-only-with-DESTDIR.patch
99 fwang 290007 # == FEDORA PATCHES ENDS ==
100 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
101     # to install gems into user dir
102     Patch20: ruby-2.0.0-p451-Do-not-install-to-user-dir.patch
103 pterjan 601635 # Upstream patch to build with new readline
104     Patch21: ruby-2.0.0-p451-readline.patch
105 fwang 290007
106 fwang 291591 %package -n %{libname}
107 fwang 291590 Summary: Libraries necessary to run Ruby
108     Group: Development/Ruby
109    
110 blino 1152 %package doc
111     Summary: Documentation for the powerful language Ruby
112     Group: Development/Ruby
113 fwang 202696 BuildArch: noarch
114 blino 1152
115     %package devel
116     Summary: Development file for the powerful language Ruby
117     Group: Development/Ruby
118 fwang 311925 Requires: %{name} = %{version}
119     Requires: %{libname} = %{version}
120 blino 1152
121     %package tk
122     Summary: Tk extension for the powerful language Ruby
123     Group: Development/Ruby
124 fwang 311925 Requires: %{name} = %{version}
125 blino 1152
126 fwang 291551 %package RubyGems
127     Summary: The Ruby standard for packaging ruby libraries
128     Group: Development/Ruby
129 fwang 291590 Version: %{rubygems_version}
130 fwang 291551 Requires: ruby(abi) = %{subver}
131 fwang 291590 Provides: gem = %{rubygems_version}
132     Provides: rubygems = %{rubygems_version}
133     Provides: ruby(rubygems) = %{rubygems_version}
134 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
135 tv 674754 Conflicts: ruby-devel < 2.0.0.p451-4.mga5
136 fwang 291561 BuildArch: noarch
137 fwang 291551
138 pterjan 435211 %define rake_ver 0.9.6
139 fwang 291551 %package rake
140     Summary: Simple ruby build program with capabilities similar to make
141     Group: Development/Ruby
142 shlomif 291767 Version: %{rake_ver}
143 fwang 291551 Requires: ruby(abi) = %{subver}
144 fwang 291561 BuildArch: noarch
145 fwang 291551
146 pterjan 435211 %define minitest_ver 4.3.2
147 fwang 291562 %package minitest
148 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
149 fwang 291562 Group: Development/Ruby
150 shlomif 291767 Version: %{minitest_ver}
151 fwang 291562 License: MIT
152 fwang 291590 Requires: ruby(abi) = %{subver}
153     Requires: ruby(rubygems) >= %{rubygems_version}
154 fwang 291562 BuildArch: noarch
155    
156 pterjan 435211 %define json_ver 1.7.7
157 fwang 291562 %package json
158     Summary: This is a JSON implementation as a Ruby extension in C
159     Group: Development/Ruby
160 shlomif 291767 Version: %{json_ver}
161 fwang 291562 License: Ruby or GPLv2
162 fwang 291590 Requires: ruby(abi) = %{subver}
163     Requires: ruby(rubygems) >= %{rubygems_version}
164 fwang 291562
165 pterjan 435211 %define rdoc_ver 4.0.0
166 fwang 291562 %package rdoc
167     Summary: A tool to generate HTML and command-line documentation for Ruby projects
168     Group: Development/Ruby
169 shlomif 291767 Version: %{rdoc_ver}
170 fwang 291562 License: GPLv2 and Ruby and MIT
171 fwang 291590 Requires: ruby(abi) = %{subver}
172     Requires: ruby(rubygems) >= %{rubygems_version}
173     Requires: ruby(irb) = %{version}
174 shlomif 291767 Provides: rdoc = %{rdoc_ver}
175     Provides: ri = %{rdoc_ver}
176 fwang 291562 BuildArch: noarch
177    
178 fwang 291590 %package irb
179     Summary: The Interactive Ruby
180     Group: Development/Ruby
181     Provides: irb = %{version}-%{release}
182     Provides: ruby(irb) = %{version}-%{release}
183 fwang 313459 Conflicts: ruby < 1.9
184 fwang 313460 BuildArch: noarch
185 fwang 291590
186 pterjan 435211 %define bigdecimal_ver 1.2.0
187 fwang 291590 %package bigdecimal
188     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
189     Group: Development/Ruby
190 pterjan 435211 Version: %{bigdecimal_ver}
191 fwang 291590 License: GPL+ or Artistic
192     Requires: ruby(abi) = %{subver}
193     Requires: ruby(rubygems) >= %{rubygems_version}
194    
195 pterjan 435211 %define io_console_ver 0.4.2
196 fwang 291590 %package io-console
197     Summary: IO/Console is a simple console utilizing library
198     Group: Development/Ruby
199 pterjan 435211 Version: %{io_console_ver}
200 fwang 291590 Requires: ruby(abi) = %{subver}
201     Requires: ruby(rubygems) >= %{rubygems_version}
202    
203 pterjan 435211 %define psych_ver 2.0.0
204     %package psych
205     Summary: A libyaml wrapper for Ruby
206     Version: %{psych_ver}
207     Group: Development/Ruby
208     License: MIT
209     Requires: ruby(abi) = %{subver}
210     Requires: ruby(rubygems) >= %{rubygems_version}
211     Conflicts: ruby < 2.0.0
212    
213     %define test_unit_ver 2.0.0
214     %package test-unit
215     Summary: test/unit compatible API testing framework
216     Version: %{psych_ver}
217     Group: Development/Ruby
218     License: MIT
219     Requires: ruby(abi) = %{subver}
220     Requires: ruby(rubygems) >= %{rubygems_version}
221     Conflicts: ruby < 2.0.0
222     BuildArch: noarch
223    
224 blino 1152 %description
225     Ruby is the interpreted scripting language for quick and
226     easy object-oriented programming. It has many features to
227     process text files and to do system management tasks (as in
228     Perl). It is simple, straight-forward, and extensible.
229    
230     %description doc
231     Ruby is the interpreted scripting language for quick and
232     easy object-oriented programming. It has many features to
233     process text files and to do system management tasks (as in
234     Perl). It is simple, straight-forward, and extensible.
235    
236     This package contains the Ruby's documentation
237    
238 fwang 291590 %description -n %{libname}
239     This package includes the libruby, necessary to run Ruby.
240    
241 blino 1152 %description devel
242     Ruby is the interpreted scripting language for quick and
243     easy object-oriented programming. It has many features to
244     process text files and to do system management tasks (as in
245     Perl). It is simple, straight-forward, and extensible.
246    
247     This package contains the Ruby's devel files.
248    
249     %description tk
250     Ruby is the interpreted scripting language for quick and
251     easy object-oriented programming. It has many features to
252     process text files and to do system management tasks (as in
253     Perl). It is simple, straight-forward, and extensible.
254    
255     This package contains the Tk extension for Ruby.
256    
257 fwang 291551 %description RubyGems
258     RubyGems is the Ruby standard for publishing and managing third party
259     libraries.
260    
261 fwang 291552 %description rake
262     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
263     specified in standard Ruby syntax.
264    
265 fwang 291562 %description rdoc
266     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
267     includes the 'rdoc' and 'ri' tools for generating and displaying online
268     documentation.
269    
270     %description json
271     This is a implementation of the JSON specification according to RFC 4627.
272     You can think of it as a low fat alternative to XML, if you want to store
273     data to disk or transmit it over a network rather than use a verbose
274     markup language.
275    
276     %description minitest
277     minitest/unit is a small and incredibly fast unit testing framework.
278    
279     minitest/spec is a functionally complete spec engine.
280    
281     minitest/benchmark is an awesome way to assert the performance of your
282     algorithms in a repeatable manner.
283    
284     minitest/mock by Steven Baker, is a beautifully tiny mock object
285     framework.
286    
287     minitest/pride shows pride in testing and adds coloring to your test
288     output.
289    
290 fwang 291590 %description irb
291     The irb is acronym for Interactive Ruby. It evaluates ruby expression
292     from the terminal.
293    
294     %description bigdecimal
295     Ruby provides built-in support for arbitrary precision integer arithmetic.
296     For example:
297    
298     42**13 -> 1265437718438866624512
299    
300     BigDecimal provides similar support for very large or very accurate floating
301     point numbers. Decimal arithmetic is also useful for general calculation,
302     because it provides the correct answers people expect–whereas normal binary
303     floating point arithmetic often introduces subtle errors because of the
304     conversion between base 10 and base 2.
305    
306     %description io-console
307     IO/Console provides very simple and portable access to console. It doesn't
308     provide higher layer features, such like curses and readline.
309    
310 pterjan 435211 %description psych
311     Psych is a YAML parser and emitter. Psych leverages
312     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
313     capabilities. In addition to wrapping libyaml, Psych also knows how to
314     serialize and de-serialize most Ruby objects to and from the YAML format.
315    
316     %description test-unit
317     This library implements test/unit compatible API on minitest.
318     The test/unit means that test/unit which was bundled with Ruby 1.8.
319    
320 blino 1152 %prep
321     %setup -q -n ruby-%{rubyver}-%{patchversion}
322 fwang 290007 %apply_patches
323 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
324     rm lib/mkmf.rb.0*
325 blino 1152
326     %build
327 fwang 290038 autoconf
328 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
329 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
330 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
331 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
332 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
333     --with-sitearchdir='%{ruby_sitearchdir}' \
334     --with-vendordir='%{ruby_vendorlibdir}' \
335     --with-vendorarchdir='%{ruby_vendorarchdir}' \
336 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
337 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
338     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
339     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
340     --with-rubygemsdir='%{rubygems_dir}' \
341     --with-ruby-pc='%{name}.pc' \
342     --enable-multiarch \
343     --with-ruby-version=''
344 blino 1152 %make
345    
346     %install
347     %makeinstall_std install-doc
348    
349     install -d %buildroot%{_datadir}/emacs/site-lisp
350     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
351    
352     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
353     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
354     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
355     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
356     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
357     EOF
358    
359     # Install the rpm macros
360     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
361     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
362 fwang 289961
363 tv 673709 # Install dependency generators.
364     mkdir -p %{buildroot}%{_rpmconfigdir}/fileattrs
365     install -m 644 %{SOURCE8} %{buildroot}%{_rpmconfigdir}/fileattrs
366     install -m 755 %{SOURCE9} %{buildroot}%{_rpmconfigdir}
367     install -m 755 %{SOURCE10} %{buildroot}%{_rpmconfigdir}
368    
369 pterjan 435211 # Install custom operating_system.rb
370     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
371     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
372    
373 pterjan 617250 # Version is empty if --with-ruby-version is specified.
374     # http://bugs.ruby-lang.org/issues/7807
375     sed -i 's/Version: .*/Version: %{rubyver}/' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
376    
377 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
378     %if !%build_gems
379 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
380 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
381 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
382     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
383 pterjan 560987 rm -fr %{buildroot}%{gems_dir}/{gems,specifications}
384 fwang 311915 %if !%bootstrap
385 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
386 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
387     rm -fr %{buildroot}%{rubygems_dir}/rubygems
388 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
389     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
390 fwang 293412 %endif
391 fwang 311914 %endif
392 fwang 293412
393 blino 1152 %check
394     make test
395    
396 fwang 289961 %files
397 fwang 291551 %{_bindir}/erb
398     %{_bindir}/ruby
399 fwang 291560 %dir %{ruby_libdir}
400     %{ruby_libdir}/*.rb
401 fwang 291590 %exclude %{ruby_libdir}/irb.rb
402 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
403     %exclude %{ruby_libdir}/remote-tk.rb
404     %exclude %{ruby_libdir}/tcltk.rb
405     %exclude %{ruby_libdir}/tk.rb
406     %exclude %{ruby_libdir}/tkafter.rb
407     %exclude %{ruby_libdir}/tkbgerror.rb
408     %exclude %{ruby_libdir}/tkcanvas.rb
409     %exclude %{ruby_libdir}/tkclass.rb
410     %exclude %{ruby_libdir}/tkconsole.rb
411     %exclude %{ruby_libdir}/tkdialog.rb
412     %exclude %{ruby_libdir}/tkentry.rb
413     %exclude %{ruby_libdir}/tkfont.rb
414     %exclude %{ruby_libdir}/tkmacpkg.rb
415     %exclude %{ruby_libdir}/tkmenubar.rb
416     %exclude %{ruby_libdir}/tkmngfocus.rb
417     %exclude %{ruby_libdir}/tkpalette.rb
418     %exclude %{ruby_libdir}/tkscrollbox.rb
419     %exclude %{ruby_libdir}/tktext.rb
420     %exclude %{ruby_libdir}/tkvirtevent.rb
421     %exclude %{ruby_libdir}/tkwinpkg.rb
422     %{ruby_libdir}/cgi
423     %{ruby_libdir}/date
424     %{ruby_libdir}/digest
425     %{ruby_libdir}/dl
426     %{ruby_libdir}/drb
427     %{ruby_libdir}/fiddle
428     %{ruby_libdir}/matrix
429     %{ruby_libdir}/net
430     %{ruby_libdir}/openssl
431     %{ruby_libdir}/optparse
432 pterjan 435566 %{ruby_libdir}/psych
433 fwang 291560 %{ruby_libdir}/racc
434     %{ruby_libdir}/rbconfig
435     %{ruby_libdir}/rexml
436     %{ruby_libdir}/rinda
437     %{ruby_libdir}/ripper
438     %{ruby_libdir}/rss
439     %{ruby_libdir}/shell
440 pterjan 435211 %{ruby_libdir}/syslog
441 fwang 291560 %{ruby_libdir}/uri
442     %{ruby_libdir}/webrick
443     %{ruby_libdir}/xmlrpc
444     %{ruby_libdir}/yaml
445     %dir %{ruby_libarchdir}
446     %{ruby_libarchdir}/continuation.so
447     %{ruby_libarchdir}/coverage.so
448     %{ruby_libarchdir}/curses.so
449     %{ruby_libarchdir}/date_core.so
450     %{ruby_libarchdir}/dbm.so
451     %dir %{ruby_libarchdir}/digest
452     %{ruby_libarchdir}/digest.so
453     %{ruby_libarchdir}/digest/*.so
454     %dir %{ruby_libarchdir}/dl
455     %{ruby_libarchdir}/dl.so
456     %{ruby_libarchdir}/dl/*.so
457     %dir %{ruby_libarchdir}/enc
458     %{ruby_libarchdir}/enc/*.so
459 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
460     %{ruby_libarchdir}/enc/trans/*.so
461 fwang 291560 %{ruby_libarchdir}/etc.so
462     %{ruby_libarchdir}/fcntl.so
463     %{ruby_libarchdir}/fiber.so
464     %{ruby_libarchdir}/fiddle.so
465     %{ruby_libarchdir}/gdbm.so
466     %dir %{ruby_libarchdir}/io
467     %{ruby_libarchdir}/io/nonblock.so
468     %{ruby_libarchdir}/io/wait.so
469     %dir %{ruby_libarchdir}/mathn
470 fwang 291562 %{ruby_libarchdir}/mathn/*.so
471 fwang 291560 %{ruby_libarchdir}/nkf.so
472     %{ruby_libarchdir}/objspace.so
473     %{ruby_libarchdir}/openssl.so
474 pterjan 435566 %{ruby_libarchdir}/psych.so
475 fwang 291560 %{ruby_libarchdir}/pathname.so
476     %{ruby_libarchdir}/pty.so
477     %dir %{ruby_libarchdir}/racc
478     %{ruby_libarchdir}/racc/*.so
479     %{ruby_libarchdir}/rbconfig.rb
480     %{ruby_libarchdir}/readline.so
481     %{ruby_libarchdir}/ripper.so
482     %{ruby_libarchdir}/sdbm.so
483     %{ruby_libarchdir}/socket.so
484     %{ruby_libarchdir}/stringio.so
485     %{ruby_libarchdir}/strscan.so
486     %{ruby_libarchdir}/syslog.so
487     %{ruby_libarchdir}/zlib.so
488 fwang 291551 %{_mandir}/man1/erb.1.*
489     %{_mandir}/man1/ruby.1.*
490 blino 1152 %{_datadir}/emacs/site-lisp/*
491     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
492     %{_sysconfdir}/rpm/macros.d/%{name}.macros
493 fwang 291560 %{_datadir}/ruby/site_ruby
494     %{_libdir}/ruby/site_ruby
495     %{_datadir}/ruby/vendor_ruby
496     %{_libdir}/ruby/vendor_ruby
497 fwang 311914 %if %bootstrap
498     %{_bindir}/gem
499 fwang 448831 %dir %{rubygems_dir}
500     %{rubygems_dir}/rbconfig
501     %{rubygems_dir}/rubygems
502     %{rubygems_dir}/rubygems.rb
503     %{rubygems_dir}/ubygems.rb
504 fwang 311914 %endif
505 blino 1152
506     %files doc
507     %{_datadir}/ri
508 pterjan 435211 %{_datadir}/doc/ruby
509 blino 1152
510 fwang 291590 %files -n %{libname}
511     %{_libdir}/libruby.so.%{subver}
512     %{_libdir}/libruby.so.%{rubyapi}
513    
514 blino 1152 %files devel
515 fwang 290003 %{_includedir}/*
516 blino 1152 %{_libdir}/libruby-static.a
517     %{_libdir}/libruby.so
518 fwang 290003 %{_libdir}/pkgconfig/*.pc
519 tv 673709 %{_rpmconfigdir}/fileattrs/rubygems.attr
520 blino 1152
521     %files tk
522 fwang 291560 %{ruby_libarchdir}/tcltklib.so
523     %{ruby_libarchdir}/tkutil.so
524     %{ruby_libdir}/multi-tk.rb
525     %{ruby_libdir}/remote-tk.rb
526     %{ruby_libdir}/tcltk.rb
527     %{ruby_libdir}/tk.rb
528     %{ruby_libdir}/tkafter.rb
529     %{ruby_libdir}/tkbgerror.rb
530     %{ruby_libdir}/tkcanvas.rb
531     %{ruby_libdir}/tkclass.rb
532     %{ruby_libdir}/tkconsole.rb
533     %{ruby_libdir}/tkdialog.rb
534     %{ruby_libdir}/tkentry.rb
535     %{ruby_libdir}/tkfont.rb
536     %{ruby_libdir}/tkmacpkg.rb
537     %{ruby_libdir}/tkmenubar.rb
538     %{ruby_libdir}/tkmngfocus.rb
539     %{ruby_libdir}/tkpalette.rb
540     %{ruby_libdir}/tkscrollbox.rb
541     %{ruby_libdir}/tktext.rb
542     %{ruby_libdir}/tkvirtevent.rb
543     %{ruby_libdir}/tkwinpkg.rb
544     %{ruby_libdir}/tk
545     %{ruby_libdir}/tkextlib
546 fwang 291551
547 fwang 293412 %files irb
548     %{_bindir}/irb
549     %{ruby_libdir}/irb.rb
550     %{ruby_libdir}/irb
551     %{_mandir}/man1/irb.1*
552    
553     %if %build_gems
554 fwang 291551 %files RubyGems
555     %{_bindir}/gem
556     %dir %{rubygems_dir}
557     %{rubygems_dir}/rbconfig
558     %{rubygems_dir}/rubygems
559     %{rubygems_dir}/rubygems.rb
560     %{rubygems_dir}/ubygems.rb
561 tv 674754 %{_rpmconfigdir}/rubygems.req
562     %{_rpmconfigdir}/rubygems.prov
563 fwang 291551
564 fwang 291562 %files minitest
565     %{ruby_libdir}/minitest
566 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
567 fwang 291562
568 fwang 291551 %files rake
569     %{_bindir}/rake
570     %{_mandir}/man1/rake.1.*
571 fwang 291562 %{ruby_libdir}/rake
572 pterjan 560987 %{gems_dir}/gems/rake-*
573     %{gems_dir}/specifications/default/rake-*.gemspec
574 fwang 291562
575     %files rdoc
576     %{_bindir}/rdoc
577     %{_bindir}/ri
578     %{ruby_libdir}/rdoc
579 pterjan 560987 %{gems_dir}/gems/rdoc-*
580     %{gems_dir}/specifications/default/rdoc-*.gemspec
581 fwang 291562 %{_mandir}/man1/ri.1.*
582    
583     %files json
584     %dir %{ruby_libarchdir}/json
585     %dir %{ruby_libarchdir}/json/ext
586     %{ruby_libarchdir}/json/ext/*.so
587     %{ruby_libdir}/json
588 pterjan 560987 %{gems_dir}/specifications/default/json-*.gemspec
589 fwang 291590
590     %files bigdecimal
591     %{ruby_libdir}/bigdecimal
592     %{ruby_libarchdir}/bigdecimal.so
593 pterjan 560987 %{gems_dir}/specifications/default/bigdecimal-*.gemspec
594 fwang 291590
595     %files io-console
596     %{ruby_libdir}/io
597     %{ruby_libarchdir}/io/console.so
598 pterjan 560987 %{gems_dir}/specifications/default/io-console-*.gemspec
599 pterjan 435211
600     %files psych
601     %{ruby_libdir}/psych
602     %{ruby_libarchdir}/psych.so
603 pterjan 560987 %{gems_dir}/specifications/default/psych-*.gemspec
604 pterjan 435211
605     %files test-unit
606     %{_bindir}/testrb
607     %{ruby_libdir}/test
608 pterjan 560987 %{gems_dir}/gems/test-unit-*
609 pterjan 435211 %{rubygems_dir}/specifications/default/test-unit-*.gemspec
610 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30