/[packages]/cauldron/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /cauldron/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 894459 - (hide annotations) (download)
Fri Oct 23 09:47:10 2015 UTC (8 years, 5 months ago) by pterjan
File size: 21539 byte(s)
- build gems to allow bootstrap
- various fixes and cleanups, not yet tested if more are needed
1 shlomif 893775 # Taken from the fedora ruby-2.2.3 .spec. Thanks!
2 blino 1152
3 shlomif 893775 %global major_version 2
4     %global minor_version 2
5     %global teeny_version 3
6     %global major_minor_version %{major_version}.%{minor_version}
7    
8     %global ruby_version %{major_minor_version}.%{teeny_version}
9     %global ruby_release %{ruby_version}
10    
11     # Specify the named version. It has precedense to revision.
12     #%%global milestone rc1
13    
14     # Keep the revision enabled for pre-releases from SVN.
15     #%%global revision 48936
16    
17     %global ruby_archive %{name}-%{ruby_version}
18    
19     # If revision and milestone are removed/commented out, the official release build is expected.
20     %if 0%{?milestone:1}%{?revision:1} != 0
21     %global development_release %{?milestone}%{?!milestone:%{?revision:r%{revision}}}
22     %global ruby_archive %{ruby_archive}-%{?milestone}%{?!milestone:%{?revision:r%{revision}}}
23     %endif
24    
25    
26 blino 894458 %global release 3
27 shlomif 893775 %{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
28    
29     %global rubygems_version 2.4.5.1
30    
31     # The RubyGems library has to stay out of Ruby directory three, since the
32     # RubyGems should be share by all Ruby implementations.
33     %global rubygems_dir %{_datadir}/rubygems
34    
35     # TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM.
36     # http://redmine.ruby-lang.org/issues/5313
37     %global irb_version %{ruby_version}
38    
39     %global bigdecimal_version 1.2.6
40     %global io_console_version 0.4.3
41     %global json_version 1.8.1
42     %global minitest_version 5.4.3
43     %global power_assert_version 0.2.2
44     %global psych_version 2.0.8
45     %global rake_version 10.4.2
46     %global rdoc_version 4.2.0
47     %global test_unit_version 3.0.8
48    
49     # Might not be needed in the future, if we are lucky enough.
50     # https://bugzilla.redhat.com/show_bug.cgi?id=888262
51     %global tapset_root %{_datadir}/systemtap
52     %global tapset_dir %{tapset_root}/tapset
53     %global tapset_libdir %(echo %{_libdir} | sed 's/64//')*
54    
55     %global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/;s/sparcv./sparc/')
56    
57     %global with_rubypick 1
58    
59     # Additional defines by Mageia.
60    
61     %define subver %{major_minor_version}
62     %define rubyapi %{subver}.0
63     %define rubyver %{ruby_version}
64     %define rel %{release}
65    
66 fwang 291590 %define libname %mklibname ruby %{subver}
67    
68 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
69     %define ruby_libarchdir %{_libdir}/%{name}
70    
71 fwang 290007 # This is the local lib/arch and should not be used for packaging.
72 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
73     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
74 fwang 290007
75     # This is the general location for libs/archs compatible with all
76     # or most of the Ruby versions available in the Fedora repositories.
77 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
78 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
79 fwang 290007
80 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
81     # RubyGems should be shared by all Ruby implementations.
82 pterjan 894459 %define gems_dir %{_datadir}/gems
83 fwang 290007
84 blino 894458 %define bootstrap 0
85 pterjan 894459 %define build_gems 1
86 fwang 292558
87 blino 1152 Summary: Object Oriented Script Language
88     Name: ruby
89 shlomif 893775 Version: %{rubyver}
90 blino 1152 Release: %mkrel %rel
91 kamil 397518 License: Ruby or BSD
92 blino 1152 Group: Development/Ruby
93     BuildRequires: autoconf
94     BuildRequires: byacc
95 shlomif 291698 BuildRequires: doxygen
96 blino 1152 BuildRequires: ncurses-devel
97     BuildRequires: readline-devel
98 shlomif 893775 BuildRequires: tcl-devel
99 ovitters 648773 BuildRequires: tk-devel
100 fwang 276350 BuildRequires: db-devel
101 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
102 blino 1152 BuildRequires: openssl-devel
103     BuildRequires: zlib-devel
104 fwang 289987 BuildRequires: libffi-devel
105     BuildRequires: yaml-devel
106 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
107 tv 674762 Conflicts: ruby-devel < 2.0.0.p451-4.mga5
108 blino 1152 Obsoletes: ruby-rexml
109     Provides: ruby-rexml
110 pterjan 435566 # Couldn't get the standalone gem to work
111     Provides: rubygem(psych)
112 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
113     Provides: /usr/bin/ruby
114 fwang 293445 Provides: ruby(abi) = %rubyapi
115 shlomif 893775 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}.tar.xz
116 pterjan 435211 Source1: operating_system.rb
117 blino 1152 Source3: ruby.macros
118 tv 673709 # From FC:
119     # RPM dependency generators.
120     Source8: rubygems.attr
121     Source9: rubygems.req
122     Source10: rubygems.prov
123 shlomif 893775 URL: http://ruby-lang.org/
124 fwang 292558 %if !%bootstrap
125     Requires: rubygems >= %{rubygems_version}
126 fwang 293395 BuildRequires: ruby
127 fwang 292558 %endif
128 blino 1152
129 fwang 290007 # == FEDORA PATCHES BEGINS ==
130 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
131 shlomif 893775 Patch0: ruby-2.1.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
132     # Allows to override libruby.so placement. Hopefully we will be able to return
133     # to plain --with-rubyarchprefix.
134     # http://bugs.ruby-lang.org/issues/8973
135     Patch1: ruby-2.1.0-Enable-configuration-of-archlibdir.patch
136     # Force multiarch directories for i.86 to be always named i386. This solves
137     # some differencies in build between Fedora and RHEL.
138     Patch2: ruby-2.1.0-always-use-i386.patch
139 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
140 shlomif 893775 # http://bugs.ruby-lang.org/issues/5617
141     Patch4: ruby-2.1.0-custom-rubygems-location.patch
142 pterjan 435211 # Make mkmf verbose by default
143 shlomif 893775 Patch5: ruby-1.9.3-mkmf-verbose.patch
144     # Adds support for '--with-prelude' configuration option. This allows to built
145     # in support for ABRT.
146     # http://bugs.ruby-lang.org/issues/8566
147     Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
148     # Don't use SSLv3 for tests.
149     # https://bugs.ruby-lang.org/issues/10046
150     Patch9: ruby-2.3.0-fix-test-ctx-client-session-cb.patch
151     Patch10: ruby-2.3.0-Don-t-force-SSLv3-in-test-as-it-is-insecure-and-may-.patch
152     Patch11: ruby-2.3.0-Use-OP_NO_TICKET-when-testing-SSL-session-cache-call.patch
153 fwang 290007 # == FEDORA PATCHES ENDS ==
154 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
155     # to install gems into user dir
156 blino 894359 Patch20: ruby-2.3.0-Do-not-install-to-user-dir.patch
157 fwang 290007
158 shlomif 893775 # Patch22: ruby-2.0.0-tk2.6.patch
159 luigiwalser 795834
160 fwang 291591 %package -n %{libname}
161 fwang 291590 Summary: Libraries necessary to run Ruby
162     Group: Development/Ruby
163    
164 blino 1152 %package doc
165     Summary: Documentation for the powerful language Ruby
166     Group: Development/Ruby
167 fwang 202696 BuildArch: noarch
168 blino 1152
169     %package devel
170     Summary: Development file for the powerful language Ruby
171     Group: Development/Ruby
172 fwang 311925 Requires: %{name} = %{version}
173     Requires: %{libname} = %{version}
174 blino 1152
175     %package tk
176     Summary: Tk extension for the powerful language Ruby
177     Group: Development/Ruby
178 fwang 311925 Requires: %{name} = %{version}
179 blino 1152
180 fwang 291551 %package RubyGems
181     Summary: The Ruby standard for packaging ruby libraries
182     Group: Development/Ruby
183 fwang 291590 Version: %{rubygems_version}
184 fwang 291551 Requires: ruby(abi) = %{subver}
185 fwang 291590 Provides: gem = %{rubygems_version}
186     Provides: rubygems = %{rubygems_version}
187     Provides: ruby(rubygems) = %{rubygems_version}
188 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
189 fwang 291561 BuildArch: noarch
190 fwang 291551
191 shlomif 893775 %define rake_ver %{rake_version}
192 fwang 291551 %package rake
193     Summary: Simple ruby build program with capabilities similar to make
194     Group: Development/Ruby
195 shlomif 291767 Version: %{rake_ver}
196 fwang 291551 Requires: ruby(abi) = %{subver}
197 fwang 291561 BuildArch: noarch
198 fwang 291551
199 shlomif 893775 %define minitest_ver %{minitest_version}
200 fwang 291562 %package minitest
201 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
202 fwang 291562 Group: Development/Ruby
203 shlomif 291767 Version: %{minitest_ver}
204 fwang 291562 License: MIT
205 fwang 291590 Requires: ruby(abi) = %{subver}
206     Requires: ruby(rubygems) >= %{rubygems_version}
207 fwang 291562 BuildArch: noarch
208    
209 pterjan 894459 %define power_assert_ver %{power_assert_version}
210     %package power_assert
211     Summary: Power Assert for Ruby
212     Group: Development/Ruby
213     Version: %{power_assert_ver}
214     License: BSD
215     Requires: ruby(abi) = %{subver}
216     Requires: ruby(rubygems) >= %{rubygems_version}
217     BuildArch: noarch
218    
219 shlomif 893775 %define json_ver %{json_version}
220 fwang 291562 %package json
221     Summary: This is a JSON implementation as a Ruby extension in C
222     Group: Development/Ruby
223 shlomif 291767 Version: %{json_ver}
224 fwang 291562 License: Ruby or GPLv2
225 fwang 291590 Requires: ruby(abi) = %{subver}
226     Requires: ruby(rubygems) >= %{rubygems_version}
227 fwang 291562
228 shlomif 893775 %define rdoc_ver %{rdoc_version}
229 fwang 291562 %package rdoc
230     Summary: A tool to generate HTML and command-line documentation for Ruby projects
231     Group: Development/Ruby
232 shlomif 291767 Version: %{rdoc_ver}
233 fwang 291562 License: GPLv2 and Ruby and MIT
234 fwang 291590 Requires: ruby(abi) = %{subver}
235     Requires: ruby(rubygems) >= %{rubygems_version}
236     Requires: ruby(irb) = %{version}
237 shlomif 291767 Provides: rdoc = %{rdoc_ver}
238     Provides: ri = %{rdoc_ver}
239 fwang 291562 BuildArch: noarch
240    
241 fwang 291590 %package irb
242     Summary: The Interactive Ruby
243     Group: Development/Ruby
244     Provides: irb = %{version}-%{release}
245     Provides: ruby(irb) = %{version}-%{release}
246 fwang 313459 Conflicts: ruby < 1.9
247 fwang 313460 BuildArch: noarch
248 fwang 291590
249 shlomif 893775 %define bigdecimal_ver %{bigdecimal_version}
250 fwang 291590 %package bigdecimal
251     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
252     Group: Development/Ruby
253 pterjan 435211 Version: %{bigdecimal_ver}
254 fwang 291590 License: GPL+ or Artistic
255     Requires: ruby(abi) = %{subver}
256     Requires: ruby(rubygems) >= %{rubygems_version}
257    
258 shlomif 893775 %define io_console_ver %{io_console_version}
259 fwang 291590 %package io-console
260     Summary: IO/Console is a simple console utilizing library
261     Group: Development/Ruby
262 pterjan 435211 Version: %{io_console_ver}
263 fwang 291590 Requires: ruby(abi) = %{subver}
264     Requires: ruby(rubygems) >= %{rubygems_version}
265    
266 shlomif 893775 %define psych_ver %{psych_version}
267 pterjan 435211 %package psych
268     Summary: A libyaml wrapper for Ruby
269     Version: %{psych_ver}
270     Group: Development/Ruby
271     License: MIT
272     Requires: ruby(abi) = %{subver}
273     Requires: ruby(rubygems) >= %{rubygems_version}
274     Conflicts: ruby < 2.0.0
275    
276 shlomif 893775 %define test_unit_ver %{test_unit_version}
277 pterjan 435211 %package test-unit
278     Summary: test/unit compatible API testing framework
279     Version: %{psych_ver}
280     Group: Development/Ruby
281     License: MIT
282     Requires: ruby(abi) = %{subver}
283     Requires: ruby(rubygems) >= %{rubygems_version}
284     Conflicts: ruby < 2.0.0
285     BuildArch: noarch
286    
287 blino 1152 %description
288     Ruby is the interpreted scripting language for quick and
289     easy object-oriented programming. It has many features to
290     process text files and to do system management tasks (as in
291     Perl). It is simple, straight-forward, and extensible.
292    
293     %description doc
294     Ruby is the interpreted scripting language for quick and
295     easy object-oriented programming. It has many features to
296     process text files and to do system management tasks (as in
297     Perl). It is simple, straight-forward, and extensible.
298    
299     This package contains the Ruby's documentation
300    
301 fwang 291590 %description -n %{libname}
302     This package includes the libruby, necessary to run Ruby.
303    
304 blino 1152 %description devel
305     Ruby is the interpreted scripting language for quick and
306     easy object-oriented programming. It has many features to
307     process text files and to do system management tasks (as in
308     Perl). It is simple, straight-forward, and extensible.
309    
310     This package contains the Ruby's devel files.
311    
312     %description tk
313     Ruby is the interpreted scripting language for quick and
314     easy object-oriented programming. It has many features to
315     process text files and to do system management tasks (as in
316     Perl). It is simple, straight-forward, and extensible.
317    
318     This package contains the Tk extension for Ruby.
319    
320 fwang 291551 %description RubyGems
321     RubyGems is the Ruby standard for publishing and managing third party
322     libraries.
323    
324 fwang 291552 %description rake
325     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
326     specified in standard Ruby syntax.
327    
328 fwang 291562 %description rdoc
329     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
330     includes the 'rdoc' and 'ri' tools for generating and displaying online
331     documentation.
332    
333     %description json
334     This is a implementation of the JSON specification according to RFC 4627.
335     You can think of it as a low fat alternative to XML, if you want to store
336     data to disk or transmit it over a network rather than use a verbose
337     markup language.
338    
339     %description minitest
340     minitest/unit is a small and incredibly fast unit testing framework.
341    
342     minitest/spec is a functionally complete spec engine.
343    
344     minitest/benchmark is an awesome way to assert the performance of your
345     algorithms in a repeatable manner.
346    
347     minitest/mock by Steven Baker, is a beautifully tiny mock object
348     framework.
349    
350     minitest/pride shows pride in testing and adds coloring to your test
351     output.
352    
353 pterjan 894459 %description power_assert
354     Power Assert shows each value of variables and method calls in the expression.
355     It is useful for testing, providing which value wasn't correct when the
356     condition is not satisfied.
357    
358 fwang 291590 %description irb
359     The irb is acronym for Interactive Ruby. It evaluates ruby expression
360     from the terminal.
361    
362     %description bigdecimal
363     Ruby provides built-in support for arbitrary precision integer arithmetic.
364     For example:
365    
366     42**13 -> 1265437718438866624512
367    
368     BigDecimal provides similar support for very large or very accurate floating
369     point numbers. Decimal arithmetic is also useful for general calculation,
370     because it provides the correct answers people expect–whereas normal binary
371     floating point arithmetic often introduces subtle errors because of the
372     conversion between base 10 and base 2.
373    
374     %description io-console
375     IO/Console provides very simple and portable access to console. It doesn't
376     provide higher layer features, such like curses and readline.
377    
378 pterjan 435211 %description psych
379     Psych is a YAML parser and emitter. Psych leverages
380     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
381     capabilities. In addition to wrapping libyaml, Psych also knows how to
382     serialize and de-serialize most Ruby objects to and from the YAML format.
383    
384     %description test-unit
385     This library implements test/unit compatible API on minitest.
386     The test/unit means that test/unit which was bundled with Ruby 1.8.
387    
388 blino 1152 %prep
389 shlomif 893775 %setup -q -n ruby-%{rubyver}
390 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
391 shlomif 893775 %patch0 -p1
392     %patch1 -p1
393     %patch2 -p1
394     %patch4 -p1
395     %patch5 -p1
396     %patch6 -p1
397     %patch9
398     %patch10
399     %patch11
400     %patch20 -p1
401     # #patch22 -p1
402 blino 1152
403     %build
404 fwang 290038 autoconf
405 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
406 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
407 shlomif 893775 --enable-multiarch \
408     --with-rubylibprefix='%{ruby_libdir}' \
409     --with-archlibdir='%{_libdir}' \
410 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
411 shlomif 893775 --with-sitedir='%{ruby_sitelibdir}' \
412     --with-sitearchdir='%{ruby_sitearchdir}' \
413     --with-vendordir='%{ruby_vendorlibdir}' \
414     --with-vendorarchdir='%{ruby_vendorarchdir}' \
415     --with-rubyhdrdir='%{_includedir}' \
416     --with-rubyarchhdrdir='%{_includedir}' \
417 pterjan 435211 --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
418     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
419     --with-rubygemsdir='%{rubygems_dir}' \
420     --with-ruby-pc='%{name}.pc' \
421     --enable-multiarch \
422     --with-ruby-version=''
423 blino 1152 %make
424    
425     %install
426     %makeinstall_std install-doc
427    
428     install -d %buildroot%{_datadir}/emacs/site-lisp
429     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
430    
431     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
432     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
433     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
434     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
435     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
436     EOF
437    
438 shlomif 893775 # Install the rpm macros
439 blino 1152 mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
440     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
441 fwang 289961
442 tv 673709 # Install dependency generators.
443     mkdir -p %{buildroot}%{_rpmconfigdir}/fileattrs
444     install -m 644 %{SOURCE8} %{buildroot}%{_rpmconfigdir}/fileattrs
445     install -m 755 %{SOURCE9} %{buildroot}%{_rpmconfigdir}
446     install -m 755 %{SOURCE10} %{buildroot}%{_rpmconfigdir}
447    
448 pterjan 435211 # Install custom operating_system.rb
449     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
450     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
451    
452 pterjan 617250 # Version is empty if --with-ruby-version is specified.
453     # http://bugs.ruby-lang.org/issues/7807
454     sed -i 's/Version: .*/Version: %{rubyver}/' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
455    
456 pterjan 894459 rm -f %{buildroot}%{gems_dir}/cache/{minitest,power_assert,test-unit}-*.gem
457    
458 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
459     %if !%build_gems
460 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
461 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
462 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
463     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
464 pterjan 560987 rm -fr %{buildroot}%{gems_dir}/{gems,specifications}
465 fwang 311915 %if !%bootstrap
466 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
467 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
468     rm -fr %{buildroot}%{rubygems_dir}/rubygems
469 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
470     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
471 fwang 293412 %endif
472 fwang 311914 %endif
473 fwang 293412
474 blino 1152 %check
475     make test
476    
477 fwang 289961 %files
478 fwang 291551 %{_bindir}/erb
479     %{_bindir}/ruby
480 fwang 291560 %dir %{ruby_libdir}
481     %{ruby_libdir}/*.rb
482 fwang 291590 %exclude %{ruby_libdir}/irb.rb
483 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
484     %exclude %{ruby_libdir}/remote-tk.rb
485     %exclude %{ruby_libdir}/tcltk.rb
486     %exclude %{ruby_libdir}/tk.rb
487     %exclude %{ruby_libdir}/tkafter.rb
488     %exclude %{ruby_libdir}/tkbgerror.rb
489     %exclude %{ruby_libdir}/tkcanvas.rb
490     %exclude %{ruby_libdir}/tkclass.rb
491     %exclude %{ruby_libdir}/tkconsole.rb
492     %exclude %{ruby_libdir}/tkdialog.rb
493     %exclude %{ruby_libdir}/tkentry.rb
494     %exclude %{ruby_libdir}/tkfont.rb
495     %exclude %{ruby_libdir}/tkmacpkg.rb
496     %exclude %{ruby_libdir}/tkmenubar.rb
497     %exclude %{ruby_libdir}/tkmngfocus.rb
498     %exclude %{ruby_libdir}/tkpalette.rb
499     %exclude %{ruby_libdir}/tkscrollbox.rb
500     %exclude %{ruby_libdir}/tktext.rb
501     %exclude %{ruby_libdir}/tkvirtevent.rb
502     %exclude %{ruby_libdir}/tkwinpkg.rb
503     %{ruby_libdir}/cgi
504     %{ruby_libdir}/digest
505     %{ruby_libdir}/drb
506     %{ruby_libdir}/fiddle
507     %{ruby_libdir}/matrix
508     %{ruby_libdir}/net
509     %{ruby_libdir}/openssl
510     %{ruby_libdir}/optparse
511 pterjan 435566 %{ruby_libdir}/psych
512 fwang 291560 %{ruby_libdir}/racc
513     %{ruby_libdir}/rbconfig
514     %{ruby_libdir}/rexml
515     %{ruby_libdir}/rinda
516     %{ruby_libdir}/ripper
517     %{ruby_libdir}/rss
518     %{ruby_libdir}/shell
519 pterjan 435211 %{ruby_libdir}/syslog
520 shlomif 893775 %{ruby_libdir}/unicode_normalize/normalize.rb
521     %{ruby_libdir}/unicode_normalize/tables.rb
522     %{ruby_libdir}/unicode_normalize.rb
523 fwang 291560 %{ruby_libdir}/uri
524     %{ruby_libdir}/webrick
525     %{ruby_libdir}/xmlrpc
526     %{ruby_libdir}/yaml
527     %dir %{ruby_libarchdir}
528     %{ruby_libarchdir}/continuation.so
529     %{ruby_libarchdir}/coverage.so
530     %{ruby_libarchdir}/date_core.so
531     %{ruby_libarchdir}/dbm.so
532     %dir %{ruby_libarchdir}/digest
533     %{ruby_libarchdir}/digest.so
534     %{ruby_libarchdir}/digest/*.so
535     %dir %{ruby_libarchdir}/enc
536     %{ruby_libarchdir}/enc/*.so
537 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
538     %{ruby_libarchdir}/enc/trans/*.so
539 fwang 291560 %{ruby_libarchdir}/etc.so
540     %{ruby_libarchdir}/fcntl.so
541     %{ruby_libarchdir}/fiber.so
542     %{ruby_libarchdir}/fiddle.so
543     %{ruby_libarchdir}/gdbm.so
544     %dir %{ruby_libarchdir}/io
545     %{ruby_libarchdir}/io/nonblock.so
546     %{ruby_libarchdir}/io/wait.so
547     %dir %{ruby_libarchdir}/mathn
548 fwang 291562 %{ruby_libarchdir}/mathn/*.so
549 fwang 291560 %{ruby_libarchdir}/nkf.so
550     %{ruby_libarchdir}/objspace.so
551     %{ruby_libarchdir}/openssl.so
552 pterjan 435566 %{ruby_libarchdir}/psych.so
553 fwang 291560 %{ruby_libarchdir}/pathname.so
554     %{ruby_libarchdir}/pty.so
555     %dir %{ruby_libarchdir}/racc
556     %{ruby_libarchdir}/racc/*.so
557     %{ruby_libarchdir}/rbconfig.rb
558 shlomif 893775 %{ruby_libarchdir}/rbconfig/sizeof.so
559 fwang 291560 %{ruby_libarchdir}/readline.so
560     %{ruby_libarchdir}/ripper.so
561     %{ruby_libarchdir}/sdbm.so
562     %{ruby_libarchdir}/socket.so
563     %{ruby_libarchdir}/stringio.so
564     %{ruby_libarchdir}/strscan.so
565     %{ruby_libarchdir}/syslog.so
566 shlomif 893775 %{ruby_libarchdir}/thread.so
567 fwang 291560 %{ruby_libarchdir}/zlib.so
568 fwang 291551 %{_mandir}/man1/erb.1.*
569     %{_mandir}/man1/ruby.1.*
570 blino 1152 %{_datadir}/emacs/site-lisp/*
571     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
572     %{_sysconfdir}/rpm/macros.d/%{name}.macros
573 fwang 291560 %{_datadir}/ruby/site_ruby
574     %{_libdir}/ruby/site_ruby
575     %{_datadir}/ruby/vendor_ruby
576     %{_libdir}/ruby/vendor_ruby
577 fwang 311914 %if %bootstrap
578     %{_bindir}/gem
579 fwang 448831 %dir %{rubygems_dir}
580     %{rubygems_dir}/rbconfig
581     %{rubygems_dir}/rubygems
582     %{rubygems_dir}/rubygems.rb
583     %{rubygems_dir}/ubygems.rb
584 fwang 311914 %endif
585 tv 674762 %{_rpmconfigdir}/fileattrs/rubygems.attr
586     %{_rpmconfigdir}/rubygems.req
587     %{_rpmconfigdir}/rubygems.prov
588 blino 1152
589     %files doc
590     %{_datadir}/ri
591 pterjan 435211 %{_datadir}/doc/ruby
592 blino 1152
593 fwang 291590 %files -n %{libname}
594     %{_libdir}/libruby.so.%{subver}
595     %{_libdir}/libruby.so.%{rubyapi}
596    
597 blino 1152 %files devel
598 fwang 290003 %{_includedir}/*
599 blino 1152 %{_libdir}/libruby-static.a
600     %{_libdir}/libruby.so
601 fwang 290003 %{_libdir}/pkgconfig/*.pc
602 blino 1152
603     %files tk
604 fwang 291560 %{ruby_libarchdir}/tcltklib.so
605     %{ruby_libarchdir}/tkutil.so
606     %{ruby_libdir}/multi-tk.rb
607     %{ruby_libdir}/remote-tk.rb
608     %{ruby_libdir}/tcltk.rb
609     %{ruby_libdir}/tk.rb
610     %{ruby_libdir}/tkafter.rb
611     %{ruby_libdir}/tkbgerror.rb
612     %{ruby_libdir}/tkcanvas.rb
613     %{ruby_libdir}/tkclass.rb
614     %{ruby_libdir}/tkconsole.rb
615     %{ruby_libdir}/tkdialog.rb
616     %{ruby_libdir}/tkentry.rb
617     %{ruby_libdir}/tkfont.rb
618     %{ruby_libdir}/tkmacpkg.rb
619     %{ruby_libdir}/tkmenubar.rb
620     %{ruby_libdir}/tkmngfocus.rb
621     %{ruby_libdir}/tkpalette.rb
622     %{ruby_libdir}/tkscrollbox.rb
623     %{ruby_libdir}/tktext.rb
624     %{ruby_libdir}/tkvirtevent.rb
625     %{ruby_libdir}/tkwinpkg.rb
626     %{ruby_libdir}/tk
627     %{ruby_libdir}/tkextlib
628 fwang 291551
629 fwang 293412 %files irb
630     %{_bindir}/irb
631     %{ruby_libdir}/irb.rb
632     %{ruby_libdir}/irb
633     %{_mandir}/man1/irb.1*
634    
635     %if %build_gems
636 fwang 291551 %files RubyGems
637     %{_bindir}/gem
638     %dir %{rubygems_dir}
639     %{rubygems_dir}/rbconfig
640     %{rubygems_dir}/rubygems
641     %{rubygems_dir}/rubygems.rb
642     %{rubygems_dir}/ubygems.rb
643    
644 fwang 291562 %files minitest
645 pterjan 894459 %{gems_dir}/gems/minitest-%{minitest_version}
646     %{gems_dir}/specifications/minitest-%{minitest_version}.gemspec
647 fwang 291562
648 pterjan 894459 %files power_assert
649     %{gems_dir}/gems/power_assert-%{power_assert_version}
650     %{gems_dir}/specifications/power_assert-%{power_assert_version}.gemspec
651    
652 fwang 291551 %files rake
653     %{_bindir}/rake
654     %{_mandir}/man1/rake.1.*
655 fwang 291562 %{ruby_libdir}/rake
656 pterjan 894459 %{gems_dir}/gems/rake-%{rake_version}
657     %{gems_dir}/specifications/default/rake-%{rake_version}.gemspec
658 fwang 291562
659     %files rdoc
660     %{_bindir}/rdoc
661     %{_bindir}/ri
662     %{ruby_libdir}/rdoc
663 pterjan 894459 %{gems_dir}/gems/rdoc-%{rdoc_version}
664     %{gems_dir}/specifications/default/rdoc-%{rdoc_version}.gemspec
665 fwang 291562 %{_mandir}/man1/ri.1.*
666    
667     %files json
668     %dir %{ruby_libarchdir}/json
669     %dir %{ruby_libarchdir}/json/ext
670     %{ruby_libarchdir}/json/ext/*.so
671     %{ruby_libdir}/json
672 pterjan 894459 %{gems_dir}/specifications/default/json-%{json_version}.gemspec
673 fwang 291590
674     %files bigdecimal
675     %{ruby_libdir}/bigdecimal
676     %{ruby_libarchdir}/bigdecimal.so
677 pterjan 894459 %{gems_dir}/specifications/default/bigdecimal-%{bigdecimal_version}.gemspec
678 fwang 291590
679     %files io-console
680     %{ruby_libdir}/io
681     %{ruby_libarchdir}/io/console.so
682 pterjan 894459 %{gems_dir}/specifications/default/io-console-%{io_console_version}.gemspec
683 pterjan 435211
684     %files psych
685     %{ruby_libdir}/psych
686     %{ruby_libarchdir}/psych.so
687 pterjan 894459 %{gems_dir}/specifications/default/psych-%{psych_version}.gemspec
688 pterjan 435211
689     %files test-unit
690 pterjan 560987 %{gems_dir}/gems/test-unit-*
691 pterjan 894459 %{gems_dir}/specifications/test-unit-%{test_unit_version}.gemspec
692 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30