/[packages]/cauldron/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /cauldron/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 894484 - (hide annotations) (download)
Fri Oct 23 12:53:36 2015 UTC (8 years, 6 months ago) by pterjan
File size: 21912 byte(s)
Force provides
1 shlomif 893775 # Taken from the fedora ruby-2.2.3 .spec. Thanks!
2 blino 1152
3 shlomif 893775 %global major_version 2
4     %global minor_version 2
5     %global teeny_version 3
6     %global major_minor_version %{major_version}.%{minor_version}
7    
8     %global ruby_version %{major_minor_version}.%{teeny_version}
9     %global ruby_release %{ruby_version}
10    
11     # Specify the named version. It has precedense to revision.
12     #%%global milestone rc1
13    
14     # Keep the revision enabled for pre-releases from SVN.
15     #%%global revision 48936
16    
17     %global ruby_archive %{name}-%{ruby_version}
18    
19     # If revision and milestone are removed/commented out, the official release build is expected.
20     %if 0%{?milestone:1}%{?revision:1} != 0
21     %global development_release %{?milestone}%{?!milestone:%{?revision:r%{revision}}}
22     %global ruby_archive %{ruby_archive}-%{?milestone}%{?!milestone:%{?revision:r%{revision}}}
23     %endif
24    
25    
26 pterjan 894469 %global rel 6
27 pterjan 894460 %{!?release_string:%global release_string %mkrel %{?development_release:0.}%{rel}%{?development_release:.%{development_release}}}
28 shlomif 893775
29     %global rubygems_version 2.4.5.1
30    
31     # The RubyGems library has to stay out of Ruby directory three, since the
32     # RubyGems should be share by all Ruby implementations.
33     %global rubygems_dir %{_datadir}/rubygems
34    
35     # TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM.
36     # http://redmine.ruby-lang.org/issues/5313
37     %global irb_version %{ruby_version}
38    
39     %global bigdecimal_version 1.2.6
40     %global io_console_version 0.4.3
41     %global json_version 1.8.1
42     %global minitest_version 5.4.3
43     %global power_assert_version 0.2.2
44     %global psych_version 2.0.8
45     %global rake_version 10.4.2
46     %global rdoc_version 4.2.0
47     %global test_unit_version 3.0.8
48    
49     # Might not be needed in the future, if we are lucky enough.
50     # https://bugzilla.redhat.com/show_bug.cgi?id=888262
51     %global tapset_root %{_datadir}/systemtap
52     %global tapset_dir %{tapset_root}/tapset
53     %global tapset_libdir %(echo %{_libdir} | sed 's/64//')*
54    
55     %global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/;s/sparcv./sparc/')
56    
57     %global with_rubypick 1
58    
59     # Additional defines by Mageia.
60    
61     %define subver %{major_minor_version}
62     %define rubyapi %{subver}.0
63     %define rubyver %{ruby_version}
64    
65 fwang 291590 %define libname %mklibname ruby %{subver}
66    
67 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
68     %define ruby_libarchdir %{_libdir}/%{name}
69    
70 fwang 290007 # This is the local lib/arch and should not be used for packaging.
71 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
72     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
73 fwang 290007
74     # This is the general location for libs/archs compatible with all
75     # or most of the Ruby versions available in the Fedora repositories.
76 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
77 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
78 fwang 290007
79 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
80     # RubyGems should be shared by all Ruby implementations.
81 pterjan 894459 %define gems_dir %{_datadir}/gems
82 fwang 290007
83 pterjan 894460 %define bootstrap 1
84 pterjan 894459 %define build_gems 1
85 fwang 292558
86 blino 1152 Summary: Object Oriented Script Language
87     Name: ruby
88 shlomif 893775 Version: %{rubyver}
89 pterjan 894460 Release: %release_string
90 kamil 397518 License: Ruby or BSD
91 blino 1152 Group: Development/Ruby
92     BuildRequires: autoconf
93     BuildRequires: byacc
94 shlomif 291698 BuildRequires: doxygen
95 blino 1152 BuildRequires: ncurses-devel
96     BuildRequires: readline-devel
97 shlomif 893775 BuildRequires: tcl-devel
98 ovitters 648773 BuildRequires: tk-devel
99 fwang 276350 BuildRequires: db-devel
100 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
101 blino 1152 BuildRequires: openssl-devel
102     BuildRequires: zlib-devel
103 fwang 289987 BuildRequires: libffi-devel
104     BuildRequires: yaml-devel
105 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
106 tv 674762 Conflicts: ruby-devel < 2.0.0.p451-4.mga5
107 blino 1152 Obsoletes: ruby-rexml
108     Provides: ruby-rexml
109 pterjan 435566 # Couldn't get the standalone gem to work
110     Provides: rubygem(psych)
111 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
112     Provides: /usr/bin/ruby
113 pterjan 894480 Provides: ruby(abi) = %subver
114 shlomif 893775 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}.tar.xz
115 pterjan 435211 Source1: operating_system.rb
116 blino 1152 Source3: ruby.macros
117 tv 673709 # From FC:
118     # RPM dependency generators.
119     Source8: rubygems.attr
120     Source9: rubygems.req
121     Source10: rubygems.prov
122 shlomif 893775 URL: http://ruby-lang.org/
123 fwang 292558 %if !%bootstrap
124     Requires: rubygems >= %{rubygems_version}
125 fwang 293395 BuildRequires: ruby
126 fwang 292558 %endif
127 blino 1152
128 fwang 290007 # == FEDORA PATCHES BEGINS ==
129 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
130 shlomif 893775 Patch0: ruby-2.1.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
131     # Allows to override libruby.so placement. Hopefully we will be able to return
132     # to plain --with-rubyarchprefix.
133     # http://bugs.ruby-lang.org/issues/8973
134     Patch1: ruby-2.1.0-Enable-configuration-of-archlibdir.patch
135     # Force multiarch directories for i.86 to be always named i386. This solves
136     # some differencies in build between Fedora and RHEL.
137     Patch2: ruby-2.1.0-always-use-i386.patch
138 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
139 shlomif 893775 # http://bugs.ruby-lang.org/issues/5617
140     Patch4: ruby-2.1.0-custom-rubygems-location.patch
141 pterjan 435211 # Make mkmf verbose by default
142 shlomif 893775 Patch5: ruby-1.9.3-mkmf-verbose.patch
143     # Adds support for '--with-prelude' configuration option. This allows to built
144     # in support for ABRT.
145     # http://bugs.ruby-lang.org/issues/8566
146     Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
147     # Don't use SSLv3 for tests.
148     # https://bugs.ruby-lang.org/issues/10046
149     Patch9: ruby-2.3.0-fix-test-ctx-client-session-cb.patch
150     Patch10: ruby-2.3.0-Don-t-force-SSLv3-in-test-as-it-is-insecure-and-may-.patch
151     Patch11: ruby-2.3.0-Use-OP_NO_TICKET-when-testing-SSL-session-cache-call.patch
152 fwang 290007 # == FEDORA PATCHES ENDS ==
153 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
154     # to install gems into user dir
155 blino 894359 Patch20: ruby-2.3.0-Do-not-install-to-user-dir.patch
156 fwang 290007
157 shlomif 893775 # Patch22: ruby-2.0.0-tk2.6.patch
158 luigiwalser 795834
159 fwang 291591 %package -n %{libname}
160 fwang 291590 Summary: Libraries necessary to run Ruby
161     Group: Development/Ruby
162    
163 blino 1152 %package doc
164     Summary: Documentation for the powerful language Ruby
165     Group: Development/Ruby
166 fwang 202696 BuildArch: noarch
167 blino 1152
168     %package devel
169     Summary: Development file for the powerful language Ruby
170     Group: Development/Ruby
171 fwang 311925 Requires: %{name} = %{version}
172     Requires: %{libname} = %{version}
173 blino 1152
174     %package tk
175     Summary: Tk extension for the powerful language Ruby
176     Group: Development/Ruby
177 fwang 311925 Requires: %{name} = %{version}
178 blino 1152
179 fwang 291551 %package RubyGems
180     Summary: The Ruby standard for packaging ruby libraries
181     Group: Development/Ruby
182 fwang 291590 Version: %{rubygems_version}
183 fwang 291551 Requires: ruby(abi) = %{subver}
184 fwang 291590 Provides: gem = %{rubygems_version}
185     Provides: rubygems = %{rubygems_version}
186     Provides: ruby(rubygems) = %{rubygems_version}
187 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
188 fwang 291561 BuildArch: noarch
189 fwang 291551
190 shlomif 893775 %define rake_ver %{rake_version}
191 fwang 291551 %package rake
192     Summary: Simple ruby build program with capabilities similar to make
193     Group: Development/Ruby
194 shlomif 291767 Version: %{rake_ver}
195 pterjan 894484 Provides: rubygem(rake) = %{rake_ver}
196 fwang 291551 Requires: ruby(abi) = %{subver}
197 fwang 291561 BuildArch: noarch
198 fwang 291551
199 shlomif 893775 %define minitest_ver %{minitest_version}
200 fwang 291562 %package minitest
201 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
202 fwang 291562 Group: Development/Ruby
203 shlomif 291767 Version: %{minitest_ver}
204 fwang 291562 License: MIT
205 pterjan 894484 Provides: rubygem(minitest) = %{minitest_ver}
206 fwang 291590 Requires: ruby(abi) = %{subver}
207     Requires: ruby(rubygems) >= %{rubygems_version}
208 fwang 291562 BuildArch: noarch
209    
210 pterjan 894459 %define power_assert_ver %{power_assert_version}
211     %package power_assert
212     Summary: Power Assert for Ruby
213     Group: Development/Ruby
214     Version: %{power_assert_ver}
215     License: BSD
216 pterjan 894484 Provides: rubygem(power_assert) = %{power_assert_ver}
217 pterjan 894459 Requires: ruby(abi) = %{subver}
218     Requires: ruby(rubygems) >= %{rubygems_version}
219     BuildArch: noarch
220    
221 shlomif 893775 %define json_ver %{json_version}
222 fwang 291562 %package json
223     Summary: This is a JSON implementation as a Ruby extension in C
224     Group: Development/Ruby
225 shlomif 291767 Version: %{json_ver}
226 fwang 291562 License: Ruby or GPLv2
227 pterjan 894484 Provides: rubygem(json) = %{json_ver}
228 fwang 291590 Requires: ruby(abi) = %{subver}
229     Requires: ruby(rubygems) >= %{rubygems_version}
230 fwang 291562
231 shlomif 893775 %define rdoc_ver %{rdoc_version}
232 fwang 291562 %package rdoc
233     Summary: A tool to generate HTML and command-line documentation for Ruby projects
234     Group: Development/Ruby
235 shlomif 291767 Version: %{rdoc_ver}
236 fwang 291562 License: GPLv2 and Ruby and MIT
237 pterjan 894484 Provides: rubygem(rdoc) = %{rdoc_ver}
238 fwang 291590 Requires: ruby(abi) = %{subver}
239     Requires: ruby(rubygems) >= %{rubygems_version}
240     Requires: ruby(irb) = %{version}
241 shlomif 291767 Provides: rdoc = %{rdoc_ver}
242     Provides: ri = %{rdoc_ver}
243 fwang 291562 BuildArch: noarch
244    
245 fwang 291590 %package irb
246     Summary: The Interactive Ruby
247     Group: Development/Ruby
248     Provides: irb = %{version}-%{release}
249     Provides: ruby(irb) = %{version}-%{release}
250 fwang 313459 Conflicts: ruby < 1.9
251 fwang 313460 BuildArch: noarch
252 fwang 291590
253 shlomif 893775 %define bigdecimal_ver %{bigdecimal_version}
254 fwang 291590 %package bigdecimal
255     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
256     Group: Development/Ruby
257 pterjan 435211 Version: %{bigdecimal_ver}
258 fwang 291590 License: GPL+ or Artistic
259 pterjan 894484 Provides: rubygem(bigdecimal) = %{bigdecimal_ver}
260 fwang 291590 Requires: ruby(abi) = %{subver}
261     Requires: ruby(rubygems) >= %{rubygems_version}
262    
263 shlomif 893775 %define io_console_ver %{io_console_version}
264 fwang 291590 %package io-console
265     Summary: IO/Console is a simple console utilizing library
266     Group: Development/Ruby
267 pterjan 435211 Version: %{io_console_ver}
268 pterjan 894484 Provides: rubygem(io-console) = %{io_console_ver}
269 fwang 291590 Requires: ruby(abi) = %{subver}
270     Requires: ruby(rubygems) >= %{rubygems_version}
271    
272 shlomif 893775 %define psych_ver %{psych_version}
273 pterjan 435211 %package psych
274     Summary: A libyaml wrapper for Ruby
275     Version: %{psych_ver}
276     Group: Development/Ruby
277     License: MIT
278 pterjan 894484 Provides: rubygem(psych) = %{psych_ver}
279 pterjan 435211 Requires: ruby(abi) = %{subver}
280     Requires: ruby(rubygems) >= %{rubygems_version}
281     Conflicts: ruby < 2.0.0
282    
283 shlomif 893775 %define test_unit_ver %{test_unit_version}
284 pterjan 435211 %package test-unit
285     Summary: test/unit compatible API testing framework
286     Version: %{psych_ver}
287     Group: Development/Ruby
288     License: MIT
289 pterjan 894484 Provides: rubygem(test-unit) = %{test_unit_ver}
290 pterjan 435211 Requires: ruby(abi) = %{subver}
291     Requires: ruby(rubygems) >= %{rubygems_version}
292     Conflicts: ruby < 2.0.0
293     BuildArch: noarch
294    
295 blino 1152 %description
296     Ruby is the interpreted scripting language for quick and
297     easy object-oriented programming. It has many features to
298     process text files and to do system management tasks (as in
299     Perl). It is simple, straight-forward, and extensible.
300    
301     %description doc
302     Ruby is the interpreted scripting language for quick and
303     easy object-oriented programming. It has many features to
304     process text files and to do system management tasks (as in
305     Perl). It is simple, straight-forward, and extensible.
306    
307     This package contains the Ruby's documentation
308    
309 fwang 291590 %description -n %{libname}
310     This package includes the libruby, necessary to run Ruby.
311    
312 blino 1152 %description devel
313     Ruby is the interpreted scripting language for quick and
314     easy object-oriented programming. It has many features to
315     process text files and to do system management tasks (as in
316     Perl). It is simple, straight-forward, and extensible.
317    
318     This package contains the Ruby's devel files.
319    
320     %description tk
321     Ruby is the interpreted scripting language for quick and
322     easy object-oriented programming. It has many features to
323     process text files and to do system management tasks (as in
324     Perl). It is simple, straight-forward, and extensible.
325    
326     This package contains the Tk extension for Ruby.
327    
328 fwang 291551 %description RubyGems
329     RubyGems is the Ruby standard for publishing and managing third party
330     libraries.
331    
332 fwang 291552 %description rake
333     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
334     specified in standard Ruby syntax.
335    
336 fwang 291562 %description rdoc
337     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
338     includes the 'rdoc' and 'ri' tools for generating and displaying online
339     documentation.
340    
341     %description json
342     This is a implementation of the JSON specification according to RFC 4627.
343     You can think of it as a low fat alternative to XML, if you want to store
344     data to disk or transmit it over a network rather than use a verbose
345     markup language.
346    
347     %description minitest
348     minitest/unit is a small and incredibly fast unit testing framework.
349    
350     minitest/spec is a functionally complete spec engine.
351    
352     minitest/benchmark is an awesome way to assert the performance of your
353     algorithms in a repeatable manner.
354    
355     minitest/mock by Steven Baker, is a beautifully tiny mock object
356     framework.
357    
358     minitest/pride shows pride in testing and adds coloring to your test
359     output.
360    
361 pterjan 894459 %description power_assert
362     Power Assert shows each value of variables and method calls in the expression.
363     It is useful for testing, providing which value wasn't correct when the
364     condition is not satisfied.
365    
366 fwang 291590 %description irb
367     The irb is acronym for Interactive Ruby. It evaluates ruby expression
368     from the terminal.
369    
370     %description bigdecimal
371     Ruby provides built-in support for arbitrary precision integer arithmetic.
372     For example:
373    
374     42**13 -> 1265437718438866624512
375    
376     BigDecimal provides similar support for very large or very accurate floating
377     point numbers. Decimal arithmetic is also useful for general calculation,
378     because it provides the correct answers people expect–whereas normal binary
379     floating point arithmetic often introduces subtle errors because of the
380     conversion between base 10 and base 2.
381    
382     %description io-console
383     IO/Console provides very simple and portable access to console. It doesn't
384     provide higher layer features, such like curses and readline.
385    
386 pterjan 435211 %description psych
387     Psych is a YAML parser and emitter. Psych leverages
388     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
389     capabilities. In addition to wrapping libyaml, Psych also knows how to
390     serialize and de-serialize most Ruby objects to and from the YAML format.
391    
392     %description test-unit
393     This library implements test/unit compatible API on minitest.
394     The test/unit means that test/unit which was bundled with Ruby 1.8.
395    
396 blino 1152 %prep
397 shlomif 893775 %setup -q -n ruby-%{rubyver}
398 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
399 shlomif 893775 %patch0 -p1
400     %patch1 -p1
401     %patch2 -p1
402     %patch4 -p1
403     %patch5 -p1
404     %patch6 -p1
405     %patch9
406     %patch10
407     %patch11
408     %patch20 -p1
409     # #patch22 -p1
410 blino 1152
411     %build
412 fwang 290038 autoconf
413 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
414 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
415 shlomif 893775 --enable-multiarch \
416     --with-rubylibprefix='%{ruby_libdir}' \
417     --with-archlibdir='%{_libdir}' \
418 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
419 shlomif 893775 --with-sitedir='%{ruby_sitelibdir}' \
420     --with-sitearchdir='%{ruby_sitearchdir}' \
421     --with-vendordir='%{ruby_vendorlibdir}' \
422     --with-vendorarchdir='%{ruby_vendorarchdir}' \
423     --with-rubyhdrdir='%{_includedir}' \
424     --with-rubyarchhdrdir='%{_includedir}' \
425 pterjan 435211 --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
426     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
427     --with-rubygemsdir='%{rubygems_dir}' \
428     --with-ruby-pc='%{name}.pc' \
429     --enable-multiarch \
430     --with-ruby-version=''
431 blino 1152 %make
432    
433     %install
434     %makeinstall_std install-doc
435    
436     install -d %buildroot%{_datadir}/emacs/site-lisp
437     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
438    
439     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
440     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
441     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
442     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
443     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
444     EOF
445    
446 shlomif 893775 # Install the rpm macros
447 blino 1152 mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
448     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
449 fwang 289961
450 tv 673709 # Install dependency generators.
451     mkdir -p %{buildroot}%{_rpmconfigdir}/fileattrs
452     install -m 644 %{SOURCE8} %{buildroot}%{_rpmconfigdir}/fileattrs
453     install -m 755 %{SOURCE9} %{buildroot}%{_rpmconfigdir}
454     install -m 755 %{SOURCE10} %{buildroot}%{_rpmconfigdir}
455    
456 pterjan 435211 # Install custom operating_system.rb
457     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
458     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
459    
460 pterjan 617250 # Version is empty if --with-ruby-version is specified.
461     # http://bugs.ruby-lang.org/issues/7807
462     sed -i 's/Version: .*/Version: %{rubyver}/' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
463    
464 pterjan 894459 rm -f %{buildroot}%{gems_dir}/cache/{minitest,power_assert,test-unit}-*.gem
465    
466 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
467     %if !%build_gems
468 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
469 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
470 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
471     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
472 pterjan 560987 rm -fr %{buildroot}%{gems_dir}/{gems,specifications}
473 fwang 311915 %if !%bootstrap
474 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
475 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
476     rm -fr %{buildroot}%{rubygems_dir}/rubygems
477 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
478     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
479 fwang 293412 %endif
480 fwang 311914 %endif
481 fwang 293412
482 blino 1152 %check
483     make test
484    
485 fwang 289961 %files
486 fwang 291551 %{_bindir}/erb
487     %{_bindir}/ruby
488 fwang 291560 %dir %{ruby_libdir}
489     %{ruby_libdir}/*.rb
490 fwang 291590 %exclude %{ruby_libdir}/irb.rb
491 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
492     %exclude %{ruby_libdir}/remote-tk.rb
493     %exclude %{ruby_libdir}/tcltk.rb
494     %exclude %{ruby_libdir}/tk.rb
495     %exclude %{ruby_libdir}/tkafter.rb
496     %exclude %{ruby_libdir}/tkbgerror.rb
497     %exclude %{ruby_libdir}/tkcanvas.rb
498     %exclude %{ruby_libdir}/tkclass.rb
499     %exclude %{ruby_libdir}/tkconsole.rb
500     %exclude %{ruby_libdir}/tkdialog.rb
501     %exclude %{ruby_libdir}/tkentry.rb
502     %exclude %{ruby_libdir}/tkfont.rb
503     %exclude %{ruby_libdir}/tkmacpkg.rb
504     %exclude %{ruby_libdir}/tkmenubar.rb
505     %exclude %{ruby_libdir}/tkmngfocus.rb
506     %exclude %{ruby_libdir}/tkpalette.rb
507     %exclude %{ruby_libdir}/tkscrollbox.rb
508     %exclude %{ruby_libdir}/tktext.rb
509     %exclude %{ruby_libdir}/tkvirtevent.rb
510     %exclude %{ruby_libdir}/tkwinpkg.rb
511     %{ruby_libdir}/cgi
512     %{ruby_libdir}/digest
513     %{ruby_libdir}/drb
514     %{ruby_libdir}/fiddle
515     %{ruby_libdir}/matrix
516     %{ruby_libdir}/net
517     %{ruby_libdir}/openssl
518     %{ruby_libdir}/optparse
519 pterjan 435566 %{ruby_libdir}/psych
520 fwang 291560 %{ruby_libdir}/racc
521     %{ruby_libdir}/rbconfig
522     %{ruby_libdir}/rexml
523     %{ruby_libdir}/rinda
524     %{ruby_libdir}/ripper
525     %{ruby_libdir}/rss
526     %{ruby_libdir}/shell
527 pterjan 435211 %{ruby_libdir}/syslog
528 shlomif 893775 %{ruby_libdir}/unicode_normalize/normalize.rb
529     %{ruby_libdir}/unicode_normalize/tables.rb
530     %{ruby_libdir}/unicode_normalize.rb
531 fwang 291560 %{ruby_libdir}/uri
532     %{ruby_libdir}/webrick
533     %{ruby_libdir}/xmlrpc
534     %{ruby_libdir}/yaml
535     %dir %{ruby_libarchdir}
536     %{ruby_libarchdir}/continuation.so
537     %{ruby_libarchdir}/coverage.so
538     %{ruby_libarchdir}/date_core.so
539     %{ruby_libarchdir}/dbm.so
540     %dir %{ruby_libarchdir}/digest
541     %{ruby_libarchdir}/digest.so
542     %{ruby_libarchdir}/digest/*.so
543     %dir %{ruby_libarchdir}/enc
544     %{ruby_libarchdir}/enc/*.so
545 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
546     %{ruby_libarchdir}/enc/trans/*.so
547 fwang 291560 %{ruby_libarchdir}/etc.so
548     %{ruby_libarchdir}/fcntl.so
549     %{ruby_libarchdir}/fiber.so
550     %{ruby_libarchdir}/fiddle.so
551     %{ruby_libarchdir}/gdbm.so
552     %dir %{ruby_libarchdir}/io
553     %{ruby_libarchdir}/io/nonblock.so
554     %{ruby_libarchdir}/io/wait.so
555     %dir %{ruby_libarchdir}/mathn
556 fwang 291562 %{ruby_libarchdir}/mathn/*.so
557 fwang 291560 %{ruby_libarchdir}/nkf.so
558     %{ruby_libarchdir}/objspace.so
559     %{ruby_libarchdir}/openssl.so
560 pterjan 435566 %{ruby_libarchdir}/psych.so
561 fwang 291560 %{ruby_libarchdir}/pathname.so
562     %{ruby_libarchdir}/pty.so
563     %dir %{ruby_libarchdir}/racc
564     %{ruby_libarchdir}/racc/*.so
565     %{ruby_libarchdir}/rbconfig.rb
566 shlomif 893775 %{ruby_libarchdir}/rbconfig/sizeof.so
567 fwang 291560 %{ruby_libarchdir}/readline.so
568     %{ruby_libarchdir}/ripper.so
569     %{ruby_libarchdir}/sdbm.so
570     %{ruby_libarchdir}/socket.so
571     %{ruby_libarchdir}/stringio.so
572     %{ruby_libarchdir}/strscan.so
573     %{ruby_libarchdir}/syslog.so
574 shlomif 893775 %{ruby_libarchdir}/thread.so
575 fwang 291560 %{ruby_libarchdir}/zlib.so
576 fwang 291551 %{_mandir}/man1/erb.1.*
577     %{_mandir}/man1/ruby.1.*
578 blino 1152 %{_datadir}/emacs/site-lisp/*
579     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
580     %{_sysconfdir}/rpm/macros.d/%{name}.macros
581 fwang 291560 %{_datadir}/ruby/site_ruby
582     %{_libdir}/ruby/site_ruby
583     %{_datadir}/ruby/vendor_ruby
584     %{_libdir}/ruby/vendor_ruby
585 fwang 311914 %if %bootstrap
586     %{_bindir}/gem
587 fwang 448831 %dir %{rubygems_dir}
588     %{rubygems_dir}/rbconfig
589     %{rubygems_dir}/rubygems
590     %{rubygems_dir}/rubygems.rb
591     %{rubygems_dir}/ubygems.rb
592 fwang 311914 %endif
593 tv 674762 %{_rpmconfigdir}/fileattrs/rubygems.attr
594     %{_rpmconfigdir}/rubygems.req
595     %{_rpmconfigdir}/rubygems.prov
596 blino 1152
597     %files doc
598     %{_datadir}/ri
599 pterjan 435211 %{_datadir}/doc/ruby
600 blino 1152
601 fwang 291590 %files -n %{libname}
602     %{_libdir}/libruby.so.%{subver}
603     %{_libdir}/libruby.so.%{rubyapi}
604    
605 blino 1152 %files devel
606 fwang 290003 %{_includedir}/*
607 blino 1152 %{_libdir}/libruby-static.a
608     %{_libdir}/libruby.so
609 fwang 290003 %{_libdir}/pkgconfig/*.pc
610 blino 1152
611     %files tk
612 fwang 291560 %{ruby_libarchdir}/tcltklib.so
613     %{ruby_libarchdir}/tkutil.so
614     %{ruby_libdir}/multi-tk.rb
615     %{ruby_libdir}/remote-tk.rb
616     %{ruby_libdir}/tcltk.rb
617     %{ruby_libdir}/tk.rb
618     %{ruby_libdir}/tkafter.rb
619     %{ruby_libdir}/tkbgerror.rb
620     %{ruby_libdir}/tkcanvas.rb
621     %{ruby_libdir}/tkclass.rb
622     %{ruby_libdir}/tkconsole.rb
623     %{ruby_libdir}/tkdialog.rb
624     %{ruby_libdir}/tkentry.rb
625     %{ruby_libdir}/tkfont.rb
626     %{ruby_libdir}/tkmacpkg.rb
627     %{ruby_libdir}/tkmenubar.rb
628     %{ruby_libdir}/tkmngfocus.rb
629     %{ruby_libdir}/tkpalette.rb
630     %{ruby_libdir}/tkscrollbox.rb
631     %{ruby_libdir}/tktext.rb
632     %{ruby_libdir}/tkvirtevent.rb
633     %{ruby_libdir}/tkwinpkg.rb
634     %{ruby_libdir}/tk
635     %{ruby_libdir}/tkextlib
636 fwang 291551
637 fwang 293412 %files irb
638     %{_bindir}/irb
639     %{ruby_libdir}/irb.rb
640     %{ruby_libdir}/irb
641     %{_mandir}/man1/irb.1*
642    
643     %if %build_gems
644 fwang 291551 %files RubyGems
645     %{_bindir}/gem
646     %dir %{rubygems_dir}
647     %{rubygems_dir}/rbconfig
648     %{rubygems_dir}/rubygems
649     %{rubygems_dir}/rubygems.rb
650     %{rubygems_dir}/ubygems.rb
651    
652 fwang 291562 %files minitest
653 pterjan 894459 %{gems_dir}/gems/minitest-%{minitest_version}
654     %{gems_dir}/specifications/minitest-%{minitest_version}.gemspec
655 fwang 291562
656 pterjan 894459 %files power_assert
657     %{gems_dir}/gems/power_assert-%{power_assert_version}
658     %{gems_dir}/specifications/power_assert-%{power_assert_version}.gemspec
659    
660 fwang 291551 %files rake
661     %{_bindir}/rake
662     %{_mandir}/man1/rake.1.*
663 fwang 291562 %{ruby_libdir}/rake
664 pterjan 894459 %{gems_dir}/gems/rake-%{rake_version}
665     %{gems_dir}/specifications/default/rake-%{rake_version}.gemspec
666 fwang 291562
667     %files rdoc
668     %{_bindir}/rdoc
669     %{_bindir}/ri
670     %{ruby_libdir}/rdoc
671 pterjan 894459 %{gems_dir}/gems/rdoc-%{rdoc_version}
672     %{gems_dir}/specifications/default/rdoc-%{rdoc_version}.gemspec
673 fwang 291562 %{_mandir}/man1/ri.1.*
674    
675     %files json
676     %dir %{ruby_libarchdir}/json
677     %dir %{ruby_libarchdir}/json/ext
678     %{ruby_libarchdir}/json/ext/*.so
679     %{ruby_libdir}/json
680 pterjan 894459 %{gems_dir}/specifications/default/json-%{json_version}.gemspec
681 fwang 291590
682     %files bigdecimal
683     %{ruby_libdir}/bigdecimal
684     %{ruby_libarchdir}/bigdecimal.so
685 pterjan 894459 %{gems_dir}/specifications/default/bigdecimal-%{bigdecimal_version}.gemspec
686 fwang 291590
687     %files io-console
688     %{ruby_libdir}/io
689     %{ruby_libarchdir}/io/console.so
690 pterjan 894459 %{gems_dir}/specifications/default/io-console-%{io_console_version}.gemspec
691 pterjan 435211
692     %files psych
693     %{ruby_libdir}/psych
694     %{ruby_libarchdir}/psych.so
695 pterjan 894459 %{gems_dir}/specifications/default/psych-%{psych_version}.gemspec
696 pterjan 435211
697     %files test-unit
698 pterjan 560987 %{gems_dir}/gems/test-unit-*
699 pterjan 894459 %{gems_dir}/specifications/test-unit-%{test_unit_version}.gemspec
700 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30