/[packages]/cauldron/ruby/pristine/SPECS/ruby.spec
ViewVC logotype

Annotation of /cauldron/ruby/pristine/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 289970 - (hide annotations) (download)
Sat Sep 8 08:44:55 2012 UTC (11 years, 7 months ago) by fwang
Original Path: cauldron/ruby/current/SPECS/ruby.spec
File size: 3600 byte(s)
update file list
1 fwang 289958 %define subver 1.9
2     %define rubyver 1.9.3
3     %define patchversion p194
4     %define rel 1
5 blino 1152
6     Summary: Object Oriented Script Language
7     Name: ruby
8     Version: %{rubyver}.%{patchversion}
9     Release: %mkrel %rel
10     License: Ruby or GPLv2
11     Group: Development/Ruby
12     BuildRequires: autoconf
13     BuildRequires: byacc
14     BuildRequires: ncurses-devel
15     BuildRequires: readline-devel
16     BuildRequires: tcl-devel tk-devel
17 fwang 276350 BuildRequires: db-devel
18 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
19 blino 1152 BuildRequires: openssl-devel
20     BuildRequires: zlib-devel
21     Obsoletes: ruby-rexml
22     Provides: ruby-rexml
23     # explicit file provides (since such requires are automatically added by find-requires)
24     Provides: /usr/bin/ruby
25     Provides: ruby(abi) = %subver
26    
27 fwang 289958 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
28 blino 1152 Source3: ruby.macros
29     Patch0: ruby-lib64.patch
30     Patch1: ruby-do-not-use-system-ruby-to-generate-ri-doc.patch
31     Patch2: ruby-add-old-os-to-search-path.patch
32     Patch3: ruby-do_not_propagate_no-undefined.patch
33     URL: http://www.ruby-lang.org/
34    
35     %package doc
36     Summary: Documentation for the powerful language Ruby
37     Group: Development/Ruby
38 fwang 202696 BuildArch: noarch
39 blino 1152
40     %package devel
41     Summary: Development file for the powerful language Ruby
42     Group: Development/Ruby
43     Requires: %{name} = %{version}
44    
45     %package tk
46     Summary: Tk extension for the powerful language Ruby
47     Group: Development/Ruby
48     Requires: %{name} = %{version}
49    
50     %description
51     Ruby is the interpreted scripting language for quick and
52     easy object-oriented programming. It has many features to
53     process text files and to do system management tasks (as in
54     Perl). It is simple, straight-forward, and extensible.
55    
56     %description doc
57     Ruby is the interpreted scripting language for quick and
58     easy object-oriented programming. It has many features to
59     process text files and to do system management tasks (as in
60     Perl). It is simple, straight-forward, and extensible.
61    
62     This package contains the Ruby's documentation
63    
64     %description devel
65     Ruby is the interpreted scripting language for quick and
66     easy object-oriented programming. It has many features to
67     process text files and to do system management tasks (as in
68     Perl). It is simple, straight-forward, and extensible.
69    
70     This package contains the Ruby's devel files.
71    
72     %description tk
73     Ruby is the interpreted scripting language for quick and
74     easy object-oriented programming. It has many features to
75     process text files and to do system management tasks (as in
76     Perl). It is simple, straight-forward, and extensible.
77    
78     This package contains the Tk extension for Ruby.
79    
80     %prep
81     %setup -q -n ruby-%{rubyver}-%{patchversion}
82    
83     %build
84     CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
85 fwang 289958 %configure2_5x --enable-shared --disable-rpath --enable-pthread
86 blino 1152 %make
87    
88     %install
89     %makeinstall_std install-doc
90    
91     install -d %buildroot%{_datadir}/emacs/site-lisp
92     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
93    
94     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
95     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
96     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
97     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
98     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
99     EOF
100    
101     # Install the rpm macros
102     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
103     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
104 fwang 289961
105 blino 1152 %check
106     make test
107    
108 fwang 289961 %files
109 blino 1152 %{_bindir}/*
110     %{_libdir}/libruby.so.*
111 fwang 289970 %{_libdir}/ruby
112 blino 1152 %{_mandir}/*/*
113     %{_datadir}/emacs/site-lisp/*
114     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
115     %{_sysconfdir}/rpm/macros.d/%{name}.macros
116    
117     %files doc
118     %{_datadir}/ri
119    
120     %files devel
121     %{_libdir}/libruby-static.a
122     %{_libdir}/libruby.so
123    
124     %files tk

  ViewVC Help
Powered by ViewVC 1.1.30