/[packages]/cauldron/ruby/pristine/SPECS/ruby.spec
ViewVC logotype

Annotation of /cauldron/ruby/pristine/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 601634 - (hide annotations) (download)
Mon Mar 10 00:55:21 2014 UTC (10 years, 1 month ago) by pterjan
Original Path: cauldron/ruby/current/SPECS/ruby.spec
File size: 17993 byte(s)
Patch to force installing bundled gems to system directory even if build is running as user
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4 pterjan 601593 %define patchversion p451
5     %define rel 1
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
22     # RubyGems should be shared by all Ruby implementations.
23 pterjan 560984 %define rubygems_dir %{_datadir}/rubygems
24 pterjan 560987 %define gems_dir %{_datadir}/ruby/gems
25 pterjan 435211 %define rubygems_version 2.0.2
26 fwang 290007
27 fwang 468908 %define bootstrap 0
28 fwang 468812 %define build_gems 0
29 fwang 292558
30 blino 1152 Summary: Object Oriented Script Language
31     Name: ruby
32     Version: %{rubyver}.%{patchversion}
33     Release: %mkrel %rel
34 kamil 397518 License: Ruby or BSD
35 blino 1152 Group: Development/Ruby
36     BuildRequires: autoconf
37     BuildRequires: byacc
38 shlomif 291698 BuildRequires: doxygen
39 blino 1152 BuildRequires: ncurses-devel
40     BuildRequires: readline-devel
41     BuildRequires: tcl-devel tk-devel
42 fwang 276350 BuildRequires: db-devel
43 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
44 blino 1152 BuildRequires: openssl-devel
45     BuildRequires: zlib-devel
46 fwang 289987 BuildRequires: libffi-devel
47     BuildRequires: yaml-devel
48 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
49 blino 1152 Obsoletes: ruby-rexml
50     Provides: ruby-rexml
51 pterjan 435566 # Couldn't get the standalone gem to work
52     Provides: rubygem(psych)
53 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
54     Provides: /usr/bin/ruby
55 fwang 293445 Provides: ruby(abi) = %rubyapi
56 fwang 463762 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
57 pterjan 435211 Source1: operating_system.rb
58 blino 1152 Source3: ruby.macros
59     URL: http://www.ruby-lang.org/
60 fwang 292558 %if !%bootstrap
61     Requires: rubygems >= %{rubygems_version}
62 fwang 293395 BuildRequires: ruby
63 fwang 292558 %endif
64 blino 1152
65 fwang 290007 # == FEDORA PATCHES BEGINS ==
66 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
67     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
68     # Fixes random WEBRick test failures.
69     # https://bugs.ruby-lang.org/issues/6573.
70     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
71 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
72     # http://redmine.ruby-lang.org/issues/5617
73     Patch8: ruby-1.9.3-custom-rubygems-location.patch
74     # Add support for installing binary extensions according to FHS.
75     # https://github.com/rubygems/rubygems/issues/210
76 pterjan 435211 # Note that 8th patch might be resolved by
77     # https://bugs.ruby-lang.org/issues/7897
78     Patch9: rubygems-2.0.0-binary-extensions.patch
79     # Make mkmf verbose by default
80     Patch12: ruby-1.9.3-mkmf-verbose.patch
81     # This slightly changes behavior of "gem install --install-dir" behavior.
82     # Without this patch, Specifications.dirs is modified and gems installed on
83     # the system cannot be required anymore. This causes later issues when RDoc
84     # documentation should be generated, since json gem is sudenly not accessible.
85     # https://github.com/rubygems/rubygems/pull/452
86     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
87     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
88     # https://github.com/rubygems/rubygems/pull/455
89     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
90 fwang 490240 # Fixes issues with DESTDIR.
91     # https://bugs.ruby-lang.org/issues/8115
92     Patch18: ruby-2.0.0-p247-Revert-mkmf.rb-prefix-install_dirs-only-with-DESTDIR.patch
93 fwang 290007 # == FEDORA PATCHES ENDS ==
94 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
95     # to install gems into user dir
96     Patch20: ruby-2.0.0-p451-Do-not-install-to-user-dir.patch
97 fwang 290007
98 fwang 291591 %package -n %{libname}
99 fwang 291590 Summary: Libraries necessary to run Ruby
100     Group: Development/Ruby
101    
102 blino 1152 %package doc
103     Summary: Documentation for the powerful language Ruby
104     Group: Development/Ruby
105 fwang 202696 BuildArch: noarch
106 blino 1152
107     %package devel
108     Summary: Development file for the powerful language Ruby
109     Group: Development/Ruby
110 fwang 311925 Requires: %{name} = %{version}
111     Requires: %{libname} = %{version}
112 blino 1152
113     %package tk
114     Summary: Tk extension for the powerful language Ruby
115     Group: Development/Ruby
116 fwang 311925 Requires: %{name} = %{version}
117 blino 1152
118 fwang 291551 %package RubyGems
119     Summary: The Ruby standard for packaging ruby libraries
120     Group: Development/Ruby
121 fwang 291590 Version: %{rubygems_version}
122 fwang 291551 Requires: ruby(abi) = %{subver}
123 fwang 291590 Provides: gem = %{rubygems_version}
124     Provides: rubygems = %{rubygems_version}
125     Provides: ruby(rubygems) = %{rubygems_version}
126 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
127 fwang 291561 BuildArch: noarch
128 fwang 291551
129 pterjan 435211 %define rake_ver 0.9.6
130 fwang 291551 %package rake
131     Summary: Simple ruby build program with capabilities similar to make
132     Group: Development/Ruby
133 shlomif 291767 Version: %{rake_ver}
134 fwang 291551 Requires: ruby(abi) = %{subver}
135 fwang 291561 BuildArch: noarch
136 fwang 291551
137 pterjan 435211 %define minitest_ver 4.3.2
138 fwang 291562 %package minitest
139 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
140 fwang 291562 Group: Development/Ruby
141 shlomif 291767 Version: %{minitest_ver}
142 fwang 291562 License: MIT
143 fwang 291590 Requires: ruby(abi) = %{subver}
144     Requires: ruby(rubygems) >= %{rubygems_version}
145 fwang 291562 BuildArch: noarch
146    
147 pterjan 435211 %define json_ver 1.7.7
148 fwang 291562 %package json
149     Summary: This is a JSON implementation as a Ruby extension in C
150     Group: Development/Ruby
151 shlomif 291767 Version: %{json_ver}
152 fwang 291562 License: Ruby or GPLv2
153 fwang 291590 Requires: ruby(abi) = %{subver}
154     Requires: ruby(rubygems) >= %{rubygems_version}
155 fwang 291562
156 pterjan 435211 %define rdoc_ver 4.0.0
157 fwang 291562 %package rdoc
158     Summary: A tool to generate HTML and command-line documentation for Ruby projects
159     Group: Development/Ruby
160 shlomif 291767 Version: %{rdoc_ver}
161 fwang 291562 License: GPLv2 and Ruby and MIT
162 fwang 291590 Requires: ruby(abi) = %{subver}
163     Requires: ruby(rubygems) >= %{rubygems_version}
164     Requires: ruby(irb) = %{version}
165 shlomif 291767 Provides: rdoc = %{rdoc_ver}
166     Provides: ri = %{rdoc_ver}
167 fwang 291562 BuildArch: noarch
168    
169 fwang 291590 %package irb
170     Summary: The Interactive Ruby
171     Group: Development/Ruby
172     Provides: irb = %{version}-%{release}
173     Provides: ruby(irb) = %{version}-%{release}
174 fwang 313459 Conflicts: ruby < 1.9
175 fwang 313460 BuildArch: noarch
176 fwang 291590
177 pterjan 435211 %define bigdecimal_ver 1.2.0
178 fwang 291590 %package bigdecimal
179     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
180     Group: Development/Ruby
181 pterjan 435211 Version: %{bigdecimal_ver}
182 fwang 291590 License: GPL+ or Artistic
183     Requires: ruby(abi) = %{subver}
184     Requires: ruby(rubygems) >= %{rubygems_version}
185    
186 pterjan 435211 %define io_console_ver 0.4.2
187 fwang 291590 %package io-console
188     Summary: IO/Console is a simple console utilizing library
189     Group: Development/Ruby
190 pterjan 435211 Version: %{io_console_ver}
191 fwang 291590 Requires: ruby(abi) = %{subver}
192     Requires: ruby(rubygems) >= %{rubygems_version}
193    
194 pterjan 435211 %define psych_ver 2.0.0
195     %package psych
196     Summary: A libyaml wrapper for Ruby
197     Version: %{psych_ver}
198     Group: Development/Ruby
199     License: MIT
200     Requires: ruby(abi) = %{subver}
201     Requires: ruby(rubygems) >= %{rubygems_version}
202     Conflicts: ruby < 2.0.0
203    
204     %define test_unit_ver 2.0.0
205     %package test-unit
206     Summary: test/unit compatible API testing framework
207     Version: %{psych_ver}
208     Group: Development/Ruby
209     License: MIT
210     Requires: ruby(abi) = %{subver}
211     Requires: ruby(rubygems) >= %{rubygems_version}
212     Conflicts: ruby < 2.0.0
213     BuildArch: noarch
214    
215 blino 1152 %description
216     Ruby is the interpreted scripting language for quick and
217     easy object-oriented programming. It has many features to
218     process text files and to do system management tasks (as in
219     Perl). It is simple, straight-forward, and extensible.
220    
221     %description doc
222     Ruby is the interpreted scripting language for quick and
223     easy object-oriented programming. It has many features to
224     process text files and to do system management tasks (as in
225     Perl). It is simple, straight-forward, and extensible.
226    
227     This package contains the Ruby's documentation
228    
229 fwang 291590 %description -n %{libname}
230     This package includes the libruby, necessary to run Ruby.
231    
232 blino 1152 %description devel
233     Ruby is the interpreted scripting language for quick and
234     easy object-oriented programming. It has many features to
235     process text files and to do system management tasks (as in
236     Perl). It is simple, straight-forward, and extensible.
237    
238     This package contains the Ruby's devel files.
239    
240     %description tk
241     Ruby is the interpreted scripting language for quick and
242     easy object-oriented programming. It has many features to
243     process text files and to do system management tasks (as in
244     Perl). It is simple, straight-forward, and extensible.
245    
246     This package contains the Tk extension for Ruby.
247    
248 fwang 291551 %description RubyGems
249     RubyGems is the Ruby standard for publishing and managing third party
250     libraries.
251    
252 fwang 291552 %description rake
253     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
254     specified in standard Ruby syntax.
255    
256 fwang 291562 %description rdoc
257     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
258     includes the 'rdoc' and 'ri' tools for generating and displaying online
259     documentation.
260    
261     %description json
262     This is a implementation of the JSON specification according to RFC 4627.
263     You can think of it as a low fat alternative to XML, if you want to store
264     data to disk or transmit it over a network rather than use a verbose
265     markup language.
266    
267     %description minitest
268     minitest/unit is a small and incredibly fast unit testing framework.
269    
270     minitest/spec is a functionally complete spec engine.
271    
272     minitest/benchmark is an awesome way to assert the performance of your
273     algorithms in a repeatable manner.
274    
275     minitest/mock by Steven Baker, is a beautifully tiny mock object
276     framework.
277    
278     minitest/pride shows pride in testing and adds coloring to your test
279     output.
280    
281 fwang 291590 %description irb
282     The irb is acronym for Interactive Ruby. It evaluates ruby expression
283     from the terminal.
284    
285     %description bigdecimal
286     Ruby provides built-in support for arbitrary precision integer arithmetic.
287     For example:
288    
289     42**13 -> 1265437718438866624512
290    
291     BigDecimal provides similar support for very large or very accurate floating
292     point numbers. Decimal arithmetic is also useful for general calculation,
293     because it provides the correct answers people expect–whereas normal binary
294     floating point arithmetic often introduces subtle errors because of the
295     conversion between base 10 and base 2.
296    
297     %description io-console
298     IO/Console provides very simple and portable access to console. It doesn't
299     provide higher layer features, such like curses and readline.
300    
301 pterjan 435211 %description psych
302     Psych is a YAML parser and emitter. Psych leverages
303     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
304     capabilities. In addition to wrapping libyaml, Psych also knows how to
305     serialize and de-serialize most Ruby objects to and from the YAML format.
306    
307     %description test-unit
308     This library implements test/unit compatible API on minitest.
309     The test/unit means that test/unit which was bundled with Ruby 1.8.
310    
311 blino 1152 %prep
312     %setup -q -n ruby-%{rubyver}-%{patchversion}
313 fwang 290007 %apply_patches
314 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
315     rm lib/mkmf.rb.0*
316 blino 1152
317     %build
318 fwang 290038 autoconf
319 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
320 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
321 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
322 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
323 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
324     --with-sitearchdir='%{ruby_sitearchdir}' \
325     --with-vendordir='%{ruby_vendorlibdir}' \
326     --with-vendorarchdir='%{ruby_vendorarchdir}' \
327 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
328 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
329     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
330     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
331     --with-rubygemsdir='%{rubygems_dir}' \
332     --with-ruby-pc='%{name}.pc' \
333     --enable-multiarch \
334     --with-ruby-version=''
335 blino 1152 %make
336    
337     %install
338     %makeinstall_std install-doc
339    
340     install -d %buildroot%{_datadir}/emacs/site-lisp
341     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
342    
343     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
344     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
345     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
346     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
347     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
348     EOF
349    
350     # Install the rpm macros
351     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
352     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
353 fwang 289961
354 pterjan 435211 # Install custom operating_system.rb
355     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
356     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
357    
358 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
359     %if !%build_gems
360 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
361 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
362 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
363     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
364 pterjan 560987 rm -fr %{buildroot}%{gems_dir}/{gems,specifications}
365 fwang 311915 %if !%bootstrap
366 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
367 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
368     rm -fr %{buildroot}%{rubygems_dir}/rubygems
369 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
370     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
371 fwang 293412 %endif
372 fwang 311914 %endif
373 fwang 293412
374 blino 1152 %check
375     make test
376    
377 fwang 289961 %files
378 fwang 291551 %{_bindir}/erb
379     %{_bindir}/ruby
380 fwang 291560 %dir %{ruby_libdir}
381     %{ruby_libdir}/*.rb
382 fwang 291590 %exclude %{ruby_libdir}/irb.rb
383 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
384     %exclude %{ruby_libdir}/remote-tk.rb
385     %exclude %{ruby_libdir}/tcltk.rb
386     %exclude %{ruby_libdir}/tk.rb
387     %exclude %{ruby_libdir}/tkafter.rb
388     %exclude %{ruby_libdir}/tkbgerror.rb
389     %exclude %{ruby_libdir}/tkcanvas.rb
390     %exclude %{ruby_libdir}/tkclass.rb
391     %exclude %{ruby_libdir}/tkconsole.rb
392     %exclude %{ruby_libdir}/tkdialog.rb
393     %exclude %{ruby_libdir}/tkentry.rb
394     %exclude %{ruby_libdir}/tkfont.rb
395     %exclude %{ruby_libdir}/tkmacpkg.rb
396     %exclude %{ruby_libdir}/tkmenubar.rb
397     %exclude %{ruby_libdir}/tkmngfocus.rb
398     %exclude %{ruby_libdir}/tkpalette.rb
399     %exclude %{ruby_libdir}/tkscrollbox.rb
400     %exclude %{ruby_libdir}/tktext.rb
401     %exclude %{ruby_libdir}/tkvirtevent.rb
402     %exclude %{ruby_libdir}/tkwinpkg.rb
403     %{ruby_libdir}/cgi
404     %{ruby_libdir}/date
405     %{ruby_libdir}/digest
406     %{ruby_libdir}/dl
407     %{ruby_libdir}/drb
408     %{ruby_libdir}/fiddle
409     %{ruby_libdir}/matrix
410     %{ruby_libdir}/net
411     %{ruby_libdir}/openssl
412     %{ruby_libdir}/optparse
413 pterjan 435566 %{ruby_libdir}/psych
414 fwang 291560 %{ruby_libdir}/racc
415     %{ruby_libdir}/rbconfig
416     %{ruby_libdir}/rexml
417     %{ruby_libdir}/rinda
418     %{ruby_libdir}/ripper
419     %{ruby_libdir}/rss
420     %{ruby_libdir}/shell
421 pterjan 435211 %{ruby_libdir}/syslog
422 fwang 291560 %{ruby_libdir}/uri
423     %{ruby_libdir}/webrick
424     %{ruby_libdir}/xmlrpc
425     %{ruby_libdir}/yaml
426     %dir %{ruby_libarchdir}
427     %{ruby_libarchdir}/continuation.so
428     %{ruby_libarchdir}/coverage.so
429     %{ruby_libarchdir}/curses.so
430     %{ruby_libarchdir}/date_core.so
431     %{ruby_libarchdir}/dbm.so
432     %dir %{ruby_libarchdir}/digest
433     %{ruby_libarchdir}/digest.so
434     %{ruby_libarchdir}/digest/*.so
435     %dir %{ruby_libarchdir}/dl
436     %{ruby_libarchdir}/dl.so
437     %{ruby_libarchdir}/dl/*.so
438     %dir %{ruby_libarchdir}/enc
439     %{ruby_libarchdir}/enc/*.so
440 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
441     %{ruby_libarchdir}/enc/trans/*.so
442 fwang 291560 %{ruby_libarchdir}/etc.so
443     %{ruby_libarchdir}/fcntl.so
444     %{ruby_libarchdir}/fiber.so
445     %{ruby_libarchdir}/fiddle.so
446     %{ruby_libarchdir}/gdbm.so
447     %dir %{ruby_libarchdir}/io
448     %{ruby_libarchdir}/io/nonblock.so
449     %{ruby_libarchdir}/io/wait.so
450     %dir %{ruby_libarchdir}/mathn
451 fwang 291562 %{ruby_libarchdir}/mathn/*.so
452 fwang 291560 %{ruby_libarchdir}/nkf.so
453     %{ruby_libarchdir}/objspace.so
454     %{ruby_libarchdir}/openssl.so
455 pterjan 435566 %{ruby_libarchdir}/psych.so
456 fwang 291560 %{ruby_libarchdir}/pathname.so
457     %{ruby_libarchdir}/pty.so
458     %dir %{ruby_libarchdir}/racc
459     %{ruby_libarchdir}/racc/*.so
460     %{ruby_libarchdir}/rbconfig.rb
461     %{ruby_libarchdir}/readline.so
462     %{ruby_libarchdir}/ripper.so
463     %{ruby_libarchdir}/sdbm.so
464     %{ruby_libarchdir}/socket.so
465     %{ruby_libarchdir}/stringio.so
466     %{ruby_libarchdir}/strscan.so
467     %{ruby_libarchdir}/syslog.so
468     %{ruby_libarchdir}/zlib.so
469 fwang 291551 %{_mandir}/man1/erb.1.*
470     %{_mandir}/man1/ruby.1.*
471 blino 1152 %{_datadir}/emacs/site-lisp/*
472     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
473     %{_sysconfdir}/rpm/macros.d/%{name}.macros
474 fwang 291560 %{_datadir}/ruby/site_ruby
475     %{_libdir}/ruby/site_ruby
476     %{_datadir}/ruby/vendor_ruby
477     %{_libdir}/ruby/vendor_ruby
478 fwang 311914 %if %bootstrap
479     %{_bindir}/gem
480 fwang 448831 %dir %{rubygems_dir}
481     %{rubygems_dir}/rbconfig
482     %{rubygems_dir}/rubygems
483     %{rubygems_dir}/rubygems.rb
484     %{rubygems_dir}/ubygems.rb
485 fwang 311914 %endif
486 blino 1152
487     %files doc
488     %{_datadir}/ri
489 pterjan 435211 %{_datadir}/doc/ruby
490 blino 1152
491 fwang 291590 %files -n %{libname}
492     %{_libdir}/libruby.so.%{subver}
493     %{_libdir}/libruby.so.%{rubyapi}
494    
495 blino 1152 %files devel
496 fwang 290003 %{_includedir}/*
497 blino 1152 %{_libdir}/libruby-static.a
498     %{_libdir}/libruby.so
499 fwang 290003 %{_libdir}/pkgconfig/*.pc
500 blino 1152
501     %files tk
502 fwang 291560 %{ruby_libarchdir}/tcltklib.so
503     %{ruby_libarchdir}/tkutil.so
504     %{ruby_libdir}/multi-tk.rb
505     %{ruby_libdir}/remote-tk.rb
506     %{ruby_libdir}/tcltk.rb
507     %{ruby_libdir}/tk.rb
508     %{ruby_libdir}/tkafter.rb
509     %{ruby_libdir}/tkbgerror.rb
510     %{ruby_libdir}/tkcanvas.rb
511     %{ruby_libdir}/tkclass.rb
512     %{ruby_libdir}/tkconsole.rb
513     %{ruby_libdir}/tkdialog.rb
514     %{ruby_libdir}/tkentry.rb
515     %{ruby_libdir}/tkfont.rb
516     %{ruby_libdir}/tkmacpkg.rb
517     %{ruby_libdir}/tkmenubar.rb
518     %{ruby_libdir}/tkmngfocus.rb
519     %{ruby_libdir}/tkpalette.rb
520     %{ruby_libdir}/tkscrollbox.rb
521     %{ruby_libdir}/tktext.rb
522     %{ruby_libdir}/tkvirtevent.rb
523     %{ruby_libdir}/tkwinpkg.rb
524     %{ruby_libdir}/tk
525     %{ruby_libdir}/tkextlib
526 fwang 291551
527 fwang 293412 %files irb
528     %{_bindir}/irb
529     %{ruby_libdir}/irb.rb
530     %{ruby_libdir}/irb
531     %{_mandir}/man1/irb.1*
532    
533     %if %build_gems
534 fwang 291551 %files RubyGems
535     %{_bindir}/gem
536     %dir %{rubygems_dir}
537     %{rubygems_dir}/rbconfig
538     %{rubygems_dir}/rubygems
539     %{rubygems_dir}/rubygems.rb
540     %{rubygems_dir}/ubygems.rb
541    
542 fwang 291562 %files minitest
543     %{ruby_libdir}/minitest
544 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
545 fwang 291562
546 fwang 291551 %files rake
547     %{_bindir}/rake
548     %{_mandir}/man1/rake.1.*
549 fwang 291562 %{ruby_libdir}/rake
550 pterjan 560987 %{gems_dir}/gems/rake-*
551     %{gems_dir}/specifications/default/rake-*.gemspec
552 fwang 291562
553     %files rdoc
554     %{_bindir}/rdoc
555     %{_bindir}/ri
556     %{ruby_libdir}/rdoc
557 pterjan 560987 %{gems_dir}/gems/rdoc-*
558     %{gems_dir}/specifications/default/rdoc-*.gemspec
559 fwang 291562 %{_mandir}/man1/ri.1.*
560    
561     %files json
562     %dir %{ruby_libarchdir}/json
563     %dir %{ruby_libarchdir}/json/ext
564     %{ruby_libarchdir}/json/ext/*.so
565     %{ruby_libdir}/json
566 pterjan 560987 %{gems_dir}/specifications/default/json-*.gemspec
567 fwang 291590
568     %files bigdecimal
569     %{ruby_libdir}/bigdecimal
570     %{ruby_libarchdir}/bigdecimal.so
571 pterjan 560987 %{gems_dir}/specifications/default/bigdecimal-*.gemspec
572 fwang 291590
573     %files io-console
574     %{ruby_libdir}/io
575     %{ruby_libarchdir}/io/console.so
576 pterjan 560987 %{gems_dir}/specifications/default/io-console-*.gemspec
577 pterjan 435211
578     %files psych
579     %{ruby_libdir}/psych
580     %{ruby_libarchdir}/psych.so
581 pterjan 560987 %{gems_dir}/specifications/default/psych-*.gemspec
582 pterjan 435211
583     %files test-unit
584     %{_bindir}/testrb
585     %{ruby_libdir}/test
586 pterjan 560987 %{gems_dir}/gems/test-unit-*
587 pterjan 435211 %{rubygems_dir}/specifications/default/test-unit-*.gemspec
588 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30