/[packages]/cauldron/solaar/current/SPECS/solaar.spec
ViewVC logotype

Contents of /cauldron/solaar/current/SPECS/solaar.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1379409 - (show annotations) (download)
Thu Mar 21 06:39:16 2019 UTC (5 years, 1 month ago) by daviddavid
File size: 2297 byte(s)
SILENT: remove bogus zh_TW.po files

1 %define oname Solaar
2
3 %define date 20190130
4 %if %{date}
5 %define release %mkrel 12.git%{date}.%{rel}
6 %define tarballver %{commit}
7 %define tarballdir %{commit}
8 %define tarballgit +git%{date}
9 %define commit c07c115ee379e82db84283aaa29dc53df033a8c8
10 %else
11 %define release %mkrel %{rel}
12 %define tarballver %{version}
13 %define tarballdir %{version}
14 %endif
15
16 %define rel 1
17
18 Name: solaar
19 Version: 0.9.2
20 Release: %{release}
21 Summary: Device manager for Logitech's Unifying Receiver
22 License: GPLv2
23 Group: System/Kernel and hardware
24 Url: http://pwr.github.io/Solaar/
25 Source0: https://github.com/pwr/%{oname}/archive/%{tarballdir}/%{name}-%{version}%{?tarballgit}.tar.gz
26 BuildArch: noarch
27 BuildRequires: gettext
28 BuildRequires: python3dist(setuptools)
29 Requires: python3dist(pyudev)
30 Requires: python3dist(pygobject)
31
32 %description
33 Solaar is a Linux device manager for Logitech’s Unifying Receiver
34 peripherals. It is able to pair/unpair devices to the receiver, and
35 for most devices read battery status.
36
37 It comes in two flavors, command-line and GUI. Both are able to list
38 the devices paired to a Unifying Receiver, show detailed info for
39 each device, and also pair/unpair supported devices with the receiver.
40
41 %prep
42 %autosetup -n %{oname}-%{tarballver} -p1
43
44 # Correct Python interpreter path in all executables /usr/bin/env python -> /usr/bin/python
45 find -name '*.py' -print0 | xargs -0 sed -i -e 's,^#!/usr/bin/env python,#!%{__python},'
46
47 # "Upgrade" Python interpreter path to Python3 /usr/bin/python -> /usr/bin/python3
48 find -name '*.py' -print0 | xargs -0 sed -i -e 's,^#!%{__python},#!%{__python3},'
49
50 # create all translations files (solaar.mo) on ./share/locale
51 rm po/zh_TW.po
52 sh ./tools/po-compile.sh
53
54 %build
55 %py3_build
56
57 %install
58 %py3_install
59
60 mkdir -p %{buildroot}%{_udevrulesdir}
61 cp rules.d/42-logitech-unify-permissions.rules %{buildroot}%{_udevrulesdir}
62
63 %find_lang %{name}
64
65 %files -f %{name}.lang
66 %doc README.md share/README docs
67 %dir %{_datadir}/%{name}/
68 %dir %{python3_sitelib}/*
69 %{_bindir}/%{name}*
70 %{_datadir}/applications/%{name}.desktop
71 %{_sysconfdir}/xdg/autostart/%{name}.desktop
72 %{_datadir}/%{name}/*
73 %{_iconsdir}/*/*/*/%{name}.svg
74 %{python3_sitelib}/%{name}-%{version}-py%{python3_version}.egg-info
75 %{python3_sitelib}/*/*
76 %config %{_udevrulesdir}/42-logitech-unify-permissions.rules

  ViewVC Help
Powered by ViewVC 1.1.30