1 |
%define oname Soya |
2 |
%define tutver 0.14 |
3 |
|
4 |
Name: soya |
5 |
Version: 0.15rc1 |
6 |
Release: %mkrel 28 |
7 |
Summary: A practical high-level object-oriented 3D engine |
8 |
License: GPLv2+ |
9 |
Group: Development/Python |
10 |
Url: http://home.gna.org/oomadness/en/index.html |
11 |
Source0: http://download.gna.org/soya/%{oname}-%{version}.tar.bz2 |
12 |
Source1: http://download.gna.org/soya/%{oname}Tutorial-%{tutver}.tar.bz2 |
13 |
Patch0: %{oname}-%{version}-svn-fix-compilation.patch |
14 |
Patch1: Soya-0.15rc1-ode-2.patch |
15 |
Patch2: Soya-0.15rc1-null-characters-world-py.patch |
16 |
Patch3: Soya-0.15rc1-deprecated-tostring-call.patch |
17 |
Patch4: soya-0.15rc1-pillow.patch |
18 |
# pyrex is needed for patch3 |
19 |
BuildRequires: pythonegg(2)(pyrex) |
20 |
BuildRequires: pkgconfig(python2) |
21 |
BuildRequires: pkgconfig(libpng) |
22 |
BuildRequires: pkgconfig(sdl) |
23 |
BuildRequires: pkgconfig(cal3d) |
24 |
BuildRequires: pkgconfig(glu) |
25 |
BuildRequires: pkgconfig(ode) |
26 |
BuildRequires: pkgconfig(glew) |
27 |
BuildRequires: pkgconfig(freetype2) |
28 |
BuildRequires: pkgconfig(openal) |
29 |
Requires: editobj2 |
30 |
Requires: pythonegg(2)(pillow) |
31 |
|
32 |
%description |
33 |
A practical high-level object-oriented 3D engine. |
34 |
|
35 |
# (jiba) A separate package for the tutorial |
36 |
%package tutorial |
37 |
Summary: Tutorial for the Soya 3D engine |
38 |
License: GPLv2+ |
39 |
Group: Development/Python |
40 |
Requires: %{name} >= %{version} |
41 |
Recommends: blender |
42 |
Recommends: pythonegg(2)(pillow) |
43 |
Recommends: cerealizer |
44 |
|
45 |
%description tutorial |
46 |
This is a set of tutorial for Soya. |
47 |
Soya is a practical high-level object-oriented 3D engine for Python 2. |
48 |
|
49 |
%prep |
50 |
%setup -q -c %{oname}-%{version} -a 1 |
51 |
# The source needs to be in a "soya" dir to prevent this pyrex error: |
52 |
# Pyrex.Compiler.Errors.CompileError: BUILD/Soya-0.15rc1/_soya.pyx:0:0: 'Soya-0.15rc1._soya' is not a valid module name |
53 |
mv %{oname}-%{version} soya |
54 |
|
55 |
pushd soya |
56 |
%patch0 -p2 |
57 |
%patch1 -p1 |
58 |
%patch2 -p1 |
59 |
%patch3 -p1 |
60 |
%patch4 -p1 |
61 |
rm -rf `find -name CVS` `find -name .cvswrappers` |
62 |
popd |
63 |
|
64 |
%build |
65 |
pushd soya |
66 |
%py2_build |
67 |
popd |
68 |
|
69 |
%install |
70 |
pushd soya |
71 |
%py2_install |
72 |
popd |
73 |
|
74 |
%files |
75 |
%doc soya/{README,CHANGES,AUTHORS} |
76 |
%{_bindir}/%{name}_editor |
77 |
%{python2_sitearch}/%{name}/ |
78 |
%{python2_sitearch}/*.egg-info |
79 |
|
80 |
%files tutorial |
81 |
%doc %{oname}Tutorial-%{tutver}/AUTHORS %{oname}Tutorial-%{tutver}/tutorial |