/[packages]/cauldron/uucp/current/SPECS/uucp.spec
ViewVC logotype

Contents of /cauldron/uucp/current/SPECS/uucp.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 404859 - (show annotations) (download)
Sun Mar 24 15:20:47 2013 UTC (11 years ago) by colin
File size: 3643 byte(s)
Add systemd requires and general post/pre fixes (mga#9302)
1 Summary: The uucp utility for copying files between systems
2 Name: uucp
3 Version: 1.07
4 Release: %mkrel 12
5 License: GPL v2
6 Group: Networking/File transfer
7 URL: http://www.airs.com/ian/uucp.html
8 Source0: ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.bz2
9 Source1: uucp.log
10 Source2: %{name}-tmpfiles.conf
11 Patch0: uucp-1.07-misc.patch
12 Patch7: uucp-1.07-64bit-fixes.patch
13 Patch8: uucp-1.07-config.patch
14 Patch9: uucp-1.07-sigfpe.patch
15 Patch11: uucp-1.06.1-pipe.patch
16 Patch12: uucp-1.07-printf.patch
17 BuildRequires: texinfo
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
19 Requires(post): systemd >= %{systemd_required_version}
20 Requires(post): rpm-helper
21 Requires(post): info-install
22 Requires(preun): info-install
23
24 %description
25 The uucp command copies files between systems. Uucp is primarily used
26 by remote machines downloading and uploading email and news files to
27 local machines.
28
29 Install the uucp package if you need to use uucp to transfer files
30 between machines.
31
32 %prep
33 %setup -q
34 %patch0 -p1 -b .misc
35 %patch7 -p1 -b .64bit-fixes
36 %patch8 -p1 -b .config
37 %patch9 -p1 -b .sigfpe
38 %patch11 -p1 -b .pipe
39 %patch12 -p1 -b .printf
40
41 %build
42 LDFLAGS=-s \
43 %configure --with-newconfigdir=%{_sysconfdir}/%{name} --with-oldconfigdir=%{_sysconfdir}/%{name}
44 %make
45
46 %install
47 rm -rf %{buildroot}
48 %{makeinstall} install-info
49
50 mkdir -p %{buildroot}/var/spool/uucp
51 mkdir -p %{buildroot}/var/spool/uucppublic
52 mkdir -p %{buildroot}%{_sysconfdir}/uucp/oldconfig
53
54 rm -rf %{buildroot}/var/log/uucp
55 mkdir -p %{buildroot}/var/log/uucp
56
57 mkdir -p %{buildroot}%{_libdir}/uucp
58 ln -sf ../../sbin/uucico %{buildroot}%{_libdir}/uucp
59
60 install -m644 %{SOURCE1} -D %{buildroot}%{_sysconfdir}/logrotate.d/uucp
61 install -D -p -m 0644 %{SOURCE2} %{buildroot}%{_tmpfilesdir}/%{name}.conf
62
63 # Create ghost files
64 touch %{buildroot}/var/log/uucp/{Log,Stats,Debug}
65
66 # the following is kind of gross, but it is effective
67 for i in dial passwd port dialcode sys call ; do
68 cat > %{buildroot}/etc/uucp/$i <<EOF
69 # This is an example of a $i file. This file have the syntax compatible
70 # with Taylor UUCP (not HDB nor anything else). Please check uucp
71 # documentation if you are not sure how Taylor config files are supposed to
72 # look like. Edit it as appropriate for your system.
73
74 # Everything after a '#' character is a comment.
75 EOF
76 done
77
78 %clean
79 rm -rf %{buildroot}
80
81 %post
82 %_tmpfilescreate %{name}
83 %{_install_info uucp.info}
84 # These permissions have to be synced with below %%files
85 %create_ghostfile /var/log/uucp/Log uucp uucp 644
86 %create_ghostfile /var/log/uucp/Stats uucp uucp 644
87 %create_ghostfile /var/log/uucp/Debug uucp uucp 640
88
89 %preun
90 %{_remove_install_info uucp.info}
91
92 %files
93 %defattr(-,root,root,755)
94 %doc README ChangeLog NEWS
95 %doc sample contrib
96 %attr(-,uucp,uucp) %dir /var/spool/uucp
97 %attr(-,uucp,uucp) %dir /var/spool/uucppublic
98 %attr(755,uucp,uucp) %dir %{_sysconfdir}/uucp
99 %{_infodir}/uucp.info*
100 %{_sbindir}/uuchk
101 %{_sbindir}/uuconv
102 %{_sbindir}/uusched
103 %attr(6555,uucp,uucp) %{_sbindir}/uucico
104 %attr(6555,uucp,uucp) %{_sbindir}/uuxqt
105 %attr(-,uucp,uucp) %{_bindir}/*
106 %{_mandir}/*/*
107 %{_libdir}/uucp/uucico
108 %{_tmpfilesdir}/%{name}.conf
109 %attr(-,uucp,uucp) %dir /var/log/uucp
110 %attr(644,root,root) %config(noreplace) %{_sysconfdir}/logrotate.d/uucp
111 %attr(644,uucp,uucp) %ghost /var/log/uucp/Log
112 %attr(644,uucp,uucp) %ghost /var/log/uucp/Stats
113 %attr(600,uucp,uucp) %ghost /var/log/uucp/Debug
114 %config(noreplace) %{_sysconfdir}/uucp/dial
115 %config(noreplace) %{_sysconfdir}/uucp/dialcode
116 %config(noreplace) %{_sysconfdir}/uucp/port
117 %config(noreplace) %{_sysconfdir}/uucp/passwd
118 %config(noreplace) %{_sysconfdir}/uucp/sys
119 %config(noreplace) %{_sysconfdir}/uucp/call
120

  ViewVC Help
Powered by ViewVC 1.1.30