/[packages]/cauldron/wayland/current/SPECS/wayland.spec
ViewVC logotype

Contents of /cauldron/wayland/current/SPECS/wayland.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 402087 - (show annotations) (download)
Mon Mar 11 08:24:06 2013 UTC (11 years, 1 month ago) by rtp
File size: 3534 byte(s)
- disable publican/doc on arm as publican will call fop which is in java.

1 %define name wayland
2 %define version 1.0.3
3 %define release %mkrel 3
4
5 %define client_major 0
6 %define server_major 0
7 %define cursor_major 0
8
9 %define libname_devel %mklibname %{name} -d
10
11 %define client_name %{name}-client
12 %define client_libname %mklibname %{client_name} %{client_major}
13
14 %define server_name %{name}-server
15 %define server_libname %mklibname %{server_name} %{server_major}
16
17 %define cursor_name %{name}-cursor
18 %define cursor_libname %mklibname %{cursor_name} %{cursor_major}
19
20 Summary: Wayland Compositor Infrastructure
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 Source0: http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
25 License: MIT
26 Group: System/Libraries
27 Url: http://wayland.freedesktop.org/
28 BuildRequires: expat-devel
29 BuildRequires: pkgconfig(libffi)
30 # for protocol doc
31 BuildRequires: xsltproc
32 BuildRequires: doxygen
33 %ifnarch %arm %mips
34 # enabling it means it'll try to use fop which is written in java
35 BuildRequires: publican
36 %endif
37
38 %description
39 Wayland is a protocol for a compositor to talk to its clients as well
40 as a C library implementation of that protocol. The compositor can be
41 a standalone display server running on Linux kernel modesetting and
42 evdev input devices, an X application, or a wayland client itself. The
43 clients can be traditional applications, X servers (rootless or
44 fullscreen) or other display servers.
45
46 %package -n %{libname_devel}
47 Summary: Header files for %{name}
48 Group: Development/C
49 Provides: %{name}-devel = %{version}-%{release}
50 Requires: %{client_libname} = %{version}-%{release}
51 Requires: %{server_libname} = %{version}-%{release}
52 Requires: %{cursor_libname} = %{version}-%{release}
53 Requires: %{name}-tools = %{version}-%{release}
54
55 %description -n %{libname_devel}
56 This package contains the header and pkg-config files for developing
57 with %{name}.
58
59 %package -n %{client_libname}
60 Summary: Libraries for %{client_name}
61 Group: System/Libraries
62
63 %description -n %{client_libname}
64 This package contains the libraries for %{client_name}.
65
66 %package -n %{server_libname}
67 Summary: Libraries for %{server_name}
68 Group: System/Libraries
69
70 %description -n %{server_libname}
71 This package contains the libraries for %{server_name}.
72
73 %package -n %{cursor_libname}
74 Summary: Libraries for %{cursor_name}
75 Group: System/Libraries
76
77 %description -n %{cursor_libname}
78 This package contains the libraries for %{cursor_name}.
79
80 %package tools
81 Summary: %{name} devel tools
82 Group: System/Libraries
83 Conflicts: %{libname_devel} < 0.95-3
84
85 %description tools
86 This package contains development tools for %{name}.
87
88 %package doc
89 Summary: %{name} documentation
90 Group: Documentation
91 %description doc
92 This package contains documentation of %{name}.
93
94 %prep
95 %setup -q
96
97 %build
98 autoreconf -vfi
99 %configure2_5x --disable-static
100 %make
101
102 %install
103 %makeinstall
104 rm -f %{buildroot}%{_libdir}/*.la
105
106 %files -n %{client_libname}
107 %{_libdir}/lib%{client_name}.so.%{client_major}
108 %{_libdir}/lib%{client_name}.so.%{client_major}.*
109
110 %files -n %{server_libname}
111 %{_libdir}/lib%{server_name}.so.%{server_major}
112 %{_libdir}/lib%{server_name}.so.%{server_major}.*
113
114 %files -n %{cursor_libname}
115 %{_libdir}/lib%{cursor_name}.so.%{cursor_major}
116 %{_libdir}/lib%{cursor_name}.so.%{cursor_major}.*
117
118 %files -n %{libname_devel}
119 %{_includedir}/%{name}-*.h
120 %{_libdir}/lib%{name}*.so
121 %{_libdir}/pkgconfig/%{name}*.pc
122 %{_datadir}/aclocal/%{name}-scanner.m4
123 %{_datadir}/aclocal/%{name}-scanner.mk
124
125 %files tools
126 %{_bindir}/%{name}-scanner
127
128 %files doc
129 %ifnarch %arm %mips
130 %doc %{_docdir}/%{name}/*
131 %endif
132 %{_mandir}/man3/wl_*.3*

  ViewVC Help
Powered by ViewVC 1.1.30