/[packages]/cauldron/xbmc/current/SPECS/xbmc.spec
ViewVC logotype

Annotation of /cauldron/xbmc/current/SPECS/xbmc.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 132036 - (hide annotations) (download)
Sat Aug 6 08:13:24 2011 UTC (12 years, 8 months ago) by fwang
File size: 18531 byte(s)
SILENT: more upstream build patch
1 ennael 78010
2     %define name xbmc
3     %define branch_release dharma
4     %define extra_feature pvr
5 anssi 89302 %define version 10.1
6 anssi 93516 %define snap 0
7 fwang 113516 %define rel 3
8 ennael 78010
9 anssi 93516 %if %snap
10 ennael 78010 %define branch %branch_release.%extra_feature
11     %else
12     %define branch %extra_feature
13     %endif
14    
15     %define branchr %([ "%branch" ] && echo .%branch | tr - _)
16    
17     # There are some compatibility issues with the various python addons which
18     # are mostly tested against bundled python only, and there are too many of
19     # them to be checked out and fixed by us for system python compatibility.
20     # Additional issues are caused by the bundled python having several system
21     # calls redirected through xbmc VFS layer, which doesn't currently work when
22     # using the system python. Usage of system python can probably be safely
23     # re-enabled when XBMC upstream migrates away from python 2.4 and fixes the
24     # issues regarding external python (this is planned). -Anssi 11/2010
25     %define system_python 0
26    
27     # using system python2.7+ reportedly causes problems with
28     # getcwd() and chdir() calls from python
29     # http://trac.xbmc.org/ticket/8658
30     %define system_python 0
31    
32     Summary: XBMC Media Center - media player and home entertainment system
33     Name: %{name}
34     Version: %{version}
35 anssi 93516 %if %snap
36     Release: %mkrel 0.svn%snap%branchr.%rel
37 ennael 78010 # REV=$(git log -1 origin/Dharma | grep git-svn-id | sed -ne 's,^.*@\([^ ]\+\).*$,\1,p')
38     # git archive --prefix=xbmc-dharma-$REV/ origin/Dharma | xz > xbmc-dharma-$REV.tar.xz
39 anssi 93516 Source: %{name}-%branch_release-%snap.tar.xz
40 ennael 78010 %else
41     Release: %mkrel 1.%branch.%rel
42     Source: %{name}-%{version}.tar.gz
43     %endif
44     URL: http://xbmc.org/
45    
46     # needed modules when using bundled python (versions are those expected by the Makefiles):
47     Source11: http://www.effbot.org/downloads/Imaging-1.1.7.tar.gz
48     Source12: http://pysqlite.googlecode.com/files/pysqlite-2.5.6.tar.gz
49    
50     # bring snapshot up-to-date with pvr branch
51     # https://github.com/opdenkamp/xbmc/tree/Dharma-pvr
52     Patch0: xbmc-10.0-opdenkamp-pvr-fdb057b7754.patch
53    
54     # bring snapshot up-to-date with main branch (patches rediffed for pvr):
55     # already up-to-date
56     #Patch18: xbmc-dharma-r35305-r%svnsnap.patch
57    
58     # VDPAU backports from upstream master
59     Patch31: 0001-changed-split-CDVDVideoCodecFFmpeg-GetPicture.patch
60     Patch32: 0002-fixed-VDPAU-temporal-deinterlacer-was-not-provided-e.patch
61     Patch33: 0003-changed-allow-VDPAU-reverse-telecine-when-deinterlac.patch
62     Patch34: 0004-fixed-VDPAU-reverse-telecine.patch
63     Patch35: 0005-changed-enable-VDPAU-temporal-deinterlacer-when-temp.patch
64     Patch36: 0006-fixed-flush-VDPAU-video-surfaces-and-picture-queue-w.patch
65     Patch37: 0007-fixed-picture.iDuration-0-comparison.patch
66     Patch38: 0008-fixed-vdpau-needs-to-memset-its-DVDVideoPicture-stru.patch
67    
68     # backports from upstream master
69     Patch40: 0001-added-note-in-linux-crashlog-if-gdb-is-not-installed.patch
70     Patch41: 0001-Added-9763-Fix-64-bit-WiiRemote-connection-issues-Th.patch
71    
72 fwang 132032 # adopt to new ffmpeg api (upstream patch)
73     Patch51: 773159bea90303826ad21e061e95793efddcff44.patch
74     Patch52: cd0ccf86d3868708cde37ee231d45df283027745.patch
75 fwang 132036 Patch53: 7ec64dc154bafbc0ed42b2a4970e10402afa6362.patch
76 fwang 132032
77 ennael 78010 # Disable updates of the default skin. Our one is the PVR version, while the
78     # one in the XBMC.org addon repository would be the vanilla one (Confluence
79     # is currently not in the addon repository, though, as of 2010-10).
80     Patch60: xbmc-disable-confluence-update.patch
81    
82     # Workaround http://www.nvnews.net/vbulletin/showthread.php?t=156665
83     # by forcing SDL to use alsa when pulse is disabled and nvidia proprietary
84     # driver version 260.x.y older than 260.19.21 is active.
85     Patch61: 0001-added-workaround-for-crash-with-nonpulse-nvidia260.patch
86    
87     # forkpty and openpty are in -lutil
88     Patch62: 0001-fixed-undefined-symbols-in-internal-python.patch
89    
90     # Ensure backward-compatibility with pvr-testing2 and prevent future compatibility
91     # issues with trunk Addons database format
92     Patch63: 0001-changed-use-the-legacy-pvr-testing2-addon-database.patch
93    
94     # Do not use avg_frame_rate for mkv files on 2010.1 and older, instead
95     # use time_base if needed (fixes MicroDVD subtitles with 23.976 H.264 mkv)
96     Patch65: xbmc-old-libavformat-mkv-subs.patch
97    
98     # build faad support with internal headers, but do not build the
99     # internal library; use system lib with dlopen instead;
100     # this allows keeping it as an optional external library
101     Patch70: xbmc-hack-ext-faad-with-int-headers.patch
102    
103     # CVE fixes for the internal python
104     Patch81: 0001-fixed-CVE-2007-2052-in-internal-python-Mandriva.patch
105     Patch82: 0002-fixed-CVE-2007-4965-in-internal-python-upstream.patch
106     Patch83: 0003-fixed-CVE-2008-1679-in-internal-python-upstream.patch
107     Patch84: 0004-fixed-CVE-2008-1887-in-internal-python-upstream.patch
108     Patch85: 0005-fixed-CVE-2008-1721-in-internal-python-upstream.patch
109     Patch86: 0006-fixed-CVE-2008-2315-in-internal-python-Gentoo.patch
110     Patch87: 0007-fixed-CVE-2008-3142-in-internal-python-Gentoo.patch
111     Patch88: 0008-fixed-CVE-2008-3144-in-internal-python-Gentoo.patch
112     Patch89: 0009-fixed-CVE-2008-4864-in-internal-python-Mandriva.patch
113     Patch90: 0010-fixed-CVE-2008-5031-in-internal-python-upstream.patch
114     Patch91: 0011-fixed-CVE-2010-1634-in-internal-python-Mandriva.patch
115     Patch92: 0012-fixed-CVE-2010-2089-in-internal-python-Mandriva.patch
116     Patch93: 0013-fixed-CVE-2009-2625-in-internal-python-Mandriva.patch
117     Patch94: 0014-fixed-CVE-2010-3492-in-internal-python-Mandriva.patch
118     Patch95: 0015-fixed-CVE-2010-3493-in-internal-python-Mandriva.patch
119    
120 fwang 132032
121 ennael 78010 # nosefart audio plugin and RSXS-0.9 based screensavers are GPLv2 only
122     # libhts, libhdhomerun and several eventclients are GPLv3+
123     # the rest is GPLv2+
124     License: GPLv3+ and GPLv2+ and GPLv2
125     Group: Video
126     BuildRoot: %{_tmppath}/%{name}-root
127     BuildRequires: boost-devel
128     BuildRequires: ffmpeg-devel
129     BuildRequires: libmpeg2dec-devel
130     BuildRequires: libogg-devel
131     BuildRequires: libwavpack-devel
132     BuildRequires: python-devel
133     BuildRequires: glew-devel
134     BuildRequires: mesagl-devel
135     BuildRequires: mesaglu-devel
136     BuildRequires: libmad-devel
137     BuildRequires: libjpeg-devel
138     BuildRequires: libsamplerate-devel
139     BuildRequires: libvorbis-devel
140     BuildRequires: bzip2-devel
141     BuildRequires: mysql-devel
142     BuildRequires: liblzo2-devel
143     BuildRequires: zlib-devel
144     BuildRequires: openssl-devel
145     BuildRequires: fontconfig-devel
146     BuildRequires: fribidi-devel
147     BuildRequires: sqlite3-devel
148     BuildRequires: libpng-devel
149     BuildRequires: libpcre-devel
150     BuildRequires: libcdio-devel
151     BuildRequires: libmms-devel
152     BuildRequires: freetype2-devel
153     BuildRequires: libflac-devel
154     BuildRequires: libsmbclient-devel
155     BuildRequires: SDL_mixer-devel
156     BuildRequires: libjasper-devel
157     BuildRequires: libtiff-devel
158     BuildRequires: SDL_image-devel
159     BuildRequires: libalsa-devel
160     BuildRequires: enca-devel
161     BuildRequires: libxt-devel
162     BuildRequires: libxtst-devel
163     BuildRequires: libxmu-devel
164     BuildRequires: libxinerama-devel
165     BuildRequires: libcurl-devel
166     BuildRequires: dbus-devel
167     BuildRequires: hal-devel
168     BuildRequires: SDL-devel
169     BuildRequires: pulseaudio-devel
170     BuildRequires: avahi-common-devel
171     BuildRequires: avahi-client-devel
172     BuildRequires: libxrandr-devel
173     BuildRequires: vdpau-devel
174     BuildRequires: cwiid-devel
175     BuildRequires: libice-devel
176     BuildRequires: libx11-devel
177     BuildRequires: crystalhd-devel
178     BuildRequires: libmicrohttpd-devel
179     BuildRequires: libmodplug-devel
180     BuildRequires: ssh-devel
181     BuildRequires: libva-devel
182     BuildRequires: gettext-devel
183     BuildRequires: expat-devel
184     BuildRequires: libass-devel
185     BuildRequires: rtmp-devel
186     BuildRequires: bluray-devel
187     BuildRequires: bluez-devel
188     BuildRequires: cmake
189     BuildRequires: gperf
190     BuildRequires: zip
191     %ifarch %ix86
192     BuildRequires: nasm
193     %endif
194     %if !%system_python
195     # python-imaging
196     BuildRequires: lcms-devel
197     %endif
198     Requires: lsb-release
199     # dlopened (existence check required by rpm5 as it doesn't use stderr):
200     %define dlopenreq() %([ -e %{_libdir}/lib%{1}.so ] && rpm -qf --qf '%%{name}' $(readlink -f %{_libdir}/lib%{1}.so) 2>/dev/null || echo %{name})
201     Requires: %dlopenreq curl
202     Requires: %dlopenreq FLAC
203     Requires: %dlopenreq mad
204     Requires: %dlopenreq ogg
205     Requires: %dlopenreq vorbis
206     Requires: %dlopenreq vorbisenc
207     Requires: %dlopenreq vorbisfile
208     Requires: %dlopenreq modplug
209     Requires: %dlopenreq rtmp
210     # not nearly as common as the above, so just suggest instead for now:
211     Suggests: %dlopenreq bluray
212     Suggests: %dlopenreq crystalhd
213     # for FEH.py, to check current configuration is ok for xbmc:
214     Requires: xdpyinfo
215     Requires: glxinfo
216     # for FEH.py to allow it to give an error message (should be available already
217     # on most systems):
218     Requires: pygtk2
219     %if %system_python
220     # for xbmc python scripts:
221     Requires: python-imaging
222     Requires: python-sqlite2
223     %endif
224     # Packages not shipped by Mandriva:
225     Suggests: %{_lib}faad2_2
226     Suggests: %{_lib}lame0
227     Suggests: %{_lib}dca0
228     Suggests: %{_lib}dvdcss2
229    
230     # Packages have been merged
231     Obsoletes: xbmc-core < 9.11-1.svn29468
232     Obsoletes: xbmc-skin-confluence < 9.11-1.svn29468
233     Obsoletes: xbmc-skin-pm3-hd < 9.11-1.svn29468
234     Obsoletes: xbmc-nosefart < 9.11-1.svn29468
235     Obsoletes: xbmc-screensavers-default < 9.11-1.svn29468
236     Obsoletes: xbmc-script-examples < 9.11-1.svn27796
237     Obsoletes: xbmc-web-pm3 < 9.11-1.svn27796
238    
239     %description
240     XBMC is an award-winning free and open source software media player
241     and entertainment hub for digital media.
242    
243     While XBMC functions very well as a standard media player application
244     for your computer, it has been designed to be the perfect companion
245     for your HTPC. Supporting an almost endless range of remote controls,
246     and combined with its beautiful interface and powerful skinning
247     engine, XBMC feels very natural to use from the couch and is the
248     ideal solution for your home theater.
249    
250     This is the stable version of XBMC from the dharma release branch,
251     with PVR support added from opdenkamp Dharma-pvr branch. Support for
252     RAR files and XBMS protocol is not included due to license issues.
253    
254     %package eventclients-common
255     Summary: Common files for XBMC eventclients
256     Group: Video
257     %py_requires
258    
259     %description eventclients-common
260     XBMC is an award-winning free and open source software media player
261     and entertainment hub for digital media.
262    
263     This package contains common files for eventclients.
264    
265     %package eventclients-devel
266     Summary: Development files for XBMC eventclients
267     Group: Development/C
268    
269     %description eventclients-devel
270     XBMC is an award-winning free and open source software media player
271     and entertainment hub for digital media.
272    
273     This package contains files needed to build eventclients.
274    
275     %package eventclient-wiiremote
276     Summary: Wii Remote eventclient for XBMC
277     Group: Video
278     Requires: %{name}-eventclients-common = %{version}-%{release}
279    
280     %description eventclient-wiiremote
281     XBMC is an award-winning free and open source software media player
282     and entertainment hub for digital media.
283    
284     This package contains the Wii Remote eventclient.
285    
286     %package eventclient-j2me
287     Summary: J2ME eventclient for XBMC
288     Group: Video
289     Requires: python-pybluez
290     Requires: %{name}-eventclients-common = %{version}-%{release}
291    
292     %description eventclient-j2me
293     XBMC is an award-winning free and open source software media player
294     and entertainment hub for digital media.
295    
296     This package contains the J2ME eventclient, providing a bluetooth
297     server that can communicate with a mobile tool supporting J2ME.
298    
299     %package eventclient-ps3
300     Summary: PS3 eventclients for XBMC
301     Group: Video
302     Requires: python-pybluez
303     Requires: %{name}-eventclients-common = %{version}-%{release}
304     # requires via zeroconf.py, only used by xbmc-ps3d:
305     Requires: python-gobject avahi-python python-dbus
306     # TODO merge all these?, and TODO zeroconf.py to a correct package? :)
307     Obsoletes: eventclient-ps3remote < 9.11-1.svn31936
308    
309     %description eventclient-ps3
310     XBMC is an award-winning free and open source software media player
311     and entertainment hub for digital media.
312    
313     This package contains the PS3 remote and sixaxis eventclients.
314    
315     %package eventclient-xbmc-send
316     Summary: PS3 eventclient for XBMC
317     Group: Video
318     Requires: %{name}-eventclients-common = %{version}-%{release}
319    
320     %description eventclient-xbmc-send
321     XBMC is an award-winning free and open source software media player
322     and entertainment hub for digital media.
323    
324     This package contains the xbmc-send eventclient.
325    
326     %prep
327 anssi 93516 %if %snap
328     %setup -q -n %name-%branch_release-%snap
329 ennael 78010 %else
330     %setup -q
331     %endif
332     %apply_patches
333     # otherwise backups end up in binary rpms
334     find -type f \( -name '*.00??' -o -name '*.00??~' \) -print -delete
335    
336     # remove prebuilt libraries
337     find -type f \( -iname '*.so' -o -iname '*.dll' -o -iname '*.exe' \) -delete
338    
339     # GPLv2 only
340     rm -r xbmc/lib/cmyth/Win32/include/mysql
341     # BSD 4-clause
342     rm -r xbmc/cores/DllLoader/exports/emu_socket
343    
344     # rm disabled stuff to detect possible bugs
345     rm -rf xbmc/cores/dvdplayer/Codecs/{libdts,liba52} xbmc/cores/paplayer/AC3Codec/liba52
346    
347     # win32 only
348     rm -rf system/players/dvdplayer/etc/fonts
349    
350     %if !%system_python
351     cp %{SOURCE11} lib/addons/script.module.pil
352     cp %{SOURCE12} lib/addons/script.module.pysqlite
353    
354     # we need to fix the lookup directories (otherwise setup.py queries
355     # incorrect information from the bundled python)
356     tar -xzf %{SOURCE11} -C lib/addons/script.module.pil
357     sed -ri 's|^([A-Z0-9]+_ROOT =) None|\1 "%{_libdir}", "%{_includedir}"|' lib/addons/script.module.pil/Imaging-*/setup.py
358     %endif
359    
360     %build
361 anssi 93516 %if %snap
362     export GIT_REV=%snap
363 ennael 78010 %else
364 anssi 93516 export GIT_REV=$(basename %SOURCE0)
365 ennael 78010 %endif
366     ./bootstrap
367    
368     # due to xbmc modules that use symbols from xbmc binary
369     # and are not using libtool
370     %define _disable_ld_no_undefined 1
371    
372 anssi 93516 # Workaround configure using git to override GIT_REV (TODO: fix it properly)
373     export ac_cv_prog_HAVE_GIT="no"
374    
375 ennael 78010 %configure2_5x \
376     --disable-debug \
377     --disable-ccache \
378     --enable-external-libraries \
379     %if !%system_python
380     --disable-external-python \
381     %endif
382     --disable-non-free \
383     --disable-dvdcss \
384     --disable-faac \
385     --enable-goom \
386     --with-lirc-device=/var/run/lirc/lircd
387    
388     # non-free = unrar + xbms
389     # dvdcss is handled via dlopen when disabled
390     # faac is always handled via libavcodec
391    
392     %make
393     %make -C tools/EventClients wiimote
394    
395     %if !%system_python
396     for dir in lib/addons/script.module.*; do
397     %make -C $dir
398     done
399     %endif
400    
401     %install
402     rm -rf %{buildroot}
403     %makeinstall_std
404     %makeinstall_std -C tools/EventClients
405    
406     # unused
407     rm %{buildroot}%{_datadir}/xsessions/XBMC.desktop
408     # our version of the above:
409     install -d -m755 %{buildroot}%{_sysconfdir}/X11/wmsession.d
410     cat > %{buildroot}%{_sysconfdir}/X11/wmsession.d/15XBMC <<EOF
411     NAME=XBMC
412     ICON=xbmc.png
413     DESC=XBMC Media Center
414     EXEC=%{_bindir}/xbmc-standalone
415     SCRIPT:
416     exec %{_bindir}/xbmc-standalone
417     EOF
418    
419     # unused files, TODO fix this upstream:
420     find %{buildroot}%{_datadir}/xbmc/addons/skin.*/media -name '*.png' -delete
421    
422     ( # for IFS and +x
423     # Check for issues in ELF binaries
424     undefined=
425     fhserr=
426     echo Silencing output of checking symbols and FHS conformance
427     set +x
428     IFS=$'\n'
429     for file in $(find %{buildroot} -type f); do
430     type="$(file "$file")"
431     echo "$type" | grep -q "ELF" || continue
432    
433     # Check that a binary file is not in datadir:
434     echo "$file" | grep -q "%{_datadir}" && fhserr="${fhserr}$file\n"
435    
436     # check for undefined symbols in XBMC modules
437     echo "$type" | grep -q "shared object" || continue
438     for symbol in $(LD_LIBRARY_PATH=$LD_LIBRARY_PATH:%{buildroot}%{_libdir} ldd -r "$file" 2>&1 | grep undefined | awk '{ print $3 }'); do
439     # undefined symbols may also be provided by XBMC:
440     nm -f posix -D --no-demangle --defined-only %{buildroot}%{_libdir}/xbmc/xbmc.bin | grep -q "^$symbol " && continue
441     # The symbol was not provided by XBMC.
442     # Check if it is available through its dependencies:
443     for filename in $(objdump -p %{buildroot}%{_libdir}/xbmc/xbmc.bin | grep NEEDED | awk '{ print $2 }'); do
444     depfile="/%{_lib}/$filename"
445     [ -e "$depfile" ] || depfile="%{_libdir}/$filename"
446     nm -f posix -D --no-demangle --defined-only $depfile | grep -q "^$symbol " && continue 2
447     done
448     # Euphoria references rsxs PNG class, but it is never used at runtime,
449     # so it results in no errors due to RTLD_LAZY being used by xbmc module loader.
450     # _imaging*.so and _sqlite.so are python modules that exist when using bundled python
451     case $file:$symbol in */Euphoria.xbs:_ZN3PNG*|*/_imaging*.so:*|*/_sqlite.so:*) continue; esac
452     # the symbol was not found
453     undefined="${undefined}$file: $symbol\n"
454     done
455     done
456     ok=1
457     [ -n "$undefined" ] && echo -e "$undefined" && echo "Undefined symbols!" && ok=
458     [ -n "$fhserr" ] && echo -e "$fhserr" && echo "Binaries in datadir!" && ok=
459     [ -n "$ok" ]
460     )
461    
462     %clean
463     rm -rf %{buildroot}
464    
465     %files
466     %defattr(-,root,root)
467     %doc %{_docdir}/xbmc
468     %{_sysconfdir}/X11/wmsession.d/15XBMC
469     %{_bindir}/xbmc
470     %{_bindir}/xbmc-standalone
471     %dir %{_libdir}/xbmc
472     %dir %{_libdir}/xbmc/addons
473     %dir %{_libdir}/xbmc/system
474     %dir %{_libdir}/xbmc/system/players
475     %dir %{_libdir}/xbmc/system/players/dvdplayer
476     %dir %{_libdir}/xbmc/system/players/paplayer
477     %dir %{_libdir}/xbmc/system/python
478     %{_libdir}/xbmc/xbmc.bin
479     %{_libdir}/xbmc/xbmc-xrandr
480     %dir %{_libdir}/xbmc/addons/*
481     %{_libdir}/xbmc/addons/*/*.so
482     %{_libdir}/xbmc/addons/*/*.pvr
483     %{_libdir}/xbmc/addons/*/*.vis
484     %{_libdir}/xbmc/addons/*/*.xbs
485     %{_libdir}/xbmc/addons/script.module.*/*.xml
486     %{_libdir}/xbmc/system/ImageLib-*-linux.so
487     %{_libdir}/xbmc/system/hdhomerun-*-linux.so
488     %{_libdir}/xbmc/system/libcpluff-*-linux.so
489     %{_libdir}/xbmc/system/libexif-*-linux.so
490     %{_libdir}/xbmc/system/libid3tag-*-linux.so
491     %{_libdir}/xbmc/system/players/dvdplayer/libdvdnav-*-linux.so
492     %{_libdir}/xbmc/system/players/paplayer/adpcm-*-linux.so
493     %{_libdir}/xbmc/system/players/paplayer/libsidplay2-*-linux.so
494     %{_libdir}/xbmc/system/players/paplayer/nosefart-*-linux.so
495     %{_libdir}/xbmc/system/players/paplayer/stsoundlibrary-*-linux.so
496     %{_libdir}/xbmc/system/players/paplayer/timidity-*-linux.so
497     %{_libdir}/xbmc/system/players/paplayer/vgmstream-*-linux.so
498     %ifarch %ix86
499     %{_libdir}/xbmc/system/players/paplayer/SNESAPU-*-linux.so
500     %endif
501     %{_libdir}/xbmc/system/python/python*-*-linux.so
502     %if !%system_python
503     %{_libdir}/xbmc/addons/script.module.pil/*
504     %{_libdir}/xbmc/addons/script.module.pysqlite/*
505     %{_libdir}/xbmc/system/python/python*.zip
506     %endif
507     %dir %{_datadir}/xbmc
508     %{_datadir}/xbmc/addons
509     %{_datadir}/xbmc/FEH.py
510     %{_datadir}/xbmc/language
511     %{_datadir}/xbmc/media
512     %{_datadir}/xbmc/sounds
513     %{_datadir}/xbmc/system
514     %{_datadir}/xbmc/userdata
515     %{_datadir}/applications/xbmc.desktop
516     %{_iconsdir}/hicolor/*/apps/xbmc.png
517    
518     %files eventclients-common
519     %defattr(-,root,root)
520     %python_sitelib/xbmc
521     %dir %{_datadir}/pixmaps/xbmc
522     %{_datadir}/pixmaps/xbmc/*.png
523    
524     %files eventclients-devel
525     %defattr(-,root,root)
526     %dir %{_includedir}/xbmc
527     %{_includedir}/xbmc/xbmcclient.h
528    
529     %files eventclient-j2me
530     %defattr(-,root,root)
531     %{_bindir}/xbmc-j2meremote
532    
533     %files eventclient-ps3
534     %defattr(-,root,root)
535     %{_bindir}/xbmc-ps3d
536     %{_bindir}/xbmc-ps3remote
537    
538     %files eventclient-xbmc-send
539     %defattr(-,root,root)
540     %{_bindir}/xbmc-send
541    
542     %files eventclient-wiiremote
543     %defattr(-,root,root)
544     %{_bindir}/xbmc-wiiremote
545    
546    

  ViewVC Help
Powered by ViewVC 1.1.30