/[packages]/cauldron/xbmc/current/SPECS/xbmc.spec
ViewVC logotype

Annotation of /cauldron/xbmc/current/SPECS/xbmc.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 132054 - (hide annotations) (download)
Sat Aug 6 08:55:58 2011 UTC (12 years, 8 months ago) by fwang
File size: 18616 byte(s)
SILENT: remove unneeded patch
1 ennael 78010
2     %define name xbmc
3     %define branch_release dharma
4     %define extra_feature pvr
5 anssi 89302 %define version 10.1
6 anssi 93516 %define snap 0
7 fwang 113516 %define rel 3
8 ennael 78010
9 anssi 93516 %if %snap
10 ennael 78010 %define branch %branch_release.%extra_feature
11     %else
12     %define branch %extra_feature
13     %endif
14    
15     %define branchr %([ "%branch" ] && echo .%branch | tr - _)
16    
17     # There are some compatibility issues with the various python addons which
18     # are mostly tested against bundled python only, and there are too many of
19     # them to be checked out and fixed by us for system python compatibility.
20     # Additional issues are caused by the bundled python having several system
21     # calls redirected through xbmc VFS layer, which doesn't currently work when
22     # using the system python. Usage of system python can probably be safely
23     # re-enabled when XBMC upstream migrates away from python 2.4 and fixes the
24     # issues regarding external python (this is planned). -Anssi 11/2010
25     %define system_python 0
26    
27     # using system python2.7+ reportedly causes problems with
28     # getcwd() and chdir() calls from python
29     # http://trac.xbmc.org/ticket/8658
30     %define system_python 0
31    
32     Summary: XBMC Media Center - media player and home entertainment system
33     Name: %{name}
34     Version: %{version}
35 anssi 93516 %if %snap
36     Release: %mkrel 0.svn%snap%branchr.%rel
37 ennael 78010 # REV=$(git log -1 origin/Dharma | grep git-svn-id | sed -ne 's,^.*@\([^ ]\+\).*$,\1,p')
38     # git archive --prefix=xbmc-dharma-$REV/ origin/Dharma | xz > xbmc-dharma-$REV.tar.xz
39 anssi 93516 Source: %{name}-%branch_release-%snap.tar.xz
40 ennael 78010 %else
41     Release: %mkrel 1.%branch.%rel
42     Source: %{name}-%{version}.tar.gz
43     %endif
44     URL: http://xbmc.org/
45    
46     # needed modules when using bundled python (versions are those expected by the Makefiles):
47     Source11: http://www.effbot.org/downloads/Imaging-1.1.7.tar.gz
48     Source12: http://pysqlite.googlecode.com/files/pysqlite-2.5.6.tar.gz
49    
50     # bring snapshot up-to-date with pvr branch
51     # https://github.com/opdenkamp/xbmc/tree/Dharma-pvr
52     Patch0: xbmc-10.0-opdenkamp-pvr-fdb057b7754.patch
53    
54     # bring snapshot up-to-date with main branch (patches rediffed for pvr):
55     # already up-to-date
56     #Patch18: xbmc-dharma-r35305-r%svnsnap.patch
57    
58     # VDPAU backports from upstream master
59     Patch31: 0001-changed-split-CDVDVideoCodecFFmpeg-GetPicture.patch
60     Patch32: 0002-fixed-VDPAU-temporal-deinterlacer-was-not-provided-e.patch
61     Patch33: 0003-changed-allow-VDPAU-reverse-telecine-when-deinterlac.patch
62     Patch34: 0004-fixed-VDPAU-reverse-telecine.patch
63     Patch35: 0005-changed-enable-VDPAU-temporal-deinterlacer-when-temp.patch
64     Patch36: 0006-fixed-flush-VDPAU-video-surfaces-and-picture-queue-w.patch
65     Patch37: 0007-fixed-picture.iDuration-0-comparison.patch
66     Patch38: 0008-fixed-vdpau-needs-to-memset-its-DVDVideoPicture-stru.patch
67    
68     # backports from upstream master
69     Patch40: 0001-added-note-in-linux-crashlog-if-gdb-is-not-installed.patch
70     Patch41: 0001-Added-9763-Fix-64-bit-WiiRemote-connection-issues-Th.patch
71    
72 fwang 132032 # adopt to new ffmpeg api (upstream patch)
73     Patch51: 773159bea90303826ad21e061e95793efddcff44.patch
74     Patch52: cd0ccf86d3868708cde37ee231d45df283027745.patch
75 fwang 132036 Patch53: 7ec64dc154bafbc0ed42b2a4970e10402afa6362.patch
76 fwang 132037 Patch54: b9103e3522625e6c5349d37370989753a3da3960.patch
77 fwang 132032
78 ennael 78010 # Disable updates of the default skin. Our one is the PVR version, while the
79     # one in the XBMC.org addon repository would be the vanilla one (Confluence
80     # is currently not in the addon repository, though, as of 2010-10).
81     Patch60: xbmc-disable-confluence-update.patch
82    
83     # Workaround http://www.nvnews.net/vbulletin/showthread.php?t=156665
84     # by forcing SDL to use alsa when pulse is disabled and nvidia proprietary
85     # driver version 260.x.y older than 260.19.21 is active.
86     Patch61: 0001-added-workaround-for-crash-with-nonpulse-nvidia260.patch
87    
88     # forkpty and openpty are in -lutil
89     Patch62: 0001-fixed-undefined-symbols-in-internal-python.patch
90    
91     # Ensure backward-compatibility with pvr-testing2 and prevent future compatibility
92     # issues with trunk Addons database format
93     Patch63: 0001-changed-use-the-legacy-pvr-testing2-addon-database.patch
94    
95     # Do not use avg_frame_rate for mkv files on 2010.1 and older, instead
96     # use time_base if needed (fixes MicroDVD subtitles with 23.976 H.264 mkv)
97     Patch65: xbmc-old-libavformat-mkv-subs.patch
98    
99     # build faad support with internal headers, but do not build the
100     # internal library; use system lib with dlopen instead;
101     # this allows keeping it as an optional external library
102     Patch70: xbmc-hack-ext-faad-with-int-headers.patch
103    
104     # CVE fixes for the internal python
105     Patch81: 0001-fixed-CVE-2007-2052-in-internal-python-Mandriva.patch
106     Patch82: 0002-fixed-CVE-2007-4965-in-internal-python-upstream.patch
107     Patch83: 0003-fixed-CVE-2008-1679-in-internal-python-upstream.patch
108     Patch84: 0004-fixed-CVE-2008-1887-in-internal-python-upstream.patch
109     Patch85: 0005-fixed-CVE-2008-1721-in-internal-python-upstream.patch
110     Patch86: 0006-fixed-CVE-2008-2315-in-internal-python-Gentoo.patch
111     Patch87: 0007-fixed-CVE-2008-3142-in-internal-python-Gentoo.patch
112     Patch88: 0008-fixed-CVE-2008-3144-in-internal-python-Gentoo.patch
113     Patch89: 0009-fixed-CVE-2008-4864-in-internal-python-Mandriva.patch
114     Patch90: 0010-fixed-CVE-2008-5031-in-internal-python-upstream.patch
115     Patch91: 0011-fixed-CVE-2010-1634-in-internal-python-Mandriva.patch
116     Patch92: 0012-fixed-CVE-2010-2089-in-internal-python-Mandriva.patch
117     Patch93: 0013-fixed-CVE-2009-2625-in-internal-python-Mandriva.patch
118     Patch94: 0014-fixed-CVE-2010-3492-in-internal-python-Mandriva.patch
119     Patch95: 0015-fixed-CVE-2010-3493-in-internal-python-Mandriva.patch
120    
121 fwang 132032
122 ennael 78010 # nosefart audio plugin and RSXS-0.9 based screensavers are GPLv2 only
123     # libhts, libhdhomerun and several eventclients are GPLv3+
124     # the rest is GPLv2+
125     License: GPLv3+ and GPLv2+ and GPLv2
126     Group: Video
127     BuildRoot: %{_tmppath}/%{name}-root
128     BuildRequires: boost-devel
129     BuildRequires: ffmpeg-devel
130     BuildRequires: libmpeg2dec-devel
131     BuildRequires: libogg-devel
132     BuildRequires: libwavpack-devel
133     BuildRequires: python-devel
134     BuildRequires: glew-devel
135     BuildRequires: mesagl-devel
136     BuildRequires: mesaglu-devel
137     BuildRequires: libmad-devel
138     BuildRequires: libjpeg-devel
139     BuildRequires: libsamplerate-devel
140     BuildRequires: libvorbis-devel
141     BuildRequires: bzip2-devel
142     BuildRequires: mysql-devel
143     BuildRequires: liblzo2-devel
144     BuildRequires: zlib-devel
145     BuildRequires: openssl-devel
146     BuildRequires: fontconfig-devel
147     BuildRequires: fribidi-devel
148     BuildRequires: sqlite3-devel
149     BuildRequires: libpng-devel
150     BuildRequires: libpcre-devel
151     BuildRequires: libcdio-devel
152     BuildRequires: libmms-devel
153     BuildRequires: freetype2-devel
154     BuildRequires: libflac-devel
155     BuildRequires: libsmbclient-devel
156     BuildRequires: SDL_mixer-devel
157     BuildRequires: libjasper-devel
158     BuildRequires: libtiff-devel
159     BuildRequires: SDL_image-devel
160     BuildRequires: libalsa-devel
161     BuildRequires: enca-devel
162     BuildRequires: libxt-devel
163     BuildRequires: libxtst-devel
164     BuildRequires: libxmu-devel
165     BuildRequires: libxinerama-devel
166     BuildRequires: libcurl-devel
167     BuildRequires: dbus-devel
168     BuildRequires: hal-devel
169     BuildRequires: SDL-devel
170     BuildRequires: pulseaudio-devel
171     BuildRequires: avahi-common-devel
172     BuildRequires: avahi-client-devel
173     BuildRequires: libxrandr-devel
174     BuildRequires: vdpau-devel
175     BuildRequires: cwiid-devel
176     BuildRequires: libice-devel
177     BuildRequires: libx11-devel
178     BuildRequires: crystalhd-devel
179     BuildRequires: libmicrohttpd-devel
180     BuildRequires: libmodplug-devel
181     BuildRequires: ssh-devel
182     BuildRequires: libva-devel
183     BuildRequires: gettext-devel
184     BuildRequires: expat-devel
185     BuildRequires: libass-devel
186     BuildRequires: rtmp-devel
187     BuildRequires: bluray-devel
188     BuildRequires: bluez-devel
189     BuildRequires: cmake
190     BuildRequires: gperf
191     BuildRequires: zip
192     %ifarch %ix86
193     BuildRequires: nasm
194     %endif
195     %if !%system_python
196     # python-imaging
197     BuildRequires: lcms-devel
198     %endif
199     Requires: lsb-release
200     # dlopened (existence check required by rpm5 as it doesn't use stderr):
201     %define dlopenreq() %([ -e %{_libdir}/lib%{1}.so ] && rpm -qf --qf '%%{name}' $(readlink -f %{_libdir}/lib%{1}.so) 2>/dev/null || echo %{name})
202     Requires: %dlopenreq curl
203     Requires: %dlopenreq FLAC
204     Requires: %dlopenreq mad
205     Requires: %dlopenreq ogg
206     Requires: %dlopenreq vorbis
207     Requires: %dlopenreq vorbisenc
208     Requires: %dlopenreq vorbisfile
209     Requires: %dlopenreq modplug
210     Requires: %dlopenreq rtmp
211     # not nearly as common as the above, so just suggest instead for now:
212     Suggests: %dlopenreq bluray
213     Suggests: %dlopenreq crystalhd
214     # for FEH.py, to check current configuration is ok for xbmc:
215     Requires: xdpyinfo
216     Requires: glxinfo
217     # for FEH.py to allow it to give an error message (should be available already
218     # on most systems):
219     Requires: pygtk2
220     %if %system_python
221     # for xbmc python scripts:
222     Requires: python-imaging
223     Requires: python-sqlite2
224     %endif
225     # Packages not shipped by Mandriva:
226     Suggests: %{_lib}faad2_2
227     Suggests: %{_lib}lame0
228     Suggests: %{_lib}dca0
229     Suggests: %{_lib}dvdcss2
230    
231     # Packages have been merged
232     Obsoletes: xbmc-core < 9.11-1.svn29468
233     Obsoletes: xbmc-skin-confluence < 9.11-1.svn29468
234     Obsoletes: xbmc-skin-pm3-hd < 9.11-1.svn29468
235     Obsoletes: xbmc-nosefart < 9.11-1.svn29468
236     Obsoletes: xbmc-screensavers-default < 9.11-1.svn29468
237     Obsoletes: xbmc-script-examples < 9.11-1.svn27796
238     Obsoletes: xbmc-web-pm3 < 9.11-1.svn27796
239    
240     %description
241     XBMC is an award-winning free and open source software media player
242     and entertainment hub for digital media.
243    
244     While XBMC functions very well as a standard media player application
245     for your computer, it has been designed to be the perfect companion
246     for your HTPC. Supporting an almost endless range of remote controls,
247     and combined with its beautiful interface and powerful skinning
248     engine, XBMC feels very natural to use from the couch and is the
249     ideal solution for your home theater.
250    
251     This is the stable version of XBMC from the dharma release branch,
252     with PVR support added from opdenkamp Dharma-pvr branch. Support for
253     RAR files and XBMS protocol is not included due to license issues.
254    
255     %package eventclients-common
256     Summary: Common files for XBMC eventclients
257     Group: Video
258     %py_requires
259    
260     %description eventclients-common
261     XBMC is an award-winning free and open source software media player
262     and entertainment hub for digital media.
263    
264     This package contains common files for eventclients.
265    
266     %package eventclients-devel
267     Summary: Development files for XBMC eventclients
268     Group: Development/C
269    
270     %description eventclients-devel
271     XBMC is an award-winning free and open source software media player
272     and entertainment hub for digital media.
273    
274     This package contains files needed to build eventclients.
275    
276     %package eventclient-wiiremote
277     Summary: Wii Remote eventclient for XBMC
278     Group: Video
279     Requires: %{name}-eventclients-common = %{version}-%{release}
280    
281     %description eventclient-wiiremote
282     XBMC is an award-winning free and open source software media player
283     and entertainment hub for digital media.
284    
285     This package contains the Wii Remote eventclient.
286    
287     %package eventclient-j2me
288     Summary: J2ME eventclient for XBMC
289     Group: Video
290     Requires: python-pybluez
291     Requires: %{name}-eventclients-common = %{version}-%{release}
292    
293     %description eventclient-j2me
294     XBMC is an award-winning free and open source software media player
295     and entertainment hub for digital media.
296    
297     This package contains the J2ME eventclient, providing a bluetooth
298     server that can communicate with a mobile tool supporting J2ME.
299    
300     %package eventclient-ps3
301     Summary: PS3 eventclients for XBMC
302     Group: Video
303     Requires: python-pybluez
304     Requires: %{name}-eventclients-common = %{version}-%{release}
305     # requires via zeroconf.py, only used by xbmc-ps3d:
306     Requires: python-gobject avahi-python python-dbus
307     # TODO merge all these?, and TODO zeroconf.py to a correct package? :)
308     Obsoletes: eventclient-ps3remote < 9.11-1.svn31936
309    
310     %description eventclient-ps3
311     XBMC is an award-winning free and open source software media player
312     and entertainment hub for digital media.
313    
314     This package contains the PS3 remote and sixaxis eventclients.
315    
316     %package eventclient-xbmc-send
317     Summary: PS3 eventclient for XBMC
318     Group: Video
319     Requires: %{name}-eventclients-common = %{version}-%{release}
320    
321     %description eventclient-xbmc-send
322     XBMC is an award-winning free and open source software media player
323     and entertainment hub for digital media.
324    
325     This package contains the xbmc-send eventclient.
326    
327     %prep
328 anssi 93516 %if %snap
329     %setup -q -n %name-%branch_release-%snap
330 ennael 78010 %else
331     %setup -q
332     %endif
333     %apply_patches
334     # otherwise backups end up in binary rpms
335     find -type f \( -name '*.00??' -o -name '*.00??~' \) -print -delete
336    
337     # remove prebuilt libraries
338     find -type f \( -iname '*.so' -o -iname '*.dll' -o -iname '*.exe' \) -delete
339    
340     # GPLv2 only
341     rm -r xbmc/lib/cmyth/Win32/include/mysql
342     # BSD 4-clause
343     rm -r xbmc/cores/DllLoader/exports/emu_socket
344    
345     # rm disabled stuff to detect possible bugs
346     rm -rf xbmc/cores/dvdplayer/Codecs/{libdts,liba52} xbmc/cores/paplayer/AC3Codec/liba52
347    
348     # win32 only
349     rm -rf system/players/dvdplayer/etc/fonts
350    
351     %if !%system_python
352     cp %{SOURCE11} lib/addons/script.module.pil
353     cp %{SOURCE12} lib/addons/script.module.pysqlite
354    
355     # we need to fix the lookup directories (otherwise setup.py queries
356     # incorrect information from the bundled python)
357     tar -xzf %{SOURCE11} -C lib/addons/script.module.pil
358     sed -ri 's|^([A-Z0-9]+_ROOT =) None|\1 "%{_libdir}", "%{_includedir}"|' lib/addons/script.module.pil/Imaging-*/setup.py
359     %endif
360    
361     %build
362 anssi 93516 %if %snap
363     export GIT_REV=%snap
364 ennael 78010 %else
365 anssi 93516 export GIT_REV=$(basename %SOURCE0)
366 ennael 78010 %endif
367     ./bootstrap
368    
369     # due to xbmc modules that use symbols from xbmc binary
370     # and are not using libtool
371     %define _disable_ld_no_undefined 1
372    
373 anssi 93516 # Workaround configure using git to override GIT_REV (TODO: fix it properly)
374     export ac_cv_prog_HAVE_GIT="no"
375    
376 ennael 78010 %configure2_5x \
377     --disable-debug \
378     --disable-ccache \
379     --enable-external-libraries \
380 fwang 132053 --disable-external-ffmpeg \
381 ennael 78010 %if !%system_python
382     --disable-external-python \
383     %endif
384     --disable-non-free \
385     --disable-dvdcss \
386     --disable-faac \
387     --enable-goom \
388     --with-lirc-device=/var/run/lirc/lircd
389    
390     # non-free = unrar + xbms
391     # dvdcss is handled via dlopen when disabled
392     # faac is always handled via libavcodec
393    
394     %make
395     %make -C tools/EventClients wiimote
396    
397     %if !%system_python
398     for dir in lib/addons/script.module.*; do
399     %make -C $dir
400     done
401     %endif
402    
403     %install
404     rm -rf %{buildroot}
405     %makeinstall_std
406     %makeinstall_std -C tools/EventClients
407    
408     # unused
409     rm %{buildroot}%{_datadir}/xsessions/XBMC.desktop
410     # our version of the above:
411     install -d -m755 %{buildroot}%{_sysconfdir}/X11/wmsession.d
412     cat > %{buildroot}%{_sysconfdir}/X11/wmsession.d/15XBMC <<EOF
413     NAME=XBMC
414     ICON=xbmc.png
415     DESC=XBMC Media Center
416     EXEC=%{_bindir}/xbmc-standalone
417     SCRIPT:
418     exec %{_bindir}/xbmc-standalone
419     EOF
420    
421     # unused files, TODO fix this upstream:
422     find %{buildroot}%{_datadir}/xbmc/addons/skin.*/media -name '*.png' -delete
423    
424     ( # for IFS and +x
425     # Check for issues in ELF binaries
426     undefined=
427     fhserr=
428     echo Silencing output of checking symbols and FHS conformance
429     set +x
430     IFS=$'\n'
431     for file in $(find %{buildroot} -type f); do
432     type="$(file "$file")"
433     echo "$type" | grep -q "ELF" || continue
434    
435     # Check that a binary file is not in datadir:
436     echo "$file" | grep -q "%{_datadir}" && fhserr="${fhserr}$file\n"
437    
438     # check for undefined symbols in XBMC modules
439     echo "$type" | grep -q "shared object" || continue
440     for symbol in $(LD_LIBRARY_PATH=$LD_LIBRARY_PATH:%{buildroot}%{_libdir} ldd -r "$file" 2>&1 | grep undefined | awk '{ print $3 }'); do
441     # undefined symbols may also be provided by XBMC:
442     nm -f posix -D --no-demangle --defined-only %{buildroot}%{_libdir}/xbmc/xbmc.bin | grep -q "^$symbol " && continue
443     # The symbol was not provided by XBMC.
444     # Check if it is available through its dependencies:
445     for filename in $(objdump -p %{buildroot}%{_libdir}/xbmc/xbmc.bin | grep NEEDED | awk '{ print $2 }'); do
446     depfile="/%{_lib}/$filename"
447     [ -e "$depfile" ] || depfile="%{_libdir}/$filename"
448     nm -f posix -D --no-demangle --defined-only $depfile | grep -q "^$symbol " && continue 2
449     done
450     # Euphoria references rsxs PNG class, but it is never used at runtime,
451     # so it results in no errors due to RTLD_LAZY being used by xbmc module loader.
452     # _imaging*.so and _sqlite.so are python modules that exist when using bundled python
453     case $file:$symbol in */Euphoria.xbs:_ZN3PNG*|*/_imaging*.so:*|*/_sqlite.so:*) continue; esac
454     # the symbol was not found
455     undefined="${undefined}$file: $symbol\n"
456     done
457     done
458     ok=1
459     [ -n "$undefined" ] && echo -e "$undefined" && echo "Undefined symbols!" && ok=
460     [ -n "$fhserr" ] && echo -e "$fhserr" && echo "Binaries in datadir!" && ok=
461     [ -n "$ok" ]
462     )
463    
464     %clean
465     rm -rf %{buildroot}
466    
467     %files
468     %defattr(-,root,root)
469     %doc %{_docdir}/xbmc
470     %{_sysconfdir}/X11/wmsession.d/15XBMC
471     %{_bindir}/xbmc
472     %{_bindir}/xbmc-standalone
473     %dir %{_libdir}/xbmc
474     %dir %{_libdir}/xbmc/addons
475     %dir %{_libdir}/xbmc/system
476     %dir %{_libdir}/xbmc/system/players
477     %dir %{_libdir}/xbmc/system/players/dvdplayer
478     %dir %{_libdir}/xbmc/system/players/paplayer
479     %dir %{_libdir}/xbmc/system/python
480     %{_libdir}/xbmc/xbmc.bin
481     %{_libdir}/xbmc/xbmc-xrandr
482     %dir %{_libdir}/xbmc/addons/*
483     %{_libdir}/xbmc/addons/*/*.so
484     %{_libdir}/xbmc/addons/*/*.pvr
485     %{_libdir}/xbmc/addons/*/*.vis
486     %{_libdir}/xbmc/addons/*/*.xbs
487     %{_libdir}/xbmc/addons/script.module.*/*.xml
488     %{_libdir}/xbmc/system/ImageLib-*-linux.so
489     %{_libdir}/xbmc/system/hdhomerun-*-linux.so
490     %{_libdir}/xbmc/system/libcpluff-*-linux.so
491     %{_libdir}/xbmc/system/libexif-*-linux.so
492     %{_libdir}/xbmc/system/libid3tag-*-linux.so
493     %{_libdir}/xbmc/system/players/dvdplayer/libdvdnav-*-linux.so
494     %{_libdir}/xbmc/system/players/paplayer/adpcm-*-linux.so
495     %{_libdir}/xbmc/system/players/paplayer/libsidplay2-*-linux.so
496     %{_libdir}/xbmc/system/players/paplayer/nosefart-*-linux.so
497     %{_libdir}/xbmc/system/players/paplayer/stsoundlibrary-*-linux.so
498     %{_libdir}/xbmc/system/players/paplayer/timidity-*-linux.so
499     %{_libdir}/xbmc/system/players/paplayer/vgmstream-*-linux.so
500     %ifarch %ix86
501     %{_libdir}/xbmc/system/players/paplayer/SNESAPU-*-linux.so
502     %endif
503     %{_libdir}/xbmc/system/python/python*-*-linux.so
504     %if !%system_python
505     %{_libdir}/xbmc/addons/script.module.pil/*
506     %{_libdir}/xbmc/addons/script.module.pysqlite/*
507     %{_libdir}/xbmc/system/python/python*.zip
508     %endif
509     %dir %{_datadir}/xbmc
510     %{_datadir}/xbmc/addons
511     %{_datadir}/xbmc/FEH.py
512     %{_datadir}/xbmc/language
513     %{_datadir}/xbmc/media
514     %{_datadir}/xbmc/sounds
515     %{_datadir}/xbmc/system
516     %{_datadir}/xbmc/userdata
517     %{_datadir}/applications/xbmc.desktop
518     %{_iconsdir}/hicolor/*/apps/xbmc.png
519    
520     %files eventclients-common
521     %defattr(-,root,root)
522     %python_sitelib/xbmc
523     %dir %{_datadir}/pixmaps/xbmc
524     %{_datadir}/pixmaps/xbmc/*.png
525    
526     %files eventclients-devel
527     %defattr(-,root,root)
528     %dir %{_includedir}/xbmc
529     %{_includedir}/xbmc/xbmcclient.h
530    
531     %files eventclient-j2me
532     %defattr(-,root,root)
533     %{_bindir}/xbmc-j2meremote
534    
535     %files eventclient-ps3
536     %defattr(-,root,root)
537     %{_bindir}/xbmc-ps3d
538     %{_bindir}/xbmc-ps3remote
539    
540     %files eventclient-xbmc-send
541     %defattr(-,root,root)
542     %{_bindir}/xbmc-send
543    
544     %files eventclient-wiiremote
545     %defattr(-,root,root)
546     %{_bindir}/xbmc-wiiremote
547    
548    

  ViewVC Help
Powered by ViewVC 1.1.30