/[packages]/cauldron/xbmc/current/SPECS/xbmc.spec
ViewVC logotype

Annotation of /cauldron/xbmc/current/SPECS/xbmc.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 78144 - (hide annotations) (download)
Sun Mar 27 18:41:56 2011 UTC (13 years, 1 month ago) by ennael
File size: 18522 byte(s)
clean spec file

1 ennael 78010
2     %define name xbmc
3     %define branch_release dharma
4     %define extra_feature pvr
5     %define version 10.0
6     # the svn revision of the end-result:
7     %define svnsnap 0
8     # the svn revision of the tarball:
9     # (for stable releases, set basesnap to tag rev (it will be shown in gui
10     # when svnsnap is set to 0)
11     %define basesnap 33648
12     %define rel 4
13    
14     %if %svnsnap
15     %define branch %branch_release.%extra_feature
16     %else
17     %define branch %extra_feature
18     %endif
19    
20     %define branchr %([ "%branch" ] && echo .%branch | tr - _)
21    
22     # There are some compatibility issues with the various python addons which
23     # are mostly tested against bundled python only, and there are too many of
24     # them to be checked out and fixed by us for system python compatibility.
25     # Additional issues are caused by the bundled python having several system
26     # calls redirected through xbmc VFS layer, which doesn't currently work when
27     # using the system python. Usage of system python can probably be safely
28     # re-enabled when XBMC upstream migrates away from python 2.4 and fixes the
29     # issues regarding external python (this is planned). -Anssi 11/2010
30     %define system_python 0
31    
32     # using system python2.7+ reportedly causes problems with
33     # getcwd() and chdir() calls from python
34     # http://trac.xbmc.org/ticket/8658
35     %define system_python 0
36    
37     Summary: XBMC Media Center - media player and home entertainment system
38     Name: %{name}
39     Version: %{version}
40     %if %svnsnap
41     Release: %mkrel 0.svn%svnsnap%branchr.%rel
42     # REV=$(git log -1 origin/Dharma | grep git-svn-id | sed -ne 's,^.*@\([^ ]\+\).*$,\1,p')
43     # git archive --prefix=xbmc-dharma-$REV/ origin/Dharma | xz > xbmc-dharma-$REV.tar.xz
44     Source: %{name}-%branch_release-%basesnap.tar.xz
45     %else
46     Release: %mkrel 1.%branch.%rel
47     Source: %{name}-%{version}.tar.gz
48     %endif
49     URL: http://xbmc.org/
50    
51     # needed modules when using bundled python (versions are those expected by the Makefiles):
52     Source11: http://www.effbot.org/downloads/Imaging-1.1.7.tar.gz
53     Source12: http://pysqlite.googlecode.com/files/pysqlite-2.5.6.tar.gz
54    
55     # bring snapshot up-to-date with pvr branch
56     # https://github.com/opdenkamp/xbmc/tree/Dharma-pvr
57     Patch0: xbmc-10.0-opdenkamp-pvr-fdb057b7754.patch
58    
59     # bring snapshot up-to-date with main branch (patches rediffed for pvr):
60     # already up-to-date
61     #Patch18: xbmc-dharma-r35305-r%svnsnap.patch
62    
63     # VDPAU backports from upstream master
64     Patch31: 0001-changed-split-CDVDVideoCodecFFmpeg-GetPicture.patch
65     Patch32: 0002-fixed-VDPAU-temporal-deinterlacer-was-not-provided-e.patch
66     Patch33: 0003-changed-allow-VDPAU-reverse-telecine-when-deinterlac.patch
67     Patch34: 0004-fixed-VDPAU-reverse-telecine.patch
68     Patch35: 0005-changed-enable-VDPAU-temporal-deinterlacer-when-temp.patch
69     Patch36: 0006-fixed-flush-VDPAU-video-surfaces-and-picture-queue-w.patch
70     Patch37: 0007-fixed-picture.iDuration-0-comparison.patch
71     Patch38: 0008-fixed-vdpau-needs-to-memset-its-DVDVideoPicture-stru.patch
72    
73     # backports from upstream master
74     Patch40: 0001-added-note-in-linux-crashlog-if-gdb-is-not-installed.patch
75     Patch41: 0001-Added-9763-Fix-64-bit-WiiRemote-connection-issues-Th.patch
76    
77     # Disable updates of the default skin. Our one is the PVR version, while the
78     # one in the XBMC.org addon repository would be the vanilla one (Confluence
79     # is currently not in the addon repository, though, as of 2010-10).
80     Patch60: xbmc-disable-confluence-update.patch
81    
82     # Workaround http://www.nvnews.net/vbulletin/showthread.php?t=156665
83     # by forcing SDL to use alsa when pulse is disabled and nvidia proprietary
84     # driver version 260.x.y older than 260.19.21 is active.
85     Patch61: 0001-added-workaround-for-crash-with-nonpulse-nvidia260.patch
86    
87     # forkpty and openpty are in -lutil
88     Patch62: 0001-fixed-undefined-symbols-in-internal-python.patch
89    
90     # Ensure backward-compatibility with pvr-testing2 and prevent future compatibility
91     # issues with trunk Addons database format
92     Patch63: 0001-changed-use-the-legacy-pvr-testing2-addon-database.patch
93    
94     # Do not require ethernet encapsulation for an internet connection
95     Patch64: xbmc-allow-ppp.patch
96    
97     # Do not use avg_frame_rate for mkv files on 2010.1 and older, instead
98     # use time_base if needed (fixes MicroDVD subtitles with 23.976 H.264 mkv)
99     Patch65: xbmc-old-libavformat-mkv-subs.patch
100    
101     # build faad support with internal headers, but do not build the
102     # internal library; use system lib with dlopen instead;
103     # this allows keeping it as an optional external library
104     Patch70: xbmc-hack-ext-faad-with-int-headers.patch
105    
106     # CVE fixes for the internal python
107     Patch81: 0001-fixed-CVE-2007-2052-in-internal-python-Mandriva.patch
108     Patch82: 0002-fixed-CVE-2007-4965-in-internal-python-upstream.patch
109     Patch83: 0003-fixed-CVE-2008-1679-in-internal-python-upstream.patch
110     Patch84: 0004-fixed-CVE-2008-1887-in-internal-python-upstream.patch
111     Patch85: 0005-fixed-CVE-2008-1721-in-internal-python-upstream.patch
112     Patch86: 0006-fixed-CVE-2008-2315-in-internal-python-Gentoo.patch
113     Patch87: 0007-fixed-CVE-2008-3142-in-internal-python-Gentoo.patch
114     Patch88: 0008-fixed-CVE-2008-3144-in-internal-python-Gentoo.patch
115     Patch89: 0009-fixed-CVE-2008-4864-in-internal-python-Mandriva.patch
116     Patch90: 0010-fixed-CVE-2008-5031-in-internal-python-upstream.patch
117     Patch91: 0011-fixed-CVE-2010-1634-in-internal-python-Mandriva.patch
118     Patch92: 0012-fixed-CVE-2010-2089-in-internal-python-Mandriva.patch
119     Patch93: 0013-fixed-CVE-2009-2625-in-internal-python-Mandriva.patch
120     Patch94: 0014-fixed-CVE-2010-3492-in-internal-python-Mandriva.patch
121     Patch95: 0015-fixed-CVE-2010-3493-in-internal-python-Mandriva.patch
122    
123     # nosefart audio plugin and RSXS-0.9 based screensavers are GPLv2 only
124     # libhts, libhdhomerun and several eventclients are GPLv3+
125     # the rest is GPLv2+
126     License: GPLv3+ and GPLv2+ and GPLv2
127     Group: Video
128     BuildRoot: %{_tmppath}/%{name}-root
129     BuildRequires: boost-devel
130     BuildRequires: ffmpeg-devel
131     BuildRequires: libmpeg2dec-devel
132     BuildRequires: libogg-devel
133     BuildRequires: libwavpack-devel
134     BuildRequires: python-devel
135     BuildRequires: glew-devel
136     BuildRequires: mesagl-devel
137     BuildRequires: mesaglu-devel
138     BuildRequires: libmad-devel
139     BuildRequires: libjpeg-devel
140     BuildRequires: libsamplerate-devel
141     BuildRequires: libvorbis-devel
142     BuildRequires: bzip2-devel
143     BuildRequires: mysql-devel
144     BuildRequires: liblzo2-devel
145     BuildRequires: zlib-devel
146     BuildRequires: openssl-devel
147     BuildRequires: fontconfig-devel
148     BuildRequires: fribidi-devel
149     BuildRequires: sqlite3-devel
150     BuildRequires: libpng-devel
151     BuildRequires: libpcre-devel
152     BuildRequires: libcdio-devel
153     BuildRequires: libmms-devel
154     BuildRequires: freetype2-devel
155     BuildRequires: libflac-devel
156     BuildRequires: libsmbclient-devel
157     BuildRequires: SDL_mixer-devel
158     BuildRequires: libjasper-devel
159     BuildRequires: libtiff-devel
160     BuildRequires: SDL_image-devel
161     BuildRequires: libalsa-devel
162     BuildRequires: enca-devel
163     BuildRequires: libxt-devel
164     BuildRequires: libxtst-devel
165     BuildRequires: libxmu-devel
166     BuildRequires: libxinerama-devel
167     BuildRequires: libcurl-devel
168     BuildRequires: dbus-devel
169     BuildRequires: hal-devel
170     BuildRequires: SDL-devel
171     BuildRequires: pulseaudio-devel
172     BuildRequires: avahi-common-devel
173     BuildRequires: avahi-client-devel
174     BuildRequires: libxrandr-devel
175     BuildRequires: vdpau-devel
176     BuildRequires: cwiid-devel
177     BuildRequires: libice-devel
178     BuildRequires: libx11-devel
179     BuildRequires: crystalhd-devel
180     BuildRequires: libmicrohttpd-devel
181     BuildRequires: libmodplug-devel
182     BuildRequires: ssh-devel
183     BuildRequires: libva-devel
184     BuildRequires: gettext-devel
185     BuildRequires: expat-devel
186     BuildRequires: libass-devel
187     BuildRequires: rtmp-devel
188     BuildRequires: bluray-devel
189     BuildRequires: bluez-devel
190     BuildRequires: cmake
191     BuildRequires: gperf
192     BuildRequires: zip
193     %ifarch %ix86
194     BuildRequires: nasm
195     %endif
196     %if !%system_python
197     # python-imaging
198     BuildRequires: lcms-devel
199     %endif
200     Requires: lsb-release
201     # dlopened (existence check required by rpm5 as it doesn't use stderr):
202     %define dlopenreq() %([ -e %{_libdir}/lib%{1}.so ] && rpm -qf --qf '%%{name}' $(readlink -f %{_libdir}/lib%{1}.so) 2>/dev/null || echo %{name})
203     Requires: %dlopenreq curl
204     Requires: %dlopenreq FLAC
205     Requires: %dlopenreq mad
206     Requires: %dlopenreq ogg
207     Requires: %dlopenreq vorbis
208     Requires: %dlopenreq vorbisenc
209     Requires: %dlopenreq vorbisfile
210     Requires: %dlopenreq modplug
211     Requires: %dlopenreq rtmp
212     # not nearly as common as the above, so just suggest instead for now:
213     Suggests: %dlopenreq bluray
214     Suggests: %dlopenreq crystalhd
215     # for FEH.py, to check current configuration is ok for xbmc:
216     Requires: xdpyinfo
217     Requires: glxinfo
218     # for FEH.py to allow it to give an error message (should be available already
219     # on most systems):
220     Requires: pygtk2
221     %if %system_python
222     # for xbmc python scripts:
223     Requires: python-imaging
224     Requires: python-sqlite2
225     %endif
226     # Packages not shipped by Mandriva:
227     Suggests: %{_lib}faad2_2
228     Suggests: %{_lib}lame0
229     Suggests: %{_lib}dca0
230     Suggests: %{_lib}dvdcss2
231    
232     # Packages have been merged
233     Obsoletes: xbmc-core < 9.11-1.svn29468
234     Obsoletes: xbmc-skin-confluence < 9.11-1.svn29468
235     Obsoletes: xbmc-skin-pm3-hd < 9.11-1.svn29468
236     Obsoletes: xbmc-nosefart < 9.11-1.svn29468
237     Obsoletes: xbmc-screensavers-default < 9.11-1.svn29468
238     Obsoletes: xbmc-script-examples < 9.11-1.svn27796
239     Obsoletes: xbmc-web-pm3 < 9.11-1.svn27796
240    
241     %description
242     XBMC is an award-winning free and open source software media player
243     and entertainment hub for digital media.
244    
245     While XBMC functions very well as a standard media player application
246     for your computer, it has been designed to be the perfect companion
247     for your HTPC. Supporting an almost endless range of remote controls,
248     and combined with its beautiful interface and powerful skinning
249     engine, XBMC feels very natural to use from the couch and is the
250     ideal solution for your home theater.
251    
252     This is the stable version of XBMC from the dharma release branch,
253     with PVR support added from opdenkamp Dharma-pvr branch. Support for
254     RAR files and XBMS protocol is not included due to license issues.
255    
256     %package eventclients-common
257     Summary: Common files for XBMC eventclients
258     Group: Video
259     %py_requires
260    
261     %description eventclients-common
262     XBMC is an award-winning free and open source software media player
263     and entertainment hub for digital media.
264    
265     This package contains common files for eventclients.
266    
267     %package eventclients-devel
268     Summary: Development files for XBMC eventclients
269     Group: Development/C
270    
271     %description eventclients-devel
272     XBMC is an award-winning free and open source software media player
273     and entertainment hub for digital media.
274    
275     This package contains files needed to build eventclients.
276    
277     %package eventclient-wiiremote
278     Summary: Wii Remote eventclient for XBMC
279     Group: Video
280     Requires: %{name}-eventclients-common = %{version}-%{release}
281    
282     %description eventclient-wiiremote
283     XBMC is an award-winning free and open source software media player
284     and entertainment hub for digital media.
285    
286     This package contains the Wii Remote eventclient.
287    
288     %package eventclient-j2me
289     Summary: J2ME eventclient for XBMC
290     Group: Video
291     Requires: python-pybluez
292     Requires: %{name}-eventclients-common = %{version}-%{release}
293    
294     %description eventclient-j2me
295     XBMC is an award-winning free and open source software media player
296     and entertainment hub for digital media.
297    
298     This package contains the J2ME eventclient, providing a bluetooth
299     server that can communicate with a mobile tool supporting J2ME.
300    
301     %package eventclient-ps3
302     Summary: PS3 eventclients for XBMC
303     Group: Video
304     Requires: python-pybluez
305     Requires: %{name}-eventclients-common = %{version}-%{release}
306     # requires via zeroconf.py, only used by xbmc-ps3d:
307     Requires: python-gobject avahi-python python-dbus
308     # TODO merge all these?, and TODO zeroconf.py to a correct package? :)
309     Obsoletes: eventclient-ps3remote < 9.11-1.svn31936
310    
311     %description eventclient-ps3
312     XBMC is an award-winning free and open source software media player
313     and entertainment hub for digital media.
314    
315     This package contains the PS3 remote and sixaxis eventclients.
316    
317     %package eventclient-xbmc-send
318     Summary: PS3 eventclient for XBMC
319     Group: Video
320     Requires: %{name}-eventclients-common = %{version}-%{release}
321    
322     %description eventclient-xbmc-send
323     XBMC is an award-winning free and open source software media player
324     and entertainment hub for digital media.
325    
326     This package contains the xbmc-send eventclient.
327    
328     %prep
329     %if %svnsnap
330     %setup -q -n %name-%branch_release-%basesnap
331     %else
332     %setup -q
333     %endif
334     %apply_patches
335     # otherwise backups end up in binary rpms
336     find -type f \( -name '*.00??' -o -name '*.00??~' \) -print -delete
337    
338     # remove prebuilt libraries
339     find -type f \( -iname '*.so' -o -iname '*.dll' -o -iname '*.exe' \) -delete
340    
341     # GPLv2 only
342     rm -r xbmc/lib/cmyth/Win32/include/mysql
343     # BSD 4-clause
344     rm -r xbmc/cores/DllLoader/exports/emu_socket
345    
346     # rm disabled stuff to detect possible bugs
347     rm -rf xbmc/cores/dvdplayer/Codecs/{libdts,liba52} xbmc/cores/paplayer/AC3Codec/liba52
348    
349     # win32 only
350     rm -rf system/players/dvdplayer/etc/fonts
351    
352     %if !%system_python
353     cp %{SOURCE11} lib/addons/script.module.pil
354     cp %{SOURCE12} lib/addons/script.module.pysqlite
355    
356     # we need to fix the lookup directories (otherwise setup.py queries
357     # incorrect information from the bundled python)
358     tar -xzf %{SOURCE11} -C lib/addons/script.module.pil
359     sed -ri 's|^([A-Z0-9]+_ROOT =) None|\1 "%{_libdir}", "%{_includedir}"|' lib/addons/script.module.pil/Imaging-*/setup.py
360     %endif
361    
362     %build
363     %if %svnsnap
364     export SVN_REV=%svnsnap
365     %else
366     export SVN_REV=%basesnap
367     %endif
368     ./bootstrap
369    
370     # due to xbmc modules that use symbols from xbmc binary
371     # and are not using libtool
372     %define _disable_ld_no_undefined 1
373    
374     %configure2_5x \
375     --disable-debug \
376     --disable-ccache \
377     --enable-external-libraries \
378     %if !%system_python
379     --disable-external-python \
380     %endif
381     --disable-non-free \
382     --disable-dvdcss \
383     --disable-faac \
384     --enable-goom \
385     --with-lirc-device=/var/run/lirc/lircd
386    
387     # non-free = unrar + xbms
388     # dvdcss is handled via dlopen when disabled
389     # faac is always handled via libavcodec
390    
391     %make
392     %make -C tools/EventClients wiimote
393    
394     %if !%system_python
395     for dir in lib/addons/script.module.*; do
396     %make -C $dir
397     done
398     %endif
399    
400     %install
401     rm -rf %{buildroot}
402     %makeinstall_std
403     %makeinstall_std -C tools/EventClients
404    
405     # unused
406     rm %{buildroot}%{_datadir}/xsessions/XBMC.desktop
407     # our version of the above:
408     install -d -m755 %{buildroot}%{_sysconfdir}/X11/wmsession.d
409     cat > %{buildroot}%{_sysconfdir}/X11/wmsession.d/15XBMC <<EOF
410     NAME=XBMC
411     ICON=xbmc.png
412     DESC=XBMC Media Center
413     EXEC=%{_bindir}/xbmc-standalone
414     SCRIPT:
415     exec %{_bindir}/xbmc-standalone
416     EOF
417    
418     # unused files, TODO fix this upstream:
419     find %{buildroot}%{_datadir}/xbmc/addons/skin.*/media -name '*.png' -delete
420    
421     ( # for IFS and +x
422     # Check for issues in ELF binaries
423     undefined=
424     fhserr=
425     echo Silencing output of checking symbols and FHS conformance
426     set +x
427     IFS=$'\n'
428     for file in $(find %{buildroot} -type f); do
429     type="$(file "$file")"
430     echo "$type" | grep -q "ELF" || continue
431    
432     # Check that a binary file is not in datadir:
433     echo "$file" | grep -q "%{_datadir}" && fhserr="${fhserr}$file\n"
434    
435     # check for undefined symbols in XBMC modules
436     echo "$type" | grep -q "shared object" || continue
437     for symbol in $(LD_LIBRARY_PATH=$LD_LIBRARY_PATH:%{buildroot}%{_libdir} ldd -r "$file" 2>&1 | grep undefined | awk '{ print $3 }'); do
438     # undefined symbols may also be provided by XBMC:
439     nm -f posix -D --no-demangle --defined-only %{buildroot}%{_libdir}/xbmc/xbmc.bin | grep -q "^$symbol " && continue
440     # The symbol was not provided by XBMC.
441     # Check if it is available through its dependencies:
442     for filename in $(objdump -p %{buildroot}%{_libdir}/xbmc/xbmc.bin | grep NEEDED | awk '{ print $2 }'); do
443     depfile="/%{_lib}/$filename"
444     [ -e "$depfile" ] || depfile="%{_libdir}/$filename"
445     nm -f posix -D --no-demangle --defined-only $depfile | grep -q "^$symbol " && continue 2
446     done
447     # Euphoria references rsxs PNG class, but it is never used at runtime,
448     # so it results in no errors due to RTLD_LAZY being used by xbmc module loader.
449     # _imaging*.so and _sqlite.so are python modules that exist when using bundled python
450     case $file:$symbol in */Euphoria.xbs:_ZN3PNG*|*/_imaging*.so:*|*/_sqlite.so:*) continue; esac
451     # the symbol was not found
452     undefined="${undefined}$file: $symbol\n"
453     done
454     done
455     ok=1
456     [ -n "$undefined" ] && echo -e "$undefined" && echo "Undefined symbols!" && ok=
457     [ -n "$fhserr" ] && echo -e "$fhserr" && echo "Binaries in datadir!" && ok=
458     [ -n "$ok" ]
459     )
460    
461     %clean
462     rm -rf %{buildroot}
463    
464     %files
465     %defattr(-,root,root)
466     %doc %{_docdir}/xbmc
467     %{_sysconfdir}/X11/wmsession.d/15XBMC
468     %{_bindir}/xbmc
469     %{_bindir}/xbmc-standalone
470     %dir %{_libdir}/xbmc
471     %dir %{_libdir}/xbmc/addons
472     %dir %{_libdir}/xbmc/system
473     %dir %{_libdir}/xbmc/system/players
474     %dir %{_libdir}/xbmc/system/players/dvdplayer
475     %dir %{_libdir}/xbmc/system/players/paplayer
476     %dir %{_libdir}/xbmc/system/python
477     %{_libdir}/xbmc/xbmc.bin
478     %{_libdir}/xbmc/xbmc-xrandr
479     %dir %{_libdir}/xbmc/addons/*
480     %{_libdir}/xbmc/addons/*/*.so
481     %{_libdir}/xbmc/addons/*/*.pvr
482     %{_libdir}/xbmc/addons/*/*.vis
483     %{_libdir}/xbmc/addons/*/*.xbs
484     %{_libdir}/xbmc/addons/script.module.*/*.xml
485     %{_libdir}/xbmc/system/ImageLib-*-linux.so
486     %{_libdir}/xbmc/system/hdhomerun-*-linux.so
487     %{_libdir}/xbmc/system/libcpluff-*-linux.so
488     %{_libdir}/xbmc/system/libexif-*-linux.so
489     %{_libdir}/xbmc/system/libid3tag-*-linux.so
490     %{_libdir}/xbmc/system/players/dvdplayer/libdvdnav-*-linux.so
491     %{_libdir}/xbmc/system/players/paplayer/adpcm-*-linux.so
492     %{_libdir}/xbmc/system/players/paplayer/libsidplay2-*-linux.so
493     %{_libdir}/xbmc/system/players/paplayer/nosefart-*-linux.so
494     %{_libdir}/xbmc/system/players/paplayer/stsoundlibrary-*-linux.so
495     %{_libdir}/xbmc/system/players/paplayer/timidity-*-linux.so
496     %{_libdir}/xbmc/system/players/paplayer/vgmstream-*-linux.so
497     %ifarch %ix86
498     %{_libdir}/xbmc/system/players/paplayer/SNESAPU-*-linux.so
499     %endif
500     %{_libdir}/xbmc/system/python/python*-*-linux.so
501     %if !%system_python
502     %{_libdir}/xbmc/addons/script.module.pil/*
503     %{_libdir}/xbmc/addons/script.module.pysqlite/*
504     %{_libdir}/xbmc/system/python/python*.zip
505     %endif
506     %dir %{_datadir}/xbmc
507     %{_datadir}/xbmc/addons
508     %{_datadir}/xbmc/FEH.py
509     %{_datadir}/xbmc/language
510     %{_datadir}/xbmc/media
511     %{_datadir}/xbmc/sounds
512     %{_datadir}/xbmc/system
513     %{_datadir}/xbmc/userdata
514     %{_datadir}/applications/xbmc.desktop
515     %{_iconsdir}/hicolor/*/apps/xbmc.png
516    
517     %files eventclients-common
518     %defattr(-,root,root)
519     %python_sitelib/xbmc
520     %dir %{_datadir}/pixmaps/xbmc
521     %{_datadir}/pixmaps/xbmc/*.png
522    
523     %files eventclients-devel
524     %defattr(-,root,root)
525     %dir %{_includedir}/xbmc
526     %{_includedir}/xbmc/xbmcclient.h
527    
528     %files eventclient-j2me
529     %defattr(-,root,root)
530     %{_bindir}/xbmc-j2meremote
531    
532     %files eventclient-ps3
533     %defattr(-,root,root)
534     %{_bindir}/xbmc-ps3d
535     %{_bindir}/xbmc-ps3remote
536    
537     %files eventclient-xbmc-send
538     %defattr(-,root,root)
539     %{_bindir}/xbmc-send
540    
541     %files eventclient-wiiremote
542     %defattr(-,root,root)
543     %{_bindir}/xbmc-wiiremote
544    
545    

  ViewVC Help
Powered by ViewVC 1.1.30