/[packages]/updates/1/mysql/current/SPECS/mysql.spec
ViewVC logotype

Annotation of /updates/1/mysql/current/SPECS/mysql.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 57950 - (hide annotations) (download)
Wed Feb 23 20:48:51 2011 UTC (13 years, 1 month ago) by ahmad
Original Path: cauldron/mysql/current/SPECS/mysql.spec
File size: 26012 byte(s)
- update to 5.5.9
- drop patch108, fixed upstream
- add patch to fix some header file locations (hint from Mandriva)
1 ahmad 6918 %define Werror_cflags %nil
2     %define _disable_ld_no_undefined 1
3    
4     #(ie. use with rpm --rebuild):
5     #
6     # --with debug Compile with debugging code
7     #
8     # enable build with debugging code: will _not_ strip away any debugging code,
9     # will _add_ -g3 to CFLAGS, will _add_ --enable-maintainer-mode to
10     # configure.
11    
12     %define build_debug 0
13     %define build_test 0
14    
15     # commandline overrides:
16     # rpm -ba|--rebuild --with 'xxx'
17     %{?_with_debug: %{expand: %%define build_debug 1}}
18     %{?_with_test: %{expand: %%define build_test 1}}
19     %{?_without_test: %global build_test 0}
20    
21     %if %{build_debug}
22     # disable build root strip policy
23     %define __spec_install_post %{_libdir}/rpm/brp-compress || :
24    
25     # This gives extra debuggin and huge binaries
26     %{expand:%%define optflags %{optflags} %([ ! $DEBUG ] && echo '-g3')}
27     %endif
28    
29     %if %{build_debug}
30     %define build_debug 1
31     %endif
32    
33     %if %{build_test}
34     %define build_test 1
35     %endif
36    
37     %define _requires_exceptions perl(this)
38    
39     %define major 16
40     %define libname %mklibname mysql %{major}
41     %define develname %mklibname -d mysql
42     %define staticdevelname %mklibname -d -s mysql
43    
44     %define muser mysql
45    
46     Summary: A very fast and reliable SQL database engine
47     Name: mysql
48 ahmad 57950 Version: 5.5.9
49     Release: %mkrel 1
50 ahmad 6918 Group: Databases
51     License: GPL
52     URL: http://www.mysql.com/
53     Source0: http://mysql.dataphone.se/Downloads/MySQL-5.1/mysql-%{version}.tar.gz
54     Source1: http://mysql.dataphone.se/Downloads/MySQL-5.1/mysql-%{version}.tar.gz.asc
55     Source2: mysqld.sysconfig
56     Source3: my.cnf
57     Source4: libmysql.version
58     # fedora patches
59     Patch0: mysql-errno.patch
60     Patch1: mysql-strmov.patch
61     Patch2: mysql-install-test.patch
62     Patch3: mysql-expired-certs.patch
63     Patch4: mysql-stack-guard.patch
64     Patch5: mysql-chain-certs.patch
65     Patch6: mysql-versioning.patch
66     Patch7: mysql-dubious-exports.patch
67     Patch8: mysql-disable-test.patch
68 ahmad 29144 Patch9: mysql-home.patch
69     Patch10: mysql-embedded-crash.patch
70    
71 ahmad 6918 # mandriva patches
72     Patch100: mysql-mysqldumpslow_no_basedir.diff
73     Patch101: mysql-logrotate.diff
74     Patch102: mysql-initscript.diff
75     Patch103: mysql_upgrade-exit-status.patch
76     Patch104: mysql-5.1.31-shebang.patch
77     Patch105: mysql-5.1.35-test-variables-big.patch
78     Patch106: mysql-5.1.36-hotcopy.patch
79     Patch107: mysql-install_db-quiet.patch
80 rtp 29549 Patch109: mysql_valist_fix.patch
81 ahmad 57950 # (ahmad) add patch to fix some header files location (hint from Mandriva)
82     Patch110: mysql-5.5.9-fix-headers-location.patch
83 ahmad 6918 Requires(post): rpm-helper
84     Requires(preun): rpm-helper
85     Requires(pre): rpm-helper
86     Requires(postun): rpm-helper
87     Requires(post): mysql-common = %{version}-%{release}
88     Requires(preun): mysql-common = %{version}-%{release}
89     Requires(post): mysql-client = %{version}-%{release}
90     Requires(preun): mysql-client = %{version}-%{release}
91     Requires(postun): mysql-common = %{version}-%{release}
92     Requires(postun): mysql-client = %{version}-%{release}
93     Requires: mysql-common = %{version}-%{release}
94     Requires: mysql-core = %{version}-%{release}
95     Requires: mysql-client = %{version}-%{release}
96     BuildRequires: bison
97     BuildRequires: cmake
98     BuildRequires: dos2unix
99     BuildRequires: doxygen
100     BuildRequires: glibc-devel
101     BuildRequires: libaio-devel
102     BuildRequires: libstdc++-devel
103     BuildRequires: libtermcap-devel
104     BuildRequires: multiarch-utils >= 1.0.3
105     BuildRequires: ncurses-devel
106     BuildRequires: openssl-devel
107     BuildRequires: python
108     BuildRequires: readline-devel
109     BuildRequires: systemtap
110     BuildRequires: tetex
111     BuildRequires: texinfo
112     BuildRequires: xfs-devel
113     BuildRequires: zlib-devel
114     BuildConflicts: edit-devel
115     Provides: msqlormysql mysqlserver
116     Provides: mysql-max = %{version}-%{release}
117     Obsoletes: mysql-max < 5.1.43
118     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
119    
120     %description
121     The MySQL(TM) software delivers a very fast, multi-threaded, multi-user, and
122     robust SQL (Structured Query Language) database server. MySQL Server is
123     intended for mission-critical, heavy-load production systems as well as for
124     embedding into mass-deployed software. MySQL is a trademark of MySQL AB.
125    
126     The mysql server is compiled with the following storage engines:
127    
128     - InnoDB Storage Engine
129     - Archive Storage Engine
130     - CSV Storage Engine
131     - Federated Storage Engine
132     - User Defined Functions (UDFs).
133     - Blackhole Storage Engine
134     - Partition Storage Engine
135     - Perfschema Storage Engine
136    
137     %package core
138     Summary: Server core binary
139     Group: System/Servers
140     Conflicts: mysql < 5.1.39-3
141     Conflicts: mysql-max < 5.1.43
142     Requires: mysql-common-core >= %{version}-%{release}
143    
144     %description core
145     Core mysqld server binary. For a full MySQL database server, install
146     package 'mysql'.
147    
148     %package common-core
149     Summary: Common files required by core binary
150     Group: System/Servers
151     Conflicts: mysql-common < 5.1.43-1
152    
153     %description common-core
154     Common files minimally required by mysqld server binary.
155    
156     %package common
157     Summary: Common files
158     Group: System/Servers
159     Requires(post): rpm-helper
160     Requires(preun): rpm-helper
161     Requires(pre): rpm-helper
162     Requires(postun): rpm-helper
163     Requires(post): mysql-client >= %{version}-%{release}
164     Requires(preun): mysql-client >= %{version}-%{release}
165     Requires: mysql-client >= %{version}-%{release}
166     Requires: mysql-common-core >= %{version}-%{release}
167    
168     %description common
169     Common files for the MySQL(TM) database server.
170    
171     %package client
172     Summary: Client
173     Group: Databases
174     Requires(post): %{libname} >= %{version}-%{release}
175     Requires(preun): %{libname} >= %{version}-%{release}
176     Requires: %{libname} >= %{version}-%{release}
177    
178     %description client
179     This package contains the standard MySQL clients.
180    
181     %package bench
182     Summary: Benchmarks and test system
183     Group: System/Servers
184     Requires(post): mysql-client >= %{version}-%{release}
185     Requires(preun): mysql-client >= %{version}-%{release}
186     Requires: mysql-client >= %{version}-%{release}
187     Requires: perl
188    
189     %description bench
190     This package contains MySQL benchmark scripts and data.
191    
192     %package -n %{libname}
193     Summary: Shared libraries
194     Group: System/Libraries
195     Provides: mysql-shared-libs = %{version}-%{release}
196     Provides: mysql-shared = %{version}-%{release}
197    
198     %description -n %{libname}
199     This package contains the shared libraries (*.so*) which certain languages and
200     applications need to dynamically load and use MySQL.
201    
202     %package -n %{develname}
203     Summary: Development header files and libraries
204     Group: Development/Other
205     Requires(post): %{libname} >= %{version}-%{release}
206     Requires(preun): %{libname} >= %{version}-%{release}
207     Requires(post): mysql-common >= %{version}-%{release}
208     Requires(preun): mysql-common >= %{version}-%{release}
209     Requires(post): mysql-client >= %{version}-%{release}
210     Requires(preun): mysql-client >= %{version}-%{release}
211     Requires: %{libname} = %{version}-%{release}
212     Requires: mysql-common >= %{version}-%{release}
213     Requires: mysql-client >= %{version}-%{release}
214     Provides: mysql-devel = %{version}-%{release}
215     Provides: %{libname}-devel = %{version}-%{release}
216     Obsoletes: %{libname}-devel
217     Conflicts: %{mklibname mysql 12 -d}
218     Conflicts: %{mklibname mysql 14 -d}
219     Conflicts: %{mklibname mysql 15 -d}
220    
221     %description -n %{develname}
222     This package contains the development header files and libraries necessary to
223     develop MySQL client applications.
224    
225     This package also contains the MySQL server as an embedded library.
226    
227     The embedded MySQL server library makes it possible to run a full-featured
228     MySQL server inside the client application. The main benefits are increased
229     speed and more simple management for embedded applications.
230    
231     The API is identical for the embedded MySQL version and the client/server
232     version.
233    
234     %package -n %{staticdevelname}
235     Summary: Static development libraries
236     Group: Development/Other
237     Requires: mysql-devel >= %{version}-%{release}
238     Provides: mysql-static-devel = %{version}-%{release}
239     Provides: %{libname}-static-devel = %{version}-%{release}
240     Obsoletes: %{libname}-static-devel
241    
242     %description -n %{staticdevelname}
243     This package contains the static development libraries.
244    
245     %prep
246    
247     %setup -q -n mysql-%{version}
248    
249     # fedora patches
250     %patch0 -p1 -b .errno
251     %patch1 -p1 -b .strmov
252     %patch2 -p1 -b .install-test
253     %patch3 -p1 -b .expired-certs
254     %patch4 -p1 -b .stack-guard
255     %patch5 -p1 -b .chain-certs
256     %patch6 -p1 -b .versioning
257     %patch7 -p1 -b .dubious-exports
258     %patch8 -p1 -b .disable-test
259 ahmad 29144 %patch9 -p1 -b .mysql-home
260     %patch10 -p1 -b .mysql-embedded-crash
261 ahmad 6918
262     # mandriva patches
263     %patch100 -p0 -b .mysqldumpslow_no_basedir
264     %patch101 -p0 -b .logrotate
265     %patch102 -p0 -b .initscript
266     %patch103 -p1 -b .mysql_upgrade-exit-status
267     %patch104 -p1 -b .shebang
268     %patch105 -p0 -b .test-variables-big
269     %patch106 -p0 -b .hotcopy
270     %patch107 -p0 -b .install_db-quiet
271 rtp 29549 %patch109 -p1 -b .va_list_arm
272 ahmad 57950 %patch110 -p1 -b .headers-location
273 rtp 29549
274 ahmad 16644 mkdir -p Mageia
275     cp %{SOURCE2} Mageia/mysqld.sysconfig
276     cp %{SOURCE3} Mageia/my.cnf
277 ahmad 6918
278     # lib64 fix
279 ahmad 16644 perl -pi -e "s|/usr/lib/|%{_libdir}/|g" Mageia/my.cnf
280 ahmad 6918
281     # antiborker
282     perl -pi -e "s|\@bindir\@|%{_bindir}|g" support-files/* scripts/*
283     perl -pi -e "s|\@sbindir\@|%{_sbindir}|g" support-files/* scripts/*
284     perl -pi -e "s|\@libexecdir\@|%{_sbindir}|g" support-files/* scripts/*
285     perl -pi -e "s|\@localstatedir\@|/var/lib/mysql|g" support-files/* scripts/*
286     perl -pi -e "s|^basedir=.*|basedir=%{_prefix}|g" support-files/* scripts/mysql_install_db*
287    
288     # this may be part of the problems with mysql-test
289     # http://bugs.mysql.com/bug.php?id=52223
290     #perl -pi -e "s|basedir/lib\b|basedir/%{_lib}\b|g" mysql-test/mysql-test-run.pl
291     #perl -pi -e "s|basedir/lib/|basedir/%{_lib}/|g" mysql-test/mysql-test-run.pl
292    
293     # workaround for upstream bug #56342
294     rm -f mysql-test/t/ssl_8k_key-master.opt
295    
296     # upstream has fallen down badly on symbol versioning, do it ourselves
297     cp %{SOURCE4} libmysql/libmysql.version
298    
299     %build
300     %serverbuild
301     export CFLAGS="${CFLAGS:-%{optflags}}"
302     export CXXFLAGS="${CXXFLAGS:-%{optflags}}"
303     export FFLAGS="${FFLAGS:-%{optflags}}"
304    
305     %cmake \
306     -DCMAKE_BUILD_TYPE=RelWithDebInfo \
307     -DCMAKE_INSTALL_PREFIX=%{_prefix} \
308     -DINSTALL_SBINDIR=sbin \
309     -DMYSQL_DATADIR=/var/lib/mysql \
310     -DSYSCONFDIR=%{_sysconfdir} \
311     -DINSTALL_PLUGINDIR=%{_lib}/mysql/plugin \
312     -DINSTALL_MANDIR=share/man \
313     -DINSTALL_SHAREDIR=share/mysql \
314     -DINSTALL_LIBDIR=%{_lib} \
315     -DINSTALL_INCLUDEDIR=include/mysql \
316     -DINSTALL_INFODIR=share/info \
317     -DINSTALL_MYSQLDATADIR=/var/lib/mysql \
318     -DINSTALL_MYSQLTESTDIR=share/mysql/mysql-test \
319     -DINSTALL_SQLBENCHDIR=share/mysql \
320     -DINSTALL_SUPPORTFILESDIR=share/mysql \
321     -DINSTALL_MYSQLSHAREDIR=share/mysql \
322     -DMYSQL_UNIX_ADDR=/var/lib/mysql/mysql.sock \
323     -DWITH_READLINE=0 \
324     -DWITH_LIBEDIT=0 \
325     -DWITH_LIBWRAP=1 \
326     -DWITH_SSL=system \
327     -DWITH_ZLIB=system \
328     -DWITH_PIC=1 \
329     -DMYSQL_TCP_PORT=3306 \
330     -DEXTRA_CHARSETS=all \
331     -DENABLED_LOCAL_INFILE=1 \
332     -DENABLE_DTRACE=1 \
333     -DWITH_EMBEDDED_SERVER=1 \
334     -DMYSQL_USER=%{muser} \
335     %if %{build_debug}
336     -DWITH_DEBUG=1 \
337     %else
338     -DWITH_DEBUG=0 \
339     %endif
340     -DWITHOUT_EXAMPLE_STORAGE_ENGINE=1 \
341     -DWITHOUT_NDBCLUSTER_STORAGE_ENGINE=1 \
342     -DWITHOUT_DAEMON_EXAMPLE=1 \
343     -DFEATURE_SET="community" \
344 ahmad 16644 -DCOMPILATION_COMMENT="Mageia - MySQL Community Edition (GPL)"
345 ahmad 6918
346     cp ../libmysql/libmysql.version libmysql/libmysql.version
347    
348     %make
349    
350    
351     %install
352     rm -rf %{buildroot}
353    
354     # don't fiddle with the initscript!
355     export DONT_GPRINTIFY=1
356    
357     %if %{build_debug}
358     export DONT_STRIP=1
359     %endif
360    
361     install -d %{buildroot}%{_sysconfdir}/sysconfig
362     install -d %{buildroot}%{_initrddir}
363     install -d %{buildroot}%{_var}/run/mysqld
364     install -d %{buildroot}%{_var}/log/mysqld
365     install -d %{buildroot}/var/lib/mysql/{mysql,test}
366    
367     %makeinstall_std -C build
368    
369     # install init scripts
370     install -m0755 build/support-files/mysql.server %{buildroot}%{_initrddir}/mysqld
371    
372     # install configuration files
373 ahmad 16644 install -m0644 Mageia/mysqld.sysconfig %{buildroot}%{_sysconfdir}/sysconfig/mysqld
374     install -m0644 Mageia/my.cnf %{buildroot}%{_sysconfdir}/my.cnf
375 ahmad 6918
376     # bork
377     mv %{buildroot}%{_bindir}/mysqlaccess.conf %{buildroot}%{_sysconfdir}/
378     chmod 644 %{buildroot}%{_sysconfdir}/mysqlaccess.conf
379     mv %{buildroot}%{_prefix}/scripts/mysql_install_db %{buildroot}%{_bindir}/
380     mv %{buildroot}%{_datadir}/mysql/aclocal %{buildroot}%{_datadir}/aclocal
381    
382     pushd %{buildroot}%{_bindir}
383     ln -sf mysqlcheck mysqlrepair
384     ln -sf mysqlcheck mysqlanalyze
385     ln -sf mysqlcheck mysqloptimize
386     popd
387    
388     # nuke -Wl,--as-needed from the mysql_config file
389     perl -pi -e "s|^ldflags=.*|ldflags=\'-rdynamic\'|g" %{buildroot}%{_bindir}/mysql_config
390    
391     # cmake generates some completely wacko references to -lprobes_mysql when
392     # building with dtrace support. Haven't found where to shut that off,
393     # so resort to this blunt instrument. While at it, let's not reference
394     # libmysqlclient_r anymore either.
395     sed -e 's/-lprobes_mysql//' -e 's/-lmysqlclient_r/-lmysqlclient/' \
396     %{buildroot}%{_bindir}/mysql_config >mysql_config.tmp
397     cp -f mysql_config.tmp %{buildroot}%{_bindir}/mysql_config
398     chmod 755 %{buildroot}%{_bindir}/mysql_config
399    
400     # libmysqlclient_r is no more. Upstream tries to replace it with symlinks
401     # but that really doesn't work (wrong soname in particular). We'll keep
402     # just the devel libmysqlclient_r.so link, so that rebuilding without any
403     # source change is enough to get rid of dependency on libmysqlclient_r.
404     rm -f %{buildroot}%{_libdir}/libmysqlclient_r.so*
405     ln -s libmysqlclient.so %{buildroot}%{_libdir}/libmysqlclient_r.so
406    
407     # mysql-test includes one executable that doesn't belong under /usr/share,
408     # so move it and provide a symlink
409     mv %{buildroot}%{_datadir}/mysql/mysql-test/lib/My/SafeProcess/my_safe_process %{buildroot}%{_bindir}
410     ln -s %{_bindir}/my_safe_process %{buildroot}%{_datadir}/mysql/mysql-test/lib/My/SafeProcess/my_safe_process
411    
412     # house cleaning
413     rm -rf %{buildroot}%{_datadir}/info
414     rm -f %{buildroot}%{_bindir}/mysqltest_embedded
415     rm -f %{buildroot}%{_bindir}/client_test
416     rm -f %{buildroot}%{_bindir}/make_win_binary_distribution
417     rm -f %{buildroot}%{_bindir}/make_win_src_distribution
418     rm -f %{buildroot}%{_datadir}/mysql/binary-configure
419     rm -f %{buildroot}%{_datadir}/mysql/config.huge.ini
420     rm -f %{buildroot}%{_datadir}/mysql/config.medium.ini
421     rm -f %{buildroot}%{_datadir}/mysql/config.small.ini
422     rm -f %{buildroot}%{_datadir}/mysql/mysqld_multi.server
423     rm -f %{buildroot}%{_datadir}/mysql/mysql-log-rotate
424     rm -f %{buildroot}%{_datadir}/mysql/mysql.server
425     rm -f %{buildroot}%{_datadir}/mysql/ndb-config-2-node.ini
426     rm -f %{buildroot}%{_datadir}/mysql/binary-configure
427     rm -f %{buildroot}%{_mandir}/man1/make_win_bin_dist.1*
428     rm -f %{buildroot}%{_mandir}/man1/make_win_src_distribution.1*
429     rm -f %{buildroot}%{_datadir}/mysql/magic
430    
431     # no idea how to fix this
432     rm -rf %{buildroot}%{_prefix}/data
433     rm -rf %{buildroot}%{_prefix}/docs
434     rm -rf %{buildroot}%{_prefix}/scripts
435     rm -f %{buildroot}%{_prefix}/COPYING
436     rm -f %{buildroot}%{_prefix}/INSTALL-BINARY
437     rm -f %{buildroot}%{_prefix}/README
438    
439     %multiarch_binaries %{buildroot}%{_bindir}/mysql_config
440     %multiarch_includes %{buildroot}%{_includedir}/mysql/my_config.h
441    
442     cat > README.urpmi <<EOF
443    
444     The initscript used to start mysql has been reverted to use the one shipped
445     by MySQL AB. This means the following changes:
446    
447     * The generation of the initial system mysql database is now done when mysql
448     is started from the initscript and only if the /var/lib/mysql/mysql
449     directory is empty (mysql_install_db). Previousely this was quite hidden and
450     silently done at (rpm) install time. As a consequence to this change you may
451     have to perform some manual tasks to upgrade the mysql system database and
452     such. So, doing something like this might help you:
453    
454     /etc/rc.d/init.d/mysqld stop
455     TMPDIR=/var/tmp mysql_install_db
456     mysql_upgrade
457    
458     The cluster functionalities (ndb) has been deactivated and will be removed in
459     future mysql versions. A new product named mysql-cluster has been added (in
460     contrib) that replaces the cluster functionalities.
461    
462     The mysql-common-core package ships with a default /etc/my.cnf file that is
463     based on the my-medium.cnf file that comes with the source code.
464    
465     Starting from mysql-5.1.43-2 the storage engines is built as dynamically
466     loadable modules. You can either load the engines using the /etc/my.cnf file or
467     at runtime. Please look at these lines in the /etc/my.cnf file to enable
468     additional engines or disable one or more of the default ones:
469    
470     plugin_dir=%{_libdir}/mysql/plugin
471     plugin-load=ha_archive.so;ha_blackhole.so;ha_federated.so
472    
473     Starting from mysql-5.1.44-3 the html documentation and the mysql.info is not
474 ahmad 16644 shipped with the Mageia packages due to strict licensing.
475 ahmad 6918
476     EOF
477    
478     ################################################################################
479     # run the tests
480     %if %{build_test}
481     # disable failing tests
482     echo "rpl_trigger : Unstable test case" >> mysql-test/t/disabled.def
483     echo "type_enum : Unstable test case" >> mysql-test/t/disabled.def
484     echo "windows : For MS Windows only" >> mysql-test/t/disabled.def
485     pushd build/mysql-test
486     export LANG=C
487     export LC_ALL=C
488     export LANGUAGE=C
489     perl ./mysql-test-run.pl \
490     --mtr-build-thread="$((${RANDOM} % 100))" \
491     --skip-ndb \
492     --timer \
493     --retry=0 \
494     --ssl \
495     --mysqld=--binlog-format=mixed \
496     --testcase-timeout=60 \
497     --suite-timeout=120 || false
498     popd
499     %endif
500    
501     %pre
502     # enable plugins
503     if [ -f %{_sysconfdir}/my.cnf ]; then
504     perl -pi -e "s|^#plugin-load|plugin-load|g" %{_sysconfdir}/my.cnf
505     perl -pi -e "s|^#federated|federated|g" %{_sysconfdir}/my.cnf
506     fi
507    
508     %pre common
509     # delete the mysql group if no mysql user is found, before adding the user
510     if [ -z "`getent passwd %{muser}`" ] && ! [ -z "`getent group %{muser}`" ]; then
511     %{_sbindir}/groupdel %{muser} 2> /dev/null || :
512     fi
513    
514     %_pre_useradd %{muser} /var/lib/mysql /bin/bash
515    
516     %post common
517    
518     %post
519     # Change permissions so that the user that will run the MySQL daemon
520     # owns all needed files.
521     chown -R %{muser}:%{muser} /var/lib/mysql /var/run/mysqld /var/log/mysqld
522    
523     # make sure the /var/lib/mysql directory can be accessed
524     chmod 711 /var/lib/mysql
525    
526     %_post_service mysqld
527    
528     %preun
529     %_preun_service mysqld
530    
531     %postun
532     if [ "$1" = "0" ]; then
533     if [ -f /var/lock/subsys/mysqld ]; then
534     %{_initrddir}/mysqld restart > /dev/null 2>/dev/null || :
535     fi
536     fi
537    
538     %pre common-core
539     # enable plugins
540     if [ -f %{_sysconfdir}/my.cnf ]; then
541     perl -pi -e "s|^#plugin-load|plugin-load|g" %{_sysconfdir}/my.cnf
542     perl -pi -e "s|^#federated|federated|g" %{_sysconfdir}/my.cnf
543     fi
544    
545     %clean
546     rm -rf %{buildroot}
547    
548     %files
549     %defattr(-,root,root)
550     %doc README.urpmi
551     %attr(0755,root,root) %{_initrddir}/mysqld
552     %dir %{_libdir}/mysql/plugin
553     %attr(0755,root,root) %{_libdir}/mysql/plugin/adt_null.so
554     %attr(0755,root,root) %{_libdir}/mysql/plugin/auth.so
555     %attr(0755,root,root) %{_libdir}/mysql/plugin/auth_socket.so
556     %attr(0755,root,root) %{_libdir}/mysql/plugin/auth_test_plugin.so
557     %attr(0755,root,root) %{_libdir}/mysql/plugin/ha_archive.so
558     %attr(0755,root,root) %{_libdir}/mysql/plugin/ha_blackhole.so
559     %attr(0755,root,root) %{_libdir}/mysql/plugin/ha_federated.so
560     %attr(0755,root,root) %{_libdir}/mysql/plugin/mypluglib.so
561     %attr(0755,root,root) %{_libdir}/mysql/plugin/qa_auth_client.so
562     %attr(0755,root,root) %{_libdir}/mysql/plugin/qa_auth_interface.so
563     %attr(0755,root,root) %{_libdir}/mysql/plugin/qa_auth_server.so
564     %attr(0755,root,root) %{_libdir}/mysql/plugin/semisync_master.so
565     %attr(0755,root,root) %{_libdir}/mysql/plugin/semisync_slave.so
566    
567     %files client
568     %defattr(-,root,root)
569     %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/mysqlaccess.conf
570     %attr(0755,root,root) %{_bindir}/msql2mysql
571     %attr(0755,root,root) %{_bindir}/mysql
572     %attr(0755,root,root) %{_bindir}/mysqlaccess
573     %attr(0755,root,root) %{_bindir}/mysqladmin
574     %attr(0755,root,root) %{_bindir}/mysqlanalyze
575     %attr(0755,root,root) %{_bindir}/mysqlbinlog
576     %attr(0755,root,root) %{_bindir}/mysqlcheck
577     %attr(0755,root,root) %{_bindir}/mysqldump
578     %attr(0755,root,root) %{_bindir}/mysqldumpslow
579     %attr(0755,root,root) %{_bindir}/mysql_find_rows
580     %attr(0755,root,root) %{_bindir}/mysqlimport
581     %attr(0755,root,root) %{_bindir}/mysqloptimize
582     %attr(0755,root,root) %{_bindir}/mysqlrepair
583     %attr(0755,root,root) %{_bindir}/mysqlshow
584     %attr(0755,root,root) %{_bindir}/mysqlslap
585     %attr(0755,root,root) %{_bindir}/mysql_waitpid
586     %attr(0644,root,root) %{_mandir}/man1/msql2mysql.1*
587     %attr(0644,root,root) %{_mandir}/man1/myisam_ftdump.1*
588     %attr(0644,root,root) %{_mandir}/man1/mysql.1*
589     %attr(0644,root,root) %{_mandir}/man1/mysqlaccess.1*
590     %attr(0644,root,root) %{_mandir}/man1/mysqladmin.1*
591     %attr(0644,root,root) %{_mandir}/man1/mysqlbinlog.1*
592     %attr(0644,root,root) %{_mandir}/man1/mysqlcheck.1*
593     %attr(0644,root,root) %{_mandir}/man1/mysqldump.1*
594     %attr(0644,root,root) %{_mandir}/man1/mysqldumpslow.1*
595     %attr(0644,root,root) %{_mandir}/man1/mysql_find_rows.1*
596     %attr(0644,root,root) %{_mandir}/man1/mysqlimport.1*
597     %attr(0644,root,root) %{_mandir}/man1/mysqlshow.1*
598     %attr(0644,root,root) %{_mandir}/man1/mysql_waitpid.1*
599    
600     %files bench
601     %defattr(-,root,root)
602     %doc build/sql-bench/README
603     %attr(0755,root,root) %{_bindir}/my_safe_process
604     %attr(0755,root,root) %{_bindir}/mysql_client_test
605     %attr(0755,root,root) %{_bindir}/mysql_client_test_embedded
606     %{_datadir}/mysql/sql-bench
607     %attr(-,mysql,mysql) %{_datadir}/mysql/mysql-test
608     %attr(0644,root,root) %{_mandir}/man1/mysql-stress-test.pl.1*
609     %attr(0644,root,root) %{_mandir}/man1/mysql-test-run.pl.1*
610     %attr(0644,root,root) %{_mandir}/man1/mysql_client_test.1*
611     %attr(0644,root,root) %{_mandir}/man1/mysql_client_test_embedded.1*
612     %attr(0644,root,root) %{_mandir}/man1/mysqltest.1*
613     %attr(0644,root,root) %{_mandir}/man1/mysqltest_embedded.1*
614    
615     %files core
616     %defattr(-,root,root)
617     %attr(0755,root,root) %{_sbindir}/mysqld
618    
619     %files common-core
620     %defattr(-,root,root)
621     %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/my.cnf
622     %dir %{_datadir}/mysql
623     %{_datadir}/mysql/english
624     %{_datadir}/mysql/charsets
625    
626     %files common
627     %defattr(-,root,root)
628     %doc README COPYING
629     %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/mysqld
630     %attr(0755,root,root) %{_bindir}/innochecksum
631     %attr(0755,root,root) %{_bindir}/myisamchk
632     %attr(0755,root,root) %{_bindir}/myisam_ftdump
633     %attr(0755,root,root) %{_bindir}/myisamlog
634     %attr(0755,root,root) %{_bindir}/myisampack
635     %attr(0755,root,root) %{_bindir}/my_print_defaults
636     %attr(0755,root,root) %{_bindir}/mysqlbug
637     %attr(0755,root,root) %{_bindir}/mysql_convert_table_format
638     %attr(0755,root,root) %{_bindir}/mysqld_multi
639     %attr(0755,root,root) %{_bindir}/mysqld_safe
640     %attr(0755,root,root) %{_bindir}/mysql_fix_extensions
641     %attr(0755,root,root) %{_bindir}/mysqlhotcopy
642     %attr(0755,root,root) %{_bindir}/mysql_install_db
643     %attr(0755,root,root) %{_bindir}/mysql_secure_installation
644     %attr(0755,root,root) %{_bindir}/mysql_setpermission
645     %attr(0755,root,root) %{_bindir}/mysqltest
646     %attr(0755,root,root) %{_bindir}/mysql_tzinfo_to_sql
647     %attr(0755,root,root) %{_bindir}/mysql_upgrade
648     %attr(0755,root,root) %{_bindir}/mysql_zap
649     %attr(0755,root,root) %{_bindir}/perror
650     %attr(0755,root,root) %{_bindir}/replace
651     %attr(0755,root,root) %{_bindir}/resolveip
652     %attr(0755,root,root) %{_bindir}/resolve_stack_dump
653     %attr(0711,%{muser},%{muser}) %dir /var/lib/mysql
654     %attr(0711,%{muser},%{muser}) %dir /var/lib/mysql/mysql
655     %attr(0711,%{muser},%{muser}) %dir /var/lib/mysql/test
656     %attr(0755,%{muser},%{muser}) %dir %{_var}/run/mysqld
657     %attr(0755,%{muser},%{muser}) %dir %{_var}/log/mysqld
658     %{_datadir}/mysql/*.cnf
659     %{_datadir}/mysql/fill_help_tables.sql
660     %{_datadir}/mysql/mysql_system_tables.sql
661     %{_datadir}/mysql/mysql_system_tables_data.sql
662     %{_datadir}/mysql/mysql_test_data_timezone.sql
663     %{_datadir}/mysql/errmsg-utf8.txt
664     %{_datadir}/mysql/czech
665     %{_datadir}/mysql/danish
666     %{_datadir}/mysql/dutch
667     %{_datadir}/mysql/estonian
668     %{_datadir}/mysql/french
669     %{_datadir}/mysql/german
670     %{_datadir}/mysql/greek
671     %{_datadir}/mysql/hungarian
672     %{_datadir}/mysql/italian
673     %{_datadir}/mysql/japanese
674     %{_datadir}/mysql/korean
675     %{_datadir}/mysql/norwegian
676     %{_datadir}/mysql/norwegian-ny
677     %{_datadir}/mysql/polish
678     %{_datadir}/mysql/portuguese
679     %{_datadir}/mysql/romanian
680     %{_datadir}/mysql/russian
681     %{_datadir}/mysql/serbian
682     %{_datadir}/mysql/slovak
683     %{_datadir}/mysql/spanish
684     %{_datadir}/mysql/swedish
685     %{_datadir}/mysql/ukrainian
686     %attr(0644,root,root) %{_mandir}/man1/innochecksum.1*
687     %attr(0644,root,root) %{_mandir}/man1/myisamchk.1*
688     %attr(0644,root,root) %{_mandir}/man1/myisamlog.1*
689     %attr(0644,root,root) %{_mandir}/man1/myisampack.1*
690     %attr(0644,root,root) %{_mandir}/man1/my_print_defaults.1*
691     %attr(0644,root,root) %{_mandir}/man1/mysqlbug.1*
692     %attr(0644,root,root) %{_mandir}/man1/mysql_convert_table_format.1*
693     %attr(0644,root,root) %{_mandir}/man1/mysqld_multi.1*
694     %attr(0644,root,root) %{_mandir}/man1/mysqld_safe.1*
695     %attr(0644,root,root) %{_mandir}/man1/mysql_fix_extensions.1*
696     %attr(0644,root,root) %{_mandir}/man1/mysqlhotcopy.1*
697     %attr(0644,root,root) %{_mandir}/man1/mysql_install_db.1*
698     %attr(0644,root,root) %{_mandir}/man1/mysqlman.1*
699     %attr(0644,root,root) %{_mandir}/man1/mysql_secure_installation.1*
700     %attr(0644,root,root) %{_mandir}/man1/mysql.server.1*
701     %attr(0644,root,root) %{_mandir}/man1/mysql_setpermission.1*
702     %attr(0644,root,root) %{_mandir}/man1/mysqlslap.1*
703     %attr(0644,root,root) %{_mandir}/man1/mysql_tzinfo_to_sql.1*
704     %attr(0644,root,root) %{_mandir}/man1/mysql_upgrade.1*
705     %attr(0644,root,root) %{_mandir}/man1/mysql_zap.1*
706     %attr(0644,root,root) %{_mandir}/man1/perror.1*
707     %attr(0644,root,root) %{_mandir}/man1/replace.1*
708     %attr(0644,root,root) %{_mandir}/man1/resolveip.1*
709     %attr(0644,root,root) %{_mandir}/man1/resolve_stack_dump.1*
710     %attr(0644,root,root) %{_mandir}/man8/mysqld.8*
711    
712     %files -n %{libname}
713     %defattr(-,root,root)
714     %doc Docs/ChangeLog
715     %attr(0755,root,root) %{_libdir}/libmysqlclient.so.%{major}*
716     # not sure about this one...
717     %attr(0755,root,root) %{_libdir}/libmysqlservices.so
718    
719     %files -n %{develname}
720     %defattr(-,root,root)
721     %doc INSTALL-SOURCE
722     %multiarch %{multiarch_bindir}/mysql_config
723     %attr(0755,root,root) %{_bindir}/mysql_config
724     %attr(0755,root,root) %{_libdir}/libmysqlclient_r.so
725     %attr(0755,root,root) %{_libdir}/libmysqlclient.so
726     %dir %{_includedir}/mysql
727     %dir %{_includedir}/mysql/psi
728     %attr(0644,root,root) %{_includedir}/mysql/*.h
729     %attr(0644,root,root) %{_includedir}/mysql/psi/*.h
730     %multiarch %{multiarch_includedir}/mysql/my_config.h
731     %attr(0644,root,root) %{_mandir}/man1/comp_err.1*
732     %attr(0644,root,root) %{_mandir}/man1/mysql_config.1*
733     %attr(0644,root,root) %{_datadir}/aclocal/mysql.m4
734    
735     %files -n %{staticdevelname}
736     %defattr(-,root,root)
737     %attr(0644,root,root) %{_libdir}/*.a

  ViewVC Help
Powered by ViewVC 1.1.30