/[packages]/updates/1/mysql/current/SPECS/mysql.spec
ViewVC logotype

Annotation of /updates/1/mysql/current/SPECS/mysql.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 6918 - (hide annotations) (download)
Wed Jan 12 02:44:26 2011 UTC (13 years, 2 months ago) by ahmad
Original Path: cauldron/mysql/current/SPECS/mysql.spec
File size: 25893 byte(s)
imported package mysql
1 ahmad 6918 %define Werror_cflags %nil
2     %define _disable_ld_no_undefined 1
3    
4     #(ie. use with rpm --rebuild):
5     #
6     # --with debug Compile with debugging code
7     #
8     # enable build with debugging code: will _not_ strip away any debugging code,
9     # will _add_ -g3 to CFLAGS, will _add_ --enable-maintainer-mode to
10     # configure.
11    
12     %define build_debug 0
13     %define build_test 0
14    
15     # commandline overrides:
16     # rpm -ba|--rebuild --with 'xxx'
17     %{?_with_debug: %{expand: %%define build_debug 1}}
18     %{?_with_test: %{expand: %%define build_test 1}}
19     %{?_without_test: %global build_test 0}
20    
21     %if %{build_debug}
22     # disable build root strip policy
23     %define __spec_install_post %{_libdir}/rpm/brp-compress || :
24    
25     # This gives extra debuggin and huge binaries
26     %{expand:%%define optflags %{optflags} %([ ! $DEBUG ] && echo '-g3')}
27     %endif
28    
29     %if %{build_debug}
30     %define build_debug 1
31     %endif
32    
33     %if %{build_test}
34     %define build_test 1
35     %endif
36    
37     %define _requires_exceptions perl(this)
38    
39     %define major 16
40     %define libname %mklibname mysql %{major}
41     %define develname %mklibname -d mysql
42     %define staticdevelname %mklibname -d -s mysql
43    
44     %define muser mysql
45    
46     Summary: A very fast and reliable SQL database engine
47     Name: mysql
48     Version: 5.5.8
49     Release: %mkrel 4
50     Group: Databases
51     License: GPL
52     URL: http://www.mysql.com/
53     Source0: http://mysql.dataphone.se/Downloads/MySQL-5.1/mysql-%{version}.tar.gz
54     Source1: http://mysql.dataphone.se/Downloads/MySQL-5.1/mysql-%{version}.tar.gz.asc
55     Source2: mysqld.sysconfig
56     Source3: my.cnf
57     Source4: libmysql.version
58     # fedora patches
59     Patch0: mysql-errno.patch
60     Patch1: mysql-strmov.patch
61     Patch2: mysql-install-test.patch
62     Patch3: mysql-expired-certs.patch
63     Patch4: mysql-stack-guard.patch
64     Patch5: mysql-chain-certs.patch
65     Patch6: mysql-versioning.patch
66     Patch7: mysql-dubious-exports.patch
67     Patch8: mysql-disable-test.patch
68     # mandriva patches
69     Patch100: mysql-mysqldumpslow_no_basedir.diff
70     Patch101: mysql-logrotate.diff
71     Patch102: mysql-initscript.diff
72     Patch103: mysql_upgrade-exit-status.patch
73     Patch104: mysql-5.1.31-shebang.patch
74     Patch105: mysql-5.1.35-test-variables-big.patch
75     Patch106: mysql-5.1.36-hotcopy.patch
76     Patch107: mysql-install_db-quiet.patch
77     Patch108: mysql-5.5.8-bug58350.diff
78     Requires(post): rpm-helper
79     Requires(preun): rpm-helper
80     Requires(pre): rpm-helper
81     Requires(postun): rpm-helper
82     Requires(post): mysql-common = %{version}-%{release}
83     Requires(preun): mysql-common = %{version}-%{release}
84     Requires(post): mysql-client = %{version}-%{release}
85     Requires(preun): mysql-client = %{version}-%{release}
86     Requires(postun): mysql-common = %{version}-%{release}
87     Requires(postun): mysql-client = %{version}-%{release}
88     Requires: mysql-common = %{version}-%{release}
89     Requires: mysql-core = %{version}-%{release}
90     Requires: mysql-client = %{version}-%{release}
91     BuildRequires: bison
92     BuildRequires: cmake
93     BuildRequires: dos2unix
94     BuildRequires: doxygen
95     BuildRequires: glibc-devel
96     BuildRequires: libaio-devel
97     BuildRequires: libstdc++-devel
98     BuildRequires: libtermcap-devel
99     BuildRequires: multiarch-utils >= 1.0.3
100     BuildRequires: ncurses-devel
101     BuildRequires: openssl-devel
102     BuildRequires: python
103     BuildRequires: readline-devel
104     BuildRequires: systemtap
105     BuildRequires: tetex
106     BuildRequires: texinfo
107     BuildRequires: xfs-devel
108     BuildRequires: zlib-devel
109     BuildConflicts: edit-devel
110     Provides: msqlormysql mysqlserver
111     Provides: mysql-max = %{version}-%{release}
112     Obsoletes: mysql-max < 5.1.43
113     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
114    
115     %description
116     The MySQL(TM) software delivers a very fast, multi-threaded, multi-user, and
117     robust SQL (Structured Query Language) database server. MySQL Server is
118     intended for mission-critical, heavy-load production systems as well as for
119     embedding into mass-deployed software. MySQL is a trademark of MySQL AB.
120    
121     The mysql server is compiled with the following storage engines:
122    
123     - InnoDB Storage Engine
124     - Archive Storage Engine
125     - CSV Storage Engine
126     - Federated Storage Engine
127     - User Defined Functions (UDFs).
128     - Blackhole Storage Engine
129     - Partition Storage Engine
130     - Perfschema Storage Engine
131    
132     %package core
133     Summary: Server core binary
134     Group: System/Servers
135     Conflicts: mysql < 5.1.39-3
136     Conflicts: mysql-max < 5.1.43
137     Requires: mysql-common-core >= %{version}-%{release}
138    
139     %description core
140     Core mysqld server binary. For a full MySQL database server, install
141     package 'mysql'.
142    
143     %package common-core
144     Summary: Common files required by core binary
145     Group: System/Servers
146     Conflicts: mysql-common < 5.1.43-1
147    
148     %description common-core
149     Common files minimally required by mysqld server binary.
150    
151     %package common
152     Summary: Common files
153     Group: System/Servers
154     Requires(post): rpm-helper
155     Requires(preun): rpm-helper
156     Requires(pre): rpm-helper
157     Requires(postun): rpm-helper
158     Requires(post): mysql-client >= %{version}-%{release}
159     Requires(preun): mysql-client >= %{version}-%{release}
160     Requires: mysql-client >= %{version}-%{release}
161     Requires: mysql-common-core >= %{version}-%{release}
162    
163     %description common
164     Common files for the MySQL(TM) database server.
165    
166     %package client
167     Summary: Client
168     Group: Databases
169     Requires(post): %{libname} >= %{version}-%{release}
170     Requires(preun): %{libname} >= %{version}-%{release}
171     Requires: %{libname} >= %{version}-%{release}
172    
173     %description client
174     This package contains the standard MySQL clients.
175    
176     %package bench
177     Summary: Benchmarks and test system
178     Group: System/Servers
179     Requires(post): mysql-client >= %{version}-%{release}
180     Requires(preun): mysql-client >= %{version}-%{release}
181     Requires: mysql-client >= %{version}-%{release}
182     Requires: perl
183    
184     %description bench
185     This package contains MySQL benchmark scripts and data.
186    
187     %package -n %{libname}
188     Summary: Shared libraries
189     Group: System/Libraries
190     Provides: mysql-shared-libs = %{version}-%{release}
191     Provides: mysql-shared = %{version}-%{release}
192    
193     %description -n %{libname}
194     This package contains the shared libraries (*.so*) which certain languages and
195     applications need to dynamically load and use MySQL.
196    
197     %package -n %{develname}
198     Summary: Development header files and libraries
199     Group: Development/Other
200     Requires(post): %{libname} >= %{version}-%{release}
201     Requires(preun): %{libname} >= %{version}-%{release}
202     Requires(post): mysql-common >= %{version}-%{release}
203     Requires(preun): mysql-common >= %{version}-%{release}
204     Requires(post): mysql-client >= %{version}-%{release}
205     Requires(preun): mysql-client >= %{version}-%{release}
206     Requires: %{libname} = %{version}-%{release}
207     Requires: mysql-common >= %{version}-%{release}
208     Requires: mysql-client >= %{version}-%{release}
209     Provides: mysql-devel = %{version}-%{release}
210     Provides: %{libname}-devel = %{version}-%{release}
211     Obsoletes: %{libname}-devel
212     Conflicts: %{mklibname mysql 12 -d}
213     Conflicts: %{mklibname mysql 14 -d}
214     Conflicts: %{mklibname mysql 15 -d}
215    
216     %description -n %{develname}
217     This package contains the development header files and libraries necessary to
218     develop MySQL client applications.
219    
220     This package also contains the MySQL server as an embedded library.
221    
222     The embedded MySQL server library makes it possible to run a full-featured
223     MySQL server inside the client application. The main benefits are increased
224     speed and more simple management for embedded applications.
225    
226     The API is identical for the embedded MySQL version and the client/server
227     version.
228    
229     %package -n %{staticdevelname}
230     Summary: Static development libraries
231     Group: Development/Other
232     Requires: mysql-devel >= %{version}-%{release}
233     Provides: mysql-static-devel = %{version}-%{release}
234     Provides: %{libname}-static-devel = %{version}-%{release}
235     Obsoletes: %{libname}-static-devel
236    
237     %description -n %{staticdevelname}
238     This package contains the static development libraries.
239    
240     %prep
241    
242     %setup -q -n mysql-%{version}
243    
244     # fedora patches
245     %patch0 -p1 -b .errno
246     %patch1 -p1 -b .strmov
247     %patch2 -p1 -b .install-test
248     %patch3 -p1 -b .expired-certs
249     %patch4 -p1 -b .stack-guard
250     %patch5 -p1 -b .chain-certs
251     %patch6 -p1 -b .versioning
252     %patch7 -p1 -b .dubious-exports
253     %patch8 -p1 -b .disable-test
254    
255     # mandriva patches
256     %patch100 -p0 -b .mysqldumpslow_no_basedir
257     %patch101 -p0 -b .logrotate
258     %patch102 -p0 -b .initscript
259     %patch103 -p1 -b .mysql_upgrade-exit-status
260     %patch104 -p1 -b .shebang
261     %patch105 -p0 -b .test-variables-big
262     %patch106 -p0 -b .hotcopy
263     %patch107 -p0 -b .install_db-quiet
264     %patch108 -p1 -b .bug58350
265    
266     mkdir -p Mandriva
267     cp %{SOURCE2} Mandriva/mysqld.sysconfig
268     cp %{SOURCE3} Mandriva/my.cnf
269    
270     # lib64 fix
271     perl -pi -e "s|/usr/lib/|%{_libdir}/|g" Mandriva/my.cnf
272    
273     # antiborker
274     perl -pi -e "s|\@bindir\@|%{_bindir}|g" support-files/* scripts/*
275     perl -pi -e "s|\@sbindir\@|%{_sbindir}|g" support-files/* scripts/*
276     perl -pi -e "s|\@libexecdir\@|%{_sbindir}|g" support-files/* scripts/*
277     perl -pi -e "s|\@localstatedir\@|/var/lib/mysql|g" support-files/* scripts/*
278     perl -pi -e "s|^basedir=.*|basedir=%{_prefix}|g" support-files/* scripts/mysql_install_db*
279    
280     # this may be part of the problems with mysql-test
281     # http://bugs.mysql.com/bug.php?id=52223
282     #perl -pi -e "s|basedir/lib\b|basedir/%{_lib}\b|g" mysql-test/mysql-test-run.pl
283     #perl -pi -e "s|basedir/lib/|basedir/%{_lib}/|g" mysql-test/mysql-test-run.pl
284    
285     # workaround for upstream bug #56342
286     rm -f mysql-test/t/ssl_8k_key-master.opt
287    
288     # upstream has fallen down badly on symbol versioning, do it ourselves
289     cp %{SOURCE4} libmysql/libmysql.version
290    
291     %build
292     %serverbuild
293     export CFLAGS="${CFLAGS:-%{optflags}}"
294     export CXXFLAGS="${CXXFLAGS:-%{optflags}}"
295     export FFLAGS="${FFLAGS:-%{optflags}}"
296    
297     %cmake \
298     -DCMAKE_BUILD_TYPE=RelWithDebInfo \
299     -DCMAKE_INSTALL_PREFIX=%{_prefix} \
300     -DINSTALL_SBINDIR=sbin \
301     -DMYSQL_DATADIR=/var/lib/mysql \
302     -DSYSCONFDIR=%{_sysconfdir} \
303     -DINSTALL_PLUGINDIR=%{_lib}/mysql/plugin \
304     -DINSTALL_MANDIR=share/man \
305     -DINSTALL_SHAREDIR=share/mysql \
306     -DINSTALL_LIBDIR=%{_lib} \
307     -DINSTALL_INCLUDEDIR=include/mysql \
308     -DINSTALL_INFODIR=share/info \
309     -DINSTALL_MYSQLDATADIR=/var/lib/mysql \
310     -DINSTALL_MYSQLTESTDIR=share/mysql/mysql-test \
311     -DINSTALL_SQLBENCHDIR=share/mysql \
312     -DINSTALL_SUPPORTFILESDIR=share/mysql \
313     -DINSTALL_MYSQLSHAREDIR=share/mysql \
314     -DMYSQL_UNIX_ADDR=/var/lib/mysql/mysql.sock \
315     -DWITH_READLINE=0 \
316     -DWITH_LIBEDIT=0 \
317     -DWITH_LIBWRAP=1 \
318     -DWITH_SSL=system \
319     -DWITH_ZLIB=system \
320     -DWITH_PIC=1 \
321     -DMYSQL_TCP_PORT=3306 \
322     -DEXTRA_CHARSETS=all \
323     -DENABLED_LOCAL_INFILE=1 \
324     -DENABLE_DTRACE=1 \
325     -DWITH_EMBEDDED_SERVER=1 \
326     -DMYSQL_USER=%{muser} \
327     %if %{build_debug}
328     -DWITH_DEBUG=1 \
329     %else
330     -DWITH_DEBUG=0 \
331     %endif
332     -DWITHOUT_EXAMPLE_STORAGE_ENGINE=1 \
333     -DWITHOUT_NDBCLUSTER_STORAGE_ENGINE=1 \
334     -DWITHOUT_DAEMON_EXAMPLE=1 \
335     -DFEATURE_SET="community" \
336     -DCOMPILATION_COMMENT="Mandriva Linux - MySQL Community Edition (GPL)"
337    
338     cp ../libmysql/libmysql.version libmysql/libmysql.version
339    
340     %make
341    
342    
343     %install
344     rm -rf %{buildroot}
345    
346     # don't fiddle with the initscript!
347     export DONT_GPRINTIFY=1
348    
349     %if %{build_debug}
350     export DONT_STRIP=1
351     %endif
352    
353     install -d %{buildroot}%{_sysconfdir}/sysconfig
354     install -d %{buildroot}%{_initrddir}
355     install -d %{buildroot}%{_var}/run/mysqld
356     install -d %{buildroot}%{_var}/log/mysqld
357     install -d %{buildroot}/var/lib/mysql/{mysql,test}
358    
359     %makeinstall_std -C build
360    
361     # install init scripts
362     install -m0755 build/support-files/mysql.server %{buildroot}%{_initrddir}/mysqld
363    
364     # install configuration files
365     install -m0644 Mandriva/mysqld.sysconfig %{buildroot}%{_sysconfdir}/sysconfig/mysqld
366     install -m0644 Mandriva/my.cnf %{buildroot}%{_sysconfdir}/my.cnf
367    
368     # bork
369     mv %{buildroot}%{_bindir}/mysqlaccess.conf %{buildroot}%{_sysconfdir}/
370     chmod 644 %{buildroot}%{_sysconfdir}/mysqlaccess.conf
371     mv %{buildroot}%{_prefix}/scripts/mysql_install_db %{buildroot}%{_bindir}/
372     mv %{buildroot}%{_datadir}/mysql/aclocal %{buildroot}%{_datadir}/aclocal
373    
374     pushd %{buildroot}%{_bindir}
375     ln -sf mysqlcheck mysqlrepair
376     ln -sf mysqlcheck mysqlanalyze
377     ln -sf mysqlcheck mysqloptimize
378     popd
379    
380     # nuke -Wl,--as-needed from the mysql_config file
381     perl -pi -e "s|^ldflags=.*|ldflags=\'-rdynamic\'|g" %{buildroot}%{_bindir}/mysql_config
382    
383     # cmake generates some completely wacko references to -lprobes_mysql when
384     # building with dtrace support. Haven't found where to shut that off,
385     # so resort to this blunt instrument. While at it, let's not reference
386     # libmysqlclient_r anymore either.
387     sed -e 's/-lprobes_mysql//' -e 's/-lmysqlclient_r/-lmysqlclient/' \
388     %{buildroot}%{_bindir}/mysql_config >mysql_config.tmp
389     cp -f mysql_config.tmp %{buildroot}%{_bindir}/mysql_config
390     chmod 755 %{buildroot}%{_bindir}/mysql_config
391    
392     # libmysqlclient_r is no more. Upstream tries to replace it with symlinks
393     # but that really doesn't work (wrong soname in particular). We'll keep
394     # just the devel libmysqlclient_r.so link, so that rebuilding without any
395     # source change is enough to get rid of dependency on libmysqlclient_r.
396     rm -f %{buildroot}%{_libdir}/libmysqlclient_r.so*
397     ln -s libmysqlclient.so %{buildroot}%{_libdir}/libmysqlclient_r.so
398    
399     # mysql-test includes one executable that doesn't belong under /usr/share,
400     # so move it and provide a symlink
401     mv %{buildroot}%{_datadir}/mysql/mysql-test/lib/My/SafeProcess/my_safe_process %{buildroot}%{_bindir}
402     ln -s %{_bindir}/my_safe_process %{buildroot}%{_datadir}/mysql/mysql-test/lib/My/SafeProcess/my_safe_process
403    
404     # house cleaning
405     rm -rf %{buildroot}%{_datadir}/info
406     rm -f %{buildroot}%{_bindir}/mysqltest_embedded
407     rm -f %{buildroot}%{_bindir}/client_test
408     rm -f %{buildroot}%{_bindir}/make_win_binary_distribution
409     rm -f %{buildroot}%{_bindir}/make_win_src_distribution
410     rm -f %{buildroot}%{_datadir}/mysql/binary-configure
411     rm -f %{buildroot}%{_datadir}/mysql/config.huge.ini
412     rm -f %{buildroot}%{_datadir}/mysql/config.medium.ini
413     rm -f %{buildroot}%{_datadir}/mysql/config.small.ini
414     rm -f %{buildroot}%{_datadir}/mysql/mysqld_multi.server
415     rm -f %{buildroot}%{_datadir}/mysql/mysql-log-rotate
416     rm -f %{buildroot}%{_datadir}/mysql/mysql.server
417     rm -f %{buildroot}%{_datadir}/mysql/ndb-config-2-node.ini
418     rm -f %{buildroot}%{_datadir}/mysql/binary-configure
419     rm -f %{buildroot}%{_mandir}/man1/make_win_bin_dist.1*
420     rm -f %{buildroot}%{_mandir}/man1/make_win_src_distribution.1*
421     rm -f %{buildroot}%{_datadir}/mysql/magic
422    
423     # no idea how to fix this
424     rm -rf %{buildroot}%{_prefix}/data
425     rm -rf %{buildroot}%{_prefix}/docs
426     rm -rf %{buildroot}%{_prefix}/scripts
427     rm -f %{buildroot}%{_prefix}/COPYING
428     rm -f %{buildroot}%{_prefix}/INSTALL-BINARY
429     rm -f %{buildroot}%{_prefix}/README
430    
431     %multiarch_binaries %{buildroot}%{_bindir}/mysql_config
432     %multiarch_includes %{buildroot}%{_includedir}/mysql/my_config.h
433    
434     cat > README.urpmi <<EOF
435    
436     The initscript used to start mysql has been reverted to use the one shipped
437     by MySQL AB. This means the following changes:
438    
439     * The generation of the initial system mysql database is now done when mysql
440     is started from the initscript and only if the /var/lib/mysql/mysql
441     directory is empty (mysql_install_db). Previousely this was quite hidden and
442     silently done at (rpm) install time. As a consequence to this change you may
443     have to perform some manual tasks to upgrade the mysql system database and
444     such. So, doing something like this might help you:
445    
446     /etc/rc.d/init.d/mysqld stop
447     TMPDIR=/var/tmp mysql_install_db
448     mysql_upgrade
449    
450     The cluster functionalities (ndb) has been deactivated and will be removed in
451     future mysql versions. A new product named mysql-cluster has been added (in
452     contrib) that replaces the cluster functionalities.
453    
454     The mysql-common-core package ships with a default /etc/my.cnf file that is
455     based on the my-medium.cnf file that comes with the source code.
456    
457     Starting from mysql-5.1.43-2 the storage engines is built as dynamically
458     loadable modules. You can either load the engines using the /etc/my.cnf file or
459     at runtime. Please look at these lines in the /etc/my.cnf file to enable
460     additional engines or disable one or more of the default ones:
461    
462     plugin_dir=%{_libdir}/mysql/plugin
463     plugin-load=ha_archive.so;ha_blackhole.so;ha_federated.so
464    
465     Starting from mysql-5.1.44-3 the html documentation and the mysql.info is not
466     shipped with the Mandriva packages due to strict licensing.
467    
468     EOF
469    
470     ################################################################################
471     # run the tests
472     %if %{build_test}
473     # disable failing tests
474     echo "rpl_trigger : Unstable test case" >> mysql-test/t/disabled.def
475     echo "type_enum : Unstable test case" >> mysql-test/t/disabled.def
476     echo "windows : For MS Windows only" >> mysql-test/t/disabled.def
477     pushd build/mysql-test
478     export LANG=C
479     export LC_ALL=C
480     export LANGUAGE=C
481     perl ./mysql-test-run.pl \
482     --mtr-build-thread="$((${RANDOM} % 100))" \
483     --skip-ndb \
484     --timer \
485     --retry=0 \
486     --ssl \
487     --mysqld=--binlog-format=mixed \
488     --testcase-timeout=60 \
489     --suite-timeout=120 || false
490     popd
491     %endif
492    
493     %pre
494     # enable plugins
495     if [ -f %{_sysconfdir}/my.cnf ]; then
496     perl -pi -e "s|^#plugin-load|plugin-load|g" %{_sysconfdir}/my.cnf
497     perl -pi -e "s|^#federated|federated|g" %{_sysconfdir}/my.cnf
498     fi
499    
500     %pre common
501     # delete the mysql group if no mysql user is found, before adding the user
502     if [ -z "`getent passwd %{muser}`" ] && ! [ -z "`getent group %{muser}`" ]; then
503     %{_sbindir}/groupdel %{muser} 2> /dev/null || :
504     fi
505    
506     %_pre_useradd %{muser} /var/lib/mysql /bin/bash
507    
508     %post common
509    
510     %post
511     # Change permissions so that the user that will run the MySQL daemon
512     # owns all needed files.
513     chown -R %{muser}:%{muser} /var/lib/mysql /var/run/mysqld /var/log/mysqld
514    
515     # make sure the /var/lib/mysql directory can be accessed
516     chmod 711 /var/lib/mysql
517    
518     %_post_service mysqld
519    
520     %preun
521     %_preun_service mysqld
522    
523     %postun
524     if [ "$1" = "0" ]; then
525     if [ -f /var/lock/subsys/mysqld ]; then
526     %{_initrddir}/mysqld restart > /dev/null 2>/dev/null || :
527     fi
528     fi
529    
530     %pre common-core
531     # enable plugins
532     if [ -f %{_sysconfdir}/my.cnf ]; then
533     perl -pi -e "s|^#plugin-load|plugin-load|g" %{_sysconfdir}/my.cnf
534     perl -pi -e "s|^#federated|federated|g" %{_sysconfdir}/my.cnf
535     fi
536    
537     %if %mdkversion < 200900
538     %post -n %{libname} -p /sbin/ldconfig
539     %endif
540    
541     %if %mdkversion < 200900
542     %postun -n %{libname} -p /sbin/ldconfig
543     %endif
544    
545     %clean
546     rm -rf %{buildroot}
547    
548     %files
549     %defattr(-,root,root)
550     %doc README.urpmi
551     %attr(0755,root,root) %{_initrddir}/mysqld
552     %dir %{_libdir}/mysql/plugin
553     %attr(0755,root,root) %{_libdir}/mysql/plugin/adt_null.so
554     %attr(0755,root,root) %{_libdir}/mysql/plugin/auth.so
555     %attr(0755,root,root) %{_libdir}/mysql/plugin/auth_socket.so
556     %attr(0755,root,root) %{_libdir}/mysql/plugin/auth_test_plugin.so
557     %attr(0755,root,root) %{_libdir}/mysql/plugin/ha_archive.so
558     %attr(0755,root,root) %{_libdir}/mysql/plugin/ha_blackhole.so
559     %attr(0755,root,root) %{_libdir}/mysql/plugin/ha_federated.so
560     %attr(0755,root,root) %{_libdir}/mysql/plugin/mypluglib.so
561     %attr(0755,root,root) %{_libdir}/mysql/plugin/qa_auth_client.so
562     %attr(0755,root,root) %{_libdir}/mysql/plugin/qa_auth_interface.so
563     %attr(0755,root,root) %{_libdir}/mysql/plugin/qa_auth_server.so
564     %attr(0755,root,root) %{_libdir}/mysql/plugin/semisync_master.so
565     %attr(0755,root,root) %{_libdir}/mysql/plugin/semisync_slave.so
566    
567     %files client
568     %defattr(-,root,root)
569     %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/mysqlaccess.conf
570     %attr(0755,root,root) %{_bindir}/msql2mysql
571     %attr(0755,root,root) %{_bindir}/mysql
572     %attr(0755,root,root) %{_bindir}/mysqlaccess
573     %attr(0755,root,root) %{_bindir}/mysqladmin
574     %attr(0755,root,root) %{_bindir}/mysqlanalyze
575     %attr(0755,root,root) %{_bindir}/mysqlbinlog
576     %attr(0755,root,root) %{_bindir}/mysqlcheck
577     %attr(0755,root,root) %{_bindir}/mysqldump
578     %attr(0755,root,root) %{_bindir}/mysqldumpslow
579     %attr(0755,root,root) %{_bindir}/mysql_find_rows
580     %attr(0755,root,root) %{_bindir}/mysqlimport
581     %attr(0755,root,root) %{_bindir}/mysqloptimize
582     %attr(0755,root,root) %{_bindir}/mysqlrepair
583     %attr(0755,root,root) %{_bindir}/mysqlshow
584     %attr(0755,root,root) %{_bindir}/mysqlslap
585     %attr(0755,root,root) %{_bindir}/mysql_waitpid
586     %attr(0644,root,root) %{_mandir}/man1/msql2mysql.1*
587     %attr(0644,root,root) %{_mandir}/man1/myisam_ftdump.1*
588     %attr(0644,root,root) %{_mandir}/man1/mysql.1*
589     %attr(0644,root,root) %{_mandir}/man1/mysqlaccess.1*
590     %attr(0644,root,root) %{_mandir}/man1/mysqladmin.1*
591     %attr(0644,root,root) %{_mandir}/man1/mysqlbinlog.1*
592     %attr(0644,root,root) %{_mandir}/man1/mysqlcheck.1*
593     %attr(0644,root,root) %{_mandir}/man1/mysqldump.1*
594     %attr(0644,root,root) %{_mandir}/man1/mysqldumpslow.1*
595     %attr(0644,root,root) %{_mandir}/man1/mysql_find_rows.1*
596     %attr(0644,root,root) %{_mandir}/man1/mysqlimport.1*
597     %attr(0644,root,root) %{_mandir}/man1/mysqlshow.1*
598     %attr(0644,root,root) %{_mandir}/man1/mysql_waitpid.1*
599    
600     %files bench
601     %defattr(-,root,root)
602     %doc build/sql-bench/README
603     %attr(0755,root,root) %{_bindir}/my_safe_process
604     %attr(0755,root,root) %{_bindir}/mysql_client_test
605     %attr(0755,root,root) %{_bindir}/mysql_client_test_embedded
606     %{_datadir}/mysql/sql-bench
607     %attr(-,mysql,mysql) %{_datadir}/mysql/mysql-test
608     %attr(0644,root,root) %{_mandir}/man1/mysql-stress-test.pl.1*
609     %attr(0644,root,root) %{_mandir}/man1/mysql-test-run.pl.1*
610     %attr(0644,root,root) %{_mandir}/man1/mysql_client_test.1*
611     %attr(0644,root,root) %{_mandir}/man1/mysql_client_test_embedded.1*
612     %attr(0644,root,root) %{_mandir}/man1/mysqltest.1*
613     %attr(0644,root,root) %{_mandir}/man1/mysqltest_embedded.1*
614    
615     %files core
616     %defattr(-,root,root)
617     %attr(0755,root,root) %{_sbindir}/mysqld
618    
619     %files common-core
620     %defattr(-,root,root)
621     %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/my.cnf
622     %dir %{_datadir}/mysql
623     %{_datadir}/mysql/english
624     %{_datadir}/mysql/charsets
625    
626     %files common
627     %defattr(-,root,root)
628     %doc README COPYING
629     %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/mysqld
630     %attr(0755,root,root) %{_bindir}/innochecksum
631     %attr(0755,root,root) %{_bindir}/myisamchk
632     %attr(0755,root,root) %{_bindir}/myisam_ftdump
633     %attr(0755,root,root) %{_bindir}/myisamlog
634     %attr(0755,root,root) %{_bindir}/myisampack
635     %attr(0755,root,root) %{_bindir}/my_print_defaults
636     %attr(0755,root,root) %{_bindir}/mysqlbug
637     %attr(0755,root,root) %{_bindir}/mysql_convert_table_format
638     %attr(0755,root,root) %{_bindir}/mysqld_multi
639     %attr(0755,root,root) %{_bindir}/mysqld_safe
640     %attr(0755,root,root) %{_bindir}/mysql_fix_extensions
641     %attr(0755,root,root) %{_bindir}/mysqlhotcopy
642     %attr(0755,root,root) %{_bindir}/mysql_install_db
643     %attr(0755,root,root) %{_bindir}/mysql_secure_installation
644     %attr(0755,root,root) %{_bindir}/mysql_setpermission
645     %attr(0755,root,root) %{_bindir}/mysqltest
646     %attr(0755,root,root) %{_bindir}/mysql_tzinfo_to_sql
647     %attr(0755,root,root) %{_bindir}/mysql_upgrade
648     %attr(0755,root,root) %{_bindir}/mysql_zap
649     %attr(0755,root,root) %{_bindir}/perror
650     %attr(0755,root,root) %{_bindir}/replace
651     %attr(0755,root,root) %{_bindir}/resolveip
652     %attr(0755,root,root) %{_bindir}/resolve_stack_dump
653     %attr(0711,%{muser},%{muser}) %dir /var/lib/mysql
654     %attr(0711,%{muser},%{muser}) %dir /var/lib/mysql/mysql
655     %attr(0711,%{muser},%{muser}) %dir /var/lib/mysql/test
656     %attr(0755,%{muser},%{muser}) %dir %{_var}/run/mysqld
657     %attr(0755,%{muser},%{muser}) %dir %{_var}/log/mysqld
658     %{_datadir}/mysql/*.cnf
659     %{_datadir}/mysql/fill_help_tables.sql
660     %{_datadir}/mysql/mysql_system_tables.sql
661     %{_datadir}/mysql/mysql_system_tables_data.sql
662     %{_datadir}/mysql/mysql_test_data_timezone.sql
663     %{_datadir}/mysql/errmsg-utf8.txt
664     %{_datadir}/mysql/czech
665     %{_datadir}/mysql/danish
666     %{_datadir}/mysql/dutch
667     %{_datadir}/mysql/estonian
668     %{_datadir}/mysql/french
669     %{_datadir}/mysql/german
670     %{_datadir}/mysql/greek
671     %{_datadir}/mysql/hungarian
672     %{_datadir}/mysql/italian
673     %{_datadir}/mysql/japanese
674     %{_datadir}/mysql/korean
675     %{_datadir}/mysql/norwegian
676     %{_datadir}/mysql/norwegian-ny
677     %{_datadir}/mysql/polish
678     %{_datadir}/mysql/portuguese
679     %{_datadir}/mysql/romanian
680     %{_datadir}/mysql/russian
681     %{_datadir}/mysql/serbian
682     %{_datadir}/mysql/slovak
683     %{_datadir}/mysql/spanish
684     %{_datadir}/mysql/swedish
685     %{_datadir}/mysql/ukrainian
686     %attr(0644,root,root) %{_mandir}/man1/innochecksum.1*
687     %attr(0644,root,root) %{_mandir}/man1/myisamchk.1*
688     %attr(0644,root,root) %{_mandir}/man1/myisamlog.1*
689     %attr(0644,root,root) %{_mandir}/man1/myisampack.1*
690     %attr(0644,root,root) %{_mandir}/man1/my_print_defaults.1*
691     %attr(0644,root,root) %{_mandir}/man1/mysqlbug.1*
692     %attr(0644,root,root) %{_mandir}/man1/mysql_convert_table_format.1*
693     %attr(0644,root,root) %{_mandir}/man1/mysqld_multi.1*
694     %attr(0644,root,root) %{_mandir}/man1/mysqld_safe.1*
695     %attr(0644,root,root) %{_mandir}/man1/mysql_fix_extensions.1*
696     %attr(0644,root,root) %{_mandir}/man1/mysqlhotcopy.1*
697     %attr(0644,root,root) %{_mandir}/man1/mysql_install_db.1*
698     %attr(0644,root,root) %{_mandir}/man1/mysqlman.1*
699     %attr(0644,root,root) %{_mandir}/man1/mysql_secure_installation.1*
700     %attr(0644,root,root) %{_mandir}/man1/mysql.server.1*
701     %attr(0644,root,root) %{_mandir}/man1/mysql_setpermission.1*
702     %attr(0644,root,root) %{_mandir}/man1/mysqlslap.1*
703     %attr(0644,root,root) %{_mandir}/man1/mysql_tzinfo_to_sql.1*
704     %attr(0644,root,root) %{_mandir}/man1/mysql_upgrade.1*
705     %attr(0644,root,root) %{_mandir}/man1/mysql_zap.1*
706     %attr(0644,root,root) %{_mandir}/man1/perror.1*
707     %attr(0644,root,root) %{_mandir}/man1/replace.1*
708     %attr(0644,root,root) %{_mandir}/man1/resolveip.1*
709     %attr(0644,root,root) %{_mandir}/man1/resolve_stack_dump.1*
710     %attr(0644,root,root) %{_mandir}/man8/mysqld.8*
711    
712     %files -n %{libname}
713     %defattr(-,root,root)
714     %doc Docs/ChangeLog
715     %attr(0755,root,root) %{_libdir}/libmysqlclient.so.%{major}*
716     # not sure about this one...
717     %attr(0755,root,root) %{_libdir}/libmysqlservices.so
718    
719     %files -n %{develname}
720     %defattr(-,root,root)
721     %doc INSTALL-SOURCE
722     %multiarch %{multiarch_bindir}/mysql_config
723     %attr(0755,root,root) %{_bindir}/mysql_config
724     %attr(0755,root,root) %{_libdir}/libmysqlclient_r.so
725     %attr(0755,root,root) %{_libdir}/libmysqlclient.so
726     %dir %{_includedir}/mysql
727     %dir %{_includedir}/mysql/psi
728     %attr(0644,root,root) %{_includedir}/mysql/*.h
729     %attr(0644,root,root) %{_includedir}/mysql/psi/*.h
730     %multiarch %{multiarch_includedir}/mysql/my_config.h
731     %attr(0644,root,root) %{_mandir}/man1/comp_err.1*
732     %attr(0644,root,root) %{_mandir}/man1/mysql_config.1*
733     %attr(0644,root,root) %{_datadir}/aclocal/mysql.m4
734    
735     %files -n %{staticdevelname}
736     %defattr(-,root,root)
737     %attr(0644,root,root) %{_libdir}/*.a
738    
739    

  ViewVC Help
Powered by ViewVC 1.1.30