/[packages]/updates/5/gnome-shell/current/SPECS/gnome-shell.spec
ViewVC logotype

Contents of /updates/5/gnome-shell/current/SPECS/gnome-shell.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1188850 - (show annotations) (download)
Mon Jan 1 18:29:15 2018 UTC (6 years, 3 months ago) by luigiwalser
File size: 7088 byte(s)
add one more patch to CVE-2017-8288 fixes
1 %define url_ver %(echo %{version}|cut -d. -f1,2)
2
3 %define mutter_ver %(echo %{version}|cut -d. -f1,2,3)
4 # To make GNOME Shell extensions load, we need to get rid of DT_RUNPATH on /usr/bin/gnome-shell
5 # (see glibc bug #13945, GNOME bug #670477, Mageia bug #4523)
6 %define _disable_ld_enable_new_dtags 1
7
8 Summary: Core user interface for the GNOME 3 desktop
9 Name: gnome-shell
10 Version: 3.14.3
11 %define subrel 3
12 Release: %mkrel 8
13 Source0: https://download.gnome.org/sources/%{name}/%{url_ver}/%{name}-%{version}.tar.xz
14 Source1: gnome-shell-session
15 Patch1: 0001-screenShield-Allow-for-custom-backgrounds-on-lock-lo.patch
16 Patch2: gnome-shell-system-Fix-visibility-of-suspend-button.patch
17 Patch3: gnome-shell-Refresh-all-background-instances-after-suspend-if-needed.patch
18 Patch4: gnome-shell-authPrompt-Fix-hang-if-user-types-password-really-fast.patch
19 Patch5: gnome-shell-Delay-caribou-daemon-invocation.patch
20 Patch6: gnome-shell-ISO-week-number.patch
21 Patch7: 0001-extensions-Consistently-handle-createExtensionObject.patch
22 Patch8: 0002-extensionSystem-Catch-import-errors.patch
23 Patch9: 0003-extensionSystem-Handle-all-initExtension-extension-e.patch
24 Patch10: gnome-shell-3.24.1-CVE-2017-8288.patch
25 Patch100: gnome-shell-3.6.3.1-fix-evolution-calendar.patch
26
27 License: GPLv2+ and LGPLv2+
28 Group: Graphical desktop/GNOME
29 Url: https://wiki.gnome.org/GnomeShell
30 BuildRequires: pkgconfig(clutter-1.0)
31 BuildRequires: pkgconfig(clutter-glx-1.0) >= 1.7.5
32 BuildRequires: pkgconfig(clutter-x11-1.0) >= 1.7.5
33 BuildRequires: pkgconfig(folks) >= 0.5.2
34 BuildRequires: pkgconfig(gcr-3) >= 3.8.0
35 BuildRequires: pkgconfig(gdk-pixbuf-2.0)
36 BuildRequires: pkgconfig(gdk-x11-3.0)
37 BuildRequires: pkgconfig(gio-unix-2.0) >= 2.31.6
38 BuildRequires: pkgconfig(gjs-internals-1.0) >= 1.29.18
39 BuildRequires: pkgconfig(gl)
40 BuildRequires: pkgconfig(gnome-bluetooth-1.0) >= 3.1.0
41 BuildRequires: pkgconfig(gnome-desktop-3.0) >= 2.90.0
42 BuildRequires: pkgconfig(gnome-keyring-1)
43 BuildRequires: pkgconfig(gnome-keybindings)
44 BuildRequires: pkgconfig(gobject-2.0)
45 BuildRequires: pkgconfig(gobject-introspection-1.0) >= 0.10.1
46 BuildRequires: pkgconfig(gsettings-desktop-schemas) >= 0.1.7
47 BuildRequires: pkgconfig(gstreamer-1.0) >= 0.11.92
48 BuildRequires: pkgconfig(gstreamer-base-1.0)
49 BuildRequires: pkgconfig(gtk+-3.0) >= 3.3.9
50 BuildRequires: pkgconfig(gtk-doc)
51 BuildRequires: pkgconfig(libcanberra)
52 BuildRequires: pkgconfig(libcroco-0.6) >= 0.6.2
53 BuildRequires: pkgconfig(libecal-1.2) >= 2.32.0
54 BuildRequires: pkgconfig(libedataserver-1.2) >= 1.2.0
55 BuildRequires: pkgconfig(libgnome-menu-3.0)
56 BuildRequires: pkgconfig(libmutter) >= %{mutter_ver}
57 # ovitters: experimental Wayland
58 BuildRequires: pkgconfig(libnm-glib)
59 BuildRequires: pkgconfig(libnm-util)
60 BuildRequires: pkgconfig(libnm-gtk)
61 BuildRequires: pkgconfig(libpulse)
62 BuildRequires: pkgconfig(libpulse-mainloop-glib)
63 BuildRequires: pkgconfig(libsoup-2.4)
64 BuildRequires: pkgconfig(libstartup-notification-1.0) >= 0.11
65 BuildRequires: pkgconfig(libxml-2.0)
66 BuildRequires: pkgconfig(polkit-agent-1) >= 0.100
67 BuildRequires: pkgconfig(libsystemd-login)
68 BuildRequires: pkgconfig(libsystemd-daemon)
69 BuildRequires: pkgconfig(telepathy-glib) >= 0.17.5
70 BuildRequires: pkgconfig(telepathy-logger-0.2) >= 0.2.4
71 BuildRequires: pkgconfig(x11)
72 BuildRequires: pkgconfig(xfixes)
73 BuildRequires: pkgconfig(caribou-1.0)
74 BuildRequires: intltool >= 0.40.0
75 BuildRequires: gnome-common
76 BuildRequires: gettext-devel
77 Requires: mutter >= %{mutter_ver}
78 Requires: gjs
79 Requires: glxinfo
80 Requires: gnome-session
81 Requires: adwaita-icon-theme
82 # For a GSettings schema
83 Requires: gnome-settings-daemon
84 Requires: gsettings-desktop-schemas >= 3.9.2
85 Requires: packagekit-gtk3-module
86 Requires: telepathy-mission-control
87 Requires: gnome-control-center
88 # mga#11640 when there are multiple keyboard layouts, "Show Keyboard Layouts" option
89 Requires: libgnomekbd-common
90 # (tmb) require both libs providing typelib(Meta) so it always work (reported by tv)
91 Requires: %{_lib}mutter-gir3.0
92 Requires: %{_lib}mutter-wayland-gir3.0
93
94 # gnome-shell handles notifications natively, no notification-daemon needed
95 Provides: virtual-notification-daemon
96 # and ditto for polkit authorisation dialogs
97 Provides: polkit-agent
98
99 # --- gir/typelibs not automatically required ---
100 # mga#14269 I don't think this is needed, but Mageia 5 should get out
101 Requires: typelib(GcrUi)
102
103 # (cg) gnome-shell needs schemas defined/shipped with gdm and needs gdm for
104 # screen locking. Technically, this could be relaxed upstream and the schema
105 # moved to gsettings-desktop-schemas, so if that happens, the dep can be relaxed
106 # https://bugs.mageia.org/show_bug.cgi?id=14430
107 Requires: gdm
108
109 # (ovitters) extensions depend on 'unzip' being available; mga#16005
110 Requires: unzip
111
112 Obsoletes: gnome-applet-netspeed < 3.0.2
113
114 %description
115 GNOME Shell provides core user interface functions for the GNOME 3
116 desktop, like switching to windows and launching applications. GNOME
117 Shell takes advantage of the capabilities of modern graphics hardware
118 and introduces innovative user interface concepts to provide a
119 visually attractive and easy to use experience.
120
121 %package docs
122 Summary: Documentation for %{name}
123 Group: Documentation
124 BuildArch: noarch
125
126 %description docs
127 This package contains the documentation for %{name}.
128
129 %prep
130 %setup -q
131 %apply_patches
132
133 %build
134 %configure2_5x \
135 --enable-compile-warnings=no \
136 --disable-static --disable-schemas-compile
137 %make V=1
138
139 %install
140 GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 %makeinstall_std
141
142 %find_lang %name
143
144 mkdir -p %{buildroot}/%{_datadir}/gnome-shell/xdg-override/autostart
145 cp -f %{buildroot}/%{_datadir}/applications/gnome-shell.desktop %{buildroot}/%{_datadir}/gnome-shell/xdg-override/autostart
146
147 find %{buildroot} -name '*.la' -delete
148
149 install -m 755 %{SOURCE1} %{buildroot}/%{_datadir}/gnome-shell/
150
151 %files -f %name.lang
152 %doc README
153 %{_bindir}/*
154 %{_libdir}/%{name}
155 %{_libexecdir}/gnome-shell-calendar-server
156 %{_libexecdir}/gnome-shell-perf-helper
157 %{_libexecdir}/gnome-shell-hotplug-sniffer
158 %{_libexecdir}/gnome-shell-portal-helper
159 %{_libdir}/mozilla/plugins/*.so
160 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
161 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
162 %{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
163 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
164 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
165 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
166 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
167 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
168 %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
169 %{_datadir}/applications/%{name}.desktop
170 # ovitters: Experimental Wayland support
171 %{_datadir}/applications/%{name}-wayland.desktop
172 %{_datadir}/applications/evolution-calendar.desktop
173 %{_datadir}/applications/gnome-shell-extension-prefs.desktop
174 %{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
175 %{_datadir}/gnome-control-center/keybindings/*%{name}*.xml
176 %{_datadir}/%{name}
177 %{_mandir}/man1/%{name}.1*
178
179 %files docs
180 %{_datadir}/gtk-doc/html/shell
181 %{_datadir}/gtk-doc/html/st

  ViewVC Help
Powered by ViewVC 1.1.30