/[packages]/updates/5/graphicsmagick/current/SPECS/graphicsmagick.spec
ViewVC logotype

Contents of /updates/5/graphicsmagick/current/SPECS/graphicsmagick.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1182440 - (show annotations) (download)
Tue Dec 12 14:34:28 2017 UTC (6 years, 4 months ago) by ns80
File size: 8029 byte(s)
- new version 1.3.27 that corrects many security issues (mga#21600)

1 %define build_modules 1
2 %{?_with_modules: %global build_modules 1}
3
4 %define enable_jasper 1
5 %{?_with_jasper: %global enable_jasper 1}
6
7 %define enable_graphwiz 1
8 %{?_with_graphwiz: %global enable_graphwiz 1}
9
10 %define upstream_name GraphicsMagick
11 %define major 3
12 %define libname %mklibname %{name} %{major}
13 %define ppmajor 12
14 %define libppname %mklibname %{name}++ %{ppmajor}
15 %define libwandname %mklibname graphicsmagickwand 2
16 %define develname %mklibname %{name} -d
17 %define qlev Q8
18
19 Summary: An X application for displaying and manipulating images
20 Name: graphicsmagick
21 Version: 1.3.27
22 Release: %mkrel 1
23 License: GPLv2+
24 Group: Graphics/Editors and Converters
25 URL: http://www.graphicsmagick.org/
26 Source0: http://downloads.sourceforge.net/%{name}/%{upstream_name}-%{version}.tar.xz
27 Patch0: GraphicsMagick-1.3.15-use-so-for-modules.patch
28 Patch1: GraphicsMagick-1.3.16-perl-link.patch
29
30 # Upstream patches
31 BuildRequires: x11-proto-devel
32 BuildRequires: perl-devel
33 BuildRequires: freetype2-devel
34 BuildRequires: tiff-devel
35 BuildRequires: png-devel
36 BuildRequires: jpeg-devel
37 BuildRequires: jasper-devel
38 BuildRequires: libwmf-devel
39 BuildRequires: zlib-devel
40 BuildRequires: bzip2-devel
41 BuildRequires: libxml2-devel
42 BuildRequires: lcms-devel
43 BuildRequires: lcms2-devel
44 BuildRequires: libgs-devel
45 BuildRequires: libtool-devel
46 BuildRequires: jbigkit-devel
47 BuildRequires: chrpath
48
49 %description
50 GraphicsMagick is the swiss army knife of image processing. It
51 provides a robust collection of tools and libraries which support
52 reading, writing, and manipulating an image in over 88 major formats
53 including important formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF,
54 SVG, and TIFF. GraphicsMagick supports huge images on systems that
55 support large files, and has been tested with gigapixel-size images.
56 GraphicsMagick can create new images on the fly, making it suitable
57 for building dynamic Web applications. GraphicsMagick may be used to
58 resize, rotate, sharpen, color reduce, or add special effects to an
59 image and save the result in the same or differing image format.
60 Image processing operations are available from the command line, as
61 well as through C, C++, Perl, or Windows COM programming interfaces.
62 Extensions are available from third-parties to support programming in
63 Python, Tcl, and Ruby. With some modification, language extensions for
64 ImageMagick may be used.
65
66 %files
67 %doc ChangeLog *.txt
68 %{_bindir}/gm
69 %dir %{_libdir}/GraphicsMagick-%{version}/config
70 %{_libdir}/GraphicsMagick-%{version}/config/*.mgk
71 %dir %{_datadir}/GraphicsMagick-%{version}/config
72 %{_datadir}/GraphicsMagick-%{version}/config/*.mgk
73 %if %build_modules
74 %dir %{_libdir}/%{upstream_name}-%{version}/modules-%{qlev}
75 %{_libdir}/%{upstream_name}-%{version}/modules-%{qlev}/filters
76 %dir %{_libdir}/%{upstream_name}-%{version}/modules-%{qlev}/coders
77 %{_libdir}/%{upstream_name}-%{version}/modules-%{qlev}/coders/*.so
78 %endif
79 %{_mandir}/man1/GraphicsMagick++-config.1.*
80 %{_mandir}/man1/GraphicsMagick-config.1.*
81 %{_mandir}/man1/GraphicsMagickWand-config.1.*
82 %{_mandir}/man1/gm.1.*
83 %{_mandir}/man4/miff.4.*
84 %{_mandir}/man5/quantize.5.*
85
86 #--------------------------------------------------------------
87
88 %package -n %{libname}
89 Summary: %upstream_name libraries
90 Group: System/Libraries
91
92 %description -n %{libname}
93 This package contains the libraries needed to run programs dynamically
94 linked with GraphicsMagick libraries.
95
96 %files -n %{libname}
97 %{_libdir}/libGraphicsMagick.so.%{major}*
98
99 #--------------------------------------------------------------
100
101 %package -n %{libppname}
102 Summary: %upstream_name C++ libraries
103 Group: System/Libraries
104
105 %description -n %{libppname}
106 This package contains the libraries needed to run C++ programs dynamically
107 linked with GraphicsMagick libraries.
108
109 %files -n %{libppname}
110 %{_libdir}/libGraphicsMagick++.so.%{ppmajor}*
111
112 #--------------------------------------------------------------
113
114 %package -n %{libwandname}
115 Summary: %upstream_name libraries
116 Group: System/Libraries
117
118 %description -n %{libwandname}
119 This package contains the libraries needed to run programs dynamically
120 linked with GraphicsMagick libraries.
121
122 %files -n %{libwandname}
123 %{_libdir}/libGraphicsMagickWand.so.2*
124
125 #--------------------------------------------------------------
126
127 %package -n %{develname}
128 Summary: Static libraries and header files for %{upstream_name} app development
129 Group: Development/C
130 Provides: %{name}-devel = %{version}-%{release}
131 Provides: %{upstream_name}-devel = %{version}-%{release}
132 Obsoletes: %mklibname -d graphicsmagick 1.1.10
133 Requires: %{libname} = %{version}
134 Requires: %{libppname} = %{version}
135 Requires: %{libwandname} = %{version}
136 Requires: jbig-devel
137 %if %{enable_jasper}
138 Requires: jasper-devel
139 %endif
140 %if %{enable_graphwiz}
141 Requires: graphviz-devel
142 %global __requires_exclude devel\\(libcdt\\)|devel\\(libcircogen\\)|devel\\(libcommon\\)|devel\\(libdotgen\\)|devel\\(libdotneato\\)|devel\\(libfdpgen\\)|devel\\(libgraph\\)|devel\\(libgvrender\\)|devel\\(libneatogen\\)|devel\\(libpack\\)|devel\\(libpathplan\\)|devel\\(libtwopigen\\)|devel\\(libgvc\\)|devel\\(libgvgd\\)
143 %endif
144
145 %description -n %{develname}
146 If you want to create applications that will use GraphicsMagick code or
147 APIs, you'll need to install these packages as well as
148 GraphicsMagick. These additional packages aren't necessary if you simply
149 want to use GraphicsMagick, however.
150
151 graphicsmagick-devel is an addition to GraphicsMagick which includes static
152 libraries and header files necessary to develop applications.
153
154 %files -n %{develname}
155 %{_bindir}/GraphicsMagick++-config
156 %{_bindir}/GraphicsMagick-config
157 %{_bindir}/GraphicsMagickWand-config
158 %dir %{_includedir}/GraphicsMagick
159 %{_includedir}/GraphicsMagick/Magick++.h
160 %dir %{_includedir}/GraphicsMagick/magick
161 %{_includedir}/GraphicsMagick/magick/*.h
162 %dir %{_includedir}/GraphicsMagick/Magick++
163 %{_includedir}/GraphicsMagick/Magick++/*.h
164 %dir %{_includedir}/GraphicsMagick/wand
165 %{_includedir}/GraphicsMagick/wand/*.h
166 %{_libdir}/*.so
167 %{_libdir}/pkgconfig/*.pc
168
169 #--------------------------------------------------------------
170
171 %package -n perl-Graphics-Magick
172 Summary: Libraries and modules for access to %upstream_name from perl
173 Group: Development/Perl
174 Requires: %{name} = %{version}
175 %if %{enable_graphwiz}
176 Requires: graphviz
177 %endif
178
179 %description -n perl-Graphics-Magick
180 This is the %upstream_name perl support package. It includes perl modules
181 and support files for access to GraphicsMagick library from perl.
182
183 %files -n perl-Graphics-Magick
184 %{_mandir}/man3*/*::*.3pm*
185 %{perl_vendorarch}/Graphics
186 %{perl_vendorarch}/auto
187
188 #--------------------------------------------------------------
189
190 %package doc
191 Summary: %{name} Documentation
192 Group: Documentation
193 BuildArch: noarch
194
195 %description doc
196 This package contains HTML/PDF documentation of %{name}.
197
198 %files doc
199 %{_datadir}/doc/GraphicsMagick
200
201 #--------------------------------------------------------------
202
203 %prep
204 %autosetup -p1 -n %{upstream_name}-%{version}
205
206 %build
207 %define Werror_cflags %nil
208 %configure2_5x \
209 --enable-fast-install \
210 --without-dps \
211 %if %{build_modules}
212 --with-modules \
213 %else
214 --without-modules \
215 %endif
216 --enable-shared \
217 --disable-static \
218 --with-pic \
219 %if %{enable_jasper}
220 --with-jp2 \
221 %else
222 --without-jp2 \
223 %endif
224 --with-perl-options="INSTALLDIRS=vendor" \
225 --with-perl
226
227 %make_build
228 %make_build perl-build
229
230 %install
231 %make_install
232 %make_install -C PerlMagick
233
234 # fix rights and remove rpaths
235 chmod 755 %{buildroot}%{perl_vendorarch}/auto/Graphics/Magick/Magick.so
236 chrpath -d %{buildroot}%{perl_vendorarch}/auto/Graphics/Magick/Magick.so
237
238 # remove unwanted files
239 find %{buildroot} -name '*.la' -delete
240 rm -f %{buildroot}%{_datadir}/GraphicsMagick-%{version}/{ChangeLog,NEWS.txt}

  ViewVC Help
Powered by ViewVC 1.1.30