/[packages]/updates/5/python-django/current/SPECS/python-django.spec
ViewVC logotype

Annotation of /updates/5/python-django/current/SPECS/python-django.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 280862 - (hide annotations) (download)
Sun Aug 12 12:44:00 2012 UTC (11 years, 8 months ago) by philippem
Original Path: cauldron/python-django/current/SPECS/python-django.spec
File size: 1453 byte(s)
Fix #6986 several security issues.

- CVE-2012-3442: Cross-site scripting in authentication views
- CVE-2012-3443: Denial-of-service in image validation
- CVE-2012-3444: Denial-of-service via get_image_dimensions()

1 dmorgan 42460 %define module django
2     %define tarname Django
3     %define name python-%module
4 philippem 280862 %define version 1.4.1
5 misc 87658 %define release %mkrel 1
6 dmorgan 42460
7     Summary: A high-level Python Web framework
8     Name: %{name}
9     Version: %{version}
10     Release: %{release}
11 philippem 280862 Source0: http://www.djangoproject.com/m/releases/1.4/Django-%{version}.tar.gz
12 dmorgan 42460 License: BSD
13     Group: Development/Python
14     Url: http://www.djangoproject.com
15     BuildArch: noarch
16 misc 142748 BuildRequires: python-setuptools
17     BuildRequires: python-sphinx
18     BuildRequires: python-devel
19 dmorgan 42460
20     %description
21     Django is a high-level Python Web framework that encourages rapid development
22     and clean, pragmatic design.
23    
24     Developed and used over the past two years by a fast-moving online-news
25     operation, Django was designed from scratch to handle two challenges: the
26     intensive deadlines of a newsroom and the stringent requirements of experienced
27     Web developers. It has convenient niceties for developing content-management
28     systems, but it's an excellent tool for building any Web site.
29    
30     Django focuses on automating as much as possible and adhering to the
31     DRY principle.
32    
33     %prep
34     %setup -q -n %{tarname}-%{version}
35     sed -i 's/^\(ez_setup.use_setuptools\)/#\1/' setup.py
36    
37     %build
38     PYTHONDONTWRITEBYTECODE= %__python setup.py build
39     make -C docs/ html
40    
41     %install
42     %__rm -rf %{buildroot}
43     PYTHONDONTWRITEBYTECODE= %__python setup.py install --root=%{buildroot}
44    
45     %files
46     %doc LICENSE README docs/_build/html
47     %_bindir/*
48     %py_puresitedir/%{module}
49     %py_puresitedir/%{tarname}-*.egg-info

  ViewVC Help
Powered by ViewVC 1.1.30