/[packages]/updates/5/python-django/current/SPECS/python-django.spec
ViewVC logotype

Annotation of /updates/5/python-django/current/SPECS/python-django.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 818959 - (hide annotations) (download)
Thu Mar 19 19:02:02 2015 UTC (9 years ago) by philippem
Original Path: cauldron/python-django/current/SPECS/python-django.spec
File size: 4475 byte(s)
update to 1.7.7, fix CVE-2015-2317 CVE-2015-2316 mga#15528
1 dmorgan 42460 %define module django
2     %define tarname Django
3    
4     Summary: A high-level Python Web framework
5 ovitters 648416 Name: python-%{module}
6 philippem 818959 Version: 1.7.7
7 philippem 810764 Release: %mkrel 1
8 philippem 475168 Source0: https://pypi.python.org/packages/source/D/%{tarname}/%{tarname}-%{version}.tar.gz
9 philippem 671692 Patch0: python-django-1.7-py3-admin-completion
10 dmorgan 42460 License: BSD
11     Group: Development/Python
12     Url: http://www.djangoproject.com
13     BuildArch: noarch
14 misc 142748 BuildRequires: python-setuptools
15 marja 472897 BuildRequires: python-sphinx
16     BuildRequires: python-devel
17 marja 473530 BuildRequires: python3-devel
18 philippem 475168 BuildRequires: python3-setuptools
19 philippem 612783 Requires: %{name}-bash-completion = %{version}-%{release}
20 dmorgan 42460
21     %description
22     Django is a high-level Python Web framework that encourages rapid development
23     and clean, pragmatic design.
24    
25     Developed and used over the past two years by a fast-moving online-news
26     operation, Django was designed from scratch to handle two challenges: the
27     intensive deadlines of a newsroom and the stringent requirements of experienced
28     Web developers. It has convenient niceties for developing content-management
29     systems, but it's an excellent tool for building any Web site.
30    
31     Django focuses on automating as much as possible and adhering to the
32     DRY principle.
33    
34 philippem 612783 %package bash-completion
35     Group: Development/Python
36     Summary: bash completion files for Django
37    
38    
39     %description bash-completion
40     This package contains the bash completion files form Django high-level
41     Python Web framework.
42    
43 philippem 475168 %package -n python3-%{module}
44 marja 473530 Summary: A high-level Python Web framework
45     Group: Development/Python
46 philippem 612783 Requires: %{name}-bash-completion = %{version}-%{release}
47 marja 473530
48 philippem 475168 %description -n python3-%{module}
49 marja 473530
50     Django is a high-level Python Web framework that encourages rapid development
51     and clean, pragmatic design.
52    
53     Developed and used over the past two years by a fast-moving online-news
54     operation, Django was designed from scratch to handle two challenges: the
55     intensive deadlines of a newsroom and the stringent requirements of experienced
56     Web developers. It has convenient niceties for developing content-management
57     systems, but it's an excellent tool for building any Web site.
58    
59     Django focuses on automating as much as possible and adhering to the
60     DRY principle.
61    
62 philippem 475168 %package doc
63     Summary: Documentation for django
64     Group: Development/Python
65     Provides: python3-%{module}-doc = %{version}-%{release}
66 marja 473530
67 philippem 475168 %description doc
68     This package contains documentation for Django,
69     a high-level Python Web framework.
70    
71 dmorgan 42460 %prep
72     %setup -q -n %{tarname}-%{version}
73 philippem 612783 %patch0
74 oden 622907
75 philippem 612783 # empty files
76     for f in \
77     django/contrib/staticfiles/models.py \
78     django/contrib/webdesign/models.py \
79     django/contrib/humanize/models.py \
80     ; do
81     echo "# just a comment" > $f
82     done
83     echo "<!-- nothing -->" > django/contrib/flatpages/tests/templates/registration/login.html
84 marja 473530 cp -a . %{py3dir}
85 dmorgan 42460
86     %build
87 marja 472897 %{__python} setup.py build
88 marja 473530 pushd %{py3dir}
89     %{__python3} setup.py build
90     popd
91 dmorgan 42460
92     %install
93 marja 473530 # must do install of python 3 subpackage first, so that we don't
94     # overwrite django-admin script with the python 3 version
95     pushd %{py3dir}
96     %{__python3} setup.py install --skip-build --root %{buildroot}
97 philippem 612783 mv %{buildroot}%{_bindir}/django-admin.py %{buildroot}%{_bindir}/python3-django-admin
98 marja 473530 popd
99 dmorgan 42460
100 marja 473530 %{__python} setup.py install --skip-build --root %{buildroot}
101    
102 philippem 612783 # build documentation
103     (cd docs && mkdir djangohtml && mkdir -p _build/{doctrees,html} && make html)
104    
105    
106     # install man pages
107     mkdir -p %{buildroot}%{_mandir}/man1/
108     cp -p docs/man/* %{buildroot}%{_mandir}/man1/
109     cp -a %{buildroot}%{_mandir}/man1/django-admin.1 %{buildroot}%{_mandir}/man1/python3-django-admin.1
110     cp -a %{buildroot}%{_mandir}/man1/gather_profile_stats.1 %{buildroot}%{_mandir}/man1/python3-gather_profile_stats.1
111    
112     # install bash completion script
113     mkdir -p %{buildroot}%{_sysconfdir}/bash_completion.d/
114     install -m 0644 -p extras/django_bash_completion \
115     %{buildroot}%{_sysconfdir}/bash_completion.d/
116    
117     # Fix items in %%{_bindir}
118     mv %{buildroot}%{_bindir}/django-admin.py %{buildroot}%{_bindir}/django-admin
119    
120 dmorgan 42460 %files
121 philippem 612783 %doc AUTHORS LICENSE README.rst
122     %{_mandir}/man1/*
123     # except the python3 prefix
124     %exclude %{_mandir}/man1/python3-*
125     %{_bindir}/django-admin
126 marja 472897 %{python_sitelib}/%{module}
127     %{python_sitelib}/%{tarname}-*.egg-info
128 marja 473530
129 philippem 475168 %files -n python3-%{module}
130 philippem 612783 %doc AUTHORS LICENSE README.rst
131     %{_mandir}/man1/python3-*
132     %{_bindir}/python3-django-admin
133 marja 473530 %{python3_sitelib}/%{module}
134     %{python3_sitelib}/%{tarname}-*.egg-info
135 philippem 475168
136     %files doc
137 philippem 612783 %doc docs/_build/html
138 philippem 475168
139 philippem 612783 %files bash-completion
140     %dir %{_sysconfdir}/bash_completion.d/
141     %config(noreplace) %{_sysconfdir}/bash_completion.d/django_bash_completion
142    

  ViewVC Help
Powered by ViewVC 1.1.30