/[packages]/updates/5/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/5/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1058297 - (hide annotations) (download)
Mon Oct 3 20:54:05 2016 UTC (7 years, 6 months ago) by pterjan
File size: 18649 byte(s)
Backport patch for CVE-2016-7798
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4 luigiwalser 920553 %define patchversion p648
5 pterjan 796908 %define rel 1
6 pterjan 1058297 %define subrel 1
7 blino 1152
8 fwang 291590 %define libname %mklibname ruby %{subver}
9    
10 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
11     %define ruby_libarchdir %{_libdir}/%{name}
12    
13 fwang 290007 # This is the local lib/arch and should not be used for packaging.
14 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
15     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
16 fwang 290007
17     # This is the general location for libs/archs compatible with all
18     # or most of the Ruby versions available in the Fedora repositories.
19 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
20 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
21 fwang 290007
22 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
23     # RubyGems should be shared by all Ruby implementations.
24 pterjan 560984 %define rubygems_dir %{_datadir}/rubygems
25 pterjan 560987 %define gems_dir %{_datadir}/ruby/gems
26 pterjan 435211 %define rubygems_version 2.0.2
27 fwang 290007
28 fwang 468908 %define bootstrap 0
29 fwang 468812 %define build_gems 0
30 fwang 292558
31 blino 1152 Summary: Object Oriented Script Language
32     Name: ruby
33     Version: %{rubyver}.%{patchversion}
34     Release: %mkrel %rel
35 kamil 397518 License: Ruby or BSD
36 blino 1152 Group: Development/Ruby
37     BuildRequires: autoconf
38     BuildRequires: byacc
39 shlomif 291698 BuildRequires: doxygen
40 blino 1152 BuildRequires: ncurses-devel
41     BuildRequires: readline-devel
42 ovitters 648773 BuildRequires: tcl-devel
43     BuildRequires: tk-devel
44 fwang 276350 BuildRequires: db-devel
45 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
46 blino 1152 BuildRequires: openssl-devel
47     BuildRequires: zlib-devel
48 fwang 289987 BuildRequires: libffi-devel
49     BuildRequires: yaml-devel
50 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
51 tv 674762 Conflicts: ruby-devel < 2.0.0.p451-4.mga5
52 blino 1152 Obsoletes: ruby-rexml
53     Provides: ruby-rexml
54 pterjan 435566 # Couldn't get the standalone gem to work
55     Provides: rubygem(psych)
56 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
57     Provides: /usr/bin/ruby
58 fwang 293445 Provides: ruby(abi) = %rubyapi
59 fwang 463762 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
60 pterjan 435211 Source1: operating_system.rb
61 blino 1152 Source3: ruby.macros
62 tv 673709 # From FC:
63     # RPM dependency generators.
64     Source8: rubygems.attr
65     Source9: rubygems.req
66     Source10: rubygems.prov
67 blino 1152 URL: http://www.ruby-lang.org/
68 fwang 292558 %if !%bootstrap
69     Requires: rubygems >= %{rubygems_version}
70 fwang 293395 BuildRequires: ruby
71 fwang 292558 %endif
72 blino 1152
73 fwang 290007 # == FEDORA PATCHES BEGINS ==
74 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
75     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
76     # Fixes random WEBRick test failures.
77     # https://bugs.ruby-lang.org/issues/6573.
78     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
79 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
80     # http://redmine.ruby-lang.org/issues/5617
81     Patch8: ruby-1.9.3-custom-rubygems-location.patch
82     # Add support for installing binary extensions according to FHS.
83     # https://github.com/rubygems/rubygems/issues/210
84 pterjan 435211 # Note that 8th patch might be resolved by
85     # https://bugs.ruby-lang.org/issues/7897
86     Patch9: rubygems-2.0.0-binary-extensions.patch
87     # Make mkmf verbose by default
88     Patch12: ruby-1.9.3-mkmf-verbose.patch
89     # This slightly changes behavior of "gem install --install-dir" behavior.
90     # Without this patch, Specifications.dirs is modified and gems installed on
91     # the system cannot be required anymore. This causes later issues when RDoc
92     # documentation should be generated, since json gem is sudenly not accessible.
93     # https://github.com/rubygems/rubygems/pull/452
94     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
95     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
96     # https://github.com/rubygems/rubygems/pull/455
97     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
98 fwang 290007 # == FEDORA PATCHES ENDS ==
99 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
100     # to install gems into user dir
101     Patch20: ruby-2.0.0-p451-Do-not-install-to-user-dir.patch
102 fwang 290007
103 luigiwalser 795834 Patch21: ruby-2.0.0-CVE-2014-4975.patch
104 pterjan 1058297 Patch22: ruby-2.0.0-CVE-2016-7798.patch
105 luigiwalser 795834
106 fwang 291591 %package -n %{libname}
107 fwang 291590 Summary: Libraries necessary to run Ruby
108     Group: Development/Ruby
109    
110 blino 1152 %package doc
111     Summary: Documentation for the powerful language Ruby
112     Group: Development/Ruby
113 fwang 202696 BuildArch: noarch
114 blino 1152
115     %package devel
116     Summary: Development file for the powerful language Ruby
117     Group: Development/Ruby
118 fwang 311925 Requires: %{name} = %{version}
119     Requires: %{libname} = %{version}
120 blino 1152
121     %package tk
122     Summary: Tk extension for the powerful language Ruby
123     Group: Development/Ruby
124 fwang 311925 Requires: %{name} = %{version}
125 blino 1152
126 fwang 291551 %package RubyGems
127     Summary: The Ruby standard for packaging ruby libraries
128     Group: Development/Ruby
129 fwang 291590 Version: %{rubygems_version}
130 fwang 291551 Requires: ruby(abi) = %{subver}
131 fwang 291590 Provides: gem = %{rubygems_version}
132     Provides: rubygems = %{rubygems_version}
133     Provides: ruby(rubygems) = %{rubygems_version}
134 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
135 fwang 291561 BuildArch: noarch
136 fwang 291551
137 pterjan 435211 %define rake_ver 0.9.6
138 fwang 291551 %package rake
139     Summary: Simple ruby build program with capabilities similar to make
140     Group: Development/Ruby
141 shlomif 291767 Version: %{rake_ver}
142 fwang 291551 Requires: ruby(abi) = %{subver}
143 fwang 291561 BuildArch: noarch
144 fwang 291551
145 pterjan 435211 %define minitest_ver 4.3.2
146 fwang 291562 %package minitest
147 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
148 fwang 291562 Group: Development/Ruby
149 shlomif 291767 Version: %{minitest_ver}
150 fwang 291562 License: MIT
151 fwang 291590 Requires: ruby(abi) = %{subver}
152     Requires: ruby(rubygems) >= %{rubygems_version}
153 fwang 291562 BuildArch: noarch
154    
155 pterjan 435211 %define json_ver 1.7.7
156 fwang 291562 %package json
157     Summary: This is a JSON implementation as a Ruby extension in C
158     Group: Development/Ruby
159 shlomif 291767 Version: %{json_ver}
160 fwang 291562 License: Ruby or GPLv2
161 fwang 291590 Requires: ruby(abi) = %{subver}
162     Requires: ruby(rubygems) >= %{rubygems_version}
163 fwang 291562
164 pterjan 435211 %define rdoc_ver 4.0.0
165 fwang 291562 %package rdoc
166     Summary: A tool to generate HTML and command-line documentation for Ruby projects
167     Group: Development/Ruby
168 shlomif 291767 Version: %{rdoc_ver}
169 fwang 291562 License: GPLv2 and Ruby and MIT
170 fwang 291590 Requires: ruby(abi) = %{subver}
171     Requires: ruby(rubygems) >= %{rubygems_version}
172     Requires: ruby(irb) = %{version}
173 shlomif 291767 Provides: rdoc = %{rdoc_ver}
174     Provides: ri = %{rdoc_ver}
175 fwang 291562 BuildArch: noarch
176    
177 fwang 291590 %package irb
178     Summary: The Interactive Ruby
179     Group: Development/Ruby
180     Provides: irb = %{version}-%{release}
181     Provides: ruby(irb) = %{version}-%{release}
182 fwang 313459 Conflicts: ruby < 1.9
183 fwang 313460 BuildArch: noarch
184 fwang 291590
185 pterjan 435211 %define bigdecimal_ver 1.2.0
186 fwang 291590 %package bigdecimal
187     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
188     Group: Development/Ruby
189 pterjan 435211 Version: %{bigdecimal_ver}
190 fwang 291590 License: GPL+ or Artistic
191     Requires: ruby(abi) = %{subver}
192     Requires: ruby(rubygems) >= %{rubygems_version}
193    
194 pterjan 435211 %define io_console_ver 0.4.2
195 fwang 291590 %package io-console
196     Summary: IO/Console is a simple console utilizing library
197     Group: Development/Ruby
198 pterjan 435211 Version: %{io_console_ver}
199 fwang 291590 Requires: ruby(abi) = %{subver}
200     Requires: ruby(rubygems) >= %{rubygems_version}
201    
202 pterjan 435211 %define psych_ver 2.0.0
203     %package psych
204     Summary: A libyaml wrapper for Ruby
205     Version: %{psych_ver}
206     Group: Development/Ruby
207     License: MIT
208     Requires: ruby(abi) = %{subver}
209     Requires: ruby(rubygems) >= %{rubygems_version}
210     Conflicts: ruby < 2.0.0
211    
212     %define test_unit_ver 2.0.0
213     %package test-unit
214     Summary: test/unit compatible API testing framework
215     Version: %{psych_ver}
216     Group: Development/Ruby
217     License: MIT
218     Requires: ruby(abi) = %{subver}
219     Requires: ruby(rubygems) >= %{rubygems_version}
220     Conflicts: ruby < 2.0.0
221     BuildArch: noarch
222    
223 blino 1152 %description
224     Ruby is the interpreted scripting language for quick and
225     easy object-oriented programming. It has many features to
226     process text files and to do system management tasks (as in
227     Perl). It is simple, straight-forward, and extensible.
228    
229     %description doc
230     Ruby is the interpreted scripting language for quick and
231     easy object-oriented programming. It has many features to
232     process text files and to do system management tasks (as in
233     Perl). It is simple, straight-forward, and extensible.
234    
235     This package contains the Ruby's documentation
236    
237 fwang 291590 %description -n %{libname}
238     This package includes the libruby, necessary to run Ruby.
239    
240 blino 1152 %description devel
241     Ruby is the interpreted scripting language for quick and
242     easy object-oriented programming. It has many features to
243     process text files and to do system management tasks (as in
244     Perl). It is simple, straight-forward, and extensible.
245    
246     This package contains the Ruby's devel files.
247    
248     %description tk
249     Ruby is the interpreted scripting language for quick and
250     easy object-oriented programming. It has many features to
251     process text files and to do system management tasks (as in
252     Perl). It is simple, straight-forward, and extensible.
253    
254     This package contains the Tk extension for Ruby.
255    
256 fwang 291551 %description RubyGems
257     RubyGems is the Ruby standard for publishing and managing third party
258     libraries.
259    
260 fwang 291552 %description rake
261     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
262     specified in standard Ruby syntax.
263    
264 fwang 291562 %description rdoc
265     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
266     includes the 'rdoc' and 'ri' tools for generating and displaying online
267     documentation.
268    
269     %description json
270     This is a implementation of the JSON specification according to RFC 4627.
271     You can think of it as a low fat alternative to XML, if you want to store
272     data to disk or transmit it over a network rather than use a verbose
273     markup language.
274    
275     %description minitest
276     minitest/unit is a small and incredibly fast unit testing framework.
277    
278     minitest/spec is a functionally complete spec engine.
279    
280     minitest/benchmark is an awesome way to assert the performance of your
281     algorithms in a repeatable manner.
282    
283     minitest/mock by Steven Baker, is a beautifully tiny mock object
284     framework.
285    
286     minitest/pride shows pride in testing and adds coloring to your test
287     output.
288    
289 fwang 291590 %description irb
290     The irb is acronym for Interactive Ruby. It evaluates ruby expression
291     from the terminal.
292    
293     %description bigdecimal
294     Ruby provides built-in support for arbitrary precision integer arithmetic.
295     For example:
296    
297     42**13 -> 1265437718438866624512
298    
299     BigDecimal provides similar support for very large or very accurate floating
300     point numbers. Decimal arithmetic is also useful for general calculation,
301     because it provides the correct answers people expect–whereas normal binary
302     floating point arithmetic often introduces subtle errors because of the
303     conversion between base 10 and base 2.
304    
305     %description io-console
306     IO/Console provides very simple and portable access to console. It doesn't
307     provide higher layer features, such like curses and readline.
308    
309 pterjan 435211 %description psych
310     Psych is a YAML parser and emitter. Psych leverages
311     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
312     capabilities. In addition to wrapping libyaml, Psych also knows how to
313     serialize and de-serialize most Ruby objects to and from the YAML format.
314    
315     %description test-unit
316     This library implements test/unit compatible API on minitest.
317     The test/unit means that test/unit which was bundled with Ruby 1.8.
318    
319 blino 1152 %prep
320     %setup -q -n ruby-%{rubyver}-%{patchversion}
321 fwang 290007 %apply_patches
322 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
323     rm lib/mkmf.rb.0*
324 blino 1152
325     %build
326 fwang 290038 autoconf
327 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
328 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
329 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
330 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
331 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
332     --with-sitearchdir='%{ruby_sitearchdir}' \
333     --with-vendordir='%{ruby_vendorlibdir}' \
334     --with-vendorarchdir='%{ruby_vendorarchdir}' \
335 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
336 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
337     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
338     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
339     --with-rubygemsdir='%{rubygems_dir}' \
340     --with-ruby-pc='%{name}.pc' \
341     --enable-multiarch \
342     --with-ruby-version=''
343 blino 1152 %make
344    
345     %install
346     %makeinstall_std install-doc
347    
348     install -d %buildroot%{_datadir}/emacs/site-lisp
349     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
350    
351     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
352     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
353     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
354     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
355     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
356     EOF
357    
358     # Install the rpm macros
359     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
360     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
361 fwang 289961
362 tv 673709 # Install dependency generators.
363     mkdir -p %{buildroot}%{_rpmconfigdir}/fileattrs
364     install -m 644 %{SOURCE8} %{buildroot}%{_rpmconfigdir}/fileattrs
365     install -m 755 %{SOURCE9} %{buildroot}%{_rpmconfigdir}
366     install -m 755 %{SOURCE10} %{buildroot}%{_rpmconfigdir}
367    
368 pterjan 435211 # Install custom operating_system.rb
369     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
370     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
371    
372 pterjan 617250 # Version is empty if --with-ruby-version is specified.
373     # http://bugs.ruby-lang.org/issues/7807
374     sed -i 's/Version: .*/Version: %{rubyver}/' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
375    
376 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
377     %if !%build_gems
378 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
379 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
380 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
381     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
382 pterjan 560987 rm -fr %{buildroot}%{gems_dir}/{gems,specifications}
383 fwang 311915 %if !%bootstrap
384 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
385 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
386     rm -fr %{buildroot}%{rubygems_dir}/rubygems
387 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
388     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
389 fwang 293412 %endif
390 fwang 311914 %endif
391 fwang 293412
392 blino 1152 %check
393     make test
394    
395 fwang 289961 %files
396 fwang 291551 %{_bindir}/erb
397     %{_bindir}/ruby
398 fwang 291560 %dir %{ruby_libdir}
399     %{ruby_libdir}/*.rb
400 fwang 291590 %exclude %{ruby_libdir}/irb.rb
401 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
402     %exclude %{ruby_libdir}/remote-tk.rb
403     %exclude %{ruby_libdir}/tcltk.rb
404     %exclude %{ruby_libdir}/tk.rb
405     %exclude %{ruby_libdir}/tkafter.rb
406     %exclude %{ruby_libdir}/tkbgerror.rb
407     %exclude %{ruby_libdir}/tkcanvas.rb
408     %exclude %{ruby_libdir}/tkclass.rb
409     %exclude %{ruby_libdir}/tkconsole.rb
410     %exclude %{ruby_libdir}/tkdialog.rb
411     %exclude %{ruby_libdir}/tkentry.rb
412     %exclude %{ruby_libdir}/tkfont.rb
413     %exclude %{ruby_libdir}/tkmacpkg.rb
414     %exclude %{ruby_libdir}/tkmenubar.rb
415     %exclude %{ruby_libdir}/tkmngfocus.rb
416     %exclude %{ruby_libdir}/tkpalette.rb
417     %exclude %{ruby_libdir}/tkscrollbox.rb
418     %exclude %{ruby_libdir}/tktext.rb
419     %exclude %{ruby_libdir}/tkvirtevent.rb
420     %exclude %{ruby_libdir}/tkwinpkg.rb
421     %{ruby_libdir}/cgi
422     %{ruby_libdir}/date
423     %{ruby_libdir}/digest
424     %{ruby_libdir}/dl
425     %{ruby_libdir}/drb
426     %{ruby_libdir}/fiddle
427     %{ruby_libdir}/matrix
428     %{ruby_libdir}/net
429     %{ruby_libdir}/openssl
430     %{ruby_libdir}/optparse
431 pterjan 435566 %{ruby_libdir}/psych
432 fwang 291560 %{ruby_libdir}/racc
433     %{ruby_libdir}/rbconfig
434     %{ruby_libdir}/rexml
435     %{ruby_libdir}/rinda
436     %{ruby_libdir}/ripper
437     %{ruby_libdir}/rss
438     %{ruby_libdir}/shell
439 pterjan 435211 %{ruby_libdir}/syslog
440 fwang 291560 %{ruby_libdir}/uri
441     %{ruby_libdir}/webrick
442     %{ruby_libdir}/xmlrpc
443     %{ruby_libdir}/yaml
444     %dir %{ruby_libarchdir}
445     %{ruby_libarchdir}/continuation.so
446     %{ruby_libarchdir}/coverage.so
447     %{ruby_libarchdir}/curses.so
448     %{ruby_libarchdir}/date_core.so
449     %{ruby_libarchdir}/dbm.so
450     %dir %{ruby_libarchdir}/digest
451     %{ruby_libarchdir}/digest.so
452     %{ruby_libarchdir}/digest/*.so
453     %dir %{ruby_libarchdir}/dl
454     %{ruby_libarchdir}/dl.so
455     %{ruby_libarchdir}/dl/*.so
456     %dir %{ruby_libarchdir}/enc
457     %{ruby_libarchdir}/enc/*.so
458 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
459     %{ruby_libarchdir}/enc/trans/*.so
460 fwang 291560 %{ruby_libarchdir}/etc.so
461     %{ruby_libarchdir}/fcntl.so
462     %{ruby_libarchdir}/fiber.so
463     %{ruby_libarchdir}/fiddle.so
464     %{ruby_libarchdir}/gdbm.so
465     %dir %{ruby_libarchdir}/io
466     %{ruby_libarchdir}/io/nonblock.so
467     %{ruby_libarchdir}/io/wait.so
468     %dir %{ruby_libarchdir}/mathn
469 fwang 291562 %{ruby_libarchdir}/mathn/*.so
470 fwang 291560 %{ruby_libarchdir}/nkf.so
471     %{ruby_libarchdir}/objspace.so
472     %{ruby_libarchdir}/openssl.so
473 pterjan 435566 %{ruby_libarchdir}/psych.so
474 fwang 291560 %{ruby_libarchdir}/pathname.so
475     %{ruby_libarchdir}/pty.so
476     %dir %{ruby_libarchdir}/racc
477     %{ruby_libarchdir}/racc/*.so
478     %{ruby_libarchdir}/rbconfig.rb
479     %{ruby_libarchdir}/readline.so
480     %{ruby_libarchdir}/ripper.so
481     %{ruby_libarchdir}/sdbm.so
482     %{ruby_libarchdir}/socket.so
483     %{ruby_libarchdir}/stringio.so
484     %{ruby_libarchdir}/strscan.so
485     %{ruby_libarchdir}/syslog.so
486     %{ruby_libarchdir}/zlib.so
487 fwang 291551 %{_mandir}/man1/erb.1.*
488     %{_mandir}/man1/ruby.1.*
489 blino 1152 %{_datadir}/emacs/site-lisp/*
490     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
491     %{_sysconfdir}/rpm/macros.d/%{name}.macros
492 fwang 291560 %{_datadir}/ruby/site_ruby
493     %{_libdir}/ruby/site_ruby
494     %{_datadir}/ruby/vendor_ruby
495     %{_libdir}/ruby/vendor_ruby
496 fwang 311914 %if %bootstrap
497     %{_bindir}/gem
498 fwang 448831 %dir %{rubygems_dir}
499     %{rubygems_dir}/rbconfig
500     %{rubygems_dir}/rubygems
501     %{rubygems_dir}/rubygems.rb
502     %{rubygems_dir}/ubygems.rb
503 fwang 311914 %endif
504 tv 674762 %{_rpmconfigdir}/fileattrs/rubygems.attr
505     %{_rpmconfigdir}/rubygems.req
506     %{_rpmconfigdir}/rubygems.prov
507 blino 1152
508     %files doc
509     %{_datadir}/ri
510 pterjan 435211 %{_datadir}/doc/ruby
511 blino 1152
512 fwang 291590 %files -n %{libname}
513     %{_libdir}/libruby.so.%{subver}
514     %{_libdir}/libruby.so.%{rubyapi}
515    
516 blino 1152 %files devel
517 fwang 290003 %{_includedir}/*
518 blino 1152 %{_libdir}/libruby-static.a
519     %{_libdir}/libruby.so
520 fwang 290003 %{_libdir}/pkgconfig/*.pc
521 blino 1152
522     %files tk
523 fwang 291560 %{ruby_libarchdir}/tcltklib.so
524     %{ruby_libarchdir}/tkutil.so
525     %{ruby_libdir}/multi-tk.rb
526     %{ruby_libdir}/remote-tk.rb
527     %{ruby_libdir}/tcltk.rb
528     %{ruby_libdir}/tk.rb
529     %{ruby_libdir}/tkafter.rb
530     %{ruby_libdir}/tkbgerror.rb
531     %{ruby_libdir}/tkcanvas.rb
532     %{ruby_libdir}/tkclass.rb
533     %{ruby_libdir}/tkconsole.rb
534     %{ruby_libdir}/tkdialog.rb
535     %{ruby_libdir}/tkentry.rb
536     %{ruby_libdir}/tkfont.rb
537     %{ruby_libdir}/tkmacpkg.rb
538     %{ruby_libdir}/tkmenubar.rb
539     %{ruby_libdir}/tkmngfocus.rb
540     %{ruby_libdir}/tkpalette.rb
541     %{ruby_libdir}/tkscrollbox.rb
542     %{ruby_libdir}/tktext.rb
543     %{ruby_libdir}/tkvirtevent.rb
544     %{ruby_libdir}/tkwinpkg.rb
545     %{ruby_libdir}/tk
546     %{ruby_libdir}/tkextlib
547 fwang 291551
548 fwang 293412 %files irb
549     %{_bindir}/irb
550     %{ruby_libdir}/irb.rb
551     %{ruby_libdir}/irb
552     %{_mandir}/man1/irb.1*
553    
554     %if %build_gems
555 fwang 291551 %files RubyGems
556     %{_bindir}/gem
557     %dir %{rubygems_dir}
558     %{rubygems_dir}/rbconfig
559     %{rubygems_dir}/rubygems
560     %{rubygems_dir}/rubygems.rb
561     %{rubygems_dir}/ubygems.rb
562    
563 fwang 291562 %files minitest
564     %{ruby_libdir}/minitest
565 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
566 fwang 291562
567 fwang 291551 %files rake
568     %{_bindir}/rake
569     %{_mandir}/man1/rake.1.*
570 fwang 291562 %{ruby_libdir}/rake
571 pterjan 560987 %{gems_dir}/gems/rake-*
572     %{gems_dir}/specifications/default/rake-*.gemspec
573 fwang 291562
574     %files rdoc
575     %{_bindir}/rdoc
576     %{_bindir}/ri
577     %{ruby_libdir}/rdoc
578 pterjan 560987 %{gems_dir}/gems/rdoc-*
579     %{gems_dir}/specifications/default/rdoc-*.gemspec
580 fwang 291562 %{_mandir}/man1/ri.1.*
581    
582     %files json
583     %dir %{ruby_libarchdir}/json
584     %dir %{ruby_libarchdir}/json/ext
585     %{ruby_libarchdir}/json/ext/*.so
586     %{ruby_libdir}/json
587 pterjan 560987 %{gems_dir}/specifications/default/json-*.gemspec
588 fwang 291590
589     %files bigdecimal
590     %{ruby_libdir}/bigdecimal
591     %{ruby_libarchdir}/bigdecimal.so
592 pterjan 560987 %{gems_dir}/specifications/default/bigdecimal-*.gemspec
593 fwang 291590
594     %files io-console
595     %{ruby_libdir}/io
596     %{ruby_libarchdir}/io/console.so
597 pterjan 560987 %{gems_dir}/specifications/default/io-console-*.gemspec
598 pterjan 435211
599     %files psych
600     %{ruby_libdir}/psych
601     %{ruby_libarchdir}/psych.so
602 pterjan 560987 %{gems_dir}/specifications/default/psych-*.gemspec
603 pterjan 435211
604     %files test-unit
605     %{_bindir}/testrb
606     %{ruby_libdir}/test
607 pterjan 560987 %{gems_dir}/gems/test-unit-*
608 pterjan 435211 %{rubygems_dir}/specifications/default/test-unit-*.gemspec
609 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30