/[packages]/updates/5/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/5/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1141714 - (hide annotations) (download)
Sat Aug 19 20:07:07 2017 UTC (6 years, 8 months ago) by pterjan
File size: 18769 byte(s)
Add patches for CVE-2015-9096 and CVE-2016-2337
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4 luigiwalser 920553 %define patchversion p648
5 pterjan 796908 %define rel 1
6 pterjan 1141714 %define subrel 4
7 blino 1152
8 fwang 291590 %define libname %mklibname ruby %{subver}
9    
10 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
11     %define ruby_libarchdir %{_libdir}/%{name}
12    
13 fwang 290007 # This is the local lib/arch and should not be used for packaging.
14 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
15     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
16 fwang 290007
17     # This is the general location for libs/archs compatible with all
18     # or most of the Ruby versions available in the Fedora repositories.
19 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
20 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
21 fwang 290007
22 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
23     # RubyGems should be shared by all Ruby implementations.
24 pterjan 560984 %define rubygems_dir %{_datadir}/rubygems
25 pterjan 560987 %define gems_dir %{_datadir}/ruby/gems
26 pterjan 435211 %define rubygems_version 2.0.2
27 fwang 290007
28 fwang 468908 %define bootstrap 0
29 fwang 468812 %define build_gems 0
30 fwang 292558
31 blino 1152 Summary: Object Oriented Script Language
32     Name: ruby
33     Version: %{rubyver}.%{patchversion}
34     Release: %mkrel %rel
35 kamil 397518 License: Ruby or BSD
36 blino 1152 Group: Development/Ruby
37     BuildRequires: autoconf
38     BuildRequires: byacc
39 shlomif 291698 BuildRequires: doxygen
40 blino 1152 BuildRequires: ncurses-devel
41     BuildRequires: readline-devel
42 ovitters 648773 BuildRequires: tcl-devel
43     BuildRequires: tk-devel
44 fwang 276350 BuildRequires: db-devel
45 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
46 blino 1152 BuildRequires: openssl-devel
47     BuildRequires: zlib-devel
48 fwang 289987 BuildRequires: libffi-devel
49     BuildRequires: yaml-devel
50 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
51 tv 674762 Conflicts: ruby-devel < 2.0.0.p451-4.mga5
52 blino 1152 Obsoletes: ruby-rexml
53     Provides: ruby-rexml
54 pterjan 435566 # Couldn't get the standalone gem to work
55     Provides: rubygem(psych)
56 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
57     Provides: /usr/bin/ruby
58 fwang 293445 Provides: ruby(abi) = %rubyapi
59 fwang 463762 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
60 pterjan 435211 Source1: operating_system.rb
61 blino 1152 Source3: ruby.macros
62 tv 673709 # From FC:
63     # RPM dependency generators.
64     Source8: rubygems.attr
65     Source9: rubygems.req
66     Source10: rubygems.prov
67 blino 1152 URL: http://www.ruby-lang.org/
68 fwang 292558 %if !%bootstrap
69     Requires: rubygems >= %{rubygems_version}
70 fwang 293395 BuildRequires: ruby
71 fwang 292558 %endif
72 blino 1152
73 fwang 290007 # == FEDORA PATCHES BEGINS ==
74 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
75     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
76     # Fixes random WEBRick test failures.
77     # https://bugs.ruby-lang.org/issues/6573.
78     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
79 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
80     # http://redmine.ruby-lang.org/issues/5617
81     Patch8: ruby-1.9.3-custom-rubygems-location.patch
82     # Add support for installing binary extensions according to FHS.
83     # https://github.com/rubygems/rubygems/issues/210
84 pterjan 435211 # Note that 8th patch might be resolved by
85     # https://bugs.ruby-lang.org/issues/7897
86     Patch9: rubygems-2.0.0-binary-extensions.patch
87     # Make mkmf verbose by default
88     Patch12: ruby-1.9.3-mkmf-verbose.patch
89     # This slightly changes behavior of "gem install --install-dir" behavior.
90     # Without this patch, Specifications.dirs is modified and gems installed on
91     # the system cannot be required anymore. This causes later issues when RDoc
92     # documentation should be generated, since json gem is sudenly not accessible.
93     # https://github.com/rubygems/rubygems/pull/452
94     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
95     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
96     # https://github.com/rubygems/rubygems/pull/455
97     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
98 fwang 290007 # == FEDORA PATCHES ENDS ==
99 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
100     # to install gems into user dir
101     Patch20: ruby-2.0.0-p451-Do-not-install-to-user-dir.patch
102 fwang 290007
103 luigiwalser 795834 Patch21: ruby-2.0.0-CVE-2014-4975.patch
104 pterjan 1058297 Patch22: ruby-2.0.0-CVE-2016-7798.patch
105 pterjan 1109440 Patch23: ruby-2.0.0-CVE-2016-2339.patch
106 pterjan 1141714 Patch24: ruby-2.0.0-CVE-2015-9096.patch
107     Patch25: ruby-2.0.0-CVE-2016-2337.patch
108 luigiwalser 795834
109 fwang 291591 %package -n %{libname}
110 fwang 291590 Summary: Libraries necessary to run Ruby
111     Group: Development/Ruby
112    
113 blino 1152 %package doc
114     Summary: Documentation for the powerful language Ruby
115     Group: Development/Ruby
116 fwang 202696 BuildArch: noarch
117 blino 1152
118     %package devel
119     Summary: Development file for the powerful language Ruby
120     Group: Development/Ruby
121 fwang 311925 Requires: %{name} = %{version}
122     Requires: %{libname} = %{version}
123 blino 1152
124     %package tk
125     Summary: Tk extension for the powerful language Ruby
126     Group: Development/Ruby
127 fwang 311925 Requires: %{name} = %{version}
128 blino 1152
129 fwang 291551 %package RubyGems
130     Summary: The Ruby standard for packaging ruby libraries
131     Group: Development/Ruby
132 fwang 291590 Version: %{rubygems_version}
133 fwang 291551 Requires: ruby(abi) = %{subver}
134 fwang 291590 Provides: gem = %{rubygems_version}
135     Provides: rubygems = %{rubygems_version}
136     Provides: ruby(rubygems) = %{rubygems_version}
137 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
138 fwang 291561 BuildArch: noarch
139 fwang 291551
140 pterjan 435211 %define rake_ver 0.9.6
141 fwang 291551 %package rake
142     Summary: Simple ruby build program with capabilities similar to make
143     Group: Development/Ruby
144 shlomif 291767 Version: %{rake_ver}
145 fwang 291551 Requires: ruby(abi) = %{subver}
146 fwang 291561 BuildArch: noarch
147 fwang 291551
148 pterjan 435211 %define minitest_ver 4.3.2
149 fwang 291562 %package minitest
150 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
151 fwang 291562 Group: Development/Ruby
152 shlomif 291767 Version: %{minitest_ver}
153 fwang 291562 License: MIT
154 fwang 291590 Requires: ruby(abi) = %{subver}
155     Requires: ruby(rubygems) >= %{rubygems_version}
156 fwang 291562 BuildArch: noarch
157    
158 pterjan 435211 %define json_ver 1.7.7
159 fwang 291562 %package json
160     Summary: This is a JSON implementation as a Ruby extension in C
161     Group: Development/Ruby
162 shlomif 291767 Version: %{json_ver}
163 fwang 291562 License: Ruby or GPLv2
164 fwang 291590 Requires: ruby(abi) = %{subver}
165     Requires: ruby(rubygems) >= %{rubygems_version}
166 fwang 291562
167 pterjan 435211 %define rdoc_ver 4.0.0
168 fwang 291562 %package rdoc
169     Summary: A tool to generate HTML and command-line documentation for Ruby projects
170     Group: Development/Ruby
171 shlomif 291767 Version: %{rdoc_ver}
172 fwang 291562 License: GPLv2 and Ruby and MIT
173 fwang 291590 Requires: ruby(abi) = %{subver}
174     Requires: ruby(rubygems) >= %{rubygems_version}
175     Requires: ruby(irb) = %{version}
176 shlomif 291767 Provides: rdoc = %{rdoc_ver}
177     Provides: ri = %{rdoc_ver}
178 fwang 291562 BuildArch: noarch
179    
180 fwang 291590 %package irb
181     Summary: The Interactive Ruby
182     Group: Development/Ruby
183     Provides: irb = %{version}-%{release}
184     Provides: ruby(irb) = %{version}-%{release}
185 fwang 313459 Conflicts: ruby < 1.9
186 fwang 313460 BuildArch: noarch
187 fwang 291590
188 pterjan 435211 %define bigdecimal_ver 1.2.0
189 fwang 291590 %package bigdecimal
190     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
191     Group: Development/Ruby
192 pterjan 435211 Version: %{bigdecimal_ver}
193 fwang 291590 License: GPL+ or Artistic
194     Requires: ruby(abi) = %{subver}
195     Requires: ruby(rubygems) >= %{rubygems_version}
196    
197 pterjan 435211 %define io_console_ver 0.4.2
198 fwang 291590 %package io-console
199     Summary: IO/Console is a simple console utilizing library
200     Group: Development/Ruby
201 pterjan 435211 Version: %{io_console_ver}
202 fwang 291590 Requires: ruby(abi) = %{subver}
203     Requires: ruby(rubygems) >= %{rubygems_version}
204    
205 pterjan 435211 %define psych_ver 2.0.0
206     %package psych
207     Summary: A libyaml wrapper for Ruby
208     Version: %{psych_ver}
209     Group: Development/Ruby
210     License: MIT
211     Requires: ruby(abi) = %{subver}
212     Requires: ruby(rubygems) >= %{rubygems_version}
213     Conflicts: ruby < 2.0.0
214    
215     %define test_unit_ver 2.0.0
216     %package test-unit
217     Summary: test/unit compatible API testing framework
218     Version: %{psych_ver}
219     Group: Development/Ruby
220     License: MIT
221     Requires: ruby(abi) = %{subver}
222     Requires: ruby(rubygems) >= %{rubygems_version}
223     Conflicts: ruby < 2.0.0
224     BuildArch: noarch
225    
226 blino 1152 %description
227     Ruby is the interpreted scripting language for quick and
228     easy object-oriented programming. It has many features to
229     process text files and to do system management tasks (as in
230     Perl). It is simple, straight-forward, and extensible.
231    
232     %description doc
233     Ruby is the interpreted scripting language for quick and
234     easy object-oriented programming. It has many features to
235     process text files and to do system management tasks (as in
236     Perl). It is simple, straight-forward, and extensible.
237    
238     This package contains the Ruby's documentation
239    
240 fwang 291590 %description -n %{libname}
241     This package includes the libruby, necessary to run Ruby.
242    
243 blino 1152 %description devel
244     Ruby is the interpreted scripting language for quick and
245     easy object-oriented programming. It has many features to
246     process text files and to do system management tasks (as in
247     Perl). It is simple, straight-forward, and extensible.
248    
249     This package contains the Ruby's devel files.
250    
251     %description tk
252     Ruby is the interpreted scripting language for quick and
253     easy object-oriented programming. It has many features to
254     process text files and to do system management tasks (as in
255     Perl). It is simple, straight-forward, and extensible.
256    
257     This package contains the Tk extension for Ruby.
258    
259 fwang 291551 %description RubyGems
260     RubyGems is the Ruby standard for publishing and managing third party
261     libraries.
262    
263 fwang 291552 %description rake
264     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
265     specified in standard Ruby syntax.
266    
267 fwang 291562 %description rdoc
268     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
269     includes the 'rdoc' and 'ri' tools for generating and displaying online
270     documentation.
271    
272     %description json
273     This is a implementation of the JSON specification according to RFC 4627.
274     You can think of it as a low fat alternative to XML, if you want to store
275     data to disk or transmit it over a network rather than use a verbose
276     markup language.
277    
278     %description minitest
279     minitest/unit is a small and incredibly fast unit testing framework.
280    
281     minitest/spec is a functionally complete spec engine.
282    
283     minitest/benchmark is an awesome way to assert the performance of your
284     algorithms in a repeatable manner.
285    
286     minitest/mock by Steven Baker, is a beautifully tiny mock object
287     framework.
288    
289     minitest/pride shows pride in testing and adds coloring to your test
290     output.
291    
292 fwang 291590 %description irb
293     The irb is acronym for Interactive Ruby. It evaluates ruby expression
294     from the terminal.
295    
296     %description bigdecimal
297     Ruby provides built-in support for arbitrary precision integer arithmetic.
298     For example:
299    
300     42**13 -> 1265437718438866624512
301    
302     BigDecimal provides similar support for very large or very accurate floating
303     point numbers. Decimal arithmetic is also useful for general calculation,
304     because it provides the correct answers people expect–whereas normal binary
305     floating point arithmetic often introduces subtle errors because of the
306     conversion between base 10 and base 2.
307    
308     %description io-console
309     IO/Console provides very simple and portable access to console. It doesn't
310     provide higher layer features, such like curses and readline.
311    
312 pterjan 435211 %description psych
313     Psych is a YAML parser and emitter. Psych leverages
314     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
315     capabilities. In addition to wrapping libyaml, Psych also knows how to
316     serialize and de-serialize most Ruby objects to and from the YAML format.
317    
318     %description test-unit
319     This library implements test/unit compatible API on minitest.
320     The test/unit means that test/unit which was bundled with Ruby 1.8.
321    
322 blino 1152 %prep
323     %setup -q -n ruby-%{rubyver}-%{patchversion}
324 fwang 290007 %apply_patches
325 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
326     rm lib/mkmf.rb.0*
327 blino 1152
328     %build
329 fwang 290038 autoconf
330 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
331 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
332 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
333 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
334 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
335     --with-sitearchdir='%{ruby_sitearchdir}' \
336     --with-vendordir='%{ruby_vendorlibdir}' \
337     --with-vendorarchdir='%{ruby_vendorarchdir}' \
338 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
339 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
340     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
341     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
342     --with-rubygemsdir='%{rubygems_dir}' \
343     --with-ruby-pc='%{name}.pc' \
344     --enable-multiarch \
345     --with-ruby-version=''
346 blino 1152 %make
347    
348     %install
349     %makeinstall_std install-doc
350    
351     install -d %buildroot%{_datadir}/emacs/site-lisp
352     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
353    
354     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
355     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
356     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
357     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
358     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
359     EOF
360    
361     # Install the rpm macros
362     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
363     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
364 fwang 289961
365 tv 673709 # Install dependency generators.
366     mkdir -p %{buildroot}%{_rpmconfigdir}/fileattrs
367     install -m 644 %{SOURCE8} %{buildroot}%{_rpmconfigdir}/fileattrs
368     install -m 755 %{SOURCE9} %{buildroot}%{_rpmconfigdir}
369     install -m 755 %{SOURCE10} %{buildroot}%{_rpmconfigdir}
370    
371 pterjan 435211 # Install custom operating_system.rb
372     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
373     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
374    
375 pterjan 617250 # Version is empty if --with-ruby-version is specified.
376     # http://bugs.ruby-lang.org/issues/7807
377     sed -i 's/Version: .*/Version: %{rubyver}/' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
378    
379 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
380     %if !%build_gems
381 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
382 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
383 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
384     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
385 pterjan 560987 rm -fr %{buildroot}%{gems_dir}/{gems,specifications}
386 fwang 311915 %if !%bootstrap
387 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
388 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
389     rm -fr %{buildroot}%{rubygems_dir}/rubygems
390 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
391     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
392 fwang 293412 %endif
393 fwang 311914 %endif
394 fwang 293412
395 blino 1152 %check
396     make test
397    
398 fwang 289961 %files
399 fwang 291551 %{_bindir}/erb
400     %{_bindir}/ruby
401 fwang 291560 %dir %{ruby_libdir}
402     %{ruby_libdir}/*.rb
403 fwang 291590 %exclude %{ruby_libdir}/irb.rb
404 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
405     %exclude %{ruby_libdir}/remote-tk.rb
406     %exclude %{ruby_libdir}/tcltk.rb
407     %exclude %{ruby_libdir}/tk.rb
408     %exclude %{ruby_libdir}/tkafter.rb
409     %exclude %{ruby_libdir}/tkbgerror.rb
410     %exclude %{ruby_libdir}/tkcanvas.rb
411     %exclude %{ruby_libdir}/tkclass.rb
412     %exclude %{ruby_libdir}/tkconsole.rb
413     %exclude %{ruby_libdir}/tkdialog.rb
414     %exclude %{ruby_libdir}/tkentry.rb
415     %exclude %{ruby_libdir}/tkfont.rb
416     %exclude %{ruby_libdir}/tkmacpkg.rb
417     %exclude %{ruby_libdir}/tkmenubar.rb
418     %exclude %{ruby_libdir}/tkmngfocus.rb
419     %exclude %{ruby_libdir}/tkpalette.rb
420     %exclude %{ruby_libdir}/tkscrollbox.rb
421     %exclude %{ruby_libdir}/tktext.rb
422     %exclude %{ruby_libdir}/tkvirtevent.rb
423     %exclude %{ruby_libdir}/tkwinpkg.rb
424     %{ruby_libdir}/cgi
425     %{ruby_libdir}/date
426     %{ruby_libdir}/digest
427     %{ruby_libdir}/dl
428     %{ruby_libdir}/drb
429     %{ruby_libdir}/fiddle
430     %{ruby_libdir}/matrix
431     %{ruby_libdir}/net
432     %{ruby_libdir}/openssl
433     %{ruby_libdir}/optparse
434 pterjan 435566 %{ruby_libdir}/psych
435 fwang 291560 %{ruby_libdir}/racc
436     %{ruby_libdir}/rbconfig
437     %{ruby_libdir}/rexml
438     %{ruby_libdir}/rinda
439     %{ruby_libdir}/ripper
440     %{ruby_libdir}/rss
441     %{ruby_libdir}/shell
442 pterjan 435211 %{ruby_libdir}/syslog
443 fwang 291560 %{ruby_libdir}/uri
444     %{ruby_libdir}/webrick
445     %{ruby_libdir}/xmlrpc
446     %{ruby_libdir}/yaml
447     %dir %{ruby_libarchdir}
448     %{ruby_libarchdir}/continuation.so
449     %{ruby_libarchdir}/coverage.so
450     %{ruby_libarchdir}/curses.so
451     %{ruby_libarchdir}/date_core.so
452     %{ruby_libarchdir}/dbm.so
453     %dir %{ruby_libarchdir}/digest
454     %{ruby_libarchdir}/digest.so
455     %{ruby_libarchdir}/digest/*.so
456     %dir %{ruby_libarchdir}/dl
457     %{ruby_libarchdir}/dl.so
458     %{ruby_libarchdir}/dl/*.so
459     %dir %{ruby_libarchdir}/enc
460     %{ruby_libarchdir}/enc/*.so
461 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
462     %{ruby_libarchdir}/enc/trans/*.so
463 fwang 291560 %{ruby_libarchdir}/etc.so
464     %{ruby_libarchdir}/fcntl.so
465     %{ruby_libarchdir}/fiber.so
466     %{ruby_libarchdir}/fiddle.so
467     %{ruby_libarchdir}/gdbm.so
468     %dir %{ruby_libarchdir}/io
469     %{ruby_libarchdir}/io/nonblock.so
470     %{ruby_libarchdir}/io/wait.so
471     %dir %{ruby_libarchdir}/mathn
472 fwang 291562 %{ruby_libarchdir}/mathn/*.so
473 fwang 291560 %{ruby_libarchdir}/nkf.so
474     %{ruby_libarchdir}/objspace.so
475     %{ruby_libarchdir}/openssl.so
476 pterjan 435566 %{ruby_libarchdir}/psych.so
477 fwang 291560 %{ruby_libarchdir}/pathname.so
478     %{ruby_libarchdir}/pty.so
479     %dir %{ruby_libarchdir}/racc
480     %{ruby_libarchdir}/racc/*.so
481     %{ruby_libarchdir}/rbconfig.rb
482     %{ruby_libarchdir}/readline.so
483     %{ruby_libarchdir}/ripper.so
484     %{ruby_libarchdir}/sdbm.so
485     %{ruby_libarchdir}/socket.so
486     %{ruby_libarchdir}/stringio.so
487     %{ruby_libarchdir}/strscan.so
488     %{ruby_libarchdir}/syslog.so
489     %{ruby_libarchdir}/zlib.so
490 fwang 291551 %{_mandir}/man1/erb.1.*
491     %{_mandir}/man1/ruby.1.*
492 blino 1152 %{_datadir}/emacs/site-lisp/*
493     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
494     %{_sysconfdir}/rpm/macros.d/%{name}.macros
495 fwang 291560 %{_datadir}/ruby/site_ruby
496     %{_libdir}/ruby/site_ruby
497     %{_datadir}/ruby/vendor_ruby
498     %{_libdir}/ruby/vendor_ruby
499 fwang 311914 %if %bootstrap
500     %{_bindir}/gem
501 fwang 448831 %dir %{rubygems_dir}
502     %{rubygems_dir}/rbconfig
503     %{rubygems_dir}/rubygems
504     %{rubygems_dir}/rubygems.rb
505     %{rubygems_dir}/ubygems.rb
506 fwang 311914 %endif
507 tv 674762 %{_rpmconfigdir}/fileattrs/rubygems.attr
508     %{_rpmconfigdir}/rubygems.req
509     %{_rpmconfigdir}/rubygems.prov
510 blino 1152
511     %files doc
512     %{_datadir}/ri
513 pterjan 435211 %{_datadir}/doc/ruby
514 blino 1152
515 fwang 291590 %files -n %{libname}
516     %{_libdir}/libruby.so.%{subver}
517     %{_libdir}/libruby.so.%{rubyapi}
518    
519 blino 1152 %files devel
520 fwang 290003 %{_includedir}/*
521 blino 1152 %{_libdir}/libruby-static.a
522     %{_libdir}/libruby.so
523 fwang 290003 %{_libdir}/pkgconfig/*.pc
524 blino 1152
525     %files tk
526 fwang 291560 %{ruby_libarchdir}/tcltklib.so
527     %{ruby_libarchdir}/tkutil.so
528     %{ruby_libdir}/multi-tk.rb
529     %{ruby_libdir}/remote-tk.rb
530     %{ruby_libdir}/tcltk.rb
531     %{ruby_libdir}/tk.rb
532     %{ruby_libdir}/tkafter.rb
533     %{ruby_libdir}/tkbgerror.rb
534     %{ruby_libdir}/tkcanvas.rb
535     %{ruby_libdir}/tkclass.rb
536     %{ruby_libdir}/tkconsole.rb
537     %{ruby_libdir}/tkdialog.rb
538     %{ruby_libdir}/tkentry.rb
539     %{ruby_libdir}/tkfont.rb
540     %{ruby_libdir}/tkmacpkg.rb
541     %{ruby_libdir}/tkmenubar.rb
542     %{ruby_libdir}/tkmngfocus.rb
543     %{ruby_libdir}/tkpalette.rb
544     %{ruby_libdir}/tkscrollbox.rb
545     %{ruby_libdir}/tktext.rb
546     %{ruby_libdir}/tkvirtevent.rb
547     %{ruby_libdir}/tkwinpkg.rb
548     %{ruby_libdir}/tk
549     %{ruby_libdir}/tkextlib
550 fwang 291551
551 fwang 293412 %files irb
552     %{_bindir}/irb
553     %{ruby_libdir}/irb.rb
554     %{ruby_libdir}/irb
555     %{_mandir}/man1/irb.1*
556    
557     %if %build_gems
558 fwang 291551 %files RubyGems
559     %{_bindir}/gem
560     %dir %{rubygems_dir}
561     %{rubygems_dir}/rbconfig
562     %{rubygems_dir}/rubygems
563     %{rubygems_dir}/rubygems.rb
564     %{rubygems_dir}/ubygems.rb
565    
566 fwang 291562 %files minitest
567     %{ruby_libdir}/minitest
568 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
569 fwang 291562
570 fwang 291551 %files rake
571     %{_bindir}/rake
572     %{_mandir}/man1/rake.1.*
573 fwang 291562 %{ruby_libdir}/rake
574 pterjan 560987 %{gems_dir}/gems/rake-*
575     %{gems_dir}/specifications/default/rake-*.gemspec
576 fwang 291562
577     %files rdoc
578     %{_bindir}/rdoc
579     %{_bindir}/ri
580     %{ruby_libdir}/rdoc
581 pterjan 560987 %{gems_dir}/gems/rdoc-*
582     %{gems_dir}/specifications/default/rdoc-*.gemspec
583 fwang 291562 %{_mandir}/man1/ri.1.*
584    
585     %files json
586     %dir %{ruby_libarchdir}/json
587     %dir %{ruby_libarchdir}/json/ext
588     %{ruby_libarchdir}/json/ext/*.so
589     %{ruby_libdir}/json
590 pterjan 560987 %{gems_dir}/specifications/default/json-*.gemspec
591 fwang 291590
592     %files bigdecimal
593     %{ruby_libdir}/bigdecimal
594     %{ruby_libarchdir}/bigdecimal.so
595 pterjan 560987 %{gems_dir}/specifications/default/bigdecimal-*.gemspec
596 fwang 291590
597     %files io-console
598     %{ruby_libdir}/io
599     %{ruby_libarchdir}/io/console.so
600 pterjan 560987 %{gems_dir}/specifications/default/io-console-*.gemspec
601 pterjan 435211
602     %files psych
603     %{ruby_libdir}/psych
604     %{ruby_libarchdir}/psych.so
605 pterjan 560987 %{gems_dir}/specifications/default/psych-*.gemspec
606 pterjan 435211
607     %files test-unit
608     %{_bindir}/testrb
609     %{ruby_libdir}/test
610 pterjan 560987 %{gems_dir}/gems/test-unit-*
611 pterjan 435211 %{rubygems_dir}/specifications/default/test-unit-*.gemspec
612 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30