/[packages]/updates/5/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/5/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1170821 - (hide annotations) (download)
Tue Oct 10 20:11:05 2017 UTC (6 years, 6 months ago) by pterjan
File size: 18864 byte(s)
Add patch for CVE-2017-14064
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4 luigiwalser 920553 %define patchversion p648
5 pterjan 796908 %define rel 1
6 pterjan 1141714 %define subrel 4
7 blino 1152
8 fwang 291590 %define libname %mklibname ruby %{subver}
9    
10 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
11     %define ruby_libarchdir %{_libdir}/%{name}
12    
13 fwang 290007 # This is the local lib/arch and should not be used for packaging.
14 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
15     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
16 fwang 290007
17     # This is the general location for libs/archs compatible with all
18     # or most of the Ruby versions available in the Fedora repositories.
19 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
20 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
21 fwang 290007
22 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
23     # RubyGems should be shared by all Ruby implementations.
24 pterjan 560984 %define rubygems_dir %{_datadir}/rubygems
25 pterjan 560987 %define gems_dir %{_datadir}/ruby/gems
26 pterjan 435211 %define rubygems_version 2.0.2
27 fwang 290007
28 fwang 468908 %define bootstrap 0
29 fwang 468812 %define build_gems 0
30 fwang 292558
31 blino 1152 Summary: Object Oriented Script Language
32     Name: ruby
33     Version: %{rubyver}.%{patchversion}
34     Release: %mkrel %rel
35 kamil 397518 License: Ruby or BSD
36 blino 1152 Group: Development/Ruby
37     BuildRequires: autoconf
38     BuildRequires: byacc
39 shlomif 291698 BuildRequires: doxygen
40 blino 1152 BuildRequires: ncurses-devel
41     BuildRequires: readline-devel
42 ovitters 648773 BuildRequires: tcl-devel
43     BuildRequires: tk-devel
44 fwang 276350 BuildRequires: db-devel
45 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
46 blino 1152 BuildRequires: openssl-devel
47     BuildRequires: zlib-devel
48 fwang 289987 BuildRequires: libffi-devel
49     BuildRequires: yaml-devel
50 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
51 tv 674762 Conflicts: ruby-devel < 2.0.0.p451-4.mga5
52 blino 1152 Obsoletes: ruby-rexml
53     Provides: ruby-rexml
54 pterjan 435566 # Couldn't get the standalone gem to work
55     Provides: rubygem(psych)
56 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
57     Provides: /usr/bin/ruby
58 fwang 293445 Provides: ruby(abi) = %rubyapi
59 fwang 463762 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
60 pterjan 435211 Source1: operating_system.rb
61 blino 1152 Source3: ruby.macros
62 tv 673709 # From FC:
63     # RPM dependency generators.
64     Source8: rubygems.attr
65     Source9: rubygems.req
66     Source10: rubygems.prov
67 blino 1152 URL: http://www.ruby-lang.org/
68 fwang 292558 %if !%bootstrap
69     Requires: rubygems >= %{rubygems_version}
70 fwang 293395 BuildRequires: ruby
71 fwang 292558 %endif
72 blino 1152
73 fwang 290007 # == FEDORA PATCHES BEGINS ==
74 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
75     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
76     # Fixes random WEBRick test failures.
77     # https://bugs.ruby-lang.org/issues/6573.
78     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
79 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
80     # http://redmine.ruby-lang.org/issues/5617
81     Patch8: ruby-1.9.3-custom-rubygems-location.patch
82     # Add support for installing binary extensions according to FHS.
83     # https://github.com/rubygems/rubygems/issues/210
84 pterjan 435211 # Note that 8th patch might be resolved by
85     # https://bugs.ruby-lang.org/issues/7897
86     Patch9: rubygems-2.0.0-binary-extensions.patch
87     # Make mkmf verbose by default
88     Patch12: ruby-1.9.3-mkmf-verbose.patch
89     # This slightly changes behavior of "gem install --install-dir" behavior.
90     # Without this patch, Specifications.dirs is modified and gems installed on
91     # the system cannot be required anymore. This causes later issues when RDoc
92     # documentation should be generated, since json gem is sudenly not accessible.
93     # https://github.com/rubygems/rubygems/pull/452
94     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
95     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
96     # https://github.com/rubygems/rubygems/pull/455
97     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
98 fwang 290007 # == FEDORA PATCHES ENDS ==
99 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
100     # to install gems into user dir
101     Patch20: ruby-2.0.0-p451-Do-not-install-to-user-dir.patch
102 fwang 290007
103 luigiwalser 795834 Patch21: ruby-2.0.0-CVE-2014-4975.patch
104 pterjan 1058297 Patch22: ruby-2.0.0-CVE-2016-7798.patch
105 pterjan 1109440 Patch23: ruby-2.0.0-CVE-2016-2339.patch
106 pterjan 1141714 Patch24: ruby-2.0.0-CVE-2015-9096.patch
107     Patch25: ruby-2.0.0-CVE-2016-2337.patch
108 pterjan 1170821 # TODO: CVE-2017-0898, CVE-2017-10784, CVE-2017-14033
109     Patch26: ruby-2.0.0-CVE-2017-14064.patch
110 luigiwalser 795834
111 fwang 291591 %package -n %{libname}
112 fwang 291590 Summary: Libraries necessary to run Ruby
113     Group: Development/Ruby
114    
115 blino 1152 %package doc
116     Summary: Documentation for the powerful language Ruby
117     Group: Development/Ruby
118 fwang 202696 BuildArch: noarch
119 blino 1152
120     %package devel
121     Summary: Development file for the powerful language Ruby
122     Group: Development/Ruby
123 fwang 311925 Requires: %{name} = %{version}
124     Requires: %{libname} = %{version}
125 blino 1152
126     %package tk
127     Summary: Tk extension for the powerful language Ruby
128     Group: Development/Ruby
129 fwang 311925 Requires: %{name} = %{version}
130 blino 1152
131 fwang 291551 %package RubyGems
132     Summary: The Ruby standard for packaging ruby libraries
133     Group: Development/Ruby
134 fwang 291590 Version: %{rubygems_version}
135 fwang 291551 Requires: ruby(abi) = %{subver}
136 fwang 291590 Provides: gem = %{rubygems_version}
137     Provides: rubygems = %{rubygems_version}
138     Provides: ruby(rubygems) = %{rubygems_version}
139 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
140 fwang 291561 BuildArch: noarch
141 fwang 291551
142 pterjan 435211 %define rake_ver 0.9.6
143 fwang 291551 %package rake
144     Summary: Simple ruby build program with capabilities similar to make
145     Group: Development/Ruby
146 shlomif 291767 Version: %{rake_ver}
147 fwang 291551 Requires: ruby(abi) = %{subver}
148 fwang 291561 BuildArch: noarch
149 fwang 291551
150 pterjan 435211 %define minitest_ver 4.3.2
151 fwang 291562 %package minitest
152 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
153 fwang 291562 Group: Development/Ruby
154 shlomif 291767 Version: %{minitest_ver}
155 fwang 291562 License: MIT
156 fwang 291590 Requires: ruby(abi) = %{subver}
157     Requires: ruby(rubygems) >= %{rubygems_version}
158 fwang 291562 BuildArch: noarch
159    
160 pterjan 435211 %define json_ver 1.7.7
161 fwang 291562 %package json
162     Summary: This is a JSON implementation as a Ruby extension in C
163     Group: Development/Ruby
164 shlomif 291767 Version: %{json_ver}
165 fwang 291562 License: Ruby or GPLv2
166 fwang 291590 Requires: ruby(abi) = %{subver}
167     Requires: ruby(rubygems) >= %{rubygems_version}
168 fwang 291562
169 pterjan 435211 %define rdoc_ver 4.0.0
170 fwang 291562 %package rdoc
171     Summary: A tool to generate HTML and command-line documentation for Ruby projects
172     Group: Development/Ruby
173 shlomif 291767 Version: %{rdoc_ver}
174 fwang 291562 License: GPLv2 and Ruby and MIT
175 fwang 291590 Requires: ruby(abi) = %{subver}
176     Requires: ruby(rubygems) >= %{rubygems_version}
177     Requires: ruby(irb) = %{version}
178 shlomif 291767 Provides: rdoc = %{rdoc_ver}
179     Provides: ri = %{rdoc_ver}
180 fwang 291562 BuildArch: noarch
181    
182 fwang 291590 %package irb
183     Summary: The Interactive Ruby
184     Group: Development/Ruby
185     Provides: irb = %{version}-%{release}
186     Provides: ruby(irb) = %{version}-%{release}
187 fwang 313459 Conflicts: ruby < 1.9
188 fwang 313460 BuildArch: noarch
189 fwang 291590
190 pterjan 435211 %define bigdecimal_ver 1.2.0
191 fwang 291590 %package bigdecimal
192     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
193     Group: Development/Ruby
194 pterjan 435211 Version: %{bigdecimal_ver}
195 fwang 291590 License: GPL+ or Artistic
196     Requires: ruby(abi) = %{subver}
197     Requires: ruby(rubygems) >= %{rubygems_version}
198    
199 pterjan 435211 %define io_console_ver 0.4.2
200 fwang 291590 %package io-console
201     Summary: IO/Console is a simple console utilizing library
202     Group: Development/Ruby
203 pterjan 435211 Version: %{io_console_ver}
204 fwang 291590 Requires: ruby(abi) = %{subver}
205     Requires: ruby(rubygems) >= %{rubygems_version}
206    
207 pterjan 435211 %define psych_ver 2.0.0
208     %package psych
209     Summary: A libyaml wrapper for Ruby
210     Version: %{psych_ver}
211     Group: Development/Ruby
212     License: MIT
213     Requires: ruby(abi) = %{subver}
214     Requires: ruby(rubygems) >= %{rubygems_version}
215     Conflicts: ruby < 2.0.0
216    
217     %define test_unit_ver 2.0.0
218     %package test-unit
219     Summary: test/unit compatible API testing framework
220     Version: %{psych_ver}
221     Group: Development/Ruby
222     License: MIT
223     Requires: ruby(abi) = %{subver}
224     Requires: ruby(rubygems) >= %{rubygems_version}
225     Conflicts: ruby < 2.0.0
226     BuildArch: noarch
227    
228 blino 1152 %description
229     Ruby is the interpreted scripting language for quick and
230     easy object-oriented programming. It has many features to
231     process text files and to do system management tasks (as in
232     Perl). It is simple, straight-forward, and extensible.
233    
234     %description doc
235     Ruby is the interpreted scripting language for quick and
236     easy object-oriented programming. It has many features to
237     process text files and to do system management tasks (as in
238     Perl). It is simple, straight-forward, and extensible.
239    
240     This package contains the Ruby's documentation
241    
242 fwang 291590 %description -n %{libname}
243     This package includes the libruby, necessary to run Ruby.
244    
245 blino 1152 %description devel
246     Ruby is the interpreted scripting language for quick and
247     easy object-oriented programming. It has many features to
248     process text files and to do system management tasks (as in
249     Perl). It is simple, straight-forward, and extensible.
250    
251     This package contains the Ruby's devel files.
252    
253     %description tk
254     Ruby is the interpreted scripting language for quick and
255     easy object-oriented programming. It has many features to
256     process text files and to do system management tasks (as in
257     Perl). It is simple, straight-forward, and extensible.
258    
259     This package contains the Tk extension for Ruby.
260    
261 fwang 291551 %description RubyGems
262     RubyGems is the Ruby standard for publishing and managing third party
263     libraries.
264    
265 fwang 291552 %description rake
266     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
267     specified in standard Ruby syntax.
268    
269 fwang 291562 %description rdoc
270     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
271     includes the 'rdoc' and 'ri' tools for generating and displaying online
272     documentation.
273    
274     %description json
275     This is a implementation of the JSON specification according to RFC 4627.
276     You can think of it as a low fat alternative to XML, if you want to store
277     data to disk or transmit it over a network rather than use a verbose
278     markup language.
279    
280     %description minitest
281     minitest/unit is a small and incredibly fast unit testing framework.
282    
283     minitest/spec is a functionally complete spec engine.
284    
285     minitest/benchmark is an awesome way to assert the performance of your
286     algorithms in a repeatable manner.
287    
288     minitest/mock by Steven Baker, is a beautifully tiny mock object
289     framework.
290    
291     minitest/pride shows pride in testing and adds coloring to your test
292     output.
293    
294 fwang 291590 %description irb
295     The irb is acronym for Interactive Ruby. It evaluates ruby expression
296     from the terminal.
297    
298     %description bigdecimal
299     Ruby provides built-in support for arbitrary precision integer arithmetic.
300     For example:
301    
302     42**13 -> 1265437718438866624512
303    
304     BigDecimal provides similar support for very large or very accurate floating
305     point numbers. Decimal arithmetic is also useful for general calculation,
306     because it provides the correct answers people expect–whereas normal binary
307     floating point arithmetic often introduces subtle errors because of the
308     conversion between base 10 and base 2.
309    
310     %description io-console
311     IO/Console provides very simple and portable access to console. It doesn't
312     provide higher layer features, such like curses and readline.
313    
314 pterjan 435211 %description psych
315     Psych is a YAML parser and emitter. Psych leverages
316     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
317     capabilities. In addition to wrapping libyaml, Psych also knows how to
318     serialize and de-serialize most Ruby objects to and from the YAML format.
319    
320     %description test-unit
321     This library implements test/unit compatible API on minitest.
322     The test/unit means that test/unit which was bundled with Ruby 1.8.
323    
324 blino 1152 %prep
325     %setup -q -n ruby-%{rubyver}-%{patchversion}
326 fwang 290007 %apply_patches
327 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
328     rm lib/mkmf.rb.0*
329 blino 1152
330     %build
331 fwang 290038 autoconf
332 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
333 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
334 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
335 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
336 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
337     --with-sitearchdir='%{ruby_sitearchdir}' \
338     --with-vendordir='%{ruby_vendorlibdir}' \
339     --with-vendorarchdir='%{ruby_vendorarchdir}' \
340 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
341 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
342     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
343     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
344     --with-rubygemsdir='%{rubygems_dir}' \
345     --with-ruby-pc='%{name}.pc' \
346     --enable-multiarch \
347     --with-ruby-version=''
348 blino 1152 %make
349    
350     %install
351     %makeinstall_std install-doc
352    
353     install -d %buildroot%{_datadir}/emacs/site-lisp
354     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
355    
356     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
357     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
358     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
359     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
360     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
361     EOF
362    
363     # Install the rpm macros
364     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
365     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
366 fwang 289961
367 tv 673709 # Install dependency generators.
368     mkdir -p %{buildroot}%{_rpmconfigdir}/fileattrs
369     install -m 644 %{SOURCE8} %{buildroot}%{_rpmconfigdir}/fileattrs
370     install -m 755 %{SOURCE9} %{buildroot}%{_rpmconfigdir}
371     install -m 755 %{SOURCE10} %{buildroot}%{_rpmconfigdir}
372    
373 pterjan 435211 # Install custom operating_system.rb
374     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
375     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
376    
377 pterjan 617250 # Version is empty if --with-ruby-version is specified.
378     # http://bugs.ruby-lang.org/issues/7807
379     sed -i 's/Version: .*/Version: %{rubyver}/' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
380    
381 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
382     %if !%build_gems
383 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
384 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
385 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
386     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
387 pterjan 560987 rm -fr %{buildroot}%{gems_dir}/{gems,specifications}
388 fwang 311915 %if !%bootstrap
389 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
390 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
391     rm -fr %{buildroot}%{rubygems_dir}/rubygems
392 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
393     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
394 fwang 293412 %endif
395 fwang 311914 %endif
396 fwang 293412
397 blino 1152 %check
398     make test
399    
400 fwang 289961 %files
401 fwang 291551 %{_bindir}/erb
402     %{_bindir}/ruby
403 fwang 291560 %dir %{ruby_libdir}
404     %{ruby_libdir}/*.rb
405 fwang 291590 %exclude %{ruby_libdir}/irb.rb
406 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
407     %exclude %{ruby_libdir}/remote-tk.rb
408     %exclude %{ruby_libdir}/tcltk.rb
409     %exclude %{ruby_libdir}/tk.rb
410     %exclude %{ruby_libdir}/tkafter.rb
411     %exclude %{ruby_libdir}/tkbgerror.rb
412     %exclude %{ruby_libdir}/tkcanvas.rb
413     %exclude %{ruby_libdir}/tkclass.rb
414     %exclude %{ruby_libdir}/tkconsole.rb
415     %exclude %{ruby_libdir}/tkdialog.rb
416     %exclude %{ruby_libdir}/tkentry.rb
417     %exclude %{ruby_libdir}/tkfont.rb
418     %exclude %{ruby_libdir}/tkmacpkg.rb
419     %exclude %{ruby_libdir}/tkmenubar.rb
420     %exclude %{ruby_libdir}/tkmngfocus.rb
421     %exclude %{ruby_libdir}/tkpalette.rb
422     %exclude %{ruby_libdir}/tkscrollbox.rb
423     %exclude %{ruby_libdir}/tktext.rb
424     %exclude %{ruby_libdir}/tkvirtevent.rb
425     %exclude %{ruby_libdir}/tkwinpkg.rb
426     %{ruby_libdir}/cgi
427     %{ruby_libdir}/date
428     %{ruby_libdir}/digest
429     %{ruby_libdir}/dl
430     %{ruby_libdir}/drb
431     %{ruby_libdir}/fiddle
432     %{ruby_libdir}/matrix
433     %{ruby_libdir}/net
434     %{ruby_libdir}/openssl
435     %{ruby_libdir}/optparse
436 pterjan 435566 %{ruby_libdir}/psych
437 fwang 291560 %{ruby_libdir}/racc
438     %{ruby_libdir}/rbconfig
439     %{ruby_libdir}/rexml
440     %{ruby_libdir}/rinda
441     %{ruby_libdir}/ripper
442     %{ruby_libdir}/rss
443     %{ruby_libdir}/shell
444 pterjan 435211 %{ruby_libdir}/syslog
445 fwang 291560 %{ruby_libdir}/uri
446     %{ruby_libdir}/webrick
447     %{ruby_libdir}/xmlrpc
448     %{ruby_libdir}/yaml
449     %dir %{ruby_libarchdir}
450     %{ruby_libarchdir}/continuation.so
451     %{ruby_libarchdir}/coverage.so
452     %{ruby_libarchdir}/curses.so
453     %{ruby_libarchdir}/date_core.so
454     %{ruby_libarchdir}/dbm.so
455     %dir %{ruby_libarchdir}/digest
456     %{ruby_libarchdir}/digest.so
457     %{ruby_libarchdir}/digest/*.so
458     %dir %{ruby_libarchdir}/dl
459     %{ruby_libarchdir}/dl.so
460     %{ruby_libarchdir}/dl/*.so
461     %dir %{ruby_libarchdir}/enc
462     %{ruby_libarchdir}/enc/*.so
463 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
464     %{ruby_libarchdir}/enc/trans/*.so
465 fwang 291560 %{ruby_libarchdir}/etc.so
466     %{ruby_libarchdir}/fcntl.so
467     %{ruby_libarchdir}/fiber.so
468     %{ruby_libarchdir}/fiddle.so
469     %{ruby_libarchdir}/gdbm.so
470     %dir %{ruby_libarchdir}/io
471     %{ruby_libarchdir}/io/nonblock.so
472     %{ruby_libarchdir}/io/wait.so
473     %dir %{ruby_libarchdir}/mathn
474 fwang 291562 %{ruby_libarchdir}/mathn/*.so
475 fwang 291560 %{ruby_libarchdir}/nkf.so
476     %{ruby_libarchdir}/objspace.so
477     %{ruby_libarchdir}/openssl.so
478 pterjan 435566 %{ruby_libarchdir}/psych.so
479 fwang 291560 %{ruby_libarchdir}/pathname.so
480     %{ruby_libarchdir}/pty.so
481     %dir %{ruby_libarchdir}/racc
482     %{ruby_libarchdir}/racc/*.so
483     %{ruby_libarchdir}/rbconfig.rb
484     %{ruby_libarchdir}/readline.so
485     %{ruby_libarchdir}/ripper.so
486     %{ruby_libarchdir}/sdbm.so
487     %{ruby_libarchdir}/socket.so
488     %{ruby_libarchdir}/stringio.so
489     %{ruby_libarchdir}/strscan.so
490     %{ruby_libarchdir}/syslog.so
491     %{ruby_libarchdir}/zlib.so
492 fwang 291551 %{_mandir}/man1/erb.1.*
493     %{_mandir}/man1/ruby.1.*
494 blino 1152 %{_datadir}/emacs/site-lisp/*
495     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
496     %{_sysconfdir}/rpm/macros.d/%{name}.macros
497 fwang 291560 %{_datadir}/ruby/site_ruby
498     %{_libdir}/ruby/site_ruby
499     %{_datadir}/ruby/vendor_ruby
500     %{_libdir}/ruby/vendor_ruby
501 fwang 311914 %if %bootstrap
502     %{_bindir}/gem
503 fwang 448831 %dir %{rubygems_dir}
504     %{rubygems_dir}/rbconfig
505     %{rubygems_dir}/rubygems
506     %{rubygems_dir}/rubygems.rb
507     %{rubygems_dir}/ubygems.rb
508 fwang 311914 %endif
509 tv 674762 %{_rpmconfigdir}/fileattrs/rubygems.attr
510     %{_rpmconfigdir}/rubygems.req
511     %{_rpmconfigdir}/rubygems.prov
512 blino 1152
513     %files doc
514     %{_datadir}/ri
515 pterjan 435211 %{_datadir}/doc/ruby
516 blino 1152
517 fwang 291590 %files -n %{libname}
518     %{_libdir}/libruby.so.%{subver}
519     %{_libdir}/libruby.so.%{rubyapi}
520    
521 blino 1152 %files devel
522 fwang 290003 %{_includedir}/*
523 blino 1152 %{_libdir}/libruby-static.a
524     %{_libdir}/libruby.so
525 fwang 290003 %{_libdir}/pkgconfig/*.pc
526 blino 1152
527     %files tk
528 fwang 291560 %{ruby_libarchdir}/tcltklib.so
529     %{ruby_libarchdir}/tkutil.so
530     %{ruby_libdir}/multi-tk.rb
531     %{ruby_libdir}/remote-tk.rb
532     %{ruby_libdir}/tcltk.rb
533     %{ruby_libdir}/tk.rb
534     %{ruby_libdir}/tkafter.rb
535     %{ruby_libdir}/tkbgerror.rb
536     %{ruby_libdir}/tkcanvas.rb
537     %{ruby_libdir}/tkclass.rb
538     %{ruby_libdir}/tkconsole.rb
539     %{ruby_libdir}/tkdialog.rb
540     %{ruby_libdir}/tkentry.rb
541     %{ruby_libdir}/tkfont.rb
542     %{ruby_libdir}/tkmacpkg.rb
543     %{ruby_libdir}/tkmenubar.rb
544     %{ruby_libdir}/tkmngfocus.rb
545     %{ruby_libdir}/tkpalette.rb
546     %{ruby_libdir}/tkscrollbox.rb
547     %{ruby_libdir}/tktext.rb
548     %{ruby_libdir}/tkvirtevent.rb
549     %{ruby_libdir}/tkwinpkg.rb
550     %{ruby_libdir}/tk
551     %{ruby_libdir}/tkextlib
552 fwang 291551
553 fwang 293412 %files irb
554     %{_bindir}/irb
555     %{ruby_libdir}/irb.rb
556     %{ruby_libdir}/irb
557     %{_mandir}/man1/irb.1*
558    
559     %if %build_gems
560 fwang 291551 %files RubyGems
561     %{_bindir}/gem
562     %dir %{rubygems_dir}
563     %{rubygems_dir}/rbconfig
564     %{rubygems_dir}/rubygems
565     %{rubygems_dir}/rubygems.rb
566     %{rubygems_dir}/ubygems.rb
567    
568 fwang 291562 %files minitest
569     %{ruby_libdir}/minitest
570 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
571 fwang 291562
572 fwang 291551 %files rake
573     %{_bindir}/rake
574     %{_mandir}/man1/rake.1.*
575 fwang 291562 %{ruby_libdir}/rake
576 pterjan 560987 %{gems_dir}/gems/rake-*
577     %{gems_dir}/specifications/default/rake-*.gemspec
578 fwang 291562
579     %files rdoc
580     %{_bindir}/rdoc
581     %{_bindir}/ri
582     %{ruby_libdir}/rdoc
583 pterjan 560987 %{gems_dir}/gems/rdoc-*
584     %{gems_dir}/specifications/default/rdoc-*.gemspec
585 fwang 291562 %{_mandir}/man1/ri.1.*
586    
587     %files json
588     %dir %{ruby_libarchdir}/json
589     %dir %{ruby_libarchdir}/json/ext
590     %{ruby_libarchdir}/json/ext/*.so
591     %{ruby_libdir}/json
592 pterjan 560987 %{gems_dir}/specifications/default/json-*.gemspec
593 fwang 291590
594     %files bigdecimal
595     %{ruby_libdir}/bigdecimal
596     %{ruby_libarchdir}/bigdecimal.so
597 pterjan 560987 %{gems_dir}/specifications/default/bigdecimal-*.gemspec
598 fwang 291590
599     %files io-console
600     %{ruby_libdir}/io
601     %{ruby_libarchdir}/io/console.so
602 pterjan 560987 %{gems_dir}/specifications/default/io-console-*.gemspec
603 pterjan 435211
604     %files psych
605     %{ruby_libdir}/psych
606     %{ruby_libarchdir}/psych.so
607 pterjan 560987 %{gems_dir}/specifications/default/psych-*.gemspec
608 pterjan 435211
609     %files test-unit
610     %{_bindir}/testrb
611     %{ruby_libdir}/test
612 pterjan 560987 %{gems_dir}/gems/test-unit-*
613 pterjan 435211 %{rubygems_dir}/specifications/default/test-unit-*.gemspec
614 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30