/[packages]/updates/5/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/5/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 435246 - (hide annotations) (download)
Sun Jun 2 18:52:38 2013 UTC (10 years, 10 months ago) by pterjan
Original Path: cauldron/ruby/current/SPECS/ruby.spec
File size: 17616 byte(s)
- Disable bundled gems
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4     %define patchversion p195
5 fwang 400216 %define rel 1
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21     # The RubyGems library has to stay out of Ruby directory three, since the
22     # RubyGems should be share by all Ruby implementations.
23 fwang 311714 %define rubygems_dir %{_datadir}/ruby/gems
24 pterjan 435211 %define rubygems_version 2.0.2
25 fwang 290007
26 fwang 311923 %define bootstrap 0
27 pterjan 435246 %define build_gems 0
28 fwang 292558
29 blino 1152 Summary: Object Oriented Script Language
30     Name: ruby
31     Version: %{rubyver}.%{patchversion}
32     Release: %mkrel %rel
33 kamil 397518 License: Ruby or BSD
34 blino 1152 Group: Development/Ruby
35     BuildRequires: autoconf
36     BuildRequires: byacc
37 shlomif 291698 BuildRequires: doxygen
38 blino 1152 BuildRequires: ncurses-devel
39     BuildRequires: readline-devel
40     BuildRequires: tcl-devel tk-devel
41 fwang 276350 BuildRequires: db-devel
42 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
43 blino 1152 BuildRequires: openssl-devel
44     BuildRequires: zlib-devel
45 fwang 289987 BuildRequires: libffi-devel
46     BuildRequires: yaml-devel
47 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
48 blino 1152 Obsoletes: ruby-rexml
49     Provides: ruby-rexml
50     # explicit file provides (since such requires are automatically added by find-requires)
51     Provides: /usr/bin/ruby
52 fwang 293445 Provides: ruby(abi) = %rubyapi
53 blino 1152
54 pterjan 435211 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.gz
55     Source1: operating_system.rb
56 blino 1152 Source3: ruby.macros
57     URL: http://www.ruby-lang.org/
58 fwang 292558 %if !%bootstrap
59     Requires: rubygems >= %{rubygems_version}
60 fwang 293395 BuildRequires: ruby
61 fwang 292558 %endif
62 blino 1152
63 fwang 290007 # == FEDORA PATCHES BEGINS ==
64 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
65     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
66 fwang 290007 # http://redmine.ruby-lang.org/issues/5465
67     Patch4: ruby-1.9.3-fix-s390x-build.patch
68 pterjan 435211 # Fixes random WEBRick test failures.
69     # https://bugs.ruby-lang.org/issues/6573.
70     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
71 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
72     # http://redmine.ruby-lang.org/issues/5617
73     Patch8: ruby-1.9.3-custom-rubygems-location.patch
74     # Add support for installing binary extensions according to FHS.
75     # https://github.com/rubygems/rubygems/issues/210
76 pterjan 435211 # Note that 8th patch might be resolved by
77     # https://bugs.ruby-lang.org/issues/7897
78     Patch9: rubygems-2.0.0-binary-extensions.patch
79     # Make mkmf verbose by default
80     Patch12: ruby-1.9.3-mkmf-verbose.patch
81     # This slightly changes behavior of "gem install --install-dir" behavior.
82     # Without this patch, Specifications.dirs is modified and gems installed on
83     # the system cannot be required anymore. This causes later issues when RDoc
84     # documentation should be generated, since json gem is sudenly not accessible.
85     # https://github.com/rubygems/rubygems/pull/452
86     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
87     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
88     # https://github.com/rubygems/rubygems/pull/455
89     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
90 fwang 290007 # == FEDORA PATCHES ENDS ==
91    
92 fwang 291591 %package -n %{libname}
93 fwang 291590 Summary: Libraries necessary to run Ruby
94     Group: Development/Ruby
95    
96 blino 1152 %package doc
97     Summary: Documentation for the powerful language Ruby
98     Group: Development/Ruby
99 fwang 202696 BuildArch: noarch
100 blino 1152
101     %package devel
102     Summary: Development file for the powerful language Ruby
103     Group: Development/Ruby
104 fwang 311925 Requires: %{name} = %{version}
105     Requires: %{libname} = %{version}
106 blino 1152
107     %package tk
108     Summary: Tk extension for the powerful language Ruby
109     Group: Development/Ruby
110 fwang 311925 Requires: %{name} = %{version}
111 blino 1152
112 fwang 291551 %package RubyGems
113     Summary: The Ruby standard for packaging ruby libraries
114     Group: Development/Ruby
115 fwang 291590 Version: %{rubygems_version}
116 fwang 291551 Requires: ruby(abi) = %{subver}
117 fwang 291590 Provides: gem = %{rubygems_version}
118     Provides: rubygems = %{rubygems_version}
119     Provides: ruby(rubygems) = %{rubygems_version}
120 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
121 fwang 291561 BuildArch: noarch
122 fwang 291551
123 pterjan 435211 %define rake_ver 0.9.6
124 fwang 291551 %package rake
125     Summary: Simple ruby build program with capabilities similar to make
126     Group: Development/Ruby
127 shlomif 291767 Version: %{rake_ver}
128 fwang 291551 Requires: ruby(abi) = %{subver}
129 fwang 291561 BuildArch: noarch
130 fwang 291551
131 pterjan 435211 %define minitest_ver 4.3.2
132 fwang 291562 %package minitest
133 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
134 fwang 291562 Group: Development/Ruby
135 shlomif 291767 Version: %{minitest_ver}
136 fwang 291562 License: MIT
137 fwang 291590 Requires: ruby(abi) = %{subver}
138     Requires: ruby(rubygems) >= %{rubygems_version}
139 fwang 291562 BuildArch: noarch
140    
141 pterjan 435211 %define json_ver 1.7.7
142 fwang 291562 %package json
143     Summary: This is a JSON implementation as a Ruby extension in C
144     Group: Development/Ruby
145 shlomif 291767 Version: %{json_ver}
146 fwang 291562 License: Ruby or GPLv2
147 fwang 291590 Requires: ruby(abi) = %{subver}
148     Requires: ruby(rubygems) >= %{rubygems_version}
149 fwang 291562
150 pterjan 435211 %define rdoc_ver 4.0.0
151 fwang 291562 %package rdoc
152     Summary: A tool to generate HTML and command-line documentation for Ruby projects
153     Group: Development/Ruby
154 shlomif 291767 Version: %{rdoc_ver}
155 fwang 291562 License: GPLv2 and Ruby and MIT
156 fwang 291590 Requires: ruby(abi) = %{subver}
157     Requires: ruby(rubygems) >= %{rubygems_version}
158     Requires: ruby(irb) = %{version}
159 shlomif 291767 Provides: rdoc = %{rdoc_ver}
160     Provides: ri = %{rdoc_ver}
161 fwang 291562 BuildArch: noarch
162    
163 fwang 291590 %package irb
164     Summary: The Interactive Ruby
165     Group: Development/Ruby
166     Provides: irb = %{version}-%{release}
167     Provides: ruby(irb) = %{version}-%{release}
168 fwang 313459 Conflicts: ruby < 1.9
169 fwang 313460 BuildArch: noarch
170 fwang 291590
171 pterjan 435211 %define bigdecimal_ver 1.2.0
172 fwang 291590 %package bigdecimal
173     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
174     Group: Development/Ruby
175 pterjan 435211 Version: %{bigdecimal_ver}
176 fwang 291590 License: GPL+ or Artistic
177     Requires: ruby(abi) = %{subver}
178     Requires: ruby(rubygems) >= %{rubygems_version}
179    
180 pterjan 435211 %define io_console_ver 0.4.2
181 fwang 291590 %package io-console
182     Summary: IO/Console is a simple console utilizing library
183     Group: Development/Ruby
184 pterjan 435211 Version: %{io_console_ver}
185 fwang 291590 Requires: ruby(abi) = %{subver}
186     Requires: ruby(rubygems) >= %{rubygems_version}
187    
188 pterjan 435211 %define psych_ver 2.0.0
189     %package psych
190     Summary: A libyaml wrapper for Ruby
191     Version: %{psych_ver}
192     Group: Development/Ruby
193     License: MIT
194     Requires: ruby(abi) = %{subver}
195     Requires: ruby(rubygems) >= %{rubygems_version}
196     Conflicts: ruby < 2.0.0
197    
198     %define test_unit_ver 2.0.0
199     %package test-unit
200     Summary: test/unit compatible API testing framework
201     Version: %{psych_ver}
202     Group: Development/Ruby
203     License: MIT
204     Requires: ruby(abi) = %{subver}
205     Requires: ruby(rubygems) >= %{rubygems_version}
206     Conflicts: ruby < 2.0.0
207     BuildArch: noarch
208    
209 blino 1152 %description
210     Ruby is the interpreted scripting language for quick and
211     easy object-oriented programming. It has many features to
212     process text files and to do system management tasks (as in
213     Perl). It is simple, straight-forward, and extensible.
214    
215     %description doc
216     Ruby is the interpreted scripting language for quick and
217     easy object-oriented programming. It has many features to
218     process text files and to do system management tasks (as in
219     Perl). It is simple, straight-forward, and extensible.
220    
221     This package contains the Ruby's documentation
222    
223 fwang 291590 %description -n %{libname}
224     This package includes the libruby, necessary to run Ruby.
225    
226 blino 1152 %description devel
227     Ruby is the interpreted scripting language for quick and
228     easy object-oriented programming. It has many features to
229     process text files and to do system management tasks (as in
230     Perl). It is simple, straight-forward, and extensible.
231    
232     This package contains the Ruby's devel files.
233    
234     %description tk
235     Ruby is the interpreted scripting language for quick and
236     easy object-oriented programming. It has many features to
237     process text files and to do system management tasks (as in
238     Perl). It is simple, straight-forward, and extensible.
239    
240     This package contains the Tk extension for Ruby.
241    
242 fwang 291551 %description RubyGems
243     RubyGems is the Ruby standard for publishing and managing third party
244     libraries.
245    
246 fwang 291552 %description rake
247     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
248     specified in standard Ruby syntax.
249    
250 fwang 291562 %description rdoc
251     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
252     includes the 'rdoc' and 'ri' tools for generating and displaying online
253     documentation.
254    
255     %description json
256     This is a implementation of the JSON specification according to RFC 4627.
257     You can think of it as a low fat alternative to XML, if you want to store
258     data to disk or transmit it over a network rather than use a verbose
259     markup language.
260    
261     %description minitest
262     minitest/unit is a small and incredibly fast unit testing framework.
263    
264     minitest/spec is a functionally complete spec engine.
265    
266     minitest/benchmark is an awesome way to assert the performance of your
267     algorithms in a repeatable manner.
268    
269     minitest/mock by Steven Baker, is a beautifully tiny mock object
270     framework.
271    
272     minitest/pride shows pride in testing and adds coloring to your test
273     output.
274    
275 fwang 291590 %description irb
276     The irb is acronym for Interactive Ruby. It evaluates ruby expression
277     from the terminal.
278    
279     %description bigdecimal
280     Ruby provides built-in support for arbitrary precision integer arithmetic.
281     For example:
282    
283     42**13 -> 1265437718438866624512
284    
285     BigDecimal provides similar support for very large or very accurate floating
286     point numbers. Decimal arithmetic is also useful for general calculation,
287     because it provides the correct answers people expect–whereas normal binary
288     floating point arithmetic often introduces subtle errors because of the
289     conversion between base 10 and base 2.
290    
291     %description io-console
292     IO/Console provides very simple and portable access to console. It doesn't
293     provide higher layer features, such like curses and readline.
294    
295 pterjan 435211 %description psych
296     Psych is a YAML parser and emitter. Psych leverages
297     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
298     capabilities. In addition to wrapping libyaml, Psych also knows how to
299     serialize and de-serialize most Ruby objects to and from the YAML format.
300    
301     %description test-unit
302     This library implements test/unit compatible API on minitest.
303     The test/unit means that test/unit which was bundled with Ruby 1.8.
304    
305 blino 1152 %prep
306     %setup -q -n ruby-%{rubyver}-%{patchversion}
307 fwang 290007 %apply_patches
308 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
309     rm lib/mkmf.rb.0*
310 blino 1152
311     %build
312 fwang 290038 autoconf
313 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
314 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
315 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
316 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
317 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
318     --with-sitearchdir='%{ruby_sitearchdir}' \
319     --with-vendordir='%{ruby_vendorlibdir}' \
320     --with-vendorarchdir='%{ruby_vendorarchdir}' \
321 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
322 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
323     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
324     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
325     --with-rubygemsdir='%{rubygems_dir}' \
326     --with-ruby-pc='%{name}.pc' \
327     --enable-multiarch \
328     --with-ruby-version=''
329 blino 1152 %make
330    
331     %install
332     %makeinstall_std install-doc
333    
334     install -d %buildroot%{_datadir}/emacs/site-lisp
335     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
336    
337     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
338     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
339     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
340     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
341     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
342     EOF
343    
344     # Install the rpm macros
345     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
346     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
347 fwang 289961
348 pterjan 435211 # Install custom operating_system.rb
349     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
350     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
351    
352 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
353     %if !%build_gems
354 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
355 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
356 pterjan 435246 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,psych,test}
357 fwang 293415 rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
358 pterjan 435211 rm -fr %{buildroot}%{rubygems_dir}
359 fwang 311915 %if !%bootstrap
360 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
361 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
362     rm -fr %{buildroot}%{rubygems_dir}/rubygems
363 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
364     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
365 fwang 293412 %endif
366 fwang 311914 %endif
367 fwang 293412
368 blino 1152 %check
369     make test
370    
371 fwang 289961 %files
372 fwang 291551 %{_bindir}/erb
373     %{_bindir}/ruby
374 fwang 291560 %dir %{ruby_libdir}
375     %{ruby_libdir}/*.rb
376 fwang 291590 %exclude %{ruby_libdir}/irb.rb
377 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
378     %exclude %{ruby_libdir}/remote-tk.rb
379     %exclude %{ruby_libdir}/tcltk.rb
380     %exclude %{ruby_libdir}/tk.rb
381     %exclude %{ruby_libdir}/tkafter.rb
382     %exclude %{ruby_libdir}/tkbgerror.rb
383     %exclude %{ruby_libdir}/tkcanvas.rb
384     %exclude %{ruby_libdir}/tkclass.rb
385     %exclude %{ruby_libdir}/tkconsole.rb
386     %exclude %{ruby_libdir}/tkdialog.rb
387     %exclude %{ruby_libdir}/tkentry.rb
388     %exclude %{ruby_libdir}/tkfont.rb
389     %exclude %{ruby_libdir}/tkmacpkg.rb
390     %exclude %{ruby_libdir}/tkmenubar.rb
391     %exclude %{ruby_libdir}/tkmngfocus.rb
392     %exclude %{ruby_libdir}/tkpalette.rb
393     %exclude %{ruby_libdir}/tkscrollbox.rb
394     %exclude %{ruby_libdir}/tktext.rb
395     %exclude %{ruby_libdir}/tkvirtevent.rb
396     %exclude %{ruby_libdir}/tkwinpkg.rb
397     %{ruby_libdir}/cgi
398     %{ruby_libdir}/date
399     %{ruby_libdir}/digest
400     %{ruby_libdir}/dl
401     %{ruby_libdir}/drb
402     %{ruby_libdir}/fiddle
403     %{ruby_libdir}/matrix
404     %{ruby_libdir}/net
405     %{ruby_libdir}/openssl
406     %{ruby_libdir}/optparse
407     %{ruby_libdir}/racc
408     %{ruby_libdir}/rbconfig
409     %{ruby_libdir}/rexml
410     %{ruby_libdir}/rinda
411     %{ruby_libdir}/ripper
412     %{ruby_libdir}/rss
413     %{ruby_libdir}/shell
414 pterjan 435211 %{ruby_libdir}/syslog
415 fwang 291560 %{ruby_libdir}/uri
416     %{ruby_libdir}/webrick
417     %{ruby_libdir}/xmlrpc
418     %{ruby_libdir}/yaml
419     %dir %{ruby_libarchdir}
420     %{ruby_libarchdir}/continuation.so
421     %{ruby_libarchdir}/coverage.so
422     %{ruby_libarchdir}/curses.so
423     %{ruby_libarchdir}/date_core.so
424     %{ruby_libarchdir}/dbm.so
425     %dir %{ruby_libarchdir}/digest
426     %{ruby_libarchdir}/digest.so
427     %{ruby_libarchdir}/digest/*.so
428     %dir %{ruby_libarchdir}/dl
429     %{ruby_libarchdir}/dl.so
430     %{ruby_libarchdir}/dl/*.so
431     %dir %{ruby_libarchdir}/enc
432     %{ruby_libarchdir}/enc/*.so
433 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
434     %{ruby_libarchdir}/enc/trans/*.so
435 fwang 291560 %{ruby_libarchdir}/etc.so
436     %{ruby_libarchdir}/fcntl.so
437     %{ruby_libarchdir}/fiber.so
438     %{ruby_libarchdir}/fiddle.so
439     %{ruby_libarchdir}/gdbm.so
440     %dir %{ruby_libarchdir}/io
441     %{ruby_libarchdir}/io/nonblock.so
442     %{ruby_libarchdir}/io/wait.so
443     %dir %{ruby_libarchdir}/mathn
444 fwang 291562 %{ruby_libarchdir}/mathn/*.so
445 fwang 291560 %{ruby_libarchdir}/nkf.so
446     %{ruby_libarchdir}/objspace.so
447     %{ruby_libarchdir}/openssl.so
448     %{ruby_libarchdir}/pathname.so
449     %{ruby_libarchdir}/pty.so
450     %dir %{ruby_libarchdir}/racc
451     %{ruby_libarchdir}/racc/*.so
452     %{ruby_libarchdir}/rbconfig.rb
453     %{ruby_libarchdir}/readline.so
454     %{ruby_libarchdir}/ripper.so
455     %{ruby_libarchdir}/sdbm.so
456     %{ruby_libarchdir}/socket.so
457     %{ruby_libarchdir}/stringio.so
458     %{ruby_libarchdir}/strscan.so
459     %{ruby_libarchdir}/syslog.so
460     %{ruby_libarchdir}/zlib.so
461 fwang 291551 %{_mandir}/man1/erb.1.*
462     %{_mandir}/man1/ruby.1.*
463 blino 1152 %{_datadir}/emacs/site-lisp/*
464     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
465     %{_sysconfdir}/rpm/macros.d/%{name}.macros
466 fwang 291560 %{_datadir}/ruby/site_ruby
467     %{_libdir}/ruby/site_ruby
468     %{_datadir}/ruby/vendor_ruby
469     %{_libdir}/ruby/vendor_ruby
470 fwang 311914 %if %bootstrap
471     %{_bindir}/gem
472     %dir %{rubygems_dir}
473     %{rubygems_dir}/rbconfig
474     %{rubygems_dir}/rubygems
475     %{rubygems_dir}/rubygems.rb
476     %{rubygems_dir}/ubygems.rb
477     %endif
478 blino 1152
479     %files doc
480     %{_datadir}/ri
481 pterjan 435211 %{_datadir}/doc/ruby
482 blino 1152
483 fwang 291590 %files -n %{libname}
484     %{_libdir}/libruby.so.%{subver}
485     %{_libdir}/libruby.so.%{rubyapi}
486    
487 blino 1152 %files devel
488 fwang 290003 %{_includedir}/*
489 blino 1152 %{_libdir}/libruby-static.a
490     %{_libdir}/libruby.so
491 fwang 290003 %{_libdir}/pkgconfig/*.pc
492 blino 1152
493     %files tk
494 fwang 291560 %{ruby_libarchdir}/tcltklib.so
495     %{ruby_libarchdir}/tkutil.so
496     %{ruby_libdir}/multi-tk.rb
497     %{ruby_libdir}/remote-tk.rb
498     %{ruby_libdir}/tcltk.rb
499     %{ruby_libdir}/tk.rb
500     %{ruby_libdir}/tkafter.rb
501     %{ruby_libdir}/tkbgerror.rb
502     %{ruby_libdir}/tkcanvas.rb
503     %{ruby_libdir}/tkclass.rb
504     %{ruby_libdir}/tkconsole.rb
505     %{ruby_libdir}/tkdialog.rb
506     %{ruby_libdir}/tkentry.rb
507     %{ruby_libdir}/tkfont.rb
508     %{ruby_libdir}/tkmacpkg.rb
509     %{ruby_libdir}/tkmenubar.rb
510     %{ruby_libdir}/tkmngfocus.rb
511     %{ruby_libdir}/tkpalette.rb
512     %{ruby_libdir}/tkscrollbox.rb
513     %{ruby_libdir}/tktext.rb
514     %{ruby_libdir}/tkvirtevent.rb
515     %{ruby_libdir}/tkwinpkg.rb
516     %{ruby_libdir}/tk
517     %{ruby_libdir}/tkextlib
518 fwang 291551
519 fwang 293412 %files irb
520     %{_bindir}/irb
521     %{ruby_libdir}/irb.rb
522     %{ruby_libdir}/irb
523     %{_mandir}/man1/irb.1*
524    
525     %if %build_gems
526 fwang 291551 %files RubyGems
527     %{_bindir}/gem
528     %dir %{rubygems_dir}
529     %{rubygems_dir}/rbconfig
530     %{rubygems_dir}/rubygems
531     %{rubygems_dir}/rubygems.rb
532     %{rubygems_dir}/ubygems.rb
533    
534 fwang 291562 %files minitest
535     %{ruby_libdir}/minitest
536 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
537 fwang 291562
538 fwang 291551 %files rake
539     %{_bindir}/rake
540     %{_mandir}/man1/rake.1.*
541 fwang 291562 %{ruby_libdir}/rake
542 pterjan 435211 %{rubygems_dir}/gems/rake-*
543     %{rubygems_dir}/specifications/default/rake-*.gemspec
544 fwang 291562
545     %files rdoc
546     %{_bindir}/rdoc
547     %{_bindir}/ri
548     %{ruby_libdir}/rdoc
549 pterjan 435211 %{rubygems_dir}/gems/rdoc-*
550     %{rubygems_dir}/specifications/default/rdoc-*.gemspec
551 fwang 291562 %{_mandir}/man1/ri.1.*
552    
553     %files json
554     %dir %{ruby_libarchdir}/json
555     %dir %{ruby_libarchdir}/json/ext
556     %{ruby_libarchdir}/json/ext/*.so
557     %{ruby_libdir}/json
558 pterjan 435211 %{rubygems_dir}/specifications/default/json-*.gemspec
559 fwang 291590
560     %files bigdecimal
561     %{ruby_libdir}/bigdecimal
562     %{ruby_libarchdir}/bigdecimal.so
563 pterjan 435211 %{rubygems_dir}/specifications/default/bigdecimal-*.gemspec
564 fwang 291590
565     %files io-console
566     %{ruby_libdir}/io
567     %{ruby_libarchdir}/io/console.so
568 pterjan 435211 %{rubygems_dir}/specifications/default/io-console-*.gemspec
569    
570     %files psych
571     %{ruby_libdir}/psych
572     %{ruby_libarchdir}/psych.so
573     %{rubygems_dir}/specifications/default/psych-*.gemspec
574    
575     %files test-unit
576     %{_bindir}/testrb
577     %{ruby_libdir}/test
578     %{rubygems_dir}/gems/test-unit-*
579     %{rubygems_dir}/specifications/default/test-unit-*.gemspec
580 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30