/[packages]/updates/5/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/5/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 468812 - (hide annotations) (download)
Wed Aug 21 08:18:00 2013 UTC (10 years, 8 months ago) by fwang
Original Path: cauldron/ruby/branches/2.0/current/SPECS/ruby.spec
File size: 18062 byte(s)
temporarily obsolete newly built packages
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4 fwang 447652 %define patchversion p247
5 fwang 468812 %define rel 2
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21     # The RubyGems library has to stay out of Ruby directory three, since the
22     # RubyGems should be share by all Ruby implementations.
23 fwang 311714 %define rubygems_dir %{_datadir}/ruby/gems
24 pterjan 435211 %define rubygems_version 2.0.2
25 fwang 290007
26 fwang 448783 %define bootstrap 1
27 fwang 468812 %define build_gems 0
28 fwang 292558
29 blino 1152 Summary: Object Oriented Script Language
30     Name: ruby
31     Version: %{rubyver}.%{patchversion}
32     Release: %mkrel %rel
33 kamil 397518 License: Ruby or BSD
34 blino 1152 Group: Development/Ruby
35     BuildRequires: autoconf
36     BuildRequires: byacc
37 shlomif 291698 BuildRequires: doxygen
38 blino 1152 BuildRequires: ncurses-devel
39     BuildRequires: readline-devel
40     BuildRequires: tcl-devel tk-devel
41 fwang 276350 BuildRequires: db-devel
42 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
43 blino 1152 BuildRequires: openssl-devel
44     BuildRequires: zlib-devel
45 fwang 289987 BuildRequires: libffi-devel
46     BuildRequires: yaml-devel
47 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
48 blino 1152 Obsoletes: ruby-rexml
49 fwang 468812 Obsoletes:
50 blino 1152 Provides: ruby-rexml
51 pterjan 435566 # Couldn't get the standalone gem to work
52     Provides: rubygem(psych)
53 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
54     Provides: /usr/bin/ruby
55 fwang 293445 Provides: ruby(abi) = %rubyapi
56 fwang 463762 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
57 pterjan 435211 Source1: operating_system.rb
58 blino 1152 Source3: ruby.macros
59     URL: http://www.ruby-lang.org/
60 fwang 292558 %if !%bootstrap
61     Requires: rubygems >= %{rubygems_version}
62 fwang 293395 BuildRequires: ruby
63 fwang 292558 %endif
64 fwang 468812 Obsoletes: ruby-RubyGems < 2.0.2-%{release}
65     Obsoletes: ruby-minitest < 4.3.2-%{release}
66     Obsoletes: ruby-rake < 0.9.6-%{release}
67     Obsoletes: ruby-rdoc < 4.0.0-%{release}
68     Obsoletes: ruby-json < 1.7.7-%{release}
69     Obsoletes: ruby-bigdecimal < 1.2.0-%{release}
70     Obsoletes: ruby-io-console < 0.4.2-%{release}
71     Obsoletes: ruby-psych < 2.0.0-%{release}
72     Obsoletes: ruby-test-unit < 2.0.0-%{release}
73 blino 1152
74 fwang 290007 # == FEDORA PATCHES BEGINS ==
75 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
76     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
77     # Fixes random WEBRick test failures.
78     # https://bugs.ruby-lang.org/issues/6573.
79     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
80 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
81     # http://redmine.ruby-lang.org/issues/5617
82     Patch8: ruby-1.9.3-custom-rubygems-location.patch
83     # Add support for installing binary extensions according to FHS.
84     # https://github.com/rubygems/rubygems/issues/210
85 pterjan 435211 # Note that 8th patch might be resolved by
86     # https://bugs.ruby-lang.org/issues/7897
87     Patch9: rubygems-2.0.0-binary-extensions.patch
88     # Make mkmf verbose by default
89     Patch12: ruby-1.9.3-mkmf-verbose.patch
90     # This slightly changes behavior of "gem install --install-dir" behavior.
91     # Without this patch, Specifications.dirs is modified and gems installed on
92     # the system cannot be required anymore. This causes later issues when RDoc
93     # documentation should be generated, since json gem is sudenly not accessible.
94     # https://github.com/rubygems/rubygems/pull/452
95     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
96     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
97     # https://github.com/rubygems/rubygems/pull/455
98     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
99 fwang 290007 # == FEDORA PATCHES ENDS ==
100    
101 fwang 291591 %package -n %{libname}
102 fwang 291590 Summary: Libraries necessary to run Ruby
103     Group: Development/Ruby
104    
105 blino 1152 %package doc
106     Summary: Documentation for the powerful language Ruby
107     Group: Development/Ruby
108 fwang 202696 BuildArch: noarch
109 blino 1152
110     %package devel
111     Summary: Development file for the powerful language Ruby
112     Group: Development/Ruby
113 fwang 311925 Requires: %{name} = %{version}
114     Requires: %{libname} = %{version}
115 blino 1152
116     %package tk
117     Summary: Tk extension for the powerful language Ruby
118     Group: Development/Ruby
119 fwang 311925 Requires: %{name} = %{version}
120 blino 1152
121 fwang 291551 %package RubyGems
122     Summary: The Ruby standard for packaging ruby libraries
123     Group: Development/Ruby
124 fwang 291590 Version: %{rubygems_version}
125 fwang 291551 Requires: ruby(abi) = %{subver}
126 fwang 291590 Provides: gem = %{rubygems_version}
127     Provides: rubygems = %{rubygems_version}
128     Provides: ruby(rubygems) = %{rubygems_version}
129 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
130 fwang 291561 BuildArch: noarch
131 fwang 291551
132 pterjan 435211 %define rake_ver 0.9.6
133 fwang 291551 %package rake
134     Summary: Simple ruby build program with capabilities similar to make
135     Group: Development/Ruby
136 shlomif 291767 Version: %{rake_ver}
137 fwang 291551 Requires: ruby(abi) = %{subver}
138 fwang 291561 BuildArch: noarch
139 fwang 291551
140 pterjan 435211 %define minitest_ver 4.3.2
141 fwang 291562 %package minitest
142 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
143 fwang 291562 Group: Development/Ruby
144 shlomif 291767 Version: %{minitest_ver}
145 fwang 291562 License: MIT
146 fwang 291590 Requires: ruby(abi) = %{subver}
147     Requires: ruby(rubygems) >= %{rubygems_version}
148 fwang 291562 BuildArch: noarch
149    
150 pterjan 435211 %define json_ver 1.7.7
151 fwang 291562 %package json
152     Summary: This is a JSON implementation as a Ruby extension in C
153     Group: Development/Ruby
154 shlomif 291767 Version: %{json_ver}
155 fwang 291562 License: Ruby or GPLv2
156 fwang 291590 Requires: ruby(abi) = %{subver}
157     Requires: ruby(rubygems) >= %{rubygems_version}
158 fwang 291562
159 pterjan 435211 %define rdoc_ver 4.0.0
160 fwang 291562 %package rdoc
161     Summary: A tool to generate HTML and command-line documentation for Ruby projects
162     Group: Development/Ruby
163 shlomif 291767 Version: %{rdoc_ver}
164 fwang 291562 License: GPLv2 and Ruby and MIT
165 fwang 291590 Requires: ruby(abi) = %{subver}
166     Requires: ruby(rubygems) >= %{rubygems_version}
167     Requires: ruby(irb) = %{version}
168 shlomif 291767 Provides: rdoc = %{rdoc_ver}
169     Provides: ri = %{rdoc_ver}
170 fwang 291562 BuildArch: noarch
171    
172 fwang 291590 %package irb
173     Summary: The Interactive Ruby
174     Group: Development/Ruby
175     Provides: irb = %{version}-%{release}
176     Provides: ruby(irb) = %{version}-%{release}
177 fwang 313459 Conflicts: ruby < 1.9
178 fwang 313460 BuildArch: noarch
179 fwang 291590
180 pterjan 435211 %define bigdecimal_ver 1.2.0
181 fwang 291590 %package bigdecimal
182     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
183     Group: Development/Ruby
184 pterjan 435211 Version: %{bigdecimal_ver}
185 fwang 291590 License: GPL+ or Artistic
186     Requires: ruby(abi) = %{subver}
187     Requires: ruby(rubygems) >= %{rubygems_version}
188    
189 pterjan 435211 %define io_console_ver 0.4.2
190 fwang 291590 %package io-console
191     Summary: IO/Console is a simple console utilizing library
192     Group: Development/Ruby
193 pterjan 435211 Version: %{io_console_ver}
194 fwang 291590 Requires: ruby(abi) = %{subver}
195     Requires: ruby(rubygems) >= %{rubygems_version}
196    
197 pterjan 435211 %define psych_ver 2.0.0
198     %package psych
199     Summary: A libyaml wrapper for Ruby
200     Version: %{psych_ver}
201     Group: Development/Ruby
202     License: MIT
203     Requires: ruby(abi) = %{subver}
204     Requires: ruby(rubygems) >= %{rubygems_version}
205     Conflicts: ruby < 2.0.0
206    
207     %define test_unit_ver 2.0.0
208     %package test-unit
209     Summary: test/unit compatible API testing framework
210     Version: %{psych_ver}
211     Group: Development/Ruby
212     License: MIT
213     Requires: ruby(abi) = %{subver}
214     Requires: ruby(rubygems) >= %{rubygems_version}
215     Conflicts: ruby < 2.0.0
216     BuildArch: noarch
217    
218 blino 1152 %description
219     Ruby is the interpreted scripting language for quick and
220     easy object-oriented programming. It has many features to
221     process text files and to do system management tasks (as in
222     Perl). It is simple, straight-forward, and extensible.
223    
224     %description doc
225     Ruby is the interpreted scripting language for quick and
226     easy object-oriented programming. It has many features to
227     process text files and to do system management tasks (as in
228     Perl). It is simple, straight-forward, and extensible.
229    
230     This package contains the Ruby's documentation
231    
232 fwang 291590 %description -n %{libname}
233     This package includes the libruby, necessary to run Ruby.
234    
235 blino 1152 %description devel
236     Ruby is the interpreted scripting language for quick and
237     easy object-oriented programming. It has many features to
238     process text files and to do system management tasks (as in
239     Perl). It is simple, straight-forward, and extensible.
240    
241     This package contains the Ruby's devel files.
242    
243     %description tk
244     Ruby is the interpreted scripting language for quick and
245     easy object-oriented programming. It has many features to
246     process text files and to do system management tasks (as in
247     Perl). It is simple, straight-forward, and extensible.
248    
249     This package contains the Tk extension for Ruby.
250    
251 fwang 291551 %description RubyGems
252     RubyGems is the Ruby standard for publishing and managing third party
253     libraries.
254    
255 fwang 291552 %description rake
256     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
257     specified in standard Ruby syntax.
258    
259 fwang 291562 %description rdoc
260     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
261     includes the 'rdoc' and 'ri' tools for generating and displaying online
262     documentation.
263    
264     %description json
265     This is a implementation of the JSON specification according to RFC 4627.
266     You can think of it as a low fat alternative to XML, if you want to store
267     data to disk or transmit it over a network rather than use a verbose
268     markup language.
269    
270     %description minitest
271     minitest/unit is a small and incredibly fast unit testing framework.
272    
273     minitest/spec is a functionally complete spec engine.
274    
275     minitest/benchmark is an awesome way to assert the performance of your
276     algorithms in a repeatable manner.
277    
278     minitest/mock by Steven Baker, is a beautifully tiny mock object
279     framework.
280    
281     minitest/pride shows pride in testing and adds coloring to your test
282     output.
283    
284 fwang 291590 %description irb
285     The irb is acronym for Interactive Ruby. It evaluates ruby expression
286     from the terminal.
287    
288     %description bigdecimal
289     Ruby provides built-in support for arbitrary precision integer arithmetic.
290     For example:
291    
292     42**13 -> 1265437718438866624512
293    
294     BigDecimal provides similar support for very large or very accurate floating
295     point numbers. Decimal arithmetic is also useful for general calculation,
296     because it provides the correct answers people expect–whereas normal binary
297     floating point arithmetic often introduces subtle errors because of the
298     conversion between base 10 and base 2.
299    
300     %description io-console
301     IO/Console provides very simple and portable access to console. It doesn't
302     provide higher layer features, such like curses and readline.
303    
304 pterjan 435211 %description psych
305     Psych is a YAML parser and emitter. Psych leverages
306     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
307     capabilities. In addition to wrapping libyaml, Psych also knows how to
308     serialize and de-serialize most Ruby objects to and from the YAML format.
309    
310     %description test-unit
311     This library implements test/unit compatible API on minitest.
312     The test/unit means that test/unit which was bundled with Ruby 1.8.
313    
314 blino 1152 %prep
315     %setup -q -n ruby-%{rubyver}-%{patchversion}
316 fwang 290007 %apply_patches
317 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
318     rm lib/mkmf.rb.0*
319 blino 1152
320     %build
321 fwang 290038 autoconf
322 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
323 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
324 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
325 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
326 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
327     --with-sitearchdir='%{ruby_sitearchdir}' \
328     --with-vendordir='%{ruby_vendorlibdir}' \
329     --with-vendorarchdir='%{ruby_vendorarchdir}' \
330 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
331 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
332     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
333     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
334     --with-rubygemsdir='%{rubygems_dir}' \
335     --with-ruby-pc='%{name}.pc' \
336     --enable-multiarch \
337     --with-ruby-version=''
338 blino 1152 %make
339    
340     %install
341     %makeinstall_std install-doc
342    
343     install -d %buildroot%{_datadir}/emacs/site-lisp
344     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
345    
346     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
347     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
348     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
349     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
350     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
351     EOF
352    
353     # Install the rpm macros
354     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
355     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
356 fwang 289961
357 pterjan 435211 # Install custom operating_system.rb
358     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
359     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
360    
361 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
362     %if !%build_gems
363 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
364 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
365 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
366     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
367 fwang 448873 rm -fr %{buildroot}%{rubygems_dir}/{gems,specifications}
368 fwang 311915 %if !%bootstrap
369 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
370 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
371     rm -fr %{buildroot}%{rubygems_dir}/rubygems
372 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
373     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
374 fwang 293412 %endif
375 fwang 311914 %endif
376 fwang 293412
377 blino 1152 %check
378     make test
379    
380 fwang 289961 %files
381 fwang 291551 %{_bindir}/erb
382     %{_bindir}/ruby
383 fwang 291560 %dir %{ruby_libdir}
384     %{ruby_libdir}/*.rb
385 fwang 291590 %exclude %{ruby_libdir}/irb.rb
386 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
387     %exclude %{ruby_libdir}/remote-tk.rb
388     %exclude %{ruby_libdir}/tcltk.rb
389     %exclude %{ruby_libdir}/tk.rb
390     %exclude %{ruby_libdir}/tkafter.rb
391     %exclude %{ruby_libdir}/tkbgerror.rb
392     %exclude %{ruby_libdir}/tkcanvas.rb
393     %exclude %{ruby_libdir}/tkclass.rb
394     %exclude %{ruby_libdir}/tkconsole.rb
395     %exclude %{ruby_libdir}/tkdialog.rb
396     %exclude %{ruby_libdir}/tkentry.rb
397     %exclude %{ruby_libdir}/tkfont.rb
398     %exclude %{ruby_libdir}/tkmacpkg.rb
399     %exclude %{ruby_libdir}/tkmenubar.rb
400     %exclude %{ruby_libdir}/tkmngfocus.rb
401     %exclude %{ruby_libdir}/tkpalette.rb
402     %exclude %{ruby_libdir}/tkscrollbox.rb
403     %exclude %{ruby_libdir}/tktext.rb
404     %exclude %{ruby_libdir}/tkvirtevent.rb
405     %exclude %{ruby_libdir}/tkwinpkg.rb
406     %{ruby_libdir}/cgi
407     %{ruby_libdir}/date
408     %{ruby_libdir}/digest
409     %{ruby_libdir}/dl
410     %{ruby_libdir}/drb
411     %{ruby_libdir}/fiddle
412     %{ruby_libdir}/matrix
413     %{ruby_libdir}/net
414     %{ruby_libdir}/openssl
415     %{ruby_libdir}/optparse
416 pterjan 435566 %{ruby_libdir}/psych
417 fwang 291560 %{ruby_libdir}/racc
418     %{ruby_libdir}/rbconfig
419     %{ruby_libdir}/rexml
420     %{ruby_libdir}/rinda
421     %{ruby_libdir}/ripper
422     %{ruby_libdir}/rss
423     %{ruby_libdir}/shell
424 pterjan 435211 %{ruby_libdir}/syslog
425 fwang 291560 %{ruby_libdir}/uri
426     %{ruby_libdir}/webrick
427     %{ruby_libdir}/xmlrpc
428     %{ruby_libdir}/yaml
429     %dir %{ruby_libarchdir}
430     %{ruby_libarchdir}/continuation.so
431     %{ruby_libarchdir}/coverage.so
432     %{ruby_libarchdir}/curses.so
433     %{ruby_libarchdir}/date_core.so
434     %{ruby_libarchdir}/dbm.so
435     %dir %{ruby_libarchdir}/digest
436     %{ruby_libarchdir}/digest.so
437     %{ruby_libarchdir}/digest/*.so
438     %dir %{ruby_libarchdir}/dl
439     %{ruby_libarchdir}/dl.so
440     %{ruby_libarchdir}/dl/*.so
441     %dir %{ruby_libarchdir}/enc
442     %{ruby_libarchdir}/enc/*.so
443 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
444     %{ruby_libarchdir}/enc/trans/*.so
445 fwang 291560 %{ruby_libarchdir}/etc.so
446     %{ruby_libarchdir}/fcntl.so
447     %{ruby_libarchdir}/fiber.so
448     %{ruby_libarchdir}/fiddle.so
449     %{ruby_libarchdir}/gdbm.so
450     %dir %{ruby_libarchdir}/io
451     %{ruby_libarchdir}/io/nonblock.so
452     %{ruby_libarchdir}/io/wait.so
453     %dir %{ruby_libarchdir}/mathn
454 fwang 291562 %{ruby_libarchdir}/mathn/*.so
455 fwang 291560 %{ruby_libarchdir}/nkf.so
456     %{ruby_libarchdir}/objspace.so
457     %{ruby_libarchdir}/openssl.so
458 pterjan 435566 %{ruby_libarchdir}/psych.so
459 fwang 291560 %{ruby_libarchdir}/pathname.so
460     %{ruby_libarchdir}/pty.so
461     %dir %{ruby_libarchdir}/racc
462     %{ruby_libarchdir}/racc/*.so
463     %{ruby_libarchdir}/rbconfig.rb
464     %{ruby_libarchdir}/readline.so
465     %{ruby_libarchdir}/ripper.so
466     %{ruby_libarchdir}/sdbm.so
467     %{ruby_libarchdir}/socket.so
468     %{ruby_libarchdir}/stringio.so
469     %{ruby_libarchdir}/strscan.so
470     %{ruby_libarchdir}/syslog.so
471     %{ruby_libarchdir}/zlib.so
472 fwang 291551 %{_mandir}/man1/erb.1.*
473     %{_mandir}/man1/ruby.1.*
474 blino 1152 %{_datadir}/emacs/site-lisp/*
475     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
476     %{_sysconfdir}/rpm/macros.d/%{name}.macros
477 fwang 291560 %{_datadir}/ruby/site_ruby
478     %{_libdir}/ruby/site_ruby
479     %{_datadir}/ruby/vendor_ruby
480     %{_libdir}/ruby/vendor_ruby
481 fwang 311914 %if %bootstrap
482     %{_bindir}/gem
483 fwang 448831 %dir %{rubygems_dir}
484     %{rubygems_dir}/rbconfig
485     %{rubygems_dir}/rubygems
486     %{rubygems_dir}/rubygems.rb
487     %{rubygems_dir}/ubygems.rb
488 fwang 311914 %endif
489 blino 1152
490     %files doc
491     %{_datadir}/ri
492 pterjan 435211 %{_datadir}/doc/ruby
493 blino 1152
494 fwang 291590 %files -n %{libname}
495     %{_libdir}/libruby.so.%{subver}
496     %{_libdir}/libruby.so.%{rubyapi}
497    
498 blino 1152 %files devel
499 fwang 290003 %{_includedir}/*
500 blino 1152 %{_libdir}/libruby-static.a
501     %{_libdir}/libruby.so
502 fwang 290003 %{_libdir}/pkgconfig/*.pc
503 blino 1152
504     %files tk
505 fwang 291560 %{ruby_libarchdir}/tcltklib.so
506     %{ruby_libarchdir}/tkutil.so
507     %{ruby_libdir}/multi-tk.rb
508     %{ruby_libdir}/remote-tk.rb
509     %{ruby_libdir}/tcltk.rb
510     %{ruby_libdir}/tk.rb
511     %{ruby_libdir}/tkafter.rb
512     %{ruby_libdir}/tkbgerror.rb
513     %{ruby_libdir}/tkcanvas.rb
514     %{ruby_libdir}/tkclass.rb
515     %{ruby_libdir}/tkconsole.rb
516     %{ruby_libdir}/tkdialog.rb
517     %{ruby_libdir}/tkentry.rb
518     %{ruby_libdir}/tkfont.rb
519     %{ruby_libdir}/tkmacpkg.rb
520     %{ruby_libdir}/tkmenubar.rb
521     %{ruby_libdir}/tkmngfocus.rb
522     %{ruby_libdir}/tkpalette.rb
523     %{ruby_libdir}/tkscrollbox.rb
524     %{ruby_libdir}/tktext.rb
525     %{ruby_libdir}/tkvirtevent.rb
526     %{ruby_libdir}/tkwinpkg.rb
527     %{ruby_libdir}/tk
528     %{ruby_libdir}/tkextlib
529 fwang 291551
530 fwang 293412 %files irb
531     %{_bindir}/irb
532     %{ruby_libdir}/irb.rb
533     %{ruby_libdir}/irb
534     %{_mandir}/man1/irb.1*
535    
536     %if %build_gems
537 fwang 291551 %files RubyGems
538     %{_bindir}/gem
539     %dir %{rubygems_dir}
540     %{rubygems_dir}/rbconfig
541     %{rubygems_dir}/rubygems
542     %{rubygems_dir}/rubygems.rb
543     %{rubygems_dir}/ubygems.rb
544    
545 fwang 291562 %files minitest
546     %{ruby_libdir}/minitest
547 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
548 fwang 291562
549 fwang 291551 %files rake
550     %{_bindir}/rake
551     %{_mandir}/man1/rake.1.*
552 fwang 291562 %{ruby_libdir}/rake
553 pterjan 435211 %{rubygems_dir}/gems/rake-*
554     %{rubygems_dir}/specifications/default/rake-*.gemspec
555 fwang 291562
556     %files rdoc
557     %{_bindir}/rdoc
558     %{_bindir}/ri
559     %{ruby_libdir}/rdoc
560 pterjan 435211 %{rubygems_dir}/gems/rdoc-*
561     %{rubygems_dir}/specifications/default/rdoc-*.gemspec
562 fwang 291562 %{_mandir}/man1/ri.1.*
563    
564     %files json
565     %dir %{ruby_libarchdir}/json
566     %dir %{ruby_libarchdir}/json/ext
567     %{ruby_libarchdir}/json/ext/*.so
568     %{ruby_libdir}/json
569 pterjan 435211 %{rubygems_dir}/specifications/default/json-*.gemspec
570 fwang 291590
571     %files bigdecimal
572     %{ruby_libdir}/bigdecimal
573     %{ruby_libarchdir}/bigdecimal.so
574 pterjan 435211 %{rubygems_dir}/specifications/default/bigdecimal-*.gemspec
575 fwang 291590
576     %files io-console
577     %{ruby_libdir}/io
578     %{ruby_libarchdir}/io/console.so
579 pterjan 435211 %{rubygems_dir}/specifications/default/io-console-*.gemspec
580    
581     %files psych
582     %{ruby_libdir}/psych
583     %{ruby_libarchdir}/psych.so
584     %{rubygems_dir}/specifications/default/psych-*.gemspec
585    
586     %files test-unit
587     %{_bindir}/testrb
588     %{ruby_libdir}/test
589     %{rubygems_dir}/gems/test-unit-*
590     %{rubygems_dir}/specifications/default/test-unit-*.gemspec
591 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30