/[packages]/updates/5/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/5/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 481734 - (hide annotations) (download)
Fri Sep 20 10:59:16 2013 UTC (10 years, 6 months ago) by pterjan
Original Path: cauldron/ruby/current/SPECS/ruby.spec
File size: 17664 byte(s)
SILENT Fix mess from bad move, step 2
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4 fwang 447652 %define patchversion p247
5 fwang 468908 %define rel 4
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21     # The RubyGems library has to stay out of Ruby directory three, since the
22     # RubyGems should be share by all Ruby implementations.
23 fwang 311714 %define rubygems_dir %{_datadir}/ruby/gems
24 pterjan 435211 %define rubygems_version 2.0.2
25 fwang 290007
26 fwang 468908 %define bootstrap 0
27 fwang 468812 %define build_gems 0
28 fwang 292558
29 blino 1152 Summary: Object Oriented Script Language
30     Name: ruby
31     Version: %{rubyver}.%{patchversion}
32     Release: %mkrel %rel
33 kamil 397518 License: Ruby or BSD
34 blino 1152 Group: Development/Ruby
35     BuildRequires: autoconf
36     BuildRequires: byacc
37 shlomif 291698 BuildRequires: doxygen
38 blino 1152 BuildRequires: ncurses-devel
39     BuildRequires: readline-devel
40     BuildRequires: tcl-devel tk-devel
41 fwang 276350 BuildRequires: db-devel
42 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
43 blino 1152 BuildRequires: openssl-devel
44     BuildRequires: zlib-devel
45 fwang 289987 BuildRequires: libffi-devel
46     BuildRequires: yaml-devel
47 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
48 blino 1152 Obsoletes: ruby-rexml
49     Provides: ruby-rexml
50 pterjan 435566 # Couldn't get the standalone gem to work
51     Provides: rubygem(psych)
52 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
53     Provides: /usr/bin/ruby
54 fwang 293445 Provides: ruby(abi) = %rubyapi
55 fwang 463762 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
56 pterjan 435211 Source1: operating_system.rb
57 blino 1152 Source3: ruby.macros
58     URL: http://www.ruby-lang.org/
59 fwang 292558 %if !%bootstrap
60     Requires: rubygems >= %{rubygems_version}
61 fwang 293395 BuildRequires: ruby
62 fwang 292558 %endif
63 blino 1152
64 fwang 290007 # == FEDORA PATCHES BEGINS ==
65 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
66     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
67     # Fixes random WEBRick test failures.
68     # https://bugs.ruby-lang.org/issues/6573.
69     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
70 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
71     # http://redmine.ruby-lang.org/issues/5617
72     Patch8: ruby-1.9.3-custom-rubygems-location.patch
73     # Add support for installing binary extensions according to FHS.
74     # https://github.com/rubygems/rubygems/issues/210
75 pterjan 435211 # Note that 8th patch might be resolved by
76     # https://bugs.ruby-lang.org/issues/7897
77     Patch9: rubygems-2.0.0-binary-extensions.patch
78     # Make mkmf verbose by default
79     Patch12: ruby-1.9.3-mkmf-verbose.patch
80     # This slightly changes behavior of "gem install --install-dir" behavior.
81     # Without this patch, Specifications.dirs is modified and gems installed on
82     # the system cannot be required anymore. This causes later issues when RDoc
83     # documentation should be generated, since json gem is sudenly not accessible.
84     # https://github.com/rubygems/rubygems/pull/452
85     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
86     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
87     # https://github.com/rubygems/rubygems/pull/455
88     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
89 fwang 290007 # == FEDORA PATCHES ENDS ==
90    
91 fwang 291591 %package -n %{libname}
92 fwang 291590 Summary: Libraries necessary to run Ruby
93     Group: Development/Ruby
94    
95 blino 1152 %package doc
96     Summary: Documentation for the powerful language Ruby
97     Group: Development/Ruby
98 fwang 202696 BuildArch: noarch
99 blino 1152
100     %package devel
101     Summary: Development file for the powerful language Ruby
102     Group: Development/Ruby
103 fwang 311925 Requires: %{name} = %{version}
104     Requires: %{libname} = %{version}
105 blino 1152
106     %package tk
107     Summary: Tk extension for the powerful language Ruby
108     Group: Development/Ruby
109 fwang 311925 Requires: %{name} = %{version}
110 blino 1152
111 fwang 291551 %package RubyGems
112     Summary: The Ruby standard for packaging ruby libraries
113     Group: Development/Ruby
114 fwang 291590 Version: %{rubygems_version}
115 fwang 291551 Requires: ruby(abi) = %{subver}
116 fwang 291590 Provides: gem = %{rubygems_version}
117     Provides: rubygems = %{rubygems_version}
118     Provides: ruby(rubygems) = %{rubygems_version}
119 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
120 fwang 291561 BuildArch: noarch
121 fwang 291551
122 pterjan 435211 %define rake_ver 0.9.6
123 fwang 291551 %package rake
124     Summary: Simple ruby build program with capabilities similar to make
125     Group: Development/Ruby
126 shlomif 291767 Version: %{rake_ver}
127 fwang 291551 Requires: ruby(abi) = %{subver}
128 fwang 291561 BuildArch: noarch
129 fwang 291551
130 pterjan 435211 %define minitest_ver 4.3.2
131 fwang 291562 %package minitest
132 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
133 fwang 291562 Group: Development/Ruby
134 shlomif 291767 Version: %{minitest_ver}
135 fwang 291562 License: MIT
136 fwang 291590 Requires: ruby(abi) = %{subver}
137     Requires: ruby(rubygems) >= %{rubygems_version}
138 fwang 291562 BuildArch: noarch
139    
140 pterjan 435211 %define json_ver 1.7.7
141 fwang 291562 %package json
142     Summary: This is a JSON implementation as a Ruby extension in C
143     Group: Development/Ruby
144 shlomif 291767 Version: %{json_ver}
145 fwang 291562 License: Ruby or GPLv2
146 fwang 291590 Requires: ruby(abi) = %{subver}
147     Requires: ruby(rubygems) >= %{rubygems_version}
148 fwang 291562
149 pterjan 435211 %define rdoc_ver 4.0.0
150 fwang 291562 %package rdoc
151     Summary: A tool to generate HTML and command-line documentation for Ruby projects
152     Group: Development/Ruby
153 shlomif 291767 Version: %{rdoc_ver}
154 fwang 291562 License: GPLv2 and Ruby and MIT
155 fwang 291590 Requires: ruby(abi) = %{subver}
156     Requires: ruby(rubygems) >= %{rubygems_version}
157     Requires: ruby(irb) = %{version}
158 shlomif 291767 Provides: rdoc = %{rdoc_ver}
159     Provides: ri = %{rdoc_ver}
160 fwang 291562 BuildArch: noarch
161    
162 fwang 291590 %package irb
163     Summary: The Interactive Ruby
164     Group: Development/Ruby
165     Provides: irb = %{version}-%{release}
166     Provides: ruby(irb) = %{version}-%{release}
167 fwang 313459 Conflicts: ruby < 1.9
168 fwang 313460 BuildArch: noarch
169 fwang 291590
170 pterjan 435211 %define bigdecimal_ver 1.2.0
171 fwang 291590 %package bigdecimal
172     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
173     Group: Development/Ruby
174 pterjan 435211 Version: %{bigdecimal_ver}
175 fwang 291590 License: GPL+ or Artistic
176     Requires: ruby(abi) = %{subver}
177     Requires: ruby(rubygems) >= %{rubygems_version}
178    
179 pterjan 435211 %define io_console_ver 0.4.2
180 fwang 291590 %package io-console
181     Summary: IO/Console is a simple console utilizing library
182     Group: Development/Ruby
183 pterjan 435211 Version: %{io_console_ver}
184 fwang 291590 Requires: ruby(abi) = %{subver}
185     Requires: ruby(rubygems) >= %{rubygems_version}
186    
187 pterjan 435211 %define psych_ver 2.0.0
188     %package psych
189     Summary: A libyaml wrapper for Ruby
190     Version: %{psych_ver}
191     Group: Development/Ruby
192     License: MIT
193     Requires: ruby(abi) = %{subver}
194     Requires: ruby(rubygems) >= %{rubygems_version}
195     Conflicts: ruby < 2.0.0
196    
197     %define test_unit_ver 2.0.0
198     %package test-unit
199     Summary: test/unit compatible API testing framework
200     Version: %{psych_ver}
201     Group: Development/Ruby
202     License: MIT
203     Requires: ruby(abi) = %{subver}
204     Requires: ruby(rubygems) >= %{rubygems_version}
205     Conflicts: ruby < 2.0.0
206     BuildArch: noarch
207    
208 blino 1152 %description
209     Ruby is the interpreted scripting language for quick and
210     easy object-oriented programming. It has many features to
211     process text files and to do system management tasks (as in
212     Perl). It is simple, straight-forward, and extensible.
213    
214     %description doc
215     Ruby is the interpreted scripting language for quick and
216     easy object-oriented programming. It has many features to
217     process text files and to do system management tasks (as in
218     Perl). It is simple, straight-forward, and extensible.
219    
220     This package contains the Ruby's documentation
221    
222 fwang 291590 %description -n %{libname}
223     This package includes the libruby, necessary to run Ruby.
224    
225 blino 1152 %description devel
226     Ruby is the interpreted scripting language for quick and
227     easy object-oriented programming. It has many features to
228     process text files and to do system management tasks (as in
229     Perl). It is simple, straight-forward, and extensible.
230    
231     This package contains the Ruby's devel files.
232    
233     %description tk
234     Ruby is the interpreted scripting language for quick and
235     easy object-oriented programming. It has many features to
236     process text files and to do system management tasks (as in
237     Perl). It is simple, straight-forward, and extensible.
238    
239     This package contains the Tk extension for Ruby.
240    
241 fwang 291551 %description RubyGems
242     RubyGems is the Ruby standard for publishing and managing third party
243     libraries.
244    
245 fwang 291552 %description rake
246     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
247     specified in standard Ruby syntax.
248    
249 fwang 291562 %description rdoc
250     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
251     includes the 'rdoc' and 'ri' tools for generating and displaying online
252     documentation.
253    
254     %description json
255     This is a implementation of the JSON specification according to RFC 4627.
256     You can think of it as a low fat alternative to XML, if you want to store
257     data to disk or transmit it over a network rather than use a verbose
258     markup language.
259    
260     %description minitest
261     minitest/unit is a small and incredibly fast unit testing framework.
262    
263     minitest/spec is a functionally complete spec engine.
264    
265     minitest/benchmark is an awesome way to assert the performance of your
266     algorithms in a repeatable manner.
267    
268     minitest/mock by Steven Baker, is a beautifully tiny mock object
269     framework.
270    
271     minitest/pride shows pride in testing and adds coloring to your test
272     output.
273    
274 fwang 291590 %description irb
275     The irb is acronym for Interactive Ruby. It evaluates ruby expression
276     from the terminal.
277    
278     %description bigdecimal
279     Ruby provides built-in support for arbitrary precision integer arithmetic.
280     For example:
281    
282     42**13 -> 1265437718438866624512
283    
284     BigDecimal provides similar support for very large or very accurate floating
285     point numbers. Decimal arithmetic is also useful for general calculation,
286     because it provides the correct answers people expect–whereas normal binary
287     floating point arithmetic often introduces subtle errors because of the
288     conversion between base 10 and base 2.
289    
290     %description io-console
291     IO/Console provides very simple and portable access to console. It doesn't
292     provide higher layer features, such like curses and readline.
293    
294 pterjan 435211 %description psych
295     Psych is a YAML parser and emitter. Psych leverages
296     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
297     capabilities. In addition to wrapping libyaml, Psych also knows how to
298     serialize and de-serialize most Ruby objects to and from the YAML format.
299    
300     %description test-unit
301     This library implements test/unit compatible API on minitest.
302     The test/unit means that test/unit which was bundled with Ruby 1.8.
303    
304 blino 1152 %prep
305     %setup -q -n ruby-%{rubyver}-%{patchversion}
306 fwang 290007 %apply_patches
307 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
308     rm lib/mkmf.rb.0*
309 blino 1152
310     %build
311 fwang 290038 autoconf
312 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
313 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
314 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
315 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
316 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
317     --with-sitearchdir='%{ruby_sitearchdir}' \
318     --with-vendordir='%{ruby_vendorlibdir}' \
319     --with-vendorarchdir='%{ruby_vendorarchdir}' \
320 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
321 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
322     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
323     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
324     --with-rubygemsdir='%{rubygems_dir}' \
325     --with-ruby-pc='%{name}.pc' \
326     --enable-multiarch \
327     --with-ruby-version=''
328 blino 1152 %make
329    
330     %install
331     %makeinstall_std install-doc
332    
333     install -d %buildroot%{_datadir}/emacs/site-lisp
334     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
335    
336     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
337     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
338     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
339     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
340     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
341     EOF
342    
343     # Install the rpm macros
344     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
345     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
346 fwang 289961
347 pterjan 435211 # Install custom operating_system.rb
348     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
349     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
350    
351 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
352     %if !%build_gems
353 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
354 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
355 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
356     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
357 fwang 448873 rm -fr %{buildroot}%{rubygems_dir}/{gems,specifications}
358 fwang 311915 %if !%bootstrap
359 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
360 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
361     rm -fr %{buildroot}%{rubygems_dir}/rubygems
362 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
363     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
364 fwang 293412 %endif
365 fwang 311914 %endif
366 fwang 293412
367 blino 1152 %check
368     make test
369    
370 fwang 289961 %files
371 fwang 291551 %{_bindir}/erb
372     %{_bindir}/ruby
373 fwang 291560 %dir %{ruby_libdir}
374     %{ruby_libdir}/*.rb
375 fwang 291590 %exclude %{ruby_libdir}/irb.rb
376 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
377     %exclude %{ruby_libdir}/remote-tk.rb
378     %exclude %{ruby_libdir}/tcltk.rb
379     %exclude %{ruby_libdir}/tk.rb
380     %exclude %{ruby_libdir}/tkafter.rb
381     %exclude %{ruby_libdir}/tkbgerror.rb
382     %exclude %{ruby_libdir}/tkcanvas.rb
383     %exclude %{ruby_libdir}/tkclass.rb
384     %exclude %{ruby_libdir}/tkconsole.rb
385     %exclude %{ruby_libdir}/tkdialog.rb
386     %exclude %{ruby_libdir}/tkentry.rb
387     %exclude %{ruby_libdir}/tkfont.rb
388     %exclude %{ruby_libdir}/tkmacpkg.rb
389     %exclude %{ruby_libdir}/tkmenubar.rb
390     %exclude %{ruby_libdir}/tkmngfocus.rb
391     %exclude %{ruby_libdir}/tkpalette.rb
392     %exclude %{ruby_libdir}/tkscrollbox.rb
393     %exclude %{ruby_libdir}/tktext.rb
394     %exclude %{ruby_libdir}/tkvirtevent.rb
395     %exclude %{ruby_libdir}/tkwinpkg.rb
396     %{ruby_libdir}/cgi
397     %{ruby_libdir}/date
398     %{ruby_libdir}/digest
399     %{ruby_libdir}/dl
400     %{ruby_libdir}/drb
401     %{ruby_libdir}/fiddle
402     %{ruby_libdir}/matrix
403     %{ruby_libdir}/net
404     %{ruby_libdir}/openssl
405     %{ruby_libdir}/optparse
406 pterjan 435566 %{ruby_libdir}/psych
407 fwang 291560 %{ruby_libdir}/racc
408     %{ruby_libdir}/rbconfig
409     %{ruby_libdir}/rexml
410     %{ruby_libdir}/rinda
411     %{ruby_libdir}/ripper
412     %{ruby_libdir}/rss
413     %{ruby_libdir}/shell
414 pterjan 435211 %{ruby_libdir}/syslog
415 fwang 291560 %{ruby_libdir}/uri
416     %{ruby_libdir}/webrick
417     %{ruby_libdir}/xmlrpc
418     %{ruby_libdir}/yaml
419     %dir %{ruby_libarchdir}
420     %{ruby_libarchdir}/continuation.so
421     %{ruby_libarchdir}/coverage.so
422     %{ruby_libarchdir}/curses.so
423     %{ruby_libarchdir}/date_core.so
424     %{ruby_libarchdir}/dbm.so
425     %dir %{ruby_libarchdir}/digest
426     %{ruby_libarchdir}/digest.so
427     %{ruby_libarchdir}/digest/*.so
428     %dir %{ruby_libarchdir}/dl
429     %{ruby_libarchdir}/dl.so
430     %{ruby_libarchdir}/dl/*.so
431     %dir %{ruby_libarchdir}/enc
432     %{ruby_libarchdir}/enc/*.so
433 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
434     %{ruby_libarchdir}/enc/trans/*.so
435 fwang 291560 %{ruby_libarchdir}/etc.so
436     %{ruby_libarchdir}/fcntl.so
437     %{ruby_libarchdir}/fiber.so
438     %{ruby_libarchdir}/fiddle.so
439     %{ruby_libarchdir}/gdbm.so
440     %dir %{ruby_libarchdir}/io
441     %{ruby_libarchdir}/io/nonblock.so
442     %{ruby_libarchdir}/io/wait.so
443     %dir %{ruby_libarchdir}/mathn
444 fwang 291562 %{ruby_libarchdir}/mathn/*.so
445 fwang 291560 %{ruby_libarchdir}/nkf.so
446     %{ruby_libarchdir}/objspace.so
447     %{ruby_libarchdir}/openssl.so
448 pterjan 435566 %{ruby_libarchdir}/psych.so
449 fwang 291560 %{ruby_libarchdir}/pathname.so
450     %{ruby_libarchdir}/pty.so
451     %dir %{ruby_libarchdir}/racc
452     %{ruby_libarchdir}/racc/*.so
453     %{ruby_libarchdir}/rbconfig.rb
454     %{ruby_libarchdir}/readline.so
455     %{ruby_libarchdir}/ripper.so
456     %{ruby_libarchdir}/sdbm.so
457     %{ruby_libarchdir}/socket.so
458     %{ruby_libarchdir}/stringio.so
459     %{ruby_libarchdir}/strscan.so
460     %{ruby_libarchdir}/syslog.so
461     %{ruby_libarchdir}/zlib.so
462 fwang 291551 %{_mandir}/man1/erb.1.*
463     %{_mandir}/man1/ruby.1.*
464 blino 1152 %{_datadir}/emacs/site-lisp/*
465     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
466     %{_sysconfdir}/rpm/macros.d/%{name}.macros
467 fwang 291560 %{_datadir}/ruby/site_ruby
468     %{_libdir}/ruby/site_ruby
469     %{_datadir}/ruby/vendor_ruby
470     %{_libdir}/ruby/vendor_ruby
471 fwang 311914 %if %bootstrap
472     %{_bindir}/gem
473 fwang 448831 %dir %{rubygems_dir}
474     %{rubygems_dir}/rbconfig
475     %{rubygems_dir}/rubygems
476     %{rubygems_dir}/rubygems.rb
477     %{rubygems_dir}/ubygems.rb
478 fwang 311914 %endif
479 blino 1152
480     %files doc
481     %{_datadir}/ri
482 pterjan 435211 %{_datadir}/doc/ruby
483 blino 1152
484 fwang 291590 %files -n %{libname}
485     %{_libdir}/libruby.so.%{subver}
486     %{_libdir}/libruby.so.%{rubyapi}
487    
488 blino 1152 %files devel
489 fwang 290003 %{_includedir}/*
490 blino 1152 %{_libdir}/libruby-static.a
491     %{_libdir}/libruby.so
492 fwang 290003 %{_libdir}/pkgconfig/*.pc
493 blino 1152
494     %files tk
495 fwang 291560 %{ruby_libarchdir}/tcltklib.so
496     %{ruby_libarchdir}/tkutil.so
497     %{ruby_libdir}/multi-tk.rb
498     %{ruby_libdir}/remote-tk.rb
499     %{ruby_libdir}/tcltk.rb
500     %{ruby_libdir}/tk.rb
501     %{ruby_libdir}/tkafter.rb
502     %{ruby_libdir}/tkbgerror.rb
503     %{ruby_libdir}/tkcanvas.rb
504     %{ruby_libdir}/tkclass.rb
505     %{ruby_libdir}/tkconsole.rb
506     %{ruby_libdir}/tkdialog.rb
507     %{ruby_libdir}/tkentry.rb
508     %{ruby_libdir}/tkfont.rb
509     %{ruby_libdir}/tkmacpkg.rb
510     %{ruby_libdir}/tkmenubar.rb
511     %{ruby_libdir}/tkmngfocus.rb
512     %{ruby_libdir}/tkpalette.rb
513     %{ruby_libdir}/tkscrollbox.rb
514     %{ruby_libdir}/tktext.rb
515     %{ruby_libdir}/tkvirtevent.rb
516     %{ruby_libdir}/tkwinpkg.rb
517     %{ruby_libdir}/tk
518     %{ruby_libdir}/tkextlib
519 fwang 291551
520 fwang 293412 %files irb
521     %{_bindir}/irb
522     %{ruby_libdir}/irb.rb
523     %{ruby_libdir}/irb
524     %{_mandir}/man1/irb.1*
525    
526     %if %build_gems
527 fwang 291551 %files RubyGems
528     %{_bindir}/gem
529     %dir %{rubygems_dir}
530     %{rubygems_dir}/rbconfig
531     %{rubygems_dir}/rubygems
532     %{rubygems_dir}/rubygems.rb
533     %{rubygems_dir}/ubygems.rb
534    
535 fwang 291562 %files minitest
536     %{ruby_libdir}/minitest
537 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
538 fwang 291562
539 fwang 291551 %files rake
540     %{_bindir}/rake
541     %{_mandir}/man1/rake.1.*
542 fwang 291562 %{ruby_libdir}/rake
543 pterjan 435211 %{rubygems_dir}/gems/rake-*
544     %{rubygems_dir}/specifications/default/rake-*.gemspec
545 fwang 291562
546     %files rdoc
547     %{_bindir}/rdoc
548     %{_bindir}/ri
549     %{ruby_libdir}/rdoc
550 pterjan 435211 %{rubygems_dir}/gems/rdoc-*
551     %{rubygems_dir}/specifications/default/rdoc-*.gemspec
552 fwang 291562 %{_mandir}/man1/ri.1.*
553    
554     %files json
555     %dir %{ruby_libarchdir}/json
556     %dir %{ruby_libarchdir}/json/ext
557     %{ruby_libarchdir}/json/ext/*.so
558     %{ruby_libdir}/json
559 pterjan 435211 %{rubygems_dir}/specifications/default/json-*.gemspec
560 fwang 291590
561     %files bigdecimal
562     %{ruby_libdir}/bigdecimal
563     %{ruby_libarchdir}/bigdecimal.so
564 pterjan 435211 %{rubygems_dir}/specifications/default/bigdecimal-*.gemspec
565 fwang 291590
566     %files io-console
567     %{ruby_libdir}/io
568     %{ruby_libarchdir}/io/console.so
569 pterjan 435211 %{rubygems_dir}/specifications/default/io-console-*.gemspec
570    
571     %files psych
572     %{ruby_libdir}/psych
573     %{ruby_libarchdir}/psych.so
574     %{rubygems_dir}/specifications/default/psych-*.gemspec
575    
576     %files test-unit
577     %{_bindir}/testrb
578     %{ruby_libdir}/test
579     %{rubygems_dir}/gems/test-unit-*
580     %{rubygems_dir}/specifications/default/test-unit-*.gemspec
581 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30