/[packages]/updates/5/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/5/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 601635 - (hide annotations) (download)
Mon Mar 10 01:06:43 2014 UTC (10 years, 1 month ago) by pterjan
Original Path: cauldron/ruby/current/SPECS/ruby.spec
File size: 18077 byte(s)
Add upstream patch to fix build with new readline
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4 pterjan 601593 %define patchversion p451
5     %define rel 1
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
22     # RubyGems should be shared by all Ruby implementations.
23 pterjan 560984 %define rubygems_dir %{_datadir}/rubygems
24 pterjan 560987 %define gems_dir %{_datadir}/ruby/gems
25 pterjan 435211 %define rubygems_version 2.0.2
26 fwang 290007
27 fwang 468908 %define bootstrap 0
28 fwang 468812 %define build_gems 0
29 fwang 292558
30 blino 1152 Summary: Object Oriented Script Language
31     Name: ruby
32     Version: %{rubyver}.%{patchversion}
33     Release: %mkrel %rel
34 kamil 397518 License: Ruby or BSD
35 blino 1152 Group: Development/Ruby
36     BuildRequires: autoconf
37     BuildRequires: byacc
38 shlomif 291698 BuildRequires: doxygen
39 blino 1152 BuildRequires: ncurses-devel
40     BuildRequires: readline-devel
41     BuildRequires: tcl-devel tk-devel
42 fwang 276350 BuildRequires: db-devel
43 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
44 blino 1152 BuildRequires: openssl-devel
45     BuildRequires: zlib-devel
46 fwang 289987 BuildRequires: libffi-devel
47     BuildRequires: yaml-devel
48 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
49 blino 1152 Obsoletes: ruby-rexml
50     Provides: ruby-rexml
51 pterjan 435566 # Couldn't get the standalone gem to work
52     Provides: rubygem(psych)
53 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
54     Provides: /usr/bin/ruby
55 fwang 293445 Provides: ruby(abi) = %rubyapi
56 fwang 463762 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
57 pterjan 435211 Source1: operating_system.rb
58 blino 1152 Source3: ruby.macros
59     URL: http://www.ruby-lang.org/
60 fwang 292558 %if !%bootstrap
61     Requires: rubygems >= %{rubygems_version}
62 fwang 293395 BuildRequires: ruby
63 fwang 292558 %endif
64 blino 1152
65 fwang 290007 # == FEDORA PATCHES BEGINS ==
66 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
67     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
68     # Fixes random WEBRick test failures.
69     # https://bugs.ruby-lang.org/issues/6573.
70     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
71 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
72     # http://redmine.ruby-lang.org/issues/5617
73     Patch8: ruby-1.9.3-custom-rubygems-location.patch
74     # Add support for installing binary extensions according to FHS.
75     # https://github.com/rubygems/rubygems/issues/210
76 pterjan 435211 # Note that 8th patch might be resolved by
77     # https://bugs.ruby-lang.org/issues/7897
78     Patch9: rubygems-2.0.0-binary-extensions.patch
79     # Make mkmf verbose by default
80     Patch12: ruby-1.9.3-mkmf-verbose.patch
81     # This slightly changes behavior of "gem install --install-dir" behavior.
82     # Without this patch, Specifications.dirs is modified and gems installed on
83     # the system cannot be required anymore. This causes later issues when RDoc
84     # documentation should be generated, since json gem is sudenly not accessible.
85     # https://github.com/rubygems/rubygems/pull/452
86     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
87     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
88     # https://github.com/rubygems/rubygems/pull/455
89     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
90 fwang 490240 # Fixes issues with DESTDIR.
91     # https://bugs.ruby-lang.org/issues/8115
92     Patch18: ruby-2.0.0-p247-Revert-mkmf.rb-prefix-install_dirs-only-with-DESTDIR.patch
93 fwang 290007 # == FEDORA PATCHES ENDS ==
94 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
95     # to install gems into user dir
96     Patch20: ruby-2.0.0-p451-Do-not-install-to-user-dir.patch
97 pterjan 601635 # Upstream patch to build with new readline
98     Patch21: ruby-2.0.0-p451-readline.patch
99 fwang 290007
100 fwang 291591 %package -n %{libname}
101 fwang 291590 Summary: Libraries necessary to run Ruby
102     Group: Development/Ruby
103    
104 blino 1152 %package doc
105     Summary: Documentation for the powerful language Ruby
106     Group: Development/Ruby
107 fwang 202696 BuildArch: noarch
108 blino 1152
109     %package devel
110     Summary: Development file for the powerful language Ruby
111     Group: Development/Ruby
112 fwang 311925 Requires: %{name} = %{version}
113     Requires: %{libname} = %{version}
114 blino 1152
115     %package tk
116     Summary: Tk extension for the powerful language Ruby
117     Group: Development/Ruby
118 fwang 311925 Requires: %{name} = %{version}
119 blino 1152
120 fwang 291551 %package RubyGems
121     Summary: The Ruby standard for packaging ruby libraries
122     Group: Development/Ruby
123 fwang 291590 Version: %{rubygems_version}
124 fwang 291551 Requires: ruby(abi) = %{subver}
125 fwang 291590 Provides: gem = %{rubygems_version}
126     Provides: rubygems = %{rubygems_version}
127     Provides: ruby(rubygems) = %{rubygems_version}
128 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
129 fwang 291561 BuildArch: noarch
130 fwang 291551
131 pterjan 435211 %define rake_ver 0.9.6
132 fwang 291551 %package rake
133     Summary: Simple ruby build program with capabilities similar to make
134     Group: Development/Ruby
135 shlomif 291767 Version: %{rake_ver}
136 fwang 291551 Requires: ruby(abi) = %{subver}
137 fwang 291561 BuildArch: noarch
138 fwang 291551
139 pterjan 435211 %define minitest_ver 4.3.2
140 fwang 291562 %package minitest
141 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
142 fwang 291562 Group: Development/Ruby
143 shlomif 291767 Version: %{minitest_ver}
144 fwang 291562 License: MIT
145 fwang 291590 Requires: ruby(abi) = %{subver}
146     Requires: ruby(rubygems) >= %{rubygems_version}
147 fwang 291562 BuildArch: noarch
148    
149 pterjan 435211 %define json_ver 1.7.7
150 fwang 291562 %package json
151     Summary: This is a JSON implementation as a Ruby extension in C
152     Group: Development/Ruby
153 shlomif 291767 Version: %{json_ver}
154 fwang 291562 License: Ruby or GPLv2
155 fwang 291590 Requires: ruby(abi) = %{subver}
156     Requires: ruby(rubygems) >= %{rubygems_version}
157 fwang 291562
158 pterjan 435211 %define rdoc_ver 4.0.0
159 fwang 291562 %package rdoc
160     Summary: A tool to generate HTML and command-line documentation for Ruby projects
161     Group: Development/Ruby
162 shlomif 291767 Version: %{rdoc_ver}
163 fwang 291562 License: GPLv2 and Ruby and MIT
164 fwang 291590 Requires: ruby(abi) = %{subver}
165     Requires: ruby(rubygems) >= %{rubygems_version}
166     Requires: ruby(irb) = %{version}
167 shlomif 291767 Provides: rdoc = %{rdoc_ver}
168     Provides: ri = %{rdoc_ver}
169 fwang 291562 BuildArch: noarch
170    
171 fwang 291590 %package irb
172     Summary: The Interactive Ruby
173     Group: Development/Ruby
174     Provides: irb = %{version}-%{release}
175     Provides: ruby(irb) = %{version}-%{release}
176 fwang 313459 Conflicts: ruby < 1.9
177 fwang 313460 BuildArch: noarch
178 fwang 291590
179 pterjan 435211 %define bigdecimal_ver 1.2.0
180 fwang 291590 %package bigdecimal
181     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
182     Group: Development/Ruby
183 pterjan 435211 Version: %{bigdecimal_ver}
184 fwang 291590 License: GPL+ or Artistic
185     Requires: ruby(abi) = %{subver}
186     Requires: ruby(rubygems) >= %{rubygems_version}
187    
188 pterjan 435211 %define io_console_ver 0.4.2
189 fwang 291590 %package io-console
190     Summary: IO/Console is a simple console utilizing library
191     Group: Development/Ruby
192 pterjan 435211 Version: %{io_console_ver}
193 fwang 291590 Requires: ruby(abi) = %{subver}
194     Requires: ruby(rubygems) >= %{rubygems_version}
195    
196 pterjan 435211 %define psych_ver 2.0.0
197     %package psych
198     Summary: A libyaml wrapper for Ruby
199     Version: %{psych_ver}
200     Group: Development/Ruby
201     License: MIT
202     Requires: ruby(abi) = %{subver}
203     Requires: ruby(rubygems) >= %{rubygems_version}
204     Conflicts: ruby < 2.0.0
205    
206     %define test_unit_ver 2.0.0
207     %package test-unit
208     Summary: test/unit compatible API testing framework
209     Version: %{psych_ver}
210     Group: Development/Ruby
211     License: MIT
212     Requires: ruby(abi) = %{subver}
213     Requires: ruby(rubygems) >= %{rubygems_version}
214     Conflicts: ruby < 2.0.0
215     BuildArch: noarch
216    
217 blino 1152 %description
218     Ruby is the interpreted scripting language for quick and
219     easy object-oriented programming. It has many features to
220     process text files and to do system management tasks (as in
221     Perl). It is simple, straight-forward, and extensible.
222    
223     %description doc
224     Ruby is the interpreted scripting language for quick and
225     easy object-oriented programming. It has many features to
226     process text files and to do system management tasks (as in
227     Perl). It is simple, straight-forward, and extensible.
228    
229     This package contains the Ruby's documentation
230    
231 fwang 291590 %description -n %{libname}
232     This package includes the libruby, necessary to run Ruby.
233    
234 blino 1152 %description devel
235     Ruby is the interpreted scripting language for quick and
236     easy object-oriented programming. It has many features to
237     process text files and to do system management tasks (as in
238     Perl). It is simple, straight-forward, and extensible.
239    
240     This package contains the Ruby's devel files.
241    
242     %description tk
243     Ruby is the interpreted scripting language for quick and
244     easy object-oriented programming. It has many features to
245     process text files and to do system management tasks (as in
246     Perl). It is simple, straight-forward, and extensible.
247    
248     This package contains the Tk extension for Ruby.
249    
250 fwang 291551 %description RubyGems
251     RubyGems is the Ruby standard for publishing and managing third party
252     libraries.
253    
254 fwang 291552 %description rake
255     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
256     specified in standard Ruby syntax.
257    
258 fwang 291562 %description rdoc
259     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
260     includes the 'rdoc' and 'ri' tools for generating and displaying online
261     documentation.
262    
263     %description json
264     This is a implementation of the JSON specification according to RFC 4627.
265     You can think of it as a low fat alternative to XML, if you want to store
266     data to disk or transmit it over a network rather than use a verbose
267     markup language.
268    
269     %description minitest
270     minitest/unit is a small and incredibly fast unit testing framework.
271    
272     minitest/spec is a functionally complete spec engine.
273    
274     minitest/benchmark is an awesome way to assert the performance of your
275     algorithms in a repeatable manner.
276    
277     minitest/mock by Steven Baker, is a beautifully tiny mock object
278     framework.
279    
280     minitest/pride shows pride in testing and adds coloring to your test
281     output.
282    
283 fwang 291590 %description irb
284     The irb is acronym for Interactive Ruby. It evaluates ruby expression
285     from the terminal.
286    
287     %description bigdecimal
288     Ruby provides built-in support for arbitrary precision integer arithmetic.
289     For example:
290    
291     42**13 -> 1265437718438866624512
292    
293     BigDecimal provides similar support for very large or very accurate floating
294     point numbers. Decimal arithmetic is also useful for general calculation,
295     because it provides the correct answers people expect–whereas normal binary
296     floating point arithmetic often introduces subtle errors because of the
297     conversion between base 10 and base 2.
298    
299     %description io-console
300     IO/Console provides very simple and portable access to console. It doesn't
301     provide higher layer features, such like curses and readline.
302    
303 pterjan 435211 %description psych
304     Psych is a YAML parser and emitter. Psych leverages
305     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
306     capabilities. In addition to wrapping libyaml, Psych also knows how to
307     serialize and de-serialize most Ruby objects to and from the YAML format.
308    
309     %description test-unit
310     This library implements test/unit compatible API on minitest.
311     The test/unit means that test/unit which was bundled with Ruby 1.8.
312    
313 blino 1152 %prep
314     %setup -q -n ruby-%{rubyver}-%{patchversion}
315 fwang 290007 %apply_patches
316 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
317     rm lib/mkmf.rb.0*
318 blino 1152
319     %build
320 fwang 290038 autoconf
321 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
322 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
323 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
324 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
325 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
326     --with-sitearchdir='%{ruby_sitearchdir}' \
327     --with-vendordir='%{ruby_vendorlibdir}' \
328     --with-vendorarchdir='%{ruby_vendorarchdir}' \
329 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
330 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
331     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
332     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
333     --with-rubygemsdir='%{rubygems_dir}' \
334     --with-ruby-pc='%{name}.pc' \
335     --enable-multiarch \
336     --with-ruby-version=''
337 blino 1152 %make
338    
339     %install
340     %makeinstall_std install-doc
341    
342     install -d %buildroot%{_datadir}/emacs/site-lisp
343     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
344    
345     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
346     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
347     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
348     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
349     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
350     EOF
351    
352     # Install the rpm macros
353     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
354     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
355 fwang 289961
356 pterjan 435211 # Install custom operating_system.rb
357     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
358     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
359    
360 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
361     %if !%build_gems
362 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
363 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
364 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
365     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
366 pterjan 560987 rm -fr %{buildroot}%{gems_dir}/{gems,specifications}
367 fwang 311915 %if !%bootstrap
368 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
369 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
370     rm -fr %{buildroot}%{rubygems_dir}/rubygems
371 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
372     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
373 fwang 293412 %endif
374 fwang 311914 %endif
375 fwang 293412
376 blino 1152 %check
377     make test
378    
379 fwang 289961 %files
380 fwang 291551 %{_bindir}/erb
381     %{_bindir}/ruby
382 fwang 291560 %dir %{ruby_libdir}
383     %{ruby_libdir}/*.rb
384 fwang 291590 %exclude %{ruby_libdir}/irb.rb
385 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
386     %exclude %{ruby_libdir}/remote-tk.rb
387     %exclude %{ruby_libdir}/tcltk.rb
388     %exclude %{ruby_libdir}/tk.rb
389     %exclude %{ruby_libdir}/tkafter.rb
390     %exclude %{ruby_libdir}/tkbgerror.rb
391     %exclude %{ruby_libdir}/tkcanvas.rb
392     %exclude %{ruby_libdir}/tkclass.rb
393     %exclude %{ruby_libdir}/tkconsole.rb
394     %exclude %{ruby_libdir}/tkdialog.rb
395     %exclude %{ruby_libdir}/tkentry.rb
396     %exclude %{ruby_libdir}/tkfont.rb
397     %exclude %{ruby_libdir}/tkmacpkg.rb
398     %exclude %{ruby_libdir}/tkmenubar.rb
399     %exclude %{ruby_libdir}/tkmngfocus.rb
400     %exclude %{ruby_libdir}/tkpalette.rb
401     %exclude %{ruby_libdir}/tkscrollbox.rb
402     %exclude %{ruby_libdir}/tktext.rb
403     %exclude %{ruby_libdir}/tkvirtevent.rb
404     %exclude %{ruby_libdir}/tkwinpkg.rb
405     %{ruby_libdir}/cgi
406     %{ruby_libdir}/date
407     %{ruby_libdir}/digest
408     %{ruby_libdir}/dl
409     %{ruby_libdir}/drb
410     %{ruby_libdir}/fiddle
411     %{ruby_libdir}/matrix
412     %{ruby_libdir}/net
413     %{ruby_libdir}/openssl
414     %{ruby_libdir}/optparse
415 pterjan 435566 %{ruby_libdir}/psych
416 fwang 291560 %{ruby_libdir}/racc
417     %{ruby_libdir}/rbconfig
418     %{ruby_libdir}/rexml
419     %{ruby_libdir}/rinda
420     %{ruby_libdir}/ripper
421     %{ruby_libdir}/rss
422     %{ruby_libdir}/shell
423 pterjan 435211 %{ruby_libdir}/syslog
424 fwang 291560 %{ruby_libdir}/uri
425     %{ruby_libdir}/webrick
426     %{ruby_libdir}/xmlrpc
427     %{ruby_libdir}/yaml
428     %dir %{ruby_libarchdir}
429     %{ruby_libarchdir}/continuation.so
430     %{ruby_libarchdir}/coverage.so
431     %{ruby_libarchdir}/curses.so
432     %{ruby_libarchdir}/date_core.so
433     %{ruby_libarchdir}/dbm.so
434     %dir %{ruby_libarchdir}/digest
435     %{ruby_libarchdir}/digest.so
436     %{ruby_libarchdir}/digest/*.so
437     %dir %{ruby_libarchdir}/dl
438     %{ruby_libarchdir}/dl.so
439     %{ruby_libarchdir}/dl/*.so
440     %dir %{ruby_libarchdir}/enc
441     %{ruby_libarchdir}/enc/*.so
442 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
443     %{ruby_libarchdir}/enc/trans/*.so
444 fwang 291560 %{ruby_libarchdir}/etc.so
445     %{ruby_libarchdir}/fcntl.so
446     %{ruby_libarchdir}/fiber.so
447     %{ruby_libarchdir}/fiddle.so
448     %{ruby_libarchdir}/gdbm.so
449     %dir %{ruby_libarchdir}/io
450     %{ruby_libarchdir}/io/nonblock.so
451     %{ruby_libarchdir}/io/wait.so
452     %dir %{ruby_libarchdir}/mathn
453 fwang 291562 %{ruby_libarchdir}/mathn/*.so
454 fwang 291560 %{ruby_libarchdir}/nkf.so
455     %{ruby_libarchdir}/objspace.so
456     %{ruby_libarchdir}/openssl.so
457 pterjan 435566 %{ruby_libarchdir}/psych.so
458 fwang 291560 %{ruby_libarchdir}/pathname.so
459     %{ruby_libarchdir}/pty.so
460     %dir %{ruby_libarchdir}/racc
461     %{ruby_libarchdir}/racc/*.so
462     %{ruby_libarchdir}/rbconfig.rb
463     %{ruby_libarchdir}/readline.so
464     %{ruby_libarchdir}/ripper.so
465     %{ruby_libarchdir}/sdbm.so
466     %{ruby_libarchdir}/socket.so
467     %{ruby_libarchdir}/stringio.so
468     %{ruby_libarchdir}/strscan.so
469     %{ruby_libarchdir}/syslog.so
470     %{ruby_libarchdir}/zlib.so
471 fwang 291551 %{_mandir}/man1/erb.1.*
472     %{_mandir}/man1/ruby.1.*
473 blino 1152 %{_datadir}/emacs/site-lisp/*
474     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
475     %{_sysconfdir}/rpm/macros.d/%{name}.macros
476 fwang 291560 %{_datadir}/ruby/site_ruby
477     %{_libdir}/ruby/site_ruby
478     %{_datadir}/ruby/vendor_ruby
479     %{_libdir}/ruby/vendor_ruby
480 fwang 311914 %if %bootstrap
481     %{_bindir}/gem
482 fwang 448831 %dir %{rubygems_dir}
483     %{rubygems_dir}/rbconfig
484     %{rubygems_dir}/rubygems
485     %{rubygems_dir}/rubygems.rb
486     %{rubygems_dir}/ubygems.rb
487 fwang 311914 %endif
488 blino 1152
489     %files doc
490     %{_datadir}/ri
491 pterjan 435211 %{_datadir}/doc/ruby
492 blino 1152
493 fwang 291590 %files -n %{libname}
494     %{_libdir}/libruby.so.%{subver}
495     %{_libdir}/libruby.so.%{rubyapi}
496    
497 blino 1152 %files devel
498 fwang 290003 %{_includedir}/*
499 blino 1152 %{_libdir}/libruby-static.a
500     %{_libdir}/libruby.so
501 fwang 290003 %{_libdir}/pkgconfig/*.pc
502 blino 1152
503     %files tk
504 fwang 291560 %{ruby_libarchdir}/tcltklib.so
505     %{ruby_libarchdir}/tkutil.so
506     %{ruby_libdir}/multi-tk.rb
507     %{ruby_libdir}/remote-tk.rb
508     %{ruby_libdir}/tcltk.rb
509     %{ruby_libdir}/tk.rb
510     %{ruby_libdir}/tkafter.rb
511     %{ruby_libdir}/tkbgerror.rb
512     %{ruby_libdir}/tkcanvas.rb
513     %{ruby_libdir}/tkclass.rb
514     %{ruby_libdir}/tkconsole.rb
515     %{ruby_libdir}/tkdialog.rb
516     %{ruby_libdir}/tkentry.rb
517     %{ruby_libdir}/tkfont.rb
518     %{ruby_libdir}/tkmacpkg.rb
519     %{ruby_libdir}/tkmenubar.rb
520     %{ruby_libdir}/tkmngfocus.rb
521     %{ruby_libdir}/tkpalette.rb
522     %{ruby_libdir}/tkscrollbox.rb
523     %{ruby_libdir}/tktext.rb
524     %{ruby_libdir}/tkvirtevent.rb
525     %{ruby_libdir}/tkwinpkg.rb
526     %{ruby_libdir}/tk
527     %{ruby_libdir}/tkextlib
528 fwang 291551
529 fwang 293412 %files irb
530     %{_bindir}/irb
531     %{ruby_libdir}/irb.rb
532     %{ruby_libdir}/irb
533     %{_mandir}/man1/irb.1*
534    
535     %if %build_gems
536 fwang 291551 %files RubyGems
537     %{_bindir}/gem
538     %dir %{rubygems_dir}
539     %{rubygems_dir}/rbconfig
540     %{rubygems_dir}/rubygems
541     %{rubygems_dir}/rubygems.rb
542     %{rubygems_dir}/ubygems.rb
543    
544 fwang 291562 %files minitest
545     %{ruby_libdir}/minitest
546 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
547 fwang 291562
548 fwang 291551 %files rake
549     %{_bindir}/rake
550     %{_mandir}/man1/rake.1.*
551 fwang 291562 %{ruby_libdir}/rake
552 pterjan 560987 %{gems_dir}/gems/rake-*
553     %{gems_dir}/specifications/default/rake-*.gemspec
554 fwang 291562
555     %files rdoc
556     %{_bindir}/rdoc
557     %{_bindir}/ri
558     %{ruby_libdir}/rdoc
559 pterjan 560987 %{gems_dir}/gems/rdoc-*
560     %{gems_dir}/specifications/default/rdoc-*.gemspec
561 fwang 291562 %{_mandir}/man1/ri.1.*
562    
563     %files json
564     %dir %{ruby_libarchdir}/json
565     %dir %{ruby_libarchdir}/json/ext
566     %{ruby_libarchdir}/json/ext/*.so
567     %{ruby_libdir}/json
568 pterjan 560987 %{gems_dir}/specifications/default/json-*.gemspec
569 fwang 291590
570     %files bigdecimal
571     %{ruby_libdir}/bigdecimal
572     %{ruby_libarchdir}/bigdecimal.so
573 pterjan 560987 %{gems_dir}/specifications/default/bigdecimal-*.gemspec
574 fwang 291590
575     %files io-console
576     %{ruby_libdir}/io
577     %{ruby_libarchdir}/io/console.so
578 pterjan 560987 %{gems_dir}/specifications/default/io-console-*.gemspec
579 pterjan 435211
580     %files psych
581     %{ruby_libdir}/psych
582     %{ruby_libarchdir}/psych.so
583 pterjan 560987 %{gems_dir}/specifications/default/psych-*.gemspec
584 pterjan 435211
585     %files test-unit
586     %{_bindir}/testrb
587     %{ruby_libdir}/test
588 pterjan 560987 %{gems_dir}/gems/test-unit-*
589 pterjan 435211 %{rubygems_dir}/specifications/default/test-unit-*.gemspec
590 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30