/[packages]/updates/5/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/5/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 617250 - (hide annotations) (download)
Mon Apr 21 17:23:16 2014 UTC (9 years, 11 months ago) by pterjan
Original Path: cauldron/ruby/current/SPECS/ruby.spec
File size: 18262 byte(s)
Fix version in pkg-config file (mga#13240)
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4 pterjan 601593 %define patchversion p451
5 pterjan 617250 %define rel 2
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
22     # RubyGems should be shared by all Ruby implementations.
23 pterjan 560984 %define rubygems_dir %{_datadir}/rubygems
24 pterjan 560987 %define gems_dir %{_datadir}/ruby/gems
25 pterjan 435211 %define rubygems_version 2.0.2
26 fwang 290007
27 fwang 468908 %define bootstrap 0
28 fwang 468812 %define build_gems 0
29 fwang 292558
30 blino 1152 Summary: Object Oriented Script Language
31     Name: ruby
32     Version: %{rubyver}.%{patchversion}
33     Release: %mkrel %rel
34 kamil 397518 License: Ruby or BSD
35 blino 1152 Group: Development/Ruby
36     BuildRequires: autoconf
37     BuildRequires: byacc
38 shlomif 291698 BuildRequires: doxygen
39 blino 1152 BuildRequires: ncurses-devel
40     BuildRequires: readline-devel
41     BuildRequires: tcl-devel tk-devel
42 fwang 276350 BuildRequires: db-devel
43 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
44 blino 1152 BuildRequires: openssl-devel
45     BuildRequires: zlib-devel
46 fwang 289987 BuildRequires: libffi-devel
47     BuildRequires: yaml-devel
48 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
49 blino 1152 Obsoletes: ruby-rexml
50     Provides: ruby-rexml
51 pterjan 435566 # Couldn't get the standalone gem to work
52     Provides: rubygem(psych)
53 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
54     Provides: /usr/bin/ruby
55 fwang 293445 Provides: ruby(abi) = %rubyapi
56 fwang 463762 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
57 pterjan 435211 Source1: operating_system.rb
58 blino 1152 Source3: ruby.macros
59     URL: http://www.ruby-lang.org/
60 fwang 292558 %if !%bootstrap
61     Requires: rubygems >= %{rubygems_version}
62 fwang 293395 BuildRequires: ruby
63 fwang 292558 %endif
64 blino 1152
65 fwang 290007 # == FEDORA PATCHES BEGINS ==
66 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
67     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
68     # Fixes random WEBRick test failures.
69     # https://bugs.ruby-lang.org/issues/6573.
70     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
71 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
72     # http://redmine.ruby-lang.org/issues/5617
73     Patch8: ruby-1.9.3-custom-rubygems-location.patch
74     # Add support for installing binary extensions according to FHS.
75     # https://github.com/rubygems/rubygems/issues/210
76 pterjan 435211 # Note that 8th patch might be resolved by
77     # https://bugs.ruby-lang.org/issues/7897
78     Patch9: rubygems-2.0.0-binary-extensions.patch
79     # Make mkmf verbose by default
80     Patch12: ruby-1.9.3-mkmf-verbose.patch
81     # This slightly changes behavior of "gem install --install-dir" behavior.
82     # Without this patch, Specifications.dirs is modified and gems installed on
83     # the system cannot be required anymore. This causes later issues when RDoc
84     # documentation should be generated, since json gem is sudenly not accessible.
85     # https://github.com/rubygems/rubygems/pull/452
86     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
87     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
88     # https://github.com/rubygems/rubygems/pull/455
89     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
90 fwang 490240 # Fixes issues with DESTDIR.
91     # https://bugs.ruby-lang.org/issues/8115
92     Patch18: ruby-2.0.0-p247-Revert-mkmf.rb-prefix-install_dirs-only-with-DESTDIR.patch
93 fwang 290007 # == FEDORA PATCHES ENDS ==
94 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
95     # to install gems into user dir
96     Patch20: ruby-2.0.0-p451-Do-not-install-to-user-dir.patch
97 pterjan 601635 # Upstream patch to build with new readline
98     Patch21: ruby-2.0.0-p451-readline.patch
99 fwang 290007
100 fwang 291591 %package -n %{libname}
101 fwang 291590 Summary: Libraries necessary to run Ruby
102     Group: Development/Ruby
103    
104 blino 1152 %package doc
105     Summary: Documentation for the powerful language Ruby
106     Group: Development/Ruby
107 fwang 202696 BuildArch: noarch
108 blino 1152
109     %package devel
110     Summary: Development file for the powerful language Ruby
111     Group: Development/Ruby
112 fwang 311925 Requires: %{name} = %{version}
113     Requires: %{libname} = %{version}
114 blino 1152
115     %package tk
116     Summary: Tk extension for the powerful language Ruby
117     Group: Development/Ruby
118 fwang 311925 Requires: %{name} = %{version}
119 blino 1152
120 fwang 291551 %package RubyGems
121     Summary: The Ruby standard for packaging ruby libraries
122     Group: Development/Ruby
123 fwang 291590 Version: %{rubygems_version}
124 fwang 291551 Requires: ruby(abi) = %{subver}
125 fwang 291590 Provides: gem = %{rubygems_version}
126     Provides: rubygems = %{rubygems_version}
127     Provides: ruby(rubygems) = %{rubygems_version}
128 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
129 fwang 291561 BuildArch: noarch
130 fwang 291551
131 pterjan 435211 %define rake_ver 0.9.6
132 fwang 291551 %package rake
133     Summary: Simple ruby build program with capabilities similar to make
134     Group: Development/Ruby
135 shlomif 291767 Version: %{rake_ver}
136 fwang 291551 Requires: ruby(abi) = %{subver}
137 fwang 291561 BuildArch: noarch
138 fwang 291551
139 pterjan 435211 %define minitest_ver 4.3.2
140 fwang 291562 %package minitest
141 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
142 fwang 291562 Group: Development/Ruby
143 shlomif 291767 Version: %{minitest_ver}
144 fwang 291562 License: MIT
145 fwang 291590 Requires: ruby(abi) = %{subver}
146     Requires: ruby(rubygems) >= %{rubygems_version}
147 fwang 291562 BuildArch: noarch
148    
149 pterjan 435211 %define json_ver 1.7.7
150 fwang 291562 %package json
151     Summary: This is a JSON implementation as a Ruby extension in C
152     Group: Development/Ruby
153 shlomif 291767 Version: %{json_ver}
154 fwang 291562 License: Ruby or GPLv2
155 fwang 291590 Requires: ruby(abi) = %{subver}
156     Requires: ruby(rubygems) >= %{rubygems_version}
157 fwang 291562
158 pterjan 435211 %define rdoc_ver 4.0.0
159 fwang 291562 %package rdoc
160     Summary: A tool to generate HTML and command-line documentation for Ruby projects
161     Group: Development/Ruby
162 shlomif 291767 Version: %{rdoc_ver}
163 fwang 291562 License: GPLv2 and Ruby and MIT
164 fwang 291590 Requires: ruby(abi) = %{subver}
165     Requires: ruby(rubygems) >= %{rubygems_version}
166     Requires: ruby(irb) = %{version}
167 shlomif 291767 Provides: rdoc = %{rdoc_ver}
168     Provides: ri = %{rdoc_ver}
169 fwang 291562 BuildArch: noarch
170    
171 fwang 291590 %package irb
172     Summary: The Interactive Ruby
173     Group: Development/Ruby
174     Provides: irb = %{version}-%{release}
175     Provides: ruby(irb) = %{version}-%{release}
176 fwang 313459 Conflicts: ruby < 1.9
177 fwang 313460 BuildArch: noarch
178 fwang 291590
179 pterjan 435211 %define bigdecimal_ver 1.2.0
180 fwang 291590 %package bigdecimal
181     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
182     Group: Development/Ruby
183 pterjan 435211 Version: %{bigdecimal_ver}
184 fwang 291590 License: GPL+ or Artistic
185     Requires: ruby(abi) = %{subver}
186     Requires: ruby(rubygems) >= %{rubygems_version}
187    
188 pterjan 435211 %define io_console_ver 0.4.2
189 fwang 291590 %package io-console
190     Summary: IO/Console is a simple console utilizing library
191     Group: Development/Ruby
192 pterjan 435211 Version: %{io_console_ver}
193 fwang 291590 Requires: ruby(abi) = %{subver}
194     Requires: ruby(rubygems) >= %{rubygems_version}
195    
196 pterjan 435211 %define psych_ver 2.0.0
197     %package psych
198     Summary: A libyaml wrapper for Ruby
199     Version: %{psych_ver}
200     Group: Development/Ruby
201     License: MIT
202     Requires: ruby(abi) = %{subver}
203     Requires: ruby(rubygems) >= %{rubygems_version}
204     Conflicts: ruby < 2.0.0
205    
206     %define test_unit_ver 2.0.0
207     %package test-unit
208     Summary: test/unit compatible API testing framework
209     Version: %{psych_ver}
210     Group: Development/Ruby
211     License: MIT
212     Requires: ruby(abi) = %{subver}
213     Requires: ruby(rubygems) >= %{rubygems_version}
214     Conflicts: ruby < 2.0.0
215     BuildArch: noarch
216    
217 blino 1152 %description
218     Ruby is the interpreted scripting language for quick and
219     easy object-oriented programming. It has many features to
220     process text files and to do system management tasks (as in
221     Perl). It is simple, straight-forward, and extensible.
222    
223     %description doc
224     Ruby is the interpreted scripting language for quick and
225     easy object-oriented programming. It has many features to
226     process text files and to do system management tasks (as in
227     Perl). It is simple, straight-forward, and extensible.
228    
229     This package contains the Ruby's documentation
230    
231 fwang 291590 %description -n %{libname}
232     This package includes the libruby, necessary to run Ruby.
233    
234 blino 1152 %description devel
235     Ruby is the interpreted scripting language for quick and
236     easy object-oriented programming. It has many features to
237     process text files and to do system management tasks (as in
238     Perl). It is simple, straight-forward, and extensible.
239    
240     This package contains the Ruby's devel files.
241    
242     %description tk
243     Ruby is the interpreted scripting language for quick and
244     easy object-oriented programming. It has many features to
245     process text files and to do system management tasks (as in
246     Perl). It is simple, straight-forward, and extensible.
247    
248     This package contains the Tk extension for Ruby.
249    
250 fwang 291551 %description RubyGems
251     RubyGems is the Ruby standard for publishing and managing third party
252     libraries.
253    
254 fwang 291552 %description rake
255     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
256     specified in standard Ruby syntax.
257    
258 fwang 291562 %description rdoc
259     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
260     includes the 'rdoc' and 'ri' tools for generating and displaying online
261     documentation.
262    
263     %description json
264     This is a implementation of the JSON specification according to RFC 4627.
265     You can think of it as a low fat alternative to XML, if you want to store
266     data to disk or transmit it over a network rather than use a verbose
267     markup language.
268    
269     %description minitest
270     minitest/unit is a small and incredibly fast unit testing framework.
271    
272     minitest/spec is a functionally complete spec engine.
273    
274     minitest/benchmark is an awesome way to assert the performance of your
275     algorithms in a repeatable manner.
276    
277     minitest/mock by Steven Baker, is a beautifully tiny mock object
278     framework.
279    
280     minitest/pride shows pride in testing and adds coloring to your test
281     output.
282    
283 fwang 291590 %description irb
284     The irb is acronym for Interactive Ruby. It evaluates ruby expression
285     from the terminal.
286    
287     %description bigdecimal
288     Ruby provides built-in support for arbitrary precision integer arithmetic.
289     For example:
290    
291     42**13 -> 1265437718438866624512
292    
293     BigDecimal provides similar support for very large or very accurate floating
294     point numbers. Decimal arithmetic is also useful for general calculation,
295     because it provides the correct answers people expect–whereas normal binary
296     floating point arithmetic often introduces subtle errors because of the
297     conversion between base 10 and base 2.
298    
299     %description io-console
300     IO/Console provides very simple and portable access to console. It doesn't
301     provide higher layer features, such like curses and readline.
302    
303 pterjan 435211 %description psych
304     Psych is a YAML parser and emitter. Psych leverages
305     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
306     capabilities. In addition to wrapping libyaml, Psych also knows how to
307     serialize and de-serialize most Ruby objects to and from the YAML format.
308    
309     %description test-unit
310     This library implements test/unit compatible API on minitest.
311     The test/unit means that test/unit which was bundled with Ruby 1.8.
312    
313 blino 1152 %prep
314     %setup -q -n ruby-%{rubyver}-%{patchversion}
315 fwang 290007 %apply_patches
316 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
317     rm lib/mkmf.rb.0*
318 blino 1152
319     %build
320 fwang 290038 autoconf
321 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
322 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
323 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
324 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
325 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
326     --with-sitearchdir='%{ruby_sitearchdir}' \
327     --with-vendordir='%{ruby_vendorlibdir}' \
328     --with-vendorarchdir='%{ruby_vendorarchdir}' \
329 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
330 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
331     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
332     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
333     --with-rubygemsdir='%{rubygems_dir}' \
334     --with-ruby-pc='%{name}.pc' \
335     --enable-multiarch \
336     --with-ruby-version=''
337 blino 1152 %make
338    
339     %install
340     %makeinstall_std install-doc
341    
342     install -d %buildroot%{_datadir}/emacs/site-lisp
343     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
344    
345     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
346     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
347     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
348     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
349     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
350     EOF
351    
352     # Install the rpm macros
353     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
354     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
355 fwang 289961
356 pterjan 435211 # Install custom operating_system.rb
357     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
358     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
359    
360 pterjan 617250 # Version is empty if --with-ruby-version is specified.
361     # http://bugs.ruby-lang.org/issues/7807
362     sed -i 's/Version: .*/Version: %{rubyver}/' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
363    
364 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
365     %if !%build_gems
366 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
367 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
368 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
369     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
370 pterjan 560987 rm -fr %{buildroot}%{gems_dir}/{gems,specifications}
371 fwang 311915 %if !%bootstrap
372 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
373 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
374     rm -fr %{buildroot}%{rubygems_dir}/rubygems
375 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
376     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
377 fwang 293412 %endif
378 fwang 311914 %endif
379 fwang 293412
380 blino 1152 %check
381     make test
382    
383 fwang 289961 %files
384 fwang 291551 %{_bindir}/erb
385     %{_bindir}/ruby
386 fwang 291560 %dir %{ruby_libdir}
387     %{ruby_libdir}/*.rb
388 fwang 291590 %exclude %{ruby_libdir}/irb.rb
389 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
390     %exclude %{ruby_libdir}/remote-tk.rb
391     %exclude %{ruby_libdir}/tcltk.rb
392     %exclude %{ruby_libdir}/tk.rb
393     %exclude %{ruby_libdir}/tkafter.rb
394     %exclude %{ruby_libdir}/tkbgerror.rb
395     %exclude %{ruby_libdir}/tkcanvas.rb
396     %exclude %{ruby_libdir}/tkclass.rb
397     %exclude %{ruby_libdir}/tkconsole.rb
398     %exclude %{ruby_libdir}/tkdialog.rb
399     %exclude %{ruby_libdir}/tkentry.rb
400     %exclude %{ruby_libdir}/tkfont.rb
401     %exclude %{ruby_libdir}/tkmacpkg.rb
402     %exclude %{ruby_libdir}/tkmenubar.rb
403     %exclude %{ruby_libdir}/tkmngfocus.rb
404     %exclude %{ruby_libdir}/tkpalette.rb
405     %exclude %{ruby_libdir}/tkscrollbox.rb
406     %exclude %{ruby_libdir}/tktext.rb
407     %exclude %{ruby_libdir}/tkvirtevent.rb
408     %exclude %{ruby_libdir}/tkwinpkg.rb
409     %{ruby_libdir}/cgi
410     %{ruby_libdir}/date
411     %{ruby_libdir}/digest
412     %{ruby_libdir}/dl
413     %{ruby_libdir}/drb
414     %{ruby_libdir}/fiddle
415     %{ruby_libdir}/matrix
416     %{ruby_libdir}/net
417     %{ruby_libdir}/openssl
418     %{ruby_libdir}/optparse
419 pterjan 435566 %{ruby_libdir}/psych
420 fwang 291560 %{ruby_libdir}/racc
421     %{ruby_libdir}/rbconfig
422     %{ruby_libdir}/rexml
423     %{ruby_libdir}/rinda
424     %{ruby_libdir}/ripper
425     %{ruby_libdir}/rss
426     %{ruby_libdir}/shell
427 pterjan 435211 %{ruby_libdir}/syslog
428 fwang 291560 %{ruby_libdir}/uri
429     %{ruby_libdir}/webrick
430     %{ruby_libdir}/xmlrpc
431     %{ruby_libdir}/yaml
432     %dir %{ruby_libarchdir}
433     %{ruby_libarchdir}/continuation.so
434     %{ruby_libarchdir}/coverage.so
435     %{ruby_libarchdir}/curses.so
436     %{ruby_libarchdir}/date_core.so
437     %{ruby_libarchdir}/dbm.so
438     %dir %{ruby_libarchdir}/digest
439     %{ruby_libarchdir}/digest.so
440     %{ruby_libarchdir}/digest/*.so
441     %dir %{ruby_libarchdir}/dl
442     %{ruby_libarchdir}/dl.so
443     %{ruby_libarchdir}/dl/*.so
444     %dir %{ruby_libarchdir}/enc
445     %{ruby_libarchdir}/enc/*.so
446 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
447     %{ruby_libarchdir}/enc/trans/*.so
448 fwang 291560 %{ruby_libarchdir}/etc.so
449     %{ruby_libarchdir}/fcntl.so
450     %{ruby_libarchdir}/fiber.so
451     %{ruby_libarchdir}/fiddle.so
452     %{ruby_libarchdir}/gdbm.so
453     %dir %{ruby_libarchdir}/io
454     %{ruby_libarchdir}/io/nonblock.so
455     %{ruby_libarchdir}/io/wait.so
456     %dir %{ruby_libarchdir}/mathn
457 fwang 291562 %{ruby_libarchdir}/mathn/*.so
458 fwang 291560 %{ruby_libarchdir}/nkf.so
459     %{ruby_libarchdir}/objspace.so
460     %{ruby_libarchdir}/openssl.so
461 pterjan 435566 %{ruby_libarchdir}/psych.so
462 fwang 291560 %{ruby_libarchdir}/pathname.so
463     %{ruby_libarchdir}/pty.so
464     %dir %{ruby_libarchdir}/racc
465     %{ruby_libarchdir}/racc/*.so
466     %{ruby_libarchdir}/rbconfig.rb
467     %{ruby_libarchdir}/readline.so
468     %{ruby_libarchdir}/ripper.so
469     %{ruby_libarchdir}/sdbm.so
470     %{ruby_libarchdir}/socket.so
471     %{ruby_libarchdir}/stringio.so
472     %{ruby_libarchdir}/strscan.so
473     %{ruby_libarchdir}/syslog.so
474     %{ruby_libarchdir}/zlib.so
475 fwang 291551 %{_mandir}/man1/erb.1.*
476     %{_mandir}/man1/ruby.1.*
477 blino 1152 %{_datadir}/emacs/site-lisp/*
478     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
479     %{_sysconfdir}/rpm/macros.d/%{name}.macros
480 fwang 291560 %{_datadir}/ruby/site_ruby
481     %{_libdir}/ruby/site_ruby
482     %{_datadir}/ruby/vendor_ruby
483     %{_libdir}/ruby/vendor_ruby
484 fwang 311914 %if %bootstrap
485     %{_bindir}/gem
486 fwang 448831 %dir %{rubygems_dir}
487     %{rubygems_dir}/rbconfig
488     %{rubygems_dir}/rubygems
489     %{rubygems_dir}/rubygems.rb
490     %{rubygems_dir}/ubygems.rb
491 fwang 311914 %endif
492 blino 1152
493     %files doc
494     %{_datadir}/ri
495 pterjan 435211 %{_datadir}/doc/ruby
496 blino 1152
497 fwang 291590 %files -n %{libname}
498     %{_libdir}/libruby.so.%{subver}
499     %{_libdir}/libruby.so.%{rubyapi}
500    
501 blino 1152 %files devel
502 fwang 290003 %{_includedir}/*
503 blino 1152 %{_libdir}/libruby-static.a
504     %{_libdir}/libruby.so
505 fwang 290003 %{_libdir}/pkgconfig/*.pc
506 blino 1152
507     %files tk
508 fwang 291560 %{ruby_libarchdir}/tcltklib.so
509     %{ruby_libarchdir}/tkutil.so
510     %{ruby_libdir}/multi-tk.rb
511     %{ruby_libdir}/remote-tk.rb
512     %{ruby_libdir}/tcltk.rb
513     %{ruby_libdir}/tk.rb
514     %{ruby_libdir}/tkafter.rb
515     %{ruby_libdir}/tkbgerror.rb
516     %{ruby_libdir}/tkcanvas.rb
517     %{ruby_libdir}/tkclass.rb
518     %{ruby_libdir}/tkconsole.rb
519     %{ruby_libdir}/tkdialog.rb
520     %{ruby_libdir}/tkentry.rb
521     %{ruby_libdir}/tkfont.rb
522     %{ruby_libdir}/tkmacpkg.rb
523     %{ruby_libdir}/tkmenubar.rb
524     %{ruby_libdir}/tkmngfocus.rb
525     %{ruby_libdir}/tkpalette.rb
526     %{ruby_libdir}/tkscrollbox.rb
527     %{ruby_libdir}/tktext.rb
528     %{ruby_libdir}/tkvirtevent.rb
529     %{ruby_libdir}/tkwinpkg.rb
530     %{ruby_libdir}/tk
531     %{ruby_libdir}/tkextlib
532 fwang 291551
533 fwang 293412 %files irb
534     %{_bindir}/irb
535     %{ruby_libdir}/irb.rb
536     %{ruby_libdir}/irb
537     %{_mandir}/man1/irb.1*
538    
539     %if %build_gems
540 fwang 291551 %files RubyGems
541     %{_bindir}/gem
542     %dir %{rubygems_dir}
543     %{rubygems_dir}/rbconfig
544     %{rubygems_dir}/rubygems
545     %{rubygems_dir}/rubygems.rb
546     %{rubygems_dir}/ubygems.rb
547    
548 fwang 291562 %files minitest
549     %{ruby_libdir}/minitest
550 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
551 fwang 291562
552 fwang 291551 %files rake
553     %{_bindir}/rake
554     %{_mandir}/man1/rake.1.*
555 fwang 291562 %{ruby_libdir}/rake
556 pterjan 560987 %{gems_dir}/gems/rake-*
557     %{gems_dir}/specifications/default/rake-*.gemspec
558 fwang 291562
559     %files rdoc
560     %{_bindir}/rdoc
561     %{_bindir}/ri
562     %{ruby_libdir}/rdoc
563 pterjan 560987 %{gems_dir}/gems/rdoc-*
564     %{gems_dir}/specifications/default/rdoc-*.gemspec
565 fwang 291562 %{_mandir}/man1/ri.1.*
566    
567     %files json
568     %dir %{ruby_libarchdir}/json
569     %dir %{ruby_libarchdir}/json/ext
570     %{ruby_libarchdir}/json/ext/*.so
571     %{ruby_libdir}/json
572 pterjan 560987 %{gems_dir}/specifications/default/json-*.gemspec
573 fwang 291590
574     %files bigdecimal
575     %{ruby_libdir}/bigdecimal
576     %{ruby_libarchdir}/bigdecimal.so
577 pterjan 560987 %{gems_dir}/specifications/default/bigdecimal-*.gemspec
578 fwang 291590
579     %files io-console
580     %{ruby_libdir}/io
581     %{ruby_libarchdir}/io/console.so
582 pterjan 560987 %{gems_dir}/specifications/default/io-console-*.gemspec
583 pterjan 435211
584     %files psych
585     %{ruby_libdir}/psych
586     %{ruby_libarchdir}/psych.so
587 pterjan 560987 %{gems_dir}/specifications/default/psych-*.gemspec
588 pterjan 435211
589     %files test-unit
590     %{_bindir}/testrb
591     %{ruby_libdir}/test
592 pterjan 560987 %{gems_dir}/gems/test-unit-*
593 pterjan 435211 %{rubygems_dir}/specifications/default/test-unit-*.gemspec
594 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30