/[packages]/updates/6/caja/current/SPECS/caja.spec
ViewVC logotype

Contents of /updates/6/caja/current/SPECS/caja.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1190049 - (show annotations) (download)
Wed Jan 3 22:35:03 2018 UTC (6 years, 3 months ago) by tarakbumba
File size: 6094 byte(s)
- Updated upstream bugfix 1.18.5 release (#mga22279)
1 %define url_ver %(echo %{version}|cut -d. -f1,2)
2
3 %define oname mate-file-manager
4
5 %define major 1
6 %define gi_major 2.0
7 %define libname %mklibname %{name}-extension %{major}
8 %define develname %mklibname -d %{name}-extension
9 %define girname %mklibname %{name}-gir %{gi_major}
10
11 %define have_packagekit 1
12
13 Name: caja
14 Version: 1.18.5
15 Release: %mkrel 1
16 Summary: File manager for the MATE desktop environment
17 Group: File tools
18 License: GPLv2+ and LGPLv2+
19 URL: http://www.mate-desktop.org/
20 Source0: http://pub.mate-desktop.org/releases/%{url_ver}/%{name}-%{version}.tar.xz
21 Source4: caja-ffmpegthumbnailer.thumbnailer
22 # gw from Fedora, fix crash on weird file infos
23 # http://bugzilla.gnome.org/show_bug.cgi?id=519743
24 Patch0: nautilus-filetype-symlink-fix.patch
25 # (fc) add a search .desktop file (GNOME bug #350950) (SUSE)
26 Patch3: nautilus-bgo350950-search-desktop.diff
27 # (patch by Atilla ÖNTAŞ) This patch fixes unworking accels issue and respects mate config dirs.
28 Patch7: mate-file-manager-1.6.2-mga_fix_config_dirs.patch
29 # (gnome#674659) places-sidebar: don't double unref GMount objects
30 Patch8: mate-file-manager-1.6.2-double_unref_GMount_objects.patch
31
32 BuildRequires: pkgconfig(gtk+-3.0) >= 3.14.0
33 BuildRequires: pkgconfig(gail-3.0) >= 3.0.0
34 BuildRequires: pkgconfig(unique-3.0)
35 BuildRequires: pkgconfig(libxml-2.0) >= 2.4.7
36 BuildRequires: pkgconfig(dbus-glib-1)
37 BuildRequires: intltool
38 BuildRequires: pkgconfig(exempi-2.0) >= 1.99.5
39 BuildRequires: pkgconfig(gobject-introspection-1.0)
40 BuildRequires: pkgconfig(glib-2.0) >= 2.36.0
41 BuildRequires: pkgconfig(cairo-gobject)
42 BuildRequires: pkgconfig(libexif) >= 0.6.14
43 BuildRequires: pkgconfig(mate-desktop-2.0) >= 1.17.0
44 BuildRequires: pkgconfig(pango) >= 1.1.2
45 BuildRequires: pkgconfig(libnotify) >= 0.7.0
46 BuildRequires: pkgconfig(gio-2.0) >= 2.26.0
47 BuildRequires: pkgconfig(gio-unix-2.0)
48 BuildRequires: pkgconfig(gthread-2.0)
49 BuildRequires: pkgconfig(x11)
50 BuildRequires: pkgconfig(gmodule-2.0)
51 BuildRequires: pkgconfig(sm)
52
53 Requires: gvfs
54 # We need a seperate package for other MATE apps.
55 Requires: %{name}-schemas = %{version}-%{release}
56
57 Recommends: %{name}-extensions >= 1.16.0
58
59 # Without these, caja can not connect to a secure network or WebDav
60 Recommends: glib-networking
61 Recommends: davfs2
62
63 # Without this caja could not show thumbnails for video files
64 Recommends: ffmpegthumbnailer
65
66 Obsoletes: %{oname} < 1.7.0
67 Obsoletes: %{oname}-gksu < 1.7.0
68 Obsoletes: %{name} < 1.16.0
69
70 %description
71 Caja is the file manager and graphical shell for the MATE desktop,
72 that makes it easy to manage your files and the rest of your system.
73
74 It allows to browse directories on local and remote file systems,
75 preview files and launch applications associated with them.
76 It is also responsible for handling the icons on the MATE desktop.
77
78 %package -n %{libname}
79 Summary: Libraries for Mate file manager
80 Group: System/Libraries
81 Obsoletes: %{libname} < 1.16.0
82
83 %description -n %{libname}
84 Caja is a file manager for the MATE desktop environment.
85 This package contains libraries used by Caja.
86
87 %package -n %{girname}
88 Summary: GObject Introspection interface description for %{name}
89 Group: System/Libraries
90 Requires: %{libname} = %{version}
91 Obsoletes: %{girname} < 1.16.0
92
93 %description -n %{girname}
94 GObject Introspection interface description for %{name}
95
96 %package -n %{develname}
97 Summary: Libraries and include files for developing caja components
98 Group: Development/C
99 Requires: %{libname} = %{version}-%{release}
100 Requires: %{girname} = %{version}-%{release}
101 Provides: %{name}-devel = %{version}-%{release}
102 Obsoletes: %{oname}-devel < 1.7.0
103 Obsoletes: %{develname} < 1.16.0
104
105 %description -n %{develname}
106 This package provides the necessary development libraries and include
107 files to allow you to develop caja components.
108
109 %package -n %{name}-schemas
110 Summary: Gsettings schema files for %{name}
111 Group: File tools
112 BuildArch: noarch
113 Conflicts: %{oname} < 1.7.0
114
115 %description -n %{name}-schemas
116 This package provides caja gsettings schema files;
117 needed to run caja and various other MATE applications.
118
119 %prep
120 %autosetup -p1
121
122 %build
123 %configure2_5x \
124 --disable-static \
125 %if %{have_packagekit}
126 --enable-packagekit \
127 %else
128 --disable-packagekit \
129 %endif
130 --disable-schemas-compile \
131 --disable-update-mimedb \
132 --disable-icon-update
133
134 %make_build
135
136 %install
137 %make_install
138
139 find %{buildroot} -name *.la -delete
140
141 mkdir -p %{buildroot}%{_datadir}/thumbnailers
142 install -m644 %{_sourcedir}/caja-ffmpegthumbnailer.thumbnailer %{buildroot}%{_datadir}/thumbnailers/caja-ffmpegthumbnailer.thumbnailer
143
144 mkdir -p %{buildroot}%{_localstatedir}/lib/mate/desktop \
145 %{buildroot}%{_datadir}/%{name}/default-desktop \
146 %{buildroot}%{_libdir}/%{name}/extensions-2.0
147
148 %find_lang %{name}
149
150 %files -f %{name}.lang
151 %doc README NEWS HACKING AUTHORS
152 %dir %{_localstatedir}/lib/mate/desktop
153 %dir %{_localstatedir}/lib/mate/
154 %{_bindir}/caja
155 %{_bindir}/caja-autorun-software
156 %{_bindir}/caja-connect-server
157 %{_bindir}/caja-file-management-properties
158 %{_datadir}/caja/
159 %{_datadir}/dbus-1/services/org.mate.freedesktop.FileManager1.service
160 %{_datadir}/applications/*
161 %{_datadir}/appdata/caja.appdata.xml
162 %{_datadir}/pixmaps/%{name}/
163 %{_datadir}/mime/packages/caja.xml
164 %{_datadir}/thumbnailers/caja-ffmpegthumbnailer.thumbnailer
165 %{_datadir}/icons/hicolor/*/emblems/emblem-note.png
166 %{_mandir}/man1/caja-autorun-software.1*
167 %{_mandir}/man1/caja-connect-server.1*
168 %{_mandir}/man1/caja-file-management-properties.1*
169 %{_mandir}/man1/caja.1*
170 %{_iconsdir}/hicolor/*/apps/caja.*
171 %dir %{_libdir}/caja
172 %dir %{_libdir}/caja/extensions-2.0
173
174 %files -n %{libname}
175 %{_libdir}/libcaja-extension.so.%{major}{,.*}
176
177 %files -n %{girname}
178 %{_libdir}/girepository-1.0/Caja-%{gi_major}.typelib
179
180 %files -n %{develname}
181 %doc ChangeLog
182 %doc %{_datadir}/gtk-doc/html/libcaja-extension/
183 %{_includedir}/*
184 %{_libdir}/libcaja-extension.so
185 %{_libdir}/pkgconfig/libcaja-extension.pc
186 %{_datadir}/gir-1.0/Caja-%{gi_major}.gir
187
188 %files -n %{name}-schemas
189 %{_datadir}/glib-2.0/schemas/org.mate.*.gschema.xml

  ViewVC Help
Powered by ViewVC 1.1.30