/[packages]/updates/6/gnome-shell/current/SPECS/gnome-shell.spec
ViewVC logotype

Contents of /updates/6/gnome-shell/current/SPECS/gnome-shell.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1188851 - (show annotations) (download)
Mon Jan 1 18:32:01 2018 UTC (6 years, 3 months ago) by luigiwalser
File size: 6884 byte(s)
- 3.24.3
- add patch from fedora to fix security issue (mga#21759)

1 %define url_ver %(echo %{version}|cut -d. -f1,2)
2
3 #define mutter_ver %(echo %{version}|cut -d. -f1,2,3)
4 %define mutter_ver 3.22.0
5
6 # To make GNOME Shell extensions load, we need to get rid of DT_RUNPATH on /usr/bin/gnome-shell
7 # (see glibc bug #13945, GNOME bug #670477, Mageia bug #4523)
8 %define _disable_ld_enable_new_dtags 1
9
10 # filter out private typelib req from mutter which is already required directly,
11 # private typelib provides are also filtered out from mutter
12 %global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^typelib\\(Meta
13
14 Summary: Core user interface for the GNOME 3 desktop
15 Name: gnome-shell
16 Version: 3.24.3
17 Release: %mkrel 1
18 Source0: https://download.gnome.org/sources/%{name}/%{url_ver}/%{name}-%{version}.tar.xz
19 Source1: gnome-shell-session
20 Patch0001: 0001-screenShield-Allow-for-custom-backgrounds-on-login-s.patch
21 Patch0002: 0001-extensions-Consistently-handle-createExtensionObject.patch
22 Patch0003: 0002-extensionSystem-Catch-import-errors.patch
23 Patch0004: 0003-extensionSystem-Handle-all-initExtension-extension-e.patch
24 Patch0005: 0001-gtk-embed-ensure-we-only-listen-for-window-created-e.patch
25 License: GPLv2+ and LGPLv2+
26 Group: Graphical desktop/GNOME
27 Url: https://wiki.gnome.org/GnomeShell
28 BuildRequires: pkgconfig(clutter-1.0)
29 BuildRequires: pkgconfig(clutter-glx-1.0) >= 1.7.5
30 BuildRequires: pkgconfig(clutter-x11-1.0) >= 1.7.5
31 BuildRequires: pkgconfig(folks) >= 0.5.2
32 BuildRequires: pkgconfig(gcr-3) >= 3.8.0
33 BuildRequires: pkgconfig(gdk-pixbuf-2.0)
34 BuildRequires: pkgconfig(gdk-x11-3.0)
35 BuildRequires: pkgconfig(gio-unix-2.0) >= 2.31.6
36 BuildRequires: pkgconfig(gl)
37 BuildRequires: pkgconfig(gnome-bluetooth-1.0) >= 3.1.0
38 BuildRequires: pkgconfig(gnome-desktop-3.0) >= 2.90.0
39 BuildRequires: pkgconfig(gnome-keyring-1)
40 BuildRequires: pkgconfig(gnome-keybindings)
41 BuildRequires: pkgconfig(gobject-2.0)
42 BuildRequires: pkgconfig(gobject-introspection-1.0) >= 1.45.3
43 BuildRequires: pkgconfig(gsettings-desktop-schemas) >= 0.1.7
44 BuildRequires: pkgconfig(gstreamer-1.0) >= 0.11.92
45 BuildRequires: pkgconfig(gstreamer-base-1.0)
46 BuildRequires: pkgconfig(gtk+-3.0) >= 3.3.9
47 BuildRequires: pkgconfig(gtk-doc)
48 BuildRequires: pkgconfig(libcanberra)
49 BuildRequires: pkgconfig(libcroco-0.6) >= 0.6.2
50 BuildRequires: pkgconfig(libecal-1.2) >= 2.32.0
51 BuildRequires: pkgconfig(libedataserver-1.2) >= 1.2.0
52 BuildRequires: pkgconfig(libgnome-menu-3.0)
53 BuildRequires: pkgconfig(mutter-clutter-0)
54 BuildRequires: pkgconfig(libnm-glib)
55 BuildRequires: pkgconfig(libnm-util)
56 BuildRequires: pkgconfig(libnm-gtk)
57 BuildRequires: pkgconfig(libpulse)
58 BuildRequires: pkgconfig(libpulse-mainloop-glib)
59 BuildRequires: pkgconfig(libsoup-2.4)
60 BuildRequires: pkgconfig(libstartup-notification-1.0) >= 0.11
61 BuildRequires: pkgconfig(libxml-2.0)
62 BuildRequires: pkgconfig(polkit-agent-1) >= 0.100
63 BuildRequires: pkgconfig(systemd)
64 BuildRequires: pkgconfig(telepathy-glib) >= 0.17.5
65 BuildRequires: pkgconfig(telepathy-logger-0.2) >= 0.2.4
66 BuildRequires: pkgconfig(x11)
67 BuildRequires: pkgconfig(xfixes)
68 BuildRequires: pkgconfig(caribou-1.0)
69 BuildRequires: pkgconfig(gjs-1.0)
70 BuildRequires: intltool >= 0.40.0
71 BuildRequires: gnome-common
72 BuildRequires: gettext-devel
73 BuildRequires: pkgconfig(python3)
74 Requires: mutter >= %{mutter_ver}
75 Requires: gjs
76 Requires: glxinfo
77 Requires: gnome-session
78 Requires: adwaita-icon-theme
79 # For a GSettings schema
80 Requires: gnome-settings-daemon
81 Requires: gsettings-desktop-schemas >= 3.9.2
82 Requires: packagekit-gtk3-module
83 Requires: telepathy-mission-control
84 Requires: gnome-control-center
85 # mga#11640 when there are multiple keyboard layouts, "Show Keyboard Layouts" option
86 # also needed in 3.17+
87 Requires: libgnomekbd-common
88 # Ensures extensions.gnome.org works for Fireox 52+, Chrome, Chromiun
89 Requires: chrome-gnome-shell
90
91 # gnome-shell handles notifications natively, no notification-daemon needed
92 Provides: virtual-notification-daemon
93 # and ditto for polkit authorisation dialogs
94 Provides: polkit-agent
95
96 # --- gir/typelibs not automatically required ---
97 # mga#14269 I don't think this is needed, but Mageia 5 should get out
98 Requires: typelib(GcrUi)
99
100 # (cg) gnome-shell needs schemas defined/shipped with gdm and needs gdm for
101 # screen locking. Technically, this could be relaxed upstream and the schema
102 # moved to gsettings-desktop-schemas, so if that happens, the dep can be relaxed
103 # https://bugs.mageia.org/show_bug.cgi?id=14430
104 Requires: gdm
105
106 # (ovitters) extensions depend on 'unzip' being available; mga#16005
107 Requires: unzip
108
109 Obsoletes: gnome-applet-netspeed < 3.0.2
110
111 %description
112 GNOME Shell provides core user interface functions for the GNOME 3
113 desktop, like switching to windows and launching applications. GNOME
114 Shell takes advantage of the capabilities of modern graphics hardware
115 and introduces innovative user interface concepts to provide a
116 visually attractive and easy to use experience.
117
118 %package docs
119 Summary: Documentation for %{name}
120 Group: Documentation
121 BuildArch: noarch
122
123 %description docs
124 This package contains the documentation for %{name}.
125
126 %prep
127 %setup -q
128 %autopatch -p1
129
130 %build
131 %configure2_5x \
132 --enable-compile-warnings=no \
133 --disable-static --disable-schemas-compile
134 %make V=1
135
136 %install
137 GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 %makeinstall_std
138
139 %find_lang %name
140
141 mkdir -p %{buildroot}/%{_datadir}/gnome-shell/xdg-override/autostart
142 cp -f %{buildroot}/%{_datadir}/applications/org.gnome.Shell.desktop %{buildroot}/%{_datadir}/gnome-shell/xdg-override/autostart
143
144 find %{buildroot} -name '*.la' -delete
145
146 install -m 755 %{SOURCE1} %{buildroot}/%{_datadir}/gnome-shell/
147
148 %files -f %name.lang
149 %doc README
150 %{_bindir}/*
151 %{_libdir}/%{name}
152 %{_libexecdir}/gnome-shell-calendar-server
153 %{_libexecdir}/gnome-shell-perf-helper
154 %{_libexecdir}/gnome-shell-hotplug-sniffer
155 %{_libexecdir}/gnome-shell-portal-helper
156 %{_libdir}/mozilla/plugins/*.so
157 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
158 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
159 %{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
160 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
161 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
162 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
163 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
164 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.PadOsd.xml
165 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
166 %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
167 %{_datadir}/applications/org.gnome.Shell.desktop
168 %{_datadir}/applications/evolution-calendar.desktop
169 %{_datadir}/applications/gnome-shell-extension-prefs.desktop
170 %{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
171 %{_datadir}/gnome-control-center/keybindings/*%{name}*.xml
172 %{_datadir}/%{name}
173 %{_mandir}/man1/%{name}.1*
174 %{_datadir}/xdg-desktop-portal/portals/%{name}.portal
175
176 %files docs
177 %{_datadir}/gtk-doc/html/shell
178 %{_datadir}/gtk-doc/html/st

  ViewVC Help
Powered by ViewVC 1.1.30