/[packages]/updates/6/nextcloud-client/current/SPECS/nextcloud-client.spec
ViewVC logotype

Contents of /updates/6/nextcloud-client/current/SPECS/nextcloud-client.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1336762 - (show annotations) (download)
Thu Nov 29 20:40:25 2018 UTC (5 years, 5 months ago) by mokraemer
File size: 6113 byte(s)
Fixed requirements
1 %global _hardened_build 1
2 %define _cmake_skip_rpath %nil
3 # exclude devel(libocsync)
4 %global __requires_exclude ^(devel\\(libocsync.*)$
5
6 %define nextcloudsync_major 0
7 %define libnextcloudsync %mklibname nextcloudsync %nextcloudsync_major
8 %define libocsync_major 0
9 %define liblibocsync %mklibname ocsync %libocsync_major
10
11 Name: nextcloud-client
12 Version: 2.5.0
13 Release: %mkrel 2
14 Summary: The Nextcloud Client
15 Group: Archiving/Backup
16
17 # -libs are LGPLv2+, rest GPLv2
18 License: LGPLv2+ and GPLv2
19 Url: https://nextcloud.com/install/#install-clients
20 Source0: https://github.com/nextcloud/desktop/archive/v%{version}.tar.gz
21 #Source1: https://download.owncloud.com/desktop/stable/owncloudclient-%{version}.tar.xz
22 Source2: %{name}.appdata.xml
23 #Patch0: %{name}-2.4.0-syslibs.patch
24 #Patch1: %{name}-icon.patch
25 Patch2: %{name}-inotify.patch
26 Patch3: openssl.patch
27
28 BuildRequires: desktop-file-utils
29 BuildRequires: doxygen
30 BuildRequires: pkgconfig(neon)
31 BuildRequires: pkgconfig(openssl)
32 BuildRequires: python-sphinx
33 BuildRequires: qtsingleapplication-qt5-devel
34 BuildRequires: appstream-util
35
36 BuildRequires: kf5-macros
37
38 BuildRequires: cmake(KF5KIO)
39
40 BuildRequires: cmake(Qt5Keychain)
41
42 BuildRequires: pkgconfig(sqlite3)
43 BuildRequires: inotify-tools
44
45
46 BuildRequires: pkgconfig(Qt5Core)
47 BuildRequires: pkgconfig(Qt5Gui)
48 BuildRequires: pkgconfig(Qt5Network)
49 BuildRequires: pkgconfig(Qt5Concurrent)
50 BuildRequires: pkgconfig(Qt5WebKitWidgets)
51 BuildRequires: pkgconfig(Qt5WebEngineWidgets)
52 BuildRequires: pkgconfig(Qt5DBus)
53 BuildRequires: pkgconfig(Qt5Help)
54 BuildRequires: pkgconfig(Qt5Xml)
55
56 Requires: %liblibocsync = %{version}-%{release}
57 Requires: %libnextcloudsync = %{version}-%{release}
58 Provides: owncloud-client = %version-%release
59 Obsoletes: owncloud-client < 2.2.4-2
60
61 %description
62 Nextcloud-client enables you to connect to your private Nextcloud Server.
63 With it you can create folders in your home directory, and keep the contents
64 of those folders synced with your Nextcloud server. Simply copy a file into
65 the directory and the Nextcloud Client does the rest.
66
67 %files
68 %{_bindir}/nextcloud
69 %{_bindir}/nextcloudcmd
70 %{_datadir}/applications/nextcloud.desktop
71 %dir %{_datadir}/nextcloud
72 %{_datadir}/nextcloud/i18n/
73 %{_datadir}/icons/hicolor/*/apps/*
74 %{_datadir}/appdata/%{name}.appdata.xml
75 %dir %{_sysconfdir}/Nextcloud
76 %{_sysconfdir}/Nextcloud/sync-exclude.lst
77
78 #------------------------------------------------------------------------------
79
80 %package nautilus
81 Summary: nextcloud client nautilus extension
82 Requires: nautilus
83 Requires: nautilus-python
84 Requires: %{name} = %{version}-%{release}
85
86 %description nautilus
87 The nextcloud desktop client nautilus extension.
88
89 %files nautilus
90 %{_datadir}/nautilus-python/extensions/*
91
92 #------------------------------------------------------------------------------
93
94 %package nemo
95 Summary: Nemo overlay icons
96 Requires: nemo
97 Requires: nemo-python
98 Requires: %{name} = %{version}-%{release}
99
100 %description nemo
101 This package provides overlay icons to visualize the sync state
102 in the nemo file manager.
103
104 %files nemo
105 %{_datadir}/nemo-python/extensions/*
106
107 %package caja
108 Summary: Caja overlay icons
109 Requires: caja
110 Requires: python-caja
111 Requires: %{name}%{?_isa} = %{version}-%{release}
112
113 %description caja
114 This package provides overlay icons to visualize the sync state
115 in the caja file manager.
116
117 %files caja
118 %{_datadir}/caja-python/extensions/*
119 #------------------------------------------------------------------------------
120
121 %package dolphin
122 Summary: Dolphin overlay icons
123 Requires: dolphin
124 Requires: %{name} = %{version}-%{release}
125
126 %description dolphin
127 The nextcloud desktop client dolphin extension.
128
129 %files dolphin
130 %{_kf5_libdir}/libnextclouddolphinpluginhelper.so
131 %{_kf5_plugindir}/overlayicon/nextclouddolphinoverlayplugin.so
132 %{_qt5_plugindir}/nextclouddolphinactionplugin.so
133 %{_kf5_services}/nextclouddolphinactionplugin.desktop
134
135 #------------------------------------------------------------------------------
136
137
138 %package -n %libnextcloudsync
139 Summary: The Nextcloud Client Libraries
140 Group: System/Libraries
141 # From owncloud-client
142 Obsoletes: %{_lib}owncloudsync2 < 2.2.4-2
143
144 %description -n %libnextcloudsync
145 The Nextcloud Client Libraries.
146
147 %files -n %libnextcloudsync
148 %{_libdir}/libnextcloudsync.so.%nextcloudsync_major
149 %{_libdir}/libnextcloudsync.so.%version
150
151 #------------------------------------------------------------------------------
152
153 %package -n %liblibocsync
154 Summary: The Nextcloud Client Libraries
155 Group: System/Libraries
156 Obsoletes: %{_lib}libocsync0 < 2.2.4-4
157 # From owncloud-client
158 Obsoletes: %{_lib}ocsync2 < 2.2.4-2
159
160 %description -n %liblibocsync
161 The Nextcloud Client Libraries.
162
163
164 %files -n %liblibocsync
165 %dir %_libdir/nextcloud
166 %_libdir/nextcloud/libocsync.so.%{libocsync_major}
167 %_libdir/nextcloud/libocsync.so.%{version}
168
169 #------------------------------------------------------------------------------
170
171 %define develname %mklibname %{name} -d
172
173 %package -n %{develname}
174 Summary: Development files for nextcloud-client
175 License: LGPLv2+
176 Requires: %libnextcloudsync = %{version}-%{release}
177 Requires: %liblibocsync = %{version}-%{release}
178 Provides: %{name}-static = %{version}-%{release}
179 Provides: %{name}-devel = %{version}-%{release}
180 Obsoletes: %{name}-devel < 2.2.4-4
181 # From owncloud-client
182 Obsoletes: %{_lib}owncloud-client-devel < 2.2.4-2
183
184 %description -n %{develname}
185 Development headers for use of the nextcloud-client library.
186
187 %files -n %{develname}
188 %{_libdir}/libnextcloudsync.so
189 %{_includedir}/nextcloudsync/
190 %{_libdir}/libnextcloudsync.so
191 %{_libdir}/nextcloud/libocsync.so
192
193 #------------------------------------------------------------------------------
194
195 %prep
196 %setup -q -n desktop-%{version}
197 %autopatch -p1
198
199 %build
200
201 %cmake_kf5 \
202 -DCMAKE_SHARED_LINKER_FLAGS="-Wl,--as-needed" \
203 -DNO_SHIBBOLETH=1 \
204 -DCMAKE_INSTALL_PREFIX=%{_usr} \
205 -DINOTIFY_LIBRARY="%{_libdir}/libc.so"
206 %make_build
207
208
209 %install
210 %make_install -C build
211
212 #%find_lang client --with-qt
213 mkdir -p %{buildroot}%{_datadir}/appdata/
214 install -m 644 %{SOURCE2} %{buildroot}%{_datadir}/appdata/%{name}.appdata.xml
215
216
217 %check
218 appstream-util validate-relax --nonet %{buildroot}%{_datadir}/appdata/%{name}.appdata.xml
219

  ViewVC Help
Powered by ViewVC 1.1.30