/[packages]/updates/6/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/6/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1050451 - (hide annotations) (download)
Wed Sep 7 22:06:21 2016 UTC (7 years, 7 months ago) by luigiwalser
Original Path: cauldron/ruby/current/SPECS/ruby.spec
File size: 22475 byte(s)
SILENT: change rel back to 14 because this spec file is stupid
1 shlomif 893775 # Taken from the fedora ruby-2.2.3 .spec. Thanks!
2 blino 1152
3 shlomif 893775 %global major_version 2
4     %global minor_version 2
5 luigiwalser 1050409 %global teeny_version 5
6 shlomif 893775 %global major_minor_version %{major_version}.%{minor_version}
7    
8     %global ruby_version %{major_minor_version}.%{teeny_version}
9     %global ruby_release %{ruby_version}
10    
11     # Specify the named version. It has precedense to revision.
12     #%%global milestone rc1
13    
14     # Keep the revision enabled for pre-releases from SVN.
15     #%%global revision 48936
16    
17     %global ruby_archive %{name}-%{ruby_version}
18    
19     # If revision and milestone are removed/commented out, the official release build is expected.
20     %if 0%{?milestone:1}%{?revision:1} != 0
21     %global development_release %{?milestone}%{?!milestone:%{?revision:r%{revision}}}
22     %global ruby_archive %{ruby_archive}-%{?milestone}%{?!milestone:%{?revision:r%{revision}}}
23     %endif
24    
25    
26 luigiwalser 1050451 %define rel 14
27 pterjan 894460 %{!?release_string:%global release_string %mkrel %{?development_release:0.}%{rel}%{?development_release:.%{development_release}}}
28 shlomif 893775
29     %global rubygems_version 2.4.5.1
30    
31     # The RubyGems library has to stay out of Ruby directory three, since the
32     # RubyGems should be share by all Ruby implementations.
33     %global rubygems_dir %{_datadir}/rubygems
34    
35     # TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM.
36     # http://redmine.ruby-lang.org/issues/5313
37     %global irb_version %{ruby_version}
38    
39     %global bigdecimal_version 1.2.6
40     %global io_console_version 0.4.3
41     %global json_version 1.8.1
42     %global minitest_version 5.4.3
43     %global power_assert_version 0.2.2
44     %global psych_version 2.0.8
45     %global rake_version 10.4.2
46     %global rdoc_version 4.2.0
47     %global test_unit_version 3.0.8
48    
49     # Might not be needed in the future, if we are lucky enough.
50     # https://bugzilla.redhat.com/show_bug.cgi?id=888262
51     %global tapset_root %{_datadir}/systemtap
52     %global tapset_dir %{tapset_root}/tapset
53     %global tapset_libdir %(echo %{_libdir} | sed 's/64//')*
54    
55     %global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/;s/sparcv./sparc/')
56    
57     %global with_rubypick 1
58    
59     # Additional defines by Mageia.
60    
61     %define subver %{major_minor_version}
62     %define rubyapi %{subver}.0
63     %define rubyver %{ruby_version}
64    
65 fwang 291590 %define libname %mklibname ruby %{subver}
66    
67 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
68     %define ruby_libarchdir %{_libdir}/%{name}
69    
70 fwang 290007 # This is the local lib/arch and should not be used for packaging.
71 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
72     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
73 fwang 290007
74     # This is the general location for libs/archs compatible with all
75     # or most of the Ruby versions available in the Fedora repositories.
76 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
77 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
78 fwang 290007
79 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
80     # RubyGems should be shared by all Ruby implementations.
81 pterjan 894459 %define gems_dir %{_datadir}/gems
82 fwang 290007
83 pterjan 894524 %define bootstrap 0
84 pterjan 895045 %define build_gems 0
85 fwang 292558
86 blino 1152 Summary: Object Oriented Script Language
87     Name: ruby
88 shlomif 893775 Version: %{rubyver}
89 pterjan 894460 Release: %release_string
90 kamil 397518 License: Ruby or BSD
91 blino 1152 Group: Development/Ruby
92     BuildRequires: autoconf
93     BuildRequires: byacc
94 shlomif 291698 BuildRequires: doxygen
95 blino 1152 BuildRequires: ncurses-devel
96     BuildRequires: readline-devel
97 shlomif 893775 BuildRequires: tcl-devel
98 ovitters 648773 BuildRequires: tk-devel
99 fwang 276350 BuildRequires: db-devel
100 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
101 blino 1152 BuildRequires: openssl-devel
102     BuildRequires: zlib-devel
103 fwang 289987 BuildRequires: libffi-devel
104     BuildRequires: yaml-devel
105 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
106 tv 674762 Conflicts: ruby-devel < 2.0.0.p451-4.mga5
107 blino 1152 Obsoletes: ruby-rexml
108     Provides: ruby-rexml
109 pterjan 435566 # Couldn't get the standalone gem to work
110     Provides: rubygem(psych)
111 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
112     Provides: /usr/bin/ruby
113 pterjan 894480 Provides: ruby(abi) = %subver
114 shlomif 893775 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}.tar.xz
115 pterjan 435211 Source1: operating_system.rb
116 blino 1152 Source3: ruby.macros
117 tv 673709 # From FC:
118     # RPM dependency generators.
119     Source8: rubygems.attr
120     Source9: rubygems.req
121     Source10: rubygems.prov
122 shlomif 893775 URL: http://ruby-lang.org/
123 fwang 292558 %if !%bootstrap
124 fwang 293395 BuildRequires: ruby
125 fwang 292558 %endif
126 pterjan 895045 %if !%bootstrap || %build_gems
127 pterjan 894524 Requires: rubygems >= %{rubygems_version}
128     %endif
129 blino 1152
130 fwang 290007 # == FEDORA PATCHES BEGINS ==
131 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
132 shlomif 893775 Patch0: ruby-2.1.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
133     # Allows to override libruby.so placement. Hopefully we will be able to return
134     # to plain --with-rubyarchprefix.
135     # http://bugs.ruby-lang.org/issues/8973
136     Patch1: ruby-2.1.0-Enable-configuration-of-archlibdir.patch
137     # Force multiarch directories for i.86 to be always named i386. This solves
138     # some differencies in build between Fedora and RHEL.
139     Patch2: ruby-2.1.0-always-use-i386.patch
140 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
141 shlomif 893775 # http://bugs.ruby-lang.org/issues/5617
142     Patch4: ruby-2.1.0-custom-rubygems-location.patch
143 pterjan 435211 # Make mkmf verbose by default
144 shlomif 893775 Patch5: ruby-1.9.3-mkmf-verbose.patch
145     # Adds support for '--with-prelude' configuration option. This allows to built
146     # in support for ABRT.
147     # http://bugs.ruby-lang.org/issues/8566
148     Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
149 luigiwalser 1050409 # Use miniruby to regenerate prelude.c.
150     # https://bugs.ruby-lang.org/issues/10554
151     Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
152     # Ignore Europe/Moscow TZ test, which fails due to change in tzdata.
153     # https://github.com/ruby/ruby/commit/d16ff5c412b90b2766be97a5d3d689c5a18528d3
154     Patch8: ruby-2.2.6-Tests-depends-on-Europe-Moscow-removed.patch
155     # Fixes random TestRubyOptimization#test_tailcall_inhibited_by_rescue test
156     # suite failures.
157     # https://github.com/ruby/ruby/commit/cf23ad429da3213fd3b1261c546dfa08e7dba2bf
158     Patch9: ruby-2.2.6-Fix-random-test-failure-introduced-by-r54698.patch
159 fwang 290007 # == FEDORA PATCHES ENDS ==
160 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
161     # to install gems into user dir
162 blino 894359 Patch20: ruby-2.3.0-Do-not-install-to-user-dir.patch
163 fwang 290007
164 shlomif 893775 # Patch22: ruby-2.0.0-tk2.6.patch
165 luigiwalser 795834
166 fwang 291591 %package -n %{libname}
167 fwang 291590 Summary: Libraries necessary to run Ruby
168     Group: Development/Ruby
169    
170 blino 1152 %package doc
171     Summary: Documentation for the powerful language Ruby
172     Group: Development/Ruby
173 fwang 202696 BuildArch: noarch
174 blino 1152
175     %package devel
176     Summary: Development file for the powerful language Ruby
177     Group: Development/Ruby
178 fwang 311925 Requires: %{name} = %{version}
179     Requires: %{libname} = %{version}
180 blino 1152
181     %package tk
182     Summary: Tk extension for the powerful language Ruby
183     Group: Development/Ruby
184 fwang 311925 Requires: %{name} = %{version}
185 blino 1152
186 fwang 291551 %package RubyGems
187     Summary: The Ruby standard for packaging ruby libraries
188     Group: Development/Ruby
189 fwang 291590 Version: %{rubygems_version}
190 fwang 291551 Requires: ruby(abi) = %{subver}
191 fwang 291590 Provides: gem = %{rubygems_version}
192     Provides: rubygems = %{rubygems_version}
193     Provides: ruby(rubygems) = %{rubygems_version}
194 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
195 fwang 291561 BuildArch: noarch
196 fwang 291551
197 shlomif 893775 %define rake_ver %{rake_version}
198 fwang 291551 %package rake
199     Summary: Simple ruby build program with capabilities similar to make
200     Group: Development/Ruby
201 shlomif 291767 Version: %{rake_ver}
202 pterjan 894484 Provides: rubygem(rake) = %{rake_ver}
203 fwang 291551 Requires: ruby(abi) = %{subver}
204 fwang 291561 BuildArch: noarch
205 fwang 291551
206 shlomif 893775 %define minitest_ver %{minitest_version}
207 fwang 291562 %package minitest
208 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
209 fwang 291562 Group: Development/Ruby
210 shlomif 291767 Version: %{minitest_ver}
211 fwang 291562 License: MIT
212 pterjan 894484 Provides: rubygem(minitest) = %{minitest_ver}
213 fwang 291590 Requires: ruby(abi) = %{subver}
214     Requires: ruby(rubygems) >= %{rubygems_version}
215 fwang 291562 BuildArch: noarch
216    
217 pterjan 894459 %define power_assert_ver %{power_assert_version}
218     %package power_assert
219     Summary: Power Assert for Ruby
220     Group: Development/Ruby
221     Version: %{power_assert_ver}
222     License: BSD
223 pterjan 894484 Provides: rubygem(power_assert) = %{power_assert_ver}
224 pterjan 894459 Requires: ruby(abi) = %{subver}
225     Requires: ruby(rubygems) >= %{rubygems_version}
226     BuildArch: noarch
227    
228 shlomif 893775 %define json_ver %{json_version}
229 fwang 291562 %package json
230     Summary: This is a JSON implementation as a Ruby extension in C
231     Group: Development/Ruby
232 shlomif 291767 Version: %{json_ver}
233 fwang 291562 License: Ruby or GPLv2
234 pterjan 894484 Provides: rubygem(json) = %{json_ver}
235 fwang 291590 Requires: ruby(abi) = %{subver}
236     Requires: ruby(rubygems) >= %{rubygems_version}
237 fwang 291562
238 shlomif 893775 %define rdoc_ver %{rdoc_version}
239 fwang 291562 %package rdoc
240     Summary: A tool to generate HTML and command-line documentation for Ruby projects
241     Group: Development/Ruby
242 shlomif 291767 Version: %{rdoc_ver}
243 fwang 291562 License: GPLv2 and Ruby and MIT
244 pterjan 894484 Provides: rubygem(rdoc) = %{rdoc_ver}
245 fwang 291590 Requires: ruby(abi) = %{subver}
246     Requires: ruby(rubygems) >= %{rubygems_version}
247     Requires: ruby(irb) = %{version}
248 shlomif 291767 Provides: rdoc = %{rdoc_ver}
249     Provides: ri = %{rdoc_ver}
250 fwang 291562 BuildArch: noarch
251    
252 fwang 291590 %package irb
253     Summary: The Interactive Ruby
254     Group: Development/Ruby
255     Provides: irb = %{version}-%{release}
256     Provides: ruby(irb) = %{version}-%{release}
257 fwang 313459 Conflicts: ruby < 1.9
258 fwang 313460 BuildArch: noarch
259 fwang 291590
260 shlomif 893775 %define bigdecimal_ver %{bigdecimal_version}
261 fwang 291590 %package bigdecimal
262     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
263     Group: Development/Ruby
264 pterjan 435211 Version: %{bigdecimal_ver}
265 fwang 291590 License: GPL+ or Artistic
266 pterjan 894484 Provides: rubygem(bigdecimal) = %{bigdecimal_ver}
267 fwang 291590 Requires: ruby(abi) = %{subver}
268     Requires: ruby(rubygems) >= %{rubygems_version}
269    
270 shlomif 893775 %define io_console_ver %{io_console_version}
271 fwang 291590 %package io-console
272     Summary: IO/Console is a simple console utilizing library
273     Group: Development/Ruby
274 pterjan 435211 Version: %{io_console_ver}
275 pterjan 894484 Provides: rubygem(io-console) = %{io_console_ver}
276 fwang 291590 Requires: ruby(abi) = %{subver}
277     Requires: ruby(rubygems) >= %{rubygems_version}
278    
279 shlomif 893775 %define psych_ver %{psych_version}
280 pterjan 435211 %package psych
281     Summary: A libyaml wrapper for Ruby
282     Version: %{psych_ver}
283     Group: Development/Ruby
284     License: MIT
285 pterjan 894484 Provides: rubygem(psych) = %{psych_ver}
286 pterjan 435211 Requires: ruby(abi) = %{subver}
287     Requires: ruby(rubygems) >= %{rubygems_version}
288     Conflicts: ruby < 2.0.0
289    
290 shlomif 893775 %define test_unit_ver %{test_unit_version}
291 pterjan 435211 %package test-unit
292     Summary: test/unit compatible API testing framework
293 pterjan 897269 Version: %{test_unit_ver}
294 pterjan 435211 Group: Development/Ruby
295     License: MIT
296 pterjan 894484 Provides: rubygem(test-unit) = %{test_unit_ver}
297 pterjan 435211 Requires: ruby(abi) = %{subver}
298     Requires: ruby(rubygems) >= %{rubygems_version}
299     Conflicts: ruby < 2.0.0
300     BuildArch: noarch
301    
302 blino 1152 %description
303     Ruby is the interpreted scripting language for quick and
304     easy object-oriented programming. It has many features to
305     process text files and to do system management tasks (as in
306     Perl). It is simple, straight-forward, and extensible.
307    
308     %description doc
309     Ruby is the interpreted scripting language for quick and
310     easy object-oriented programming. It has many features to
311     process text files and to do system management tasks (as in
312     Perl). It is simple, straight-forward, and extensible.
313    
314     This package contains the Ruby's documentation
315    
316 fwang 291590 %description -n %{libname}
317     This package includes the libruby, necessary to run Ruby.
318    
319 blino 1152 %description devel
320     Ruby is the interpreted scripting language for quick and
321     easy object-oriented programming. It has many features to
322     process text files and to do system management tasks (as in
323     Perl). It is simple, straight-forward, and extensible.
324    
325     This package contains the Ruby's devel files.
326    
327     %description tk
328     Ruby is the interpreted scripting language for quick and
329     easy object-oriented programming. It has many features to
330     process text files and to do system management tasks (as in
331     Perl). It is simple, straight-forward, and extensible.
332    
333     This package contains the Tk extension for Ruby.
334    
335 fwang 291551 %description RubyGems
336     RubyGems is the Ruby standard for publishing and managing third party
337     libraries.
338    
339 fwang 291552 %description rake
340     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
341     specified in standard Ruby syntax.
342    
343 fwang 291562 %description rdoc
344     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
345     includes the 'rdoc' and 'ri' tools for generating and displaying online
346     documentation.
347    
348     %description json
349     This is a implementation of the JSON specification according to RFC 4627.
350     You can think of it as a low fat alternative to XML, if you want to store
351     data to disk or transmit it over a network rather than use a verbose
352     markup language.
353    
354     %description minitest
355     minitest/unit is a small and incredibly fast unit testing framework.
356    
357     minitest/spec is a functionally complete spec engine.
358    
359     minitest/benchmark is an awesome way to assert the performance of your
360     algorithms in a repeatable manner.
361    
362     minitest/mock by Steven Baker, is a beautifully tiny mock object
363     framework.
364    
365     minitest/pride shows pride in testing and adds coloring to your test
366     output.
367    
368 pterjan 894459 %description power_assert
369     Power Assert shows each value of variables and method calls in the expression.
370     It is useful for testing, providing which value wasn't correct when the
371     condition is not satisfied.
372    
373 fwang 291590 %description irb
374     The irb is acronym for Interactive Ruby. It evaluates ruby expression
375     from the terminal.
376    
377     %description bigdecimal
378     Ruby provides built-in support for arbitrary precision integer arithmetic.
379     For example:
380    
381     42**13 -> 1265437718438866624512
382    
383     BigDecimal provides similar support for very large or very accurate floating
384     point numbers. Decimal arithmetic is also useful for general calculation,
385     because it provides the correct answers people expect–whereas normal binary
386     floating point arithmetic often introduces subtle errors because of the
387     conversion between base 10 and base 2.
388    
389     %description io-console
390     IO/Console provides very simple and portable access to console. It doesn't
391     provide higher layer features, such like curses and readline.
392    
393 pterjan 435211 %description psych
394     Psych is a YAML parser and emitter. Psych leverages
395     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
396     capabilities. In addition to wrapping libyaml, Psych also knows how to
397     serialize and de-serialize most Ruby objects to and from the YAML format.
398    
399     %description test-unit
400     This library implements test/unit compatible API on minitest.
401     The test/unit means that test/unit which was bundled with Ruby 1.8.
402    
403 blino 1152 %prep
404 shlomif 893775 %setup -q -n ruby-%{rubyver}
405 pterjan 916671 %autopatch -p1
406 blino 1152
407     %build
408 fwang 290038 autoconf
409 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
410 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
411 shlomif 893775 --enable-multiarch \
412     --with-rubylibprefix='%{ruby_libdir}' \
413     --with-archlibdir='%{_libdir}' \
414 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
415 shlomif 893775 --with-sitedir='%{ruby_sitelibdir}' \
416     --with-sitearchdir='%{ruby_sitearchdir}' \
417     --with-vendordir='%{ruby_vendorlibdir}' \
418     --with-vendorarchdir='%{ruby_vendorarchdir}' \
419     --with-rubyhdrdir='%{_includedir}' \
420     --with-rubyarchhdrdir='%{_includedir}' \
421 pterjan 435211 --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
422     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
423     --with-rubygemsdir='%{rubygems_dir}' \
424     --with-ruby-pc='%{name}.pc' \
425     --enable-multiarch \
426     --with-ruby-version=''
427 blino 1152 %make
428    
429     %install
430     %makeinstall_std install-doc
431    
432     install -d %buildroot%{_datadir}/emacs/site-lisp
433     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
434    
435     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
436     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
437     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
438     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
439     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
440     EOF
441    
442 shlomif 893775 # Install the rpm macros
443 blino 1152 mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
444     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
445 fwang 289961
446 tv 673709 # Install dependency generators.
447     mkdir -p %{buildroot}%{_rpmconfigdir}/fileattrs
448     install -m 644 %{SOURCE8} %{buildroot}%{_rpmconfigdir}/fileattrs
449     install -m 755 %{SOURCE9} %{buildroot}%{_rpmconfigdir}
450     install -m 755 %{SOURCE10} %{buildroot}%{_rpmconfigdir}
451    
452 pterjan 435211 # Install custom operating_system.rb
453     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
454     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
455    
456 pterjan 617250 # Version is empty if --with-ruby-version is specified.
457     # http://bugs.ruby-lang.org/issues/7807
458     sed -i 's/Version: .*/Version: %{rubyver}/' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
459    
460 pterjan 894459 rm -f %{buildroot}%{gems_dir}/cache/{minitest,power_assert,test-unit}-*.gem
461    
462 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
463     %if !%build_gems
464 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
465 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
466 pterjan 912571 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal}{,.rb}
467     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so}
468     rm -fr %{buildroot}%{gems_dir}/specifications/{minitest-%{minitest_version},default/rake-%{rake_version},default/rdoc-%{rdoc_version},default/json-%{json_version},default/bigdecimal-%{bigdecimal_version},default/psych-%{psych_version}}.gemspec
469 pterjan 897269 rm -fr %{buildroot}%{gems_dir}/gems/{minitest-%{minitest_version},rake-%{rake_version},rdoc-%{rdoc_version}}
470 fwang 311915 %if !%bootstrap
471 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
472 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
473     rm -fr %{buildroot}%{rubygems_dir}/rubygems
474 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
475     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
476 fwang 293412 %endif
477 fwang 311914 %endif
478 fwang 293412
479 blino 1152 %check
480     make test
481    
482 fwang 289961 %files
483 fwang 291551 %{_bindir}/erb
484     %{_bindir}/ruby
485 fwang 291560 %dir %{ruby_libdir}
486     %{ruby_libdir}/*.rb
487 fwang 291590 %exclude %{ruby_libdir}/irb.rb
488 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
489     %exclude %{ruby_libdir}/remote-tk.rb
490     %exclude %{ruby_libdir}/tcltk.rb
491     %exclude %{ruby_libdir}/tk.rb
492     %exclude %{ruby_libdir}/tkafter.rb
493     %exclude %{ruby_libdir}/tkbgerror.rb
494     %exclude %{ruby_libdir}/tkcanvas.rb
495     %exclude %{ruby_libdir}/tkclass.rb
496     %exclude %{ruby_libdir}/tkconsole.rb
497     %exclude %{ruby_libdir}/tkdialog.rb
498     %exclude %{ruby_libdir}/tkentry.rb
499     %exclude %{ruby_libdir}/tkfont.rb
500     %exclude %{ruby_libdir}/tkmacpkg.rb
501     %exclude %{ruby_libdir}/tkmenubar.rb
502     %exclude %{ruby_libdir}/tkmngfocus.rb
503     %exclude %{ruby_libdir}/tkpalette.rb
504     %exclude %{ruby_libdir}/tkscrollbox.rb
505     %exclude %{ruby_libdir}/tktext.rb
506     %exclude %{ruby_libdir}/tkvirtevent.rb
507     %exclude %{ruby_libdir}/tkwinpkg.rb
508     %{ruby_libdir}/cgi
509     %{ruby_libdir}/digest
510     %{ruby_libdir}/drb
511     %{ruby_libdir}/fiddle
512     %{ruby_libdir}/matrix
513     %{ruby_libdir}/net
514     %{ruby_libdir}/openssl
515     %{ruby_libdir}/optparse
516 pterjan 435566 %{ruby_libdir}/psych
517 fwang 291560 %{ruby_libdir}/racc
518     %{ruby_libdir}/rbconfig
519     %{ruby_libdir}/rexml
520     %{ruby_libdir}/rinda
521     %{ruby_libdir}/ripper
522     %{ruby_libdir}/rss
523     %{ruby_libdir}/shell
524 pterjan 435211 %{ruby_libdir}/syslog
525 shlomif 893775 %{ruby_libdir}/unicode_normalize/normalize.rb
526     %{ruby_libdir}/unicode_normalize/tables.rb
527     %{ruby_libdir}/unicode_normalize.rb
528 fwang 291560 %{ruby_libdir}/uri
529     %{ruby_libdir}/webrick
530     %{ruby_libdir}/xmlrpc
531     %{ruby_libdir}/yaml
532     %dir %{ruby_libarchdir}
533     %{ruby_libarchdir}/continuation.so
534     %{ruby_libarchdir}/coverage.so
535     %{ruby_libarchdir}/date_core.so
536     %{ruby_libarchdir}/dbm.so
537     %dir %{ruby_libarchdir}/digest
538     %{ruby_libarchdir}/digest.so
539     %{ruby_libarchdir}/digest/*.so
540     %dir %{ruby_libarchdir}/enc
541     %{ruby_libarchdir}/enc/*.so
542 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
543     %{ruby_libarchdir}/enc/trans/*.so
544 fwang 291560 %{ruby_libarchdir}/etc.so
545     %{ruby_libarchdir}/fcntl.so
546     %{ruby_libarchdir}/fiber.so
547     %{ruby_libarchdir}/fiddle.so
548     %{ruby_libarchdir}/gdbm.so
549     %dir %{ruby_libarchdir}/io
550     %{ruby_libarchdir}/io/nonblock.so
551     %{ruby_libarchdir}/io/wait.so
552     %dir %{ruby_libarchdir}/mathn
553 fwang 291562 %{ruby_libarchdir}/mathn/*.so
554 fwang 291560 %{ruby_libarchdir}/nkf.so
555     %{ruby_libarchdir}/objspace.so
556     %{ruby_libarchdir}/openssl.so
557 pterjan 435566 %{ruby_libarchdir}/psych.so
558 fwang 291560 %{ruby_libarchdir}/pathname.so
559     %{ruby_libarchdir}/pty.so
560     %dir %{ruby_libarchdir}/racc
561     %{ruby_libarchdir}/racc/*.so
562     %{ruby_libarchdir}/rbconfig.rb
563 shlomif 893775 %{ruby_libarchdir}/rbconfig/sizeof.so
564 fwang 291560 %{ruby_libarchdir}/readline.so
565     %{ruby_libarchdir}/ripper.so
566     %{ruby_libarchdir}/sdbm.so
567     %{ruby_libarchdir}/socket.so
568     %{ruby_libarchdir}/stringio.so
569     %{ruby_libarchdir}/strscan.so
570     %{ruby_libarchdir}/syslog.so
571 shlomif 893775 %{ruby_libarchdir}/thread.so
572 fwang 291560 %{ruby_libarchdir}/zlib.so
573 fwang 291551 %{_mandir}/man1/erb.1.*
574     %{_mandir}/man1/ruby.1.*
575 blino 1152 %{_datadir}/emacs/site-lisp/*
576     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
577     %{_sysconfdir}/rpm/macros.d/%{name}.macros
578 fwang 291560 %{_datadir}/ruby/site_ruby
579     %{_libdir}/ruby/site_ruby
580     %{_datadir}/ruby/vendor_ruby
581     %{_libdir}/ruby/vendor_ruby
582 fwang 311914 %if %bootstrap
583 pterjan 894524 %if !%build_gems
584 fwang 311914 %{_bindir}/gem
585 fwang 448831 %dir %{rubygems_dir}
586     %{rubygems_dir}/rbconfig
587     %{rubygems_dir}/rubygems
588     %{rubygems_dir}/rubygems.rb
589     %{rubygems_dir}/ubygems.rb
590 fwang 311914 %endif
591 pterjan 894524 %endif
592 tv 674762 %{_rpmconfigdir}/fileattrs/rubygems.attr
593     %{_rpmconfigdir}/rubygems.req
594     %{_rpmconfigdir}/rubygems.prov
595 blino 1152
596     %files doc
597     %{_datadir}/ri
598 pterjan 435211 %{_datadir}/doc/ruby
599 blino 1152
600 fwang 291590 %files -n %{libname}
601     %{_libdir}/libruby.so.%{subver}
602     %{_libdir}/libruby.so.%{rubyapi}
603    
604 blino 1152 %files devel
605 fwang 290003 %{_includedir}/*
606 blino 1152 %{_libdir}/libruby-static.a
607     %{_libdir}/libruby.so
608 fwang 290003 %{_libdir}/pkgconfig/*.pc
609 blino 1152
610     %files tk
611 fwang 291560 %{ruby_libarchdir}/tcltklib.so
612     %{ruby_libarchdir}/tkutil.so
613     %{ruby_libdir}/multi-tk.rb
614     %{ruby_libdir}/remote-tk.rb
615     %{ruby_libdir}/tcltk.rb
616     %{ruby_libdir}/tk.rb
617     %{ruby_libdir}/tkafter.rb
618     %{ruby_libdir}/tkbgerror.rb
619     %{ruby_libdir}/tkcanvas.rb
620     %{ruby_libdir}/tkclass.rb
621     %{ruby_libdir}/tkconsole.rb
622     %{ruby_libdir}/tkdialog.rb
623     %{ruby_libdir}/tkentry.rb
624     %{ruby_libdir}/tkfont.rb
625     %{ruby_libdir}/tkmacpkg.rb
626     %{ruby_libdir}/tkmenubar.rb
627     %{ruby_libdir}/tkmngfocus.rb
628     %{ruby_libdir}/tkpalette.rb
629     %{ruby_libdir}/tkscrollbox.rb
630     %{ruby_libdir}/tktext.rb
631     %{ruby_libdir}/tkvirtevent.rb
632     %{ruby_libdir}/tkwinpkg.rb
633     %{ruby_libdir}/tk
634     %{ruby_libdir}/tkextlib
635 fwang 291551
636 fwang 293412 %files irb
637     %{_bindir}/irb
638     %{ruby_libdir}/irb.rb
639     %{ruby_libdir}/irb
640     %{_mandir}/man1/irb.1*
641    
642 pterjan 897269 %files power_assert
643     %{gems_dir}/gems/power_assert-%{power_assert_version}
644     %{gems_dir}/specifications/power_assert-%{power_assert_version}.gemspec
645    
646 pterjan 912571 %files io-console
647     %{ruby_libdir}/io
648     %{ruby_libarchdir}/io/console.so
649     %{gems_dir}/specifications/default/io-console-%{io_console_version}.gemspec
650    
651 pterjan 897269 %files test-unit
652     %{gems_dir}/gems/test-unit-*
653     %{gems_dir}/specifications/test-unit-%{test_unit_version}.gemspec
654    
655 fwang 293412 %if %build_gems
656 fwang 291551 %files RubyGems
657     %{_bindir}/gem
658     %dir %{rubygems_dir}
659     %{rubygems_dir}/rbconfig
660     %{rubygems_dir}/rubygems
661     %{rubygems_dir}/rubygems.rb
662     %{rubygems_dir}/ubygems.rb
663    
664 fwang 291562 %files minitest
665 pterjan 894459 %{gems_dir}/gems/minitest-%{minitest_version}
666     %{gems_dir}/specifications/minitest-%{minitest_version}.gemspec
667 fwang 291562
668 fwang 291551 %files rake
669     %{_bindir}/rake
670     %{_mandir}/man1/rake.1.*
671 fwang 291562 %{ruby_libdir}/rake
672 pterjan 912333 %{ruby_libdir}/rake.rb
673 pterjan 894459 %{gems_dir}/gems/rake-%{rake_version}
674     %{gems_dir}/specifications/default/rake-%{rake_version}.gemspec
675 fwang 291562
676     %files rdoc
677     %{_bindir}/rdoc
678     %{_bindir}/ri
679     %{ruby_libdir}/rdoc
680 pterjan 912333 %{ruby_libdir}/rdoc.rb
681 pterjan 894459 %{gems_dir}/gems/rdoc-%{rdoc_version}
682     %{gems_dir}/specifications/default/rdoc-%{rdoc_version}.gemspec
683 fwang 291562 %{_mandir}/man1/ri.1.*
684    
685     %files json
686     %dir %{ruby_libarchdir}/json
687     %dir %{ruby_libarchdir}/json/ext
688     %{ruby_libarchdir}/json/ext/*.so
689     %{ruby_libdir}/json
690 pterjan 894459 %{gems_dir}/specifications/default/json-%{json_version}.gemspec
691 fwang 291590
692     %files bigdecimal
693     %{ruby_libdir}/bigdecimal
694     %{ruby_libarchdir}/bigdecimal.so
695 pterjan 894459 %{gems_dir}/specifications/default/bigdecimal-%{bigdecimal_version}.gemspec
696 fwang 291590
697 pterjan 435211 %files psych
698     %{ruby_libdir}/psych
699 pterjan 912333 %{ruby_libdir}/psych.rb
700 pterjan 435211 %{ruby_libarchdir}/psych.so
701 pterjan 894459 %{gems_dir}/specifications/default/psych-%{psych_version}.gemspec
702 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30