/[packages]/updates/6/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/6/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 311916 - (hide annotations) (download)
Thu Nov 1 01:40:58 2012 UTC (11 years, 5 months ago) by fwang
Original Path: cauldron/ruby/current/SPECS/ruby.spec
File size: 15763 byte(s)
correctly remove files
1 fwang 289958 %define subver 1.9
2 fwang 290007 %define rubyapi 1.9.1
3 fwang 289958 %define rubyver 1.9.3
4 fwang 309414 %define patchversion p286
5 fwang 311872 %define rel 3
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21     # The RubyGems library has to stay out of Ruby directory three, since the
22     # RubyGems should be share by all Ruby implementations.
23 fwang 311714 %define rubygems_dir %{_datadir}/ruby/gems
24 fwang 291590 %define rubygems_version 1.8.23
25 fwang 290007
26 fwang 311914 %define bootstrap 1
27 fwang 293412 %define build_gems 0
28 fwang 292558
29 blino 1152 Summary: Object Oriented Script Language
30     Name: ruby
31     Version: %{rubyver}.%{patchversion}
32     Release: %mkrel %rel
33     License: Ruby or GPLv2
34     Group: Development/Ruby
35     BuildRequires: autoconf
36     BuildRequires: byacc
37 shlomif 291698 BuildRequires: doxygen
38 blino 1152 BuildRequires: ncurses-devel
39     BuildRequires: readline-devel
40     BuildRequires: tcl-devel tk-devel
41 fwang 276350 BuildRequires: db-devel
42 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
43 blino 1152 BuildRequires: openssl-devel
44     BuildRequires: zlib-devel
45 fwang 289987 BuildRequires: libffi-devel
46     BuildRequires: yaml-devel
47 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
48 blino 1152 Obsoletes: ruby-rexml
49     Provides: ruby-rexml
50     # explicit file provides (since such requires are automatically added by find-requires)
51     Provides: /usr/bin/ruby
52 fwang 293445 Provides: ruby(abi) = %rubyapi
53 blino 1152
54 fwang 289958 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
55 blino 1152 Source3: ruby.macros
56     URL: http://www.ruby-lang.org/
57 fwang 292558 %if !%bootstrap
58     Requires: rubygems >= %{rubygems_version}
59 fwang 293395 BuildRequires: ruby
60 fwang 292558 %endif
61 blino 1152
62 fwang 290007 # == FEDORA PATCHES BEGINS ==
63     # http://redmine.ruby-lang.org/issues/5231
64     Patch0: ruby-1.9.3-disable-versioned-paths.patch
65     # TODO: Should be submitted upstream?
66     Patch1: ruby-1.9.3-arch-specific-dir.patch
67     # http://redmine.ruby-lang.org/issues/5281
68     Patch2: ruby-1.9.3-added-site-and-vendor-arch-flags.patch
69     # http://redmine.ruby-lang.org/issues/5465
70     Patch4: ruby-1.9.3-fix-s390x-build.patch
71     # Fix the uninstaller, so that it doesn't say that gem doesn't exist
72     # when it exists outside of the GEM_HOME (already fixed in the upstream)
73     Patch5: ruby-1.9.3-rubygems-1.8.11-uninstaller.patch
74     # Already fixed upstream:
75     # https://github.com/ruby/ruby/commit/f212df564a4e1025f9fb019ce727022a97bfff53
76     Patch7: ruby-1.9.3-bignum-test-fix.patch
77     # Allows to install RubyGems into custom directory, outside of Ruby's tree.
78     # http://redmine.ruby-lang.org/issues/5617
79     Patch8: ruby-1.9.3-custom-rubygems-location.patch
80     # Add support for installing binary extensions according to FHS.
81     # https://github.com/rubygems/rubygems/issues/210
82     Patch9: rubygems-1.8.11-binary-extensions.patch
83     # == FEDORA PATCHES ENDS ==
84    
85 fwang 291591 %package -n %{libname}
86 fwang 291590 Summary: Libraries necessary to run Ruby
87     Group: Development/Ruby
88    
89 blino 1152 %package doc
90     Summary: Documentation for the powerful language Ruby
91     Group: Development/Ruby
92 fwang 202696 BuildArch: noarch
93 blino 1152
94     %package devel
95     Summary: Development file for the powerful language Ruby
96     Group: Development/Ruby
97 fwang 291590 Requires: %{name} = %{epoch}:%{version}
98     Requires: %{libname} = %{epoch}:%{version}
99 blino 1152
100     %package tk
101     Summary: Tk extension for the powerful language Ruby
102     Group: Development/Ruby
103 fwang 291590 Requires: %{name} = %{epoch}:%{version}
104 blino 1152
105 fwang 291551 %package RubyGems
106     Summary: The Ruby standard for packaging ruby libraries
107     Group: Development/Ruby
108 fwang 291590 Version: %{rubygems_version}
109 fwang 291551 Requires: ruby(abi) = %{subver}
110 fwang 291590 Provides: gem = %{rubygems_version}
111     Provides: rubygems = %{rubygems_version}
112     Provides: ruby(rubygems) = %{rubygems_version}
113 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
114 fwang 291561 BuildArch: noarch
115 fwang 291551
116 fwang 292839 %define rake_ver 0.9.2.2
117 fwang 291551 %package rake
118     Summary: Simple ruby build program with capabilities similar to make
119     Group: Development/Ruby
120 shlomif 291767 Version: %{rake_ver}
121 fwang 291551 Requires: ruby(abi) = %{subver}
122 shlomif 291767 Provides: rubygem(rake) = %{rake_ver}
123 fwang 291561 BuildArch: noarch
124 fwang 291551
125 shlomif 291767 %define minitest_ver 2.5.1
126 fwang 291562 %package minitest
127 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
128 fwang 291562 Group: Development/Ruby
129 shlomif 291767 Version: %{minitest_ver}
130 fwang 291562 License: MIT
131 fwang 291590 Requires: ruby(abi) = %{subver}
132     Requires: ruby(rubygems) >= %{rubygems_version}
133 shlomif 291767 Provides: rubygem(minitest) = %{minitest_ver}
134 fwang 291562 BuildArch: noarch
135    
136 shlomif 291767 %define json_ver 1.5.4
137 fwang 291562 %package json
138     Summary: This is a JSON implementation as a Ruby extension in C
139     Group: Development/Ruby
140 shlomif 291767 Version: %{json_ver}
141 fwang 291562 License: Ruby or GPLv2
142 fwang 291590 Requires: ruby(abi) = %{subver}
143     Requires: ruby(rubygems) >= %{rubygems_version}
144 shlomif 291767 Provides: rubygem(json) = %{json_ver}
145 fwang 291562
146 shlomif 291767 %define rdoc_ver 3.9.4
147 fwang 291562 %package rdoc
148     Summary: A tool to generate HTML and command-line documentation for Ruby projects
149     Group: Development/Ruby
150 shlomif 291767 Version: %{rdoc_ver}
151 fwang 291562 License: GPLv2 and Ruby and MIT
152 fwang 291590 Requires: ruby(abi) = %{subver}
153     Requires: ruby(rubygems) >= %{rubygems_version}
154     Requires: ruby(irb) = %{version}
155 shlomif 291767 Provides: rdoc = %{rdoc_ver}
156     Provides: ri = %{rdoc_ver}
157 fwang 291562 BuildArch: noarch
158    
159 fwang 291590 %package irb
160     Summary: The Interactive Ruby
161     Group: Development/Ruby
162     Provides: irb = %{version}-%{release}
163     Provides: ruby(irb) = %{version}-%{release}
164     BuildArch: noarch
165    
166     %package bigdecimal
167     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
168     Group: Development/Ruby
169     Version: 1.1.0
170     License: GPL+ or Artistic
171     Requires: ruby(abi) = %{subver}
172     Requires: ruby(rubygems) >= %{rubygems_version}
173     Provides: rubygem(bigdecimal) = 1.1.0
174    
175     %package io-console
176     Summary: IO/Console is a simple console utilizing library
177     Group: Development/Ruby
178     Version: 0.3
179     Requires: ruby(abi) = %{subver}
180     Requires: ruby(rubygems) >= %{rubygems_version}
181     Provides: rubygem(io-console) = 0.3
182    
183 blino 1152 %description
184     Ruby is the interpreted scripting language for quick and
185     easy object-oriented programming. It has many features to
186     process text files and to do system management tasks (as in
187     Perl). It is simple, straight-forward, and extensible.
188    
189     %description doc
190     Ruby is the interpreted scripting language for quick and
191     easy object-oriented programming. It has many features to
192     process text files and to do system management tasks (as in
193     Perl). It is simple, straight-forward, and extensible.
194    
195     This package contains the Ruby's documentation
196    
197 fwang 291590 %description -n %{libname}
198     This package includes the libruby, necessary to run Ruby.
199    
200 blino 1152 %description devel
201     Ruby is the interpreted scripting language for quick and
202     easy object-oriented programming. It has many features to
203     process text files and to do system management tasks (as in
204     Perl). It is simple, straight-forward, and extensible.
205    
206     This package contains the Ruby's devel files.
207    
208     %description tk
209     Ruby is the interpreted scripting language for quick and
210     easy object-oriented programming. It has many features to
211     process text files and to do system management tasks (as in
212     Perl). It is simple, straight-forward, and extensible.
213    
214     This package contains the Tk extension for Ruby.
215    
216 fwang 291551 %description RubyGems
217     RubyGems is the Ruby standard for publishing and managing third party
218     libraries.
219    
220 fwang 291552 %description rake
221     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
222     specified in standard Ruby syntax.
223    
224 fwang 291562 %description rdoc
225     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
226     includes the 'rdoc' and 'ri' tools for generating and displaying online
227     documentation.
228    
229     %description json
230     This is a implementation of the JSON specification according to RFC 4627.
231     You can think of it as a low fat alternative to XML, if you want to store
232     data to disk or transmit it over a network rather than use a verbose
233     markup language.
234    
235     %description minitest
236     minitest/unit is a small and incredibly fast unit testing framework.
237    
238     minitest/spec is a functionally complete spec engine.
239    
240     minitest/benchmark is an awesome way to assert the performance of your
241     algorithms in a repeatable manner.
242    
243     minitest/mock by Steven Baker, is a beautifully tiny mock object
244     framework.
245    
246     minitest/pride shows pride in testing and adds coloring to your test
247     output.
248    
249 fwang 291590 %description irb
250     The irb is acronym for Interactive Ruby. It evaluates ruby expression
251     from the terminal.
252    
253     %description bigdecimal
254     Ruby provides built-in support for arbitrary precision integer arithmetic.
255     For example:
256    
257     42**13 -> 1265437718438866624512
258    
259     BigDecimal provides similar support for very large or very accurate floating
260     point numbers. Decimal arithmetic is also useful for general calculation,
261     because it provides the correct answers people expect–whereas normal binary
262     floating point arithmetic often introduces subtle errors because of the
263     conversion between base 10 and base 2.
264    
265     %description io-console
266     IO/Console provides very simple and portable access to console. It doesn't
267     provide higher layer features, such like curses and readline.
268    
269 blino 1152 %prep
270     %setup -q -n ruby-%{rubyver}-%{patchversion}
271 fwang 290007 %apply_patches
272 blino 1152
273     %build
274 fwang 290038 autoconf
275 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
276 fwang 291557 %configure2_5x --enable-shared --disable-rpath --enable-pthread --disable-versioned-paths \
277     --with-rubylibprefix='%{ruby_libdir}' \
278     --with-archdir='%{ruby_libarchdir}' \
279 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
280     --with-sitearchdir='%{ruby_sitearchdir}' \
281     --with-vendordir='%{ruby_vendorlibdir}' \
282     --with-vendorarchdir='%{ruby_vendorarchdir}' \
283 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
284 fwang 293412 --with-rubygemsdir='%{rubygems_dir}'
285 blino 1152 %make
286    
287     %install
288     %makeinstall_std install-doc
289    
290     install -d %buildroot%{_datadir}/emacs/site-lisp
291     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
292    
293     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
294     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
295     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
296     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
297     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
298     EOF
299    
300     # Install the rpm macros
301     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
302     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
303 fwang 289961
304 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
305     %if !%build_gems
306 fwang 311914 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri}
307 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
308 fwang 293415 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io}
309     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
310 fwang 311916 rm -fr %{buildroot}%{rubygems_dir}/%{rubyapi}
311 fwang 311915 %if !%bootstrap
312 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
313     rm -f %{buildroot}%{rubygems_dir}/rbconfig
314     rm -f %{buildroot}%{rubygems_dir}/rubygems
315     rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
316     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
317 fwang 293412 %endif
318 fwang 311914 %endif
319 fwang 293412
320 blino 1152 %check
321     make test
322    
323 fwang 289961 %files
324 fwang 291551 %{_bindir}/erb
325     %{_bindir}/ruby
326     %{_bindir}/testrb
327 fwang 291560 %dir %{ruby_libdir}
328     %{ruby_libdir}/*.rb
329 fwang 291590 %exclude %{ruby_libdir}/irb.rb
330 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
331     %exclude %{ruby_libdir}/remote-tk.rb
332     %exclude %{ruby_libdir}/tcltk.rb
333     %exclude %{ruby_libdir}/tk.rb
334     %exclude %{ruby_libdir}/tkafter.rb
335     %exclude %{ruby_libdir}/tkbgerror.rb
336     %exclude %{ruby_libdir}/tkcanvas.rb
337     %exclude %{ruby_libdir}/tkclass.rb
338     %exclude %{ruby_libdir}/tkconsole.rb
339     %exclude %{ruby_libdir}/tkdialog.rb
340     %exclude %{ruby_libdir}/tkentry.rb
341     %exclude %{ruby_libdir}/tkfont.rb
342     %exclude %{ruby_libdir}/tkmacpkg.rb
343     %exclude %{ruby_libdir}/tkmenubar.rb
344     %exclude %{ruby_libdir}/tkmngfocus.rb
345     %exclude %{ruby_libdir}/tkpalette.rb
346     %exclude %{ruby_libdir}/tkscrollbox.rb
347     %exclude %{ruby_libdir}/tktext.rb
348     %exclude %{ruby_libdir}/tkvirtevent.rb
349     %exclude %{ruby_libdir}/tkwinpkg.rb
350     %{ruby_libdir}/cgi
351     %{ruby_libdir}/date
352     %{ruby_libdir}/digest
353     %{ruby_libdir}/dl
354     %{ruby_libdir}/drb
355     %{ruby_libdir}/fiddle
356     %{ruby_libdir}/matrix
357     %{ruby_libdir}/net
358     %{ruby_libdir}/openssl
359     %{ruby_libdir}/optparse
360     %{ruby_libdir}/psych
361     %{ruby_libdir}/racc
362     %{ruby_libdir}/rbconfig
363     %{ruby_libdir}/rexml
364     %{ruby_libdir}/rinda
365     %{ruby_libdir}/ripper
366     %{ruby_libdir}/rss
367     %{ruby_libdir}/shell
368     %{ruby_libdir}/syck
369     %{ruby_libdir}/test
370     %{ruby_libdir}/uri
371     %{ruby_libdir}/webrick
372     %{ruby_libdir}/xmlrpc
373     %{ruby_libdir}/yaml
374     %dir %{ruby_libarchdir}
375     %{ruby_libarchdir}/continuation.so
376     %{ruby_libarchdir}/coverage.so
377     %{ruby_libarchdir}/curses.so
378     %{ruby_libarchdir}/date_core.so
379     %{ruby_libarchdir}/dbm.so
380     %dir %{ruby_libarchdir}/digest
381     %{ruby_libarchdir}/digest.so
382     %{ruby_libarchdir}/digest/*.so
383     %dir %{ruby_libarchdir}/dl
384     %{ruby_libarchdir}/dl.so
385     %{ruby_libarchdir}/dl/*.so
386     %dir %{ruby_libarchdir}/enc
387     %{ruby_libarchdir}/enc/*.so
388 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
389     %{ruby_libarchdir}/enc/trans/*.so
390 fwang 291560 %{ruby_libarchdir}/etc.so
391     %{ruby_libarchdir}/fcntl.so
392     %{ruby_libarchdir}/fiber.so
393     %{ruby_libarchdir}/fiddle.so
394     %{ruby_libarchdir}/gdbm.so
395     %{ruby_libarchdir}/iconv.so
396     %dir %{ruby_libarchdir}/io
397     %{ruby_libarchdir}/io/nonblock.so
398     %{ruby_libarchdir}/io/wait.so
399     %dir %{ruby_libarchdir}/mathn
400 fwang 291562 %{ruby_libarchdir}/mathn/*.so
401 fwang 291560 %{ruby_libarchdir}/nkf.so
402     %{ruby_libarchdir}/objspace.so
403     %{ruby_libarchdir}/openssl.so
404     %{ruby_libarchdir}/pathname.so
405     %{ruby_libarchdir}/psych.so
406     %{ruby_libarchdir}/pty.so
407     %dir %{ruby_libarchdir}/racc
408     %{ruby_libarchdir}/racc/*.so
409     %{ruby_libarchdir}/rbconfig.rb
410     %{ruby_libarchdir}/readline.so
411     %{ruby_libarchdir}/ripper.so
412     %{ruby_libarchdir}/sdbm.so
413     %{ruby_libarchdir}/socket.so
414     %{ruby_libarchdir}/stringio.so
415     %{ruby_libarchdir}/strscan.so
416     %{ruby_libarchdir}/syck.so
417     %{ruby_libarchdir}/syslog.so
418     %{ruby_libarchdir}/zlib.so
419 fwang 291551 %{_mandir}/man1/erb.1.*
420     %{_mandir}/man1/ruby.1.*
421 blino 1152 %{_datadir}/emacs/site-lisp/*
422     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
423     %{_sysconfdir}/rpm/macros.d/%{name}.macros
424 fwang 291560 %{_datadir}/ruby/site_ruby
425     %{_libdir}/ruby/site_ruby
426     %{_datadir}/ruby/vendor_ruby
427     %{_libdir}/ruby/vendor_ruby
428 fwang 311914 %if %bootstrap
429     %{_bindir}/gem
430     %dir %{rubygems_dir}
431     %{rubygems_dir}/rbconfig
432     %{rubygems_dir}/rubygems
433     %{rubygems_dir}/rubygems.rb
434     %{rubygems_dir}/ubygems.rb
435     %endif
436 blino 1152
437     %files doc
438     %{_datadir}/ri
439 shlomif 291698 %{_datadir}/doc/ruby/html/*
440 blino 1152
441 fwang 291590 %files -n %{libname}
442     %{_libdir}/libruby.so.%{subver}
443     %{_libdir}/libruby.so.%{rubyapi}
444    
445 blino 1152 %files devel
446 fwang 290003 %{_includedir}/*
447 blino 1152 %{_libdir}/libruby-static.a
448     %{_libdir}/libruby.so
449 fwang 290003 %{_libdir}/pkgconfig/*.pc
450 blino 1152
451     %files tk
452 fwang 291560 %{ruby_libarchdir}/tcltklib.so
453     %{ruby_libarchdir}/tkutil.so
454     %{ruby_libdir}/multi-tk.rb
455     %{ruby_libdir}/remote-tk.rb
456     %{ruby_libdir}/tcltk.rb
457     %{ruby_libdir}/tk.rb
458     %{ruby_libdir}/tkafter.rb
459     %{ruby_libdir}/tkbgerror.rb
460     %{ruby_libdir}/tkcanvas.rb
461     %{ruby_libdir}/tkclass.rb
462     %{ruby_libdir}/tkconsole.rb
463     %{ruby_libdir}/tkdialog.rb
464     %{ruby_libdir}/tkentry.rb
465     %{ruby_libdir}/tkfont.rb
466     %{ruby_libdir}/tkmacpkg.rb
467     %{ruby_libdir}/tkmenubar.rb
468     %{ruby_libdir}/tkmngfocus.rb
469     %{ruby_libdir}/tkpalette.rb
470     %{ruby_libdir}/tkscrollbox.rb
471     %{ruby_libdir}/tktext.rb
472     %{ruby_libdir}/tkvirtevent.rb
473     %{ruby_libdir}/tkwinpkg.rb
474     %{ruby_libdir}/tk
475     %{ruby_libdir}/tkextlib
476 fwang 291551
477 fwang 293412 %files irb
478     %{_bindir}/irb
479     %{ruby_libdir}/irb.rb
480     %{ruby_libdir}/irb
481     %{_mandir}/man1/irb.1*
482    
483     %if %build_gems
484 fwang 291551 %files RubyGems
485     %{_bindir}/gem
486     %dir %{rubygems_dir}
487     %{rubygems_dir}/rbconfig
488     %{rubygems_dir}/rubygems
489     %{rubygems_dir}/rubygems.rb
490     %{rubygems_dir}/ubygems.rb
491    
492 fwang 291562 %files minitest
493     %{ruby_libdir}/minitest
494 fwang 291563 %{rubygems_dir}/%{rubyapi}/specifications/minitest-*.gemspec
495 fwang 291562
496 fwang 291551 %files rake
497     %{_bindir}/rake
498     %{_mandir}/man1/rake.1.*
499 fwang 291562 %{ruby_libdir}/rake
500 fwang 291563 %{rubygems_dir}/%{rubyapi}/gems/rake-*
501 fwang 291590 %{rubygems_dir}/%{rubyapi}/specifications/rake-*.gemspec
502 fwang 291562
503     %files rdoc
504     %{_bindir}/rdoc
505     %{_bindir}/ri
506     %{ruby_libdir}/rdoc
507 fwang 291563 %{rubygems_dir}/%{rubyapi}/gems/rdoc-*
508     %{rubygems_dir}/%{rubyapi}/specifications/rdoc-*.gemspec
509 fwang 291562 %{_mandir}/man1/ri.1.*
510    
511     %files json
512     %dir %{ruby_libarchdir}/json
513     %dir %{ruby_libarchdir}/json/ext
514     %{ruby_libarchdir}/json/ext/*.so
515     %{ruby_libdir}/json
516 fwang 291563 %{rubygems_dir}/%{rubyapi}/specifications/json-*.gemspec
517 fwang 291590
518     %files bigdecimal
519     %{ruby_libdir}/bigdecimal
520     %{ruby_libarchdir}/bigdecimal.so
521 shlomif 291732 %{rubygems_dir}/%{rubyapi}/specifications/bigdecimal-*.gemspec
522 fwang 291590
523     %files io-console
524     %{ruby_libdir}/io
525     %{ruby_libarchdir}/io/console.so
526 shlomif 291732 %{rubygems_dir}/%{rubyapi}/specifications/io-console-*.gemspec
527 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30