/[packages]/updates/6/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/6/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 395696 - (hide annotations) (download)
Fri Feb 8 15:45:16 2013 UTC (11 years, 2 months ago) by umeabot
Original Path: cauldron/ruby/current/SPECS/ruby.spec
File size: 15944 byte(s)
Rebuild for CVE-2013-0256
1 fwang 289958 %define subver 1.9
2 fwang 290007 %define rubyapi 1.9.1
3 fwang 289958 %define rubyver 1.9.3
4 fwang 389324 %define patchversion p374
5 umeabot 395696 %define rel 4
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21     # The RubyGems library has to stay out of Ruby directory three, since the
22     # RubyGems should be share by all Ruby implementations.
23 fwang 311714 %define rubygems_dir %{_datadir}/ruby/gems
24 fwang 291590 %define rubygems_version 1.8.23
25 fwang 290007
26 fwang 311923 %define bootstrap 0
27 fwang 293412 %define build_gems 0
28 fwang 292558
29 blino 1152 Summary: Object Oriented Script Language
30     Name: ruby
31     Version: %{rubyver}.%{patchversion}
32     Release: %mkrel %rel
33     License: Ruby or GPLv2
34     Group: Development/Ruby
35     BuildRequires: autoconf
36     BuildRequires: byacc
37 shlomif 291698 BuildRequires: doxygen
38 blino 1152 BuildRequires: ncurses-devel
39     BuildRequires: readline-devel
40     BuildRequires: tcl-devel tk-devel
41 fwang 276350 BuildRequires: db-devel
42 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
43 blino 1152 BuildRequires: openssl-devel
44     BuildRequires: zlib-devel
45 fwang 289987 BuildRequires: libffi-devel
46     BuildRequires: yaml-devel
47 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
48 blino 1152 Obsoletes: ruby-rexml
49     Provides: ruby-rexml
50     # explicit file provides (since such requires are automatically added by find-requires)
51     Provides: /usr/bin/ruby
52 fwang 293445 Provides: ruby(abi) = %rubyapi
53 blino 1152
54 fwang 289958 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
55 blino 1152 Source3: ruby.macros
56     URL: http://www.ruby-lang.org/
57 fwang 292558 %if !%bootstrap
58     Requires: rubygems >= %{rubygems_version}
59 fwang 293395 BuildRequires: ruby
60 fwang 292558 %endif
61 blino 1152
62 fwang 290007 # == FEDORA PATCHES BEGINS ==
63     # http://redmine.ruby-lang.org/issues/5231
64     Patch0: ruby-1.9.3-disable-versioned-paths.patch
65     # TODO: Should be submitted upstream?
66     Patch1: ruby-1.9.3-arch-specific-dir.patch
67     # http://redmine.ruby-lang.org/issues/5281
68     Patch2: ruby-1.9.3-added-site-and-vendor-arch-flags.patch
69     # http://redmine.ruby-lang.org/issues/5465
70     Patch4: ruby-1.9.3-fix-s390x-build.patch
71     # Fix the uninstaller, so that it doesn't say that gem doesn't exist
72     # when it exists outside of the GEM_HOME (already fixed in the upstream)
73     Patch5: ruby-1.9.3-rubygems-1.8.11-uninstaller.patch
74     # Already fixed upstream:
75     # https://github.com/ruby/ruby/commit/f212df564a4e1025f9fb019ce727022a97bfff53
76     Patch7: ruby-1.9.3-bignum-test-fix.patch
77     # Allows to install RubyGems into custom directory, outside of Ruby's tree.
78     # http://redmine.ruby-lang.org/issues/5617
79     Patch8: ruby-1.9.3-custom-rubygems-location.patch
80     # Add support for installing binary extensions according to FHS.
81     # https://github.com/rubygems/rubygems/issues/210
82     Patch9: rubygems-1.8.11-binary-extensions.patch
83     # == FEDORA PATCHES ENDS ==
84 pterjan 391153 # Try to fix parallel build
85     Patch10: ruby-1.9.3-mkmf-parallel-install.patch
86 fwang 394856 Patch11: rdoc-cve-2013-0256.patch
87 fwang 290007
88 fwang 291591 %package -n %{libname}
89 fwang 291590 Summary: Libraries necessary to run Ruby
90     Group: Development/Ruby
91    
92 blino 1152 %package doc
93     Summary: Documentation for the powerful language Ruby
94     Group: Development/Ruby
95 fwang 202696 BuildArch: noarch
96 blino 1152
97     %package devel
98     Summary: Development file for the powerful language Ruby
99     Group: Development/Ruby
100 fwang 311925 Requires: %{name} = %{version}
101     Requires: %{libname} = %{version}
102 blino 1152
103     %package tk
104     Summary: Tk extension for the powerful language Ruby
105     Group: Development/Ruby
106 fwang 311925 Requires: %{name} = %{version}
107 blino 1152
108 fwang 291551 %package RubyGems
109     Summary: The Ruby standard for packaging ruby libraries
110     Group: Development/Ruby
111 fwang 291590 Version: %{rubygems_version}
112 fwang 291551 Requires: ruby(abi) = %{subver}
113 fwang 291590 Provides: gem = %{rubygems_version}
114     Provides: rubygems = %{rubygems_version}
115     Provides: ruby(rubygems) = %{rubygems_version}
116 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
117 fwang 291561 BuildArch: noarch
118 fwang 291551
119 fwang 292839 %define rake_ver 0.9.2.2
120 fwang 291551 %package rake
121     Summary: Simple ruby build program with capabilities similar to make
122     Group: Development/Ruby
123 shlomif 291767 Version: %{rake_ver}
124 fwang 291551 Requires: ruby(abi) = %{subver}
125 shlomif 291767 Provides: rubygem(rake) = %{rake_ver}
126 fwang 291561 BuildArch: noarch
127 fwang 291551
128 shlomif 291767 %define minitest_ver 2.5.1
129 fwang 291562 %package minitest
130 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
131 fwang 291562 Group: Development/Ruby
132 shlomif 291767 Version: %{minitest_ver}
133 fwang 291562 License: MIT
134 fwang 291590 Requires: ruby(abi) = %{subver}
135     Requires: ruby(rubygems) >= %{rubygems_version}
136 shlomif 291767 Provides: rubygem(minitest) = %{minitest_ver}
137 fwang 291562 BuildArch: noarch
138    
139 shlomif 291767 %define json_ver 1.5.4
140 fwang 291562 %package json
141     Summary: This is a JSON implementation as a Ruby extension in C
142     Group: Development/Ruby
143 shlomif 291767 Version: %{json_ver}
144 fwang 291562 License: Ruby or GPLv2
145 fwang 291590 Requires: ruby(abi) = %{subver}
146     Requires: ruby(rubygems) >= %{rubygems_version}
147 shlomif 291767 Provides: rubygem(json) = %{json_ver}
148 fwang 291562
149 shlomif 291767 %define rdoc_ver 3.9.4
150 fwang 291562 %package rdoc
151     Summary: A tool to generate HTML and command-line documentation for Ruby projects
152     Group: Development/Ruby
153 shlomif 291767 Version: %{rdoc_ver}
154 fwang 291562 License: GPLv2 and Ruby and MIT
155 fwang 291590 Requires: ruby(abi) = %{subver}
156     Requires: ruby(rubygems) >= %{rubygems_version}
157     Requires: ruby(irb) = %{version}
158 shlomif 291767 Provides: rdoc = %{rdoc_ver}
159     Provides: ri = %{rdoc_ver}
160 fwang 291562 BuildArch: noarch
161    
162 fwang 291590 %package irb
163     Summary: The Interactive Ruby
164     Group: Development/Ruby
165     Provides: irb = %{version}-%{release}
166     Provides: ruby(irb) = %{version}-%{release}
167 fwang 313459 Conflicts: ruby < 1.9
168 fwang 313460 BuildArch: noarch
169 fwang 291590
170     %package bigdecimal
171     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
172     Group: Development/Ruby
173     Version: 1.1.0
174     License: GPL+ or Artistic
175     Requires: ruby(abi) = %{subver}
176     Requires: ruby(rubygems) >= %{rubygems_version}
177     Provides: rubygem(bigdecimal) = 1.1.0
178    
179     %package io-console
180     Summary: IO/Console is a simple console utilizing library
181     Group: Development/Ruby
182     Version: 0.3
183     Requires: ruby(abi) = %{subver}
184     Requires: ruby(rubygems) >= %{rubygems_version}
185     Provides: rubygem(io-console) = 0.3
186    
187 blino 1152 %description
188     Ruby is the interpreted scripting language for quick and
189     easy object-oriented programming. It has many features to
190     process text files and to do system management tasks (as in
191     Perl). It is simple, straight-forward, and extensible.
192    
193     %description doc
194     Ruby is the interpreted scripting language for quick and
195     easy object-oriented programming. It has many features to
196     process text files and to do system management tasks (as in
197     Perl). It is simple, straight-forward, and extensible.
198    
199     This package contains the Ruby's documentation
200    
201 fwang 291590 %description -n %{libname}
202     This package includes the libruby, necessary to run Ruby.
203    
204 blino 1152 %description devel
205     Ruby is the interpreted scripting language for quick and
206     easy object-oriented programming. It has many features to
207     process text files and to do system management tasks (as in
208     Perl). It is simple, straight-forward, and extensible.
209    
210     This package contains the Ruby's devel files.
211    
212     %description tk
213     Ruby is the interpreted scripting language for quick and
214     easy object-oriented programming. It has many features to
215     process text files and to do system management tasks (as in
216     Perl). It is simple, straight-forward, and extensible.
217    
218     This package contains the Tk extension for Ruby.
219    
220 fwang 291551 %description RubyGems
221     RubyGems is the Ruby standard for publishing and managing third party
222     libraries.
223    
224 fwang 291552 %description rake
225     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
226     specified in standard Ruby syntax.
227    
228 fwang 291562 %description rdoc
229     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
230     includes the 'rdoc' and 'ri' tools for generating and displaying online
231     documentation.
232    
233     %description json
234     This is a implementation of the JSON specification according to RFC 4627.
235     You can think of it as a low fat alternative to XML, if you want to store
236     data to disk or transmit it over a network rather than use a verbose
237     markup language.
238    
239     %description minitest
240     minitest/unit is a small and incredibly fast unit testing framework.
241    
242     minitest/spec is a functionally complete spec engine.
243    
244     minitest/benchmark is an awesome way to assert the performance of your
245     algorithms in a repeatable manner.
246    
247     minitest/mock by Steven Baker, is a beautifully tiny mock object
248     framework.
249    
250     minitest/pride shows pride in testing and adds coloring to your test
251     output.
252    
253 fwang 291590 %description irb
254     The irb is acronym for Interactive Ruby. It evaluates ruby expression
255     from the terminal.
256    
257     %description bigdecimal
258     Ruby provides built-in support for arbitrary precision integer arithmetic.
259     For example:
260    
261     42**13 -> 1265437718438866624512
262    
263     BigDecimal provides similar support for very large or very accurate floating
264     point numbers. Decimal arithmetic is also useful for general calculation,
265     because it provides the correct answers people expect–whereas normal binary
266     floating point arithmetic often introduces subtle errors because of the
267     conversion between base 10 and base 2.
268    
269     %description io-console
270     IO/Console provides very simple and portable access to console. It doesn't
271     provide higher layer features, such like curses and readline.
272    
273 blino 1152 %prep
274     %setup -q -n ruby-%{rubyver}-%{patchversion}
275 fwang 290007 %apply_patches
276 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
277     rm lib/mkmf.rb.0*
278 blino 1152
279     %build
280 fwang 290038 autoconf
281 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
282 fwang 291557 %configure2_5x --enable-shared --disable-rpath --enable-pthread --disable-versioned-paths \
283     --with-rubylibprefix='%{ruby_libdir}' \
284     --with-archdir='%{ruby_libarchdir}' \
285 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
286     --with-sitearchdir='%{ruby_sitearchdir}' \
287     --with-vendordir='%{ruby_vendorlibdir}' \
288     --with-vendorarchdir='%{ruby_vendorarchdir}' \
289 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
290 fwang 293412 --with-rubygemsdir='%{rubygems_dir}'
291 blino 1152 %make
292    
293     %install
294     %makeinstall_std install-doc
295    
296     install -d %buildroot%{_datadir}/emacs/site-lisp
297     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
298    
299     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
300     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
301     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
302     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
303     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
304     EOF
305    
306     # Install the rpm macros
307     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
308     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
309 fwang 289961
310 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
311     %if !%build_gems
312 fwang 311914 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri}
313 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
314 fwang 293415 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io}
315     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
316 fwang 311916 rm -fr %{buildroot}%{rubygems_dir}/%{rubyapi}
317 fwang 311915 %if !%bootstrap
318 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
319 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
320     rm -fr %{buildroot}%{rubygems_dir}/rubygems
321 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
322     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
323 fwang 293412 %endif
324 fwang 311914 %endif
325 fwang 293412
326 blino 1152 %check
327     make test
328    
329 fwang 289961 %files
330 fwang 291551 %{_bindir}/erb
331     %{_bindir}/ruby
332     %{_bindir}/testrb
333 fwang 291560 %dir %{ruby_libdir}
334     %{ruby_libdir}/*.rb
335 fwang 291590 %exclude %{ruby_libdir}/irb.rb
336 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
337     %exclude %{ruby_libdir}/remote-tk.rb
338     %exclude %{ruby_libdir}/tcltk.rb
339     %exclude %{ruby_libdir}/tk.rb
340     %exclude %{ruby_libdir}/tkafter.rb
341     %exclude %{ruby_libdir}/tkbgerror.rb
342     %exclude %{ruby_libdir}/tkcanvas.rb
343     %exclude %{ruby_libdir}/tkclass.rb
344     %exclude %{ruby_libdir}/tkconsole.rb
345     %exclude %{ruby_libdir}/tkdialog.rb
346     %exclude %{ruby_libdir}/tkentry.rb
347     %exclude %{ruby_libdir}/tkfont.rb
348     %exclude %{ruby_libdir}/tkmacpkg.rb
349     %exclude %{ruby_libdir}/tkmenubar.rb
350     %exclude %{ruby_libdir}/tkmngfocus.rb
351     %exclude %{ruby_libdir}/tkpalette.rb
352     %exclude %{ruby_libdir}/tkscrollbox.rb
353     %exclude %{ruby_libdir}/tktext.rb
354     %exclude %{ruby_libdir}/tkvirtevent.rb
355     %exclude %{ruby_libdir}/tkwinpkg.rb
356     %{ruby_libdir}/cgi
357     %{ruby_libdir}/date
358     %{ruby_libdir}/digest
359     %{ruby_libdir}/dl
360     %{ruby_libdir}/drb
361     %{ruby_libdir}/fiddle
362     %{ruby_libdir}/matrix
363     %{ruby_libdir}/net
364     %{ruby_libdir}/openssl
365     %{ruby_libdir}/optparse
366     %{ruby_libdir}/psych
367     %{ruby_libdir}/racc
368     %{ruby_libdir}/rbconfig
369     %{ruby_libdir}/rexml
370     %{ruby_libdir}/rinda
371     %{ruby_libdir}/ripper
372     %{ruby_libdir}/rss
373     %{ruby_libdir}/shell
374     %{ruby_libdir}/syck
375     %{ruby_libdir}/test
376     %{ruby_libdir}/uri
377     %{ruby_libdir}/webrick
378     %{ruby_libdir}/xmlrpc
379     %{ruby_libdir}/yaml
380     %dir %{ruby_libarchdir}
381     %{ruby_libarchdir}/continuation.so
382     %{ruby_libarchdir}/coverage.so
383     %{ruby_libarchdir}/curses.so
384     %{ruby_libarchdir}/date_core.so
385     %{ruby_libarchdir}/dbm.so
386     %dir %{ruby_libarchdir}/digest
387     %{ruby_libarchdir}/digest.so
388     %{ruby_libarchdir}/digest/*.so
389     %dir %{ruby_libarchdir}/dl
390     %{ruby_libarchdir}/dl.so
391     %{ruby_libarchdir}/dl/*.so
392     %dir %{ruby_libarchdir}/enc
393     %{ruby_libarchdir}/enc/*.so
394 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
395     %{ruby_libarchdir}/enc/trans/*.so
396 fwang 291560 %{ruby_libarchdir}/etc.so
397     %{ruby_libarchdir}/fcntl.so
398     %{ruby_libarchdir}/fiber.so
399     %{ruby_libarchdir}/fiddle.so
400     %{ruby_libarchdir}/gdbm.so
401     %{ruby_libarchdir}/iconv.so
402     %dir %{ruby_libarchdir}/io
403     %{ruby_libarchdir}/io/nonblock.so
404     %{ruby_libarchdir}/io/wait.so
405     %dir %{ruby_libarchdir}/mathn
406 fwang 291562 %{ruby_libarchdir}/mathn/*.so
407 fwang 291560 %{ruby_libarchdir}/nkf.so
408     %{ruby_libarchdir}/objspace.so
409     %{ruby_libarchdir}/openssl.so
410     %{ruby_libarchdir}/pathname.so
411     %{ruby_libarchdir}/psych.so
412     %{ruby_libarchdir}/pty.so
413     %dir %{ruby_libarchdir}/racc
414     %{ruby_libarchdir}/racc/*.so
415     %{ruby_libarchdir}/rbconfig.rb
416     %{ruby_libarchdir}/readline.so
417     %{ruby_libarchdir}/ripper.so
418     %{ruby_libarchdir}/sdbm.so
419     %{ruby_libarchdir}/socket.so
420     %{ruby_libarchdir}/stringio.so
421     %{ruby_libarchdir}/strscan.so
422     %{ruby_libarchdir}/syck.so
423     %{ruby_libarchdir}/syslog.so
424     %{ruby_libarchdir}/zlib.so
425 fwang 291551 %{_mandir}/man1/erb.1.*
426     %{_mandir}/man1/ruby.1.*
427 blino 1152 %{_datadir}/emacs/site-lisp/*
428     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
429     %{_sysconfdir}/rpm/macros.d/%{name}.macros
430 fwang 291560 %{_datadir}/ruby/site_ruby
431     %{_libdir}/ruby/site_ruby
432     %{_datadir}/ruby/vendor_ruby
433     %{_libdir}/ruby/vendor_ruby
434 fwang 311914 %if %bootstrap
435     %{_bindir}/gem
436     %dir %{rubygems_dir}
437     %{rubygems_dir}/rbconfig
438     %{rubygems_dir}/rubygems
439     %{rubygems_dir}/rubygems.rb
440     %{rubygems_dir}/ubygems.rb
441     %endif
442 blino 1152
443     %files doc
444     %{_datadir}/ri
445 shlomif 291698 %{_datadir}/doc/ruby/html/*
446 blino 1152
447 fwang 291590 %files -n %{libname}
448     %{_libdir}/libruby.so.%{subver}
449     %{_libdir}/libruby.so.%{rubyapi}
450    
451 blino 1152 %files devel
452 fwang 290003 %{_includedir}/*
453 blino 1152 %{_libdir}/libruby-static.a
454     %{_libdir}/libruby.so
455 fwang 290003 %{_libdir}/pkgconfig/*.pc
456 blino 1152
457     %files tk
458 fwang 291560 %{ruby_libarchdir}/tcltklib.so
459     %{ruby_libarchdir}/tkutil.so
460     %{ruby_libdir}/multi-tk.rb
461     %{ruby_libdir}/remote-tk.rb
462     %{ruby_libdir}/tcltk.rb
463     %{ruby_libdir}/tk.rb
464     %{ruby_libdir}/tkafter.rb
465     %{ruby_libdir}/tkbgerror.rb
466     %{ruby_libdir}/tkcanvas.rb
467     %{ruby_libdir}/tkclass.rb
468     %{ruby_libdir}/tkconsole.rb
469     %{ruby_libdir}/tkdialog.rb
470     %{ruby_libdir}/tkentry.rb
471     %{ruby_libdir}/tkfont.rb
472     %{ruby_libdir}/tkmacpkg.rb
473     %{ruby_libdir}/tkmenubar.rb
474     %{ruby_libdir}/tkmngfocus.rb
475     %{ruby_libdir}/tkpalette.rb
476     %{ruby_libdir}/tkscrollbox.rb
477     %{ruby_libdir}/tktext.rb
478     %{ruby_libdir}/tkvirtevent.rb
479     %{ruby_libdir}/tkwinpkg.rb
480     %{ruby_libdir}/tk
481     %{ruby_libdir}/tkextlib
482 fwang 291551
483 fwang 293412 %files irb
484     %{_bindir}/irb
485     %{ruby_libdir}/irb.rb
486     %{ruby_libdir}/irb
487     %{_mandir}/man1/irb.1*
488    
489     %if %build_gems
490 fwang 291551 %files RubyGems
491     %{_bindir}/gem
492     %dir %{rubygems_dir}
493     %{rubygems_dir}/rbconfig
494     %{rubygems_dir}/rubygems
495     %{rubygems_dir}/rubygems.rb
496     %{rubygems_dir}/ubygems.rb
497    
498 fwang 291562 %files minitest
499     %{ruby_libdir}/minitest
500 fwang 291563 %{rubygems_dir}/%{rubyapi}/specifications/minitest-*.gemspec
501 fwang 291562
502 fwang 291551 %files rake
503     %{_bindir}/rake
504     %{_mandir}/man1/rake.1.*
505 fwang 291562 %{ruby_libdir}/rake
506 fwang 291563 %{rubygems_dir}/%{rubyapi}/gems/rake-*
507 fwang 291590 %{rubygems_dir}/%{rubyapi}/specifications/rake-*.gemspec
508 fwang 291562
509     %files rdoc
510     %{_bindir}/rdoc
511     %{_bindir}/ri
512     %{ruby_libdir}/rdoc
513 fwang 291563 %{rubygems_dir}/%{rubyapi}/gems/rdoc-*
514     %{rubygems_dir}/%{rubyapi}/specifications/rdoc-*.gemspec
515 fwang 291562 %{_mandir}/man1/ri.1.*
516    
517     %files json
518     %dir %{ruby_libarchdir}/json
519     %dir %{ruby_libarchdir}/json/ext
520     %{ruby_libarchdir}/json/ext/*.so
521     %{ruby_libdir}/json
522 fwang 291563 %{rubygems_dir}/%{rubyapi}/specifications/json-*.gemspec
523 fwang 291590
524     %files bigdecimal
525     %{ruby_libdir}/bigdecimal
526     %{ruby_libarchdir}/bigdecimal.so
527 shlomif 291732 %{rubygems_dir}/%{rubyapi}/specifications/bigdecimal-*.gemspec
528 fwang 291590
529     %files io-console
530     %{ruby_libdir}/io
531     %{ruby_libarchdir}/io/console.so
532 shlomif 291732 %{rubygems_dir}/%{rubyapi}/specifications/io-console-*.gemspec
533 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30