/[packages]/updates/6/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/6/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 468808 - (hide annotations) (download)
Wed Aug 21 07:49:07 2013 UTC (10 years, 7 months ago) by fwang
Original Path: cauldron/ruby/branches/2.0/SPECS/ruby.spec
File size: 17699 byte(s)
down rel
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4 fwang 447652 %define patchversion p247
5 fwang 468808 %define rel 1
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21     # The RubyGems library has to stay out of Ruby directory three, since the
22     # RubyGems should be share by all Ruby implementations.
23 fwang 311714 %define rubygems_dir %{_datadir}/ruby/gems
24 pterjan 435211 %define rubygems_version 2.0.2
25 fwang 290007
26 fwang 448783 %define bootstrap 1
27 fwang 449018 %define build_gems 1
28 fwang 292558
29 blino 1152 Summary: Object Oriented Script Language
30     Name: ruby
31     Version: %{rubyver}.%{patchversion}
32     Release: %mkrel %rel
33 kamil 397518 License: Ruby or BSD
34 blino 1152 Group: Development/Ruby
35     BuildRequires: autoconf
36     BuildRequires: byacc
37 shlomif 291698 BuildRequires: doxygen
38 blino 1152 BuildRequires: ncurses-devel
39     BuildRequires: readline-devel
40     BuildRequires: tcl-devel tk-devel
41 fwang 276350 BuildRequires: db-devel
42 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
43 blino 1152 BuildRequires: openssl-devel
44     BuildRequires: zlib-devel
45 fwang 289987 BuildRequires: libffi-devel
46     BuildRequires: yaml-devel
47 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
48 blino 1152 Obsoletes: ruby-rexml
49     Provides: ruby-rexml
50 pterjan 435566 # Couldn't get the standalone gem to work
51     Provides: rubygem(psych)
52 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
53     Provides: /usr/bin/ruby
54 fwang 293445 Provides: ruby(abi) = %rubyapi
55 pterjan 435462 #Hack
56     Provides: ruby(abi) = 1.9.1
57 blino 1152
58 fwang 463762 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
59 pterjan 435211 Source1: operating_system.rb
60 blino 1152 Source3: ruby.macros
61     URL: http://www.ruby-lang.org/
62 fwang 292558 %if !%bootstrap
63     Requires: rubygems >= %{rubygems_version}
64 fwang 293395 BuildRequires: ruby
65 fwang 292558 %endif
66 blino 1152
67 fwang 290007 # == FEDORA PATCHES BEGINS ==
68 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
69     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
70     # Fixes random WEBRick test failures.
71     # https://bugs.ruby-lang.org/issues/6573.
72     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
73 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
74     # http://redmine.ruby-lang.org/issues/5617
75     Patch8: ruby-1.9.3-custom-rubygems-location.patch
76     # Add support for installing binary extensions according to FHS.
77     # https://github.com/rubygems/rubygems/issues/210
78 pterjan 435211 # Note that 8th patch might be resolved by
79     # https://bugs.ruby-lang.org/issues/7897
80     Patch9: rubygems-2.0.0-binary-extensions.patch
81     # Make mkmf verbose by default
82     Patch12: ruby-1.9.3-mkmf-verbose.patch
83     # This slightly changes behavior of "gem install --install-dir" behavior.
84     # Without this patch, Specifications.dirs is modified and gems installed on
85     # the system cannot be required anymore. This causes later issues when RDoc
86     # documentation should be generated, since json gem is sudenly not accessible.
87     # https://github.com/rubygems/rubygems/pull/452
88     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
89     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
90     # https://github.com/rubygems/rubygems/pull/455
91     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
92 fwang 290007 # == FEDORA PATCHES ENDS ==
93    
94 fwang 291591 %package -n %{libname}
95 fwang 291590 Summary: Libraries necessary to run Ruby
96     Group: Development/Ruby
97    
98 blino 1152 %package doc
99     Summary: Documentation for the powerful language Ruby
100     Group: Development/Ruby
101 fwang 202696 BuildArch: noarch
102 blino 1152
103     %package devel
104     Summary: Development file for the powerful language Ruby
105     Group: Development/Ruby
106 fwang 311925 Requires: %{name} = %{version}
107     Requires: %{libname} = %{version}
108 blino 1152
109     %package tk
110     Summary: Tk extension for the powerful language Ruby
111     Group: Development/Ruby
112 fwang 311925 Requires: %{name} = %{version}
113 blino 1152
114 fwang 291551 %package RubyGems
115     Summary: The Ruby standard for packaging ruby libraries
116     Group: Development/Ruby
117 fwang 291590 Version: %{rubygems_version}
118 fwang 291551 Requires: ruby(abi) = %{subver}
119 fwang 291590 Provides: gem = %{rubygems_version}
120     Provides: rubygems = %{rubygems_version}
121     Provides: ruby(rubygems) = %{rubygems_version}
122 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
123 fwang 291561 BuildArch: noarch
124 fwang 291551
125 pterjan 435211 %define rake_ver 0.9.6
126 fwang 291551 %package rake
127     Summary: Simple ruby build program with capabilities similar to make
128     Group: Development/Ruby
129 shlomif 291767 Version: %{rake_ver}
130 fwang 291551 Requires: ruby(abi) = %{subver}
131 fwang 291561 BuildArch: noarch
132 fwang 291551
133 pterjan 435211 %define minitest_ver 4.3.2
134 fwang 291562 %package minitest
135 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
136 fwang 291562 Group: Development/Ruby
137 shlomif 291767 Version: %{minitest_ver}
138 fwang 291562 License: MIT
139 fwang 291590 Requires: ruby(abi) = %{subver}
140     Requires: ruby(rubygems) >= %{rubygems_version}
141 fwang 291562 BuildArch: noarch
142    
143 pterjan 435211 %define json_ver 1.7.7
144 fwang 291562 %package json
145     Summary: This is a JSON implementation as a Ruby extension in C
146     Group: Development/Ruby
147 shlomif 291767 Version: %{json_ver}
148 fwang 291562 License: Ruby or GPLv2
149 fwang 291590 Requires: ruby(abi) = %{subver}
150     Requires: ruby(rubygems) >= %{rubygems_version}
151 fwang 291562
152 pterjan 435211 %define rdoc_ver 4.0.0
153 fwang 291562 %package rdoc
154     Summary: A tool to generate HTML and command-line documentation for Ruby projects
155     Group: Development/Ruby
156 shlomif 291767 Version: %{rdoc_ver}
157 fwang 291562 License: GPLv2 and Ruby and MIT
158 fwang 291590 Requires: ruby(abi) = %{subver}
159     Requires: ruby(rubygems) >= %{rubygems_version}
160     Requires: ruby(irb) = %{version}
161 shlomif 291767 Provides: rdoc = %{rdoc_ver}
162     Provides: ri = %{rdoc_ver}
163 fwang 291562 BuildArch: noarch
164    
165 fwang 291590 %package irb
166     Summary: The Interactive Ruby
167     Group: Development/Ruby
168     Provides: irb = %{version}-%{release}
169     Provides: ruby(irb) = %{version}-%{release}
170 fwang 313459 Conflicts: ruby < 1.9
171 fwang 313460 BuildArch: noarch
172 fwang 291590
173 pterjan 435211 %define bigdecimal_ver 1.2.0
174 fwang 291590 %package bigdecimal
175     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
176     Group: Development/Ruby
177 pterjan 435211 Version: %{bigdecimal_ver}
178 fwang 291590 License: GPL+ or Artistic
179     Requires: ruby(abi) = %{subver}
180     Requires: ruby(rubygems) >= %{rubygems_version}
181    
182 pterjan 435211 %define io_console_ver 0.4.2
183 fwang 291590 %package io-console
184     Summary: IO/Console is a simple console utilizing library
185     Group: Development/Ruby
186 pterjan 435211 Version: %{io_console_ver}
187 fwang 291590 Requires: ruby(abi) = %{subver}
188     Requires: ruby(rubygems) >= %{rubygems_version}
189    
190 pterjan 435211 %define psych_ver 2.0.0
191     %package psych
192     Summary: A libyaml wrapper for Ruby
193     Version: %{psych_ver}
194     Group: Development/Ruby
195     License: MIT
196     Requires: ruby(abi) = %{subver}
197     Requires: ruby(rubygems) >= %{rubygems_version}
198     Conflicts: ruby < 2.0.0
199    
200     %define test_unit_ver 2.0.0
201     %package test-unit
202     Summary: test/unit compatible API testing framework
203     Version: %{psych_ver}
204     Group: Development/Ruby
205     License: MIT
206     Requires: ruby(abi) = %{subver}
207     Requires: ruby(rubygems) >= %{rubygems_version}
208     Conflicts: ruby < 2.0.0
209     BuildArch: noarch
210    
211 blino 1152 %description
212     Ruby is the interpreted scripting language for quick and
213     easy object-oriented programming. It has many features to
214     process text files and to do system management tasks (as in
215     Perl). It is simple, straight-forward, and extensible.
216    
217     %description doc
218     Ruby is the interpreted scripting language for quick and
219     easy object-oriented programming. It has many features to
220     process text files and to do system management tasks (as in
221     Perl). It is simple, straight-forward, and extensible.
222    
223     This package contains the Ruby's documentation
224    
225 fwang 291590 %description -n %{libname}
226     This package includes the libruby, necessary to run Ruby.
227    
228 blino 1152 %description devel
229     Ruby is the interpreted scripting language for quick and
230     easy object-oriented programming. It has many features to
231     process text files and to do system management tasks (as in
232     Perl). It is simple, straight-forward, and extensible.
233    
234     This package contains the Ruby's devel files.
235    
236     %description tk
237     Ruby is the interpreted scripting language for quick and
238     easy object-oriented programming. It has many features to
239     process text files and to do system management tasks (as in
240     Perl). It is simple, straight-forward, and extensible.
241    
242     This package contains the Tk extension for Ruby.
243    
244 fwang 291551 %description RubyGems
245     RubyGems is the Ruby standard for publishing and managing third party
246     libraries.
247    
248 fwang 291552 %description rake
249     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
250     specified in standard Ruby syntax.
251    
252 fwang 291562 %description rdoc
253     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
254     includes the 'rdoc' and 'ri' tools for generating and displaying online
255     documentation.
256    
257     %description json
258     This is a implementation of the JSON specification according to RFC 4627.
259     You can think of it as a low fat alternative to XML, if you want to store
260     data to disk or transmit it over a network rather than use a verbose
261     markup language.
262    
263     %description minitest
264     minitest/unit is a small and incredibly fast unit testing framework.
265    
266     minitest/spec is a functionally complete spec engine.
267    
268     minitest/benchmark is an awesome way to assert the performance of your
269     algorithms in a repeatable manner.
270    
271     minitest/mock by Steven Baker, is a beautifully tiny mock object
272     framework.
273    
274     minitest/pride shows pride in testing and adds coloring to your test
275     output.
276    
277 fwang 291590 %description irb
278     The irb is acronym for Interactive Ruby. It evaluates ruby expression
279     from the terminal.
280    
281     %description bigdecimal
282     Ruby provides built-in support for arbitrary precision integer arithmetic.
283     For example:
284    
285     42**13 -> 1265437718438866624512
286    
287     BigDecimal provides similar support for very large or very accurate floating
288     point numbers. Decimal arithmetic is also useful for general calculation,
289     because it provides the correct answers people expect–whereas normal binary
290     floating point arithmetic often introduces subtle errors because of the
291     conversion between base 10 and base 2.
292    
293     %description io-console
294     IO/Console provides very simple and portable access to console. It doesn't
295     provide higher layer features, such like curses and readline.
296    
297 pterjan 435211 %description psych
298     Psych is a YAML parser and emitter. Psych leverages
299     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
300     capabilities. In addition to wrapping libyaml, Psych also knows how to
301     serialize and de-serialize most Ruby objects to and from the YAML format.
302    
303     %description test-unit
304     This library implements test/unit compatible API on minitest.
305     The test/unit means that test/unit which was bundled with Ruby 1.8.
306    
307 blino 1152 %prep
308     %setup -q -n ruby-%{rubyver}-%{patchversion}
309 fwang 290007 %apply_patches
310 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
311     rm lib/mkmf.rb.0*
312 blino 1152
313     %build
314 fwang 290038 autoconf
315 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
316 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
317 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
318 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
319 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
320     --with-sitearchdir='%{ruby_sitearchdir}' \
321     --with-vendordir='%{ruby_vendorlibdir}' \
322     --with-vendorarchdir='%{ruby_vendorarchdir}' \
323 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
324 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
325     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
326     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
327     --with-rubygemsdir='%{rubygems_dir}' \
328     --with-ruby-pc='%{name}.pc' \
329     --enable-multiarch \
330     --with-ruby-version=''
331 blino 1152 %make
332    
333     %install
334     %makeinstall_std install-doc
335    
336     install -d %buildroot%{_datadir}/emacs/site-lisp
337     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
338    
339     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
340     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
341     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
342     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
343     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
344     EOF
345    
346     # Install the rpm macros
347     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
348     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
349 fwang 289961
350 pterjan 435211 # Install custom operating_system.rb
351     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
352     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
353    
354 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
355     %if !%build_gems
356 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
357 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
358 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
359     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
360 fwang 448873 rm -fr %{buildroot}%{rubygems_dir}/{gems,specifications}
361 fwang 311915 %if !%bootstrap
362 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
363 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
364     rm -fr %{buildroot}%{rubygems_dir}/rubygems
365 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
366     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
367 fwang 293412 %endif
368 fwang 311914 %endif
369 fwang 293412
370 blino 1152 %check
371     make test
372    
373 fwang 289961 %files
374 fwang 291551 %{_bindir}/erb
375     %{_bindir}/ruby
376 fwang 291560 %dir %{ruby_libdir}
377     %{ruby_libdir}/*.rb
378 fwang 291590 %exclude %{ruby_libdir}/irb.rb
379 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
380     %exclude %{ruby_libdir}/remote-tk.rb
381     %exclude %{ruby_libdir}/tcltk.rb
382     %exclude %{ruby_libdir}/tk.rb
383     %exclude %{ruby_libdir}/tkafter.rb
384     %exclude %{ruby_libdir}/tkbgerror.rb
385     %exclude %{ruby_libdir}/tkcanvas.rb
386     %exclude %{ruby_libdir}/tkclass.rb
387     %exclude %{ruby_libdir}/tkconsole.rb
388     %exclude %{ruby_libdir}/tkdialog.rb
389     %exclude %{ruby_libdir}/tkentry.rb
390     %exclude %{ruby_libdir}/tkfont.rb
391     %exclude %{ruby_libdir}/tkmacpkg.rb
392     %exclude %{ruby_libdir}/tkmenubar.rb
393     %exclude %{ruby_libdir}/tkmngfocus.rb
394     %exclude %{ruby_libdir}/tkpalette.rb
395     %exclude %{ruby_libdir}/tkscrollbox.rb
396     %exclude %{ruby_libdir}/tktext.rb
397     %exclude %{ruby_libdir}/tkvirtevent.rb
398     %exclude %{ruby_libdir}/tkwinpkg.rb
399     %{ruby_libdir}/cgi
400     %{ruby_libdir}/date
401     %{ruby_libdir}/digest
402     %{ruby_libdir}/dl
403     %{ruby_libdir}/drb
404     %{ruby_libdir}/fiddle
405     %{ruby_libdir}/matrix
406     %{ruby_libdir}/net
407     %{ruby_libdir}/openssl
408     %{ruby_libdir}/optparse
409 pterjan 435566 %{ruby_libdir}/psych
410 fwang 291560 %{ruby_libdir}/racc
411     %{ruby_libdir}/rbconfig
412     %{ruby_libdir}/rexml
413     %{ruby_libdir}/rinda
414     %{ruby_libdir}/ripper
415     %{ruby_libdir}/rss
416     %{ruby_libdir}/shell
417 pterjan 435211 %{ruby_libdir}/syslog
418 fwang 291560 %{ruby_libdir}/uri
419     %{ruby_libdir}/webrick
420     %{ruby_libdir}/xmlrpc
421     %{ruby_libdir}/yaml
422     %dir %{ruby_libarchdir}
423     %{ruby_libarchdir}/continuation.so
424     %{ruby_libarchdir}/coverage.so
425     %{ruby_libarchdir}/curses.so
426     %{ruby_libarchdir}/date_core.so
427     %{ruby_libarchdir}/dbm.so
428     %dir %{ruby_libarchdir}/digest
429     %{ruby_libarchdir}/digest.so
430     %{ruby_libarchdir}/digest/*.so
431     %dir %{ruby_libarchdir}/dl
432     %{ruby_libarchdir}/dl.so
433     %{ruby_libarchdir}/dl/*.so
434     %dir %{ruby_libarchdir}/enc
435     %{ruby_libarchdir}/enc/*.so
436 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
437     %{ruby_libarchdir}/enc/trans/*.so
438 fwang 291560 %{ruby_libarchdir}/etc.so
439     %{ruby_libarchdir}/fcntl.so
440     %{ruby_libarchdir}/fiber.so
441     %{ruby_libarchdir}/fiddle.so
442     %{ruby_libarchdir}/gdbm.so
443     %dir %{ruby_libarchdir}/io
444     %{ruby_libarchdir}/io/nonblock.so
445     %{ruby_libarchdir}/io/wait.so
446     %dir %{ruby_libarchdir}/mathn
447 fwang 291562 %{ruby_libarchdir}/mathn/*.so
448 fwang 291560 %{ruby_libarchdir}/nkf.so
449     %{ruby_libarchdir}/objspace.so
450     %{ruby_libarchdir}/openssl.so
451 pterjan 435566 %{ruby_libarchdir}/psych.so
452 fwang 291560 %{ruby_libarchdir}/pathname.so
453     %{ruby_libarchdir}/pty.so
454     %dir %{ruby_libarchdir}/racc
455     %{ruby_libarchdir}/racc/*.so
456     %{ruby_libarchdir}/rbconfig.rb
457     %{ruby_libarchdir}/readline.so
458     %{ruby_libarchdir}/ripper.so
459     %{ruby_libarchdir}/sdbm.so
460     %{ruby_libarchdir}/socket.so
461     %{ruby_libarchdir}/stringio.so
462     %{ruby_libarchdir}/strscan.so
463     %{ruby_libarchdir}/syslog.so
464     %{ruby_libarchdir}/zlib.so
465 fwang 291551 %{_mandir}/man1/erb.1.*
466     %{_mandir}/man1/ruby.1.*
467 blino 1152 %{_datadir}/emacs/site-lisp/*
468     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
469     %{_sysconfdir}/rpm/macros.d/%{name}.macros
470 fwang 291560 %{_datadir}/ruby/site_ruby
471     %{_libdir}/ruby/site_ruby
472     %{_datadir}/ruby/vendor_ruby
473     %{_libdir}/ruby/vendor_ruby
474 fwang 311914 %if %bootstrap
475     %{_bindir}/gem
476 fwang 448831 %dir %{rubygems_dir}
477     %{rubygems_dir}/rbconfig
478     %{rubygems_dir}/rubygems
479     %{rubygems_dir}/rubygems.rb
480     %{rubygems_dir}/ubygems.rb
481 fwang 311914 %endif
482 blino 1152
483     %files doc
484     %{_datadir}/ri
485 pterjan 435211 %{_datadir}/doc/ruby
486 blino 1152
487 fwang 291590 %files -n %{libname}
488     %{_libdir}/libruby.so.%{subver}
489     %{_libdir}/libruby.so.%{rubyapi}
490    
491 blino 1152 %files devel
492 fwang 290003 %{_includedir}/*
493 blino 1152 %{_libdir}/libruby-static.a
494     %{_libdir}/libruby.so
495 fwang 290003 %{_libdir}/pkgconfig/*.pc
496 blino 1152
497     %files tk
498 fwang 291560 %{ruby_libarchdir}/tcltklib.so
499     %{ruby_libarchdir}/tkutil.so
500     %{ruby_libdir}/multi-tk.rb
501     %{ruby_libdir}/remote-tk.rb
502     %{ruby_libdir}/tcltk.rb
503     %{ruby_libdir}/tk.rb
504     %{ruby_libdir}/tkafter.rb
505     %{ruby_libdir}/tkbgerror.rb
506     %{ruby_libdir}/tkcanvas.rb
507     %{ruby_libdir}/tkclass.rb
508     %{ruby_libdir}/tkconsole.rb
509     %{ruby_libdir}/tkdialog.rb
510     %{ruby_libdir}/tkentry.rb
511     %{ruby_libdir}/tkfont.rb
512     %{ruby_libdir}/tkmacpkg.rb
513     %{ruby_libdir}/tkmenubar.rb
514     %{ruby_libdir}/tkmngfocus.rb
515     %{ruby_libdir}/tkpalette.rb
516     %{ruby_libdir}/tkscrollbox.rb
517     %{ruby_libdir}/tktext.rb
518     %{ruby_libdir}/tkvirtevent.rb
519     %{ruby_libdir}/tkwinpkg.rb
520     %{ruby_libdir}/tk
521     %{ruby_libdir}/tkextlib
522 fwang 291551
523 fwang 293412 %files irb
524     %{_bindir}/irb
525     %{ruby_libdir}/irb.rb
526     %{ruby_libdir}/irb
527     %{_mandir}/man1/irb.1*
528    
529     %if %build_gems
530 fwang 291551 %files RubyGems
531     %{_bindir}/gem
532     %dir %{rubygems_dir}
533     %{rubygems_dir}/rbconfig
534     %{rubygems_dir}/rubygems
535     %{rubygems_dir}/rubygems.rb
536     %{rubygems_dir}/ubygems.rb
537    
538 fwang 291562 %files minitest
539     %{ruby_libdir}/minitest
540 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
541 fwang 291562
542 fwang 291551 %files rake
543     %{_bindir}/rake
544     %{_mandir}/man1/rake.1.*
545 fwang 291562 %{ruby_libdir}/rake
546 pterjan 435211 %{rubygems_dir}/gems/rake-*
547     %{rubygems_dir}/specifications/default/rake-*.gemspec
548 fwang 291562
549     %files rdoc
550     %{_bindir}/rdoc
551     %{_bindir}/ri
552     %{ruby_libdir}/rdoc
553 pterjan 435211 %{rubygems_dir}/gems/rdoc-*
554     %{rubygems_dir}/specifications/default/rdoc-*.gemspec
555 fwang 291562 %{_mandir}/man1/ri.1.*
556    
557     %files json
558     %dir %{ruby_libarchdir}/json
559     %dir %{ruby_libarchdir}/json/ext
560     %{ruby_libarchdir}/json/ext/*.so
561     %{ruby_libdir}/json
562 pterjan 435211 %{rubygems_dir}/specifications/default/json-*.gemspec
563 fwang 291590
564     %files bigdecimal
565     %{ruby_libdir}/bigdecimal
566     %{ruby_libarchdir}/bigdecimal.so
567 pterjan 435211 %{rubygems_dir}/specifications/default/bigdecimal-*.gemspec
568 fwang 291590
569     %files io-console
570     %{ruby_libdir}/io
571     %{ruby_libarchdir}/io/console.so
572 pterjan 435211 %{rubygems_dir}/specifications/default/io-console-*.gemspec
573    
574     %files psych
575     %{ruby_libdir}/psych
576     %{ruby_libarchdir}/psych.so
577     %{rubygems_dir}/specifications/default/psych-*.gemspec
578    
579     %files test-unit
580     %{_bindir}/testrb
581     %{ruby_libdir}/test
582     %{rubygems_dir}/gems/test-unit-*
583     %{rubygems_dir}/specifications/default/test-unit-*.gemspec
584 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30