/[packages]/updates/6/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/6/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 552441 - (hide annotations) (download)
Sat Nov 23 10:01:59 2013 UTC (10 years, 4 months ago) by fwang
Original Path: cauldron/ruby/current/SPECS/ruby.spec
File size: 17859 byte(s)
add upstream patch to fix CVE-2013-4164
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4 fwang 447652 %define patchversion p247
5 fwang 552441 %define rel 7
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21     # The RubyGems library has to stay out of Ruby directory three, since the
22     # RubyGems should be share by all Ruby implementations.
23 fwang 311714 %define rubygems_dir %{_datadir}/ruby/gems
24 pterjan 435211 %define rubygems_version 2.0.2
25 fwang 290007
26 fwang 468908 %define bootstrap 0
27 fwang 468812 %define build_gems 0
28 fwang 292558
29 blino 1152 Summary: Object Oriented Script Language
30     Name: ruby
31     Version: %{rubyver}.%{patchversion}
32     Release: %mkrel %rel
33 kamil 397518 License: Ruby or BSD
34 blino 1152 Group: Development/Ruby
35     BuildRequires: autoconf
36     BuildRequires: byacc
37 shlomif 291698 BuildRequires: doxygen
38 blino 1152 BuildRequires: ncurses-devel
39     BuildRequires: readline-devel
40     BuildRequires: tcl-devel tk-devel
41 fwang 276350 BuildRequires: db-devel
42 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
43 blino 1152 BuildRequires: openssl-devel
44     BuildRequires: zlib-devel
45 fwang 289987 BuildRequires: libffi-devel
46     BuildRequires: yaml-devel
47 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
48 blino 1152 Obsoletes: ruby-rexml
49     Provides: ruby-rexml
50 pterjan 435566 # Couldn't get the standalone gem to work
51     Provides: rubygem(psych)
52 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
53     Provides: /usr/bin/ruby
54 fwang 293445 Provides: ruby(abi) = %rubyapi
55 fwang 463762 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
56 pterjan 435211 Source1: operating_system.rb
57 blino 1152 Source3: ruby.macros
58     URL: http://www.ruby-lang.org/
59 fwang 292558 %if !%bootstrap
60     Requires: rubygems >= %{rubygems_version}
61 fwang 293395 BuildRequires: ruby
62 fwang 292558 %endif
63 blino 1152
64 fwang 290007 # == FEDORA PATCHES BEGINS ==
65 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
66     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
67     # Fixes random WEBRick test failures.
68     # https://bugs.ruby-lang.org/issues/6573.
69     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
70 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
71     # http://redmine.ruby-lang.org/issues/5617
72     Patch8: ruby-1.9.3-custom-rubygems-location.patch
73     # Add support for installing binary extensions according to FHS.
74     # https://github.com/rubygems/rubygems/issues/210
75 pterjan 435211 # Note that 8th patch might be resolved by
76     # https://bugs.ruby-lang.org/issues/7897
77     Patch9: rubygems-2.0.0-binary-extensions.patch
78     # Make mkmf verbose by default
79     Patch12: ruby-1.9.3-mkmf-verbose.patch
80     # This slightly changes behavior of "gem install --install-dir" behavior.
81     # Without this patch, Specifications.dirs is modified and gems installed on
82     # the system cannot be required anymore. This causes later issues when RDoc
83     # documentation should be generated, since json gem is sudenly not accessible.
84     # https://github.com/rubygems/rubygems/pull/452
85     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
86     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
87     # https://github.com/rubygems/rubygems/pull/455
88     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
89 fwang 490240 # Fixes issues with DESTDIR.
90     # https://bugs.ruby-lang.org/issues/8115
91     Patch18: ruby-2.0.0-p247-Revert-mkmf.rb-prefix-install_dirs-only-with-DESTDIR.patch
92 fwang 290007 # == FEDORA PATCHES ENDS ==
93 fwang 552441 Patch100: ruby-2.0.0-CVE-2013-4164.patch
94 fwang 290007
95 fwang 291591 %package -n %{libname}
96 fwang 291590 Summary: Libraries necessary to run Ruby
97     Group: Development/Ruby
98    
99 blino 1152 %package doc
100     Summary: Documentation for the powerful language Ruby
101     Group: Development/Ruby
102 fwang 202696 BuildArch: noarch
103 blino 1152
104     %package devel
105     Summary: Development file for the powerful language Ruby
106     Group: Development/Ruby
107 fwang 311925 Requires: %{name} = %{version}
108     Requires: %{libname} = %{version}
109 blino 1152
110     %package tk
111     Summary: Tk extension for the powerful language Ruby
112     Group: Development/Ruby
113 fwang 311925 Requires: %{name} = %{version}
114 blino 1152
115 fwang 291551 %package RubyGems
116     Summary: The Ruby standard for packaging ruby libraries
117     Group: Development/Ruby
118 fwang 291590 Version: %{rubygems_version}
119 fwang 291551 Requires: ruby(abi) = %{subver}
120 fwang 291590 Provides: gem = %{rubygems_version}
121     Provides: rubygems = %{rubygems_version}
122     Provides: ruby(rubygems) = %{rubygems_version}
123 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
124 fwang 291561 BuildArch: noarch
125 fwang 291551
126 pterjan 435211 %define rake_ver 0.9.6
127 fwang 291551 %package rake
128     Summary: Simple ruby build program with capabilities similar to make
129     Group: Development/Ruby
130 shlomif 291767 Version: %{rake_ver}
131 fwang 291551 Requires: ruby(abi) = %{subver}
132 fwang 291561 BuildArch: noarch
133 fwang 291551
134 pterjan 435211 %define minitest_ver 4.3.2
135 fwang 291562 %package minitest
136 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
137 fwang 291562 Group: Development/Ruby
138 shlomif 291767 Version: %{minitest_ver}
139 fwang 291562 License: MIT
140 fwang 291590 Requires: ruby(abi) = %{subver}
141     Requires: ruby(rubygems) >= %{rubygems_version}
142 fwang 291562 BuildArch: noarch
143    
144 pterjan 435211 %define json_ver 1.7.7
145 fwang 291562 %package json
146     Summary: This is a JSON implementation as a Ruby extension in C
147     Group: Development/Ruby
148 shlomif 291767 Version: %{json_ver}
149 fwang 291562 License: Ruby or GPLv2
150 fwang 291590 Requires: ruby(abi) = %{subver}
151     Requires: ruby(rubygems) >= %{rubygems_version}
152 fwang 291562
153 pterjan 435211 %define rdoc_ver 4.0.0
154 fwang 291562 %package rdoc
155     Summary: A tool to generate HTML and command-line documentation for Ruby projects
156     Group: Development/Ruby
157 shlomif 291767 Version: %{rdoc_ver}
158 fwang 291562 License: GPLv2 and Ruby and MIT
159 fwang 291590 Requires: ruby(abi) = %{subver}
160     Requires: ruby(rubygems) >= %{rubygems_version}
161     Requires: ruby(irb) = %{version}
162 shlomif 291767 Provides: rdoc = %{rdoc_ver}
163     Provides: ri = %{rdoc_ver}
164 fwang 291562 BuildArch: noarch
165    
166 fwang 291590 %package irb
167     Summary: The Interactive Ruby
168     Group: Development/Ruby
169     Provides: irb = %{version}-%{release}
170     Provides: ruby(irb) = %{version}-%{release}
171 fwang 313459 Conflicts: ruby < 1.9
172 fwang 313460 BuildArch: noarch
173 fwang 291590
174 pterjan 435211 %define bigdecimal_ver 1.2.0
175 fwang 291590 %package bigdecimal
176     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
177     Group: Development/Ruby
178 pterjan 435211 Version: %{bigdecimal_ver}
179 fwang 291590 License: GPL+ or Artistic
180     Requires: ruby(abi) = %{subver}
181     Requires: ruby(rubygems) >= %{rubygems_version}
182    
183 pterjan 435211 %define io_console_ver 0.4.2
184 fwang 291590 %package io-console
185     Summary: IO/Console is a simple console utilizing library
186     Group: Development/Ruby
187 pterjan 435211 Version: %{io_console_ver}
188 fwang 291590 Requires: ruby(abi) = %{subver}
189     Requires: ruby(rubygems) >= %{rubygems_version}
190    
191 pterjan 435211 %define psych_ver 2.0.0
192     %package psych
193     Summary: A libyaml wrapper for Ruby
194     Version: %{psych_ver}
195     Group: Development/Ruby
196     License: MIT
197     Requires: ruby(abi) = %{subver}
198     Requires: ruby(rubygems) >= %{rubygems_version}
199     Conflicts: ruby < 2.0.0
200    
201     %define test_unit_ver 2.0.0
202     %package test-unit
203     Summary: test/unit compatible API testing framework
204     Version: %{psych_ver}
205     Group: Development/Ruby
206     License: MIT
207     Requires: ruby(abi) = %{subver}
208     Requires: ruby(rubygems) >= %{rubygems_version}
209     Conflicts: ruby < 2.0.0
210     BuildArch: noarch
211    
212 blino 1152 %description
213     Ruby is the interpreted scripting language for quick and
214     easy object-oriented programming. It has many features to
215     process text files and to do system management tasks (as in
216     Perl). It is simple, straight-forward, and extensible.
217    
218     %description doc
219     Ruby is the interpreted scripting language for quick and
220     easy object-oriented programming. It has many features to
221     process text files and to do system management tasks (as in
222     Perl). It is simple, straight-forward, and extensible.
223    
224     This package contains the Ruby's documentation
225    
226 fwang 291590 %description -n %{libname}
227     This package includes the libruby, necessary to run Ruby.
228    
229 blino 1152 %description devel
230     Ruby is the interpreted scripting language for quick and
231     easy object-oriented programming. It has many features to
232     process text files and to do system management tasks (as in
233     Perl). It is simple, straight-forward, and extensible.
234    
235     This package contains the Ruby's devel files.
236    
237     %description tk
238     Ruby is the interpreted scripting language for quick and
239     easy object-oriented programming. It has many features to
240     process text files and to do system management tasks (as in
241     Perl). It is simple, straight-forward, and extensible.
242    
243     This package contains the Tk extension for Ruby.
244    
245 fwang 291551 %description RubyGems
246     RubyGems is the Ruby standard for publishing and managing third party
247     libraries.
248    
249 fwang 291552 %description rake
250     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
251     specified in standard Ruby syntax.
252    
253 fwang 291562 %description rdoc
254     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
255     includes the 'rdoc' and 'ri' tools for generating and displaying online
256     documentation.
257    
258     %description json
259     This is a implementation of the JSON specification according to RFC 4627.
260     You can think of it as a low fat alternative to XML, if you want to store
261     data to disk or transmit it over a network rather than use a verbose
262     markup language.
263    
264     %description minitest
265     minitest/unit is a small and incredibly fast unit testing framework.
266    
267     minitest/spec is a functionally complete spec engine.
268    
269     minitest/benchmark is an awesome way to assert the performance of your
270     algorithms in a repeatable manner.
271    
272     minitest/mock by Steven Baker, is a beautifully tiny mock object
273     framework.
274    
275     minitest/pride shows pride in testing and adds coloring to your test
276     output.
277    
278 fwang 291590 %description irb
279     The irb is acronym for Interactive Ruby. It evaluates ruby expression
280     from the terminal.
281    
282     %description bigdecimal
283     Ruby provides built-in support for arbitrary precision integer arithmetic.
284     For example:
285    
286     42**13 -> 1265437718438866624512
287    
288     BigDecimal provides similar support for very large or very accurate floating
289     point numbers. Decimal arithmetic is also useful for general calculation,
290     because it provides the correct answers people expect–whereas normal binary
291     floating point arithmetic often introduces subtle errors because of the
292     conversion between base 10 and base 2.
293    
294     %description io-console
295     IO/Console provides very simple and portable access to console. It doesn't
296     provide higher layer features, such like curses and readline.
297    
298 pterjan 435211 %description psych
299     Psych is a YAML parser and emitter. Psych leverages
300     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
301     capabilities. In addition to wrapping libyaml, Psych also knows how to
302     serialize and de-serialize most Ruby objects to and from the YAML format.
303    
304     %description test-unit
305     This library implements test/unit compatible API on minitest.
306     The test/unit means that test/unit which was bundled with Ruby 1.8.
307    
308 blino 1152 %prep
309     %setup -q -n ruby-%{rubyver}-%{patchversion}
310 fwang 290007 %apply_patches
311 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
312     rm lib/mkmf.rb.0*
313 blino 1152
314     %build
315 fwang 290038 autoconf
316 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
317 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
318 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
319 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
320 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
321     --with-sitearchdir='%{ruby_sitearchdir}' \
322     --with-vendordir='%{ruby_vendorlibdir}' \
323     --with-vendorarchdir='%{ruby_vendorarchdir}' \
324 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
325 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
326     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
327     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
328     --with-rubygemsdir='%{rubygems_dir}' \
329     --with-ruby-pc='%{name}.pc' \
330     --enable-multiarch \
331     --with-ruby-version=''
332 blino 1152 %make
333    
334     %install
335     %makeinstall_std install-doc
336    
337     install -d %buildroot%{_datadir}/emacs/site-lisp
338     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
339    
340     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
341     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
342     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
343     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
344     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
345     EOF
346    
347     # Install the rpm macros
348     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
349     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
350 fwang 289961
351 pterjan 435211 # Install custom operating_system.rb
352     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
353     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
354    
355 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
356     %if !%build_gems
357 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
358 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
359 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
360     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
361 fwang 448873 rm -fr %{buildroot}%{rubygems_dir}/{gems,specifications}
362 fwang 311915 %if !%bootstrap
363 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
364 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
365     rm -fr %{buildroot}%{rubygems_dir}/rubygems
366 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
367     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
368 fwang 293412 %endif
369 fwang 311914 %endif
370 fwang 293412
371 blino 1152 %check
372     make test
373    
374 fwang 289961 %files
375 fwang 291551 %{_bindir}/erb
376     %{_bindir}/ruby
377 fwang 291560 %dir %{ruby_libdir}
378     %{ruby_libdir}/*.rb
379 fwang 291590 %exclude %{ruby_libdir}/irb.rb
380 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
381     %exclude %{ruby_libdir}/remote-tk.rb
382     %exclude %{ruby_libdir}/tcltk.rb
383     %exclude %{ruby_libdir}/tk.rb
384     %exclude %{ruby_libdir}/tkafter.rb
385     %exclude %{ruby_libdir}/tkbgerror.rb
386     %exclude %{ruby_libdir}/tkcanvas.rb
387     %exclude %{ruby_libdir}/tkclass.rb
388     %exclude %{ruby_libdir}/tkconsole.rb
389     %exclude %{ruby_libdir}/tkdialog.rb
390     %exclude %{ruby_libdir}/tkentry.rb
391     %exclude %{ruby_libdir}/tkfont.rb
392     %exclude %{ruby_libdir}/tkmacpkg.rb
393     %exclude %{ruby_libdir}/tkmenubar.rb
394     %exclude %{ruby_libdir}/tkmngfocus.rb
395     %exclude %{ruby_libdir}/tkpalette.rb
396     %exclude %{ruby_libdir}/tkscrollbox.rb
397     %exclude %{ruby_libdir}/tktext.rb
398     %exclude %{ruby_libdir}/tkvirtevent.rb
399     %exclude %{ruby_libdir}/tkwinpkg.rb
400     %{ruby_libdir}/cgi
401     %{ruby_libdir}/date
402     %{ruby_libdir}/digest
403     %{ruby_libdir}/dl
404     %{ruby_libdir}/drb
405     %{ruby_libdir}/fiddle
406     %{ruby_libdir}/matrix
407     %{ruby_libdir}/net
408     %{ruby_libdir}/openssl
409     %{ruby_libdir}/optparse
410 pterjan 435566 %{ruby_libdir}/psych
411 fwang 291560 %{ruby_libdir}/racc
412     %{ruby_libdir}/rbconfig
413     %{ruby_libdir}/rexml
414     %{ruby_libdir}/rinda
415     %{ruby_libdir}/ripper
416     %{ruby_libdir}/rss
417     %{ruby_libdir}/shell
418 pterjan 435211 %{ruby_libdir}/syslog
419 fwang 291560 %{ruby_libdir}/uri
420     %{ruby_libdir}/webrick
421     %{ruby_libdir}/xmlrpc
422     %{ruby_libdir}/yaml
423     %dir %{ruby_libarchdir}
424     %{ruby_libarchdir}/continuation.so
425     %{ruby_libarchdir}/coverage.so
426     %{ruby_libarchdir}/curses.so
427     %{ruby_libarchdir}/date_core.so
428     %{ruby_libarchdir}/dbm.so
429     %dir %{ruby_libarchdir}/digest
430     %{ruby_libarchdir}/digest.so
431     %{ruby_libarchdir}/digest/*.so
432     %dir %{ruby_libarchdir}/dl
433     %{ruby_libarchdir}/dl.so
434     %{ruby_libarchdir}/dl/*.so
435     %dir %{ruby_libarchdir}/enc
436     %{ruby_libarchdir}/enc/*.so
437 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
438     %{ruby_libarchdir}/enc/trans/*.so
439 fwang 291560 %{ruby_libarchdir}/etc.so
440     %{ruby_libarchdir}/fcntl.so
441     %{ruby_libarchdir}/fiber.so
442     %{ruby_libarchdir}/fiddle.so
443     %{ruby_libarchdir}/gdbm.so
444     %dir %{ruby_libarchdir}/io
445     %{ruby_libarchdir}/io/nonblock.so
446     %{ruby_libarchdir}/io/wait.so
447     %dir %{ruby_libarchdir}/mathn
448 fwang 291562 %{ruby_libarchdir}/mathn/*.so
449 fwang 291560 %{ruby_libarchdir}/nkf.so
450     %{ruby_libarchdir}/objspace.so
451     %{ruby_libarchdir}/openssl.so
452 pterjan 435566 %{ruby_libarchdir}/psych.so
453 fwang 291560 %{ruby_libarchdir}/pathname.so
454     %{ruby_libarchdir}/pty.so
455     %dir %{ruby_libarchdir}/racc
456     %{ruby_libarchdir}/racc/*.so
457     %{ruby_libarchdir}/rbconfig.rb
458     %{ruby_libarchdir}/readline.so
459     %{ruby_libarchdir}/ripper.so
460     %{ruby_libarchdir}/sdbm.so
461     %{ruby_libarchdir}/socket.so
462     %{ruby_libarchdir}/stringio.so
463     %{ruby_libarchdir}/strscan.so
464     %{ruby_libarchdir}/syslog.so
465     %{ruby_libarchdir}/zlib.so
466 fwang 291551 %{_mandir}/man1/erb.1.*
467     %{_mandir}/man1/ruby.1.*
468 blino 1152 %{_datadir}/emacs/site-lisp/*
469     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
470     %{_sysconfdir}/rpm/macros.d/%{name}.macros
471 fwang 291560 %{_datadir}/ruby/site_ruby
472     %{_libdir}/ruby/site_ruby
473     %{_datadir}/ruby/vendor_ruby
474     %{_libdir}/ruby/vendor_ruby
475 fwang 311914 %if %bootstrap
476     %{_bindir}/gem
477 fwang 448831 %dir %{rubygems_dir}
478     %{rubygems_dir}/rbconfig
479     %{rubygems_dir}/rubygems
480     %{rubygems_dir}/rubygems.rb
481     %{rubygems_dir}/ubygems.rb
482 fwang 311914 %endif
483 blino 1152
484     %files doc
485     %{_datadir}/ri
486 pterjan 435211 %{_datadir}/doc/ruby
487 blino 1152
488 fwang 291590 %files -n %{libname}
489     %{_libdir}/libruby.so.%{subver}
490     %{_libdir}/libruby.so.%{rubyapi}
491    
492 blino 1152 %files devel
493 fwang 290003 %{_includedir}/*
494 blino 1152 %{_libdir}/libruby-static.a
495     %{_libdir}/libruby.so
496 fwang 290003 %{_libdir}/pkgconfig/*.pc
497 blino 1152
498     %files tk
499 fwang 291560 %{ruby_libarchdir}/tcltklib.so
500     %{ruby_libarchdir}/tkutil.so
501     %{ruby_libdir}/multi-tk.rb
502     %{ruby_libdir}/remote-tk.rb
503     %{ruby_libdir}/tcltk.rb
504     %{ruby_libdir}/tk.rb
505     %{ruby_libdir}/tkafter.rb
506     %{ruby_libdir}/tkbgerror.rb
507     %{ruby_libdir}/tkcanvas.rb
508     %{ruby_libdir}/tkclass.rb
509     %{ruby_libdir}/tkconsole.rb
510     %{ruby_libdir}/tkdialog.rb
511     %{ruby_libdir}/tkentry.rb
512     %{ruby_libdir}/tkfont.rb
513     %{ruby_libdir}/tkmacpkg.rb
514     %{ruby_libdir}/tkmenubar.rb
515     %{ruby_libdir}/tkmngfocus.rb
516     %{ruby_libdir}/tkpalette.rb
517     %{ruby_libdir}/tkscrollbox.rb
518     %{ruby_libdir}/tktext.rb
519     %{ruby_libdir}/tkvirtevent.rb
520     %{ruby_libdir}/tkwinpkg.rb
521     %{ruby_libdir}/tk
522     %{ruby_libdir}/tkextlib
523 fwang 291551
524 fwang 293412 %files irb
525     %{_bindir}/irb
526     %{ruby_libdir}/irb.rb
527     %{ruby_libdir}/irb
528     %{_mandir}/man1/irb.1*
529    
530     %if %build_gems
531 fwang 291551 %files RubyGems
532     %{_bindir}/gem
533     %dir %{rubygems_dir}
534     %{rubygems_dir}/rbconfig
535     %{rubygems_dir}/rubygems
536     %{rubygems_dir}/rubygems.rb
537     %{rubygems_dir}/ubygems.rb
538    
539 fwang 291562 %files minitest
540     %{ruby_libdir}/minitest
541 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
542 fwang 291562
543 fwang 291551 %files rake
544     %{_bindir}/rake
545     %{_mandir}/man1/rake.1.*
546 fwang 291562 %{ruby_libdir}/rake
547 pterjan 435211 %{rubygems_dir}/gems/rake-*
548     %{rubygems_dir}/specifications/default/rake-*.gemspec
549 fwang 291562
550     %files rdoc
551     %{_bindir}/rdoc
552     %{_bindir}/ri
553     %{ruby_libdir}/rdoc
554 pterjan 435211 %{rubygems_dir}/gems/rdoc-*
555     %{rubygems_dir}/specifications/default/rdoc-*.gemspec
556 fwang 291562 %{_mandir}/man1/ri.1.*
557    
558     %files json
559     %dir %{ruby_libarchdir}/json
560     %dir %{ruby_libarchdir}/json/ext
561     %{ruby_libarchdir}/json/ext/*.so
562     %{ruby_libdir}/json
563 pterjan 435211 %{rubygems_dir}/specifications/default/json-*.gemspec
564 fwang 291590
565     %files bigdecimal
566     %{ruby_libdir}/bigdecimal
567     %{ruby_libarchdir}/bigdecimal.so
568 pterjan 435211 %{rubygems_dir}/specifications/default/bigdecimal-*.gemspec
569 fwang 291590
570     %files io-console
571     %{ruby_libdir}/io
572     %{ruby_libarchdir}/io/console.so
573 pterjan 435211 %{rubygems_dir}/specifications/default/io-console-*.gemspec
574    
575     %files psych
576     %{ruby_libdir}/psych
577     %{ruby_libarchdir}/psych.so
578     %{rubygems_dir}/specifications/default/psych-*.gemspec
579    
580     %files test-unit
581     %{_bindir}/testrb
582     %{ruby_libdir}/test
583     %{rubygems_dir}/gems/test-unit-*
584     %{rubygems_dir}/specifications/default/test-unit-*.gemspec
585 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30