/[packages]/updates/6/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/6/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 892256 - (hide annotations) (download)
Fri Oct 16 21:34:02 2015 UTC (8 years, 6 months ago) by pterjan
Original Path: cauldron/ruby/current/SPECS/ruby.spec
File size: 18624 byte(s)
fix user-dir patch to work in bootstrap
1 pterjan 435211 %define subver 2.0
2     %define rubyapi 2.0.0
3     %define rubyver 2.0.0
4 pterjan 820877 %define patchversion p645
5 pterjan 892256 %define rel 4
6 blino 1152
7 fwang 291590 %define libname %mklibname ruby %{subver}
8    
9 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
10     %define ruby_libarchdir %{_libdir}/%{name}
11    
12 fwang 290007 # This is the local lib/arch and should not be used for packaging.
13 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
14     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
15 fwang 290007
16     # This is the general location for libs/archs compatible with all
17     # or most of the Ruby versions available in the Fedora repositories.
18 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
19 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
20 fwang 290007
21 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
22     # RubyGems should be shared by all Ruby implementations.
23 pterjan 560984 %define rubygems_dir %{_datadir}/rubygems
24 pterjan 560987 %define gems_dir %{_datadir}/ruby/gems
25 pterjan 435211 %define rubygems_version 2.0.2
26 fwang 290007
27 fwang 468908 %define bootstrap 0
28 fwang 468812 %define build_gems 0
29 fwang 292558
30 blino 1152 Summary: Object Oriented Script Language
31     Name: ruby
32     Version: %{rubyver}.%{patchversion}
33     Release: %mkrel %rel
34 kamil 397518 License: Ruby or BSD
35 blino 1152 Group: Development/Ruby
36     BuildRequires: autoconf
37     BuildRequires: byacc
38 shlomif 291698 BuildRequires: doxygen
39 blino 1152 BuildRequires: ncurses-devel
40     BuildRequires: readline-devel
41 ovitters 648773 BuildRequires: tcl-devel
42     BuildRequires: tk-devel
43 fwang 276350 BuildRequires: db-devel
44 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
45 blino 1152 BuildRequires: openssl-devel
46     BuildRequires: zlib-devel
47 fwang 289987 BuildRequires: libffi-devel
48     BuildRequires: yaml-devel
49 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
50 tv 674762 Conflicts: ruby-devel < 2.0.0.p451-4.mga5
51 blino 1152 Obsoletes: ruby-rexml
52     Provides: ruby-rexml
53 pterjan 435566 # Couldn't get the standalone gem to work
54     Provides: rubygem(psych)
55 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
56     Provides: /usr/bin/ruby
57 fwang 293445 Provides: ruby(abi) = %rubyapi
58 fwang 463762 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
59 pterjan 435211 Source1: operating_system.rb
60 blino 1152 Source3: ruby.macros
61 tv 673709 # From FC:
62     # RPM dependency generators.
63     Source8: rubygems.attr
64     Source9: rubygems.req
65     Source10: rubygems.prov
66 blino 1152 URL: http://www.ruby-lang.org/
67 fwang 292558 %if !%bootstrap
68     Requires: rubygems >= %{rubygems_version}
69 fwang 293395 BuildRequires: ruby
70 fwang 292558 %endif
71 blino 1152
72 fwang 290007 # == FEDORA PATCHES BEGINS ==
73 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
74     Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
75     # Fixes random WEBRick test failures.
76     # https://bugs.ruby-lang.org/issues/6573.
77     Patch5: ruby-1.9.3.p195-fix-webrick-tests.patch
78 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
79     # http://redmine.ruby-lang.org/issues/5617
80     Patch8: ruby-1.9.3-custom-rubygems-location.patch
81     # Add support for installing binary extensions according to FHS.
82     # https://github.com/rubygems/rubygems/issues/210
83 pterjan 435211 # Note that 8th patch might be resolved by
84     # https://bugs.ruby-lang.org/issues/7897
85     Patch9: rubygems-2.0.0-binary-extensions.patch
86     # Make mkmf verbose by default
87     Patch12: ruby-1.9.3-mkmf-verbose.patch
88     # This slightly changes behavior of "gem install --install-dir" behavior.
89     # Without this patch, Specifications.dirs is modified and gems installed on
90     # the system cannot be required anymore. This causes later issues when RDoc
91     # documentation should be generated, since json gem is sudenly not accessible.
92     # https://github.com/rubygems/rubygems/pull/452
93     Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.patch
94     # This prevents issues, when ruby configuration specifies --with-ruby-version=''.
95     # https://github.com/rubygems/rubygems/pull/455
96     Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
97 fwang 290007 # == FEDORA PATCHES ENDS ==
98 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
99     # to install gems into user dir
100     Patch20: ruby-2.0.0-p451-Do-not-install-to-user-dir.patch
101 fwang 290007
102 luigiwalser 795834 Patch21: ruby-2.0.0-CVE-2014-4975.patch
103 pterjan 889596 Patch22: ruby-2.0.0-tk2.6.patch
104 luigiwalser 795834
105 fwang 291591 %package -n %{libname}
106 fwang 291590 Summary: Libraries necessary to run Ruby
107     Group: Development/Ruby
108    
109 blino 1152 %package doc
110     Summary: Documentation for the powerful language Ruby
111     Group: Development/Ruby
112 fwang 202696 BuildArch: noarch
113 blino 1152
114     %package devel
115     Summary: Development file for the powerful language Ruby
116     Group: Development/Ruby
117 fwang 311925 Requires: %{name} = %{version}
118     Requires: %{libname} = %{version}
119 blino 1152
120     %package tk
121     Summary: Tk extension for the powerful language Ruby
122     Group: Development/Ruby
123 fwang 311925 Requires: %{name} = %{version}
124 blino 1152
125 fwang 291551 %package RubyGems
126     Summary: The Ruby standard for packaging ruby libraries
127     Group: Development/Ruby
128 fwang 291590 Version: %{rubygems_version}
129 fwang 291551 Requires: ruby(abi) = %{subver}
130 fwang 291590 Provides: gem = %{rubygems_version}
131     Provides: rubygems = %{rubygems_version}
132     Provides: ruby(rubygems) = %{rubygems_version}
133 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
134 fwang 291561 BuildArch: noarch
135 fwang 291551
136 pterjan 435211 %define rake_ver 0.9.6
137 fwang 291551 %package rake
138     Summary: Simple ruby build program with capabilities similar to make
139     Group: Development/Ruby
140 shlomif 291767 Version: %{rake_ver}
141 fwang 291551 Requires: ruby(abi) = %{subver}
142 fwang 291561 BuildArch: noarch
143 fwang 291551
144 pterjan 435211 %define minitest_ver 4.3.2
145 fwang 291562 %package minitest
146 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
147 fwang 291562 Group: Development/Ruby
148 shlomif 291767 Version: %{minitest_ver}
149 fwang 291562 License: MIT
150 fwang 291590 Requires: ruby(abi) = %{subver}
151     Requires: ruby(rubygems) >= %{rubygems_version}
152 fwang 291562 BuildArch: noarch
153    
154 pterjan 435211 %define json_ver 1.7.7
155 fwang 291562 %package json
156     Summary: This is a JSON implementation as a Ruby extension in C
157     Group: Development/Ruby
158 shlomif 291767 Version: %{json_ver}
159 fwang 291562 License: Ruby or GPLv2
160 fwang 291590 Requires: ruby(abi) = %{subver}
161     Requires: ruby(rubygems) >= %{rubygems_version}
162 fwang 291562
163 pterjan 435211 %define rdoc_ver 4.0.0
164 fwang 291562 %package rdoc
165     Summary: A tool to generate HTML and command-line documentation for Ruby projects
166     Group: Development/Ruby
167 shlomif 291767 Version: %{rdoc_ver}
168 fwang 291562 License: GPLv2 and Ruby and MIT
169 fwang 291590 Requires: ruby(abi) = %{subver}
170     Requires: ruby(rubygems) >= %{rubygems_version}
171     Requires: ruby(irb) = %{version}
172 shlomif 291767 Provides: rdoc = %{rdoc_ver}
173     Provides: ri = %{rdoc_ver}
174 fwang 291562 BuildArch: noarch
175    
176 fwang 291590 %package irb
177     Summary: The Interactive Ruby
178     Group: Development/Ruby
179     Provides: irb = %{version}-%{release}
180     Provides: ruby(irb) = %{version}-%{release}
181 fwang 313459 Conflicts: ruby < 1.9
182 fwang 313460 BuildArch: noarch
183 fwang 291590
184 pterjan 435211 %define bigdecimal_ver 1.2.0
185 fwang 291590 %package bigdecimal
186     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
187     Group: Development/Ruby
188 pterjan 435211 Version: %{bigdecimal_ver}
189 fwang 291590 License: GPL+ or Artistic
190     Requires: ruby(abi) = %{subver}
191     Requires: ruby(rubygems) >= %{rubygems_version}
192    
193 pterjan 435211 %define io_console_ver 0.4.2
194 fwang 291590 %package io-console
195     Summary: IO/Console is a simple console utilizing library
196     Group: Development/Ruby
197 pterjan 435211 Version: %{io_console_ver}
198 fwang 291590 Requires: ruby(abi) = %{subver}
199     Requires: ruby(rubygems) >= %{rubygems_version}
200    
201 pterjan 435211 %define psych_ver 2.0.0
202     %package psych
203     Summary: A libyaml wrapper for Ruby
204     Version: %{psych_ver}
205     Group: Development/Ruby
206     License: MIT
207     Requires: ruby(abi) = %{subver}
208     Requires: ruby(rubygems) >= %{rubygems_version}
209     Conflicts: ruby < 2.0.0
210    
211     %define test_unit_ver 2.0.0
212     %package test-unit
213     Summary: test/unit compatible API testing framework
214     Version: %{psych_ver}
215     Group: Development/Ruby
216     License: MIT
217     Requires: ruby(abi) = %{subver}
218     Requires: ruby(rubygems) >= %{rubygems_version}
219     Conflicts: ruby < 2.0.0
220     BuildArch: noarch
221    
222 blino 1152 %description
223     Ruby is the interpreted scripting language for quick and
224     easy object-oriented programming. It has many features to
225     process text files and to do system management tasks (as in
226     Perl). It is simple, straight-forward, and extensible.
227    
228     %description doc
229     Ruby is the interpreted scripting language for quick and
230     easy object-oriented programming. It has many features to
231     process text files and to do system management tasks (as in
232     Perl). It is simple, straight-forward, and extensible.
233    
234     This package contains the Ruby's documentation
235    
236 fwang 291590 %description -n %{libname}
237     This package includes the libruby, necessary to run Ruby.
238    
239 blino 1152 %description devel
240     Ruby is the interpreted scripting language for quick and
241     easy object-oriented programming. It has many features to
242     process text files and to do system management tasks (as in
243     Perl). It is simple, straight-forward, and extensible.
244    
245     This package contains the Ruby's devel files.
246    
247     %description tk
248     Ruby is the interpreted scripting language for quick and
249     easy object-oriented programming. It has many features to
250     process text files and to do system management tasks (as in
251     Perl). It is simple, straight-forward, and extensible.
252    
253     This package contains the Tk extension for Ruby.
254    
255 fwang 291551 %description RubyGems
256     RubyGems is the Ruby standard for publishing and managing third party
257     libraries.
258    
259 fwang 291552 %description rake
260     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
261     specified in standard Ruby syntax.
262    
263 fwang 291562 %description rdoc
264     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
265     includes the 'rdoc' and 'ri' tools for generating and displaying online
266     documentation.
267    
268     %description json
269     This is a implementation of the JSON specification according to RFC 4627.
270     You can think of it as a low fat alternative to XML, if you want to store
271     data to disk or transmit it over a network rather than use a verbose
272     markup language.
273    
274     %description minitest
275     minitest/unit is a small and incredibly fast unit testing framework.
276    
277     minitest/spec is a functionally complete spec engine.
278    
279     minitest/benchmark is an awesome way to assert the performance of your
280     algorithms in a repeatable manner.
281    
282     minitest/mock by Steven Baker, is a beautifully tiny mock object
283     framework.
284    
285     minitest/pride shows pride in testing and adds coloring to your test
286     output.
287    
288 fwang 291590 %description irb
289     The irb is acronym for Interactive Ruby. It evaluates ruby expression
290     from the terminal.
291    
292     %description bigdecimal
293     Ruby provides built-in support for arbitrary precision integer arithmetic.
294     For example:
295    
296     42**13 -> 1265437718438866624512
297    
298     BigDecimal provides similar support for very large or very accurate floating
299     point numbers. Decimal arithmetic is also useful for general calculation,
300     because it provides the correct answers people expect–whereas normal binary
301     floating point arithmetic often introduces subtle errors because of the
302     conversion between base 10 and base 2.
303    
304     %description io-console
305     IO/Console provides very simple and portable access to console. It doesn't
306     provide higher layer features, such like curses and readline.
307    
308 pterjan 435211 %description psych
309     Psych is a YAML parser and emitter. Psych leverages
310     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
311     capabilities. In addition to wrapping libyaml, Psych also knows how to
312     serialize and de-serialize most Ruby objects to and from the YAML format.
313    
314     %description test-unit
315     This library implements test/unit compatible API on minitest.
316     The test/unit means that test/unit which was bundled with Ruby 1.8.
317    
318 blino 1152 %prep
319     %setup -q -n ruby-%{rubyver}-%{patchversion}
320 fwang 290007 %apply_patches
321 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
322     rm lib/mkmf.rb.0*
323 blino 1152
324     %build
325 fwang 290038 autoconf
326 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
327 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
328 fwang 291557 --with-rubylibprefix='%{ruby_libdir}' \
329 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
330 fwang 290007 --with-sitedir='%{ruby_sitelibdir}' \
331     --with-sitearchdir='%{ruby_sitearchdir}' \
332     --with-vendordir='%{ruby_vendorlibdir}' \
333     --with-vendorarchdir='%{ruby_vendorarchdir}' \
334 fwang 291559 --with-rubyhdrdir='%{_includedir}' \
335 pterjan 435211 --with-rubyarchhdrdir='$(archincludedir)' \
336     --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
337     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
338     --with-rubygemsdir='%{rubygems_dir}' \
339     --with-ruby-pc='%{name}.pc' \
340     --enable-multiarch \
341     --with-ruby-version=''
342 blino 1152 %make
343    
344     %install
345     %makeinstall_std install-doc
346    
347     install -d %buildroot%{_datadir}/emacs/site-lisp
348     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
349    
350     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
351     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
352     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
353     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
354     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
355     EOF
356    
357     # Install the rpm macros
358     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
359     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
360 fwang 289961
361 tv 673709 # Install dependency generators.
362     mkdir -p %{buildroot}%{_rpmconfigdir}/fileattrs
363     install -m 644 %{SOURCE8} %{buildroot}%{_rpmconfigdir}/fileattrs
364     install -m 755 %{SOURCE9} %{buildroot}%{_rpmconfigdir}
365     install -m 755 %{SOURCE10} %{buildroot}%{_rpmconfigdir}
366    
367 pterjan 435211 # Install custom operating_system.rb
368     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
369     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
370    
371 pterjan 617250 # Version is empty if --with-ruby-version is specified.
372     # http://bugs.ruby-lang.org/issues/7807
373     sed -i 's/Version: .*/Version: %{rubyver}/' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
374    
375 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
376     %if !%build_gems
377 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
378 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
379 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
380     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
381 pterjan 560987 rm -fr %{buildroot}%{gems_dir}/{gems,specifications}
382 fwang 311915 %if !%bootstrap
383 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
384 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
385     rm -fr %{buildroot}%{rubygems_dir}/rubygems
386 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
387     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
388 fwang 293412 %endif
389 fwang 311914 %endif
390 fwang 293412
391 blino 1152 %check
392     make test
393    
394 fwang 289961 %files
395 fwang 291551 %{_bindir}/erb
396     %{_bindir}/ruby
397 fwang 291560 %dir %{ruby_libdir}
398     %{ruby_libdir}/*.rb
399 fwang 291590 %exclude %{ruby_libdir}/irb.rb
400 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
401     %exclude %{ruby_libdir}/remote-tk.rb
402     %exclude %{ruby_libdir}/tcltk.rb
403     %exclude %{ruby_libdir}/tk.rb
404     %exclude %{ruby_libdir}/tkafter.rb
405     %exclude %{ruby_libdir}/tkbgerror.rb
406     %exclude %{ruby_libdir}/tkcanvas.rb
407     %exclude %{ruby_libdir}/tkclass.rb
408     %exclude %{ruby_libdir}/tkconsole.rb
409     %exclude %{ruby_libdir}/tkdialog.rb
410     %exclude %{ruby_libdir}/tkentry.rb
411     %exclude %{ruby_libdir}/tkfont.rb
412     %exclude %{ruby_libdir}/tkmacpkg.rb
413     %exclude %{ruby_libdir}/tkmenubar.rb
414     %exclude %{ruby_libdir}/tkmngfocus.rb
415     %exclude %{ruby_libdir}/tkpalette.rb
416     %exclude %{ruby_libdir}/tkscrollbox.rb
417     %exclude %{ruby_libdir}/tktext.rb
418     %exclude %{ruby_libdir}/tkvirtevent.rb
419     %exclude %{ruby_libdir}/tkwinpkg.rb
420     %{ruby_libdir}/cgi
421     %{ruby_libdir}/date
422     %{ruby_libdir}/digest
423     %{ruby_libdir}/dl
424     %{ruby_libdir}/drb
425     %{ruby_libdir}/fiddle
426     %{ruby_libdir}/matrix
427     %{ruby_libdir}/net
428     %{ruby_libdir}/openssl
429     %{ruby_libdir}/optparse
430 pterjan 435566 %{ruby_libdir}/psych
431 fwang 291560 %{ruby_libdir}/racc
432     %{ruby_libdir}/rbconfig
433     %{ruby_libdir}/rexml
434     %{ruby_libdir}/rinda
435     %{ruby_libdir}/ripper
436     %{ruby_libdir}/rss
437     %{ruby_libdir}/shell
438 pterjan 435211 %{ruby_libdir}/syslog
439 fwang 291560 %{ruby_libdir}/uri
440     %{ruby_libdir}/webrick
441     %{ruby_libdir}/xmlrpc
442     %{ruby_libdir}/yaml
443     %dir %{ruby_libarchdir}
444     %{ruby_libarchdir}/continuation.so
445     %{ruby_libarchdir}/coverage.so
446     %{ruby_libarchdir}/curses.so
447     %{ruby_libarchdir}/date_core.so
448     %{ruby_libarchdir}/dbm.so
449     %dir %{ruby_libarchdir}/digest
450     %{ruby_libarchdir}/digest.so
451     %{ruby_libarchdir}/digest/*.so
452     %dir %{ruby_libarchdir}/dl
453     %{ruby_libarchdir}/dl.so
454     %{ruby_libarchdir}/dl/*.so
455     %dir %{ruby_libarchdir}/enc
456     %{ruby_libarchdir}/enc/*.so
457 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
458     %{ruby_libarchdir}/enc/trans/*.so
459 fwang 291560 %{ruby_libarchdir}/etc.so
460     %{ruby_libarchdir}/fcntl.so
461     %{ruby_libarchdir}/fiber.so
462     %{ruby_libarchdir}/fiddle.so
463     %{ruby_libarchdir}/gdbm.so
464     %dir %{ruby_libarchdir}/io
465     %{ruby_libarchdir}/io/nonblock.so
466     %{ruby_libarchdir}/io/wait.so
467     %dir %{ruby_libarchdir}/mathn
468 fwang 291562 %{ruby_libarchdir}/mathn/*.so
469 fwang 291560 %{ruby_libarchdir}/nkf.so
470     %{ruby_libarchdir}/objspace.so
471     %{ruby_libarchdir}/openssl.so
472 pterjan 435566 %{ruby_libarchdir}/psych.so
473 fwang 291560 %{ruby_libarchdir}/pathname.so
474     %{ruby_libarchdir}/pty.so
475     %dir %{ruby_libarchdir}/racc
476     %{ruby_libarchdir}/racc/*.so
477     %{ruby_libarchdir}/rbconfig.rb
478     %{ruby_libarchdir}/readline.so
479     %{ruby_libarchdir}/ripper.so
480     %{ruby_libarchdir}/sdbm.so
481     %{ruby_libarchdir}/socket.so
482     %{ruby_libarchdir}/stringio.so
483     %{ruby_libarchdir}/strscan.so
484     %{ruby_libarchdir}/syslog.so
485     %{ruby_libarchdir}/zlib.so
486 fwang 291551 %{_mandir}/man1/erb.1.*
487     %{_mandir}/man1/ruby.1.*
488 blino 1152 %{_datadir}/emacs/site-lisp/*
489     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
490     %{_sysconfdir}/rpm/macros.d/%{name}.macros
491 fwang 291560 %{_datadir}/ruby/site_ruby
492     %{_libdir}/ruby/site_ruby
493     %{_datadir}/ruby/vendor_ruby
494     %{_libdir}/ruby/vendor_ruby
495 fwang 311914 %if %bootstrap
496     %{_bindir}/gem
497 fwang 448831 %dir %{rubygems_dir}
498     %{rubygems_dir}/rbconfig
499     %{rubygems_dir}/rubygems
500     %{rubygems_dir}/rubygems.rb
501     %{rubygems_dir}/ubygems.rb
502 fwang 311914 %endif
503 tv 674762 %{_rpmconfigdir}/fileattrs/rubygems.attr
504     %{_rpmconfigdir}/rubygems.req
505     %{_rpmconfigdir}/rubygems.prov
506 blino 1152
507     %files doc
508     %{_datadir}/ri
509 pterjan 435211 %{_datadir}/doc/ruby
510 blino 1152
511 fwang 291590 %files -n %{libname}
512     %{_libdir}/libruby.so.%{subver}
513     %{_libdir}/libruby.so.%{rubyapi}
514    
515 blino 1152 %files devel
516 fwang 290003 %{_includedir}/*
517 blino 1152 %{_libdir}/libruby-static.a
518     %{_libdir}/libruby.so
519 fwang 290003 %{_libdir}/pkgconfig/*.pc
520 blino 1152
521     %files tk
522 fwang 291560 %{ruby_libarchdir}/tcltklib.so
523     %{ruby_libarchdir}/tkutil.so
524     %{ruby_libdir}/multi-tk.rb
525     %{ruby_libdir}/remote-tk.rb
526     %{ruby_libdir}/tcltk.rb
527     %{ruby_libdir}/tk.rb
528     %{ruby_libdir}/tkafter.rb
529     %{ruby_libdir}/tkbgerror.rb
530     %{ruby_libdir}/tkcanvas.rb
531     %{ruby_libdir}/tkclass.rb
532     %{ruby_libdir}/tkconsole.rb
533     %{ruby_libdir}/tkdialog.rb
534     %{ruby_libdir}/tkentry.rb
535     %{ruby_libdir}/tkfont.rb
536     %{ruby_libdir}/tkmacpkg.rb
537     %{ruby_libdir}/tkmenubar.rb
538     %{ruby_libdir}/tkmngfocus.rb
539     %{ruby_libdir}/tkpalette.rb
540     %{ruby_libdir}/tkscrollbox.rb
541     %{ruby_libdir}/tktext.rb
542     %{ruby_libdir}/tkvirtevent.rb
543     %{ruby_libdir}/tkwinpkg.rb
544     %{ruby_libdir}/tk
545     %{ruby_libdir}/tkextlib
546 fwang 291551
547 fwang 293412 %files irb
548     %{_bindir}/irb
549     %{ruby_libdir}/irb.rb
550     %{ruby_libdir}/irb
551     %{_mandir}/man1/irb.1*
552    
553     %if %build_gems
554 fwang 291551 %files RubyGems
555     %{_bindir}/gem
556     %dir %{rubygems_dir}
557     %{rubygems_dir}/rbconfig
558     %{rubygems_dir}/rubygems
559     %{rubygems_dir}/rubygems.rb
560     %{rubygems_dir}/ubygems.rb
561    
562 fwang 291562 %files minitest
563     %{ruby_libdir}/minitest
564 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
565 fwang 291562
566 fwang 291551 %files rake
567     %{_bindir}/rake
568     %{_mandir}/man1/rake.1.*
569 fwang 291562 %{ruby_libdir}/rake
570 pterjan 560987 %{gems_dir}/gems/rake-*
571     %{gems_dir}/specifications/default/rake-*.gemspec
572 fwang 291562
573     %files rdoc
574     %{_bindir}/rdoc
575     %{_bindir}/ri
576     %{ruby_libdir}/rdoc
577 pterjan 560987 %{gems_dir}/gems/rdoc-*
578     %{gems_dir}/specifications/default/rdoc-*.gemspec
579 fwang 291562 %{_mandir}/man1/ri.1.*
580    
581     %files json
582     %dir %{ruby_libarchdir}/json
583     %dir %{ruby_libarchdir}/json/ext
584     %{ruby_libarchdir}/json/ext/*.so
585     %{ruby_libdir}/json
586 pterjan 560987 %{gems_dir}/specifications/default/json-*.gemspec
587 fwang 291590
588     %files bigdecimal
589     %{ruby_libdir}/bigdecimal
590     %{ruby_libarchdir}/bigdecimal.so
591 pterjan 560987 %{gems_dir}/specifications/default/bigdecimal-*.gemspec
592 fwang 291590
593     %files io-console
594     %{ruby_libdir}/io
595     %{ruby_libarchdir}/io/console.so
596 pterjan 560987 %{gems_dir}/specifications/default/io-console-*.gemspec
597 pterjan 435211
598     %files psych
599     %{ruby_libdir}/psych
600     %{ruby_libarchdir}/psych.so
601 pterjan 560987 %{gems_dir}/specifications/default/psych-*.gemspec
602 pterjan 435211
603     %files test-unit
604     %{_bindir}/testrb
605     %{ruby_libdir}/test
606 pterjan 560987 %{gems_dir}/gems/test-unit-*
607 pterjan 435211 %{rubygems_dir}/specifications/default/test-unit-*.gemspec
608 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30