/[packages]/updates/6/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/6/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 894348 - (hide annotations) (download)
Thu Oct 22 23:15:39 2015 UTC (8 years, 5 months ago) by blino
Original Path: cauldron/ruby/current/SPECS/ruby.spec
File size: 20754 byte(s)
rebuild in bootstrap mode to be able to rebuild ruby-json which is required by ruby-RubyGems and thus ruby
1 shlomif 893775 # Taken from the fedora ruby-2.2.3 .spec. Thanks!
2 blino 1152
3 shlomif 893775 %global major_version 2
4     %global minor_version 2
5     %global teeny_version 3
6     %global major_minor_version %{major_version}.%{minor_version}
7    
8     %global ruby_version %{major_minor_version}.%{teeny_version}
9     %global ruby_release %{ruby_version}
10    
11     # Specify the named version. It has precedense to revision.
12     #%%global milestone rc1
13    
14     # Keep the revision enabled for pre-releases from SVN.
15     #%%global revision 48936
16    
17     %global ruby_archive %{name}-%{ruby_version}
18    
19     # If revision and milestone are removed/commented out, the official release build is expected.
20     %if 0%{?milestone:1}%{?revision:1} != 0
21     %global development_release %{?milestone}%{?!milestone:%{?revision:r%{revision}}}
22     %global ruby_archive %{ruby_archive}-%{?milestone}%{?!milestone:%{?revision:r%{revision}}}
23     %endif
24    
25    
26 blino 894348 %global release 2
27 shlomif 893775 %{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
28    
29     %global rubygems_version 2.4.5.1
30    
31     # The RubyGems library has to stay out of Ruby directory three, since the
32     # RubyGems should be share by all Ruby implementations.
33     %global rubygems_dir %{_datadir}/rubygems
34    
35     # TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM.
36     # http://redmine.ruby-lang.org/issues/5313
37     %global irb_version %{ruby_version}
38    
39     %global bigdecimal_version 1.2.6
40     %global io_console_version 0.4.3
41     %global json_version 1.8.1
42     %global minitest_version 5.4.3
43     %global power_assert_version 0.2.2
44     %global psych_version 2.0.8
45     %global rake_version 10.4.2
46     %global rdoc_version 4.2.0
47     %global test_unit_version 3.0.8
48    
49     # Might not be needed in the future, if we are lucky enough.
50     # https://bugzilla.redhat.com/show_bug.cgi?id=888262
51     %global tapset_root %{_datadir}/systemtap
52     %global tapset_dir %{tapset_root}/tapset
53     %global tapset_libdir %(echo %{_libdir} | sed 's/64//')*
54    
55     %global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/;s/sparcv./sparc/')
56    
57     %global with_rubypick 1
58    
59     # Additional defines by Mageia.
60    
61     %define subver %{major_minor_version}
62     %define rubyapi %{subver}.0
63     %define rubyver %{ruby_version}
64     %define rel %{release}
65    
66 fwang 291590 %define libname %mklibname ruby %{subver}
67    
68 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
69     %define ruby_libarchdir %{_libdir}/%{name}
70    
71 fwang 290007 # This is the local lib/arch and should not be used for packaging.
72 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
73     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
74 fwang 290007
75     # This is the general location for libs/archs compatible with all
76     # or most of the Ruby versions available in the Fedora repositories.
77 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
78 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
79 fwang 290007
80 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
81     # RubyGems should be shared by all Ruby implementations.
82 pterjan 560987 %define gems_dir %{_datadir}/ruby/gems
83 fwang 290007
84 blino 894348 %define bootstrap 1
85 fwang 468812 %define build_gems 0
86 fwang 292558
87 blino 1152 Summary: Object Oriented Script Language
88     Name: ruby
89 shlomif 893775 Version: %{rubyver}
90 blino 1152 Release: %mkrel %rel
91 kamil 397518 License: Ruby or BSD
92 blino 1152 Group: Development/Ruby
93     BuildRequires: autoconf
94     BuildRequires: byacc
95 shlomif 291698 BuildRequires: doxygen
96 blino 1152 BuildRequires: ncurses-devel
97     BuildRequires: readline-devel
98 shlomif 893775 BuildRequires: tcl-devel
99 ovitters 648773 BuildRequires: tk-devel
100 fwang 276350 BuildRequires: db-devel
101 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
102 blino 1152 BuildRequires: openssl-devel
103     BuildRequires: zlib-devel
104 fwang 289987 BuildRequires: libffi-devel
105     BuildRequires: yaml-devel
106 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
107 tv 674762 Conflicts: ruby-devel < 2.0.0.p451-4.mga5
108 blino 1152 Obsoletes: ruby-rexml
109     Provides: ruby-rexml
110 pterjan 435566 # Couldn't get the standalone gem to work
111     Provides: rubygem(psych)
112 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
113     Provides: /usr/bin/ruby
114 fwang 293445 Provides: ruby(abi) = %rubyapi
115 shlomif 893775 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}.tar.xz
116 pterjan 435211 Source1: operating_system.rb
117 blino 1152 Source3: ruby.macros
118 tv 673709 # From FC:
119     # RPM dependency generators.
120     Source8: rubygems.attr
121     Source9: rubygems.req
122     Source10: rubygems.prov
123 shlomif 893775 URL: http://ruby-lang.org/
124 fwang 292558 %if !%bootstrap
125     Requires: rubygems >= %{rubygems_version}
126 fwang 293395 BuildRequires: ruby
127 fwang 292558 %endif
128 blino 1152
129 fwang 290007 # == FEDORA PATCHES BEGINS ==
130 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
131 shlomif 893775 Patch0: ruby-2.1.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
132     # Allows to override libruby.so placement. Hopefully we will be able to return
133     # to plain --with-rubyarchprefix.
134     # http://bugs.ruby-lang.org/issues/8973
135     Patch1: ruby-2.1.0-Enable-configuration-of-archlibdir.patch
136     # Force multiarch directories for i.86 to be always named i386. This solves
137     # some differencies in build between Fedora and RHEL.
138     Patch2: ruby-2.1.0-always-use-i386.patch
139 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
140 shlomif 893775 # http://bugs.ruby-lang.org/issues/5617
141     Patch4: ruby-2.1.0-custom-rubygems-location.patch
142 pterjan 435211 # Make mkmf verbose by default
143 shlomif 893775 Patch5: ruby-1.9.3-mkmf-verbose.patch
144     # Adds support for '--with-prelude' configuration option. This allows to built
145     # in support for ABRT.
146     # http://bugs.ruby-lang.org/issues/8566
147     Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
148     # Don't use SSLv3 for tests.
149     # https://bugs.ruby-lang.org/issues/10046
150     Patch9: ruby-2.3.0-fix-test-ctx-client-session-cb.patch
151     Patch10: ruby-2.3.0-Don-t-force-SSLv3-in-test-as-it-is-insecure-and-may-.patch
152     Patch11: ruby-2.3.0-Use-OP_NO_TICKET-when-testing-SSL-session-cache-call.patch
153 fwang 290007 # == FEDORA PATCHES ENDS ==
154 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
155     # to install gems into user dir
156 shlomif 893775 Patch20: ruby-2.3.0-Do-not-installt-user-dir.patch
157 fwang 290007
158 shlomif 893775 # Patch22: ruby-2.0.0-tk2.6.patch
159 luigiwalser 795834
160 fwang 291591 %package -n %{libname}
161 fwang 291590 Summary: Libraries necessary to run Ruby
162     Group: Development/Ruby
163    
164 blino 1152 %package doc
165     Summary: Documentation for the powerful language Ruby
166     Group: Development/Ruby
167 fwang 202696 BuildArch: noarch
168 blino 1152
169     %package devel
170     Summary: Development file for the powerful language Ruby
171     Group: Development/Ruby
172 fwang 311925 Requires: %{name} = %{version}
173     Requires: %{libname} = %{version}
174 blino 1152
175     %package tk
176     Summary: Tk extension for the powerful language Ruby
177     Group: Development/Ruby
178 fwang 311925 Requires: %{name} = %{version}
179 blino 1152
180 fwang 291551 %package RubyGems
181     Summary: The Ruby standard for packaging ruby libraries
182     Group: Development/Ruby
183 fwang 291590 Version: %{rubygems_version}
184 fwang 291551 Requires: ruby(abi) = %{subver}
185 fwang 291590 Provides: gem = %{rubygems_version}
186     Provides: rubygems = %{rubygems_version}
187     Provides: ruby(rubygems) = %{rubygems_version}
188 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
189 fwang 291561 BuildArch: noarch
190 fwang 291551
191 shlomif 893775 %define rake_ver %{rake_version}
192 fwang 291551 %package rake
193     Summary: Simple ruby build program with capabilities similar to make
194     Group: Development/Ruby
195 shlomif 291767 Version: %{rake_ver}
196 fwang 291551 Requires: ruby(abi) = %{subver}
197 fwang 291561 BuildArch: noarch
198 fwang 291551
199 shlomif 893775 %define minitest_ver %{minitest_version}
200 fwang 291562 %package minitest
201 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
202 fwang 291562 Group: Development/Ruby
203 shlomif 291767 Version: %{minitest_ver}
204 fwang 291562 License: MIT
205 fwang 291590 Requires: ruby(abi) = %{subver}
206     Requires: ruby(rubygems) >= %{rubygems_version}
207 fwang 291562 BuildArch: noarch
208    
209 shlomif 893775 %define json_ver %{json_version}
210 fwang 291562 %package json
211     Summary: This is a JSON implementation as a Ruby extension in C
212     Group: Development/Ruby
213 shlomif 291767 Version: %{json_ver}
214 fwang 291562 License: Ruby or GPLv2
215 fwang 291590 Requires: ruby(abi) = %{subver}
216     Requires: ruby(rubygems) >= %{rubygems_version}
217 fwang 291562
218 shlomif 893775 %define rdoc_ver %{rdoc_version}
219 fwang 291562 %package rdoc
220     Summary: A tool to generate HTML and command-line documentation for Ruby projects
221     Group: Development/Ruby
222 shlomif 291767 Version: %{rdoc_ver}
223 fwang 291562 License: GPLv2 and Ruby and MIT
224 fwang 291590 Requires: ruby(abi) = %{subver}
225     Requires: ruby(rubygems) >= %{rubygems_version}
226     Requires: ruby(irb) = %{version}
227 shlomif 291767 Provides: rdoc = %{rdoc_ver}
228     Provides: ri = %{rdoc_ver}
229 fwang 291562 BuildArch: noarch
230    
231 fwang 291590 %package irb
232     Summary: The Interactive Ruby
233     Group: Development/Ruby
234     Provides: irb = %{version}-%{release}
235     Provides: ruby(irb) = %{version}-%{release}
236 fwang 313459 Conflicts: ruby < 1.9
237 fwang 313460 BuildArch: noarch
238 fwang 291590
239 shlomif 893775 %define bigdecimal_ver %{bigdecimal_version}
240 fwang 291590 %package bigdecimal
241     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
242     Group: Development/Ruby
243 pterjan 435211 Version: %{bigdecimal_ver}
244 fwang 291590 License: GPL+ or Artistic
245     Requires: ruby(abi) = %{subver}
246     Requires: ruby(rubygems) >= %{rubygems_version}
247    
248 shlomif 893775 %define io_console_ver %{io_console_version}
249 fwang 291590 %package io-console
250     Summary: IO/Console is a simple console utilizing library
251     Group: Development/Ruby
252 pterjan 435211 Version: %{io_console_ver}
253 fwang 291590 Requires: ruby(abi) = %{subver}
254     Requires: ruby(rubygems) >= %{rubygems_version}
255    
256 shlomif 893775 %define psych_ver %{psych_version}
257 pterjan 435211 %package psych
258     Summary: A libyaml wrapper for Ruby
259     Version: %{psych_ver}
260     Group: Development/Ruby
261     License: MIT
262     Requires: ruby(abi) = %{subver}
263     Requires: ruby(rubygems) >= %{rubygems_version}
264     Conflicts: ruby < 2.0.0
265    
266 shlomif 893775 %define test_unit_ver %{test_unit_version}
267 pterjan 435211 %package test-unit
268     Summary: test/unit compatible API testing framework
269     Version: %{psych_ver}
270     Group: Development/Ruby
271     License: MIT
272     Requires: ruby(abi) = %{subver}
273     Requires: ruby(rubygems) >= %{rubygems_version}
274     Conflicts: ruby < 2.0.0
275     BuildArch: noarch
276    
277 blino 1152 %description
278     Ruby is the interpreted scripting language for quick and
279     easy object-oriented programming. It has many features to
280     process text files and to do system management tasks (as in
281     Perl). It is simple, straight-forward, and extensible.
282    
283     %description doc
284     Ruby is the interpreted scripting language for quick and
285     easy object-oriented programming. It has many features to
286     process text files and to do system management tasks (as in
287     Perl). It is simple, straight-forward, and extensible.
288    
289     This package contains the Ruby's documentation
290    
291 fwang 291590 %description -n %{libname}
292     This package includes the libruby, necessary to run Ruby.
293    
294 blino 1152 %description devel
295     Ruby is the interpreted scripting language for quick and
296     easy object-oriented programming. It has many features to
297     process text files and to do system management tasks (as in
298     Perl). It is simple, straight-forward, and extensible.
299    
300     This package contains the Ruby's devel files.
301    
302     %description tk
303     Ruby is the interpreted scripting language for quick and
304     easy object-oriented programming. It has many features to
305     process text files and to do system management tasks (as in
306     Perl). It is simple, straight-forward, and extensible.
307    
308     This package contains the Tk extension for Ruby.
309    
310 fwang 291551 %description RubyGems
311     RubyGems is the Ruby standard for publishing and managing third party
312     libraries.
313    
314 fwang 291552 %description rake
315     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
316     specified in standard Ruby syntax.
317    
318 fwang 291562 %description rdoc
319     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
320     includes the 'rdoc' and 'ri' tools for generating and displaying online
321     documentation.
322    
323     %description json
324     This is a implementation of the JSON specification according to RFC 4627.
325     You can think of it as a low fat alternative to XML, if you want to store
326     data to disk or transmit it over a network rather than use a verbose
327     markup language.
328    
329     %description minitest
330     minitest/unit is a small and incredibly fast unit testing framework.
331    
332     minitest/spec is a functionally complete spec engine.
333    
334     minitest/benchmark is an awesome way to assert the performance of your
335     algorithms in a repeatable manner.
336    
337     minitest/mock by Steven Baker, is a beautifully tiny mock object
338     framework.
339    
340     minitest/pride shows pride in testing and adds coloring to your test
341     output.
342    
343 fwang 291590 %description irb
344     The irb is acronym for Interactive Ruby. It evaluates ruby expression
345     from the terminal.
346    
347     %description bigdecimal
348     Ruby provides built-in support for arbitrary precision integer arithmetic.
349     For example:
350    
351     42**13 -> 1265437718438866624512
352    
353     BigDecimal provides similar support for very large or very accurate floating
354     point numbers. Decimal arithmetic is also useful for general calculation,
355     because it provides the correct answers people expect–whereas normal binary
356     floating point arithmetic often introduces subtle errors because of the
357     conversion between base 10 and base 2.
358    
359     %description io-console
360     IO/Console provides very simple and portable access to console. It doesn't
361     provide higher layer features, such like curses and readline.
362    
363 pterjan 435211 %description psych
364     Psych is a YAML parser and emitter. Psych leverages
365     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
366     capabilities. In addition to wrapping libyaml, Psych also knows how to
367     serialize and de-serialize most Ruby objects to and from the YAML format.
368    
369     %description test-unit
370     This library implements test/unit compatible API on minitest.
371     The test/unit means that test/unit which was bundled with Ruby 1.8.
372    
373 blino 1152 %prep
374 shlomif 893775 %setup -q -n ruby-%{rubyver}
375 pterjan 391153 # When patching mkmf.rb the mkmf.rb.0010 gets installed
376 shlomif 893775 %patch0 -p1
377     %patch1 -p1
378     %patch2 -p1
379     %patch4 -p1
380     %patch5 -p1
381     %patch6 -p1
382     %patch9
383     %patch10
384     %patch11
385     %patch20 -p1
386     # #patch22 -p1
387 blino 1152
388     %build
389 fwang 290038 autoconf
390 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
391 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
392 shlomif 893775 --enable-multiarch \
393     --with-rubylibprefix='%{ruby_libdir}' \
394     --with-archlibdir='%{_libdir}' \
395 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
396 shlomif 893775 --with-sitedir='%{ruby_sitelibdir}' \
397     --with-sitearchdir='%{ruby_sitearchdir}' \
398     --with-vendordir='%{ruby_vendorlibdir}' \
399     --with-vendorarchdir='%{ruby_vendorarchdir}' \
400     --with-rubyhdrdir='%{_includedir}' \
401     --with-rubyarchhdrdir='%{_includedir}' \
402 pterjan 435211 --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
403     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
404     --with-rubygemsdir='%{rubygems_dir}' \
405     --with-ruby-pc='%{name}.pc' \
406     --enable-multiarch \
407     --with-ruby-version=''
408 blino 1152 %make
409    
410     %install
411     %makeinstall_std install-doc
412    
413     install -d %buildroot%{_datadir}/emacs/site-lisp
414     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
415    
416     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
417     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
418     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
419     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
420     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
421     EOF
422    
423 shlomif 893775 # Install the rpm macros
424 blino 1152 mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
425     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
426 fwang 289961
427 tv 673709 # Install dependency generators.
428     mkdir -p %{buildroot}%{_rpmconfigdir}/fileattrs
429     install -m 644 %{SOURCE8} %{buildroot}%{_rpmconfigdir}/fileattrs
430     install -m 755 %{SOURCE9} %{buildroot}%{_rpmconfigdir}
431     install -m 755 %{SOURCE10} %{buildroot}%{_rpmconfigdir}
432    
433 pterjan 435211 # Install custom operating_system.rb
434     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
435     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
436    
437 pterjan 617250 # Version is empty if --with-ruby-version is specified.
438     # http://bugs.ruby-lang.org/issues/7807
439     sed -i 's/Version: .*/Version: %{rubyver}/' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
440    
441 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
442     %if !%build_gems
443 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
444 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
445 pterjan 435566 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal,io,test}
446     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so,io/console.so}
447 pterjan 560987 rm -fr %{buildroot}%{gems_dir}/{gems,specifications}
448 shlomif 893775 rm -fr %{buildroot}"$HOME/.gem"
449 fwang 311915 %if !%bootstrap
450 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
451 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
452     rm -fr %{buildroot}%{rubygems_dir}/rubygems
453 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
454     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
455 fwang 293412 %endif
456 fwang 311914 %endif
457 fwang 293412
458 blino 1152 %check
459     make test
460    
461 fwang 289961 %files
462 fwang 291551 %{_bindir}/erb
463     %{_bindir}/ruby
464 fwang 291560 %dir %{ruby_libdir}
465     %{ruby_libdir}/*.rb
466 fwang 291590 %exclude %{ruby_libdir}/irb.rb
467 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
468     %exclude %{ruby_libdir}/remote-tk.rb
469     %exclude %{ruby_libdir}/tcltk.rb
470     %exclude %{ruby_libdir}/tk.rb
471     %exclude %{ruby_libdir}/tkafter.rb
472     %exclude %{ruby_libdir}/tkbgerror.rb
473     %exclude %{ruby_libdir}/tkcanvas.rb
474     %exclude %{ruby_libdir}/tkclass.rb
475     %exclude %{ruby_libdir}/tkconsole.rb
476     %exclude %{ruby_libdir}/tkdialog.rb
477     %exclude %{ruby_libdir}/tkentry.rb
478     %exclude %{ruby_libdir}/tkfont.rb
479     %exclude %{ruby_libdir}/tkmacpkg.rb
480     %exclude %{ruby_libdir}/tkmenubar.rb
481     %exclude %{ruby_libdir}/tkmngfocus.rb
482     %exclude %{ruby_libdir}/tkpalette.rb
483     %exclude %{ruby_libdir}/tkscrollbox.rb
484     %exclude %{ruby_libdir}/tktext.rb
485     %exclude %{ruby_libdir}/tkvirtevent.rb
486     %exclude %{ruby_libdir}/tkwinpkg.rb
487     %{ruby_libdir}/cgi
488     %{ruby_libdir}/digest
489     %{ruby_libdir}/drb
490     %{ruby_libdir}/fiddle
491     %{ruby_libdir}/matrix
492     %{ruby_libdir}/net
493     %{ruby_libdir}/openssl
494     %{ruby_libdir}/optparse
495 pterjan 435566 %{ruby_libdir}/psych
496 fwang 291560 %{ruby_libdir}/racc
497     %{ruby_libdir}/rbconfig
498     %{ruby_libdir}/rexml
499     %{ruby_libdir}/rinda
500     %{ruby_libdir}/ripper
501     %{ruby_libdir}/rss
502     %{ruby_libdir}/shell
503 pterjan 435211 %{ruby_libdir}/syslog
504 shlomif 893775 %{ruby_libdir}/unicode_normalize/normalize.rb
505     %{ruby_libdir}/unicode_normalize/tables.rb
506     %{ruby_libdir}/unicode_normalize.rb
507 fwang 291560 %{ruby_libdir}/uri
508     %{ruby_libdir}/webrick
509     %{ruby_libdir}/xmlrpc
510     %{ruby_libdir}/yaml
511     %dir %{ruby_libarchdir}
512     %{ruby_libarchdir}/continuation.so
513     %{ruby_libarchdir}/coverage.so
514     %{ruby_libarchdir}/date_core.so
515     %{ruby_libarchdir}/dbm.so
516     %dir %{ruby_libarchdir}/digest
517     %{ruby_libarchdir}/digest.so
518     %{ruby_libarchdir}/digest/*.so
519     %dir %{ruby_libarchdir}/enc
520     %{ruby_libarchdir}/enc/*.so
521 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
522     %{ruby_libarchdir}/enc/trans/*.so
523 fwang 291560 %{ruby_libarchdir}/etc.so
524     %{ruby_libarchdir}/fcntl.so
525     %{ruby_libarchdir}/fiber.so
526     %{ruby_libarchdir}/fiddle.so
527     %{ruby_libarchdir}/gdbm.so
528     %dir %{ruby_libarchdir}/io
529     %{ruby_libarchdir}/io/nonblock.so
530     %{ruby_libarchdir}/io/wait.so
531     %dir %{ruby_libarchdir}/mathn
532 fwang 291562 %{ruby_libarchdir}/mathn/*.so
533 fwang 291560 %{ruby_libarchdir}/nkf.so
534     %{ruby_libarchdir}/objspace.so
535     %{ruby_libarchdir}/openssl.so
536 pterjan 435566 %{ruby_libarchdir}/psych.so
537 fwang 291560 %{ruby_libarchdir}/pathname.so
538     %{ruby_libarchdir}/pty.so
539     %dir %{ruby_libarchdir}/racc
540     %{ruby_libarchdir}/racc/*.so
541     %{ruby_libarchdir}/rbconfig.rb
542 shlomif 893775 %{ruby_libarchdir}/rbconfig/sizeof.so
543 fwang 291560 %{ruby_libarchdir}/readline.so
544     %{ruby_libarchdir}/ripper.so
545     %{ruby_libarchdir}/sdbm.so
546     %{ruby_libarchdir}/socket.so
547     %{ruby_libarchdir}/stringio.so
548     %{ruby_libarchdir}/strscan.so
549     %{ruby_libarchdir}/syslog.so
550 shlomif 893775 %{ruby_libarchdir}/thread.so
551 fwang 291560 %{ruby_libarchdir}/zlib.so
552 fwang 291551 %{_mandir}/man1/erb.1.*
553     %{_mandir}/man1/ruby.1.*
554 blino 1152 %{_datadir}/emacs/site-lisp/*
555     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
556     %{_sysconfdir}/rpm/macros.d/%{name}.macros
557 fwang 291560 %{_datadir}/ruby/site_ruby
558     %{_libdir}/ruby/site_ruby
559     %{_datadir}/ruby/vendor_ruby
560     %{_libdir}/ruby/vendor_ruby
561 fwang 311914 %if %bootstrap
562     %{_bindir}/gem
563 fwang 448831 %dir %{rubygems_dir}
564     %{rubygems_dir}/rbconfig
565     %{rubygems_dir}/rubygems
566     %{rubygems_dir}/rubygems.rb
567     %{rubygems_dir}/ubygems.rb
568 fwang 311914 %endif
569 tv 674762 %{_rpmconfigdir}/fileattrs/rubygems.attr
570     %{_rpmconfigdir}/rubygems.req
571     %{_rpmconfigdir}/rubygems.prov
572 blino 1152
573     %files doc
574     %{_datadir}/ri
575 pterjan 435211 %{_datadir}/doc/ruby
576 blino 1152
577 fwang 291590 %files -n %{libname}
578     %{_libdir}/libruby.so.%{subver}
579     %{_libdir}/libruby.so.%{rubyapi}
580    
581 blino 1152 %files devel
582 fwang 290003 %{_includedir}/*
583 blino 1152 %{_libdir}/libruby-static.a
584     %{_libdir}/libruby.so
585 fwang 290003 %{_libdir}/pkgconfig/*.pc
586 blino 1152
587     %files tk
588 fwang 291560 %{ruby_libarchdir}/tcltklib.so
589     %{ruby_libarchdir}/tkutil.so
590     %{ruby_libdir}/multi-tk.rb
591     %{ruby_libdir}/remote-tk.rb
592     %{ruby_libdir}/tcltk.rb
593     %{ruby_libdir}/tk.rb
594     %{ruby_libdir}/tkafter.rb
595     %{ruby_libdir}/tkbgerror.rb
596     %{ruby_libdir}/tkcanvas.rb
597     %{ruby_libdir}/tkclass.rb
598     %{ruby_libdir}/tkconsole.rb
599     %{ruby_libdir}/tkdialog.rb
600     %{ruby_libdir}/tkentry.rb
601     %{ruby_libdir}/tkfont.rb
602     %{ruby_libdir}/tkmacpkg.rb
603     %{ruby_libdir}/tkmenubar.rb
604     %{ruby_libdir}/tkmngfocus.rb
605     %{ruby_libdir}/tkpalette.rb
606     %{ruby_libdir}/tkscrollbox.rb
607     %{ruby_libdir}/tktext.rb
608     %{ruby_libdir}/tkvirtevent.rb
609     %{ruby_libdir}/tkwinpkg.rb
610     %{ruby_libdir}/tk
611     %{ruby_libdir}/tkextlib
612 fwang 291551
613 fwang 293412 %files irb
614     %{_bindir}/irb
615     %{ruby_libdir}/irb.rb
616     %{ruby_libdir}/irb
617     %{_mandir}/man1/irb.1*
618    
619     %if %build_gems
620 fwang 291551 %files RubyGems
621     %{_bindir}/gem
622     %dir %{rubygems_dir}
623     %{rubygems_dir}/rbconfig
624     %{rubygems_dir}/rubygems
625     %{rubygems_dir}/rubygems.rb
626     %{rubygems_dir}/ubygems.rb
627    
628 fwang 291562 %files minitest
629     %{ruby_libdir}/minitest
630 pterjan 435211 %{rubygems_dir}/specifications/default/minitest-*.gemspec
631 fwang 291562
632 fwang 291551 %files rake
633     %{_bindir}/rake
634     %{_mandir}/man1/rake.1.*
635 fwang 291562 %{ruby_libdir}/rake
636 pterjan 560987 %{gems_dir}/gems/rake-*
637     %{gems_dir}/specifications/default/rake-*.gemspec
638 fwang 291562
639     %files rdoc
640     %{_bindir}/rdoc
641     %{_bindir}/ri
642     %{ruby_libdir}/rdoc
643 pterjan 560987 %{gems_dir}/gems/rdoc-*
644     %{gems_dir}/specifications/default/rdoc-*.gemspec
645 fwang 291562 %{_mandir}/man1/ri.1.*
646    
647     %files json
648     %dir %{ruby_libarchdir}/json
649     %dir %{ruby_libarchdir}/json/ext
650     %{ruby_libarchdir}/json/ext/*.so
651     %{ruby_libdir}/json
652 pterjan 560987 %{gems_dir}/specifications/default/json-*.gemspec
653 fwang 291590
654     %files bigdecimal
655     %{ruby_libdir}/bigdecimal
656     %{ruby_libarchdir}/bigdecimal.so
657 pterjan 560987 %{gems_dir}/specifications/default/bigdecimal-*.gemspec
658 fwang 291590
659     %files io-console
660     %{ruby_libdir}/io
661     %{ruby_libarchdir}/io/console.so
662 pterjan 560987 %{gems_dir}/specifications/default/io-console-*.gemspec
663 pterjan 435211
664     %files psych
665     %{ruby_libdir}/psych
666     %{ruby_libarchdir}/psych.so
667 pterjan 560987 %{gems_dir}/specifications/default/psych-*.gemspec
668 pterjan 435211
669     %files test-unit
670     %{_bindir}/testrb
671     %{ruby_libdir}/test
672 pterjan 560987 %{gems_dir}/gems/test-unit-*
673 pterjan 435211 %{rubygems_dir}/specifications/default/test-unit-*.gemspec
674 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30