/[packages]/updates/6/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /updates/6/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1323477 - (hide annotations) (download)
Sun Oct 21 21:47:33 2018 UTC (5 years, 5 months ago) by pterjan
File size: 22365 byte(s)
Increase package release, else some subpackages are older
1 shlomif 893775 # Taken from the fedora ruby-2.2.3 .spec. Thanks!
2 blino 1152
3 shlomif 893775 %global major_version 2
4     %global minor_version 2
5 pterjan 1323476 %global teeny_version 10
6 shlomif 893775 %global major_minor_version %{major_version}.%{minor_version}
7    
8     %global ruby_version %{major_minor_version}.%{teeny_version}
9     %global ruby_release %{ruby_version}
10    
11     # Specify the named version. It has precedense to revision.
12     #%%global milestone rc1
13    
14     # Keep the revision enabled for pre-releases from SVN.
15     #%%global revision 48936
16    
17     %global ruby_archive %{name}-%{ruby_version}
18    
19     # If revision and milestone are removed/commented out, the official release build is expected.
20     %if 0%{?milestone:1}%{?revision:1} != 0
21     %global development_release %{?milestone}%{?!milestone:%{?revision:r%{revision}}}
22     %global ruby_archive %{ruby_archive}-%{?milestone}%{?!milestone:%{?revision:r%{revision}}}
23     %endif
24    
25    
26 pterjan 1323477 %define rel 16
27 luigiwalser 1187964 %define subrel 1
28 pterjan 894460 %{!?release_string:%global release_string %mkrel %{?development_release:0.}%{rel}%{?development_release:.%{development_release}}}
29 shlomif 893775
30     %global rubygems_version 2.4.5.1
31    
32     # The RubyGems library has to stay out of Ruby directory three, since the
33     # RubyGems should be share by all Ruby implementations.
34     %global rubygems_dir %{_datadir}/rubygems
35    
36     # TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM.
37     # http://redmine.ruby-lang.org/issues/5313
38     %global irb_version %{ruby_version}
39    
40     %global bigdecimal_version 1.2.6
41     %global io_console_version 0.4.3
42 pterjan 1167917 %global json_version 1.8.1.1
43 shlomif 893775 %global minitest_version 5.4.3
44     %global power_assert_version 0.2.2
45 pterjan 1167917 %global psych_version 2.0.8.1
46 shlomif 893775 %global rake_version 10.4.2
47     %global rdoc_version 4.2.0
48     %global test_unit_version 3.0.8
49    
50     # Might not be needed in the future, if we are lucky enough.
51     # https://bugzilla.redhat.com/show_bug.cgi?id=888262
52     %global tapset_root %{_datadir}/systemtap
53     %global tapset_dir %{tapset_root}/tapset
54     %global tapset_libdir %(echo %{_libdir} | sed 's/64//')*
55    
56     %global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/;s/sparcv./sparc/')
57    
58     %global with_rubypick 1
59    
60     # Additional defines by Mageia.
61    
62     %define subver %{major_minor_version}
63     %define rubyapi %{subver}.0
64     %define rubyver %{ruby_version}
65    
66 fwang 291590 %define libname %mklibname ruby %{subver}
67    
68 fwang 291557 %define ruby_libdir %{_datadir}/%{name}
69     %define ruby_libarchdir %{_libdir}/%{name}
70    
71 fwang 290007 # This is the local lib/arch and should not be used for packaging.
72 fwang 291557 %define ruby_sitelibdir %{_datadir}/ruby/site_ruby
73     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby
74 fwang 290007
75     # This is the general location for libs/archs compatible with all
76     # or most of the Ruby versions available in the Fedora repositories.
77 fwang 291551 %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby
78 fwang 291557 %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby
79 fwang 290007
80 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
81     # RubyGems should be shared by all Ruby implementations.
82 pterjan 894459 %define gems_dir %{_datadir}/gems
83 fwang 290007
84 pterjan 894524 %define bootstrap 0
85 pterjan 895045 %define build_gems 0
86 fwang 292558
87 blino 1152 Summary: Object Oriented Script Language
88     Name: ruby
89 shlomif 893775 Version: %{rubyver}
90 pterjan 894460 Release: %release_string
91 kamil 397518 License: Ruby or BSD
92 blino 1152 Group: Development/Ruby
93     BuildRequires: autoconf
94     BuildRequires: byacc
95 shlomif 291698 BuildRequires: doxygen
96 blino 1152 BuildRequires: ncurses-devel
97     BuildRequires: readline-devel
98 shlomif 893775 BuildRequires: tcl-devel
99 ovitters 648773 BuildRequires: tk-devel
100 fwang 276350 BuildRequires: db-devel
101 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
102 blino 1152 BuildRequires: openssl-devel
103     BuildRequires: zlib-devel
104 fwang 289987 BuildRequires: libffi-devel
105     BuildRequires: yaml-devel
106 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
107 tv 674762 Conflicts: ruby-devel < 2.0.0.p451-4.mga5
108 blino 1152 Obsoletes: ruby-rexml
109     Provides: ruby-rexml
110 pterjan 435566 # Couldn't get the standalone gem to work
111     Provides: rubygem(psych)
112 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
113     Provides: /usr/bin/ruby
114 pterjan 894480 Provides: ruby(abi) = %subver
115 shlomif 893775 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}.tar.xz
116 pterjan 435211 Source1: operating_system.rb
117 blino 1152 Source3: ruby.macros
118 tv 673709 # From FC:
119     # RPM dependency generators.
120     Source8: rubygems.attr
121     Source9: rubygems.req
122     Source10: rubygems.prov
123 shlomif 893775 URL: http://ruby-lang.org/
124 fwang 292558 %if !%bootstrap
125 fwang 293395 BuildRequires: ruby
126 fwang 292558 %endif
127 pterjan 895045 %if !%bootstrap || %build_gems
128 pterjan 894524 Requires: rubygems >= %{rubygems_version}
129     %endif
130 blino 1152
131 fwang 290007 # == FEDORA PATCHES BEGINS ==
132 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
133 shlomif 893775 Patch0: ruby-2.1.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
134     # Allows to override libruby.so placement. Hopefully we will be able to return
135     # to plain --with-rubyarchprefix.
136     # http://bugs.ruby-lang.org/issues/8973
137     Patch1: ruby-2.1.0-Enable-configuration-of-archlibdir.patch
138     # Force multiarch directories for i.86 to be always named i386. This solves
139     # some differencies in build between Fedora and RHEL.
140     Patch2: ruby-2.1.0-always-use-i386.patch
141 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
142 shlomif 893775 # http://bugs.ruby-lang.org/issues/5617
143     Patch4: ruby-2.1.0-custom-rubygems-location.patch
144 pterjan 435211 # Make mkmf verbose by default
145 shlomif 893775 Patch5: ruby-1.9.3-mkmf-verbose.patch
146     # Adds support for '--with-prelude' configuration option. This allows to built
147     # in support for ABRT.
148     # http://bugs.ruby-lang.org/issues/8566
149     Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
150 luigiwalser 1050409 # Use miniruby to regenerate prelude.c.
151     # https://bugs.ruby-lang.org/issues/10554
152     Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
153 fwang 290007 # == FEDORA PATCHES ENDS ==
154 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
155     # to install gems into user dir
156 blino 894359 Patch20: ruby-2.3.0-Do-not-install-to-user-dir.patch
157 pterjan 1059716 Patch21: ruby-2.2.5-CVE-2016-7798.patch
158 shlomif 893775 # Patch22: ruby-2.0.0-tk2.6.patch
159 pterjan 1141715 Patch23: ruby-2.2.5-npn_protocols.patch
160     Patch24: ruby-2.2.7-CVE-2016-2339.patch
161     Patch25: ruby-2.0.0-CVE-2015-9096.patch
162     Patch26: ruby-2.0.0-CVE-2016-2337.patch
163 luigiwalser 1187964 Patch28: ruby-2.0.0-CVE-2017-17790.patch
164 pterjan 1323474 Patch29: ruby-2.2.8-CVE-2018-16395.patch
165     Patch30: ruby-2.2.8-CVE-2018-16396.patch
166 luigiwalser 795834
167 fwang 291591 %package -n %{libname}
168 fwang 291590 Summary: Libraries necessary to run Ruby
169     Group: Development/Ruby
170    
171 blino 1152 %package doc
172     Summary: Documentation for the powerful language Ruby
173     Group: Development/Ruby
174 fwang 202696 BuildArch: noarch
175 blino 1152
176     %package devel
177     Summary: Development file for the powerful language Ruby
178     Group: Development/Ruby
179 fwang 311925 Requires: %{name} = %{version}
180     Requires: %{libname} = %{version}
181 blino 1152
182     %package tk
183     Summary: Tk extension for the powerful language Ruby
184     Group: Development/Ruby
185 fwang 311925 Requires: %{name} = %{version}
186 blino 1152
187 fwang 291551 %package RubyGems
188     Summary: The Ruby standard for packaging ruby libraries
189     Group: Development/Ruby
190 fwang 291590 Version: %{rubygems_version}
191 fwang 291551 Requires: ruby(abi) = %{subver}
192 fwang 291590 Provides: gem = %{rubygems_version}
193     Provides: rubygems = %{rubygems_version}
194     Provides: ruby(rubygems) = %{rubygems_version}
195 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
196 fwang 291561 BuildArch: noarch
197 fwang 291551
198 shlomif 893775 %define rake_ver %{rake_version}
199 fwang 291551 %package rake
200     Summary: Simple ruby build program with capabilities similar to make
201     Group: Development/Ruby
202 shlomif 291767 Version: %{rake_ver}
203 pterjan 894484 Provides: rubygem(rake) = %{rake_ver}
204 fwang 291551 Requires: ruby(abi) = %{subver}
205 fwang 291561 BuildArch: noarch
206 fwang 291551
207 shlomif 893775 %define minitest_ver %{minitest_version}
208 fwang 291562 %package minitest
209 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
210 fwang 291562 Group: Development/Ruby
211 shlomif 291767 Version: %{minitest_ver}
212 fwang 291562 License: MIT
213 pterjan 894484 Provides: rubygem(minitest) = %{minitest_ver}
214 fwang 291590 Requires: ruby(abi) = %{subver}
215     Requires: ruby(rubygems) >= %{rubygems_version}
216 fwang 291562 BuildArch: noarch
217    
218 pterjan 894459 %define power_assert_ver %{power_assert_version}
219     %package power_assert
220     Summary: Power Assert for Ruby
221     Group: Development/Ruby
222     Version: %{power_assert_ver}
223     License: BSD
224 pterjan 894484 Provides: rubygem(power_assert) = %{power_assert_ver}
225 pterjan 894459 Requires: ruby(abi) = %{subver}
226     Requires: ruby(rubygems) >= %{rubygems_version}
227     BuildArch: noarch
228    
229 shlomif 893775 %define json_ver %{json_version}
230 fwang 291562 %package json
231     Summary: This is a JSON implementation as a Ruby extension in C
232     Group: Development/Ruby
233 shlomif 291767 Version: %{json_ver}
234 fwang 291562 License: Ruby or GPLv2
235 pterjan 894484 Provides: rubygem(json) = %{json_ver}
236 fwang 291590 Requires: ruby(abi) = %{subver}
237     Requires: ruby(rubygems) >= %{rubygems_version}
238 fwang 291562
239 shlomif 893775 %define rdoc_ver %{rdoc_version}
240 fwang 291562 %package rdoc
241     Summary: A tool to generate HTML and command-line documentation for Ruby projects
242     Group: Development/Ruby
243 shlomif 291767 Version: %{rdoc_ver}
244 fwang 291562 License: GPLv2 and Ruby and MIT
245 pterjan 894484 Provides: rubygem(rdoc) = %{rdoc_ver}
246 fwang 291590 Requires: ruby(abi) = %{subver}
247     Requires: ruby(rubygems) >= %{rubygems_version}
248     Requires: ruby(irb) = %{version}
249 shlomif 291767 Provides: rdoc = %{rdoc_ver}
250     Provides: ri = %{rdoc_ver}
251 fwang 291562 BuildArch: noarch
252    
253 fwang 291590 %package irb
254     Summary: The Interactive Ruby
255     Group: Development/Ruby
256     Provides: irb = %{version}-%{release}
257     Provides: ruby(irb) = %{version}-%{release}
258 fwang 313459 Conflicts: ruby < 1.9
259 fwang 313460 BuildArch: noarch
260 fwang 291590
261 shlomif 893775 %define bigdecimal_ver %{bigdecimal_version}
262 fwang 291590 %package bigdecimal
263     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
264     Group: Development/Ruby
265 pterjan 435211 Version: %{bigdecimal_ver}
266 fwang 291590 License: GPL+ or Artistic
267 pterjan 894484 Provides: rubygem(bigdecimal) = %{bigdecimal_ver}
268 fwang 291590 Requires: ruby(abi) = %{subver}
269     Requires: ruby(rubygems) >= %{rubygems_version}
270    
271 shlomif 893775 %define io_console_ver %{io_console_version}
272 fwang 291590 %package io-console
273     Summary: IO/Console is a simple console utilizing library
274     Group: Development/Ruby
275 pterjan 435211 Version: %{io_console_ver}
276 pterjan 894484 Provides: rubygem(io-console) = %{io_console_ver}
277 fwang 291590 Requires: ruby(abi) = %{subver}
278     Requires: ruby(rubygems) >= %{rubygems_version}
279    
280 shlomif 893775 %define psych_ver %{psych_version}
281 pterjan 435211 %package psych
282     Summary: A libyaml wrapper for Ruby
283     Version: %{psych_ver}
284     Group: Development/Ruby
285     License: MIT
286 pterjan 894484 Provides: rubygem(psych) = %{psych_ver}
287 pterjan 435211 Requires: ruby(abi) = %{subver}
288     Requires: ruby(rubygems) >= %{rubygems_version}
289     Conflicts: ruby < 2.0.0
290    
291 shlomif 893775 %define test_unit_ver %{test_unit_version}
292 pterjan 435211 %package test-unit
293     Summary: test/unit compatible API testing framework
294 pterjan 897269 Version: %{test_unit_ver}
295 pterjan 435211 Group: Development/Ruby
296     License: MIT
297 pterjan 894484 Provides: rubygem(test-unit) = %{test_unit_ver}
298 pterjan 435211 Requires: ruby(abi) = %{subver}
299     Requires: ruby(rubygems) >= %{rubygems_version}
300     Conflicts: ruby < 2.0.0
301     BuildArch: noarch
302    
303 blino 1152 %description
304     Ruby is the interpreted scripting language for quick and
305     easy object-oriented programming. It has many features to
306     process text files and to do system management tasks (as in
307     Perl). It is simple, straight-forward, and extensible.
308    
309     %description doc
310     Ruby is the interpreted scripting language for quick and
311     easy object-oriented programming. It has many features to
312     process text files and to do system management tasks (as in
313     Perl). It is simple, straight-forward, and extensible.
314    
315     This package contains the Ruby's documentation
316    
317 fwang 291590 %description -n %{libname}
318     This package includes the libruby, necessary to run Ruby.
319    
320 blino 1152 %description devel
321     Ruby is the interpreted scripting language for quick and
322     easy object-oriented programming. It has many features to
323     process text files and to do system management tasks (as in
324     Perl). It is simple, straight-forward, and extensible.
325    
326     This package contains the Ruby's devel files.
327    
328     %description tk
329     Ruby is the interpreted scripting language for quick and
330     easy object-oriented programming. It has many features to
331     process text files and to do system management tasks (as in
332     Perl). It is simple, straight-forward, and extensible.
333    
334     This package contains the Tk extension for Ruby.
335    
336 fwang 291551 %description RubyGems
337     RubyGems is the Ruby standard for publishing and managing third party
338     libraries.
339    
340 fwang 291552 %description rake
341     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
342     specified in standard Ruby syntax.
343    
344 fwang 291562 %description rdoc
345     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
346     includes the 'rdoc' and 'ri' tools for generating and displaying online
347     documentation.
348    
349     %description json
350     This is a implementation of the JSON specification according to RFC 4627.
351     You can think of it as a low fat alternative to XML, if you want to store
352     data to disk or transmit it over a network rather than use a verbose
353     markup language.
354    
355     %description minitest
356     minitest/unit is a small and incredibly fast unit testing framework.
357    
358     minitest/spec is a functionally complete spec engine.
359    
360     minitest/benchmark is an awesome way to assert the performance of your
361     algorithms in a repeatable manner.
362    
363     minitest/mock by Steven Baker, is a beautifully tiny mock object
364     framework.
365    
366     minitest/pride shows pride in testing and adds coloring to your test
367     output.
368    
369 pterjan 894459 %description power_assert
370     Power Assert shows each value of variables and method calls in the expression.
371     It is useful for testing, providing which value wasn't correct when the
372     condition is not satisfied.
373    
374 fwang 291590 %description irb
375     The irb is acronym for Interactive Ruby. It evaluates ruby expression
376     from the terminal.
377    
378     %description bigdecimal
379     Ruby provides built-in support for arbitrary precision integer arithmetic.
380     For example:
381    
382     42**13 -> 1265437718438866624512
383    
384     BigDecimal provides similar support for very large or very accurate floating
385     point numbers. Decimal arithmetic is also useful for general calculation,
386     because it provides the correct answers people expect–whereas normal binary
387     floating point arithmetic often introduces subtle errors because of the
388     conversion between base 10 and base 2.
389    
390     %description io-console
391     IO/Console provides very simple and portable access to console. It doesn't
392     provide higher layer features, such like curses and readline.
393    
394 pterjan 435211 %description psych
395     Psych is a YAML parser and emitter. Psych leverages
396     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
397     capabilities. In addition to wrapping libyaml, Psych also knows how to
398     serialize and de-serialize most Ruby objects to and from the YAML format.
399    
400     %description test-unit
401     This library implements test/unit compatible API on minitest.
402     The test/unit means that test/unit which was bundled with Ruby 1.8.
403    
404 blino 1152 %prep
405 shlomif 893775 %setup -q -n ruby-%{rubyver}
406 pterjan 916671 %autopatch -p1
407 blino 1152
408     %build
409 fwang 290038 autoconf
410 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
411 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
412 shlomif 893775 --enable-multiarch \
413     --with-rubylibprefix='%{ruby_libdir}' \
414     --with-archlibdir='%{_libdir}' \
415 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
416 shlomif 893775 --with-sitedir='%{ruby_sitelibdir}' \
417     --with-sitearchdir='%{ruby_sitearchdir}' \
418     --with-vendordir='%{ruby_vendorlibdir}' \
419     --with-vendorarchdir='%{ruby_vendorarchdir}' \
420     --with-rubyhdrdir='%{_includedir}' \
421     --with-rubyarchhdrdir='%{_includedir}' \
422 pterjan 435211 --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
423     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
424     --with-rubygemsdir='%{rubygems_dir}' \
425     --with-ruby-pc='%{name}.pc' \
426     --enable-multiarch \
427     --with-ruby-version=''
428 blino 1152 %make
429    
430     %install
431     %makeinstall_std install-doc
432    
433     install -d %buildroot%{_datadir}/emacs/site-lisp
434     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
435    
436     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
437     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
438     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
439     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
440     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
441     EOF
442    
443 shlomif 893775 # Install the rpm macros
444 blino 1152 mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
445     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
446 fwang 289961
447 tv 673709 # Install dependency generators.
448     mkdir -p %{buildroot}%{_rpmconfigdir}/fileattrs
449     install -m 644 %{SOURCE8} %{buildroot}%{_rpmconfigdir}/fileattrs
450     install -m 755 %{SOURCE9} %{buildroot}%{_rpmconfigdir}
451     install -m 755 %{SOURCE10} %{buildroot}%{_rpmconfigdir}
452    
453 pterjan 435211 # Install custom operating_system.rb
454     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
455     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
456    
457 pterjan 617250 # Version is empty if --with-ruby-version is specified.
458     # http://bugs.ruby-lang.org/issues/7807
459     sed -i 's/Version: .*/Version: %{rubyver}/' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
460    
461 pterjan 894459 rm -f %{buildroot}%{gems_dir}/cache/{minitest,power_assert,test-unit}-*.gem
462    
463 fwang 293412 # drop gems if not wanted, so that we could split them out as seperated source rpm
464     %if !%build_gems
465 pterjan 435211 rm -f %{buildroot}%{_bindir}/{rake,rdoc,ri,testrb}
466 fwang 293421 rm -f %{buildroot}%{_mandir}/man1/{rake,ri}.*
467 pterjan 912571 rm -fr %{buildroot}%{ruby_libdir}/{minitest,rake,rdoc,json,bigdecimal}{,.rb}
468     rm -fr %{buildroot}%{ruby_libarchdir}/{json,bigdecimal.so}
469     rm -fr %{buildroot}%{gems_dir}/specifications/{minitest-%{minitest_version},default/rake-%{rake_version},default/rdoc-%{rdoc_version},default/json-%{json_version},default/bigdecimal-%{bigdecimal_version},default/psych-%{psych_version}}.gemspec
470 pterjan 897269 rm -fr %{buildroot}%{gems_dir}/gems/{minitest-%{minitest_version},rake-%{rake_version},rdoc-%{rdoc_version}}
471 fwang 311915 %if !%bootstrap
472 fwang 311914 rm -f %{buildroot}%{_bindir}/gem
473 fwang 311924 rm -fr %{buildroot}%{rubygems_dir}/rbconfig
474     rm -fr %{buildroot}%{rubygems_dir}/rubygems
475 fwang 311914 rm -f %{buildroot}%{rubygems_dir}/rubygems.rb
476     rm -f %{buildroot}%{rubygems_dir}/ubygems.rb
477 fwang 293412 %endif
478 fwang 311914 %endif
479 fwang 293412
480 blino 1152 %check
481     make test
482    
483 fwang 289961 %files
484 fwang 291551 %{_bindir}/erb
485     %{_bindir}/ruby
486 fwang 291560 %dir %{ruby_libdir}
487     %{ruby_libdir}/*.rb
488 fwang 291590 %exclude %{ruby_libdir}/irb.rb
489 fwang 291560 %exclude %{ruby_libdir}/multi-tk.rb
490     %exclude %{ruby_libdir}/remote-tk.rb
491     %exclude %{ruby_libdir}/tcltk.rb
492     %exclude %{ruby_libdir}/tk.rb
493     %exclude %{ruby_libdir}/tkafter.rb
494     %exclude %{ruby_libdir}/tkbgerror.rb
495     %exclude %{ruby_libdir}/tkcanvas.rb
496     %exclude %{ruby_libdir}/tkclass.rb
497     %exclude %{ruby_libdir}/tkconsole.rb
498     %exclude %{ruby_libdir}/tkdialog.rb
499     %exclude %{ruby_libdir}/tkentry.rb
500     %exclude %{ruby_libdir}/tkfont.rb
501     %exclude %{ruby_libdir}/tkmacpkg.rb
502     %exclude %{ruby_libdir}/tkmenubar.rb
503     %exclude %{ruby_libdir}/tkmngfocus.rb
504     %exclude %{ruby_libdir}/tkpalette.rb
505     %exclude %{ruby_libdir}/tkscrollbox.rb
506     %exclude %{ruby_libdir}/tktext.rb
507     %exclude %{ruby_libdir}/tkvirtevent.rb
508     %exclude %{ruby_libdir}/tkwinpkg.rb
509     %{ruby_libdir}/cgi
510     %{ruby_libdir}/digest
511     %{ruby_libdir}/drb
512     %{ruby_libdir}/fiddle
513     %{ruby_libdir}/matrix
514     %{ruby_libdir}/net
515     %{ruby_libdir}/openssl
516     %{ruby_libdir}/optparse
517 pterjan 435566 %{ruby_libdir}/psych
518 fwang 291560 %{ruby_libdir}/racc
519     %{ruby_libdir}/rbconfig
520     %{ruby_libdir}/rexml
521     %{ruby_libdir}/rinda
522     %{ruby_libdir}/ripper
523     %{ruby_libdir}/rss
524     %{ruby_libdir}/shell
525 pterjan 435211 %{ruby_libdir}/syslog
526 shlomif 893775 %{ruby_libdir}/unicode_normalize/normalize.rb
527     %{ruby_libdir}/unicode_normalize/tables.rb
528     %{ruby_libdir}/unicode_normalize.rb
529 fwang 291560 %{ruby_libdir}/uri
530     %{ruby_libdir}/webrick
531     %{ruby_libdir}/xmlrpc
532     %{ruby_libdir}/yaml
533     %dir %{ruby_libarchdir}
534     %{ruby_libarchdir}/continuation.so
535     %{ruby_libarchdir}/coverage.so
536     %{ruby_libarchdir}/date_core.so
537     %{ruby_libarchdir}/dbm.so
538     %dir %{ruby_libarchdir}/digest
539     %{ruby_libarchdir}/digest.so
540     %{ruby_libarchdir}/digest/*.so
541     %dir %{ruby_libarchdir}/enc
542     %{ruby_libarchdir}/enc/*.so
543 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
544     %{ruby_libarchdir}/enc/trans/*.so
545 fwang 291560 %{ruby_libarchdir}/etc.so
546     %{ruby_libarchdir}/fcntl.so
547     %{ruby_libarchdir}/fiber.so
548     %{ruby_libarchdir}/fiddle.so
549     %{ruby_libarchdir}/gdbm.so
550     %dir %{ruby_libarchdir}/io
551     %{ruby_libarchdir}/io/nonblock.so
552     %{ruby_libarchdir}/io/wait.so
553     %dir %{ruby_libarchdir}/mathn
554 fwang 291562 %{ruby_libarchdir}/mathn/*.so
555 fwang 291560 %{ruby_libarchdir}/nkf.so
556     %{ruby_libarchdir}/objspace.so
557     %{ruby_libarchdir}/openssl.so
558 pterjan 435566 %{ruby_libarchdir}/psych.so
559 fwang 291560 %{ruby_libarchdir}/pathname.so
560     %{ruby_libarchdir}/pty.so
561     %dir %{ruby_libarchdir}/racc
562     %{ruby_libarchdir}/racc/*.so
563     %{ruby_libarchdir}/rbconfig.rb
564 shlomif 893775 %{ruby_libarchdir}/rbconfig/sizeof.so
565 fwang 291560 %{ruby_libarchdir}/readline.so
566     %{ruby_libarchdir}/ripper.so
567     %{ruby_libarchdir}/sdbm.so
568     %{ruby_libarchdir}/socket.so
569     %{ruby_libarchdir}/stringio.so
570     %{ruby_libarchdir}/strscan.so
571     %{ruby_libarchdir}/syslog.so
572 shlomif 893775 %{ruby_libarchdir}/thread.so
573 fwang 291560 %{ruby_libarchdir}/zlib.so
574 fwang 291551 %{_mandir}/man1/erb.1.*
575     %{_mandir}/man1/ruby.1.*
576 blino 1152 %{_datadir}/emacs/site-lisp/*
577     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
578     %{_sysconfdir}/rpm/macros.d/%{name}.macros
579 fwang 291560 %{_datadir}/ruby/site_ruby
580     %{_libdir}/ruby/site_ruby
581     %{_datadir}/ruby/vendor_ruby
582     %{_libdir}/ruby/vendor_ruby
583 fwang 311914 %if %bootstrap
584 pterjan 894524 %if !%build_gems
585 fwang 311914 %{_bindir}/gem
586 fwang 448831 %dir %{rubygems_dir}
587     %{rubygems_dir}/rbconfig
588     %{rubygems_dir}/rubygems
589     %{rubygems_dir}/rubygems.rb
590     %{rubygems_dir}/ubygems.rb
591 fwang 311914 %endif
592 pterjan 894524 %endif
593 tv 674762 %{_rpmconfigdir}/fileattrs/rubygems.attr
594     %{_rpmconfigdir}/rubygems.req
595     %{_rpmconfigdir}/rubygems.prov
596 blino 1152
597     %files doc
598     %{_datadir}/ri
599 pterjan 435211 %{_datadir}/doc/ruby
600 blino 1152
601 fwang 291590 %files -n %{libname}
602     %{_libdir}/libruby.so.%{subver}
603     %{_libdir}/libruby.so.%{rubyapi}
604    
605 blino 1152 %files devel
606 fwang 290003 %{_includedir}/*
607 blino 1152 %{_libdir}/libruby-static.a
608     %{_libdir}/libruby.so
609 fwang 290003 %{_libdir}/pkgconfig/*.pc
610 blino 1152
611     %files tk
612 fwang 291560 %{ruby_libarchdir}/tcltklib.so
613     %{ruby_libarchdir}/tkutil.so
614     %{ruby_libdir}/multi-tk.rb
615     %{ruby_libdir}/remote-tk.rb
616     %{ruby_libdir}/tcltk.rb
617     %{ruby_libdir}/tk.rb
618     %{ruby_libdir}/tkafter.rb
619     %{ruby_libdir}/tkbgerror.rb
620     %{ruby_libdir}/tkcanvas.rb
621     %{ruby_libdir}/tkclass.rb
622     %{ruby_libdir}/tkconsole.rb
623     %{ruby_libdir}/tkdialog.rb
624     %{ruby_libdir}/tkentry.rb
625     %{ruby_libdir}/tkfont.rb
626     %{ruby_libdir}/tkmacpkg.rb
627     %{ruby_libdir}/tkmenubar.rb
628     %{ruby_libdir}/tkmngfocus.rb
629     %{ruby_libdir}/tkpalette.rb
630     %{ruby_libdir}/tkscrollbox.rb
631     %{ruby_libdir}/tktext.rb
632     %{ruby_libdir}/tkvirtevent.rb
633     %{ruby_libdir}/tkwinpkg.rb
634     %{ruby_libdir}/tk
635     %{ruby_libdir}/tkextlib
636 fwang 291551
637 fwang 293412 %files irb
638     %{_bindir}/irb
639     %{ruby_libdir}/irb.rb
640     %{ruby_libdir}/irb
641     %{_mandir}/man1/irb.1*
642    
643 pterjan 897269 %files power_assert
644     %{gems_dir}/gems/power_assert-%{power_assert_version}
645     %{gems_dir}/specifications/power_assert-%{power_assert_version}.gemspec
646    
647 pterjan 912571 %files io-console
648     %{ruby_libdir}/io
649     %{ruby_libarchdir}/io/console.so
650     %{gems_dir}/specifications/default/io-console-%{io_console_version}.gemspec
651    
652 pterjan 897269 %files test-unit
653     %{gems_dir}/gems/test-unit-*
654     %{gems_dir}/specifications/test-unit-%{test_unit_version}.gemspec
655    
656 fwang 293412 %if %build_gems
657 fwang 291551 %files RubyGems
658     %{_bindir}/gem
659     %dir %{rubygems_dir}
660     %{rubygems_dir}/rbconfig
661     %{rubygems_dir}/rubygems
662     %{rubygems_dir}/rubygems.rb
663     %{rubygems_dir}/ubygems.rb
664    
665 fwang 291562 %files minitest
666 pterjan 894459 %{gems_dir}/gems/minitest-%{minitest_version}
667     %{gems_dir}/specifications/minitest-%{minitest_version}.gemspec
668 fwang 291562
669 fwang 291551 %files rake
670     %{_bindir}/rake
671     %{_mandir}/man1/rake.1.*
672 fwang 291562 %{ruby_libdir}/rake
673 pterjan 912333 %{ruby_libdir}/rake.rb
674 pterjan 894459 %{gems_dir}/gems/rake-%{rake_version}
675     %{gems_dir}/specifications/default/rake-%{rake_version}.gemspec
676 fwang 291562
677     %files rdoc
678     %{_bindir}/rdoc
679     %{_bindir}/ri
680     %{ruby_libdir}/rdoc
681 pterjan 912333 %{ruby_libdir}/rdoc.rb
682 pterjan 894459 %{gems_dir}/gems/rdoc-%{rdoc_version}
683     %{gems_dir}/specifications/default/rdoc-%{rdoc_version}.gemspec
684 fwang 291562 %{_mandir}/man1/ri.1.*
685    
686     %files json
687     %dir %{ruby_libarchdir}/json
688     %dir %{ruby_libarchdir}/json/ext
689     %{ruby_libarchdir}/json/ext/*.so
690     %{ruby_libdir}/json
691 pterjan 894459 %{gems_dir}/specifications/default/json-%{json_version}.gemspec
692 fwang 291590
693     %files bigdecimal
694     %{ruby_libdir}/bigdecimal
695     %{ruby_libarchdir}/bigdecimal.so
696 pterjan 894459 %{gems_dir}/specifications/default/bigdecimal-%{bigdecimal_version}.gemspec
697 fwang 291590
698 pterjan 435211 %files psych
699     %{ruby_libdir}/psych
700 pterjan 912333 %{ruby_libdir}/psych.rb
701 pterjan 435211 %{ruby_libarchdir}/psych.so
702 pterjan 894459 %{gems_dir}/specifications/default/psych-%{psych_version}.gemspec
703 fwang 293378 %endif

  ViewVC Help
Powered by ViewVC 1.1.30