/[packages]/updates/8/java-1.8.0-openjdk/current/SPECS/java-1.8.0-openjdk.spec
ViewVC logotype

Diff of /updates/8/java-1.8.0-openjdk/current/SPECS/java-1.8.0-openjdk.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

revision 1936261 by ns80, Fri Nov 4 09:10:46 2022 UTC revision 1936262 by ns80, Thu Jan 26 15:13:21 2023 UTC
# Line 304  Line 304 
304  # note, following three variables are sedded from update_sources if used correctly. Hardcode them rather there.  # note, following three variables are sedded from update_sources if used correctly. Hardcode them rather there.
305  %global shenandoah_project      openjdk  %global shenandoah_project      openjdk
306  %global shenandoah_repo         shenandoah-jdk8u  %global shenandoah_repo         shenandoah-jdk8u
307  %global shenandoah_revision     shenandoah-jdk8u352-b08  %global shenandoah_revision     shenandoah-jdk8u362-b09
308  # Define old aarch64/jdk8u tree variables for compatibility  # Define old aarch64/jdk8u tree variables for compatibility
309  %global project         %{shenandoah_project}  %global project         %{shenandoah_project}
310  %global repo            %{shenandoah_repo}  %global repo            %{shenandoah_repo}
# Line 1199  Requires: ca-certificates Line 1199  Requires: ca-certificates
1199  # Require javapackages-filesystem for ownership of /usr/lib/jvm/ and macros  # Require javapackages-filesystem for ownership of /usr/lib/jvm/ and macros
1200  Requires: javapackages-filesystem  Requires: javapackages-filesystem
1201  # Require zoneinfo data provided by tzdata-java subpackage.  # Require zoneinfo data provided by tzdata-java subpackage.
1202  # 2022d required as of JDK-8294357  # 2022g required as of JDK-8297804
1203  # Should be bumped to 2022e once available (JDK-8295173)  Requires: tzdata-java >= 2022g
 Requires: tzdata-java >= 2022d  
1204  # for support of kernel stream control  # for support of kernel stream control
1205  # libsctp.so.1 is being `dlopen`ed on demand  # libsctp.so.1 is being `dlopen`ed on demand
1206  Requires: lksctp-tools%{?_isa}  Requires: lksctp-tools%{?_isa}
# Line 1295  Provides: java-%{origin}-src%{?1} = %{ep Line 1294  Provides: java-%{origin}-src%{?1} = %{ep
1294    
1295  Name:    java-%{javaver}-%{origin}  Name:    java-%{javaver}-%{origin}
1296  Version: %{javaver}.%{updatever}.%{buildver}  Version: %{javaver}.%{updatever}.%{buildver}
1297  Release: %mkrel %{?eaprefix}%{rpmrelease}%{?extraver}.1  Release: %mkrel %{?eaprefix}%{rpmrelease}%{?extraver}
1298  Group:   Development/Java  Group:   Development/Java
1299  # java-1.5.0-ibm from jpackage.org set Epoch to 1 for unknown reasons  # java-1.5.0-ibm from jpackage.org set Epoch to 1 for unknown reasons
1300  # and this change was brought into RHEL-4. java-1.5.0-ibm packages  # and this change was brought into RHEL-4. java-1.5.0-ibm packages
# Line 1403  Patch1003: rh1582504-rsa_default_for_key Line 1402  Patch1003: rh1582504-rsa_default_for_key
1402  #############################################  #############################################
1403  # PR2737: Allow multiple initialization of PKCS11 libraries  # PR2737: Allow multiple initialization of PKCS11 libraries
1404  Patch5: pr2737-allow_multiple_pkcs11_library_initialisation_to_be_a_non_critical_error.patch  Patch5: pr2737-allow_multiple_pkcs11_library_initialisation_to_be_a_non_critical_error.patch
 # PR2095, RH1163501: 2048-bit DH upper bound too small for Fedora infrastructure (sync with IcedTea 2.x)  
 Patch504: rh1163501-increase_2048_bit_dh_upper_bound_fedora_infrastructure_in_dhparametergenerator.patch  
1405  # Turn off strict overflow on IndicRearrangementProcessor{,2}.cpp following 8140543: Arrange font actions  # Turn off strict overflow on IndicRearrangementProcessor{,2}.cpp following 8140543: Arrange font actions
1406  Patch512: rh1649664-awt2dlibraries_compiled_with_no_strict_overflow.patch  Patch512: rh1649664-awt2dlibraries_compiled_with_no_strict_overflow.patch
1407  # RH1337583, PR2974: PKCS#10 certificate requests now use CRLF line endings rather than system line endings  # RH1337583, PR2974: PKCS#10 certificate requests now use CRLF line endings rather than system line endings
# Line 1467  Patch202: jdk8035341-allow_using_system_ Line 1464  Patch202: jdk8035341-allow_using_system_
1464  # 8042159: Allow using a system-installed lcms2  # 8042159: Allow using a system-installed lcms2
1465  Patch203: jdk8042159-allow_using_system_installed_lcms2-root.patch  Patch203: jdk8042159-allow_using_system_installed_lcms2-root.patch
1466  Patch204: jdk8042159-allow_using_system_installed_lcms2-jdk.patch  Patch204: jdk8042159-allow_using_system_installed_lcms2-jdk.patch
 # JDK-8195607, PR3776, RH1760437: sun/security/pkcs11/Secmod/TestNssDbSqlite.java failed with "NSS initialization failed" on NSS 3.34.1  
 Patch580: jdk8195607-pr3776-rh1760437-nss_sqlite_db_config.patch  
1467  # JDK-8257794: Zero: assert(istate->_stack_limit == istate->_thread->last_Java_sp() + 1) failed: wrong on Linux/x86_32  # JDK-8257794: Zero: assert(istate->_stack_limit == istate->_thread->last_Java_sp() + 1) failed: wrong on Linux/x86_32
1468  Patch581: jdk8257794-remove_broken_assert.patch  Patch581: jdk8257794-remove_broken_assert.patch
1469  # JDK-8282231: x86-32: runtime call to SharedRuntime::ldiv corrupts registers  # JDK-8282231: x86-32: runtime call to SharedRuntime::ldiv corrupts registers
# Line 1483  Patch582: jdk8282231-x86_32-missing_call Line 1478  Patch582: jdk8282231-x86_32-missing_call
1478  # able to be removed once that release is out  # able to be removed once that release is out
1479  # and used by this RPM.  # and used by this RPM.
1480  #############################################  #############################################
 # JDK-8294357: (tz) Update Timezone Data to 2022d  
 Patch2002: jdk8294357-tzdata2022d.patch  
 # JDK-8295173: (tz) Update Timezone Data to 2022e  
 Patch2003: jdk8295173-tzdata2022e.patch  
1481    
1482  #############################################  #############################################
1483  #  #
# Line 1557  BuildRequires: java-%{buildjdkver}-openj Line 1548  BuildRequires: java-%{buildjdkver}-openj
1548  %ifarch %{zero_arches}  %ifarch %{zero_arches}
1549  BuildRequires: libffi-devel  BuildRequires: libffi-devel
1550  %endif  %endif
1551  # 2021c required as of JDK-8260356 in April CPU  # 2022g required as of JDK-8297804
1552  BuildRequires: tzdata-java >= 2021c  BuildRequires: tzdata-java >= 2022g
1553  # Earlier versions have a bug in tree vectorization on PPC  # Earlier versions have a bug in tree vectorization on PPC
1554  BuildRequires: gcc >= 4.8.3-8  BuildRequires: gcc >= 4.8.3-8
1555  BuildRequires: rootcerts-java  BuildRequires: rootcerts-java
# Line 1901  sh %{SOURCE12} Line 1892  sh %{SOURCE12}
1892    
1893  # Upstreamable fixes  # Upstreamable fixes
1894  %patch502  %patch502
 %patch504  
1895  %patch512  %patch512
1896  %patch523  %patch523
1897  %patch528  %patch528
# Line 1909  sh %{SOURCE12} Line 1899  sh %{SOURCE12}
1899  %patch574  %patch574
1900  %patch111  %patch111
1901  %patch112  %patch112
 %patch580  
1902  %patch581  %patch581
1903  %patch582  %patch582
1904    
 pushd %{top_level_dir_name}  
 # tzdata updates targetted for 8u362  
 %patch2002 -p1  
 %patch2003 -p1  
 popd  
   
1905  # RPM-only fixes  # RPM-only fixes
1906  %patch539  %patch539
1907  %patch600  %patch600

Legend:
Removed from v.1936261  
changed lines
  Added in v.1936262

  ViewVC Help
Powered by ViewVC 1.1.28