Parent Directory
|
Revision Log
Links to HEAD: | (view) (download) (annotate) |
Sticky Revision: |
ext4: don't allow journal inode to have encrypt flag
ext4: fix deadlock due to mbcache entry corruption
- Revert "ACPI: PM: Add support for upcoming AMD uPEP HID AMDI007"
- Revert "ASoC: soc-pcm: Don't zero TDM masks in __soc_pcm_open()" as it breaks TGL audio (mga #31319)
- cifs: fix oops during encryption - Revert "selftests/bpf: Add test for unstable CT lookup API" - usb: dwc3: qcom: Fix memory leak in dwc3_qcom_interconnect_init
update to 5.15.86
update filelists
- update to 5.15.85 * drop merged patches
add current -stable queue
update to 5.15.82
floppy: Fix memory leak in do_floppy_init()
- xen/netback: Ensure protocol headers don't fall in the non-linear area (This is XSA-423 / CVE-2022-3643) - xen/netback: don't call kfree_skb() with interrupts disabled (XSA-424 / CVE-2022-42328 / CVE-2022-42329)
update to 5.15.81
update to 5.15.80
- mm: hwpoison: refactor refcount check handling - mm: hwpoison: handle non-anonymous THP correctly - mm: shmem: don't truncate page if memory failure happens
- update to 5.15.79 * drop merged patches
add current -stable queue
update to 5.15.78
ALSA: usb-audio: Yet more regression for for the delayed card registration
drm/amd/display: explicitly disable psr_feature_enable appropriately
update to 5.15.77
update to 5.15.76
- Revert "fs: check FMODE_LSEEK to control internal pipe splicing"
update to 5.15.74
dont prefer SOF driver over SST on BY/CHT platforms (mga#29707)
update to 5.15.73
update to 5.15.72
update to 5.15.71
- ACPI: processor idle: Practically limit "Dummy wait" workaround to old Intel systems
- update to 5.15.70 * drop merged patches
- bpf, cgroup: Fix kernel BUG in purge_effective_progs - bpf: Restrict bpf_sys_bpf to CAP_PERFMON - Revert "xhci: turn off port power in shutdown"
- update to 5.15.65 * drop merged patches
add current -stable queue
- update to 5.15.64 * drop merged patches
- bpf: Don't use tnum_range on array range checking for poke descriptors (CVE-2022-2905)
- update to 5.15.63 * drop merged patches - add current -stable queue
add current -stable queue fixes
- xfs: flush inodegc workqueue tasks before cancel - xfs: reserve quota for dir expansion when linking/unlinking files - xfs: reserve quota for target dir expansion when renaming files - xfs: remove infinite loop when reserving free block pool - xfs: always succeed at setting the reserve pool size - xfs: fix overfilling of reserve pool - xfs: fix soft lockup via spinning in filestream ag selection loop - xfs: revert "xfs: actually bump warning counts when we send warnings" - xfs: reject crazy array sizes being fed to XFS_IOC_GETBMAP*
update to 5.15.62
- x86/entry: Fix entry_INT80_compat for Xen PV guests - x86/PAT: Have pat_enabled() properly reflect state when running on Xen
io_uring: use original request task for inflight tracking
- update to 5.15.61 * drop merged patches
- block: fix infinite loop for invalid zone append - btrfs: reject log replay if there is unsupported RO compat flag - ftrace/x86: Add back ftrace_expected assignment
add more kvm fixes from -stable queue
x86/bugs: Enable STIBP for IBPB mitigated RETBleed
netfilter: conntrack: move synack init code to helper
add more kvm fixes from -stable queue
- netfilter: conntrack: re-init state for retransmitted syn-ack - netfilter: nf_conntrack_tcp: re-init for syn packets only
net_sched: cls_route: remove from list when handle is 0 (CVE-2022-2588)
- KVM: nVMX: Snapshot pre-VM-Enter BNDCFGS for !nested_run_pending case - KVM: nVMX: Snapshot pre-VM-Enter DEBUGCTL for !nested_run_pending case - KVM: SVM: Don't BUG if userspace injects an interrupt with GIF=0
- Revert "net: usb: ax88179_178a needs FLAG_SEND_ZLP"
add current -stable queue
- update to 5.15.60 * drop merged patches
drm/nouveau: recognise GA103
add current -stable queue
- update to 5.15.59 * drop merged patches
- fs: sendfile handles O_NONBLOCK of out_fd - hugetlb: fix memoryleak in hugetlb_mcopy_atomic_pte - mm: fix page leak with multiple threads mapping the same page - netfilter: nf_queue: do not allow packet truncation below transport header offset - x86/bugs: Do not enable IBPB at firmware entry when IBPB is not available
update to 5.15.58
x86/speculation: Make all RETbleed mitigations 64-bit only
update to 5.15.57
- update to 5.15.56 * drop merged patches
add fixes from -stable queue
update to 5.15.55
update to 5.15.54
update to 5.15.53
- io_uring: ensure that send/sendmsg and recv/recvmsg check sqe->ioprio - tcp: add a missing nf_reset_ct() in 3WHS handling
- update to 5.15.52 * drop merged patches
update to 5.15.51
- update to 5.15.50 * drop merged patches
init: Initialize noop_backing_dev_info early
- arm64: dts: imx8mm-beacon: Enable RTS-CTS on UART3 - arm64: dts: imx8mn-beacon: Enable RTS-CTS on UART3 - nfsd: Replace use of rwsem with errseq_t - Revert "drm/amd/display: Fix DCN3 B0 DP Alt Mapping"
update to 5.15.48
update to 5.15.47
- update to 5.15.46 * drop merged patches
revert: 'arm64: Initialize jump labels before setup_machine_fdt()'
- drop "block: Fix potential deadlock in blk_ia_range_sysfs_show()"
arm64: Initialize jump labels before setup_machine_fdt()
- mm/page_alloc: always attempt to allocate at least one page during bulk allocation
- blk-iolatency: Fix inflight count imbalances and IO hangs on offline - block: Fix potential deadlock in blk_ia_range_sysfs_show() - drm/amdgpu: add beige goby PCI ID - drm/amdgpu/cs: make commands with 0 chunks illegal behaviour. - wifi: mac80211: fix use-after-free in chanctx code
- x86/amd_nb: Add AMD Family 17h A0-AF IDs - x86/amd_nb: Add Family 19h model 70h-7Fh IDs - x86/amd_nb: Add Family 19h model 60h-6Fh IDs - hwmon: (k10temp): Add support for family 17h models A0h-AFh - hwmon: (k10temp): Add support for family 19h models 70h-7Fh - hwmon: (k10temp): Add support for family 19h models 60h-6Fh
update to 5.15.44
video: fbdev: vesafb: Fix a use-after-free due early fb_info cleanup
nfsd: destroy percpu stats counters after reply cache shutdown
ice: fix crash at allocation failure
KVM: x86/mmu: fix NULL pointer dereference on guest INVPCID
update to 5.15.43
- update to 5.15.41 * drop merged patches
update to 5.15.40
x86/mm: Fix marking of unused sub-pmd ranges
- Revert "drm/amd/pm: keep the BACO feature enabled for suspend"
dma-buf: call dma_buf_stats_setup after dmabuf is in valid list
- drm/vmwgfx: Initialize drm_mode_fb_cmd2 - drm/vmwgfx: Disable command buffers on svga3 without gbobjects - net: atlantic: always deep reset on pm op, fixing up my null deref regression
procfs: prevent unprivileged processes accessing fdinfo dir
- update to 5.15.39 * drop merged patches
nfsd: Fix a write performance regression
x86/mm: Include spinlock_t definition in pgtable.h
- drm/amdgpu: do not use passthrough mode in Xen dom0 - KVM: x86/svm: Account for family 17h event renumberings in amd_pmc_perf_hw_id - x86/fpu: Prevent FPU state corruption
update to 5.15.38
add current -stable queue
SILENT: rename patch
This form allows you to request diffs between any two revisions of this file. For each of the two "sides" of the diff, enter a numeric revision.
ViewVC Help | |
Powered by ViewVC 1.1.28 |