1 |
%define major 4 |
2 |
%define libxpm %mklibname xpm %{major} |
3 |
%define develxpm %mklibname -d xpm |
4 |
|
5 |
Name: libxpm |
6 |
Summary: X Pixmap Library |
7 |
Version: 3.5.15 |
8 |
Release: %mkrel 1 |
9 |
Group: Development/X11 |
10 |
License: MIT |
11 |
URL: http://xorg.freedesktop.org |
12 |
Source0: http://xorg.freedesktop.org/releases/individual/lib/libXpm-%{version}.tar.xz |
13 |
|
14 |
BuildRequires: ncompress |
15 |
BuildRequires: pkgconfig(x11) >= 1.0.0 |
16 |
BuildRequires: pkgconfig(xext) >= 1.0.0 |
17 |
BuildRequires: pkgconfig(xt) >= 1.0.0 |
18 |
BuildRequires: x11-proto-devel >= 1.0.0 |
19 |
BuildRequires: x11-util-macros >= 1.0.1 |
20 |
|
21 |
%description |
22 |
The xpm package contains the XPM pixmap library for the X Window |
23 |
System. The XPM library allows applications to display color, |
24 |
pixmapped images, and is used by many popular X programs. |
25 |
|
26 |
#----------------------------------------------------------- |
27 |
|
28 |
%package -n %{libxpm} |
29 |
Summary: X Pixmap Library |
30 |
Group: Development/X11 |
31 |
Provides: %{name} = %{version} |
32 |
|
33 |
%description -n %{libxpm} |
34 |
The xpm package contains the XPM pixmap library for the X Window |
35 |
System. The XPM library allows applications to display color, |
36 |
pixmapped images, and is used by many popular X programs. |
37 |
|
38 |
%files -n %{libxpm} |
39 |
%{_libdir}/libXpm.so.%{major} |
40 |
%{_libdir}/libXpm.so.%{major}.* |
41 |
|
42 |
#----------------------------------------------------------- |
43 |
|
44 |
%package -n %{develxpm} |
45 |
Summary: Development files for %{name} |
46 |
Group: Development/X11 |
47 |
Requires: %{libxpm} = %{version}-%{release} |
48 |
Provides: libxpm-devel = %{version}-%{release} |
49 |
Provides: xpm-devel = %{version}-%{release} |
50 |
Obsoletes: %{_lib}xpm-static-devel < 3.5.10-4 |
51 |
|
52 |
%description -n %{develxpm} |
53 |
Development files for %{name} |
54 |
|
55 |
%files -n %{develxpm} |
56 |
%{_bindir}/cxpm |
57 |
%{_bindir}/sxpm |
58 |
%{_libdir}/libXpm.so |
59 |
%{_libdir}/pkgconfig/xpm.pc |
60 |
%{_includedir}/X11/xpm.h |
61 |
%{_mandir}/man1/* |
62 |
%{_mandir}/man3/* |
63 |
|
64 |
#----------------------------------------------------------- |
65 |
|
66 |
%prep |
67 |
%setup -q -n libXpm-%{version} |
68 |
|
69 |
%build |
70 |
%configure --x-includes=%{_includedir}\ |
71 |
--x-libraries=%{_libdir} \ |
72 |
--disable-static |
73 |
|
74 |
%make |
75 |
|
76 |
%install |
77 |
%make_install |
78 |
|
79 |
find %{buildroot} -name "*.la" -delete |