/[packages]/updates/8/mysql-connector-c++/current/SPECS/mysql-connector-c++.spec
ViewVC logotype

Annotation of /updates/8/mysql-connector-c++/current/SPECS/mysql-connector-c++.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1474104 - (hide annotations) (download)
Fri Dec 27 20:16:00 2019 UTC (4 years, 3 months ago) by wally
Original Path: cauldron/mysql-connector-c++/current/SPECS/mysql-connector-c++.spec
File size: 4572 byte(s)
- build with new cmake macros
1 spuhler 816025 %define major 7
2 dmorgan 56412 %define libname %mklibname mysqlcppconn %{major}
3     %define develname %mklibname mysqlcppconn -d
4    
5 wally 1419766 %ifarch aarch64
6     %global _smp_ncpus_max 4
7     %endif
8    
9 dmorgan 56412 Summary: A MySQL database connector for C++
10     Name: mysql-connector-c++
11 wally 1184321 Version: 1.1.9
12 wally 1419764 Release: %mkrel 3
13 dmorgan 56412 Group: System/Libraries
14 barjac 879272 License: GPLv2
15 dmorgan 56412 URL: http://dev.mysql.com/downloads/connector/cpp/
16 fwang 307859 Source0: http://cdn.mysql.com/Downloads/Connector-C++/%{name}-%{version}.tar.gz
17 spuhler 816115 ## patches from arch-linux
18     Patch0: mysql_cxx_linkage.patch
19     Patch1: mariadb_api.patch
20 wally 1419764 ## from opensuse
21     Patch10: mysql-connector-cpp-mariadb.patch
22     Patch11: mysql-connector-cpp-1.1.9-libmysql_dynamic_proxy_typos.patch
23 dmorgan 56412 BuildRequires: cmake
24     BuildRequires: mysql-devel
25 barjac 879272 BuildRequires: boost-devel
26 dmorgan 56412
27     %description
28 spuhler 816025 MySQL Connector/C++ is a MySQL database connector for C++ development. The
29     MySQL driver for C++ can be used to connect to MySQL from C++ applications. The
30     driver mimics the JDBC 4.0 API. It implements a significant subset of JDBC 4.0.
31 dmorgan 56412
32 spuhler 816025 The Driver for C++ is designed to work best with MySQL 5.1 or later. Note - its
33     full functionality is not available when connecting to MySQL 5.0. You cannot
34     connect to MySQL 4.1 or earlier.
35    
36     Using MySQL Connector/C++ instead of the MySQL C API (MySQL Client Library)
37     offers the following advantages for C++ users:
38    
39     * Convenience of pure C++ - no C function calls
40     * Support of a well designed API - JDBC 4.0
41     * Support of a commonly known and well documented API - JDBC 4.0
42     * Support of the object oriented programming paradigma
43     * Shorter development times
44    
45 dmorgan 56412 %package -n %{libname}
46     Summary: The shared mysql-connector-cpp library
47 barjac 879272 Group: System/Libraries
48     Provides: %{name} = %{version}-%{release}
49 dmorgan 56412
50     %description -n %{libname}
51 spuhler 816025 MySQL Connector/C++ is a MySQL database connector for C++ development. The
52     MySQL driver for C++ can be used to connect to MySQL from C++ applications. The
53     driver mimics the JDBC 4.0 API. It implements a significant subset of JDBC 4.0.
54 dmorgan 56412
55 spuhler 816025 The Driver for C++ is designed to work best with MySQL 5.1 or later. Note - its
56     full functionality is not available when connecting to MySQL 5.0. You cannot
57     connect to MySQL 4.1 or earlier.
58 dmorgan 56412
59 spuhler 816025 Using MySQL Connector/C++ instead of the MySQL C API (MySQL Client Library)
60     offers the following advantages for C++ users:
61    
62     * Convenience of pure C++ - no C function calls
63     * Support of a well designed API - JDBC 4.0
64     * Support of a commonly known and well documented API - JDBC 4.0
65     * Support of the object oriented programming paradigma
66     * Shorter development times
67    
68 dmorgan 56412 %package -n %{develname}
69     Summary: Development library and header files for development with mysql-connector-cpp
70 barjac 879272 Group: Development/C++
71 dmorgan 56412 Requires: %{libname} = %{version}
72 spuhler 816025 Provides: %{name}-devel = %{version}-%{release}
73 dmorgan 56412
74     %description -n %{develname}
75 spuhler 816025 MySQL Connector/C++ is a MySQL database connector for C++ development. The
76     MySQL driver for C++ can be used to connect to MySQL from C++ applications. The
77     driver mimics the JDBC 4.0 API. It implements a significant subset of JDBC 4.0.
78 dmorgan 56412
79 spuhler 816025 The Driver for C++ is designed to work best with MySQL 5.1 or later. Note - its
80     full functionality is not available when connecting to MySQL 5.0. You cannot
81     connect to MySQL 4.1 or earlier.
82 dmorgan 56412
83 spuhler 816025 Using MySQL Connector/C++ instead of the MySQL C API (MySQL Client Library)
84     offers the following advantages for C++ users:
85    
86     * Convenience of pure C++ - no C function calls
87     * Support of a well designed API - JDBC 4.0
88     * Support of a commonly known and well documented API - JDBC 4.0
89     * Support of the object oriented programming paradigma
90     * Shorter development times
91    
92 dmorgan 56412 %prep
93 dmorgan 56455 %setup -q
94 wally 1419764 %autopatch -p1
95    
96 dmorgan 56455 %{__chmod} -x examples/*.cpp examples/*.txt
97    
98     # Save examples to keep directory clean (for doc)
99     %{__mkdir} _doc_examples
100     %{__cp} -pr examples _doc_examples
101    
102 dmorgan 56412 %build
103 wally 1419767 %cmake \
104 barjac 879272 -DMYSQL_INCLUDE_DIR=%{_includedir}/mysql \
105 spuhler 816115 -DCMAKE_INSTALL_PREFIX=/usr \
106     -DCMAKE_BUILD_TYPE=Release \
107 spuhler 816157 -DCMAKE_INSTALL_LIBDIR=%{_libdir} \
108 spuhler 816115 -DMYSQLCPPCONN_BUILD_EXAMPLES=OFF \
109 spuhler 816157 -DMYSQL_LIB=%{_libdir}/libmysqlclient.so
110 wally 1474104 %cmake_build
111 dmorgan 56412
112     %install
113 dmorgan 61364 cp build/cppconn/config.h cppconn/config.h
114 spuhler 816025
115 wally 1474104 %cmake_install
116 dmorgan 61363 rm -fr %{buildroot}%_prefix/COPYING
117     rm -fr %{buildroot}%_prefix/INSTALL
118     rm -fr %{buildroot}%_prefix/README
119 fwang 307860 rm -fr %{buildroot}%_prefix/ANNOUNCEMENT
120     rm -fr %{buildroot}%_prefix/Licenses_for_Third-Party_Components.txt
121 spuhler 816025 rm -f %{buildroot}%{_libdir}/libmysqlcppconn-static.a
122 dmorgan 56412
123     %files -n %{libname}
124 ovitters 877720 %{_libdir}/*.so.%{major}{,.*}
125 dmorgan 56412
126     %files -n %{develname}
127 wally 1184321 %doc README COPYING examples
128 dmorgan 61363 %dir %{_includedir}/cppconn
129 fwang 307859 %{_includedir}/*.h
130     %{_includedir}/cppconn/*.h
131     %{_libdir}/*.so
132 spuhler 816025

  ViewVC Help
Powered by ViewVC 1.1.30