/[packages]/updates/8/mysql-connector-c++/current/SPECS/mysql-connector-c++.spec
ViewVC logotype

Annotation of /updates/8/mysql-connector-c++/current/SPECS/mysql-connector-c++.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 682723 - (hide annotations) (download)
Tue Sep 16 17:28:30 2014 UTC (9 years, 6 months ago) by umeabot
Original Path: cauldron/mysql-connector-c++/current/SPECS/mysql-connector-c++.spec
File size: 2218 byte(s)
Mageia 5 Mass Rebuild
1 dmorgan 61363 %define major 6
2 dmorgan 56412 %define libname %mklibname mysqlcppconn %{major}
3     %define develname %mklibname mysqlcppconn -d
4    
5     Summary: A MySQL database connector for C++
6     Name: mysql-connector-c++
7 fwang 307859 Version: 1.1.1
8 umeabot 682723 Release: %mkrel 5
9 dmorgan 56412 Group: System/Libraries
10     License: GPL
11     URL: http://dev.mysql.com/downloads/connector/cpp/
12 fwang 307859 Source0: http://cdn.mysql.com/Downloads/Connector-C++/%{name}-%{version}.tar.gz
13 dmorgan 56412 BuildRequires: cmake
14     BuildRequires: mysql-devel
15 dmorgan 56456 BuildRequires: boost-devel
16 dmorgan 56412
17     %description
18     Connector/C++ is a tool that enables easy deployment and management of MySQL
19     server and database through your C++ application.
20    
21     %package -n %{libname}
22     Summary: The shared mysql-connector-cpp library
23     Group: System/Libraries
24    
25     %description -n %{libname}
26     Connector/C++ is a tool that enables easy deployment and management of MySQL
27     server and database through your C++ application.
28    
29     This package provides the shared mysql-connector-cpp library.
30    
31     %package -n %{develname}
32     Summary: Development library and header files for development with mysql-connector-cpp
33     Group: Development/C++
34     Requires: %{libname} = %{version}
35     Provides: mysql-connector-c++-devel = %{version}-%{release}
36    
37     %description -n %{develname}
38     Connector/C++ is a tool that enables easy deployment and management of MySQL
39     server and database through your C++ application.
40    
41     This package is only needed if you plan to develop or compile applications
42     which requires the mysql-connector-cpp library.
43    
44     %prep
45 dmorgan 56455 %setup -q
46     %{__sed} -i -e 's/lib$/%{_lib}/' driver/CMakeLists.txt
47     %{__chmod} -x examples/*.cpp examples/*.txt
48    
49     # Save examples to keep directory clean (for doc)
50     %{__mkdir} _doc_examples
51     %{__cp} -pr examples _doc_examples
52    
53 dmorgan 56412 %build
54 fwang 307859 %{cmake} -DMYSQLCPPCONN_BUILD_EXAMPLES:BOOL=OFF
55     %{make}
56 dmorgan 56412
57     %install
58 dmorgan 61364 cp build/cppconn/config.h cppconn/config.h
59 fwang 307859 %makeinstall_std -C build
60 dmorgan 61363 rm -fr %{buildroot}%_prefix/COPYING
61     rm -fr %{buildroot}%_prefix/INSTALL
62     rm -fr %{buildroot}%_prefix/README
63 fwang 307860 rm -fr %{buildroot}%_prefix/ANNOUNCEMENT
64     rm -fr %{buildroot}%_prefix/Licenses_for_Third-Party_Components.txt
65 dmorgan 56412
66     %files -n %{libname}
67 fwang 307859 %{_libdir}/*.so.%{major}*
68 dmorgan 56412
69     %files -n %{develname}
70 dmorgan 61363 %dir %{_includedir}/cppconn
71 fwang 307859 %{_includedir}/*.h
72     %{_includedir}/cppconn/*.h
73     %{_libdir}/*.so
74 fwang 307860 %{_libdir}/*.a

  ViewVC Help
Powered by ViewVC 1.1.30