/[packages]/updates/8/python-pydrive2/current/SPECS/python-pydrive2.spec
ViewVC logotype

Contents of /updates/8/python-pydrive2/current/SPECS/python-pydrive2.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1860693 - (show annotations) (download)
Sun May 29 14:24:19 2022 UTC (16 months ago) by wally
File size: 1960 byte(s)
- disable doc build due to a missing python3dist(furo) in mga8
1 # Created by pyp2rpm-3.3.8
2 %global pypi_name pydrive2
3 %global srcname PyDrive2
4 %global pypi_version 1.10.1
5
6 # no python3dist(furo)
7 %bcond_with docs
8
9 Name: python-%{pypi_name}
10 Version: %{pypi_version}
11 Release: %mkrel 1
12 Summary: Google Drive API made easy. Maintained fork of PyDrive
13 Group: Development/Python
14 License: Apache License 2.0
15 URL: https://github.com/iterative/PyDrive2
16 Source0: %{pypi_source}
17 BuildArch: noarch
18
19 BuildRequires: python3-devel
20 BuildRequires: python3dist(google-api-python-client)
21 BuildRequires: python3dist(six)
22 BuildRequires: python3dist(oauth2client)
23 BuildRequires: python3dist(pyyaml)
24 BuildRequires: python3dist(pyopenssl)
25 # docs
26 %if %{with docs}
27 BuildRequires: python3dist(sphinx)
28 BuildRequires: python3dist(furo)
29 %endif
30
31 %description
32 PyDrive2 is a wrapper library of google-api-python-client that simplifies many
33 common Google Drive API V2 tasks. It is an actively maintained fork of PyDrive.
34
35 %package -n python3-%{pypi_name}
36 Summary: %{summary}
37 %{?python_provide:%python_provide python3-%{pypi_name}}
38 %{?python_provide:%python_provide python3-%{srcname}}
39 Provides: python3-PyDrive2 = %{version}-%{release}
40 Obsoletes: python3-pydrive < 1.3.1-2
41
42 %description -n python3-%{pypi_name}
43 PyDrive2 is a wrapper library of google-api-python-client that simplifies many
44 common Google Drive API V2 tasks. It is an actively maintained fork of PyDrive.
45
46 %prep
47 %autosetup -n %{srcname}-%{pypi_version}
48
49 # Remove bundled egg-info
50 rm -rf *.egg-info
51
52 %build
53 %py3_build
54
55 %if %{with docs}
56 # generate html docs
57 PYTHONPATH=${PWD} sphinx-build-3 docs html
58 # remove the sphinx-build leftovers
59 rm -rf html/.{doctrees,buildinfo}
60 %endif
61
62 %install
63 %py3_install
64
65 %files -n python3-%{pypi_name}
66 %license LICENSE
67 %doc README.*
68 %if %{with docs}
69 %doc html
70 %endif
71 %{python3_sitelib}/%{pypi_name}/
72 %{python3_sitelib}/%{srcname}-%{pypi_version}-py%{python3_version}.egg-info

  ViewVC Help
Powered by ViewVC 1.1.28