1 |
%define srcname WindowMaker |
2 |
%define _pixdir %{_datadir}/pixmaps |
3 |
%define gnustepdir %{_datadir}/GNUstep |
4 |
%define wmsysdir %{_sysconfdir}/X11/WindowMaker |
5 |
%define wmdatdir %{_datadir}/WindowMaker |
6 |
%define wmdefdir %{wmdatdir}/Defaults |
7 |
|
8 |
%define major 6 |
9 |
%define libwraster %mklibname wraster %{major} |
10 |
%define libwrasterdev %mklibname wraster -d |
11 |
|
12 |
%define wgsmajor 3 |
13 |
%define libwgsname %mklibname wings %{wgsmajor} |
14 |
%define libwgsnamedev %mklibname wings -d |
15 |
|
16 |
%define wutmajor 5 |
17 |
%define libwutname %mklibname wutil %{wutmajor} |
18 |
%define libwutnamedev %mklibname wutil -d |
19 |
|
20 |
%define wmkmajor 1 |
21 |
%define libwmkname %mklibname wmaker %{wmkmajor} |
22 |
%define libwmknamedev %mklibname wmaker -d |
23 |
|
24 |
Name: windowmaker |
25 |
Version: 0.95.9 |
26 |
%define subrel 2 |
27 |
Release: %mkrel 3 |
28 |
Summary: A window manager for the X Window System |
29 |
License: GPLv2+ |
30 |
Group: Graphical desktop/WindowMaker |
31 |
|
32 |
URL: http://windowmaker.org/ |
33 |
Source0: http://windowmaker.org/pub/source/release/%{srcname}-%{version}.tar.gz |
34 |
Source1: addxdgsupport.bash |
35 |
Source2: startwindowmaker |
36 |
Source3: WindowMaker.desktop |
37 |
Source4: autostart.sh.mga |
38 |
Source5: WMState.mga |
39 |
Source6: WMWindowAttributes.mga |
40 |
Source7: WindowMaker.mga |
41 |
|
42 |
# Fixes |
43 |
# (cjw) try to implement _NET_WM_MOVERESIZE events, required by gtk+3 (though that appears to be a bug) |
44 |
Patch0: windowmaker-0.95.7-net_wm_moveresize.patch |
45 |
|
46 |
# Reconfiguration |
47 |
Patch100: %{name}-0.95.4-mga-use-xdg-menu-extension.patch |
48 |
|
49 |
# Upstream work from the next branch |
50 |
Patch200: 0001-configure-Allow-changing-default-search-paths.patch |
51 |
Patch201: 0002-Remove-apostrophes-from-instances-of-possessive-its.patch |
52 |
Patch202: 0004-configure-Fix-typo-in-libXmu-check.patch |
53 |
Patch203: 0005-wmlib-Use-X-flags-from-configure.patch |
54 |
Patch204: 0007-wrlib-Compile-with-either-ImageMagick-6-and-7.patch |
55 |
Patch205: 0008-Fix-various-abs-issues.patch |
56 |
Patch206: 0010-checkpatch.pl-Escape-curly-braces-in-regexes.patch |
57 |
Patch207: 0012-wrlib-Fix-typo-in-macro-containing-ImageMagick-versi.patch |
58 |
Patch208: 0013-Fix-typo-on-defining-imagemagick-version.patch |
59 |
|
60 |
Requires: desktop-common-data |
61 |
Requires: xdg-compliance-menu |
62 |
Requires: task-x11 |
63 |
|
64 |
BuildRequires: pkgconfig(xft) |
65 |
BuildRequires: pkgconfig(xinerama) |
66 |
BuildRequires: libhermes-devel |
67 |
BuildRequires: pkgconfig(libjpeg) |
68 |
BuildRequires: pkgconfig(libpng) |
69 |
BuildRequires: pkgconfig(libtiff-4) |
70 |
BuildRequires: giflib-devel |
71 |
BuildRequires: pkgconfig(xpm) |
72 |
BuildRequires: mawk |
73 |
BuildRequires: pkgconfig(xmu) |
74 |
BuildRequires: pkgconfig(ImageMagick) |
75 |
BuildRequires: pkgconfig(pango) |
76 |
BuildRequires: pkgconfig(libexif) |
77 |
|
78 |
Requires: default-windowmaker-desktop |
79 |
Recommends: mageia-windowmaker-desktop |
80 |
Conflicts: desktop-common-data < 1:3.10-2 |
81 |
|
82 |
%description |
83 |
Window Maker is a X11 window manager which emulates the look and feel of the |
84 |
NeXTSTEP (TM) graphical user interface. It is relatively fast, feature rich and |
85 |
easy to configure and use. Window Maker is part of the official GNU project, |
86 |
which means that Window Maker can interoperate with other GNU projects, such as |
87 |
GNOME. Window Maker allows users to switch themes on the fly, to place favorite |
88 |
applications on either an application dock, similar to AfterStep's Wharf or on |
89 |
a workspace dock, a 'clip' which extends the application dock's usefulness. |
90 |
|
91 |
%package -n %{libwraster} |
92 |
Summary: Window Maker Raster Graphics Library |
93 |
Group: Graphical desktop/WindowMaker |
94 |
Conflicts: %{_lib}wraster < 0.95 |
95 |
Provides: %{_lib}wraster2 = %{version}-%{release} |
96 |
Obsoletes: %{_lib}wraster2 < 0.95 |
97 |
|
98 |
%description -n %{libwraster} |
99 |
Also known as libwraster, it is WindowMaker's core graphics and image |
100 |
processing system. libwraster is an optimized, fast, lightweight image library. |
101 |
It takes advantage of MMX optimizations (on systems that have support for it) |
102 |
to accelerate rendering. You can load a picture from a file easily with |
103 |
libwraster, and it has support for .gif, .jpg, .png, .xpm, .ppm, and .tiff at |
104 |
the moment. Support for other image formats can be added in the future. |
105 |
|
106 |
%package -n %{libwrasterdev} |
107 |
Summary: Window Maker Raster Graphics Library development files |
108 |
Group: Development/C |
109 |
Requires: %{libwraster} = %{version}-%{release} |
110 |
Provides: libwraster-devel = %{version}-%{release} |
111 |
Conflicts: libwraster2-devel < 0.95 |
112 |
|
113 |
%description -n %{libwrasterdev} |
114 |
This package allows building applications using the libwraster library. |
115 |
|
116 |
%package -n %{libwgsname} |
117 |
Summary: Libraries for Window Maker widgets |
118 |
Group: System/Libraries |
119 |
|
120 |
%description -n %{libwgsname} |
121 |
%{summary}. |
122 |
|
123 |
%package -n %{libwgsnamedev} |
124 |
Summary: Development files for the Window Maker widgets |
125 |
Group: Development/C |
126 |
Requires: %{libwgsname} = %{version}-%{release} |
127 |
Provides: libwings-devel = %{version}-%{release} |
128 |
|
129 |
%description -n %{libwgsnamedev} |
130 |
%{summary}. |
131 |
|
132 |
%package -n %{libwutname} |
133 |
Summary: Libraries for Window Maker utilities |
134 |
Group: System/Libraries |
135 |
|
136 |
%description -n %{libwutname} |
137 |
%{summary}. |
138 |
|
139 |
%package -n %{libwutnamedev} |
140 |
Summary: Development files for the Window Maker utilities |
141 |
Group: Development/C |
142 |
Requires: %{libwutname} = %{version}-%{release} |
143 |
Provides: libwutil-devel = %{version}-%{release} |
144 |
|
145 |
%description -n %{libwutnamedev} |
146 |
%{summary}. |
147 |
|
148 |
%package -n %{libwmkname} |
149 |
Summary: Libraries for Window Maker programming interface |
150 |
Group: System/Libraries |
151 |
|
152 |
%description -n %{libwmkname} |
153 |
%{summary}. |
154 |
|
155 |
%package -n %{libwmknamedev} |
156 |
Summary: Development files for the Window Maker programming interface |
157 |
Group: Development/C |
158 |
Requires: %{libwmkname} = %{version}-%{release} |
159 |
Requires: %{libwrasterdev} = %{version}-%{release} |
160 |
Requires: %{libwgsnamedev} = %{version}-%{release} |
161 |
|
162 |
%description -n %{libwmknamedev} |
163 |
%{summary}. |
164 |
|
165 |
%package -n default-%{name}-desktop |
166 |
Summary: Default Window Maker desktop |
167 |
Group: Graphical desktop/WindowMaker |
168 |
Conflicts: %{name} < 0.95.3-0.snapshot20120330.4 |
169 |
Requires: windowmaker |
170 |
BuildArch: noarch |
171 |
|
172 |
%description -n default-%{name}-desktop |
173 |
Default config files for the Window Maker desktop. |
174 |
|
175 |
%package -n %{_real_vendor}-%{name}-desktop |
176 |
Summary: %{_vendor} Window Maker desktop |
177 |
Group: Graphical desktop/WindowMaker |
178 |
Conflicts: %{name} < 0.95.3-0.snapshot20120330.4 |
179 |
Requires: windowmaker |
180 |
Requires: windowmaker-theme-mageia |
181 |
Requires: wmcalclock |
182 |
Requires: wmudmount |
183 |
Requires: wmsystemtray |
184 |
Requires: pulseaudio-utils |
185 |
Requires: gvolwheel |
186 |
Requires: drakx-net-applet |
187 |
Requires: mate-polkit |
188 |
BuildArch: noarch |
189 |
|
190 |
%description -n %{_real_vendor}-%{name}-desktop |
191 |
%{_vendor} enhanced config files for the Window Maker desktop. |
192 |
|
193 |
%prep |
194 |
%setup -q -n %{srcname}-%{version} |
195 |
%patch0 -p1 -b .netwm-moveresize |
196 |
%patch100 -p0 |
197 |
cp %{SOURCE1} WindowMaker/addxdgsupport.bash |
198 |
|
199 |
%patch200 -p1 |
200 |
%patch201 -p1 |
201 |
%patch202 -p1 |
202 |
%patch203 -p1 |
203 |
%patch204 -p1 |
204 |
%patch205 -p1 |
205 |
%patch206 -p1 |
206 |
%patch207 -p1 |
207 |
%patch208 -p1 |
208 |
|
209 |
%build |
210 |
#xdg support in menu |
211 |
pushd WindowMaker |
212 |
./addxdgsupport.bash |
213 |
popd #WindowMaker |
214 |
|
215 |
# protect the WPrefs.app location for unclean build envs with gnustep-make installed |
216 |
unset GNUSTEP_LOCAL_ROOT |
217 |
|
218 |
LINGUAS=`(cd po ; echo *.po | sed 's/.po//g')` |
219 |
export LINGUAS |
220 |
autoreconf -fi |
221 |
%configure \ |
222 |
--prefix=%{_prefix} \ |
223 |
--enable-static=no \ |
224 |
--sysconfdir=%{_sysconfdir}/X11 \ |
225 |
--localedir=%{_datadir}/locale \ |
226 |
--with-pixmapdir=%{_pixdir} \ |
227 |
--with-gnustepdir=%{gnustepdir} \ |
228 |
--enable-xinerama \ |
229 |
--enable-usermenu \ |
230 |
--enable-pango \ |
231 |
--disable-randr \ |
232 |
--with-pic \ |
233 |
--with-x |
234 |
|
235 |
%make_build |
236 |
|
237 |
%install |
238 |
%make_install |
239 |
|
240 |
%__chmod 755 %{buildroot}%{_datadir}/WindowMaker/exitscript.sh |
241 |
|
242 |
install -D -m 755 %{SOURCE2} %{buildroot}%{_bindir}/startwindowmaker |
243 |
install -D -m 644 %{SOURCE3} %{buildroot}%{_datadir}/xsessions/WindowMaker.desktop |
244 |
|
245 |
%find_lang WindowMaker --all-name --with-man |
246 |
|
247 |
find %{buildroot}%{_libdir} -name *.la -delete |
248 |
|
249 |
# install mageia-windowmaker-desktop files |
250 |
install -D -m 755 %{S:4} %{buildroot}%{wmdatdir}/autostart.sh |
251 |
install -D -m 644 %{S:5} %{buildroot}%{wmdefdir}/WMState |
252 |
install -D -m 644 %{S:6} %{buildroot}%{wmdefdir}/WMWindowAttributes |
253 |
install -D -m 644 %{S:7} %{buildroot}%{wmdefdir}/WindowMaker |
254 |
|
255 |
%posttrans |
256 |
# (ovitters) In posttrans, $1 is always equal to 1, even in the upgrade case. |
257 |
# So just run this always: |
258 |
if [ -e %{_datadir}/xsessions/03WindowMaker.desktop ]; then |
259 |
rm -rf %{_datadir}/xsessions/03WindowMaker.desktop |
260 |
fi |
261 |
if [ -e %{_sysconfdir}/X11/dm/Sessions/03WindowMaker.desktop ]; then |
262 |
rm -rf %{_sysconfdir}/X11/dm/Sessions/03WindowMaker.desktop |
263 |
fi |
264 |
|
265 |
%files -f WindowMaker.lang |
266 |
%doc AUTHORS BUGFORM BUGS ChangeLog COPYING.WTFPL FAQ NEWS README* TODO |
267 |
%{_bindir}/* |
268 |
%{_datadir}/xsessions/WindowMaker.desktop |
269 |
%dir %{gnustepdir} |
270 |
%{gnustepdir}/Applications/WPrefs.app |
271 |
%{_mandir}/man[18]/* |
272 |
%dir %{wmdatdir} |
273 |
%{_datadir}/WindowMaker/README* |
274 |
%{_datadir}/WindowMaker/*menu* |
275 |
%{_datadir}/WindowMaker/exitscript.sh |
276 |
%{_datadir}/WindowMaker/wmmacros |
277 |
%{_datadir}/WindowMaker/Backgrounds |
278 |
%{_datadir}/WindowMaker/IconSets |
279 |
%{_datadir}/WindowMaker/Icons |
280 |
%{_datadir}/WindowMaker/Pixmaps |
281 |
%{_datadir}/WindowMaker/Styles |
282 |
%{_datadir}/WindowMaker/Themes |
283 |
%{_datadir}/WINGs/ |
284 |
|
285 |
%files -n %{libwraster} |
286 |
%{_libdir}/libwraster.so.%{major} |
287 |
%{_libdir}/libwraster.so.%{major}.* |
288 |
|
289 |
%files -n %{libwrasterdev} |
290 |
%{_includedir}/wraster.h |
291 |
%{_libdir}/libwraster.so |
292 |
%{_libdir}/pkgconfig/wrlib.pc |
293 |
|
294 |
%files -n %{libwgsname} |
295 |
%{_libdir}/libWINGs.so.%{wgsmajor} |
296 |
%{_libdir}/libWINGs.so.%{wgsmajor}.* |
297 |
|
298 |
%files -n %{libwgsnamedev} |
299 |
%{_libdir}/libWINGs.so |
300 |
%{_includedir}/WINGs |
301 |
%{_libdir}/pkgconfig/WINGs.pc |
302 |
|
303 |
%files -n %{libwutname} |
304 |
%{_libdir}/libWUtil.so.%{wutmajor} |
305 |
%{_libdir}/libWUtil.so.%{wutmajor}.* |
306 |
|
307 |
%files -n %{libwutnamedev} |
308 |
%{_libdir}/libWUtil.so |
309 |
%{_libdir}/pkgconfig/WUtil.pc |
310 |
|
311 |
%files -n %{libwmkname} |
312 |
%{_libdir}/libWMaker.so.%{wmkmajor} |
313 |
%{_libdir}/libWMaker.so.%{wmkmajor}.* |
314 |
%{_libdir}/pkgconfig/wmlib.pc |
315 |
|
316 |
%files -n %{libwmknamedev} |
317 |
%{_includedir}/WMaker.h |
318 |
%{_libdir}/libWMaker.so |
319 |
|
320 |
%files -n default-%{name}-desktop |
321 |
%dir %{wmsysdir} |
322 |
%config(noreplace)%{wmsysdir}/WMGLOBAL |
323 |
%config(noreplace)%{wmsysdir}/WMRootMenu |
324 |
%config(noreplace)%{wmsysdir}/WMState |
325 |
%config(noreplace)%{wmsysdir}/WMWindowAttributes |
326 |
%config(noreplace)%{wmsysdir}/WindowMaker |
327 |
|
328 |
%files -n %{_real_vendor}-%{name}-desktop |
329 |
%dir %{wmdefdir} |
330 |
%{wmdatdir}/autostart.sh |
331 |
%{wmdefdir}/WMState |
332 |
%{wmdefdir}/WMWindowAttributes |
333 |
%{wmdefdir}/WindowMaker |
334 |
|