/[packages]/updates/infra_5/python-whoosh/current/SPECS/python-whoosh.spec
ViewVC logotype

Contents of /updates/infra_5/python-whoosh/current/SPECS/python-whoosh.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 909189 - (show annotations) (download)
Wed Dec 9 19:54:13 2015 UTC (8 years, 4 months ago) by philippem
File size: 2117 byte(s)
adapt to mga5
1 %define mod_name Whoosh
2
3 Name: python-whoosh
4 Version: 2.7.0
5 Release: %mkrel 1
6 Summary: Fast, pure-Python full text indexing, search, and spell checking library
7 License: BSD
8 Group: Development/Python
9 URL: http://pythonhosted.org/Whoosh/
10 Source0: https://pypi.python.org/packages/source/W/%{mod_name}/%{mod_name}-%{version}.tar.gz
11 BuildArch: noarch
12 BuildRequires: python-devel
13 BuildRequires: python-setuptools
14 BuildRequires: python-nose
15 BuildRequires: python-sphinx
16
17 %description
18 Whoosh is a fast, featureful full-text indexing and searching library
19 implemented in pure Python. Programmers can use it to easily add search
20 functionality to their applications and websites. Every part of how Whoosh
21 works can be extended or replaced to meet your needs exactly.
22
23 %package -n python3-whoosh
24 Summary: Fast, pure-Python full text indexing, search, and spell checking library
25 BuildArch: noarch
26 BuildRequires: python3-devel
27 BuildRequires: python3-setuptools
28 BuildRequires: python3-nose
29 BuildRequires: python3-sphinx
30
31 %description -n python3-whoosh
32 Whoosh is a fast, featureful full-text indexing and searching library
33 implemented in pure Python. Programmers can use it to easily add search
34 functionality to their applications and websites. Every part of how Whoosh
35 works can be extended or replaced to meet your needs exactly.
36
37 %prep
38 %setup -q -n %{mod_name}-%{version}
39 cp -a . %{py3dir}
40
41 %build
42 %{__python} setup.py build
43 sphinx-build docs/source docs/html
44 rm -f docs/html/.buildinfo
45 rm -rf docs/html/.doctrees
46
47 pushd %{py3dir}
48 %{__python3} setup.py build
49 sphinx-build docs/source docs/html
50 rm -f docs/html/.buildinfo
51 rm -rf docs/html/.doctrees
52 popd
53
54 %install
55 %{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
56
57 pushd %{py3dir}
58 %{__python3} setup.py install --skip-build --root %{buildroot}
59 popd
60
61 %files
62 %doc docs/html/ README.txt LICENSE.txt
63 %{python_sitelib}/*.egg-info/
64 %{python_sitelib}/whoosh
65
66 %files -n python3-whoosh
67 %doc docs/html/ README.txt LICENSE.txt
68 %{python3_sitelib}/*.egg-info/
69 %{python3_sitelib}/whoosh
70
71

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC 1.1.30