/[adm]/puppet/modules/postgresql/manifests/init.pp
ViewVC logotype

Diff of /puppet/modules/postgresql/manifests/init.pp

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

revision 522 by misc, Sun Nov 7 13:07:01 2010 UTC revision 523 by misc, Tue Dec 7 02:40:21 2010 UTC
# Line 1  Line 1 
1  class postgresql {  class postgresql {
2            
3      $pgsql_data = "/var/lib/pgsql/data/"      $pgsql_data = "/var/lib/pgsql/data/"
4        $pg_version = '9.0'
5    
6      package { 'postgresql9.0-server':      # missing requires is corrected in cooker,
7        # should be removed
8        # once the fix is in a stable release
9        package { "postgresql$pg_version-plpgsql":
10            alias => "postgresql-plpgsql",
11            ensure => installed,
12        }
13    
14        package { "postgresql$pg_version-server":
15          alias => "postgresql-server",          alias => "postgresql-server",
16          ensure => installed          ensure => installed,
17            require => Package['postgresql-plpgsql'],
18      }      }
19    
20      service { postgresql:      service { postgresql:

Legend:
Removed from v.522  
changed lines
  Added in v.523

  ViewVC Help
Powered by ViewVC 1.1.28