1 |
Name: isodumper |
2 |
Version: 0.20 |
3 |
Release: %mkrel 1 |
4 |
Summary: Tool for writing ISO images on a USB stick |
5 |
Summary(fr_FR): Outil pour écrire des images ISO sur une clé USB |
6 |
License: GPLv2+ |
7 |
Group: System/Configuration |
8 |
URL: https://github.com/papoteur-mga/isodumper |
9 |
# wget https://github.com/papoteur-mga/isodumper/archive/%%{version}.tar.gz -O %%{name}-%%{version}.tar.gz |
10 |
Source0: %{name}-%{version}.tar.gz |
11 |
BuildArch: noarch |
12 |
|
13 |
BuildRequires: imagemagick |
14 |
BuildRequires: intltool |
15 |
|
16 |
Requires: coreutils |
17 |
Requires: pango |
18 |
Requires: polkit |
19 |
Requires: procps |
20 |
Requires: python |
21 |
Requires: pygtk2.0-libglade |
22 |
Requires: udisks |
23 |
Requires: xterm |
24 |
# Needed only for Mageia 3, because polkit doesn't work as intended |
25 |
Requires: usermode-consoleonly |
26 |
|
27 |
%description |
28 |
A GUI tool for writing ISO images on a USB stick. |
29 |
It's a fork of usb-imagewriter. |
30 |
|
31 |
This software is written in python. |
32 |
|
33 |
%description -l fr_FR |
34 |
Un outil graphique pour écrire des images ISO sur une clé USB. |
35 |
C'est un fork de usb-imagewriter |
36 |
|
37 |
Ce logiciel est écrit en python. |
38 |
|
39 |
#-------------------------------------------------------------------- |
40 |
%prep |
41 |
%setup -q |
42 |
|
43 |
%build |
44 |
%make |
45 |
|
46 |
%install |
47 |
%makeinstall_std |
48 |
|
49 |
# Needed only for Mageia 3, because polkit doesn't work as intended |
50 |
mkdir -p %{buildroot}%{_sbindir} |
51 |
mv %{buildroot}%{_bindir}/%{name} %{buildroot}%{_sbindir}/%{name} |
52 |
pushd %{buildroot}%{_bindir} |
53 |
ln -s consolehelper %{name} |
54 |
popd |
55 |
|
56 |
%find_lang %{name} |
57 |
|
58 |
%files -f %{name}.lang |
59 |
%doc COPYING CHANGELOG |
60 |
%{_bindir}/%{name} |
61 |
%{_sbindir}/%{name} |
62 |
%{_libexecdir}/%{name} |
63 |
%{_usr}/lib/%{name}/ |
64 |
%{_datadir}/%{name}/ |
65 |
%{_datadir}/polkit-1/actions/*.policy |
66 |
%{_datadir}/applications/%{name}.desktop |
67 |
%{_datadir}/pixmaps/%{name}.png |
68 |
%{_miconsdir}/%{name}.png |
69 |
%{_iconsdir}/%{name}.png |
70 |
%{_liconsdir}/%{name}.png |
71 |
%{_iconsdir}/hicolor/*/*/%{name}.png |