/[packages]/backports/4/ipython/current/SPECS/ipython.spec
ViewVC logotype

Annotation of /backports/4/ipython/current/SPECS/ipython.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 604190 - (hide annotations) (download)
Sun Mar 16 13:10:29 2014 UTC (10 years, 1 month ago) by philippem
Original Path: cauldron/ipython/current/SPECS/ipython.spec
File size: 5581 byte(s)
add Python3
1 philippem 604190 %define name ipython
2     %define version 1.2.1
3     %define release %mkrel 2
4 saispo 65239
5 philippem 604190 Summary: An interactive computing environment for Python
6     Name: %{name}
7     Version: %{version}
8     Release: %{release}
9     Source0: http://pypi.python.org/packages/source/i/ipython/%{name}-%{version}.tar.gz
10     License: BSD
11     Group: Development/Python
12     Url: http://ipython.org
13     BuildArch: noarch
14     Requires: python >= 2.6
15     Requires: python-pexpect >= 2.2
16     Requires: python-mglob
17     Requires: python-simplegeneric
18     Suggests: python-mpi4py
19     Suggests: wxPython, python-qt4, pyside >= 1.0.3
20     Suggests: python-pygments
21     Suggests: python-pyzmq >= 2.1.4
22 malo 519210 #notebook requires tornado and jinja2
23 philippem 604190 Suggests: python-tornado >= 2.1.0
24     Suggests: python-jinja2
25     Suggests: python-matplotlib
26     BuildRequires: emacs
27     BuildRequires: python-devel
28     BuildRequires: python-simplegeneric
29     BuildRequires: python-setuptools
30 saispo 65239
31 philippem 604190
32     %package -n python3-ipython
33     Group: Development/Python
34     Summary: An enhanced interactive Python shell
35     BuildRequires: python3-devel
36     BuildRequires: python3-setuptools
37     BuildRequires: python3-simplegeneric
38     Requires: python3-pexpect
39     Requires: python3-mglob
40     Requires: python3-simplegeneric
41     Suggests: python3-mpi4py
42     Suggests: python3-tornado
43     Suggests: python3-jinja2
44     Suggests: python3-matplotlib
45    
46 saispo 65239 %description
47 lebedov 146101 The goal of IPython is to create a comprehensive environment for
48     interactive and exploratory computing. To support this goal, IPython
49     has two main components:
50 saispo 65239
51 lebedov 146101 * An enhanced interactive Python shell.
52     * An architecture for interactive parallel computing.
53 saispo 65239
54 lebedov 146101 The enhanced interactive Python shell has the following main features:
55 saispo 65239
56 lebedov 146101 * Comprehensive object introspection.
57     * Input history, persistent across sessions.
58     * Caching of output results during a session with automatically
59     generated references.
60     * Readline based name completion.
61     * Extensible system of 'magic' commands for controlling the
62     environment and performing many tasks related either to IPython or
63     the operating system.
64     * Configuration system with easy switching between different setups
65     (simpler than changing $PYTHONSTARTUP environment variables every
66     time).
67     * Session logging and reloading.
68     * Extensible syntax processing for special purpose situations.
69     * Access to the system shell with user-extensible alias system.
70     * Easily embeddable in other Python programs and wxPython GUIs.
71     * Integrated access to the pdb debugger and the Python profiler.
72 saispo 65239
73 lebedov 146101 The parallel computing architecture has the following main features:
74 saispo 65239
75 lebedov 146101 * Quickly parallelize Python code from an interactive Python/IPython
76     session.
77     * A flexible and dynamic process model that be deployed on anything
78     from multicore workstations to supercomputers.
79     * An architecture that supports many different styles of parallelism,
80     from message passing to task farming.
81     * Both blocking and fully asynchronous interfaces.
82     * High level APIs that enable many things to be parallelized in a few
83     lines of code.
84     * Share live parallel jobs with other users securely.
85     * Dynamically load balanced task farming system.
86     * Robust error handling in parallel code.
87    
88 philippem 604190 %description -n python3-ipython
89     IPython provides a replacement for the interactive Python interpreter with
90     extra functionality.
91    
92     Main features:
93     * Comprehensive object introspection.
94     * Input history, persistent across sessions.
95     * Caching of output results during a session with automatically generated\
96     references.
97     * Readline based name completion.
98     * Extensible system of 'magic' commands for controlling the environment and
99     performing many tasks related either to IPython or the operating system.
100     * Configuration system with easy switching between different setups (simpler
101     than changing $PYTHONSTARTUP environment variables every time).
102     * Session logging and reloading.
103     * Extensible syntax processing for special purpose situations.
104     * Access to the system shell with user-extensible alias system.
105     * Easily embeddable in other Python programs.
106     * Integrated access to the pdb debugger and the Python profiler.
107    
108 saispo 65239 %prep
109 luigiwalser 468289 %setup -q
110 philippem 604190 # delete bundling libs
111     pushd IPython/external
112     # python's own modules
113     rm argparse/_argparse.py
114 saispo 65239
115 philippem 604190 # use decorators of numpy
116     rm decorators/_decorators.py
117    
118     # other packages exist in Mageia
119     rm simplegeneric/_simplegeneric.py
120     rm pexpect/_pexpect.py
121    
122     popd
123    
124     cp -a . %{py3dir}
125     find %{py3dir} -name '*.py' | xargs sed -i '1s|^#!python|#!%{__python3}|'
126    
127 saispo 65239 %build
128     emacs -batch -f batch-byte-compile docs/emacs/ipython.el
129 philippem 604190 pushd %{py3dir}
130     %{__python3} setup.py build
131     popd
132 saispo 65239
133 philippem 604190 %{__python} setup.py build
134    
135 saispo 65239 %install
136 philippem 604190 pushd %{py3dir}
137     %{__python3} setup.py install -O1 --skip-build --root %{buildroot}
138     popd
139    
140     %{__python} setup.py install -O1 --skip-build --root %{buildroot}
141    
142 saispo 65239 %__mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/
143     %__install -m 644 docs/emacs/ipython.el* %{buildroot}%{_datadir}/emacs/site-lisp/
144 lebedov 146101 chmod 644 %{buildroot}%{_mandir}/man1/*.1*
145     find %{buildroot} -name .buildinfo -exec rm -f {} \;
146     find %{buildroot} -name .git_commit_info.ini -exec rm -rf {} \;
147 saispo 65239
148     %files
149 luigiwalser 468289 %doc examples
150 philippem 604190 %{_bindir}/ipython
151     %{_bindir}/irunner
152     %{_bindir}/pycolor
153     %{_bindir}/ipcluster
154     %{_bindir}/ipcontroller
155     %{_bindir}/ipengine
156     %{_bindir}/iplogger
157     %{_bindir}/iptest
158    
159     %{python_sitelib}/*
160 saispo 65239 %{_datadir}/emacs/site-lisp/*
161     %{_mandir}/man1/*
162 philippem 604190 %{_datadir}/doc/%{name}
163    
164     %files -n python3-ipython
165     %doc examples
166     %{_bindir}/ipython3
167     %{_bindir}/irunner3
168     %{_bindir}/pycolor3
169     %{_bindir}/ipcluster3
170     %{_bindir}/ipcontroller3
171     %{_bindir}/ipengine3
172     %{_bindir}/iplogger3
173     %{_bindir}/iptest3
174    
175     %{python3_sitelib}/*
176    

  ViewVC Help
Powered by ViewVC 1.1.30